DCS Driver fails to start with (Error 401) Could not connect to the URL. Unauthorized User Account error

  • 7022137
  • 20-Oct-2017
  • 09-Aug-2019

Environment

Identity Manager 4.5.x, Identity Manager 4.6.x
Identity Reporting 4.5.x, Identity Reporting 4.6.x
Data Collection Service Driver
OSP 6.x

Situation

When trying to setup the Data Collection Service Driver, it requires the settings for SSO. In this scenario, the reporting server is setup for HTTP, and the OSP server is setup with HTTPS.



When trying to start the Data Collection Service Driver, and the connection settings have been verified, a level 5 trace will show the driver still won't start because of the following error:

 

Code(-9006) The driver returned a "retry" status indicating that the operation should be retried later. Detail from driver: <description>Subscriber Error: (Error 401) Could not connect to

the URL 'https://reporting.test.com:8543/IDMRPT-CORE/rpt/idvs'.  Unauthorized User Account error



Resolution

This issue has been reported to engineering.

Workaround:
Setup the reporting server for HTTPS. Consider these steps from the documentation for updating the SSL settings.
Make sure that the URL in the "SSO Service Address" field matches is lower case.

Cause

The DCS Driver currently doesn't know how to handle clear text with the HTTP connection for Reporting server settings, while requiring encryption through the HTTPS connection of the OSP settings. Having them either both HTTP or both HTTPS does not have this startup issue.

Status

Reported to Engineering

Additional Information

As a note - this error can also trigger for any settings that are incorrect for the driver configuration. If login to the Reporting webapp is successful, but the DCS Driver is still getting this error, then verify that the user and password, as well as the SSO Client ID and Client Secret are also correct.