B.8 Inventory and Monitoring Commands for Linux, Solaris and AIX

This section contains lists of commands used by PlateSpin Recon during inventory and monitoring.

B.8.1 Inventory Commands for Solaris

Table B-7 Inventory Commands for Solaris

Command

Description

kstat

Get network connection speed.

chmod

Change file access permissions for the inventory script that is placed on the machine being inventoried.

rm

Remove the inventory script that was placed on the machine.

prtdiag

Get CPU cache information and machine model for Sparc.

psrinfo

Get processor information such as family, model, step, etc., which are related to x86 mainly.

isainfo

Get CPU instruction set information such as sse, sse2, mmx, etc., which are related to x86 mainly.

prtconf 

Get configured device information, which is related to L2 cache information of x86, network adapter resolving, and ACPI support.

ifconfig 

Get network related information such as IP address, DHCP, net mask, etc.

ndd 

Get network connection speed.

uname 

Determine kernel version.

mount 

Get boot loader.

pkginfo 

Get installed programs.

ps 

Get process information.

who 

Get run level.

hostname

Get host name.

B.8.2 Inventory Commands for Linux

Table B-8 Inventory Commands for Linux

Command

Description

chkconfig 

Get service(daemon) information.

df 

Get size information for the mounted volumes

mount

Get volume information.

e2label 

Get disk label.

route 

Get gateway.

ifconfig 

Get network related information such as IP address, net address, and so on.

egrep 

Get DHCP information.

getcfg

Get DHCP for SUSE.

rpm 

Get installed programs.

lspci 

Get PCI device information such as vendor name, device model in human readable format.

iwconfig 

Get wireless network adapter NIC list.

iwlist 

Get wireless bit rate.

ethtool 

Get speed and link status for network connection.

If the command does not return a value for the speed, a default speed of 100 Mbps is considered.

dmesg 

Get real MAC address.

kudzu

Get network device information for Redhat Linux.

hwinfo

Get network adapter information for SUSE Linux.

fdisk 

Determine if a partition is active or not.

runlevel 

Get current run level.

hostname

Get host name and DNS domain name.

xm info

Get memory information from Xen machine.

B.8.3 Inventory Commands for AIX

NOTE:Novell PlateSpin Recon supports AIX 5.3 TL7 or later.

Table B-9 Inventory Commands for AIX

Command

Description

rpm 

Get a list of installed programs.

ps 

Get service (daemon) information.

mount

Get list of mounted volumes.

df 

Get size information for mounted volumes.

lslv 

Get SerialNumber and Label for mounted volumes.

hostname 

Get hostname.

namerslv 

Get DNS domain name.

getconf

Determine whether a 64-bit kernel.

uname 

Determine OS release version.

ifconfig 

Get configured network adapters and their IP address.

netstat 

Get MAC address.

entstat 

Get speed of network adapter.

prtconf 

Get processor information and default gateway.

lspv 

Get list of disks and their partitions.

bootinfo

Get disk size.

lscfg

Get disk model, manufacturer and type and network adapter model.

lsitab 

Get daemon information.

getconf 

Get machine memory and bootloader information.

lsattr

Get machine serial number and model,hyperthreading details and subnet mask.

B.8.4 Monitoring Commands for Linux and Solaris

Table B-10 Monitoring Commands for Linux and Solaris

Command

Platform

Description

psrinfo

Solaris

count processor number.

mpstat

Solaris

Get processor time per cpu instance.

vmstat

Solaris

Get processor queue length and memory available.

ifconfig 

Solaris, Linux

Get NIC list.

sed 

Solaris, Linux

Edit input stream.

tail 

Solaris, Linux

Edit input stream.

netstat 

Solaris

Get network package transfer rate.

kstat

Solaris

Get NIC speed.

prtconf

Solaris

Get module and instance binding for NIC.

iostat

Solaris

Get disk io information such as queue and speed.

expr 

Solaris, Linux

evaluate express.

B.8.5 Monitoring Commands for AIX

NOTE:Novell PlateSpin Recon supports AIX 5.3 TL7 or later.

Table B-11 AIX Monitoring Commands

Command

Description

vmstat

Get Available Memory in Bytes

ifconfig

Get NIC information

entstat

Get Network Packets, Bytes Send/Received

mpstat

Get Percentage processor time

iostat

Get Disk transfer per second, disk idle, disk byte per second

sar

Get Disk Queue length, Percentage processor used

lspv

Get Disk partitioned or Unpartitioned space, disk list

bootinfo

Get disk size

df

Get the volume level information

oslevel

Get the version of AIX

B.8.6 Text Processing

grep, cat, cut, awk, ls