2.1 Product Requirements

Ensure that your Identity Manager environment meets the following prerequisites before installing NetIQ Identity Manager Home.

2.1.1 Platform Requirements

Identity Manager Home requires one of the following operating systems:

  • SUSE Linux Enterprise Server 11 SP2 or SP3 (64-bit)

  • Red Hat Enterprise Linux 5 or 6 (64-bit)

2.1.2 NetIQ Software Requirements

Identity Manager Home requires Identity Manager 4.0.2 Advanced Edition with the following components:

  • eDirectory 8.8.7 (32-bit or 64-bit) or eDirectory 8.8.8 (64-bit)

    NOTE:Identity Manager Home requires one of the versions of eDirectory supported for Identity Manager 4.0.2. For more detailed information about overall Identity Manager requirements, see “System Requirements”, in the Identity Manager 4.0.2 Framework Installation Guide

  • Identity Manager 4.0.2 Engine & Remote Loader Patch 3 or later

  • Identity Manager Roles Based Provisioning Module 4.0.2 Field Patch D or later

    NOTE:After you install Roles Based Provisioning Module 4.0.2 Field Patch D, ensure you follow the included steps for upgrading to Java 2 version 1.7.

  • Designer for Identity Manager 4.0.2 Auto Update 4A or later

  • (Conditional) Event Auditing Service for Identity Manager

  • (Conditional) Identity Manager 4.0.2 Data Collection Service (DCS) Driver version 4.0.0.3 or later, with minimum Package version 2.2.1.20130828112545

  • (Conditional) Identity Manager 4.0.2 Managed System Gateway (MSGW) Driver version 4.0.0.5 or later

    NOTE:You only need to install the Event Auditing Service, Data Collection Service Driver, and Managed System Gateway Driver if you use the Identity Reporting Module in your environment.

  • All other Identity Manager 4.0.2 drivers with latest patches

NOTE:Identity Manager 4.0.2 Standard Edition does not support Identity Manager Home or the Identity Manager Provisioning Dashboard.

2.1.3 Application Server Requirements

Identity Manager Home requires JBoss AS 5.1 or later.

NOTE:Identity Manager currently only supports installing Identity Manager Home on a server running JBoss.

2.1.4 Database Requirements

Identity Manager Home requires one of the following databases:

  • Microsoft SQL Server 2008

  • MySQL 5.1

  • Oracle Database 11g

  • PostgreSQL 8.4.3 or 9.0

2.1.5 Additional Software Requirements

  • Java 2 Platform Standard Edition Development version 1.7 or later (JDK or JRE) from Sun (Oracle)

  • (Optional) SSL

    NOTE:If you want to use Identity Manager Home with HTTPS, you must enable SSL on your application server.

2.1.6 Supported Browsers

Users can access Identity Manager Home and the Provisioning Dashboard using any of the following supported browsers:

  • Desktop Computers:

    • Apple Safari 7.0.1

    • Google Chrome 31 or later

    • Microsoft Internet Explorer 9 or 10

      NOTE:If you use Internet Explorer 9 to access Identity Manager Home and the Provisioning Dashboard and set the Document Mode to Quirks Mode, the browser may not display the user interfaces correctly. For more information on this issue, see the NetIQ Identity Manager Home and Provisioning Dashboard Release Notes.

    • Mozilla Firefox 21 or later

  • iPads:

    • Apple Safari

    • Google Chrome 31 or later

NOTE:All browsers must have cookies enabled to access Identity Manager Home and the Provisioning Dashboard. If cookies are disabled, the product does not work.