Versionshinweise zu NetIQ Identity Manager Designer 4.6

Februar 2017

NetIQ Identity Manager Designer 4.6 bietet neue Funktionen und ist einfacher in der Bedienung. Einige in früheren Versionen auftretende Probleme wurden behoben.

Viele der eingeführten Verbesserungen sind Umsetzungen von Vorschlägen unserer Kunden. Wir möchten uns auf diesem Wege bei Ihnen für Ihr wertvolles Feedback bedanken. Wir hoffen, Sie unterstützen uns weiterhin dabei, unsere Produkte optimal an Ihre Bedürfnisse anzupassen. Feedback können Sie in unseren Identity Manager Community-Foren auf unserer Community-Website posten, auf der Sie auch Produktbenachrichtigungen, Blogs und Produktbenutzergruppen finden.

Informationen über die Neuheiten in früheren Versionen finden Sie im Abschnitt „Frühere Versionen“ auf der Dokumentations-Website zu Identity Manager.

Weitere Informationen zu dieser Version und die aktuellen Versionshinweise finden Sie auf der Dokumentationsseite zu Identity Manager. Dieses Produkt steht auf der Website der Identity Manager-Produkte zum Herunterladen bereit.

1.0 Neue Funktionen

In den folgenden Abschnitten werden die wichtigsten Funktionen beschrieben, die in dieser Version enthalten sind. Außerdem wird erläutert, welche Funktionen aus dem Produkt entfernt und welche Probleme in dieser Version behoben wurden:

1.1 Neue Funktionen

Unterstützung neuer Aktionen zur Erstellung von Rollen und Ressourcen

Diese Version unterstützt die Aktion zur Erstellung von Rollen und Ressourcen im Richtlinien-Builder. Diese Aktion ist nur bei Identity Manager-Server Version 4.6 verfügbar. Weitere Informationen finden Sie in den Abschnitten Erstellen von Ressourcen und Erstellen von Rollen im NetIQ Identity Manager – Handbuch zum Erstellen von Richtlinien mit Designer.

Assistent zur Erstellung von eDir-to-eDir-Zertifikaten umfasst neue Algorithmen zur Unterstützung von Suite B-fähigen eDirectory-Servern

Designer umfasst weitere Optionen für Schlüsselgrößen und Hash-Algorithmen zur Unterstützung der Kommunikation zwischen Suite B-fähigen eDirectory-Servern. Wenn Sie im Suite B-Modus kommunizieren möchten und eine Schlüsselgröße angeben, richtet Designer einen entsprechenden sicheren Hash-Algorithmus zur Verwendung mit der ausgewählten Schlüsselgröße ein. Der Assistent zur Zertifikatserstellung unterstützt auch weiterhin die Methode zum Aufbau der Kommunikation im Nicht-Suite B-Modus. Weitere Informationen finden Sie unter eDir-to-eDir SSL/TLS im NetIQ Designer for Identity Manager Administration Guide (Verwaltungshandbuch zu NetIQ Designer für Identity Manager).

Neue Benutzeroberfläche zum Konfigurieren strukturierter globaler Konfigurationswerte

Designer umfasst eine neue Benutzeroberfläche, auf der Sie strukturierte globale Konfigurationswerte (Global Configuration Values, GCV) konfigurieren können. Dies ist insbesondere dann hilfreich, wenn Sie über eine große Anzahl strukturierter GCV-Instanzen verfügen, wie es beim Konfigurieren von Sekundärsystemen im Fan-out-Treiber für die SAP-Benutzerverwaltung der Fall ist.

Die neue Benutzeroberfläche von Designer ist die Standardmethode zum Konfigurieren der strukturierten GCVs. Sie können jedoch weiterhin die alte Methode verwenden; ändern Sie dazu die Einstellung Strukturierte GCVs im früheren Layout anzeigen in den Designer-Einstellungen.

Unterstützung für neue Verbesserungen der Identity Manager-Engine

Designer 4.6 unterstützt die nachfolgenden Verbesserungen in der Engine von Identity Manager 4.6.

  • Abonnentendienstkanal: In Identity Manager wird der Abonnentendienstkanal eingeführt, mit dem Sie Abfragen außer der Reihe separat verarbeiten können, ohne den normalen Ablauf der Ereignisse im Cache zu unterbrechen. Der Abonnentendienstkanal kann beispielsweise die Aktualisierung der Prozesscodezuordnung, die Datenerfassung und die von dxcmd ausgelösten Abfragen separat verarbeiten. Dies trägt zur Verbesserung der Leistung der Treiber bei. Diese Funktion wird mit dem neuen Engine-Steuerungswert „Abonnentendienstkanal aktivieren“ gesteuert. Diese Funktion steht zurzeit nur zusammen mit dem JDBC-Fan-Out-Treiber zur Verfügung.

  • NashornScript-Engine: Diese Version bietet Unterstützung für die Nashorn-ECMAScript-Engine. Zur Verwendung von Nashorn ändern Sie die Standardeinstellung mit dem Engine-Steuerungswert „Rhino ECMAScript verwenden“.

Weitere Informationen zu den durch Designer unterstützten ECVs finden Sie unter Engine-Steuerungswerte im Verwaltungshandbuch zu NetIQ Designer für Identity Manager.

Unterstützung für Java 8 Update 112

Designer wurde auf Java 8 Update 112 aktualisiert.

Unterstützung für die Installation von Designer unter Windows Server 2012

Das Designer-Installationsprogramm wurde aktualisiert und unterstützt nun die Installation auf der Windows Server 2012-Plattform.

1.2 Korrekturen

Diese Version umfasst die folgenden Software-Korrekturen:

Konfiguration des Fan-out-Treibers der SAP-Benutzerverwaltung mit mehreren Sekundärsystemen

Wenn der Treiber für die Verbindung mit zahlreichen Sekundärsystemen konfiguriert ist, zeigt Designer mit der neuen Benutzeroberfläche zur Konfiguration der strukturierten GCVs die vorherigen Systeme an, wenn Sie die neuen Systeme konfigurieren. Weitere Informationen finden Sie in Neue Benutzeroberfläche zum Konfigurieren strukturierter globaler Konfigurationswerte. (Bug 973553)

Durch das Aufrüsten von Treiberpaketen für die Benutzeranwendung wird die Anpassung von Workflows nicht überschrieben

Wenn Sie einen Workflow angepasst haben und die Treiberpakete für die Benutzeranwendung aufgerüstet werden, behält Designer die Änderungen an den Workflows bei. (Bug 1000141)

Paket mit &-Zeichen im Herstellernamen wird beim Online-Paketimport von der Site der veröffentlichten Pakete aufgelistet

Designer zeigt Pakete mit dem Sonderzeichen "&" im Herstellernamensfeld in der Liste der für die Aktualisierung verfügbaren Pakete korrekt an. (Bug 865150)

Hinzufügen mehrerer Lesen-Attribute zu einem Abfrage-Hauptwort möglich

Wenn Sie im Richtlinien-Builder eine neue Regel erstellen und einen Abfragetoken in einer Aktion innerhalb der Regel verwenden, behält Designer die Werte der vorher hinzugefügten Attribute nunmehr bei, wenn der Abfrage mehrere Lesen-Attribute hinzugefügt werden. (Bug 956992)

Sie können die Attribute beim Hinzufügen mehrerer Lesen-Attribute löschen.

Richtliniensatzansicht wird beim Öffnen des Richtlinieneditors angezeigt

Wenn Sie ein Richtliniensatzobjekt auswählen, sehen Sie die Richtlinien in diesem Satz, wenn Sie die Richtlinie im Richtlinieneditor öffnen. (Bug 924668)

Keine häufigen Erinnerungen von Workflows

Wenn Sie beim Entwickeln eines Workflows einen Wert für die Parameter "Reminder Start" (Start der Erinnerung) oder "Escalation Reminder Start" (Start der Eskalationserinnerung) und keinen Wert für die Parameter "Reminder Intervall" (Erinnerungsintervall) oder "Escalation Reminder Interval" (Eskalationserinnerungsintervall) angeben, sendet die Benutzeranwendung immer wieder Email-Benachrichtigungen an den Benutzer, der für den Empfang von Erinnerungen oder Eskalationsmeldungen konfiguriert wurde. Designer validiert nun die Erinnerungs- und Eskalationseinstellungen und zeigt Validierungfehler an, falls die angegebenen Einstellungen nicht korrekt sind. (Bug 655116)

Das Paketaufrüstungsprogramm zeigt Paketeingabeaufforderungen für Pakete ohne Eingabeaufforderung an

Wenn Sie mit dem Paketaufrüstungsprogramm in einem Arbeitsgang mehrere Pakete, von denen ein Paket keine Eingabeaufforderung aufweist, oder ein einzelnes Paket ohne Eingabeaufforderung aufrüsten, zeigt das Dienstprogramm nunmehr Eingabeaufforderungen für alle aufgerüsteten Pakete an. (Bug 1015123)

Die Aktionen des Objekts „Do Move Source“ (Ursprung verschieben) oder „Do Move Destination“ (Ziel verschieben) ermöglichen kein Speichern der Richtlinie ohne Angabe der Werte für die obligatorischen Parameter

Wenn Sie Aktionen zum Verschieben eines Ursprungs- oder Zielobjekts im Richtlinien-Builder erstellen, zeigt Designer nunmehr eine Fehlermeldung an, wenn die obligatorischen Felder nicht angegeben werden. (Bug 500572)

Konfigurieren eines Abfragetokens zum Lesen von mehreren Attributen mit dem Argument-Builder

Wenn Sie im Richtlinien-Builder eine neue Regel erstellen und ein Abfragetoken in einer Aktion innerhalb der Regel verwenden, können Sie nur den Argument-Builder verwenden, um ein einzelnes Attribut anzugeben, das von der Abfrage gelesen wird. Wenn Sie mehrere Attribute angeben, überschreibt Designer nunmehr die vorhandenen Attribute nicht mehr mit den neuen Attributen. (Bug 676701)

Beim Simulieren einer Richtlinie werden keine Elemente aus dem XML-Dokument entfernt

Beim Testen einer Richtlinie im Simulator entfernt dieser die Verweiselemente (ref) oder manchmal sowohl die Verweiselemente (ref) als auch die untergeordneten Elemente (child) aus dem Richtliniendokument. (Bug 918430)

Durch Verknüpfen eines benutzerdefinierten ECV aus einem importierten Projekt werden der ECV in Designer und das Identitätsdepot nicht gelöscht

Wenn ein benutzerdefinierter ECV mit dem Live-Identitätsdepot verknüpft wird, löscht dieser Vorgang den ECV nicht mehr aus Designer und dem Live-Identitätsdepot. (Bug 1011538)

Keine redundanten Informationsmeldungen beim Importieren oder Verknüpfen mehrerer Treiber

Designer zeigt beim Importieren oder Verknüpfen von Treibern nicht mehr ständig dieselbe Meldung an. (Bug 1015260)

Polling-Intervall-Feld bleibt nicht leer

Wenn Sie beim Einstellen der Auftragsparameter das Feld Polling-Intervall leer lassen, wird Designer entweder den Wert des Felds auf den im Treiberpaket definierten Mindestwert aktualisieren oder den Standardwert 0 festlegen.

Keine Leistungsbeeinträchtigung durch geänderte Proxyservereinstellungen

Wenn Sie Designer anfänglich mit einem Proxyserver einrichten und später die Proxyeinstellungen zurücksetzen, verarbeitet Designer die Änderungen an den Proxyeinstellungen ordnungsgemäß, ohne dass die Leistung der Designer-Vorgänge beeinträchtigt wird. (Bug 815566)

1.3 Was wurde entfernt?

In der folgenden Liste finden Sie eine Übersicht der Features und Funktionen, die mit dieser Version veraltet sind bzw. bald veraltet sein werden.

32-Bit Designer

Designer 4.6 funktioniert auf 64-Bit-Systemen. Die Installation von Designer wird auf 32-Bit-Plattformen nicht mehr unterstützt.

2.0 Systemanforderungen

Informationen über die Voraussetzungen, Systemanforderungen, Aufrüstung oder Migration finden Sie im Abschnitt zu den Installationsanforderungen im Einrichtungshandbuch zu NetIQ Identity Manager.

3.0 Installation von Designer 4.6

Nachdem Sie Identity Manager 4.6 käuflich erworben haben, melden Sie sich bei der Identity Manager-Produkt-Website an und folgen Sie dem Link zum Herunterladen der Software. Folgende Dateien stehen zur Verfügung:

Tabelle 1 Identity Manager-ISO-Imagedateien

ISO

Plattform

Beschreibung

Identity_Manager_4.6_Linux.iso

Linux

Enthält Identity Manager-Server (Engine, Remote Loader, Fan-out-Agent, Treiber und Plugins), Designer, iManager, Analyzer, OSP, SSPR, Identitätsanwendungen, Identitätsberichterstellung und Sentinel Log Management für Identity Governance and Administration (IGA)

Identity_Manager_4.6_Windows.iso

Windows

Enthält Identity Manager-Server (Engine, Remote Loader, Fan-out-Agent, Treiber und Plugins), Designer, iManager, Analyzer, OSP, SSPR, Identitätsanwendungen und Identitätsberichterstellung

HINWEIS:Sentinel for Log Management für IGA wird unter Windows nicht unterstützt.

Sie können Designer mit dem Produktinstallationsprogramm oder über das integrierte Installationsprogramm installieren, das die aktuellen Versionen aller für Identity Manager erforderlichen Komponenten umfasst. Weitere Informationen zu den Voraussetzungen, Systemanforderungen, zur Installation oder zur Aufrüstung finden Sie im Abschnitt Installieren von Designer für Identity Manager im Einrichtungshandbuch zu NetIQ Identity Manager.

Informationen zum Herunterladen der Installationskits finden Sie auf der Website NetIQ Downloads.

4.0 Aufrüsten auf Designer 4.6

Mit dem Designer-Installationsprogramm können Sie von Designer 4.5 oder auf Designer 4.6 aufrüsten. Die unterstützten Aufrüstungspfade für 4.6 finden Sie im Abschnitt zur Vorbereitung der Aufrüstung von Identity Manager im Einrichtungshandbuch zu NetIQ Identity Manager.

Eine vorhandene Installation von Designer kann nicht mit dem integrierten Installationsprozess aufgerüstet werden. Weitere Informationen finden Sie unter Aufrüsten von Identity Manager im Einrichtungshandbuch zu NetIQ Identity Manager.

5.0 Aktualisieren von Designer-Paketen im Offline-Modus

Zum Aktualisieren von Designer-Paketen im Offline-Modus stellen Sie die Paketaktualisierungsdateien in einem lokalen Verzeichnis auf dem Computer bereit und konfigurieren Sie Designer dann so, dass die Dateien aus diesem Verzeichnis gelesen werden.

So erstellen Sie eine Offline-Kopie der Paketaktualisierungsdateien:

  1. Melden Sie sich beim Computer an, auf dem Designer installiert ist, und erstellen Sie ein lokales Verzeichnis.

  2. Kopieren Sie die in Schritt 1 erstellten Paketaktualisierungsdateien in das Verzeichnis:

    • Linux: Wechseln Sie in einer Shell zum Verzeichnis und führen Sie die folgenden Befehle aus:

      wget -r -nH -np https://nu.novell.com/designer/packages/idm/updatesite1_0_0/

      wget -r -nH -np https://nu.novell.com/designer/packages/idm/updatesite2_0_0/

    • Windows:

      1. Öffnen Sie die Paketaktualisierungs-Website unter einer der folgenden URLs:

        • https://nu.novell.com/designer/packages/idm/updatesite1_0_0/

        • https://nu.novell.com/designer/packages/idm/updatesite2_0_0/

      2. Wählen Sie die erforderlichen Dateien aus und laden Sie sie herunter.

So konfigurieren Sie Designer zum Lesen der Dateien aus dem lokalen Verzeichnis:

  1. Starten Sie Designer.

  2. Klicken Sie im Hauptmenü von Designer auf Fenster > Einstellungen.

  3. Klicken Sie auf NetIQ > Paketmanager > Online-Aktualisierungen.

  4. Tippen Sie auf das Plus-Symbol und geben Sie eine neue URL ein.

  5. Füllen Sie die folgenden Felder aus:

    1. Anbieter: Geben Sie den Namen des Anbieters für die Paketaktualisierung an.

    2. URL: Geben Sie die URL im Format file:///<Pfad_zu_Dateien>/packages/idm/updatesite1_0_0/ an.

      Bei gemounteten ISO-Dateien unter Linux gilt das folgende URL-Format:

      file:////media/designer460offline/packages/idm/updatesite1_0_0/

      file:////media/designer460offline/packages/idm/updatesite2_0_0/

      HINWEIS:Sollen mehrere Paket-Websites eingefügt werden, wiederholen Sie diesen Schritt und geben Sie die zusätzlichen URLs an.

  6. Klicken Sie auf OK.

  7. Aktivieren Sie die erforderlichen Kontrollkästchen für die Websites im Fenster Einstellungen.

    HINWEIS:Die neuen Websites sind standardmäßig ausgewählt.

  8. Klicken Sie auf Anwenden und dann auf OK.

  9. Klicken Sie im Hauptmenü von Designer auf Hilfe > Auf Paketaktualisierungen prüfen.

  10. Wählen Sie die erforderlichen Aktualisierungen aus und klicken Sie auf Ja, sodass die Designer-Paketaktualisierungen akzeptiert und aktualisiert werden.

    Sie müssen Designer neu starten, damit die Änderungen in Kraft treten.

6.0 Bekannte Probleme

NetIQ Corporation ist bestrebt, Produkte zu bieten, die hochwertige Lösungen für die Softwarebedürfnisse Ihres Unternehmens darstellen. Die nachfolgend beschriebenen Probleme werden zurzeit untersucht. Wenden Sie sich an den Technischen Support, wenn Sie weitere Hilfe zu einem Problem benötigen.

6.1 Probleme bei der Installation

Beim Installieren von Designer treten möglicherweise die folgenden Probleme auf:

Installation auf englischem Windows mit ostasiatischem Sprachpaket und Doppelbyte-Installationspfad

Wenn Sie die englische Version von Windows ausführen, auf der das ostasiatische Sprachpaket installiert ist, wird bei der Installation in einem Pfad, der Doppelbyte-Zeichen enthält, ein Fehler ausgegeben, der besagt, dass die komprimierte Datei nicht extrahiert werden kann. Es gibt bekannte Probleme mit Doppelbyte-Zeichensätzen in Windows-Dateipfaden, die auf den Hersteller des Betriebssystems oder des Installations-Frameworks zurückzuführen sind. Alternativ ist eine Installation unter Verwendung von Pfaden mit Doppelbyte-Zeichensätzen bei der Installation auf einer lokalisierten Version des Betriebssystems möglich.

Warnmeldungen beim Start von Designer nach der Installation

Folgende Warnmeldungen werden auf der SUSE Linux Enterprise Desktop (SLED 11)-Plattform angezeigt:

Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory

Sie können diese Meldung ignorieren. (Bug 492755, Bug 494258)

Der Kommunikationsaufbau zu eDirectory in Designer 4.5 verursacht einen Fehler unter Windows 7

Problem: Dieses Problem tritt auf, weil möglicherweise eine frühere Version von NICI nicht ordnungsgemäß deinstalliert wurde. Möglicherweise sind nicht alle Dateien im Dateisystem gelöscht worden. (Bug 542862)

Behelfslösung: Entfernen Sie alle NICI-Dateien aus dem System und installieren Sie Designer erneut.

Das Installationsprogramm erstellt keine Desktopverknüpfung für Designer auf nicht englischen openSUSE-Servern

Wenn Sie Designer 4.5 auf einem openSUSE-Server in einer nicht-englischen Umgebung installieren, erstellt das Installationsprogramm kein Verknüpfungssymbol für Designer auf dem Desktop. (Bug 751561)

Die Benutzeroberfläche ist bei der Installation von Active Directory Base in nicht englischen Gebietsschemata nicht lesbar

Bei Installation von Active Directory Base werden einige Benutzeroberflächenelemente im Assistenten für die Treiberkonfiguration auf der Remote Loader-Seite nicht richtig dargestellt.

Für dieses Problem ist keine Lösung verfügbar.

6.2 Allgemeine Informationen

Beim Arbeiten mit Designer treten möglicherweise die folgenden Probleme auf:

Der Projektkonvertierer unterstützt keinen remote gemounteten Arbeitsbereich

Problem: Wenn Sie das Designer 3.5-Projekt in Designer 4.6 konvertieren, nachdem der Designer 3.5-Arbeitsbereich auf dem lokalen Computer, auf dem Designer 4.6 installiert ist, gemountet wurde, konvertiert der Projektkonvertierer das Designer 3.5-Projekt nicht. (Bug 658159)

Behelfslösung: Kopieren Sie den Designer 3.5-Arbeitsbereich auf den lokalen Computer, auf dem Designer 4.6 installiert ist, und führen Sie dann den Projektkonvertierer aus.

Auf Linux-Plattformen funktioniert der interne Webbrowser in Designer nicht

Problem: Der interne Webbrowser funktioniert wegen XULRunner-Problemen nicht erwartungsgemäß. (Bug 612438)

Behelfslösung: Stellen Sie über Designer > Windows > Einstellungen > Allgemein > Webbrowser > Externen Browser verwenden den externen Browser ein. Damit wird die iManager-URL im Standardwebbrowser des Systems (beispielsweise Mozilla Firefox oder Microsoft Internet Explorer) geladen.

Ordnungsgemäße Konfiguration der LDAP-Ports nach dem Importieren eines Projekts in Designer

Problem: Wenn Sie ein Projekt erstellen, nachdem Sie es aus einem Live-System in Designer importiert haben, werden in den Eigenschaften für das Identitätsdepot die Ports nicht ordnungsgemäß konfiguriert. (Bug 680745)

Behelfslösung: Ändern Sie die LDAP-Ports in Eigenschaften für das Identitätsdepot, bevor Sie das importierte Projekt bereitstellen.

Designer unterstützt keine dn-ref-Auftragsparameter als Paketeingabeaufforderungen

Designer unterstützt keine Auftragsparameter des Typs dn-ref als Paketeingabeaufforderungen. Wenn Sie einen dn-ref-Auftragsparameter als Paketeingabeaufforderung hinzufügen müssen, verwenden Sie stattdessen einen dn-Auftragsparameter. (Bug 806651, Bug 777509)

Designer zeigt nach dem Aktualisieren die Treiberpakete der Benutzeranwendung möglicherweise nicht ordnungsgemäß an

Problem: Wenn Sie für einen Benutzeranwendungstreiber in Designer ein Paket erstellen, das kein Basispaket ist, und dann auf Designer 4.6 aktualisieren, zeigt Designer das Paket in der Liste „Verfügbare Pakete“ nicht an, wenn Sie den Benutzeranwendungstreiber installieren. (Bug 827294, Bug 789499)

Behelfslösung: Zum Installieren des Pakets deaktivieren Sie das Kontrollkästchen Nur zutreffende Paketversionen anzeigen, wählen Sie das entsprechende Paket und klicken Sie dann auf Weiter.

Designer kann beim Treiberimport verschiedene Versionen des Globalkonfigurationswerts nicht zusammenführen

Wenn Sie einen Treiber in Designer installieren, der mindestens einen Globalkonfigurationswert (GCV) enthält, und dann versuchen, eine zweite Treiberversion mit einer geänderten Version des vorhandenen Globalkonfigurationswerts zu importieren, zeigt Designer eine Meldung mit dem Hinweis an, dass die globalen Variablen nicht zusammengeführt werden können.

Designer unterstützt gegenwärtig die Zusammenführung vorhandener Globalkonfigurationswerte beim Treiberimport nicht. Dies ist unabhängig davon, ob die im Konflikt stehenden Werte im Treiber, im Treibersatz oder in einem GCV-Ressourcenobjekt gefunden werden. (Bug 838471, Bug 841105)

Designer importiert zuvor in XML exportierte Rollen oder Ressourcen nicht erneut

Problem: Wenn Sie eine Rolle oder einen Ressourcenuntercontainer in der Bereitstellungsansicht des Rollenkatalogs erstellen, exportieren Sie den Rollenkatalog in eine XML-Datei. Löschen Sie anschließend den Untercontainer und die Rolle bzw. die Ressource und versuchen Sie, die Rolle bzw. Ressource durch Importieren aus der XML-Datei wiederherzustellen. Durch den Import wird die Rolle bzw. Ressource nicht neu erstellt. (Bug 846134, Bug 846604)

Behelfslösung: Zum Importieren von Untercontainern und Objekten des Rollenkatalogs aus einer XML-Datei müssen Sie einen neuen Benutzeranwendungstreiber erstellen und die XML-Datei in den Rollenkatalog des Treibers importieren.

Designer überschreibt beim Aktualisieren die geänderte Paketverknüpfungsreihenfolge

Wenn Sie die Reihenfolge der Verknüpfungen in einem Paket ändern, erkennt Designer das Paket nicht als benutzerdefiniert. Wenn Sie das Paket aktualisieren, überschreibt Designer daher die geänderte Verknüpfungsreihenfolge mit der im aktualisierten Paket angegebenen Reihenfolge. (Bug 845207)

Eine Fehlermeldung wird beim Bereitstellen eines gelöschten Rollencontainers oder -untercontainers angezeigt

Problem: Wenn Sie einen Container oder Untercontainer mit Rollen löschen und versuchen, diesen bereitzustellen, tritt ein Fehler auf. Der Grund hierfür ist, dass ein Container oder Untercontainer, der Rollen enthält, nicht gelöscht werden kann. (Bug 846814, Bug 846359)

Behelfslösung:

  1. Löschen Sie die Rollen, die im Container oder Untercontainer enthalten sind.

  2. Stellen Sie den Container oder Untercontainer bereit und warten Sie, bis der Rollentreiber die Rollen gelöscht hat.

  3. Nachdem die Rollen gelöscht wurden, löschen Sie den Container bzw. Untercontainer.

  4. Stellen Sie den Container, der den gelöschten Untercontainer enthält, bereit.

Beim Bearbeiten von Benachrichtigungsschablonen im Email-Schablonen-Editor wird eine Fehlermeldung angezeigt

Wenn Sie eine Benachrichtigungsschablone im Email-Schablonen-Editor bearbeiten, wird eine Fehlermeldung auf der Registerkarte „Fehler“ angezeigt. Wenn Sie beispielsweise eine HTML-Email-Schablone wie den Link Hinweis vergessen öffnen und Text in das Text-Tag eingeben, wird eine Fehlermeldung auf der Registerkarte „Fehler“ angezeigt. (Bug 879626)

Ressource und Ressourcencontainer fehlen, wenn Objekte aus Ressourcen in der Bereitstellungsansicht importiert werden

Problem: Wenn Sie Bereitstellungsobjekte (aus XML-Dateien) aus Ressourcen in der Bereitstellungsansicht importieren, werden die Container und die darin enthaltenen Objekte weder erfolgreich importiert noch wie erwartet in der Bereitstellungsansicht angezeigt. Stattdessen fehlen die Container und es werden nur die Ressourcen angezeigt. (Bug 847299)

Behelfslösung: Importieren Sie die Bereitstellungsobjekte (XML-Dateien), indem Sie mit der rechten Maustaste auf Rollenkatalog und nicht auf Ressource klicken. Damit wird sichergestellt, dass die Ressource und die Ressourcencontainer importiert und in der Bereitstellungsansicht angezeigt werden.

Beim Aktualisierung eines Bereitstellungsordners mit einem vorhandenen Namen wird ein Versionskontrollfehler angezeigt

Wenn Sie zwei Benutzeranwendungstreiber mit demselben Namen erstellen und einen Aktualisierungsvorgang durchführen, wird ein Versionskontrollfehler angezeigt. Der Grund hierfür ist ein Konflikt, der auftritt, wenn ein Benutzer die an dem Projekt vorgenommenen Änderungen speichert und ein anderer Benutzer dieses Projekt zur gleichen Zeit aktualisiert.

Weitere Informationen zum Verwalten von Paketen in der Versionskontrolle finden Sie im Abschnitt zu den Best Practices zum Verwalten von Paketen im Verwaltungshandbuch für NetIQ Designer für Identity Manager. (Bug 881818)

Die Schriftgröße einiger Registerkarten in der Designer 4.5-Benutzeroberfläche erscheint erhöht, wenn Designer auf einem 24-Zoll-Bildschirm mit einer Auflösung von 1920 x 1200 unter Linux ausgeführt wird

Um dieses Problem zu lösen, folgen Sie den Anweisungen auf folgender Website:. (Bug 889167)

Der Status eines kürzlich erstellten leeren Rollen- und Ressourcenuntercontainers wird im Vergleich mit dem Live-Identitätsdepot-Server als "gleich" angezeigt

Wenn Sie einen kürzlich erstellten leeren Rollen- oder Ressourcenuntercontainer (durch Klicken auf Live-Vergleich in der Bereitstellungsansicht) vergleichen, wird der Vergleichsstatus im Fenster Designer/eDirectory-Objektvergleich nicht als „ungleich“ angezeigt. Stattdessen wird er als „gleich“ angezeigt. (Bug 890543)

Ports zur Bereitstellung der Berechtigungsrichtlinie

Der Standardport für die Bereitstellung ist Port 389. Die Berechtigungsrichtlinie wird auch auf anderen Ports, etwa Port 636, bereitgestellt.

Starten Sie zum Ändern des Ports den Modellierer, wechseln Sie zur Ansicht Eigenschaften und wählen Sie Identitätsdepot aus. Legen Sie die Einstellung useLDAPSecureChannel auf „true“ fest.

Beim Importieren eines Pakets mit der ]]>-Zeichenkette in einem ECMA-Ressourcenobjekt wird ein Fehler angezeigt

Problem: Pakete mit der Zeichenkette ]]> können in einer ECMA-Ressource nicht importiert werden. Die folgende Fehlermeldung wird angezeigt: (Bug 1004484)

The bundle file does not contain a valid XML document: ": (47): character not allowed.

Behelfslösung: Mögliche Behelfslösungen sind:

  • Verwenden Sie die folgende Funktion:

    function test()
    {
     return "]"+"]"+">"
    	
    }

    ODER

  • Verwenden Sie die folgenden Funktionen:

    function test()
    {
     return "]]\>"
     	return "]]&gt"
      
    }

Designer kann keine Zertifikate erstellen, wenn der Name der Treiberkonfiguration lang ist und CA vor KMO abläuft

Problem: Bei der Erstellung von Zertifikaten für Treiberkonfigurationen mit langen Namen versucht Designer manchmal, KMOs mit Namen, die mehr als 64 Zeichen enthalten, zu erstellen. Das Zertifikat wird folglich nicht erstellt.

Das Zertifikat wird ebenfalls nicht erstellt, wenn das CA-Ablaufdatum vor dem KMO-Ablaufdatum liegt. (Bug 1000125)

Behelfslösung: Führen Sie die folgenden Schritte aus:

  • Für den Fall, dass eine Treiberkonfiguration einen langen Namen aufweist, ist keine Behelfslösung verfügbar.

  • Wenn das CA-Ablaufdatum vor dem KMO-Ablaufdatum liegt, vergewissern Sie sich, dass der Wert des Attributs NotAfter auf einen Wert festgelegt ist, der größer als der entsprechende Attributwert der Zertifizierungsstelle ist.

Richtlinien mit demselben Namen in verschiedenen Projekten werden als dieselbe Richtlinie behandelt

Problem: Wenn Sie eine Richtlinie in einem Projekt öffnen und anschließend eine Kopie des Projekts erstellen, dann die bereits geöffnete Richtlinie im kopierten Projekt öffnen, werden Sie von Designer zum Editor umgeleitet, der die Richtlinie des ursprünglichen Projekts enthält. (Bug 1016705)

Behelfslösung: Schließen Sie den Richtlinieneditor im ursprünglichen Projekt und öffnen Sie ihn im kopierten Projekt.

Importieren eines Treibers mit geänderten treiberbasierten GCVs nicht möglich

Problem: Designer kann neue GCVs hinzufügen, unterstützt jedoch nicht die Zusammenführung vorhandener GCVs mit den GCVs, die in einer importierten Treiberkonfiguration bearbeitet wurden. In diesen Fällen meldet Designer konfliktverursachende GCVs, die er am Treiber, im Treibersatz oder in GCV-Ressourcenobjekten findet. (Bug 1000122)

Behelfslösung: Momentan lässt sich dieses Problem nicht umgehen.

Designer rendert die Treiberfenster "Importieren" oder "Bereitstellen" nicht ordnungsgemäß

Problem: Beim Importieren oder Bereitstellen eines Treibers im Identitätsdepot rendert Designer die Fenster "Importieren" oder "Bereitstellen" nicht ordnungsgemäß.

Behelfslösung: Führen Sie eine der folgenden Aktionen durch:

  • Drücken Sie Windows + D, um in die Desktopansicht zu wechseln, und kehren Sie dann zur Designer-Anwendung zurück. Dadurch wird das Fenster "Importieren" oder "Bereitstellen" ordnungsgemäß gerendert.

  • Wechseln Sie zu einer anderen Desktopanwendung und kehren Sie dann zur Designer-Anwendung zurück.

Designer zeigt beim Importieren des Identitätsdepots eine Fehlermeldung an

Problem: Beim Importieren des Identitätsdepots in Designer wird die Fehlermeldung Standard-Berechtigungserfassungsobjekt fehlt angezeigt.

Behelfslösung: Führen Sie die folgenden Schritte aus:

  • Klicken Sie in der Fehlermeldung auf OK.

  • Setzen Sie den Import des Identitätsdepots fort.

  • Importieren Sie alle Vorlagen mit der Option Email-Vorlagen > Alle Vorlagen hinzufügen in Designer und stellen Sie sie im Identitätsdepot bereit.

6.3 Linux-spezifische Probleme

Beim Arbeiten mit Designer auf Linux-Plattformen treten möglicherweise die folgenden Probleme auf:

Ausführen von Designer unter Linux mit gtk-qt-

NetIQ Corporation empfiehlt, Designer nicht mit installiertem RPM gtk-qt-engine auszuführen, da dies zu Systemabstürzen und Problemen mit Designer-Motiven führt. Dieses RPM-Paket wird mit SUSE Linux und einigen anderen Linux-Distributionen installiert.

Wenn Sie das RPM-Paket gtk-qt-engine verwenden müssen, laden Sie die aktuelle Version von der KDE-Look-Website herunter. Auch bei der neuesten Version dieses Pakets ist es möglich, dass die Motiv-Funktionalität von Designer nicht verfügbar ist.

Geben Sie Folgendes ein, um festzustellen, ob das RPM-Paket gtk-qt-engine installiert ist:

rpm -qa|grep gtk-qt

Wenn gtk-qt-engine in der Liste angezeigt wird, führen Sie den folgenden Befehl als Benutzer root aus, um das Paket zu entfernen:

rpm -e gtk-qt-engine

Designer-Start unter SLED/SLES 11 und SELD/SLES 12 SP1 nicht möglich

Hinzufügen von XULRunner zur Designer.ini unter SLED/SLES 11 und SELD/SLES 12 SP1

Um Designer zu starten, müssen Sie der Datei Designer.ini die entsprechende XULRunner-Version hinzufügen. Führen Sie dazu die folgenden Schritte aus:

  1. Prüfen Sie die XULRunner-Version im Verzeichnis /usr/lib.

  2. Öffnen Sie die Datei designer.ini im Installationsverzeichnis von Designer.

  3. Wenn Sie SLED 12 SP1 ausführen, fügen Sie die folgende Zeile am Ende der Datei Designer.ini hinzu:

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-24.0/
  4. Speichern Sie die Datei Designer.ini und starten Sie Designer. (Bug 617010)

Unter 64-Bit-Linux stürzt die JVM beim Starten von Designer, Öffnen der Begrüßungsseite oder Öffnen der Hilfe ab

Problem: Wenn die 32-Bit-Version von XULRunner auf einer 64-Bit-Linux-Distribution installiert ist, stürzt die JVM möglicherweise ab, wenn Designer gestartet, die Begrüßungsseite angezeigt oder ein Hilfethema aufgerufen wird. (Bug 748277, Bug 749437)

Behelfslösung:

  1. Öffnen Sie die Datei designer.ini im Installationsverzeichnis von Designer.

  2. Fügen Sie am Ende der Datei Designer.ini die folgende Zeile hinzu:

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9/
  3. Speichern Sie die Datei Designer.ini und starten Sie Designer.

Begrüßungsseite wird auf einigen Linux-Distributionen nicht angezeigt

Problem: Wenn die Begrüßungsseite unter Linux nicht ordnungsgemäß angezeigt wird, hängt dies vermutlich damit zusammen, dass Ihre Version von XULRunner nicht mit Eclipse kompatibel ist. Designer verwendet für einige Seiten, z. B. die Begrüßungsseite und das Hilfesystem, den von XULRunner bereitgestellten eingebetteten Browser.

Behelfslösung: So laden Sie eine kompatible Version von XULRunner herunter:

  1. Laden Sie das XULRunner-Installationsprogramm für Linux von der Mozilla FTP-Website herunter.

  2. Heben Sie die Registrierung Ihrer aktuellen XULRunner-Version auf, indem Sie als root folgenden Befehl ausführen:

    xulrunner --unregister-global
  3. Befolgen Sie die Anweisungen zur Installation von XULRunner.

  4. Starten Sie Designer neu und vergewissern Sie sich, dass die Begrüßungsseite wie erwartet angezeigt wird.

Beim Durchsuchen des Hilfesystems von Designer 4.6 auf der openSUSE 11.2-Plattform tritt eine Ausnahme auf

Problem: Wenn Sie den Inhalt der Hilfe auf einer openSUSE 11.2-Plattform durchsuchen, wird ein Ausnahmefehler ausgegeben. Dies hängt vermutlich damit zusammen, dass Ihre Version von XULRunner nicht mit Eclipse kompatibel ist. (Bug 609379)

Behelfslösung:

  1. Laden Sie die Datei xulrunner-1.8.1.3.en-US.linux-i686.tar herunter und installieren Sie sie auf openSUSE 11.2.

  2. Öffnen Sie die Datei Designer.ini im Installationsverzeichnis von Designer und fügen Sie am Ende der Datei folgende Zeile hinzu:

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner
  3. Speichern Sie die Datei Designer.ini und starten Sie Designer neu.

Designer zeigt die Begrüßungsseite unter openSUSE 13.2 nicht an

Problem: Designer zeigt die Begrüßungsseite auf einem openSUSE 13.2-Server nicht korrekt an. (Bug 754029)

Behelfslösung: Installieren Sie XULRunner 1.9.2 auf dem openSUSE-Server:

  1. Öffnen Sie die Datei designer.ini im Installationsverzeichnis von Designer.

  2. Fügen Sie am Ende der Datei Designer.ini die folgende Zeile hinzu:

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9.2/
  3. Speichern Sie die Datei Designer.ini und starten Sie Designer.

Designer stürzt beim Durchführen eines Live-Imports ab

Problem: Wenn Sie einen Live-Import in Designer 4.5 ausführen, der auf eDirectory 8.8 SP7 ausgeführt wird, stürzt Designer ab. Dies wird durch eine nicht kompatible NICI-Bibliothek verursacht, da Designer 4.6 für eDirectory 8.8.8 mit NICI 2.7.7 ausgelegt ist. eDirectory 8.8 SP7 verwendet jedoch NICI 2.7.6. (Bug 872479)

Behelfslösung: Rüsten Sie entweder auf eDirectory 8.8 SP8 auf oder gehen Sie wie folgt vor:

  1. Stoppen Sie Designer.

  2. Führen Sie den folgenden Befehl aus:

    export
    LD_LIBRARY_PATH=/opt/novell/lib64/:/opt/novell/eDirectory/lib64/:/opt/novell/eDirectory/lib64/nds-modules/
  3. Starten Sie Designer mit dem Befehl ./Designer.

    Verwenden Sie nicht den Befehl StartDesigner.sh.

6.4 Workflow-/Bereitstellungsprobleme

Bei Verwendung von Workflows in Designer treten möglicherweise die folgenden Probleme auf:

Ressourcen, die Rollen zugeordnet sind, werden nicht aus der Ressourcenliste des Rolleneditors gelöscht

Problem: Unter der Ressourcenliste im Rolleneditor steht eine schreibgeschützte Liste der zugeordneten Ressourcen zusammen mit der Rolle zur Verfügung. Die Informationen in dieser Liste werden für alle Rollen abgerufen und aktualisiert, wenn aus eDirectory der Rollenkatalog importiert wird. Sie können neue Ressourcenverknüpfungen erkennen, nicht jedoch die Ressourcenverknüpfungen, die in der Benutzeranwendung entfernt wurden. (Bug 516730)

Behelfslösung: Vergewissern Sie sich, dass die gelöschten Ressourcenverknüpfungen von der Ressourcenliste entfernt werden.

  1. Bevor Sie den Live-Import vom Rollenkatalog aus ausführen, wechseln Sie in die Navigatoransicht und navigieren Sie zum Ordner \MyProject\Model\Provisioning\AppConfig\RoleConfig\ResourceAssociations.

  2. Entfernen Sie alle Dateien in dem Ordner außer der Datei ResourceAssociations.digest.

  3. Wählen Sie aus der Bereitstellungsansicht das Rollenkatalogobjekt aus und führen Sie den Live-Import aus, um alle Ressourcenverknüpfungen erneut zu importieren und die aktualisierten korrekten Informationen anzugeben.

Designer zeigt einen Fehler an, wenn der Rollenkatalog bereitgestellt wird, nachdem Rollen- oder Ressourcenuntercontainer gelöscht wurden

Problem: Wenn Sie einen Rollen- oder Ressourcenuntercontainer erstellen, dem Untercontainer mindestens ein Objekt hinzufügen, den Rollenkatalog bereitstellen und den Untercontainer dann löschen und versuchen, den Katalog erneut bereitzustellen, gibt Designer die Fehlermeldung java.lang.NullPointerException aus.

Dieses Problem tritt auf, weil Designer Rollen- oder Ressourcenobjekte nicht sofort löscht, wenn Sie diese Objekte im Rollenkatalog löschen. Stattdessen markiert Designer die Objekte zum Löschen durch den Rollen- und Ressourcendiensttreiber, wenn der Treiber den Katalog für das Identitätsdepot bereitstellt. (Bug 846814)

Behelfslösung: Führen Sie die folgenden Schritte durch:

  1. Klicken Sie in der Bereitstellungsansicht mit der rechten Maustaste auf das Rollen- oder Ressourcenobjekt, das sich in dem zu löschenden Untercontainer befindet, und wählen Sie Löschen aus.

  2. Wählen Sie Objekt im Identitätsdepot beim Bereitstellen des übergeordneten Containers löschen aus und klicken Sie auf OK.

  3. Klicken Sie mit der rechten Maustaste auf Rollenkatalog und wählen Sie Live > Alle bereitstellen.

  4. Klicken Sie auf Bereitstellen und dann auf OK.

  5. Um zu überprüfen, ob der Rollen- und Ressourcendiensttreiber die Rolle gelöscht hat, melden Sie sich in iManager an.

  6. Klicken Sie in iManager auf die Option Objekte anzeigen.

  7. Navigieren Sie im Baum zu Ihrem Benutzeranwendungstreiber und erweitern Sie AppConfig > RoleConfig > RoleDefs.

  8. Klicken Sie auf den Container, in dem die Rolle zuvor gespeichert war. Wenn sich die Rolle nach wie vor in dem Container im Identitätsdepot befindet, wählen Sie „Aktualisieren“, bis die Rolle vom Rollen- und Ressourcendiensttreiber entfernt wird.

  9. Klicken Sie in der Bereitstellungsansicht in Designer mit der rechten Maustaste auf den Untercontainer, den Sie entfernen möchten, und wählen Sie Löschen aus. Klicken Sie dann auf OK.

  10. Klicken Sie mit der rechten Maustaste auf Rollenkatalog und wählen Sie Live > Alle bereitstellen.

  11. Klicken Sie auf Bereitstellen und dann auf OK.

Designer zeigt beim Löschen von Rollen einen nicht korrekten Status an

Problem: Designer zeigt den Bereitstellungsstatus gegenwärtig nicht korrekt an, wenn Sie eine Rolle im Rollenkatalog in Designer löschen und den Katalog anschließend im Identitätsdepot bereitstellen. Wenn der Rollen- und Ressourcendiensttreiber eine Rolle im Identitätsdepot erfolgreich löscht, zeigt Designer in einigen Fällen fälschlicherweise eine Fehlermeldung an. Wenn der Rollen- und Ressourcentreiber gestoppt wird, zeigt Designer gleichzeitig fälschlicherweise eine Erfolgsmeldung an. (Bug 846029, Bug 847047)

Behelfslösung: Führen Sie die folgenden Schritte aus, um zu überprüfen, ob der Rollen- und Ressourcentreiber die Rolle, die Sie im Identitätsdepot gelöscht haben, entfernt hat:

  1. Melden Sie sich in iManager an und klicken Sie auf Objekte anzeigen.

  2. Navigieren Sie im Baum zu Ihrem Benutzeranwendungstreiber und erweitern Sie AppConfig > RoleConfig > RoleDefs.

  3. Klicken Sie auf den Container, in dem die Rolle zuvor gespeichert war.

  4. Schließen Sie iManager, wenn Sie den Vorgang beendet haben.

Das Aktualisieren eines Benutzeranwendungspakets führt dazu, dass Designer 4.6 doppelte Objekte erstellt und die Bereitstellung des Treibers blockiert

Problem: Wenn Sie Designer 4.6 in Ihrer Umgebung installieren, den Benutzeranwendungstreiber importieren oder erstellen und dann eines der Pakete des Benutzeranwendungstreibers herauf- oder herabstufen, erstellt Designer doppelte Objekte in der Verzeichnisabstraktionsschicht, einschließlich Objekten in den Kategorien „Benutzer“, „Bereitstellung“, „Rolle“ und „Ressource“. Aufgrund der doppelten Objekte stellt Designer den Treiber nicht in der Live-Umgebung bereit und der Treiber funktioniert nicht wie erwartet. (Bug 855670, Bug 857475, Bug 826765)

Behelfslösung: Führen Sie die folgenden Schritte durch:

  1. Starten Sie Designer.

  2. Wenn Sie zur Bestätigung aufgefordert werden, ob nach Designer-Updates gesucht werden soll, wählen Sie Ja aus und klicken Sie auf OK.

  3. Aktualisieren Sie Ihre Designer-Installation auf die Version 4.5 AU4.

  4. Löschen Sie den vorhandenen Benutzeranwendungstreiber.

  5. (Bedingt) Führen Sie die folgenden Schritte aus, wenn das Identitätsdepot eine frühere Version des Benutzeranwendungstreibers enthält:

    1. Klicken Sie im Modellierer mit der rechten Maustaste auf den Treibersatz und wählen Sie Live > Importieren aus.

    2. Klicken Sie auf Durchsuchen.

    3. Wählen Sie den Benutzeranwendungstreiber in Ihrem Identitätsdepot aus und klicken Sie auf OK. Klicken Sie dann auf Weiter.

    4. Klicken Sie zur Bestätigung auf Ja.

    5. Klicken Sie auf Importieren und abschließend auf OK.

  6. (Bedingt) Führen Sie folgende Schritte aus, wenn Sie eine frühere Sicherung des Benutzeranwendungstreibers zur Verfügung haben:

    1. Klicken Sie im Modellierer mit der rechten Maustaste auf den Treibersatz und wählen Sie Aus Konfigurationsdatei importieren.

    2. Klicken Sie auf Durchsuchen und navigieren Sie zum Speicherort der gesicherten Konfigurationsdatei des Benutzeranwendungstreibers.

    3. Wählen Sie die XML-Datei und klicken Sie auf OK. Klicken Sie dann erneut auf OK.

    4. Geben Sie die gewünschten Informationen für den importierten Treiber an und klicken Sie auf Weiter.

    5. Klicken Sie auf OK, wenn Sie den Vorgang ausgeführt haben.

  7. Klicken Sie im Modellierer mit der rechten Maustaste auf den Benutzeranwendungstreiber und wählen Sie Treiber > Eigenschaften.

  8. Klicken Sie auf Pakete.

  9. Führen Sie notwendige Aktionen zum Herauf- oder Herunterstufen aus und klicken Sie auf OK.

  10. Klicken Sie mit der rechten Maustaste auf den Treiber und wählen Sie Treiber > Live > Bereitstellen. Folgen Sie dann den Schritten in der Bereitstellungszusammenfassung.

6.5 Probleme beim Generieren von Dokumenten

Bei Verwendung des Dokumentgenerators treten möglicherweise die folgenden Probleme auf:

Der Dokumentgenerator generiert keine Dokumentation für rollenbasierte Objekte

Designer 4.5 generiert keine Dokumentation für rollenbasierte Berechtigungsrichtlinien und rollenbasierte Provisioning-Modul-Ressourcen. Weitere Informationen über das Generieren von Dokumentationen für Projekte finden Sie unter „Documenting Projects“ (Dokumentieren von Projekten) im Designer 4.0.2 for Identity Manager 4.0.2 Administration Guide (Administrationshandbuch zu Designer 4.0.2 for Identity Manager 4.0.2). (Bug 480369)

Fehler beim Generieren der Dokumentation für Projekte mit vielen Treibern oder großen RBPM-Bereitstellungen

In Designer-Projekten mit mehr als 40 installierten Treibern oder sehr großen rollenbasierten Provisioning-Modulbereitstellungen tritt beim Dokumentgenerator ein Fehler aufgrund von nicht ausreichendem Speicherplatz auf.

Dieser Fehler ist auf Beschränkungen im Apache FOP-Druckformatierungsprogramm zurückzuführen, das Designer zum Generieren der Dokumentation verwendet. Informationen zu den Speicherbeschränkungen des FOP-Formatierungsprogramms sowie Empfehlungen zur Verbesserung der Speichernutzung finden Sie im Abschnitt zur Speicherverwendung auf der Apache FOP-Projektseite. (Bug 796616, Bug 520231)

Generierte Dokumente werden nicht automatisch in der Projektansicht aufgeführt

Problem: Wenn Sie ein Dokument in Designer erstellen, wird es nicht im Ordner „Generiert“ aufgeführt, obwohl das generierte PDF-Dokument fehlerfrei geöffnet wird. (Bug 879625)

Behelfslösung: Aktualisieren Sie den Ordner „Generiert“, um das generierte Dokument in der Liste verfügbar zu machen.

6.6 Probleme mit der Abwärtskompatibilität

Beim Arbeiten mit Arbeitsbereichen, die in früheren Designer-Versionen erstellt wurden, treten möglicherweise die folgenden Probleme auf:

Designer 4.6 unterstützt keine Workspaces der Version 2.1.1

Workspaces von Designer 2.1.1 sind nicht mit Designer 4.6 kompatibel. Designer speichert Projekt- und Konfigurationsinformationen in einem Workspace. Diese Workspaces sind nicht innerhalb verschiedener Designer-Versionen kompatibel. Sie müssen mit Designer 4.6 auf einen neuen Arbeitsbereich zeigen und nicht auf einen Arbeitsbereich, der von einer früheren Designer-Version verwendet wird.

Designer 4.6 unterstützt keine Konvertierung von Projekten, die älter als Designer 3.0 sind

Konvertieren Sie zur Behebung dieses Problems die älteren Projekte zuerst in Designer 3.0.1 und importieren Sie sie anschließend in Designer 3.5. (Bug 531135)

6.7 Probleme beim Aufrüsten

Beim Aufrüsten von Designer treten möglicherweise die folgenden Probleme auf:

Designer-Fenster für automatische Aktualisierung enthält fehlerhafte Informationen zur Aufrüstung

Problem: Die Funktion zur automatischen Aktualisierung führt lediglich eine automatische Aktualisierung durch, jedoch keine Aufrüstung der aktuellen Version auf Designer 4.6.

Behelfslösung: Rüsten Sie manuell auf Designer 4.6 auf.

Aufrüstung von Designer 3.0.1 auf Designer 4.6 wird nicht unterstützt

Problem: Designer 3.5 und höher ist eine vollwertige RCP-Anwendung. Es unterstützt keine Aufrüstungen von Designer-Versionen vor 3.5. Wenn Sie ein Designer 3.0.1-Projekt in die neueste Version von Designer importieren, konvertiert Designer das Projekt automatisch auf die Version 4.6, sodass das Projekt in der neuesten Designer-Version verwendet werden kann. (Bug 531690)

Behelfslösung: Momentan lässt sich dieses Problem nicht umgehen.

Schemaänderungen müssen nach dem Aufrüsten auf Designer 4.5 manuell modifiziert und bereitgestellt werden

Problem: Wenn Sie ein Projekt mit einer früheren Version von Designer erstellen und Ihre Umgebung dann auf Designer 4.6 aufrüsten, müssen Sie das Schema manuell aktualisieren und bereitstellen, damit es mit dem Projekt zusammen funktioniert.

Wenn Sie ein Projekt mit einer früheren Version von Designer erstellen und dieses Projekt dann in eine Designer 4.6-Umgebung importieren, müssen Sie außerdem das Schema aktualisieren und das aktualisierte Schema bereitstellen. (Bug 845210)

Behelfslösung: Führen Sie die folgenden Schritte aus, um Designer 4.6-Schemaänderungen zu modifizieren und bereitzustellen:

  1. Klicken Sie im Modellierer mit der rechten Maustaste auf das Identitätsdepot und wählen Sie Depotschema verwalten aus.

  2. Wählen Sie in der Liste „Klassen“ den Eintrag DirXML-PkgItemAux aus.

  3. Klicken Sie im Fenster „Attribute“ der Klasse DirXML-PkgItemAux auf das Symbol Optional hinzufügen.

  4. Wählen Sie im Fenster „Optionales Attribut auswählen“ das Attribut DirXML-pkgLinkages aus und klicken Sie auf OK.

  5. Klicken Sie auf OK.

  6. Speichern Sie Ihr Designer-Projekt.

  7. Klicken Sie mit der rechten Maustaste auf das Identitätsdepot und wählen Sie Live > Schema > Vergleichen aus.

  8. Klicken Sie auf das Dropdownmenü und wählen Sie Alles anzeigen aus.

  9. Erweitern Sie Attribute und wählen Sie DirXML-pkgLinkages aus.

  10. Wenn der Vergleichsstatus Ungleich lautet, wählen Sie eDirectory aktualisieren aus.

  11. Erweitern Sie Klassen und wählen Sie DirXML-PkgItemAux aus.

  12. Wenn der Vergleichsstatus Ungleich lautet, wählen Sie eDirectory aktualisieren aus.

  13. Klicken Sie auf Abgleich und dann auf Nein.

  14. Klicken Sie auf OK, wenn Sie den Vorgang ausgeführt haben.

Migrieren von Paketverknüpfungen auf die neue Struktur nach dem Aufrüsten auf Designer 4.5

Führen Sie die folgenden Schritte aus, um Ihren Paketkatalog auf die neue Verknüpfungsstruktur zu migrieren:

  1. (Bedingt) Wenn Sie Ihr Projekt noch nicht in Designer 4.6 importiert haben, klicken Sie auf Datei > Importieren und folgen Sie den Schritten im Importassistenten.

  2. (Bedingt) Wenn Sie ein vorhandenes Projekt aktualisieren möchten, empfehlen wir Ihnen, das Projekt zu sichern:

    1. Klicken Sie auf Projekt > Projekt exportieren.

    2. Wählen Sie das Projekt im Fenster „Projekt exportieren“ aus.

    3. Wählen Sie In Archivdatei aus.

    4. (Bedingt) Klicken Sie abhängig von Ihrer Umgebung entweder auf Im .zip-Format speichern oder auf Im .tar-Format speichern.

    5. Klicken Sie auf Durchsuchen und navigieren Sie zu dem Speicherort, an dem Sie die Sicherungsdatei ablegen möchten.

  3. Klicken Sie in der Gliederungsansicht mit der rechten Maustaste auf Paketkatalog und wählen Sie Verbindungen migrieren aus.

  4. Klicken Sie auf Ja, um zu bestätigen, dass Sie Ihr Projekt gesichert haben.

  5. Klicken Sie auf OK.

Diese Vorgehensweise ist für Projekte bestimmt, die mit einer früheren Version als Designer 4.6 erstellt wurden, sowie für Projekte, die aus dem Identitätsdepot importiert wurden. (Bug 847441)

Durch Aktualisieren des Benutzeranwendungstreiberpakets von Designer 3.0 auf Designer 4.6 wird das Paket als „Benutzerdefiniert“ angezeigt

Wenn Sie ein Benutzeranwendungstreiberpaket mit Designer 3.0 erstellen und dann auf Designer 4.6 aufrüsten, wird die Eigenschaft des installierten Benutzeranwendungsbasispakets als „Benutzerdefiniert“ angezeigt. (Bug 889949)

Eine Fehlermeldung wird nach dem Aufrüsten von Designer 4.0.2 beim erstmaligen Starten von Designer angezeigt

Problem: Dieser Fehler tritt auf, da der Container org.eclipse.osgi vom Aufrüstungsprogramm nicht gelöscht wird. (Bug 886559)

Behelfslösung: Löschen Sie den Container in <designer_install_location>\configuration\ und starten Sie Designer.

Designer generiert keine Zertifikate für eDirectory-Server mit NICI 2.7.7.0

Problem: Wenn Sie eine ältere Version von eDirectory verwenden (8.8.X oder 9.0) und Designer auf demselben Computer installieren, rüstet Designer NICI nicht auf 3.0.1.0 auf. Designer generiert daher keine Zertifikate für eDirectory-Server.

Behelfslösung: Momentan lässt sich dieses Problem nicht umgehen.

6.8 Probleme bei der Deinstallation

Beim Deinstallieren von Designer treten möglicherweise die folgenden Probleme auf:

Bei der Deinstallation werden die Ordner „Pakete“ und „Plugins“ nicht vom Windows-Server entfernt

Wenn Sie das Installationsprogramm zur Deinstallation von Designer am Windows-Server ausführen, entfernt das Installationsprogramm möglicherweise nicht alle Ordner, die beim Installationsvorgang erstellt wurden. In einigen Umgebungen entfernt das Installationsprogramm nicht die Ordner Pakete oder Plugins aus dem Installationsordner für Designer. (Bug 748541)

7.0 Kontaktangaben

Wir möchten Ihnen stets eine nützliche, aussagekräftige Dokumentation an die Hand geben. Sie haben Verbesserungsvorschläge? Dann senden Sie sie uns per Email an Documentation-Feedback@netiq.com. Wir freuen uns auf Ihre Rückmeldung.

Ausführliche Kontaktinformationen finden Sie auf der Website mit den Support-Kontaktangaben.

Allgemeine Informationen zu unserem Unternehmen und unseren Produkten finden Sie auf der NetIQ-Firmenwebsite.

Werden Sie Mitglied in unserer Community, und führen Sie interaktive Gespräche mit Fachkollegen und NetIQ-Experten. In der NetIQ-Online-Community finden Sie Produktinformationen, Links zu nützlichen Ressourcen, Blogs und Social-Media-Kanäle.