Bits error 80190191 when trying to check package into the deployment (NETIQKB73077)

  • 7773077
  • 01-Jul-2011
  • 23-Jan-2012

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager 8.0.x

Situation

A software package (such as an updated Module) fails to check-in, IIS logs indicate a 80190191 error coming from BITS when trying to check-in the package.

Resolution

In the IIS Snap-in verify BITS Uploading to the virtual directory:

  1. Expand Computer
  2. Expand Websites
  3. Expand Default Web Site
  4. Right Click the WebDepot > Properties
  5. BITS Server Extension, Make sure the 'Allow clients to transfer data to this virtual directory' is enabled.

Make sure to also Stop the WinHTTPProxy Auto Discovery Service on the machine that is trying to check the pacakage into Control Center.

The issue should be resolved at this point.

Cause

The IUSR account is unable to write to the target directory through BITS.
The WinHTTPProxy Auto Discovery Service is preventing the connection from occuring.

Additional Information

Formerly known as NETIQKB73077