Environment
NetIQ AppManager 8.x
NetIQ AppManager 9.x
Situation
When looking at performance monitor on a 64-bit machine, NetIQms, NetIQmc and/or NetIQccm are missing.
Resolution
To register NetIQ AppManager counters follow these instructions:
Verify that either the "mccnt.dll" file is present in the Windows\System32 (for 32-bit operating systems) or Windows\SysWOW64 (for 64-bit operating systems)folder or "Library" registry exists under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetIQmc\Performance" and it should point to the mccnt.dll location in order to be able to load the 32 bit Perf Counter.
Open a Command Prompt with Run as Administrator and change directory to the Windows\System32 (for 32-bit operating systems) or Windows\SysWOW64 (for 64-bit operating systems) folder.
- Type the following command and press Enter:
regedt32.exe /S "installation_drive_and_folder\AppManager\bin\mccnt.reg"
For example:
regedt32.exe /S "C:\Program Files (x86)\NetIQ\AppManager\bin\mccnt.reg" - Type the following command and press Enter:
lodctr.exe ?installation_drive_and_folder\AppManager\bin\mccnt.ini?
For example:
lodctr.exe ?C:\Program Files (x86)\NetIQ\AppManager\bin\mccnt.ini? - Restart the machine.
To open the 32-bit performance monitor:
1. Run %windir%\SysWOW64\perfmon.exe from the run prompt.
Cause
There are two probable causes:
1. Performance counters are not properly registered.
2. The performance monitor being used only displays 64-bit counters.