SSPR Error: 5052 ERROR_LOCALDB_UNAVAILABLE

  • 7024345
  • 16-Dec-2019
  • 16-Dec-2019

Environment

SSPR 4.3
SSPR 4.4

Situation

SSPR won't load
Error: 5052 ERROR_LOCALDB_UNAVAILABLE
Problem occurs after power failure
Error log shows:

5082 ERROR_STARTUP_ERROR (unable to initialize LocalDB: 5052 ERROR_LOCALDB_UNAVAILABLE (error creating new LocalDB instance: jetbrains.exodus.ExodusException:Unexpected file length, address = 64021856256, file = 000001rk000.xd))

Resolution

Delete the contents of the local database.

Delete the contents of the local database.   In a Windows installation the local database is everything under LocalDB/derby-db.  In a Linux installation the local db is located in the LocalDB/xodus directory.  By default in an IDM installation this will be /opt/netiq/idm/apps/sspr/sspr_data/LocalDB/xodus.   Delete everything in the xodus or derby-dy directory. In Linux environments this can be done with the command "rm -r LocalDB."   

LocalDB will be re-created when SSPR restarts.

Cause

File corruption caused by power outage.

Additional Information

Note that deleting the local database will have no effect on the SSPR password policy.  The SSPR “local” policy is stored in the ssprconfiguration.xml file, not in the local database.  

Unless user data is stored in the local database (which we do NOT recommend), the local database only contains temporary cache files, statistics, intruder status, and logging data.  Unless user data is stored in the local database deleting the local db will not result in the loss of anything that will affect the functionality of SSPR.