Unable to create new comptuer account within the DRA Web Console

  • 7023310
  • 28-Aug-2018
  • 29-Aug-2018

Environment

NetIQ Directory and Resource Administrator 9.2.0.1

Situation

When using the DRA 9.2.0.1 web console to create a new computer account, users are prompted for RIS settings.

When using the DRA 9.2.0.1 web console to create a new computer account, users are not able to submit the create computer form

When using the DRA 9.2.0.1 web console to create a new computer account, the apply button remains grayed out


Resolution

There are a few different workarounds to the issue. These will need to be implemented on each IIS server.

Option 1 - Create a custom computer create page 

1. Logon to the Web Console as a DRA user with DRA Administration powers

2. Use the Customization tab to access the web console customization options

3. Select the Computer create object line, and then click the properties task button

4. Remove the Remote Installation Services page from the left hand side

5. Save the changes

Option 2 - Place any valid GUID format into the the Computer’s unique ID’ field

1. When in the computer create page, select the Remote Installation Services task

2. Enable the This is a managed computer (RIS client) option

3. Paste a valid formatted GUID within the Computer's unique ID field

Note: A list of sample GUIDs can be found via the help button below the field

Option 3 - Manually edit the create computer JSON file

1. Backup and then edit the existing C:\inetpub\wwwroot\DRAClient\components\lib\ui-templates\computer-create-pages.json file

2. On Line 65 change "useRegExValidation": true, to "useRegExValidation": false,

3. This changes lines 60-65 to:

"label": "Computer's unique ID",
"dataField": "netbootGUID",
"required": true,
"mandatory": true,
"useRegExValidation": false,

Cause

Within DRA 9.2.0.1, there is an issue in which the settings for Remote Installation Services are incorrectly set to be validated. This occurs even if the check box for “When using the DRA 9.2.0.1 web console to create a new computer account”, is not enabled.

Additional Information

The information within this KB only applies to the DRA 9.2 Hotfix 1 published on Aug 23, 2018.

The files used within IIS for the DRA Web Console do not replicate globally. The changes within this KB must be manually replicated to all IIS Servers within your environment.