My Favorites

Close

Please to see your favorites.


AD User accounts set to expire after being viewed in the Web Console

This document (7022446) is provided subject to the disclaimer at the end of this document.

Environment

Directory & Resource Administrator 9.1.0.x
Directory & Resource Administrator 9.1

Situation

There is a known bug within the Web Console that may be the cause of the following issues:
- User accounts expire at random
- Users seem to accidentally set accounts they view to expire
- Check box preventing account expiration becomes unchecked at random
- Pressing 'Cancel' in the Account tab asks about dismissing any modifications
- No changes are made, yet the Ok/Apply buttons stay active in the Account tab

Resolution

There is a current work around for this bug. Within the DRA Web Console follow these steps:
1. Select the user account in question.
2. Open the Property Page, and click the Account tab.
3. Look at the "Account Expiration Time", check the box next to "Not Set" and accept the change.
 Please Note: By manually going back into the properties for this user, and checking this box (or disabling the expiration via ADU&C or D&C Console) this user's Account tab will no longer attempt to uncheck the "Not Set" when viewing the Account tab.

Cause

To reproduce this issue, follow these steps:
1. Log on to the Web Console with any account that is able to view another user's Property Page
2. Locate any user account that has the "Not Set" checkbox enabled/checked, within the Account tab
3. Notice that the Ok/Apply buttons are not grayed out, even though nothing has been changed.
4. Accept the changes
4a. This account is now set to expire in 30 days
 
This is the bug. After simply viewing the Account tab information within the Web Console and then clicking Ok/Apply, it enables the Account Expiration. The bug looks to the "Not Set" box and unchecks it, even though it appears to still be checked before 'changes' are made.

Additional Information

This KB ONLY applies to the versions listed in the beginning of the article.
 
The information provided in the Resolution is meant to be a work around for the issue.
 
As of now this is a newly discovered bug, so there is no targeted release. It may be some time before we can update with a targeted release.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022446
  • Creation Date:08-DEC-17
  • Modified Date:08-DEC-17
    • NovellDirectory and Resource Administrator

Did this document solve your problem? Provide Feedback