17.2 Relatórios integrados

Os relatórios integrados permitem gerar relatórios sobre mudanças de objetos, listas de objetos e mais informações de objetos. Esses relatórios não fazem parte dos Serviços do DRA Reporting e nenhuma configuração é necessária para habilitar os relatórios de histórico de mudanças incorporados. Consulte os tópicos desta seção para saber como acessar esses relatórios.

NOTA:Os relatórios do histórico de mudanças também podem ser acessados para eventos fora do DRA quando o DRA é integrado ao Change Guardian. Para obter informações sobre esse tipo de relatórios e como configurar um servidor do Change Guardian, veja Histórico de mudanças unificado.

17.2.1 Gerando relatórios sobre mudanças de objetos

Você pode ver informações de mudança em tempo real para objetos em seus domínios, gerando relatórios de detalhes da atividade. Por exemplo, você pode ver uma lista de mudanças feitas em um objeto ou por um objeto durante um período de tempo especificado. Você também pode exportar e imprimir relatórios de detalhes da atividade.

Para relatar mudanças de objeto:

  1. Encontre os objetos que correspondam aos seus critérios.

  2. Clique o botão direito do mouse em um objeto e selecione Reporting > Changes made to objectName (Gerador de Relatórios > Mudanças feitas ao objectName) ou Reporting > Changes made by objectName (Gerador de Relatórios > Mudanças feitas por objectName).

  3. Selecione as datas de início e término para especificar as mudanças que você deseja ver.

  4. Se desejar mudar o número de linhas a serem exibidas, digite um número acima do valor padrão de 250.

    NOTA:O número de linhas exibidas aplica-se a cada servidor de Administração em seu ambiente. Se você incluir 3 servidores de Administração no relatório e usar o valor padrão de 250 linhas para exibir, até 750 linhas poderão ser exibidas no relatório.

  5. Se desejar incluir apenas servidores de Administração específicos no relatório, selecione Restrict query to these DRA servers (Restringir consulta a esses servidores do DRA) e digite o nome do servidor ou os nomes que você deseja incluir no relatório. Separe vários nomes de servidores com vírgulas.

  6. Clique em OK.

17.2.2 Gerador de relatórios em listas de objetos

Você pode exportar ou imprimir dados de listas de objetos. Com esse recurso, você pode relatar e distribuir de maneira rápida e fácil informações gerais sobre seus objetos gerenciados.

Ao exportar uma lista de objetos, você pode especificar o local, o nome e o formato do arquivo. O DRA oferece suporte aos formatos HTML, CSV e XML, portanto, você pode exportar essas informações para aplicativos de banco de dados ou publicar resultados de lista em uma página da Web

NOTA:Você também pode selecionar vários itens em uma lista e, em seguida, copiar esses itens para um aplicativo de texto, como o Bloco de Notas.

Para relatar listas de objetos:

  1. Encontre os objetos que correspondam aos seus critérios.

  2. Para exportar esta lista de objetos, clique em Export List (Exportar Lista) no menu Arquivo.

  3. Para imprimir esta lista de objetos, clique em Print List (Imprimir Lista) no menu Arquivo.

  4. Especifique as informações apropriadas para gravar ou imprimir essa lista.

17.2.3 Gerando relatórios sobre mais informações do objeto

Você pode exportar ou imprimir dados de guias de mais informações que listam atributos de objetos, como membros de grupos. Com esse recurso, você pode relatar e distribuir com rapidez e facilidade mais informações frequentemente necessárias sobre objetos específicos.

Ao exportar uma guia de mais informações do objeto, você pode especificar o local, o nome e o formato do arquivo. O DRA oferece suporte aos formatos HTML, CSV e XML, portanto, você pode exportar essas informações para aplicativos de banco de dados ou publicar resultados de lista em uma página da Web.

Para relatar mais informações do objeto:

  1. Encontre o objeto que corresponde aos seus critérios.

  2. No menu Ver, clique em Mais informações.

  3. No painel de mais informações, selecione a guia apropriada.

  4. Para exportar mais informações do objeto, clique na Lista Export Details (Exportar Mais Informações) no menu Arquivo.

  5. Para imprimir mais informações do objeto, clique em Print Details List (Imprimir Lista de Mais Informações) no menu Arquivo.

  6. Especifique as informações apropriadas para gravar ou imprimir essa lista.