Technical Specifications

Select Category

Choose a component below to learn about the technical specifications. For more information about installation or hardware requirements, see the Identity Manager Setup Guide.

Categories:

Platforms for Identity Manager

  Identity Vault Identity Manager Engine Remote Loader Designer Identity Applications Identity Reporting Analyzer Sentinel Log Management for IGA

Open Enterprise Server 2015 SP1

Yes Yes Yes   Yes Yes    

Open Enterprise Server 11 SP3

Yes Yes Yes   Yes Yes    

OpenSUSE 13.1

      Yes     Yes  

Red Hat 7.3

Yes Yes Yes   Yes     Yes

Red Hat 7.2

        Yes Yes   Yes

Red Hat 7.1

        Yes Yes    

Red Hat 7.0

        Yes Yes    

Red Hat 6.8

Yes Yes Yes   Yes Yes   Yes

Red Hat 6.7

              Yes

SUSE Linux Enterprise Desktop 12

      Yes        

SUSE Linux Enterprise Desktop 11

      Yes        

SUSE Linux Enterprise Server 12 SP1

Yes Yes Yes Yes Yes Yes Yes  

SUSE Linux Enterprise Server 11 SP4

Yes Yes Yes Yes Yes Yes Yes Yes

Windows Server 2016

    Yes          

Windows Server 2012 R2

Yes Yes Yes Yes Yes Yes Yes  

Windows Server 2012

Yes Yes Yes Yes Yes   Yes  

Windows Server 2008 R2

    Yes Yes     Yes  

Windows Server 2008 SP2

    Yes Yes        

Windows 10

      Yes        

Windows 8.1

      Yes     Yes  

Windows 7 SP1

      Yes     Yes  

System Requirements for Identity Vault

Category Minimum Requirement

Processor

1 GHz

Disk Space

  • 300 MB for the Identity Vault
  • 150 MB of additional disk space for every 50,000 users

Memory

2 GB

Operating System

One of the following 64-bit operating systems:

  • Open Enterprise Server 2015 SP1
  • Open Enterprise Server 11 SP3
  • Red Hat 6.8
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2012 R2
  • Windows Server 2012

Directory Services

NetIQ eDirectory 8.8.8 Patch 9 Hotfix 2 (runs with iManager 2.7.7 Patch 9 or later)

or

NetIQ eDirectory 9.0.2 Hotfix 2 (runs with iManager 3.0.2 Patch 1 or later)

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.5
  • Windows Server 2012 R2 Virtualization with Hyper-V

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.


System Requirements for Identity Manager Engine

Category Requirement

Processor

1 GHz

Disk space

  • 300 MB
  • 150 MB of additional disk space for every 50,000 users

Memory

  • 2 GB for the Identity Manager engine
  • 2 GB for Identity Manager drivers

Operating System

One of the following 64-bit operating systems, at a minimum:

  • Open Enterprise Server 2015 SP1
  • Open Enterprise Server 11 SP3
  • Red Hat 7.3
  • Red Hat 6.8
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2012 R2
  • Windows Server 2012

You cannot use the integrated installation process on a system running Open Enterprise Server.

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.0 and later
  • Windows Server 2012 R2 Virtualization with Hyper-V

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.

Operating System Hotfixes

Before installing Identity Manager, NetIQ recommends that you apply the latest operating system patches according to the manufacturer's automated update facility.

Additional Software

All of the following products:

  • NetIQ eDirectory 8.8.8 Patch 9 Hotfix 2
  • NetIQ eDirectory 9.0.2 Hotfix 2
  • iManager 2.7.7 Patch 9 (for NetIQ eDirectory 8.8.8 Patch 9 or later)
  • iManager 3.0.2 Patch 1 (for NetIQ eDirectory 9.0.2 or later)

System Requirements for Remote Loader (all types)

Remote Loader (Linux)
Category Requirement

Processor

Pentium* III 600 MHz, at a minimum

Memory

512 MB for the Remote Loader

Operating System

One of the following 64-bit operating systems, at a minimum:

  • Open Enterprise Server 2015 SP1
  • Open Enterprise Server 11 SP3
  • Red Hat Enterprise Linux Server 7.3
  • Red Hat Enterprise Linux Server 6.8
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2

For a 32-bit operating system:

  • Windows Server 2008 SP2

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.5

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.


.NET Remote Loader (Windows)
Category Requirement

Processor

Pentium* III 600 MHz, at a minimum

Memory

512 MB for the .NET Remote Loader

Operating System

One of the following 64-bit operating systems, at a minimum:

  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2

For a 32-bit operating system:

  • Windows Server 2008 SP2 (32-bit or 64-bit)

.NET Framework

4.x

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.5
  • Windows Server 2012 R2 Virtualization with Hyper-V

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.


Java Remote Loader (Linux or Windows)
Category Requirement

Processor

Pentium* III 600 MHz, at a minimum

Memory

512 MB for the Remote Loader

JRE

Java8u112, at a minimum

Platform Agent

PA v2011.1r5, at a minimum


System Requirements for iManager Server

Category Requirement

iManager Version

One of the following versions:

  • iManager 3.0.2 Patch 1
  • iManager 2.7.7 Patch 9

Processor

Pentium* III 600 MHz, at a minimum

Disk Space

Linux: 200 MB, at a minimum

Windows: 500 MB, at a minimum

Memory

512 MB (1 GB recommended)

80 MB for iManager plug-ins

Operating System

One of the operating systems listed in Server-Based and Client-Based Versions of iManager in the NetIQ iManager Installation Guide. The operating system must be compatible with one of the supported versions of NetIQ eDirectory for the Identity Vault.

You cannot install iManager on a Solaris platform. However, iManager can still manage and work with applications and resources, such as eDirectory, that run on Solaris.

Web Browsers

Any of the web browsers listed in Server-Based and Client-Based Versions of iManager in the NetIQ iManager Installation Guide.

Application Server

Tomcat 8.5.x, or the version supplied with iManager

You can manually integrate an existing IIS or Apache web server infrastructure with iManager on a Windows server.

Directory Services

NetIQ eDirectory 8.8.8 Patch 9 Hotfix 2 for iManager 2.7.7 Patch 9

or

NetIQ eDirectory 9.0.2 Hotfix 2 for iManager 3.0.2 Patch1

Default Ports

8080, 8443, and 9009


System Requirements for iManager Workstation

Category Requirement

iManager Version

One of the following versions:

  • iManager 3.0.2 Patch 1
  • iManager 2.7.7 Patch 9

Processor

Pentium* III 600 MHz, at a minimum

Disk Space

200 MB, at a minimum

Memory

256 MB (512 MB recommended)

Operating System

One of the operating systems listed in Server-Based and Client-Based Versions of iManager in the NetIQ iManager Installation Guide. The operating system must be compatible with one of the supported versions of NetIQ eDirectory for the Identity Vault.

Web Browsers

Any of the web browsers listed in Server-Based and Client-Based Versions of iManager in the NetIQ iManager Installation Guide.

Application Server

Tomcat 8.5.x, bundled with iManager Workstation

Software

Java 1.8.0_x or later, bundled with iManager Workstation

Default Ports

8080, 8443, and 9009


System Requirements for Designer

Category Requirement

Processor

1 GHz

Disk Space

1 GB

Memory

2 GB for Designer

Operating System

NetIQ ships both 32-bit and 64-bit Designer. You can install Designer on the following 64-bit operating systems, at a minimum:

Servers

  • openSUSE 13.1
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2
  • Windows Server 2008

Desktops

  • SUSE Linux Enterprise Desktop 12 SP1
  • SUSE Linux Enterprise Desktop 11 SP4
  • Windows 10
  • Windows 8
  • Windows 7

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.5
  • Windows Server 2012 R2 Virtualization with Hyper-V

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.


System Requirements for Identity Applications

The operating system requirements also apply to the following components that you use with the identity applications: PostgreSQL, Tomcat, NetIQ One SSO Provider (OSP), and NetIQ Self Service Password Reset.

Category Requirement

Processor

1 GHz, at a minimum

Disk Space

  • 1 GB for data
  • Enough space for the content of supporting applications, such as the database and application server logs

Memory

512 MB (4 GB recommended)

Operating System

One of the following 64-bit operating systems, at a minimum:

  • Open Enterprise Server 2015 SP1
  • Open Enterprise Server 11 SP3
  • Red Hat Enterprise Linux 7.3
  • Red Hat Enterprise Linux 7.2
  • Red Hat Enterprise Linux 7.1;
  • Red Hat Enterprise Linux 7.0
  • Red Hat Enterprise Linux 6.8
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2012 R2
  • Windows Server 2012

NetIQ recommends that you apply the latest operating system patches according to the manufacturer's automated update facility.

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.5
  • Windows Server 2012 R2 Virtualization with Hyper-V

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.

Database

  • Microsoft SQL Server 2014 with JDBC 3.0 3.0.1119.0
  • Oracle 12c with JDBC 1 2.1.0.1.0
  • PostgreSQL 9.4.10 with JDBC 4.2 (SLES 11 SP4 only)
  • PostgreSQL 9.6.1 with JDBC 4.2 (other supported platforms)

Application Server

  • Apache Tomcat 8.5.x

Java

Java Development Kit (JDK) or Java Runtime Environment (JRE) version 1.8.0_112 or later from Sun (Oracle)

Port

8180

Web Browser

Any of the following browsers, at a minimum:

  • Apple Safari 9
  • Google Chrome 51
  • Microsoft Edge
  • Microsoft Internet Explorer 11
  • Mozilla Firefox 46

To access the identity applications, the browser must have cookies enabled. If cookies are disabled, the product does not work.

Audit

One of the following auditing services:

  • OpenXDAS 0.8.345
  • (Conditional) For servers running SLES SP4 with Open XDAS:
    • openxdas-0.8.351-1.1.i586.rpm
    • openxdas-0.8.351-1.1.x86_64.rpm
  • Novell Audit 2.0.2-77

Domain Services for Windows

Open Enterprise Server 11 SP3

For a 32-bit operating system:

  • Open Enterprise Server 11 SP3

Directory services

NetIQ eDirectory 8.8.8 Patch 9 Hotfix 2

or

NetIQ eDirectory 9.0.2 Hotfix 2


System Requirements for Sentinel Log Management for IGA

Category Requirement

Processor

4 to 8 CPU cores

Disk Space

200 GB

Memory

8 to 15 GB

Operating System

One of the following 64-bit operating systems, at a minimum:

  • Red Hat Enterprise Linux 7.3
  • Red Hat Enterprise Linux 7.2
  • Red Hat Enterprise Linux 7.1
  • Red Hat Enterprise Linux 7.0
  • Red Hat Enterprise Linux 6.8
  • Red Hat Enterprise Linux 6.7
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4

System Requirements for Identity Reporting

Category Requirement

Processor

Pentium* III 600 MHz, at a minimum

Disk Space

1 GB

Enough space for the content of supporting applications, such as the database and application server logs.

Memory

512 MB (4 GB recommended)

Operating System

One of the following 64-bit operating systems, at a minimum:

  • Open Enterprise Server 2015 SP1
  • Open Enterprise Server 11 SP3
  • Red Hat Enterprise Linux 7.2
  • Red Hat Enterprise Linux 7.1
  • Red Hat Enterprise Linux 7.0
  • Red Hat Enterprise Linux 6.8
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2012 R2

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.5 and later
  • Windows Server 2012 R2 Virtualization with Hyper-V

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.

Application Server

  • Apache Tomcat 8.5.x

Java

Java Development Kit (JDK) or Java Runtime Environment (JRE) version 1.8.0_112 or later from Sun (Oracle)

Web Browser

Any of the following browsers, at a minimum:

Desktop:

  • Apple Safari 5.1.7 for Windows
  • Safari 7.0.1
  • Google Chrome 51
  • Microsoft Internet Explorer 11
  • Mozilla Firefox 47

iPad:

  • Apple Safari 7
  • Google Chrome 51

The browser must have cookies enabled. If cookies are disabled, the product does not work.

Databases

Identity Reporting database (and EAS) runs on the following platform, at a minimum:

  • PostgreSQL 9.6.x

You can run reports against the following databases, at a minimum:

  • Oracle 12c
  • PostgreSQL 9.6.x

System Requirements for Analyzer

Category Requirement

Processor

1 GHz, at a minimum

Memory

512 MB (4 GB recommended)

Video Resolution

1024x768 (1280x1025 recommended)

Operating System

One of the following 64-bit operating systems, at a minimum:

  • openSUSE 13.2
  • SUSE Linux Enterprise Server 12 SP1
  • SUSE Linux Enterprise Server 11 SP4
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008

For a 32-bit operating system, at a minimum:

  • openSUSE 13.2

Virtualization Systems

One of the following virtualization platforms:

  • Hyper-V Server 2012 R2
  • VMware ESX 5.0 and later

NetIQ supports Identity Manager on enterprise-class virtualization systems that provide official support for the operating systems where NetIQ products are running. As long as the vendors of the virtualization systems officially support these operating systems, NetIQ supports the entire Identity Manager stack on them.

Operating System Hotfixes

NetIQ recommends that you apply the latest operating system patches according to the manufacturer's automated update facility before you install Identity Manager.

Additional Software Components

  • compat-2008.5.6-6.1.i586.rpm (32-bit system) or compat-32bit-2008.5.6-6.1.x86_64.rpm (64-bit system)
  • Gettext utility (on Linux computers only)

System Requirements for Identity Manager Drivers

Driver System Requirements Local Installation Platforms Remote Installation Platforms
Driver for Access Review
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • Access Review 1.1 or later
  • Database JDBC file
  • Access Review driver is installed with the Remote Loader on the same server as Access Review/Identity governance
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Active Directory
  • NetIQ Identity Manager 4.5 or later




  • NetIQ Identity Manager 4.6 or later
  • Exchange Server 2010, Exchange Server 2013, or Exchange Server 2016
  • Microsoft .NET Framework version 4.5.2 or later
  • Windows Management Framework 3.0 (required on Windows Server 2008 R2 only)
  • Windows Management Framework 4.0 or later
  • Windows PowerShell 2.0 or later
Windows Server 2012 R2 (64-bit), Windows Server 2012 (64-bit), Windows Server 2008 R2 (64-bit), or Windows Server 2008 SP2 (32-bit and 64-bit) Windows Server 2016 (64-bit), Windows Server 2012 R2 (64-bit), Windows Server 2012 (64-bit), Windows Server 2008 R2 (64-bit), or Windows Server 2008 SP2 (32-bit and 64-bit)
Driver for Office 365 and Azure Active Directory
  • NetIQ Identity Manager 4.5.5 or later


  • NetIQ Identity Manager 4.6 or later
  • Microsoft Windows Server 2008 R2, Microsoft Windows Server 2012, Microsoft Windows Server 2012 R2, or Microsoft Windows Server 2016
  • Microsoft Windows Management Framework 4.0 (required for Windows Server 2008 R2)
  • Microsoft .NET Framework Version 4.5 or later
  • Microsoft Visual C++ 2012 Redistributable packages
  • Microsoft Online Services Sign-In Assistant version 7.250.4556.0 and later
  • Windows Azure AD Module for Windows PowerShell
  • If you are using the driver with Identity Manager 4.5.5, ensure that you apply Identity Manager Integration Module for Microsoft Enterprise 4.6 activation key to activate the driver.
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Blackboard
  • NetIQ Identity Manager 3.6 or later


  • Blackboard 9 or later
All Identity Manager engine supported platforms All supported platforms
Driver for eDirectory
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Google Apps
  • NetIQ Identity Manager 4.0.2 (Engine Patch 2) or later (JRE 1.7 required)

  • NetIQ Identity Manager 4.5 or later
  • NetIQ Identity Manager 4.6 or later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for GroupWise 2014
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • GroupWise 2014 SP1 and later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Identity Tracking
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • Sentinel 7.1 or later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Drivers for JDBC   All Identity Manager engine supported platforms All Remote Loader supported platforms
JDBC Driver
  • NetIQ Identity Manager 4.5 or later
  • NetIQ Identity Manager 4.6 or later
  • Supported databases
  • IBM DB2 Universal Database (UDB) 9.0 or later
  • Informix Dynamic Server (IDS) 11.0 or later
  • Microsoft SQL Server 2008, 2008 R2, 2012, 2014, and 2016
  • MySQL 5.5.x or later and 5.6.x or later
  • Oracle 11g Release 2 (11.2) or later, 12c
  • PostgreSQL 8.4.x or later, 9.0.x or later, and 9.6.3
  • Sybase Adaptive Server Enterprise (ASE) 15.0 or later
   
JDBC Fan-Out Driver
  • NetIQ Identity Manager 4.5 or later
  • NetIQ Identity Manager 4.6 or later
  • Microsoft SQL Server 2008, 2008 R2, 2012, 2014, and 2016
  • MySQL 5.5.x or later and 5.6.x or later
  • Oracle 11g Release 1 (11.1) or later, 12c
  • Sybase Adaptive Server Enterprise (ASE) 15.0 or later
   
Driver for JMS
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • JBossMQ v4.2.2
  • JBoss Messaging 1.3.0, JBoss Messaging 1.4.6, and Messaging 2.4.0
  • IBM WebSphere MQ v6.x, MQ v7.x, and MQ 7.5
  • SonicMQ v7.x, and Sonic 8.5
  • TIBCO EMS v4, v5, and v8.0
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for LDAP
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • Supports LDAP v3 compliant LDAP directories
All Identity Manager engine supported platforms All Remote Loader supported platforms
Drivers for Linux and UNIX   All Identity Manager engine supported platforms All Remote Loader supported platforms
Bidirectional Driver
  • NetIQ Identity Manager 4.6 Integration Module
  • AIX* 6, 7
  • CentOS 6, 7 (32-bit, 64-bit)
  • Debian* N/A
  • HP-UX* 11.23 (RISC and IA64_32)
  • Oracle Linux N/A
  • Red Hat* Linux 6, 7 (32-bit, 64-bit)
  • Solaris* SPARC* 10, 11
  • Solaris x86 10, 11
  • SUSE® Linux 10, 11, 12 (32-bit, 64-bit)
  • SUSE zLinux s390x 10, 11 (64-bit)
   
Fan-out Driver
  • NetIQ Identity Manager 4.6 Integration Module
  • AIX* 6, 7
  • CentOS 6, 7 (32-bit, 64-bit)
  • Debian* N/A
  • HP-UX* 11.23 (RISC and IA64_32)
  • Oracle Linux N/A
  • Red Hat* Linux 6, 7 (32-bit, 64-bit)
  • Solaris* SPARC* 10, 11
  • Solaris x86 10, 11
  • SUSE® Linux 10, 11, 12 (32-bit, 64-bit)
  • SUSE zLinux s390x 10, 11 (64-bit)
   
Driver for Linux and UNIX Settings
  • NetIQ Identity Manager 4.6 or later


  • The server that the driver runs on must hold read/write replicas of the objects the driver manages
  • To use LUM or NetIQ Samba integration, you must be using Open Enterprise Server
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Lotus Notes
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later


  • Lotus Notes Client is only supported on the workstation platforms

  • Lotus Domino v8.5, v8.5.2, v8.5.3, and v9.0
Local installation not supported Windows XP, Windows 7 and 8, SLED 32-bit, or RHEL 6 Client 32-bit

Install the Remote Loader on a separate workstation where the Notes Client is already installed
Driver for Multi-Domain Active Directory
  • NetIQ Identity Manager 4.5 SP2 or later



  • NetIQ Identity Manager 4.6 or later
  • .NET Remote Loader 4.5 Service Pack 2 (64-bit)
  • Microsoft .NET Framework 4.5
  • Windows Message Queuing feature
  • Microsoft Windows Management Framework 4.0
  • Microsoft Windows PowerShell version 4.0
All Identity Manager engine supported platforms Windows Server 2016 (64-bit), Windows Server 2012 R2 (64-bit) or later, Windows Server 2012 (64-bit), or Windows Server 2008 R2 (64-bit)
Drivers for Mainframe   All Identity Manager engine supported platforms All Remote Loader supported platforms
Bidirectional Driver
  • NetIQ Identity Manager 4.6 Integration Module
  • z/OS* 2.2, 2.3
  • RACF*
  • (supported z/OS version)
  • Top Secret* r14, r15, r16
  • ACF/2* r15, r16
   
Drivers for Midrange   All Identity Manager engine supported platforms All Remote Loader supported platforms
Bidirectional Driver
  • NetIQ Identity Manager 4.5 Integration Module
  • IBM* i, i5/OS*, OS/400* V5R4, IBM i 6.1, IBM i 7.1 and later
   
Driver for Oracle E-Business Suite
  • NetIQ Identity Manager 4.5 or later



  • NetIQ Identity Manager 4.6 or later
  • Oracle E-Business Suite 12.1.1 and above
All Identity Manager engine supported platforms


Install the Oracle EBS driver files on the Identity Manager server and use a SOAP endpoint to connect to the Oracle EBS system
All Remote Loader supported platforms


Install the Remote Loader (required to run the driver on a non-Identity Manager server) and the Oracle EBS driver files on a non-Identity Manager server where you want to run the driver
Driver for Office 365
  • NetIQ Identity Manager 4.5.1 or later




  • NetIQ Identity Manager 4.6 or later
  • Microsoft Windows Management Framework 4.0 or later
  • Microsoft Windows PowerShell Version 4.0
  • Microsoft .NET Framework Version 4.5 or later
  • Microsoft Visual C++ 2012
  • Microsoft Online Services Sign-In Assistant version 7.250.4556.0 and above
Local installation not supported Microsoft Windows Server 2016 (64-bit), Microsoft Windows Server 2012 R2, Microsoft Windows Server 2012, or Microsoft Windows Server 2008 R2 (64-bit)
Driver for Peoplesoft 5.2
  • NetIQ Identity Manager 4.5 or later
  • NetIQ Identity Manager 4.6 or later
  • PeopleSoft Application Server with PeopleTools 8.17 or later versions in the 8.1x release, 8.20 or later versions in the 8.2x release, 8.41 or later versions in the 8.4x release, or 8.50 and later versions in the 8.5x release.
Local installation not supported All Remote Loader supported platforms
Driver for Remedy Action Request System (ARS)
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • AR System Server 7.1 or later
  • AR System Server 8.x
  • AR System Server 9.x
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for REST
  • NetIQ Identity Manager 4.5 SP1 or later


  • NetIQ Identity Manager 4.6 or later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Salesforce.com
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • Salefsforce.com
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for SAP HR
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • SAP Java Connector (JCO) client technology version 3.x
  • SAP R/3 version 4.5B or higher (NetWeaver 7.3.x is the latest supported version) and mySAP
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for SAP Portal
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • SAP NetWeaver 7.x
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for SAP User Management
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • SAP Java Connector (JCO) client technology version 3.x
  • SAP R/3 version 4.5B or later (NetWeaver 7.3.x is the latest supported version) and mySAP.
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for SAP User Management Fan-Out
  • NetIQ Identity Manager 4.5 or later


  • NetIQ Identity Manager 4.6 or later
  • JCo 3.0.2 or later
  • SAP Basic 7.00 system or later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for Scripting
  • NetIQ Identity Manager 4.6 or later


  • AIX* 6.1, 7
  • HP-UX* 11.23, 11.31 (IA64_32, IA64_64)
  • Mac OS X 10.8, 10.9 (Darwin x86)
  • Solaris* SPARC* 10, 11
  • Solaris x86 10, 11
  • SUSE® Linux 10, 11, 12(32 and 64-bit)
  • SUSE zLinux s390x 10, 11 (64-bit)
  • Red Hat* Linux 6, 7 (32 and 64-bit)
  • CentOS Linux 6, 7 (32 and 64-bit)
  • Debian* Linux 6, 7 (32-bit)
  • Oracle Linux 7 (32 and 64-bit)
  • Windows Server 2003 (all editions), Windows Server 2003 R2 (all editions), Windows Server 2008 (all editions), Windows Server 2008 R2 (all editions; Server Core installation not supported), Windows Server 2012 (all editions; Core installation not supported), Windows Server 2012 R2 (all editions; Core installation not supported), Windows XP SP2/SP3, Windows Vista, Windows 7, Windows 8, or Windows 8.1
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for ServiceNow
  • NetIQ Identity Manager 4.5 SP2 or later


  • NetIQ Identity Manager 4.6 or later
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for SOAP
  • NetIQ Identity Manager 4.5 or later
  • NetIQ Identity Manager 4.6 or later
  • SOAP 1.1
All Identity Manager engine supported platforms All Remote Loader supported platforms
Driver for SharePoint
  • NetIQ Identity Manager 4.5 or later



  • NetIQ Identity Manager 4.6 or later



  • Microsoft .NET Framework version 4.5 or later
  • Windows Server 2008 R2 (64-bit), Windows Server 2012 (64-bit), Windows Server 2012 R2 (64-bit), or Windows Server 2016
  • SharePoint Server 2013 or SharePoint Server 2016
  • Active Directory driver









Local installation not supported
SharePoint driver uses the .NET Remote Loader service to run on a Windows SharePoint server

Install on Windows Server 2003 SP2 (32-bit), Windows Server 2008 (32-bit and 64-bit), and Windows Server 2008 R2 (64-bit)
Driver for Ellucian Banner
  • NetIQ Identity Manager 4.0.1 or later
  • NetIQ Identity Manager 4.5 or later
  • NetIQ Identity Manager 4.6 or later
All Identity Manager engine supported platforms All Remote Loader supported platforms