Operating Systems Supported


Supported Operating Systems Required Additional Software
Database Server
  • Windows Server 2012 R2
  • Windows Server 2012

NOTE: If you install the databases remotely, the Aegis setup program does not validate the operating system on the remote computer.

  • One of the following:
    • Microsoft SQL Server 2016
    • Microsoft SQL Server 2014
    • Microsoft SQL Server 2012
  • Microsoft SQL Server Native Client for the installed version of Microsoft SQL Server
Aegis Server
  • Windows Server 2012 R2
  • Windows 2012
  • Microsoft Message Queuing 3.0, 4.0, 5.0, 6.0, or 6.3
  • Microsoft .NET Framework 2.0 (required for pre-3.2 activities)
  • Microsoft .NET Framework 4.0*Microsoft SQL Server Native Client for the version of Microsoft SQL Server installed on the Database Server computerWindows PowerShell 2.0**

* The Aegis Server components do not use Microsoft .NET Framework 3.x, but .NET Framework 3.x and 4.x can coexist on the Aegis Server computer.

** The Aegis Server components do not use Windows PowerShell 3.0, but PowerShell 2.0 and 3.0 can coexist on the Aegis Server computer.

Web Server
  • Windows Server 2012 R2
  • Windows Server 2012
  • Microsoft Internet Information Services 6, 7, 7.5, 8, or 8.5 *
  • One of the following versions of Microsoft ASP.NET:
    • If you are running IIS 6 or 7.x, ASP.NET 2.0, 3.0, or 3.5
    • If you are running IIS 8.x, ASP.NET 4.0 or 4.5
  • Microsoft .NET Framework 2.0 (for Reporting Center Web service only)
  • Microsoft .NET Framework 4.0 (required for all other components)
  • Microsoft .NET Framework 4.6 (required for all other components)
  • Windows PowerShell 2.0 (required only for a cluster environment)

*If you install IIS 7.x or 8.x, you must enable IIS 6 compatibility mode.

Operations Console

Windows Server

Any of the following browsers:

  • Microsoft Internet Explorer or Edge
  • Google Chrome
  • Mozilla Firefox
Configuration Console
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows 10
  • Windows 8 x64

NOTE: If you install the databases remotely, the Aegis setup program does not validate the operating system on the remote computer.

  • One of the following:
    • Microsoft SQL Server 2016
    • Microsoft SQL Server 2014
    • Microsoft SQL Server 2012
  • Microsoft SQL Server Native Client for the installed version of Microsoft SQL Server

NOTE

  • Non-U.S. language versions of Microsoft SQL Server are not supported.
  • If you install the databases remotely, the Aegis setup program does not validate the version of Microsoft SQL Server on the remote computer.