Error: 'Error: System.InvalidCastException' received when selecting the 'Log On To' button on the Us (NETIQKB46026)

  • 7746026
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 7.0 SP1

symptom
Error: 'Error: System.InvalidCastException' received when selecting the 'Log On To' button on the User Properties page

cause
The issue is due to the client not handling a single workstation value in an NT 4 domain.

fix

This issue is addressed in NetIQ Directory and Resource Administrator and Exchange Administrator version 7.0 SP1 Hotfix 46026.

Hotfix 46026 addresses an issue where you receive a System.InvalidCastException error when viewing workstation logon restrictions for user accounts in the Directory and Resource Administrator (DRA) Account and Resource Management Console. This error occurs when you view workstation logon restrictions for Windows NT 4.0 user accounts with workstation logon restrictions that only allow the user account to log on to one workstation. This issue also effects Windows 2000 and Windows 2003 user accounts that have been upgraded from Windows NT 4.0. Applying Hotfix 46026 ensures DRA correctly displays user account workstation logon restrictions.

Note: This Hotfix requires DRA version 7.0 SP1.

To download and install this hotfix:

  1. Close all DRA user interfaces.
  2. Run the DRA70001_Hotfix46026.msi file on each computer where you installed the DRA Account and Resource Management Console.

This hotfix modifies the NetIQ.DRA.Console.Accounts.dll file on each computer where you installed the Account and Resource Management Console. By default, this file is located in the Program Files/NetIQ/DRA folder.

For more information, contact NetIQ Technical Support at www.netiq.com/support.



Additional Information

Formerly known as NETIQKB46026