Cloning an account with an Exchange 5.5 mailbox generates the error: 'There is no connection agreeme (NETIQKB44418)

  • 7744418
  • 02-Feb-2007
  • 21-Jun-2007

Resolution

fact
Directory and Resource Administrator 7.0 SP1

fact
Directory and Resource Administrator 7.5

fact
Microsoft Exchange Server 5.5

symptom
Cloning an account with an Exchange 5.5 mailbox generates the error: 'There is no connection agreement'.

symptom
Using the close operation in a mixed Exchange 5.5 and Exchange 2000 or later environment with Active Directory Connector (ADC) enabled.

cause
We are checking the msExchHomeServerName property to see whether the user has an Exchange 2000 mailbox (this is in CExchProvider::GetMailFlags).  This property contains the DN (Exchange 5.5 format) of the home server.   We are assuming that if this value is populated, the user has an Exchange 2000 mailbox.  In this case, however, ADC is populating this field with the Exchange 5.5 mailbox.  This makes Directory and Resource Administrator (DRA) think that the user has both an Exchange 5.5 mailbox and an Exchange 2000 mailbox.  In the user clone code for this case, DRA will always try to clone the Exchange 2000 mailbox, not the Exchange 5.5 mailbox.

fix
This issue is addressed in NetIQ Directory and Resource Administrator and Exchange Administrator version 7.5 Hotfix 44418.

Hotfix 44418 corrects an issue with how DRA handles Exchange 5.5 mailboxes when cloning a user account.  DRA can provide invalid options during the clone operation in a mixed Exchange 5.5 and Exchange 2000 or later environment with Active Directory Connector enabled.  This hotfix corrects this issue and ensures DRA correctly handles Exchange 5.5 mailboxes during clone operations.

Note: This Hotfix requires DRA version 7.5.  If you experience this issue on DRA version 7.0 SP1, you will need to upgrade to DRA version 7.5 first before applying the hotfix.

To download and install this hotfix:

  1.  Run the DRA70001_Hotfix44418.msi file on each Administration server computer.
  2.  Perform an immediate full accounts cache refresh.  For more information on how to perform an immediate full accounts cache refresh, see the product Help.

This hotfix modifies the following files on the Administration server computer:

  • Accounts.dll
  • DraDomFile.exe
  • ExchProvider.dll

By default, these files are located in the Program Files\NetIQ\DRA folder.

For more information, please contact NetIQ Technical Support at www.netiq.com/support.



Additional Information

Formerly known as NETIQKB44418