Error: ' *++(8760) Warning - CopyMessages() return MAPI_W_PARTIAL_COMPLETION [HR=0x00040680]' (NETIQKB1818)

  • 7701818
  • 02-Feb-2007
  • 19-May-2009

Environment

Exchange Migrator 2.x
Exchange Migrator 1.x

Situation

Error: '001-03-28 14:50:15*++(8760) Warning - CopyMessages() return MAPI_W_PARTIAL_COMPLETION [HR=0x00040680]'

Error: '2001-03-28 14:50:15*++(8761) Warning - Dropping down to copying messages one at a time'

Error: '2001-03-28 14:50:16*++(8763) Warning - CopyMessages() return MAPI_W_PARTIAL_COMPLETION. Message skipped. [HR=0x00040680]'

Error: '2001-03-28 14:50:16*++(8764) Warning - CopyMessages() return MAPI_W_PARTIAL_COMPLETION. Message'
Only part of the mailbox has migrated.

This error contains text like "MAPI partial completion."

Resolution


NetIQ recommends you turn off virus scanning software during migration, review your mailbox size restrictions, and ensure you are using the correct version of the Exchange Migrator console if only part of the mailbox has migrated or if the previously noted EMApplog logs occurred.

To resolve this issue, complete the following tasks before starting the mailbox migration again.

  1. Turn off the virus scan software while you are performing the mailbox migration.
    Note: For more information about problems caused by having virus scan running while migrating or exporting files. For more information, see the Microsoft article q264731 that deals with MAPI-Based Tasks not working when virus API Anti-Virus software is running on the Exchange server computer.
  2. Turn off mailbox size limit restrictions.
  3. Verify that recipient policies are not impeding the mailbox migration.
  4. Ensure the Exchange Migrator console machine has the correct version and location of the Exchange DLLs as outlined in the following KB article: NETIQKB15740 
      1. Reboot the EM console computer after changing out the MAPI32.dll. This will ensure that the OS initializes and recognizes the new MAPI.

    For more information, contact Technical Support at www.netiq.com/support.

    Cause

    Currently there are three documented reasons for this issue:
    • Virus scanning software running at the same time as you are migrating a mailbox.
    • The mailbox size restrictions on the target Microsoft Exchange server prevent a complete mail transfer.
    • The same Exchange Migrator console and target production environment is being used, however, the source environment has changed from the lab environment to the production environment.

    Additional Information

    Formerly known as NETIQKB1818

    We have also found that even though Virus scanning is disabled and/or not installed on the source Exchange server, there are times when this error message may still appear most often on email messages that have attachments. We have found that utilizing an Exchange 5.5 registry key named OpenRetryDelay can prove useful and allow EM to successfully migrate the problem messages. Please refer to the following Microsoft article for more information:

    264731 - XADM: MAPI-Based Tasks Do Not Work with Virus API Anti-Virus Software Running on the Exchange Server Computer
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;264731