17.2 組み込みのレポート

組み込みのレポートで、オブジェクトの変更、オブジェクトのリスト、およびオブジェクトの詳細に関する各レポートを生成できます。これらのレポートは、DRA Reporting Servicesの一部ではないため、ビルトイン変更履歴レポートを有効にするために設定する必要はありません。これらのレポートのアクセス方法については、このセクションのトピックを参照してください。

メモ:DRAが変更ガーディアンに統合されている場合は、DRAの外部からのイベントに対する変更履歴レポートにアクセスすることもできます。これらのレポートの種類、および変更ガーディアンサーバの設定に関する詳細については、「統合された変更履歴」を参照してください。

17.2.1 オブジェクトの変更に関するレポート

Activity Detailレポートを生成することで、ドメイン内のオブジェクトに関する変更情報をリアルタイムで確認できます。たとえば、指定した期間中にオブジェクトに対して加えられた変更、またはオブジェクトが加えた変更がリスト表示されます。Activity Detailレポートはエクスポートや印刷することもできます。

オブジェクトの変更のレポートを生成するには:

  1. 所望の条件に一致するオブジェクトを検索します。

  2. オブジェクトを右クリックして、[レポーティング]>[次に対して行われた変更...objectName](または[Reporting]>[次によって行われた変更...objectName])の順に選択します。

  3. 変更を表示する期間の開始日と終了日を選択します。

  4. 表示する行数を変更したい場合は、デフォルトの値(250)を必要な値に書き換えます。

    メモ:表示される行数は、環境内の各管理サーバに適用されます。レポートに3つの管理サーバを含めてデフォルト値の250行を使用すると、そのレポートに表示できる行数は最大で750行になります。

  5. 特定のサーバだけをレポートに含めたい場合は、[Restrict query to these DRA servers (クエリをこれらのDRAサーバに制限★)]を選択し、レポートに含めるサーバの名前を(1つまたは複数)入力します。複数のサーバ名を指定する場合はカンマで区切ります。

  6. [OK]をクリックします。

17.2.2 オブジェクトリストのレポート

オブジェクトのリストからデータをエクスポートおよび印刷することができます。この機能により、管理対象オブジェクトの一般情報に関するレポートの生成や配布が素早く簡単にできます。

オブジェクトリストをエクスポートする場合は、ファイルの場所、名前、および形式を指定することができます。DRAでは、HTML、CSV、XMLの各形式がサポートされています。オブジェクトの一般情報をデータベースアプリケーションにエクスポートすることも、リスト出力の結果をWebページに投稿することもできます。

メモ:リスト内の複数の項目を選択して項目をメモ帳などのテキストアプリケーションにコピーすることもできます。

オブジェクトのリストを表示するには:

  1. 所望の条件に一致するオブジェクトを検索します。

  2. このオブジェクトのリストをエクスポートするには、[ファイル]メニューから[Export List (リストをエクスポート)]をクリックします。

  3. このオブジェクトのリストを印刷するには、[ファイル]メニューから[Print List (リストを印刷)]をクリックします。

  4. 適切な情報を指定して、このリストを保存または印刷します。

17.2.3 オブジェクトの詳細に関するレポート

グループメンバーシップなど、オブジェクト属性をリスト表示する詳細タブからデータをエクスポートおよび印刷することができます。この機能により、特定のオブジェクトに関し必要な詳細情報を素早く簡単に頻繁にレポート生成および配布することができます。

オブジェクトの詳細のタブをエクスポートする場合は、ファイルの場所、名前、および形式を指定することができます。DRAでは、HTML、CSV、XMLの各形式がサポートされています。オブジェクトの一般情報をデータベースアプリケーションにエクスポートすることも、リスト出力の結果をWebページに投稿することもできます。

オブジェクトの詳細のレポートを生成するには:

  1. 所望の条件に一致するオブジェクトを検索します。

  2. [表示]メニューの[詳細]をクリックします。

  3. 詳細ペインで適切なプロセスを選択します。

  4. これらのオブジェクト詳細情報をエクスポートするには、[ファイル]メニューの[Export Details List (詳細情報のリストをエクスポート)]をクリックします。

  5. これらのオブジェクト詳細情報を印刷するには、[ファイル]メニューの[Print Details List (詳細情報のリストを印刷)]をクリックします。

  6. 適切な情報を指定して、このリストを保存または印刷します。