17.2 Rapports intégrés

Les rapports intégrés vous permettent de générer des rapports sur les modifications, les listes et les détails des objets. Ces rapports ne font pas partie des services DRA Reporting, et aucune configuration n'est requise pour activer les rapports intégrés de l'historique des modifications. Reportez-vous aux rubriques de cette section pour savoir comment accéder à ces rapports.

REMARQUE :Il est également possible d'accéder aux rapports de l'historique des modifications pour les événements en dehors de DRA lorsque celui-ci est intégré à Change Guardian. Pour plus d'informations sur ces types de rapports et sur la configuration d'un serveur Change Guardian, reportez-vous à la section Historique des modifications unifiées.

17.2.1 Création de rapports sur les modifications des objets

Vous pouvez afficher les informations de modification en temps réel des objets de vos domaines en générant des rapports de détail des activités. Par exemple, vous pouvez afficher une liste des modifications apportées à un objet ou par un objet au cours d'une période spécifiée. Vous pouvez également exporter et imprimer les rapports de détail des activités.

Pour générer un rapport sur les modifications des objets :

  1. Recherchez les objets qui correspondent à vos critères.

  2. Cliquez avec le bouton droit sur un objet, puis sélectionnez Création de rapports > Modifications apportées à nom_objet ou Reporting > Modifications apportées par nom_objet.

  3. Sélectionnez les dates de début et de fin pour spécifier les modifications que vous souhaitez afficher.

  4. Si vous souhaitez modifier le nombre de lignes à afficher, entrez un nombre à la place de la valeur par défaut de 250.

    REMARQUE :le nombre de lignes affichées s'applique à chaque serveur d'administration de votre environnement. Si vous incluez 3 serveurs d'administration dans le rapport et que vous utilisez la valeur par défaut de 250 lignes à afficher, le rapport peut afficher jusqu'à 750 lignes.

  5. Si vous souhaitez que le rapport inclue uniquement certains serveurs d'administration, sélectionnez Restrict query to these DRA servers (Limiter la requête à ces serveurs DRA) et tapez le nom du serveur ou les noms que vous souhaitez voir figurer dans le rapport. Séparez le nom des différents serveurs par une virgule.

  6. Cliquez sur OK.

17.2.2 Création de rapports sur les listes des objets

Vous pouvez exporter ou imprimer les données des listes des objets. Cette fonctionnalité vous permet de créer rapidement et facilement des rapports sur les informations générales relatives à vos objets gérés et de distribuer ces informations.

Lorsque vous exportez une liste d'objets, vous pouvez spécifier l'emplacement du fichier, son nom et son format. DRA prend en charge les formats XML, CSV et HTML, de sorte que vous pouvez exporter ces informations dans des applications de base de données ou publier les résultats sur une page Web.

REMARQUE :vous pouvez également sélectionner plusieurs éléments dans une liste, puis copier ces éléments dans une application de texte, telle que le bloc-notes.

Pour générer un rapport sur les listes des objets :

  1. Recherchez les objets qui correspondent à vos critères.

  2. Pour exporter cette liste d'objets, cliquez sur Export List (Exporter la liste) dans le menu File (Fichier).

  3. Pour imprimer cette liste d'objets, cliquez sur Print List (Imprimer la liste) dans le menu File (Fichier).

  4. Spécifiez les informations appropriées pour enregistrer ou imprimer cette liste.

17.2.3 Création de rapports sur les détails des objets

Vous pouvez exporter ou imprimer les données des onglets Détails qui répertorient les attributs des objets tels que les adhésions aux groupes. Cette fonctionnalité vous permet de créer rapidement et facilement des rapports sur les informations nécessaires concernant des objets spécifiques et de les distribuer souvent.

Lorsque vous exportez les informations d'un onglet de détails d'objet, vous pouvez spécifier l'emplacement du fichier, son nom et son format. DRA prend en charge les formats XML, CSV et HTML, de sorte que vous pouvez exporter ces informations dans des applications de base de données ou publier les résultats sur une page Web.

Pour générer un rapport sur les détails d'un objet :

  1. Recherchez l'objet qui correspond à vos critères.

  2. Dans le menu View (Afficher), cliquez sur Details (Détails).

  3. Dans le volet Details (Détails), sélectionnez l'onglet approprié.

  4. Pour exporter ces détails d'objet, cliquez sur Export Details (Exporter les détails) dans le menu File (Fichier).

  5. Pour imprimer ces détails d'objet, cliquez sur Print Details List (Imprimer la liste des détails) dans le menu File (Fichier).

  6. Spécifiez les informations appropriées pour enregistrer ou imprimer cette liste.