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About This Book and the Library

The Appliance Guide provides information about the requirements, initial configuration, and
maintenance for the PlateSpin Transformation Manager Appliance.

Intended Audience

This document is intended for IT staff, such as data center administrators and operators, who use the
product to plan, execute, and monitor their large-scale data center transformation projects and
workload migration projects.

Information in the Library

The documentation library for this product is available in HTML and PDF formats on the PlateSpin
Transformation Manager Documentation website (https://www.netiq.com/documentation/platespin-
transformation-manager-1-1/).

Additional Resources
We encourage you to use the following additional resources online:

+ Micro Focus Workload Migration and Disaster Recovery channel on YouTube.com (https://
www.youtube.com/channel/UChuzpo3HbYpPI93icqeOzJQ): A channel that offers product
webcasts, demos, and training.

+ PlateSpin Transformation Manager Product Resources (https://www.netiq.com/products/
platespin-transformation-manager/resources/): A product website that offers white papers and
other technical information.

¢ User Community (https://www.netiq.com/communities/): A web-based community with a variety
of discussion topics.

¢ Support Knowledgebase (https://www.netig.com/support/kb/): A collection of in-depth technical
articles.

Customer Care

For specific product issues, contact Customer Care (http://www.netiq.com/support).

Documentation Support

Our goal is to provide documentation that meets your needs. If you have suggestions for
documentation improvements, click comment on this topic at the bottom of any page in the HTML
version of the documentation. You can also email Documentation-Feedback@netig.com. We value
your input and look forward to hearing from you.

About This Book and the Library
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Overview of the Appliance

The PlateSpin Transformation Manager Appliance hosts the PlateSpin Transformation Manager
Server software, PostgreSQL database software, and PTM database instance for your transformation
projects.

+ “Benefits of the Appliance” on page 7

+ “Appliance Requirements” on page 7

Benefits of the Appliance

Delivery of PlateSpin Transformation Manager as an appliance provides the following benefits:

+ Simple deployment. The appliance is ready to configure and run on your VMware hypervisor.
You do not need to install the operating system, set up prerequisite applications, or configure its
databases.

+ Better performance. The appliance is built on a specific and tuned version of the SUSE Linux
Enterprise Server (SLES) operating system. The appliance includes everything that PlateSpin
Transformation Manager needs, and only what it needs. It omits the unneeded applications and
services that can consume system resources.

+ Web-based appliance administration. The appliance provides a web-based Appliance
Management Console that allows you to easily configure only what is required to deploy or
manage the appliance in your environment. You do not need to understand the underlying
operating system, software, or databases.

If you contact Technical Support with a PlateSpin Transformation Manager support incident, you
might be asked to access the Appliance Terminal Console as the r oot user. Your support
representative will provide guidance on any required actions. Otherwise, there are no
administrative tasks that involve r oot access or the bash interface.

+ Easy update. You update the appliance by deploying the appliance boot disk for the updated
appliance version, and using the existing data disk.

Appliance Requirements

Ensure that your system meets the requirements in this section before you begin the installation of
the PlateSpin Transformation Manager Appliance.

+ “Appliance Host Server” on page 8
+ “Appliance Management Console” on page 9
+ “Transformation Manager Web Interface” on page 10

+ “PlateSpin Migrate Connector” on page 11

Overview of the Appliance 7



Appliance Host Server

You deploy the OVF file for the PlateSpin Transformation Manager Appliance on your virtualization
host server.

+ “Virtualization Host Server” on page 8

¢ “Virtual Machine” on page 8

+ “Virtual Storage” on page 8

Virtualization Host Server

PlateSpin transformation supports the following virtualization software:

+ VMware ESXi version 5.5 or higher. The ESXi host must have a VMware enterprise license.
+ VMware vSphere Client 5.x or higher. Use this tool to set up the hypervisor environment for
the appliance VM.

Micro Focus recommends setting up NTP (Network Time Protocol) for the Appliance and the host
server in accordance with the VMware Time Keeping Best Practices for Linux Guests (KB 1006427)
(https://kb.vmware.com/kb/1006427).

Virtual Machine

The OVF creates a virtual machine. This section describes the VM minimum requirements.
+ Memory: The host server must provide a minimum of 4 GB of memory for the virtual machine.
This memory configuration is the appliance default.

¢ Processor: The host server must provide a minimum of 2 vCPUs for the virtual machine. This
processor configuration is the appliance default.

+ |P Address Information: During the deployment, you must provide the following IP address
information for the appliance, including:

¢ Static IP address

+ Network mask

+ Gateway IP address

+ DNS hostname associated with the IP address
+ |P address of a DNS server

+ |P address or DNS name of the NTP server

Micro Focus recommends setting up NTP for the VM in accordance with the VMware Time
Keeping Best Practices for Linux Guests (KB 1006427) (https://kb.vmware.com/kb/
1006427).

Virtual Storage

You must provide a boot disk and a data disk when you deploy the appliance:

+ Disk 1 Boot: The boot partition for the appliance stores the system files, including the guest
operating system, all appliance-specific software, and the appliance system event logs that are
stored in the / var directory. The default size is 20 GB.

Overview of the Appliance
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+ Disk 2 /vastorage: The / vast or age partition stores the PlateSpin Transformation Manager
software and PostgreSQL database, the appliance configuration information, and the Ganglia
health metrics. You must create and add this virtual disk during the appliance installation. The
required size is 20 GB or larger.

Appliance Management Console

Most of your management interaction with the PlateSpin Transformation Manager Appliance takes
place through the browser-based PlateSpin Transformation Manager Appliance Management
Console.

+ “Supported Web Browsers” on page 9

+ “Supported Languages” on page 9

+ “Ports and Firewalls” on page 9

Supported Web Browsers

PlateSpin Transformation Manager supports the following web browsers for the Appliance
Management Console:

+ Google Chrome (latest version)

+ Microsoft Internet Explorer 11

+ Mozilla Firefox (latest version)

NOTE: JavaScript (Active Scripting) must be enabled in your web browser.

Supported Languages

The Appliance Management Console supports English (En) and Japanese (Ja) languages in your
web browser. Modify the Language setting in your web browser with your preferred language as the
first in the list. For translated Online Help, also set your Language preference on www.netig.com and
allow cookies.

Ports and Firewalls

PlateSpin Transformation Manager communications use the following ports. They are opened by
default for the appliance, as noted. Ensure that you open the following ports in all firewalls in your
network between the PlateSpin Transformation Manager Appliance and the computers you use to
access the appliance.

Table 1-1 Communications Ports for Appliance Management

Component Port Description

Appliance Management Console 9443 Use this port to securely manage the appliance.
(HTTPS, secure SSL)

Overview of the Appliance 9
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Component Port Description

Transformation Manager Database 5432 If you configure a remote PostgreSQL database
(PostgreSQL) for the appliance, this port is used by PTM to
access to your remote database. PostgreSQL
allows TCP traffic, incoming and outgoing.
Secure traffic by enabling SSL in the
post gresqgl . conf file on your remote
PostgreSQL server.

This port is closed by default if the PostgreSQL
is installed on the appliance.

SSH 22 You can use SSH to remotely access the
appliance to start, stop, or restart it without
using a VMware client.

SSH is disabled by default. See “Starting,
Stopping, or Restarting System Services” on
page 25.

Ganglia 8649 (secure, default) The Ganglia gnond daemon uses UDP port

8649 for communications.
9080 (non-secure)

The gret ad daemon uses TCP port 8649 for
metrics data.

You can enable port 9080 to allow anonymous
access to the Ganglia monitoring information.
See “View Ganglia Metrics Directly Using Port
9080 (Not Secure)” on page 31.

Transformation Manager Web Interface

PlateSpin Transformation Manager server software is automatically installed on the Appliance. User
interaction with the PlateSpin Transformation Manager Server takes place through the browser-based
PlateSpin Transformation Manager Web Interface.

+ “Supported Web Browsers” on page 10

+ “Supported Languages” on page 11

+ “Ports and Firewalls” on page 11

Supported Web Browsers

PlateSpin Transformation Manager supports the following web browsers for the PlateSpin Server
Web Interface:

+ Google Chrome (latest version)

+ Microsoft Internet Explorer 11

+ Mozilla Firefox (latest version)

NOTE: JavaScript (Active Scripting) must be enabled in your web browser.

Overview of the Appliance



Supported Languages

The Web Interface supports English (En) and Japanese (Ja) languages in your web browser. Modify
the Language setting in your web browser with your preferred language as the first in the list.

Ports and Firewalls

PlateSpin Transformation Manager communications use the following ports for the PlateSpin
Transformation Manager Server. They are opened by default for the Appliance, as noted. Ensure that
you open the following ports in all firewalls in your network between the PlateSpin Transformation
Manager Appliance and the computers you use to access the PlateSpin Transformation Manager
Server.

Table 1-2 Communications Ports for the Transformation Manager Web Interface

Component Port Description

Web Interface 8183 Port 8183 is enabled by default. It allows TCP
(HTTPS, secure SSL)  traffic, incoming and outgoing.

8182 NOTE: Micro Focus recommends that you use
the secure port and SSL options for accessing

HTTP, non-secure
( ' ) the Web Interface.

For security reasons, port 8182 is disabled by
default. If you enable it, allow TCP traffic,
incoming and outgoing.

Table 1-3 shows the protocol and port required for messaging for discovery and automated migration.
These messages reflect events and state changes and do not contain sensitive information.

Table 1-3 Event Messaging Requirements for Network Protocols and Ports

Traffic Network Protocol and Port Other Requirements

Event Messaging 61613 TCP, incoming This port is open by default on the

Transformation Manager Appliance.
(not secure)

For automated migration, open this
port on the PlateSpin Migrate
servers assigned to the project.

PlateSpin Migrate Connector

An instance of the PlateSpin Migrate Connector is automatically installed and configured to work with
the PlateSpin Transformation Manager server on the Appliance. User interaction with the PlateSpin
Migrate Connector takes place through a configuration file on the Appliance and global settings in the
PlateSpin Transformation Manager Web Interface. See “Configuring PlateSpin Migrate Connector” in
the PlateSpin Migrate Connector Quick Start.

Overview of the Appliance 11
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Installing and Configuring the Appliance

PlateSpin Transformation Manager is distributed as an appliance that you deploy on your VMware
virtualization host. The appliance includes the PlateSpin Transformation Manager Server software
and the PostgreSQL database.

+ “Downloading the Appliance” on page 13

+ “Deploying the Appliance and Configuring the Virtual Environment” on page 13

+ “Configuring the Appliance” on page 15

+ “Configuring the PlateSpin Transformation Manager Server for the First Time” on page 16

+ “Post-Installation Tasks” on page 18

Downloading the Appliance

1 Download the PlateSpin Transformation Manager Appliance file from the NetlQ Downloads
(https://dl.netig.com) site:

Pl at espi nTM x86_64- 1. 1. 0. xxx. ovf. zi p, where xxx represents the build number.

2 Extractthe Pl at espi nTM x86_64- 1. 1. 0. xxx. ovf. zi p file on your management workstation so
that the Pl at eSpi nTM ver si on file folder appears.

Extract the file using a third-party extractor; do not use the default Windows extractor.

3 Configure the virtualization host server where you will run the appliance. Continue with
“Deploying the Appliance and Configuring the Virtual Environment” on page 13.

Deploying the Appliance and Configuring the Virtual
Environment

Use the instructions in this section to prepare your VMware host server for the appliance. Before you
begin, ensure that you understand the “Appliance Requirements” on page 7.
1 On the VMware host server, deploy the appliance:
la Inthe vSphere client, click File > Deploy OVF Template.

If the virtualization software you are using does not support . ovf , you must convert the
. ovf file to . vnx using the VMware OVF Tool available on the VMware Website.

1b Browse to and select the . ovf file in the Pl at eSpi nTM ver si on file folder, then click Next.
1c Review the settings, then click Next.
1d In the Name field, rename the appliance to a name of your choosing, then click Next.

le Select the datastore (Hard Disk 1, the Boot partition) where you want to store the virtual
machine files, then click Next.

1f Review the default disk format setting, then click Next to accept it.
1g Click Finish.
2 In the vSphere client, create a separate VMware hard disk (Hard Disk 2) for the appliance.

Installing and Configuring the Appliance 13
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This hard disk stores your PlateSpin Transformation Manager files. It also stores configuration
files that are used for appliance upgrade.

2a In the vSphere client, select the virtualization host where you set up the virtual machine,
then click the Virtual Machines tab.

2b Right-click the virtual machine that you just created and for which you want to create
secondary storage, then click Edit Settings.

2c On the Virtual Machine Properties page, select the Hardware tab, then click Add.

2d In the Add Hardware wizard, configure the hard disk.

Page Action

Device Type 1. Select Hard Disk, then click Next.

Select a Disk 1. Select Create a new virtual disk, then click Next.

Create a Disk 1. Inthe Capacity section, specify the amount of hard disk space that

you want to allocate.

See Disk 2 /vastorage for information about minimum disk capacity
requirements.

2. Inthe Disk Provisioning section, select either of the following disk
formats, depending on the VMware version that you are running:

¢ Thick Provision Eager Zeroed
¢ Support clustering features such as Fault Tolerance

3. Inthe Location section, select Specify a datastore or datastore
cluster, click Browse, select a datastore, then click OK.

4. Click Next.

Advanced Options 1. Inthe Virtual Device Node section, select SCSI (1:0) from the drop-
down list.

NOTE: Do not change the controller to VMware Paravirtual at this
point of the installation process. You can optionally modify this setting
as a post-installation task. See “Change the SCSI Controller to
VMware Paravirtual SCSI for Hard Disk 2" on page 18.

2. In the Mode section, select Independent and Persistent.
These settings allow the appliance to be updated.
3. Click Next.

Summary 1. Review the specifications you set for the new hard disk, then click
Finish.

3 Increase the amount of memory that VMware allocates for the appliance.

3a In the Virtual Machine Properties window, select Memory, then increase the setting to a
suitable size for your environment.

3b Click OK to exit the Virtual Machine Properties window.

4 (Optional) Upgrade the virtual machine hardware version to the latest that your infrastructure can
support. To do so, in the vSphere client, right-click the virtual machine that you just created, and
for which you want to upgrade the hardware, then click Upgrade Virtual Hardware.

5 Power on the appliance (virtual machine).
6 (Optional) Install VMware Tools on the host server.

7 Continue with “Configuring the Appliance” on page 15.
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Configuring the Appliance

After you have downloaded the appliance and successfully deployed the virtual machine in the virtual
environment, you are ready to configure the appliance.

1 In the vSphere client, power on the appliance.

2 Click the Console tab.

3 After the appliance starts, select your preferred keyboard layout in the Keyboard Language
drop-down, then accept the license agreement.

4 On the Passwords and Time Zone page, specify the following appliance information:

Option

Action

Root password

Type the r oot user password that you want to set for the appliance, then type it
again to confirm it.

Vaadmin password

Type the vaadm n user password that you want to set for the appliance, then
type it again to confirm it.

The vaadmi n user is the preferred identity to use when you log in to the
appliance. The vaadm n user name is case sensitive and should use all
lowercase letters.

NTP Server Type the IP address or DNS name of a reliable external Network Time Protocol
(NTP) server. For example, ti ne. exanpl e. com
For the best results, set up NTP in accordance with the VMware Timekeeping
Best Practices for Linux Guests (http://kb.vmware.com/selfservice/microsites/
search.do?language=en_US&cmd=displayKC&externalld=1006427).

Region Specify your local region.

Time Zone Specify your local time zone.

5 Click Next.

6 On the Network Configuration page, specify the following network information:

Option Action

Hostname Type the fully qualified DNS host name associated with the appliance IP
address. For example, pt m exanpl e. com

IP address Type the static IP address for the appliance. For example, 10. 10. 10. 10.

Network mask

Type the network mask associated with the appliance IP address. For example,
255. 255. 255. 0.

Gateway

Type the IP address of the gateway on the subnet where your appliance is
located. For example, 10. 10. 10. 254.

DNS servers

Type the IP address of a primary DNS server for your network. For example,
10. 10. 10. 1. A secondary DNS server is optional.

Domain search

Type the domain that is associated with the Hostname setting.

7 Click Next.

8 Select the Hard Drive for Hard Disk 2.

Installing and Configuring the Appliance
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The Hard Disk 2 that you created for / vast or age is automatically detected and sdb is displayed
as the hard drive. Accept the defaults for the other options on this page, then click Next.

9 Click Configure.

The appliance displays a message indicating that the installation was successful. Do not log in at
the terminal prompt. Appliance administration requires the Appliance Management Console to
configure the appliance settings. Using native Linux tools can result in service disruption or
failure.

10 Continue with “Configuring the PlateSpin Transformation Manager Server for the First Time” on
page 16.

Configuring the PlateSpin Transformation Manager
Server for the First Time

After you install the PlateSpin Transformation Manager Appliance and configure its network settings,
you are ready to configure the PlateSpin Transformation Manager Server for the first time. This
configuration process uses a quick wizard that gets your system up and running. You can then make
further configuration decisions, as described in “Post-Installation Tasks” on page 18.

To configure the PlateSpin Transformation Manager Server:
1 After you have installed the appliance, as described in “Configuring the Appliance” on page 15,
navigate to the following URL from a web browser:

https://ip_address_or_DNS nane: 9443

Use the IP address or DNS name of the server that you specified during the appliance
installation.

2 Log in to the appliance using the vaadni n user and the password that you set.

The appliance takes you directly to the PlateSpin Transformation Manager Server Initial Server
Configuration page if it has not been configured yet or if it detects that an update is needed. In
these cases, skip Step 3.

3 Click the Server Configuration icon.
4 On the Initial Server Configuration page, complete the following information, then click Submit.

4a PostgreSQL Database Connection
Use one of the following options:

+ Local database: PlateSpin Transformation Manager automatically pre-installs the
PostgreSQL database on the appliance. Select Auto Setup Local Database to
automatically create a database instance, database administrator user, and a
password for the user. Table 2-1 shows the default settings.

16 Installing and Configuring the Appliance



Table 2-1 PostgreSQL Database Default Values

Parameter Default Value
Database Host localhost
Database Port 5432

Create a New Database Selected
Database Name transmgr
Database User Name tmadmin

+ Remote database: You can alternatively set up the PlateSpin Transformation
Manager database as a database instance on an existing PostgreSQL database in
your network.

1.
2.

Deselect Auto Setup Local Database.

Replace | ocal host with the DNS name or IP address of the host server for the
remote PostgreSQL database, and specify the PostgreSQL port.

. Specify the credentials of the database administrator user who has the schema

rights necessary to create a new instance for the PlateSpin Transformation
Manager database.

. Specify a name for the PlateSpin Transformation Manager database instance

(default: t ransngr).

Specify the username and password for the database user who will be created as

the administrator user (default: t madmni n) for the PlateSpin Transformation
Manager database instance.

4b Initial User Configuration

4c

The initial user for the PlateSpin Transformation Manager Server is the System
Administrator user who has all rights for configuration and management throughout the Web

Interface.

Provide the full name, a valid email address that is unique to your PlateSpin Transformation
Manager environment, and a password for this user.

You cannot delete this user from the Appliance Management Console. You can add another

System Administrator user for the PlateSpin Transformation Manager Server if it becomes

necessary to replace or augment the initial user account. See Administrative Users.

NOTE: You add and manage other users on the Users page in the PlateSpin
Transformation Manager Web Interface. See “Managing Users” in the PlateSpin
Transformation Manager User Guide.

Web Server Configuration

Micro Focus recommends that you use the secure port 8183 and SSL options for accessing
the Web Interface. You can enable or disable the HTTP port 8182 to allow non-secure

traffic.

Specify the DNS name for the PlateSpin Transformation Manager Server. It is populated
automatically with the DNS address used as the subject of the SSL certificate on the
appliance.

Installing and Configuring the Appliance
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5 On successful configuration, select one of the following options to continue with “Post-
Installation Tasks” on page 18:

+ Appliance Home: View or set the configuration settings for the appliance. See “View or
Modify Appliance Settings” on page 19.

+ Add Certificate: Add your signed SSL certificate for the appliance. See “Add a Self-
Signed Digital Certificate to the Appliance” on page 18.

+ Launch PlateSpin Transformation Manager Web Console: Open the Web Interface to
configure the PTM software or to set up your transformation projects. See the following:

+ “Configure the Web Interface” on page 19

+ “Configure Transformation Projects” on page 19

Post-Installation Tasks

After you set up the appliance, perform the following post-installation tasks:

+ “Add a Self-Signed Digital Certificate to the Appliance” on page 18

+ “Change the SCSI Controller to VMware Paravirtual SCSI for Hard Disk 2” on page 18
+ “View or Modify Appliance Settings” on page 19

+ “Configure the Web Interface” on page 19

+ “Configure Transformation Projects” on page 19

Add a Self-Signed Digital Certificate to the Appliance

The appliance ships with a self-signed digital certificate. The certificate works for both the appliance
(port 9443) and the PlateSpin Transformation Manager software (ports 8182 and 8183).

NOTE: This configuration task is optional. For higher security, Micro Focus recommends that you use
a trusted server certificate that is signed by a trusted certificate authority (CA) such as VeriSign or
Equifax.

You can use your own existing signed certificate, or you can use the Digital Certificate tool on the
appliance to create a certificate, have it signed by a trusted certificate authority, and then add it to the
appliance. See “Digital Certificates” on page 26.

Change the SCSI Controller to VMware Paravirtual SCSI for
Hard Disk 2

For Hard Disk 2, you can optionally change the SCSI controller to VMware Paravirtual (PVSCSI) for
Hard Disk 2.

NOTE: This configuration task is optional.

1 After the installation is complete, power on the appliance.

2 Ensure that the system is running. Log in as the appliance vaadmin user and verify the health of
the appliance and services.

3 Shut down the appliance.

Installing and Configuring the Appliance



4 In VMware, change the SCSI controller for Hard Disk 2 to VMware Paravirtual.
5 Power on the appliance.

View or Modify Appliance Settings

After you configure the appliance for the first time, you can view or modify the settings by using the
Appliance System Configuration page. See Chapter 3, “Managing the Appliance,” on page 21.

Configure the Web Interface

Use the PlateSpin Transformation Manager Web Interface to configure and manage the software.
See the following in the PlateSpin Transformation Manager User Guide:

+ “Accessing the Web Interface”
+ “Managing Licenses”
+ “Configuring Operating Systems”

Configure Transformation Projects

Use the PlateSpin Transformation Manager Web Interface to plan, manage, and execute your
transformation projects. See the following in the PlateSpin Transformation Manager User Guide:

¢ “Users”
+ “Planning”
+ “Workloads”

+ “Resources”

Installing and Configuring the Appliance
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Managing the Appliance

The PlateSpin Transformation Manager Appliance is the virtual machine that hosts the PlateSpin
Transformation Manager Server and its database. You can use the Appliance Management Console
to change certain configuration settings for the appliance, such as administrative passwords for the
vaadmin user and r oot user, network settings, and certificate settings. You should perform these
tasks only from the Console, because native Linux tools are not aware of the configuration
requirements and dependencies of the PlateSpin Transformation Manager services.

To access the Appliance Management Console:
1 In a web browser, specify the DNS name or the IP address for the appliance with the port

number 9443.
https://<ptm-ipaddr-or-dns-name>:9443
For example:
https://10. 10. 10. 1: 9443
or
https://ptm exanpl e. com 9443

2 Specify the administrative username and password for the appliance, then click Sign in. The
default users are vaadni n or r oot .

3 (Conditional) The Appliance Management Console automatically displays one the following
PlateSpin Transformation Manager options if it detects the stated condition:

+ Initial Configuration: The Initial Configuration tool opens if the PlateSpin Transformation
Manager Server has not been configured. You must complete the initial setup before you
can manage the appliance or the PlateSpin Transformation Manager Server.

+ Upgrade: The Upgrade tool opens if the RPM files for PlateSpin Transformation Manager
or the guest operating system have been upgraded. You must complete the upgrade before
you can manage the appliance or the PlateSpin Transformation Manager Server.

4 Continue using the Appliance Configuration tools.
The Appliance System Configuration page displays the following options:

+ Administrative Passwords
+ Network
+ Time

+ System Services

*

Digital Certificates

*

Firewall

*

Ganglia Configuration and Monitoring

+ Storage

*

/var Mount Configuration
* Support

Field Patch

Online Update

*

*
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+ Reboot or Shutdown
+ Logout
+ Configuring Proxy Client Settings

Administrative Passwords

Use the Administrative Passwords tool to modify the passwords and SSH access permissions for the
appliance administrators: the vaadni n user and the r oot user. You might need to modify passwords
periodically in keeping with your password policy, or if you reassign responsibility for the appliance
administration to another person.

The vaadmi n user can use the Administrative Passwords page to perform the following task:

+ Modify the vaadni n user password. To change a password, you must be able to provide the old
password.

+ The vaadmin user automatically has permissions necessary to remotely access the appliance
with SSH instead of using a VMware client. The SSH service must be enabled and running to
allow SSH access.

NOTE: The SSH service is disabled and is not running by default. For information about how to
start SSH on the appliance, see “System Services” on page 24.

The r oot user can use the Administrative Passwords page to perform the following tasks:

+ Modify the r oot user password. To change a password, you must be able to provide the old
password.

+ Enable or disable (default) r oot user SSH access to the appliance.

When this option is selected, the root user is able to SSH to the appliance. If this option is
deselected, only the vaadmni n user can SSH to the appliance, and the root user cannot SSH
even if the sshd service is running.

To manage the administrative access as the vaadmi n user:
1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Administrative Passwords &=,

3 Specify a new password for the vaadm n administrator. You must also specify the current
vaadm n password.

4 Click OK.
To manage the administrative access as the r oot user:

1 Log in to the Appliance Management Console as the r oot user.

2 Click Administrative Passwords &=,
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3 Specify a new password for the r oot administrator. You must also specify the current r oot
password.

4 (Optional) Select or deselect Allow root access to SSH. It is deselected by default.
5 Click OK.

Network

Use the Network tool to configure settings for the DNS servers, search domains, gateway, and NICs
for the appliance. You might need to modify these settings after the initial setup if you move the
appliance VM to a new host server, or move the host server to a new domain in your network
environment. You can also optionally restrict the networks that are allowed to access the appliance.

To configure network settings for the appliance:

1 Log in to the Appliance Management Console as the vaadni n user.

a9
2 Click Network "LF.

3 Inthe DNS Configuration section, you can modify the DNS name servers, search domains, and
gateway settings for your appliance network.

If the Search Domains field is left blank, it is auto-populated with the domain of the appliance
hostname. For example, if the hostname of the appliance is pt m nyconpany. com the domain is
auto-populated with nyconpany. com

4 Inthe NIC Configuration section, you can modify the IP address, hostname, and network mask
of any NIC associated with the appliance.

4a Click the ID of the NIC.

4b Edit the IP address, hostname, or network mask for the selected NIC.
4c Click OK.

4d Repeat these steps for each NIC that you want to configure.

5 (Optional) In the Appliance Administration Ul (port 9443) Access Restrictions section, do one
of the following:

+ Specify the IP address of each network for which you want to allow access to the appliance.
Only the listed networks are allowed.

+ Leave this section blank to allow any network to access the appliance.

NOTE: After you configure the appliance, changes to your appliance network environment can
impact the appliance communications.

6 Click OK.
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Time

Use the Time tool to configure the Network Time Protocol (NTP) server, the geographic region, and
the time zone where you have deployed the appliance.

To configure time parameters for the appliance:

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Time (),

3 Change the following time configuration options as appropriate:
NTP Server: Specify the NTP server that you want to use for time synchronization.
Region: Select the geographic region where your appliance is located.
Time Zone: Select the time zone where your appliance is located.

4 Click OK.

System Services

Use the System Services tool to view the status of services running on the appliance, or performs on
them. System services include the following:

¢+ SSH

* Jetty

+ PostgreSQL

PlateSpin Transformation Manager

*

*

PlateSpin Migrate Connector for PTM

To access the System Services page:

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click System Services {i}'
You can perform the following actions:

+ “Starting, Stopping, or Restarting System Services” on page 25

+ “Making System Services Automatic or Manual” on page 25
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+ “Downloading Log Files for System Services” on page 25

+ “Enabling or Disabling the SSH Service” on page 26

Starting, Stopping, or Restarting System Services

You might want to start, stop, or restart the SSH, Jetty, PostgreSQL, or PlateSpin Transformation
Manager services.

For example, if you create a custom theme for the PTM Web Interface, you will enable and disable
SSH and restart PlateSpin Transformation Manager as part of the setup process.

To start, stop, or restart a service on the appliance:

1 Click System Services {:}
2 Select the service that you want to start, stop, or restart.
3 Click Action, then select Start, Stop, or Restart.

4 Click Close to exit System Services.

Making System Services Automatic or Manual

1 Click System Services {:}

2 Select the service that you want to make automatic or manual.

3 Click Options, then select either Set as Automatic or Set as Manual.
4 Click Close to exit System Services.

Downloading Log Files for System Services

If you experience an issue with the Web Interface, you might need to download the log files to send
them to Technical Support.

1 Click System Services {:}'

2 Inthe Log Files column, click the download link for the appropriate service to download the log
files to your management workstation:

SSH: The SSH service that is running on the appliance has no relevant log files for download.
Jetty: Downloads the jetty. stderrout. | og file.

PostgreSQL: The database for the PlateSpin Transformation Manager product has no relevant
log files for download.

PlateSpin Transformation Manager: Collects, zips, and downloads the following log files:
¢ tmserver.log
+ pl at espi n-transfor mgr. out
* platespin_transformgr_config.log

PlateSpin Migrate Connector for PTM: Collects, zips, and downloads the following log files:
¢ migrate_connector.log
+ pl at espi n-mi grat e- connect or. out

3 Click Close to exit System Services.
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Enabling or Disabling the SSH Service

To enable the SSH service on the Appliance VM:

Log in to the Appliance Management Console as the vaadni n user, then click System Services.
Select the SSH service.

Select Action > Start.

Click Options, then select either Set as Automatic or Set as Manual.

Click Close to exit System Services.

Log out of the Appliance Management Console, then close your web browser.

~N o o~ WDN P

From your computer, start an SSH session and log in as the vaadni n user or r oot user to the
user appliance.

To disable the SSH service on the Appliance VM:

Exit any open SSH sessions.

Log in to the Appliance Management Console as the vaadni n user, then click System Services.
Select the SSH service.

Select Action > Stop.

Click Close to exit System Services.

o 01 A W N P

Log out of the Appliance Management Console, then close your web browser.

Digital Certificates

Use the Digital Certificates tool to add and activate certificates for the appliance. You can use the
digital certificate tool to create your own certificate and then have it signed by a CA, or you can use an
existing certificate and key pair if you have one that you want to use.

R

NOTE: The appliance ships with a self-signed digital certificate. Instead of using this self-signed
certificate, Micro Focus recommends that you use a trusted server certificate that is signed by a
trusted certificate authority (CA) such as VeriSign or Equifax.

The certificate works for both the appliance (port 9443) and the PlateSpin Transformation Manager
Web Interface (ports 8182 and 8183). You do not need to update your certificate when you update the
software.

Complete the following sections to change the digital certificate for your appliance:

+ “Using the Digital Certificate Tool” on page 27
+ “Using an Existing Certificate and Key Pair” on page 28
+ “Activating the Certificate” on page 28
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Using the Digital Certificate Tool

+ “Creating a New Self-Signed Certificate” on page 27

+ “Getting Your Certificate Officially Signed” on page 27

Creating a New Self-Signed Certificate

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Digital Certificates |# |

3 In the Key Store drop-down list, ensure that Web Application Certificates is selected.

4 Click File > New Certificate (Key Pair), then specify the following information:

4a General

4b

4c

Alias: Specify a name that you want to use to identify and manage this certificate.
Validity (days): Specify how long you want the certificate to remain valid.

Algorithm Details

Key Algorithm: Select either RSA or DSA.

Key Size: Select the desired key size.

Signature Algorithm: Select the desired signature algorithm.

Owner Information

Common Name (CN): This must match the server name in the URL in order for browsers
to accept the certificate for SSL communication.

Organizational Unit (OU): (Optional) Small organization name, such as a department or
division. For example, Purchasing.

Organization (O): (Optional) Large organization name. For example, Micro Focus.
City or Locality (L): (Optional) City name. For example, Provo.

State or Province (ST): (Optional) State or province name. For example, Utah.
Two-letter Country Code (C): (Optional) Two-letter country code. For example, US.

5 Click OK to create the certificate.

After the certificate is created, it is self-signed.

6 Make the certificate official, as described in “Getting Your Certificate Officially Signed” on
page 27.

Getting Your Certificate Officially Signed

1 On the Digital Certificates page, select the certificate that you just created, then click File >
Certificate Requests > Generate CSR.

2 Complete the process of emailing your digital certificate to a certificate authority (CA), such as
Verisign.

The CA takes your Certificate Signing Request (CSR) and generates an official certificate based
on the information in the CSR. The CA then mails the new certificate and certificate chain back
to you.
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3 After you have received the official certificate and certificate chain from the CA:

3a Revisit the Digital Certificates page.

3b Click File > Import > Trusted Certificate. Browse to the trusted certificate chain that you
received from the CA, then click OK.

3c Select the self-signed certificate, then click File > Certification Request > Import CA Reply.
3d Browse to and upload the official certificate to be used to update the certificate information.

On the Digital Certificates page, the name in the Issuer column for your certificate changes
to the name of the CA that stamped your certificate.

4 Activate the certificate, as described in “Activating the Certificate” on page 28.

Using an Existing Certificate and Key Pair

When you use an existing certificate and key pair, use a . P12 key pair format.

1

Log in to the Appliance Management Console as the vaadni n user.

Click Digital Certificates LN

3 In the Key Store drop-down menu, select JVM Certificates.

Click File > Import > Trusted Certificate. Browse to and select your existing certificate, then click
OK.

Click File > Import > Trusted Certificate. Browse to and select your existing certificate chain for
the certificate that you selected in Step 4, then click OK.

Click File > Import > Key Pair. Browse to and select your . P12 key pair file, specify your
password if needed, then click OK.

Continue with “Activating the Certificate” on page 28.

Activating the Certificate

1

On the Digital Certificates page, in the Key Store drop-down menu, select Web Application
Certificates.

Select the certificate that you want to make active, click Set as Active, then click Yes.

Verify that the certificate and the certificate chain were created correctly by selecting the
certificate and clicking View Info.

When you successfully activate the certificate, click Close to exit Digital Certificates.

Firewall

Use the Firewall tool to view your current firewall configuration directly from the appliance. By default,
all ports are blocked except those needed by the appliance. For example, the Login page for the
Appliance Management Console uses port 9443, so this port is open by default.
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NOTE: To have a seamless experience with the appliance, ensure that you do not block the ports
with your firewall settings. See “Ports and Firewalls” on page 9.

To view firewall settings for the appliance:

1 Log in to the Appliance Management Console as the vaadmi n user.

2 Click Firewall &/,
The Firewall page lists port numbers with the current status of each port number. The page is for
informational purposes and is not editable.

3 Click Close to exit the Firewall page

Ganglia Configuration and Monitoring

Ganglia is a scalable, distributed monitoring system that allows you to gather important information
about your appliance. The default metrics that you can monitor are CPU, disk, load, memory,
network, and process.

+ “Configure Ganglia” on page 29

+ “View Ganglia Metrics Using the Appliance Management Console Port 9443 (Secure)” on
page 30

+ “View Ganglia Metrics Directly Using Port 9080 (Not Secure)” on page 31

Configure Ganglia

Use the Ganglia Configuration tool to configure monitoring for the appliance. The Ganglia gnond
daemon uses UDP port 8649 for communications. The gnet ad daemon uses TCP port 8649 for
metrics data. You can also enable or disable non-secure HTTP viewing of the metrics on port 9080.

*nl

=

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Ganglia Configuration Ij]
3 As appropriate, change the following Ganglia configuration options:

Monitoring Services

+ Enable Full Monitoring Services: Select this option to receive and store metrics from
other appliances, and to allow the Ganglia Web Interface to run on the appliance. This
option is enabled by default.

You might want to disable Ganglia monitoring by deselecting this option:
+ If you already have a monitoring system that you plan to use for the appliance.

Managing the Appliance 29



+ If you plan to configure a dedicated appliance for viewing monitoring information.

You specify a dedicated appliance by selecting Unicast under Monitoring Options, and
then specifying the DNS name or IP address of the appliance that collects the
monitoring information.

Monitoring Options

+ Enable monitoring on this appliance: Select this option to enable Ganglia monitoring on
this appliance.

+ Multicast: Select this option to send monitoring information to other appliances on the
network. This option is selected by default.

+ Unicast: (Recommended) Select this option to send monitoring information to a single
destination.

NOTE: Unicast mode is recommended for improving performance of the system.

Publish to: Specify the URL where Ganglia sends monitoring information when it is
running in Unicast mode.

Monitoring Tool Options

+ Enable direct http port 9080 access: Select this option to enable the Ganglia Monitoring
dashboard to be available directly at the following URL using the non-secure http protocol
and port 9080:

http://ptm_dns_server_name:9080/gweb/

4 (Optional) Click Reset Database to remove all existing Ganglia metrics from the Ganglia
database on this appliance.

This option is not related to the PlateSpin Transformation Manager database.
5 Click OK.
6 Click Close to exit Ganglia Configuration.

View Ganglia Metrics Using the Appliance Management
Console Port 9443 (Secure)

Use the Ganglia Monitoring tool to securely view the Ganglia Dashboard in the Appliance
Management Console using port 9443. The dashboard displays the health and status metrics for the
appliance.

N

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Ganglia Monitoring Ij

The Ganglia Dashboard opens in a new tab to the following web page:
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https://ptm_dns_server_name:9443/gweb/
3 When you are done viewing information, close the Ganglia tab in your web browser.

View Ganglia Metrics Directly Using Port 9080 (Not Secure)

1 Ensure that you have enabled Monitoring Tool Options > Enable direct http port 9080 access.
2 In a web browser, go to the following URL.:

http://ptm_dns_server_name:9080/gweb/

No login is required.
3 When you are done viewing information, close your web browser.

Storage

Use the Storage tool to expand the storage space for the Boot partition (Hard Disk 1) and the /
vast or age (virtual appliance storage) partition (Hard Disk 2) that you created in “Deploying the
Appliance and Configuring the Virtual Environment” on page 13. You can also expand the / var
partition if you created a separate disk for the log files.

=

="

To expand the size of an appliance disk partitions:

1 Log in to the Appliance Management Console as the vaadmi n user.

2 Click Storage ‘—“

3 Use the tools provided by your virtualization platform vendor to expand the virtual disks that
contain the partitions you are expanding.

4 In the virtual disks table, select the partitions to be expanded.

5 Click Expand partitions.

This action stops the appliance services, expands the selected partitions to the size of their
respective disks, and restarts appliance services.

6 Restart the appliance so the operating system can detect the disks that have been expanded.
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/[var Mount Configuration

Use the / var Mount Configuration tool to configure the location of the / var directory if you move it to
a separate hard disk on the appliance or to a remote NFS directory. By default, the appliance logs its
system events in the / var directory on the Boot partition (Hard Disk 1). Because the / var directory
can fill up with log files and cause the Boot partition to grow, you can locate the / var directory on a
separate dedicated hard disk on the appliance, or on a dedicated remote NFS directory.

To move the /var directory to a dedicated disk or to a remote NFS directory:

1 Use the VMware vSphere client to create a virtual disk and assign it to the appliance's virtual
machine.

2 Log in to the Appliance Management Console as the vaadmni n user.

3 Click /var Mount Configuration .E|.
4 Specify the hard disk information for the / var directory:
+ Select disk: Select the hard disk where you want to place the / var directory.

+ File system type: Specify the type of file system.
5 Click OK.

Support

Use the Support tool to send configuration information to Technical Support (https://www.netiq.com/
support/) by uploading files directly with FTP, or by downloading the files to your management
workstation and sending them by an alternative method.

To send configuration files to Technical Support:

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Support o,
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3 Use one of the following methods to send the appliance’s configuration files to Technical Support
(https://www.netig.com/support/):

+ Select Automatically send the configuration to Micro Focus using FTP to initiate the FTP
transfer of configuration information.

+ Select Download and save the configuration file locally, then send it to Micro Focus
manually to download configuration information to your management workstation. You can
then send the information to Technical Support (https://www.netig.com/support/) using a
method of your choice.

4 Click OK to complete the process.

Field Patch

Use the Field Patch option to manage patches for Transformation Manager Server software, patches
for the PlateSpin Migrate Connector software for the installed instance, and security patches for the
software and operating system. You can install new patches, view currently installed patches, and
uninstall patches. You can download patches from the Patch Finder website (https://dl.netig.com/
patch/finder/).

To manage patches:

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Field Patch [,
3 (Conditional) Install a downloaded patch:

3a Download the PlateSpin Transformation Manager patch file from the Patch Finder website
(https://dl.netig.com/patch/finder/) to your management computer.

3b On the Field Patch page in the Install a Downloaded Patch section, click Browse.
3c Browse to and select the patch that you downloaded in Step 3a.
3d Click Install.
4 (Conditional) Uninstall a patch:
You might not be able to uninstall some patches.
4a In the Patch Name column of the Field Patch list, select the patch that you want to uninstall.
4b Click Uninstall Latest Patch.
5 (Conditional) Download a log file that includes details about the patch installation.
5a Click Download Log File for the appropriate patch.
6 Click Close to exit the Field Test Patch page.
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Online Update

Use the Online Update option to register for the online update service from the Customer Center
(https://www.netig.com/customercenter). You can alternatively register with a a Local Subscription
Management Tool (SMT) server from which you can download software updates. You can install
updates automatically or manually to update the Appliance.

Use the Online Update option to manage product updates for Transformation Manager Server
software, product updates for the PlateSpin Migrate Connector software for the installed instance,
and security updates for the software and operating system.

To activate the Update Channel, you use the same Full License key that you used to activate the
product. An Evaluation key will not activate the channel.

To register for the Online Update Service:

1 Log in to the Appliance Management Console as the vaadni n user.

2 Click Online Update |E .
3 If the Registration dialog does not open automatically, click the Register tab.
4 Specify the Service Type:
+ Local SMT (Go to Step 5.)
+ Customer Center (Go to Step 6.)
5 (Local SMT) Specify the following information for the SMT server, then continue with Step 7.
+ Hostname such as snt . exanpl e. com
+ (Optional) SSL certificate URL that communicates with the SMT server
+ (Optional) Namespace path of the file or directory

6 (Customer Center) Specify the following information about the Customer Center (https://
www.netig.com/customercenter) account for this PlateSpin Transformation Manager Appliance:

+ Email address of the account in Customer Center
+ Activation key (the same Full License key that you used to activate the product)
+ Allow data send (select any of the following)
+ Hardware Profile
¢ Optional information
7 Click Register.
Wait while the appliance registers with the service.
8 Click OK to dismiss the confirmation.

After you have registered the appliance, you can view a list of the needed updates, or view a list of
installed updates. You can use manual or automatic options to update the appliance.
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To perform other actions after registration:

+ Update Now: Click Update Now to trigger downloaded updates.

+ Schedule: Configure the type of updates to download and whether to automatically agree with
the licenses.

To schedule online update:
1. Click the Schedule tab.
2. Select a schedule for download updates (Manual, Daily, Weekly, Monthly).
+ View Info: Click View Info to display a list of installed and downloaded software updates.
+ Refresh: Click Refresh to reload the status of updates on the Appliance.

Reboot or Shutdown

You might need to initiate a graceful shut down or to restart the appliance for maintenance. Using the
Appliance Management Console options is preferred over using a Power Off/On option in the
hypervisor's VM management tool.

1 Log in to the Appliance Management Console as the vaadni n user.
2 In the upper right corner of the Appliance Configuration pane, click Reboot or click Shutdown.

Logout

For security reasons, you should sign out to exit your management session with the appliance, then
close your web browser. Your session terminates automatically when you close your web browser.

To sign out of the Appliance Management Console:

1 In the upper-right corner of the Appliance Management Console page, next to the user name,
click Logout.

2 Close the web browser.

Configuring Proxy Client Settings

If you have a Proxy Server in your environment, you can enable PlateSpin Transformation Manager
to use that server for Internet communications by configuring the Proxy client settings on the
PlateSpin Transformation Manager Appliance and host servers of PlateSpin Migrate Connector
instances. The Proxy client informs applications of the Proxy Server URL and credentials to use (if
you specify them). It does not affect how the applications communicate with the server.

+ “Configuring Proxy Client Settings for the PTM Appliance” on page 36

+ “Configuring Proxy Client Settings for Migrate Connector Hosts” on page 38
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Configuring Proxy Client Settings for the PTM Appliance

You can enable the PlateSpin Transformation Manager Appliance to work with the Proxy Server in
your environment. Log in to the Appliance via SSH, then use YaST to configure the Internet proxy
client settings that the Appliance, Web Interface, and PlateSpin Migrate Connector instance will use
for HTTP and HTTPS communications.

To configure Proxy client settings on the Appliance:

1 Enable the SSH protocol on the Appliance.

la

1b
1c
1d
le

1f

In a web browser, log in to the Appliance Management Console as the vaadmi n user.
https://<ptm-ipaddr-or-dns-name>:9443

Click System Services ‘{j}’

Select the SSH service.

Select Action > Start.

Click Close to exit System Services.

Log out of the Appliance Management Console, then close your web browser.

2 Configure the Proxy client settings needed to access your Proxy Server:
2a From your computer, start an SSH session for ptm-ipaddr-or-dns-name on port 22, then log

2b

in as the r oot user to the Appliance.
You can use any SSH tool, such as Putty (http://www.putty.org/).
At the terminal prompt, enter

yast
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2c In YaST, navigate to Network Services, select Proxy, then press Enter.
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2d On the Proxy Configuration page, on Enable Proxy, press the Space bar to select the check
box.

Proxy Configuration

qqaaaoaqaaaaoaaqaaqaoaqaqaaaoaaqaaaaqaqaaaaaaoaoaqaaaoaoaaagg. k

o g (oo (o (s (o (o Lo o o {0 o (o (o (o (o o (o [ o L o (o (o o s (o (o gy
& [ qoaaqgaooaaaqaqaoaag k

qaaaaaqaaaaaaqqaqaaaaqaqaoaa

2e Tab to navigate to the fields and configure the Proxy settings by using the information for
your Proxy Server. Provide the URL for the Proxy Server for HTTP or HTTPS (or both)
communications, depending on what protocols you enabled for the Appliance.

HTTP Proxy URL: The URL (with hostname and port number) of the Proxy Server used for
non-secure access to the Internet. For example: http://proxyl.example.com:3126/

HTTPS Proxy URL: The URL (with hostname and port number) of the Proxy Server used
for secure access to the Internet. For example: https://proxy2.example.com:3128/
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FTP Proxy URL: The URL (with hostname and port number) of the Proxy Server used for
access to the file transfer services (FTP). For example: https://ftp.proxy.example.com:2121/

Use the Same Proxy for All Protocols: Enable this option and provide a single URL in
HTTP Proxy URL that will be used as the Proxy Server for HTTP, HTTPS, and FTP
communications.

No Proxy Domains: Specify a comma-separated list of domains for which requests should
be made directly without caching. The default is | ocal host .

Proxy User Name and Proxy Password: Provide the credentials for your Proxy Server if
it requires authorization.

2f (Optional) Tab to Test Proxy Settings, then press Enter.
2g Tab to OK, then press Enter to save and apply the settings.
2h Tab to Quit, then press Enter to exit YaST.
2i At the terminal prompt, enter exi t to close the SSH session.
3 Disable the SSH protocol on the Appliance.
3a In a web browser, log in to the Appliance Management Console as the vaadmi n user.
https://<ptm-ipaddr-or-dns-name>:9443

3b Click System Services {:}

3c Select the SSH service.

3d Select Action > Stop.

3e Click Close to exit System Services.

3f Log out of the Appliance Management Console, then close your web browser.

Configuring Proxy Client Settings for Migrate Connector
Hosts

You can enable the PlateSpin Migrate Connector host servers to work with the Proxy Server in your
environment. On SUSE Linux Enterprise Server (SLES) servers that host an instance of Migrate
Connector, log in to the desktop and use YaST2 to configure the Internet proxy client settings that the
Connector instance will use for HTTP and HTTPS communications.

To configure Proxy client settings on SLES servers that host a Migrate Connector instance:

1 Login as the root user to the desktop on the SLES server.

2 Start the YaST Control Center from the main menu. Provide the r oot user password if you are
prompted for it.

To start the YaST Control Center from the command line, open a terminal, then enter yast 2.
3 Select Network Services, then select Proxy.

4 Configure the Proxy settings by using the information for your Proxy Server. Provide the URL for
the Proxy Server for HTTP and HTTPS communications.

HTTP Proxy URL: The URL (with hostname and port number) of the Proxy Server used for non-
secure access to the Internet. For example: http://proxyl.example.com:3126/

HTTPS Proxy URL: The URL (with hostname and port number) of the Proxy Server used for
secure access to the Internet. For example: https://proxy2.example.com:3128/

FTP Proxy URL: The URL (with hostname and port number) of the Proxy Server used for
access to the file transfer services (FTP). For example: https://ftp.proxy3.example.com:2121/
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Use the Same Proxy for All Protocols: Enable this option and provide a single URL in HTTP
Proxy URL that will be used as the Proxy Server for HTTP, HTTPS, and FTP communications.

No Proxy Domains: Specify a comma-separated list of domains for which requests should be
made directly without caching. The default is | ocal host .

Proxy User Name and Proxy Password: Provide the credentials for your Proxy Server if it
requires authorization.

5 Click Test Proxy Settings.

6 Click Finish to save and apply the settings.
7 Exit YaST.

8 Log out of the server.
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Configuring the PlateSpin
Transformation Manager Server

The PlateSpin Transformation Manager Appliance provides additional tools to manage the PlateSpin
Transformation Manager Server that it hosts.

To access the PlateSpin Transformation Manager Tools:
1 In a web browser, specify the DNS name or the IP address for the appliance with the port
number 9443. For example:
https://10. 10. 10. 1: 9443
or
https://ptm exanpl e. com 9443

2 Specify the administrative username and password for the appliance, then click Sign in. The
default users are vaadni n or r oot .

3 Under PlateSpin Transformation Manager Tools, click Configuration e

4 (Conditional) The Appliance Management Console automatically opens the following PlateSpin
Transformation Manager Tools if it detects the stated condition:

+ Initial Configuration: The Initial Configuration tool opens if the PlateSpin Transformation
Manager Server has not been configured. You must complete the initial setup before you
can manage the appliance or the PlateSpin Transformation Manager Server.

+ Upgrade: The Upgrade tool opens if the RPM files for PlateSpin Transformation Manager
or the guest operating system have been upgraded. You must complete the upgrade before
you can manage the appliance or the PlateSpin Transformation Manager Server.

5 Continue using the PlateSpin Transformation Manager Server Tools.
The PlateSpin Transformation Manager Tools page displays the following options:

+ ‘“Initial Configuration” on page 42

+ “Administrative Users” on page 43

+ “Web Server Configuration” on page 44

¢ “Upgrade” on page 44

+ “Web Interface Session Timeout” on page 44
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Initial Configuration

You can configure or reconfigure the PlateSpin Transformation Manager Server settings. You can use
the Administrative Users tool and the Web Server Configuration tool to modify the application settings
without losing any data.

NOTE: A reconfiguration restores the PlateSpin Transformation Manager application and its
PostgreSQL database to their initial state. All data is lost.

1 Log in to the Appliance Management Console as the vaadni n user.

2 Under PlateSpin Transformation Manager Tools, click Configuration @
3 On the PlateSpin Transformation Manager Configuration page, select Initial Configuration.
4 Select one of the following:

¢ Server Configuration: This option is available if the PlateSpin Transformation Manager
application is not configured.

+ Overwrite Configuration: This option is available if the PlateSpin Transformation Manager
application is already configured. Select this option only if you want to overwrite the existing
configuration settings and delete all project data.

5 Complete the configuration information.

5a PostgreSQL Database Connection
Use one of the following options:

+ Local database: PlateSpin Transformation Manager automatically pre-installs the
PostgreSQL database on the appliance. Select Auto Setup Local Database to
automatically create a database instance, database administrator user, and a
password for the user. Table 4-1 shows the default settings.

Table 4-1 PostgreSQL Database Default Values

Parameter Default Value
Database Host localhost
Database Port 5432

Create a New Database Selected
Database Name transmgr
Database User Name tmadmin

+ Remote database: You can alternatively set up the PlateSpin Transformation
Manager database as a database instance on an existing PostgreSQL database in
your network.

1. Deselect Auto Setup Local Database.

2. Replace | ocal host with the DNS name or IP address of the host server for the
remote PostgreSQL database, and specify the PostgreSQL port.

3. Specify the credentials of the database administrator user who has the schema
rights necessary to create a new instance for the PlateSpin Transformation
Manager database.
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4. Specify a name for the PlateSpin Transformation Manager database instance
(default: t ransngr).

5. Specify the username and password for the database user who will be created as
the administrator user (default: t madni n) for the PlateSpin Transformation
Manager database instance.

5b Initial User Configuration

The initial user for the PlateSpin Transformation Manager Server is the System
Administrator user who has all rights for configuration and management throughout the Web
Interface.

Provide the full name, a valid email address that is unique to your PlateSpin Transformation
Manager environment, and a password for this user.

You cannot delete this user from the Appliance Management Console. You can add another
System Administrator user for the PlateSpin Transformation Manager Server if it becomes
necessary to replace or augment the initial user account. See Administrative Users.

NOTE: You add and manage other users on the Users page in the PlateSpin
Transformation Manager Web Interface. See “Managing Users” in the PlateSpin
Transformation Manager User Guide.

5¢c Web Server Configuration

Micro Focus recommends that you use the secure port 8183 and SSL options for accessing
the Web Interface. You can enable or disable the HTTP port 8182 to allow non-secure
traffic.

Specify the DNS name for the PlateSpin Transformation Manager Server. It is populated
automatically with the DNS address used as the subject of the SSL certificate on the
appliance.

6 Click Submit.

Administrative Users

You might need to add a new System Administrator user to the PlateSpin Transformation Manager
Server if you forget the initial username and password, or if that initial user is no longer available to
manage the server. The new user has the same global privileges as the default System Administrator
user that was created for the PlateSpin Transformation Manager Web Interface during the installation.

NOTE: In the Web Interface, the default System Administrator can set up additional users and assign
them to the Administrators group. Members of the Administrators group will also have global
permissions in the Web Interface.

1 Log in to the Appliance Management Console as the vaadni n user.

2 Under PlateSpin Transformation Manager Tools, click Configuration 6
3 On the PlateSpin Transformation Manager Configuration page, select Administrative Users.

4 Provide the full name, a valid email address that is unique to your PlateSpin Transformation
Manager environment, and a password for this user.

5 Click Submit.
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Web Server Configuration

The administrative users of the PlateSpin Transformation Manager Appliance can reconfigure the
Jetty WebServer HTTPS and HTTP ports for the Web Interface.

1 Log in to the Appliance Management Console as the vaadni n user.

2 Under PlateSpin Transformation Manager Tools, click Configuration @

3 On the PlateSpin Transformation Manager Configuration page, select Web Server
Configuration.

4 For the Web Console HTTPS Port, specify the port to use for secure SSL connections with the
PlateSpin Transformation Manager Web Interface. The default port is 8183

5 (Optional, not recommended) Select Enable HTTP to allow users to access the PlateSpin
Transformation Manager Web Interface over port 8182 for non-secure connections.

6 Click Submit.

Upgrade

The Upgrade option is available if the appliance detects that the RPM files for PlateSpin
Transformation Manager or the guest operating system have been upgraded. After you log in to the
Appliance Management Console, you must complete the upgrade before you can manage the
appliance or the PlateSpin Transformation Manager Server.

1 (Optional, recommended) Log out of the Appliance Management Console, back up your
PlateSpin Transformation Manager database, then log in again to the Appliance Management
Console.

2 When you are redirected to the Upgrade page, click Complete Upgrade.

The upgrade automatically starts the PlateSpin Transformation Manager service and the
PlateSpin Migrate Connector for PTM service.

Web Interface Session Timeout

A user session in the PlateSpin Transformation Manager Web Interface times out by default after 30
minutes of browser inactivity. The Web Interface Session Timeout interval is configurable with the
t m sessi on. ti meout . m nut es property in the / opt/ m cr of ocus/ ps_t r ansf or m_ngr/ confi g/
syst em properti es file. If the property is not specified in this file, the session timeout defaults to 30
minutes.

1 Enable the SSH service on the Appliance VM.
See “Enabling or Disabling the SSH Service” on page 26.
Start an SSH session with the Appliance VM, then log in as the vaadni n user or r oot user.
Navigate to the / opt / mi cr of ocus/ ps_t ransf orm ngr/ confi g/ directory.

Open the syst em properti es file in a text editor.

aa b~ W N

Add the tm sessi on. ti meout . m nut es property and specify the value in minutes to set the
interval of browser inactivity to allow before a Web Interface session times out.

6 Save the file and close the text editor.

Configuring the PlateSpin Transformation Manager Server



7 Restart the PlateSpin Transformation Manager service to allow the Web Interface Session
Timeout value to take effect.

In your SSH session, enter the following at a terminal console:
rcps_transformngr restart

8 Exit your SSH session.
9 (Optional) Disable the SSH service on the Appliance VM.
See “Enabling or Disabling the SSH Service” on page 26.
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Configuring a Custom Ul Theme for the
Web Interface

PlateSpin Transformation Manager allows you to create a custom look-and-feel for the Web Interface.
You copy the default theme files to a new directory, customize the files as appropriate, and then point
to the custom theme location in the Web Interface configuration file.

PlateSpin Transformation Manager provides two key configurable components for the Web Interface
theme:
+ Theme folder: / vast or age/ pt m t hermes/ <your _t heme_di rect or y>/

¢ Color variables: A custom CSS file defines about 20 colors that, along with their derivative
colors, affect about 80 percent of text, titles, underscores, buttons, shadings, and so on
throughout the Web Interface. You can modify the color definitions to suit the color scheme
for your business.

+ Images: You can replace any of the various images related to icons displayed for
configuration, dashboard, resources, projects, users, and workloads.

+ Theme configuration file: / et ¢/ opt / mi cr of ocus/ ps_t ransform ngr/confi g/
transf ormati onmanager -t henes. cf g

+ Product Name: You can specify the full and short product name that displays in the Web
Interface.

¢+ Theme: You can specify the default Tr ansf or mat i onManager theme directory, or specify
your custom theme directory.

Use the following procedures to set your custom theme:

+ “Setting Up Your Custom Theme” on page 47
+ “Resetting Your Custom Theme after an Upgrade” on page 49

Setting Up Your Custom Theme

To create a custom theme for the PTM Web Interface:

1 Enable the SSH service on the appliance:
la Log in to the Appliance Management Console as the vaadmi n user.
1b Click System Services.
1lc Select the SSH service.
1d Select Action > Start.
le Click Close to exit System Services.
2 Start an SSH session and log in as the vaadni n user to the user appliance.
3 Set up your custom theme files:
3a Navigate to the / vast or age/ pt mi t herres/ directory.
3b Create a subdirectory under t henmes for your custom theme, such as MyConpanyThene.
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3c

3d

3e

Copy the contents of the / vast or age/ pt nf t henmres/ Tr ansf or mat i onManager directory to
your new theme directory (/ vast or age/ pt m t hemres/ MyConpany Thene).

In your custom theme directory, update the custom CSS file for color variables;
/ vast orage/ pt m t hemes/ <your _t heme_di rect ory>/ en/ web/ t hene_vari abl es. t ntss

In your custom theme directory, change the image files as appropriate to define your
custom theme for the PTM Web Interface.

4 Modify the t r ansf or mat i onmanager - t henes. cf g file with your custom settings:

4a

4b

4c

4d

Open the / et ¢/ opt / m crof ocus/ ps_transform ngr/config/transfornati onmanager -
t henes. cf g file in a text editor.

Modify the ser ver . t hene directive to replace the Tr ansf or mat i onManager theme with
your custom theme MyConpany Thene.

For example, change this line:

server. t heme=Tr ansf or mat i onManager

to this:

server. t heme=MyConpany Thene

(Optional) Modify the lines that specify the product name.

server. product name=<span>Pl at eSpi n</ span> Transformati on Manager
server. short product name=Tr ansf or mati on Manager

Save your changes.

5 Restart the PlateSpin Transformation Manager service to allow the theme changes to take effect.

Do one of the following:

*

*

In your SSH session, enter the following at a terminal console:
rcps_transformnmgr restart

Log in to the Appliance Management Console, click System Services, select PlateSpin
Transformation Manager (ps_t r ansf or m_nmgr ), then select Action > Restart.

6 Log in to the PTM Web Interface to verify your Ul changes.

To make additional changes, return to the appliance to update your custom theme files as
appropriate, then restart the service to apply the changes.

7 After your theme changes are complete, end your SSH session.
8 Disable the SSH service:

8a

8b
8c
8d
8e

Log in to the Appliance Management Console as the vaadni n user, then click System
Services.

Select the SSH service.

Select Action > Stop.

Click Close to exit System Services.

Log out of the Appliance Management Console, then close your web browser.
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Resetting Your Custom Theme after an Upgrade

An appliance update ignores your custom theme directory, but updates files in the default theme
location. After an upgrade or update, you must verify that your themes are still valid and manually
update your theme files as necessary.

After a patch or online update, manually update your theme:

1 Enable the SSH service on the appliance:

la Log in to the Appliance Management Console as the vaadni n user, then click System
Services.

1b Select the SSH service.
1c Select Action > Start.
1d Click Close to exit System Services.
2 Start an SSH session and log in as the vaadmi n user to the appliance.
3 Navigate to the / vast or age/ pt ni t henes/ Tr ansf or mat i onManager directory.

4 Copy the latest version of the CSS and image files that you modified from the
Transf or mat i onManager location to a working location.

5 Merge your custom settings to these new files.
6 Copy the updated files to your theme directory (/ vast or age/ pt mi t henes/ MyConpany Thene).
7 Restart the PlateSpin Transformation Manager service to allow the theme changes to take effect.
Do one of the following:
+ In your SSH session, enter the following at a terminal console:

rcps_transformngr restart

+ Log in to the Appliance Management Console, click System Services, select PlateSpin
Transformation Manager (ps_t r ansf or m ngr ), then select Action > Restart.

8 Log in to the PTM Web Interface to verify your Ul changes.

To make additional changes, return to the appliance to update your custom theme files as
appropriate, then restart the service to apply the changes.

9 After the theme changes are complete, end your SSH session.
10 Disable the SSH service:

10a Log in to the Appliance Management Console as the vaadni n user, then click System
Services.

10b Select the SSH service.

10c Select Action > Stop.

10d Click Close to exit System Services.

10e Log out of the Appliance Management Console, then close your web browser.
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Documentation Updates

This section contains information on documentation content changes that were made in this
Appliance Guide after the initial release of PlateSpin Transformation Manager 1.1.

May 2017

Location

Update

“Configuring Proxy Client Settings” on page 35

This section is new.

Documentation Updates
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