22.3 Turning on Trace Messages

You might want to send trace messages to the error log so that the messages are captured in a file. You can then easily e-mail the trace message to Novell Support or others.

Programmers sometimes place hidden messages in their code so that if you are having problems, you can turn on the trace functionality and get additional insight. Even if you don’t understand the hidden messages, they can help Novell Support diagnose the problem.

To get trace messages:

  1. Click Window > Preferences to display the Preferences dialog box.

  2. Click Novell > Designer > Trace.

    The Designer for IDM and trace options
  3. Select Enable tracing, then select the options that you want to include or show.

    Options to enable tracing and select plug-ins
  4. Select the plug-ins that you want to trace, then click OK.

To view the results of traces:

  1. Select Window > Show View > Trace.

  2. View data in the Trace view.

    The Trace view
  3. You can also turn on trace options from the Trace view by clicking the Preferences icon The Trace view in the Trace view.

The following options are available when you right-click inside the Trace view:

Table 22-4 Right-Click Options in the Trace View




Undo a previously executed action.

Cut, Copy and Paste

Cut, copy and paste items in the Trace view by selecting the item, then clicking the desired action.


Delete items in the Trace view.

Select All

Simultaneously select all trace messages in the Trace view.

An icon toolbar is located in the upper right corner of the Trace view. For information on the icons in this toolbar, see Trace View in Understanding Designer for Identity Manager.