15.3 Capturing Identity Manager Processes to a File

Identity Manager processes are saved to a file by using a parameter on the driver or through DSTrace. The parameter on the driver is the Trace file parameter.

The driver processed that are captured through DSTrace are the processes that occur on the Identity Manager engine. If you use the Remote Loader, you need to capture a trace on the Remote Loader at the same time as you are capturing the trace on the Identity Manager engine.

The following methods helps you capture and save Identity Manager processes through DSTrace on different OS platforms.

15.3.1 Windows

  1. Open the Control Panel > NDS Services > dstrace.dlm, then click Start.

    A window opens named NDS Server Trace Utility.

  2. Select Edit > Options, then click Clear All.

    This clears all of the default flags.

  3. Select DirXML and DirXML Drivers.

  4. Click OK.

  5. Select File > New.

  6. Specify the filename and location of where you want the DSTrace information saved, then click Open.

  7. Wait for the event to occur.

  8. Select File > Close.

    This stops the information from being written to the log file.

  9. Open the file in a text editor and search for the event or the object you modified.

15.3.2 UNIX

  1. Enter ndstrace to start the ndstrace utility.

  2. Enter set ndstrace=nodebug

    Turns off all trace flags currently set.

  3. Enter set ndstrace on

    Displays trace messages to the console.

  4. Enter set ndstrace file on

    Captures trace messages to the file ndstrace.log the directory where eDirectory is installed. By default it is /var/nds.

  5. Enter set ndstrace=+dxml

    Displays the Identity Manager events.

  6. Enter set ndstrace=+dvrs

    Displays the Identity Manager driver events.

  7. Wait for the event to occur.

  8. Enter set ndstrace file off

    This stops the logging of information to the file.

  9. Enter exit to quit the ndstrace utility.

  10. Open the file in a text editor. Search for the event or the object that was modified.

15.3.3 iMonitor

iMonitor allows you to get DSTrace information from a web browser. It does not matter where Identity Manager is running. These are the files that run iMonitor:

  • NDSIMON.DLM Runs on Windows.

  • ndsimonitor Runs on UNIX.

  1. Access iMonitor from http://server_ip:8008/nds.

    Port 8008 is the default port.

  2. Enter a username and password with administrative rights, then click Login.

  3. Select Trace Configuration on the left side.

  4. Click Clear All.

  5. Select DirXML and DirXML Drivers.

  6. Click Trace On.

  7. Select Trace History on the left side.

  8. Click the document with the Modification Time of Current to see a live trace.

  9. Change the Refresh Interval if you want to see information more often.

  10. Select Trace Configuration on the left side, then click Trace Off to turn the tracing off.

  11. You can view the trace history by selecting Trace History. The files are distinguished by their time stamps.

If you need a copy of the HTML file, the default location is:

  • Windows: Drive_letter:\Novell\NDS\ndsimon\dstrace\*.htm

  • UNIX/Linux: /var/nds/dstrace/*.htm

15.3.4 Remote Loader

You can capture the events that occur on the machine running the Remote Loader service.

  1. Launch the Remote Loader Console by clicking the icon.

  2. Select the driver instance, then click Edit.

  3. Set the Trace Level to 3 or above.

  4. Specify a location and file for the trace file.

  5. Specify the amount of disk space that the file is allowed.

  6. Click OK twice to save the changes.

You can also enable tracing from the command line by using the following switches. For more information, see Configuring the Remote Loader in the Identity Manager 4.0.1 Remote Loader Guide.

Table 15-3 Command Line Tracing Switches


Secondary Name






Specifies the trace level. This is only used when hosting an application shim. Trace levels correspond to those used on the Identity Manager server.

Example: -trace 3 or -t3




Specify a file to write trace messages to. Trace messages are written to the file if the trace level is greater than zero. Trace messages are written to the file even if the trace window is not open.


-tracefile c:\temp\trace.txt


-tf c:\temp\trace.txt




Specifies the approximate maximum size that trace file data can occupy on disk. If you specify this option, there is a trace file with the name specified using the tracefile option and up to 9 additional “roll-over” files. The roll-over files are named using the base of the main trace filename plus “_n”, where n is 1 through 9.

The size parameter is the number of bytes. Specify the size by using the suffixes K, M, or G for kilobytes, megabytes, or gigabytes.

If the trace file data is larger than the specified maximum when the Remote Loader is started, the trace file data remains larger than the specified maximum until roll-over is completed through all 10 files.

Example: -tracefilemax 1000M or -tfm 1000M