37.1 Requirements for Configuring OSP to Work with AD FS

Ensure that the following requirements are met before you configure OSP to work with AD FS.

  • AD FS must use the same TLS version that the Tomcat instance for Identity Manager uses for both incoming and outgoing communication. By default, Identity Manager uses TLS 1.2 and AD FS uses TLS 1.0. If AD FS uses a lower version than what Identity Manager uses, it can cause issues with the integration. For more information, see Microsoft documentation.

  • Identity Manager uses SSL for communication. For more information, see Section 41.0, Using SSL for Secure Communication.

  • Identity Manager version must be 4.8 or later.