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NetIQ Identity Manager Analyzer 4.7 provides several enhancements and resolves specific previous
issues.
Many of these improvements were made in direct response to suggestions from our customers. We
thank you for your time and valuable input. We hope you continue to help us ensure that our products
meet all your needs. You can post feedback in the Identity Manager Community Forums, our
community Web site that also includes product notifications, blogs, and product user groups.
For information about what’s new in previous releases, see the “Previous Releases” section at the
Identity Manager Documentation Web site.
The documentation for this product and the latest release notes are available on the NetIQ Web site
on a page that does not require you to log in. If you have suggestions for documentation
improvements, click comment on this topic at the bottom of any page in the HTML version of the
documentation posted at the Identity Manager Documentation Web site.
To download this product, see the Identity Manager Product Web site.
 Section 1, “What’s New?,” on page 1
 Section 2, “System Requirements,” on page 1
 Section 3, “Installing Analyzer 4.7,” on page 1
 Section 4, “Upgrading to Analyzer 4.7,” on page 2
 Section 5, “Known Issues,” on page 2
 Section 6, “Using the Product Evaluation Key,” on page 5
 Section 7, “Contact Information,” on page 6
 Section 8, “Legal Notice,” on page 6
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What’s New?
This release adds support for Java 8 Update 162.
It does not include any other new features.
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System Requirements
For information about hardware requirements and supported operating systems, see the Technical
Information for Identity Manager page.
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Installing Analyzer 4.7
After you purchased Identity Manager 4.7, log in to the Identity Manager Product Web site and follow
the link that allows you to download the software. The following files are available:
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Table 1 Identity Manager ISO Images

ISO

Description

Identity_Manager_4.7_Linux.iso

Contains all Identity Manager components for Linux.
Identity Manager Server (Identity Manager Engine,
Remote Loader, Fan-Out Agent, iManager Web
Administration), Identity Applications, Identity
Reporting, Designer, and Analyzer

Identity_Manager_4.7_Windows.iso Contains all Identity Manager components for
Windows.
Identity Manager Server (Identity Manager Engine,
Remote Loader, Fan-Out Agent, iManager Web
Administration), Identity Applications, Identity
Reporting, Designer, and Analyzer
Identity_Manager_4.7_Linux_Analy Contains Analyzer for Linux
zer.tar.gz
Identity_Manager_4.7_Windows_Ana Contains Analyzer for Windows
lyzer.zip

To download the installation kits, see the NetIQ Downloads Web site.
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Upgrading to Analyzer 4.7
You can upgrade to Analyzer 4.7 from Analyzer 4.6. For information about the supported upgrade
paths, see Preparing to Upgrade Identity Manager in the NetIQ Identity Manager Setup Guide for
Linux or Preparing to Upgrade Identity Manager in the NetIQ Identity Manager Setup Guide for
Windows.
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Known Issues
NetIQ Corporation strives to ensure our products provide quality solutions for your enterprise
software needs. The following issues are currently being researched. If you need further assistance
with any issue, please contact Technical Support (http://www.netiq.com/support).
 Section 5.1, “SAP User Driver Requires Additional Files,” on page 3
 Section 5.2, “DB2 Driver Requires Additional Libraries,” on page 3
 Section 5.3, “Warning About Modifying Data,” on page 3
 Section 5.4, “Errors When Sending Updated Data to an Application,” on page 3
 Section 5.5, “Importing Does Not Return Data from the Application,” on page 3
 Section 5.6, “Some Characters Cause Problems with Pattern Frequency Analysis,” on page 4
 Section 5.7, “Unable to Import Connections from Designer,” on page 4
 Section 5.8, “Matching Analysis Does Not Exclude Deleted Values,” on page 4
 Section 5.9, “Application Schema Import Fails,” on page 5
 Section 5.10, “Matching Is Case Sensitive When Using HSQL,” on page 5

2

NetIQ Identity Manager Analyzer 4.7 Release Notes

5.1

SAP User Driver Requires Additional Files
To use the SAP user driver, you must install the sapjco.jar library in Analyzer, and install the
librfc32.dll and sapjcorfc.dll into the Windows %systemroot% folder (typically
C:\windows\system32).
Restart Analyzer after installing these files.

5.2

DB2 Driver Requires Additional Libraries
The Analyzer DB2 driver requires the following two libraries to function properly. You can download
these libraries from IBM (http://www.ibm.com/developerworks/).
 db2java.zip
 db2jcc.jar

5.3

Warning About Modifying Data
Issue: Analyzer does not prevent users from modifying anything in a data set. If a user with
appropriate rights to the source application modifies a value, for example a GUID or DN, Analyzer
does not attempt to determine if the modification causes a problem when written out to the source
application.
Workaround: To avoid causing unintended problems in the source application, users should be
careful when modifying data and sending those modifications to the source application.

5.4

Errors When Sending Updated Data to an Application
Issue: When you attempt to push updated data to the source application from Analyzer’s Data
Browser (by clicking Save to Application), you might get an error indicating there was a problem with
the update operation. However, the Data Browser’s modified data indicators in the data table change
to indicate that the updates were successful.
Workaround: If this occurs, the data updates might have been unsuccessful. Re-import the data
from the source application to make sure you know the true state of the data before making any other
data modifications.
Problems with the update operation occur primarily when adding a value to a multi-valued attribute.

5.5

Importing Does Not Return Data from the Application
The following issues can prevent Analyzer from displaying data set content in the Data Browser view:
 Section 5.5.1, “SQL Reserved Word Used as a Column Name,” on page 3
 Section 5.5.2, “Subscriber Is Disabled for the Selected Connection,” on page 4

5.5.1

SQL Reserved Word Used as a Column Name
Analyzer does not support SQL reserved words as column names for data sets (For example, group
or select.) If a column name is an SQL reserved word, no data displays in the Data Browser view. To
avoid this, exclude the column (attribute) with a reserved-word name from the data set.
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5.5.2

Subscriber Is Disabled for the Selected Connection
Issue: By default, Analyzer’s Subscriber channel is enabled so that you can perform data set queries.
However, if a connection profile was synchronized from Designer with the Subscriber channel
disabled, it remains disabled for Analyzer. If your data sets do not have any data, confirm that the
connection profile’s Subscriber channel is enabled in Analyzer.
Workaround: To do this, right-click the desired connection profile, then select Properties. In the
connection profile properties, select IDS Configuration > Parameters > Subscriber Options. Make
sure that Disable subscriber is set to No (default).

5.6

Some Characters Cause Problems with Pattern Frequency
Analysis
The Pattern Frequency analysis metric does not work properly with data that includes the following
characters. If you attempt to do a pattern frequency analysis on a data set that has values that
contain any of these characters, the analysis fails and returns an empty result. (Bug 379384)

5.7

Character

Description

+

Plus (addition) symbol

*

Asterisk

.

Period

‘

Apostrophe

?

Question mark

|

Pipe symbol

\

Backslash symbol

()

Left or right parentheses

[]

Left or right bracket

Unable to Import Connections from Designer
Issue: If connections do not import properly from Designer, the likely problem is that the server
configuration associated with the driver set in Designer is incorrect or incomplete. For example, when
you create a new driver set in Designer, the default server DN is server.context. If you attempt to
import connection information that includes invalid information like this, the import fails. (Bug
368384)
Workaround: Before importing connection information from Designer, make sure that the server
information is valid.

5.8

Matching Analysis Does Not Exclude Deleted Values
If you have deleted values in the Data Browser that have not been updated to the application, the
deleted values are still considered when running a Matching Analysis.
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5.9

Application Schema Import Fails
Issue: The Identity Vault schema does not support multiple classes with the same name. Some
application schemas, such as Notes, do support duplicate class names. If you want to import an
application schema that includes duplicate class names, you should first consolidate the duplicate
class names into a single class that contains the attributes from all duplicate classes. (403735)
Workaround: If you cannot resolve the duplicate classes in the application schema, you can
manually resolve the duplicate class names in Analyzer by doing the following:
WARNING: This procedure is not recommended and can cause inconsistencies in the Identity Vault
schema. It should only be used if absolutely necessary.
1 Open the IDS Trace view (Window > Show View > IDS Trace).
2 In the Project view, right-click the appropriate connection, then select Refresh Schema.

This captures the application schema in the IDS Trace. If the IDS Trace does not capture the
entire schema, increase the IDS Trace window size by clicking the Preferences icon, then
increasing the Maximum lines to retain setting.
3 Open the Navigator view (Window > Show View > Navigator).
4 In the Navigator view, expand the appropriate project, then browse to Model > Analyzer.
5 Double-click the appropriate schema file (*ShimConfig.xml) to open it in an XML editor.

If there are multiple shim configuration files, you can identify the application associated with each
file by opening the file and looking at the contents of the <class-name>, <auth-id>, and <authcontext> tags.
6 In the XML editor, search for the following elements. If they do not exist, add them to the schema
immediately above the closing </shim-config> tag.
<app-schema-def>
<schema-def>
...
</schema-def>
<app-schema-def>
7 In IDS Trace, locate the <NDS> tag, then paste the contents of the <NDS> tag into the <schemadef> tag in the *ShimConfig.xml file.

Make sure you do not include the <NDS> as part of what you copy and paste into the
*ShimConfig.xml.
8 Search for any duplicate <ClassDef> elements in the schema definition and consolidate all
attribute definitions <attr-def> under a single <ClassDef> element.
9 Save the changes to the schema file (Ctrl+S), then restart Analyzer.

5.10

Matching Is Case Sensitive When Using HSQL
If you are using HSQL as the back end database for Analyzer, matching is case sensitive. If you are
using MySQL, the back end database is case insensitive. (Bug 437550)
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Using the Product Evaluation Key
You can try using Analyzer before purchasing the product. For trying the product, enter C064 0010
0000 E203 2CCA evaluation key in the License dialog box after launching Analyzer. The product
evaluation key is valid up to 14 days after you start using the product. (Bug 728283)
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Contact Information
Our goal is to provide documentation that meets your needs. If you have suggestions for
improvements, please email Documentation-Feedback@netiq.com (mailto:DocumentationFeedback@netiq.com). We value your input and look forward to hearing from you.
For detailed contact information, see the Support Contact Information website (http://www.netiq.com/
support/process.asp#phone).
For general corporate and product information, see the NetIQ Corporate website (http://
www.netiq.com/).
For interactive conversations with your peers and NetIQ experts, become an active member of our
community (https://www.netiq.com/communities/). The NetIQ online community provides product
information, useful links to helpful resources, blogs, and social media channels.
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Legal Notice
For information about legal notices, trademarks, disclaimers, warranties, export and other use
restrictions, U.S. Government rights, patent policy, and FIPS compliance, see https://www.netiq.com/
company/legal/.
Copyright © 2018 NetIQ Corporation. All Rights Reserved.
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