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About This Guide

This guide introduces the NetlQ Cloud manager VM Client, including its basic administration
environment, which is accessed through an Eclipse rich client platform. The guide provides an
introductory overview of the VM Client, and explains how to install, monitor, and manage VMs.

The guide is organized as follows:

¢ Chapter 1, “Overview,” on page 9

¢ Chapter 2, “Getting Started,” on page 13

¢ Chapter 3, “Understanding the VM Client Interface,” on page 27

¢ Chapter 4, “Managing VM Host Servers,” on page 69

¢ Chapter 5, “Managing Virtual Machines,” on page 83

¢ Chapter 6, “Managing Repositories,” on page 135

¢ Chapter 7, “Managing Templates,” on page 149

¢ Chapter 8, “Managing Clones of Templates,” on page 167

¢ Chapter 9, “Managing with Groups,” on page 171

¢ Chapter 10, “VM Client Debugging and Troubleshooting,” on page 189
¢ Appendix A, “VM Installation Sources,” on page 195

¢ Appendix B, “NPIV Terminology,” on page 197

¢ Appendix C, “Uninstalling the VM Client,” on page 199

¢ Appendix E, “VM Client Documentation Quick Index,” on page 205

Audience

This book is for data center VM operators. It assumes that users of the product have the following
background:

¢ General understanding of network operating environments and systems architecture

+ Knowledge of basic Linux shell commands, the Windows command prompt, and text editors

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comments feature at the bottom of each page of the
online documentation, or go to www.novell.com/documentation/feedback.html (http://
www.novell.com/documentation/feedback.html) and enter your comments there.

Additional Documentation

For other NetIQ Cloud Manager 2.1 documentation, see the NetIQ Cloud Manager 2.1
documentation site (http://www.novell.com/documentation/cloudmanager?).

About This Guide
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1.1

Overview

Review the following sections to understand the NetlQ Cloud Manager VM Client:

¢ Section 1.1, “What Is the VM Client?,” on page 9
¢ Section 1.2, “Understanding the Virtual Machine Life Cycle,” on page 10
¢ Section 1.3, “Using This Guide to Manage VMs,” on page 11

What Is the VM Client?

The VM Client is a management interface that VM operators can use to manage the life cycle of the
virtual machines (VMs) in your enterprise, including creating, starting, stopping, migrating, and
deleting VMs. Cloud Manager lets you better align IT to your business, control costs, and minimize
risks across all VM platforms in the data center. You can increase the functionality of your data center
by fully leveraging VMs as a usable resource.

The VM Client provides management of VMs from several different virtualization host types,
including SUSE Linux Enterprise Server (SLES) Xen, VMware (through vSphere), and Microsoft
Windows Server 2008 R2 with Hyper-V.

The VM Client also allows you to manage both VMs and VM host servers in your data center. A VM
host is a server running the Orchestration Agent.

For information on installing the VM Client, see
The VM Client provides the following:
+ A VM creation wizard that covers a VM’s installation source and mode, its virtualization mode,

repository, and hardware configurations

¢ A VM editing wizard, which can also be used to edit existing VMs, even those that are in a
running state

¢ The ability to discover existing VMs residing on your VM host servers

¢ The ability to discover VM host servers in your virtualization grid; a machine can be a host
server if it is running hypervisor software

¢ Methods for controlling VMs, such as starting, stopping, pausing, and suspending

¢ The ability to migrate a running VM from one host server to another in real time

¢ The ability to install and manage the Cloud Manager Orchestration Agent on your VMs
¢ The ability to make templates of VMs, including making clones of the templates

¢ The ability to move a VM'’s repository from one host server to another

¢ The ability to group VMs, VM hosts, repositories, and templates for easier management

¢ Detailed views of the properties for each VM, host server, repository, and template

Overview



¢ The ability to monitor your VMs and host servers in real time
¢ Event logs for VMs, host servers, and templates

The VM Client enhances the functionality of the Cloud Manager Orchestration Server, enabling it to
control VMs in your data center.

Cloud Manager also provides the Orchestration Console, where you can manage and control data
center jobs and processes through the application of rules, policies, scheduling, utilization, and
billing data center resources. For more information on the Orchestration Console, see the NetIQ Cloud
Manager 2.1 Orchestration Console Reference.

The VM Client and the Orchestration Console management interfaces work together to help you to
maximize the use of VMs in your data center. You can have fewer physical machines while giving
your data center many additional resources, and you can manage the physical VM host machines and
their VMs in your data center.

The Orchestration Server manages resources to perform work. It does this through automated jobs
(written in Jython) that in turn are broken down into joblets that are distributed among multiple
resources. For more information about Cloud Manager Orchestration Server operations, see “What
You Should Know” in the NetIQ Cloud Manager 2.1 Orchestration Developer Reference.

In addition, as calls for resources lessen and resources are released, the Orchestration Server
evaluates the capabilities of the active resources (VM or physical machine) and keeps the best
resource for the job. This might include any of the currently running VMs.

1.2 Understanding the Virtual Machine Life Cycle

The life cycle of a VM includes its creation, testing, modifications, use in your environment, and
removal when it's no longer needed.

For example, in setting up your VM environment, you might want to first create basic VMs from
which you can create templates. Then, to enable the most efficient use of your current hardware
capabilities, you can use those templates to create the many different specialized VMs that you need
to perform the various jobs. You can create and manage VM-related jobs through the Orchestration
Console interface.

Life cycle functions are performed one at a time per given VM as jobs on the host server in order to
prevent conflicts in using the VM. Life cycle events include:

¢ Creating a VM

¢ Starting and stopping a VM

¢ Pausing, suspending, and resuming a VM

¢ Installing the Orchestration Agent on a VM

¢ Creating a template from a VM

¢ Using the VM (starting, stopping, pausing, suspending, restarting, and shutting down)

¢ Running jobs for the VM

+ Editing a VM

¢ Editing a template

¢ Moving a stopped VM to another host server

¢ Migrating a running VM to another host server

10 NetlQ Cloud Manager 2.1 VM Client Guide and Reference



1.3

¢ Resynchronizing a VM to ensure that the state of the VM displayed in the Orchestration Console
is accurate

¢ Cloning a VM from a template

To view the histories of life cycle events or why they might fail, simply review a VM’s logs. For more
information, see Section 5.2, “Using Feedback to Manage VMs,” on page 87.

Using This Guide to Manage VMs

After installing the Cloud Manager VM Client, do the following;:

O X N o W N =

_ = =
N R O

* * * *

*

*

*

Become familiar with the VM Client interface.
Start the VM Client interface.

Register existing VM host servers.

Discover the registered host servers.
Discover the registered VMs.

Log in to a virtualization grid.

Create your VMs.

Install the VMs.

Install the Orchestration Agent on the VMs.
Create templates of the VMs.

. Add repositories.

. Configure the VMs:

Edit a VM or template.
Delete a VM.

Delete a template.
Clone a template.
Move a VM.

Migrate a VM.

Create groups for managing VMs, host servers, repositories, and templates.

13. Use the VMs:

*

*

*

*

*

*

*

*

*

Understand the various VM statuses.

Start VMs.

Stop VMs.

View a VM'’s server console.

Pause a VM.

Suspend a VM.

Resynchronize a host server with the Orchestration Console.
Resynchronize a VM with the Orchestration Console.

View logging details that are fed back from the Orchestration Server.

View the error log for a VM.

Overview
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*

Open the Progress View for a VM while a life cycle function is running.

View a VM'’s details.

*

¢ View a host server’s details.

¢ View a repository’s details.

¢ View a template’s details.
14. Troubleshoot VMs.

15. Find operating system installation sources for VMs.

12 NetlQ Cloud Manager 2.1 VM Client Guide and Reference



2.1

211

Getting Started

To get started with the Cloud Manager VM Client, do the following:

¢ Section 2.1, “Installing the VM Client,” on page 13

¢ Section 2.2, “Starting and Logging In to the VM Client Interface,” on page 16
¢ Section 2.3, “Logging In to Another Virtualization Grid,” on page 21

¢ Section 2.4, “Registering VM Hosts,” on page 22

¢ Section 2.5, “Discovering Registered VM Hosts,” on page 23

*

Section 2.6, “Discovering VMs of the Registered VM Hosts,” on page 24

*

Section 2.7, “Registering VMs,” on page 24

Installing the VM Client

The VM Client program is installed on your Windows or Linux administration machines. The
interface is an Eclipse-based rich client environment designed to allow you to create and manage
virtual machines (VMs).

To install the VM Client, first fulfill the minimum requirements, then select the installation platform:

¢ Section 2.1.1, “Minimum Installation Requirements,” on page 13
¢ Section 2.1.2, “Installing the VM Client on the Windows Operating System,” on page 15

¢ Section 2.1.3, “Installing the VM Client in a Linux Environment,” on page 15

Minimum Installation Requirements

To install the VM Client software, you must meet the following requirements:

¢ “Host Servers for VM Repositories” on page 13
¢ “Workstations for Running the VM Client Software” on page 14

¢ “Uninstallation of Previous Versions of the Client” on page 14

Host Servers for VM Repositories

The VM Client operates in conjunction with the Cloud Manager Orchestration Server software,
which provides the grid environment for creating, storing, and using VMs. For information on
installing Orchestration Console for management of Orchestration Servers, see “Installing the
Console and Clients on Windows” or “Installing the Console and Clients on a SLES Server”in the
NetIQ Cloud Manager 2.1 Orchestration Installation Guide.

Getting Started 13



Workstations for Running the VM Client Software

The following table contains a list of operating system, hardware requirements, and installation file
paths for the VM Client. The installed program execution file is found in the ISO in the indicated
folder.

Table 2-1 Workstation Installation Constraints

. Recommended . .
Operating System Hardware Installation File
Windows XP, + (386 (32-bit) and 64- cd image\Windows\vmclient install.exe
Windows Vista, and bit o di )  the following i
wind 7 where cd_image is one of the following images:
Incows + 240 MB of free
space + NetlQ_Cloud_Manager-2.0.0-SLE10.i386.is0

+ NetlQ_Cloud_Manager-2.0.0-SLE10.x86_64.iso
+ NetlQ_Cloud_Manager-2.0.0-SLE11.i386.iso
+ NetlQ_Cloud_Manager-2.0.0-SLE11.x86_64.iso

SLED/SLES 10 SP3 * i386 (32-bit) and 64- cd image/slel0/SLE10/vmclient install

and bit
where cd_image is one of the following images:
SLED/SLES 10 + 257 MB of free
SP34 space + NetlQ_Cloud_Manager-2.0.0-SLE10.i386.iso
+ NetlQ_Cloud_Manager-2.0.0-SLE10.x86_64.iso
SLED/SLES 11 * i386 (32-bit) and 64- cd image/SLE1l/vmclient install
bit
where cd_image is one of the following images:
+ 257 MB of free
space + NetlQ_Cloud_Manager-2.0.0-SLE11.i386.iso

* NetlQ_Cloud_Manager-2.0.0-SLE11.x86_64.iso

Uninstallation of Previous Versions of the Client

You must uninstall the previous version of VM Client before installing version 2.6:

¢ Windows: On the Windows machine where the client is installed, click Start > Settings > Control
Panel > Add or Remove Programs, select Cloud Manager VM Client 3.0, then click Remove.

¢ Linux: Run the following command:

/opt/novell/zenworks/vmmanagement /Uninstall ZENworks VMM/
Uninstall Novell ZENworks VM Manager 2.5

This opens the InstallAnyWhere utility to uninstall the VM Client.

14 NetlQ Cloud Manager 2.1 VM Client Guide and Reference



2.1.2 Installing the VM Client on the Windows Operating System

These installation steps apply only to Windows 7, Windows Vista, and Windows XP.

1

Copy the vmclient_install.exe file from the \Windows folder (see Table 2-1 on page 14) to a
location on your management Windows workstation.

Double-click the vimclient _install.exe file to start the installation program:

3 Click Next on the Introduction page to display the License Agreement page:

10

11
12

Read the terms of the license agreement; if you agree to abide by the terms, select the I accept the
terms of the License Agreement option, then click Next to display the Important Information page;
otherwise, click Cancel to exit the installation:

After reviewing the third-party licenses, if you agree with them, click Next to display the Choose
Install Folder page; otherwise, click Cancel to exit the installation:

Select your installation folder, then click Next to display the Choose Shortcut Folder page:

Select a shortcut folder and any other options and groupings you want for the control of this
interface, then click Next to display the Supported Hardware Platforms page:

Click Next to display the Pre-Installation Summary page:

Verify the information and click Previous as necessary to make changes.
When ready, click Install to begin the installation:

When the installation has completed, the Install Complete page is displayed:
Click Done to finish the installation.

For some necessary setup tasks, continue with Chapter 5, “Managing Virtual Machines,” on
page 83.

2.1.3 Installing the VM Client in a Linux Environment

1
2
3

Copy the Cloud Manager 2.0 product ISO file to your management Linux workstation.
Open a terminal on the workstation and log in as root.

Mount the Cloud Manager 2.0 product ISO file to a temporary directory.

For example, if you copied the 32-bit version of the SLES 11 ISO file to Desktop, enter the

following commands:

mkdir /mnt/iso

cd /Desktop

mount -o loop Novell Cloud Manager-2.0.0-SLE11.i386.iso /mnt/iso
cd /mnt/iso/SLE11l

Getting Started 15
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From the /mnt/iso/SLE11 directory, enter . /vmclient_install to launch the installer:

5 Click Next on the Introduction page to display the License Agreement page:

10
11
12

13
14

Read the terms of the license agreement; if you agree to abide by the terms, select the I accept the
terms of the License Agreement option, then click Next to display the Important Information page;
otherwise, click Cancel to exit the installation:

After reviewing the third-party licenses, if you agree with them, click Next to display the Choose
Install Folder page; otherwise, click Cancel to exit the installation:

Select your installation folder, then click Next to display the Choose Desktop Launcher Folder
page:

Select a shortcut folder and any other options and groupings you want for the control of this
interface, then click Next to display the Supported Hardware Platforms page:

Click Next to display the Pre-Installation Summary page:

Verify the information and click Previous as necessary to make changes.
When ready, click Install to begin the installation:

When the installation has completed, the Install Complete page is displayed:
Click Done to finish the installation.

For some necessary setup tasks, continue with Chapter 5, “Managing Virtual Machines,” on
page 83.

2.2 Starting and Logging In to the VM Client Interface

You can run the VM Client on both Windows and Linux workstations:

*

*

221

1

Section 2.2.1, “Starting the Interface on a Windows Workstation,” on page 16

Section 2.2.2, “Starting the Interface on a Linux Workstation,” on page 19

Starting the Interface on a Windows Workstation

On your Windows workstation, double-click the VM Client icon (#) on your desktop to open the
interface.

If you do not have the icon, the executable’s location is determined by where you installed the
VM Client software. The default is C: \Program Files\Orchestrate VM Client
2.6\bin\vmclient .bat.

For information on multiple VM operators logging in to the VM Client, see Section 3.2.1,
“Multiple VM Operator Logins,” on page 36.

NetlQ Cloud Manager 2.1 VM Client Guide and Reference



The first time you start the VM Client, the following Welcome page is displayed:

i PlateSpin Orchestrate VM Client

EEX

ELE EDIT ACTIONS VIEW HELP

Welcome

PlateSpin. Orchestrate
VM Client
Managing the entire VM life cycle

O @

Overview Latest Features Manage Your VMs

N

For comments and suggestions E-mail to vmmanager@novell.com

| " NotConnected | 18 version Info | Show/Hide Progress View

The Welcome page does not display the next time you log in to the VM Client.
The Welcome page can be accessed at any time by clicking View > Show Welcome Page.

For more information, see Section 3.1, “Understanding and Navigating the Welcome Page,” on
page 28.

Getting Started 17
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2 To close the Welcome page, click Manage Your VMs to display the following login dialog box:

£ VM Client Login M =13

The PlateSpin Orchestrate ¥YM Client needs aredentials to access
network-based resources and services.
Pleasze log in.

password: [

'E' The Server field cannot be empty.

3 Specify the IP address or DNS name of an Orchestration Server.

The Orchestration Server is associated with a virtualization grid, which can be associated with
registered VM host servers. Therefore, logging in to one of the Orchestration Servers allows you
to manage all VMs in the datagrid.

4 Enter a username and password to authenticate you as the administrator of the Orchestration
Server, then click Login to view the VM Client interface:

£ PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HAP

Inventory Virtual Machines

S IEEE |

Host Servers

Storage

Status Notes

This example shows how the interface looks the first time anyone logs in to the VM Client.

5 (Conditional) If this is the first time that anyone has logged in to the VM Client, continue with
Section 2.4, “Registering VM Hosts,” on page 22 to set up the virtualization environment.

NetlQ Cloud Manager 2.1 VM Client Guide and Reference



2.2.2  Starting the Interface on a Linux Workstation

1 On your Linux workstation, open a command terminal, change to the /opt /novell/zenworks/
vmmanagement /bin/ directory (the default installation location), or to wherever you installed
the client, then enter the following command:

./vmclient.sh

For information on multiple VM operators logging in to the VM Client, see Section 3.2.1,
“Multiple VM Operator Logins,” on page 36.

The first time you start the VM Client, the following Welcome page is displayed:

PlateSpin/@rchestrate VM Client

FILE EDIT  ACTIONS  VIEW  HELP

Welcome

PlateSpin. Orchestrate
VM Client

Managing the entire VM life cycle

Overview Latest Features Manage Your VMs
N For comments and suggestions E-mail to
vmmanager@novell.com

24 Mot Connected | 18 Version Info | ShowHide Progress View

The Welcome page does not display the next time you log in to the VM Client.

The Welcome page can be accessed at any time by clicking View > Show Welcome Page.

For more information, see Section 3.1, “Understanding and Navigating the Welcome Page,” on
page 28.
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2 To close the Welcome page, click Manage Your VMs to display the login dialog box:

VM Client Login

The PlateSpin Orchestrate VM Client needs credentials to acc
network-based resources and services.
Please log in.

Server:

User ID:

Password:

The Server field cannot be empty.

3 Specify the IP address or DNS name of a Orchestration Server.

The Orchestration Server is associated with a virtualization grid, which can be associated with
registered VM host servers. Therefore, logging in to an Orchestration Server allows you to
manage all VMs in the grid.

4 Enter a username and password to authenticate you as the administrator of the Orchestration
Server, then click Login to view the VM Client interface:

PlateS pin @rchestrate VM Client

EILE  EDIT  ACTIONS  VIEW HELP

Inventory Virtual Machines
F  Host Servers
Storage

Templates Status Notes

Login successful. Connected to server: 137.65.167.241 & Orchestrate | 1M Version Info | Show/Hide Progress View

5 (Conditional) If this is the first time that anyone has logged in to the VM Client, continue with
Section 2.4, “Registering VM Hosts,” on page 22 to set up the virtualization environment.
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2.3 Logging In to Another Virtualization Grid

You can log in to a different Orchestration Server at any time for access to a different virtualization
grid. However, you cannot be logged in to multiple Orchestration Servers. If you log in to another
Orchestration Server, the previous login is replaced.

For information on multiple VM operators logging in to the VM Client, see Section 3.2.1, “Multiple
VM Operator Logins,” on page 36.

1 In the VM Client, click File > Log In.

£ VM Client Login (=13

The PlateSpin Orchestrate YM Client needs credentials to access
network-based resources and services.
Please log in.

Server.

user 10: [
password: [

'E' The Server field cannot be empty.

T e

If you are already logged in to a virtualization grid, you can press Ctrl+Shift+I to log in to a
different datagrid.

2 Fill in the fields:

Server: Specify either the DNS name or IP address of the Orchestration Server.

User ID: Specify a username that has admin rights on the server.
Password: Specify this user’s password.

3 Click Login.
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2.4 Registering VM Hosts

After being installed on a computing node, having its credentials defined, and associating itself with
the computing node, the Orchestration Agent begins broadcasting the availability of its host as a
potential computing resource. A host is defined as a machine running a supported hypervisor agent.

However, before the Orchestration Server can allow an agent to authenticate and establish ongoing
communication, you need to create a resource account for the agent on the Orchestration Server.
When this account is created or “registered,” the agent’s host node can be discovered and recognized
as a computing resource that can perform the jobs assigned to it. In the Orchestration Console, you
can choose to automatically or manually register a VM host server to the Orchestration Server by
configuring the Auto Register Agents option (the Resources panel in the Authentication tab of the
datagrid). If you choose to manually register to the Orchestration Server, the unregistered VM host
servers are displayed in the VM Client. These hosts might or might not have a supported hypervisor
installed and running on them.

To register the VM host servers:

1 Inthe VM Client, click Host Servers in the Inventory panel:

£ PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Discovered [ 1]
Virtual Machines (=] (@] (0] (=]
~ Host Servers

Discovered [1]

¥ Storage

Status Active V... | Notes

u 0
Templates

& Orchestrate | T VersionInfo | Show/Hide Progress Vie

Discovered (#) is displayed below Host Servers, where # represents the number of host servers that
are waiting to be registered with the Orchestration Server.

2 Click Discovered (#) to display the unregistered host servers in the details section on the right.

You can accept (see Step 3) or reject (see Step 4) any of the listed host servers. The host servers
that you accept become part of your virtualization grid.

3 Accept an unregistered host server in one of the following ways:

button.

* Select the server in the details view, then click the
¢ Right-click the server in the details view, then select Accept.

¢ Select the server in the details view, then click Actions > Accept.
£ PlateSpin Orchestrate VM Client

EILE EDIT ACTIONS VIEW HELP

Inventory Discovered [ 1]
Virtual Machines (=] [(a] (0] (=]
~ Host Servers

Discovered [1]

»  Storage

Status | Active V.. | Notes Technology

|} 0
Templates

8 Orchestrate | T versionInfo | S
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2.5

You can choose to register multiple host servers at a time.

After the host server has been registered with the Orchestration Server, it is listed with its
operating system.

If the host server does not become registered after a few minutes, run the Discover Hosts job from
the Action menu.

4 (Optional) To reject the registration of a host server, do one of the following;:

button.

* Select the server in the details view, then click the

¢ Right-click the server in the details view, then select Reject.

¢ Select the server in the details view, then click Actions > Reject.
The unregistered server is removed from the Host Servers.

The next time that an unregistered host server attempts to register to the Orchestration Server,
the rejected servers are again listed as candidates for acceptance into the virtualization grid.

5 Click the Storage view.

The only repositories shown are ZOS and the host’s local repository. ZOS is the shared datagrid
repository for all hosts to use in storing templates. For information on repositories, see

Chapter 6, “Managing Repositories,” on page 135. For information on templates, see Chapter 7,
“Managing Templates,” on page 149.

6 To discover whether there are other VM hosts in the datagrid, continue with Section 2.5,
“Discovering Registered VM Hosts,” on page 23.

Discovering Registered VM Hosts

When you first install the VM Client, it is not aware of all of the possible registered VM hosts in the
virtualization grid that you log in to. The discovery process finds all hosts that have a supported
hypervisor installed and running on them.

You should discover these hosts before continuing to use the product. You should discover hosts
before attempting to discover VMs so that any VMs belonging to a particular host can be discovered.

Before discovering the VMware technology-based hosts, ensure that the appropriate policies have
been configured in the Orchestration Console. For more information on configuring the policies, see
“Orchestration Provisioning Adapter Information” in the NetIQ Cloud Manager 2.1 VM Orchestration
Reference.

To discover the existing registered VM hosts:

1 In the VM Client, click Actions > Discover Hosts.

£ PlateSpin Orchestrate VM Client

EILE EDIT ACTIONS VIEW HELP

Inventory Discovered [ 1]
Virtual Machines (=] [(a] (0] (=]
~ Host Servers

Discovered [1]

»  Storage

Status | Active V.. | Notes Technology

|} 0
Templates

8 Orchestrate | T versionInfo | S
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2.6

2.7

All the registered VM hosts that are in the virtualization grid and that have hypervisors installed
are displayed.

2 To discover any VMs belonging to the VM hosts that you discovered, continue with Section 2.6,
“Discovering VMs of the Registered VM Hosts,” on page 24.

Discovering VMs of the Registered VM Hosts

You can use the VMs you have previously created or the VMs you have built by using other
hypervisors in your data center. To make use of these VMs, you need to run a discover job. You use
the VM Client to detect the VMware ESX, Microsoft Hyper-V, VMware Server, VMware Virtual
Center, and SUSE Xen VM host machines. After you have detected the host machines, you can detect
the VMs contained on the host machines and in other VM storage repositories.

The only VMs that are automatically discovered are those that are stored in the default location of /
var/lib/xen/images, unless an Orchestration repository is created that represents an alternative
storage location.

Before discovering the VMware technology-based VMs, ensure that the appropriate policies have
been configured in the Orchestration Console. For more information on configuring the policies, see
“Orchestration Provisioning Adapter Information” in the NetIQ Cloud Manager 2.1 VM Orchestration
Reference.

To discover the VMs belonging to the registered VM Hosts:

1 In the VM Client, click Actions > Discover Virtual Machines.
2 To accept the discovered VMs, continue with Section 2.7, “Registering VMs,” on page 24.

Registering VMs

If you install the Orchestration Agent on a VM, it must then be registered (accepted) in order to be
managed in the VM Client.

In the Orchestration Console, you can choose to automatically or manually register a VM to the
Orchestration Server by configuring the Auto Register Agents option (the Resources panel in the
Authentication tab of the datagrid). If you choose to manually register to the Orchestration Server, the
unregistered VMs are displayed in the VM Client in the Discovered (#) group.

NetlQ Cloud Manager 2.1 VM Client Guide and Reference



To register a VM:

1 In the VM Client, double-click the Virtual Machines view.

L PlateSpin Orchestrate VM Client |Z||E|fz|

FILE EDIT ACTICNS WIE HELP

Inventory Virtual Machines

v Virtual Machines EEm® |

Discovered [1]

¢ Host Servers

Hame
RedHat5-32bit
SLES10SP1_64bit

windows2008

Status
|
|
|

Hotes 05

F  Storage

UInknown
F Templates

Unknown

Unknown

® Orchestrate | 8 Yersion Info |

Discovered (#) is displayed below Virtual Machines, where # represents the number of VMs that
are waiting to be registered with the Orchestration Server.

2 Click Discovered (#) to display the unregistered VMs in the details section on the right.

You can accept (see Step 3) or reject (see Step 4) any of the listed VMs that were discovered. The

VMs that you accept become part of your virtualization grid.
3 Accept a discovered VM in one of the following ways:

* Select the VM in the details view, then click the button.

¢ Right-click the VM in the details view, then select Accept.
¢ Select the VM in the details view, then click Actions > Accept.
You can choose to register multiple VMs at a time.

After a VM has been registered, it is listed with its operating system.

It can take a few minutes for this acceptance process to be completed. Do not proceed with using

the VMs until the acceptance process is complete.
4 (Optional) To reject a VM, do one of the following;:
+ Select the VM in the details view, then click the IES==8 button.
¢ Right-click the VM in the details view, then select Reject.
¢ Select the VM in the details view, then click Actions > Reject.
The unregistered VM is removed from the Virtual Machines list.

The next time that an unregistered VM attempts to register to the Orchestration Server, the
rejected VMs are again listed as candidates for acceptance into the datagrid.

If the VM is running, you can tell whether a VM has the Orchestration Agent installed on it by
whether there are pie charts in its CPU and Memory columns.

Getting Started
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Understanding the VM Client Interface

The Cloud Manager VM Client interface, built on an Eclipse-based rich client platform, uses a
graphical user interface (GUI) to help you create, store, edit, and use VMs. This interface can be
installed on both Windows and Linux administration devices.

Review the following sections for tips on navigating and using the VM Client interface:

*

*

*

Section 3.1, “Understanding and Navigating the Welcome Page,” on page 28
Section 3.2, “Understanding the VM Client Window,” on page 35

Section 3.3, “Using the Error Log,” on page 59

Section 3.4, “Using the Progress View,” on page 63

Section 3.5, “Resetting the VM Client Perspectives,” on page 64

Section 3.6, “Changing the VM Client Theme,” on page 65

Understanding the VM Client Interface
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3.1 Understanding and Navigating the Welcome Page

The Welcome page provides basic information on the VM Client. By default, it is displayed when you
first open the VM Client. Thereafter, you can access the Welcome page using View > Show Welcome
Page.

Figure 3-1 The VM Client Welcome Page

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Welcome

PlateSpin. Orchestrate
VM Client

Managing the entire VM life cycle

Overview Latest Features Manage Your VMs

N For comments and suggestions E-mail to vmmanager@novell.com

| " NotConnected | 18 yersion Info | Show/Hide Progress View

Starting the VM Client from your desktop icon or the program’s executable does not automatically
log you in to the VM Client. This Welcome Page is available without authenticating.

To authenticate, click the Manage Your VMs button on the Welcome page to open the VM Client Login
dialog box.

The Eclipse-based VM Client GUI allows you to detach any section from the main VM Client
window. For example, you can click within the Welcome page and drag it to another location on your
desktop. This can also be done with various other sections in the VM Client, such as the Progress View

and Error Log sections.

The VM Client window is resizable, as are any sections that can be dragged out of the VM Client
window. Sections can also be resized within the full VM Client window.

28 NetlQ Cloud Manager 2.1 VM Client Guide and Reference



311

Review the following sections for other navigation tips:

*

*

Section 3.1.1, “Welcome Page Main Menu Options,” on page 29
Section 3.1.2, “Welcome Page Buttons,” on page 33

Welcome Page Main Menu Options

The main VM Client menu options are available at the top of the Welcome page, but only those that

are applicable are enabled:

*

File > Exit: Closes the VM Client interface.

Closing the VM Client interface does not affect the status of any VMs, meaning that the VMs that

have processes running, such as cloning, starting, moving, and so on, continue to run those
processes. These processes are jobs that are being run on the servers hosting the VMs.

View > Show Welcome Page: Displays the Welcome page.

View > Show Inventory Views: Displays the Inventory panel. For more information, see Section 3.2,

“Understanding the VM Client Window,” on page 35.
View > Change Theme: Opens the Change Theme dialog box, where you can change the VM

Client’s appearance. For more information, see Section 3.6, “Changing the VM Client Theme,”

on page 65.
Help > Version Information: Opens the following dialog box:

¥ Version Compatibility Information |:|@@

&k The following version information has been obtained and chedked for compatibility.
rl-. Hover over a row for details.

WM Client Yersion Status
PlateSpin Orchestrate WM Client 2.0, 2. qualifier @ VM Client needs upgrade

Server Version
137.65,167. 241 2.0.2_J0528

Warning: Using PlateSpin Orchestrate YM Client with version incompatibilities might result in
application errars.

Understanding the VM Client Interface
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This provides software compatibility information that you might need to know when the
software is not working correctly.

To view more details for an entry, mouse over its row:

¥ Version Compatibility Information |Z|@@

sion information has been obtained and chedked for compatibility.
w for details.

WM Client Yersion Status

PlateSpin Orchestrate Wi Clisnt 20 7 nualifier 3  wM Client neads upgrade
Version Source:

Bundle-version fram:
Plugin: com,novell. vnos
Edipse RCP Application: PlateSpin Crchestrate YM Client
WM Client 205 library version: 2.0.2 65339

Server Version
137.65.167. 241 2.0,2_70528

Warning: Using PlateSpin Orchestrate VM Client with wersion incompatibilities might result in
application errars.

¢ Help > Readme: Opens the product Readme in your default Web browser.

¢ Help > VM Client Reference and Guide: Opens the product documentation for the VM Client in
your default Web browser.

¢ Help > How to Use This Guide: Opens a section of the product documentation in your default Web
browser and provides a list of things you can do in the VM Client. The list is ordered in a tutorial
fashion.

¢ Help > Index: Opens a quick index to hard-to-find VM Client information in your default Web
browser.
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¢ Help > About Cloud Manager VM Client: Displays the following dialog box:

£ PplateSpin Orchestrate YM Client

PlateSpin Orchestrate ¥M Client
Please send all product inquiries and recommendations to
vmmanager @novell. com

Wersion: 2.0.2.qualifier
Build id:

PlateSpins
Copyright {c) 2003-2009, Novell, Inc, All rights reserved.
Orchestrate Visit htto: . novel, com
This product indudes software developed by
IBM Corp. using the Edipse platform - (all rights reserved) and the
Apache Software Foundation hitp: /fwww.apache.org

Maovell is an Edipse Foundation Member

I:Cu nfiguration Delails
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The Configuration Details button opens the following dialog box where you can copy the text-
based configuration information to your operating system’s clipboard for further use.

i Configuration Details

*=% Date: Tuesday, June 2, 2009 11:59;59 AM MT
== Platform Details:

=% System properties:

ACTIVE_PART _ID=com.novel.vnos. editors, VMListEditor
COMNECTION_TYPE=Z0SCommunicator
CURRENT_EDITOR_IMPUT=null
CURRENT_EDITOR_IMPUT_LIST TYPE=VirtualMachineList
CURREMT_EDITOR_IMPUT _TYPE=RootInvGroupMode
YMM_IS_COMMECTED =true

awt. toolkit=sun.awt windows. WToolkit

edipse. commands=-auncher
C:\WMM_Development\edipse3. 4\edipse. exe

-Mame

Edipse

-showsplash

600

-product

com.novell, vnos. product

-data

C:\WMM_Developmentiworkspace/. . fedipse 3. 4fruntime-vmm
-configuration

file:C: VMM _Development/workspace/.metadata/. plugins forg. edipse. pde. core VMM product/
-dey

file:C: VMM _Development/workspace/.metadata/. pluginsforg. edipse. pde. core VMM product/dev. properties
-0s

win32

-NE

win32

-arch

edipse.ee.install, verify=falze

edipse.home. location=file: /C: /VMM_Development edipse3. 4/
edipse.launcher=C:\WMM_Development'edipse3. \edipse.exe
edipse.p2.data.area=@config.dir'p2

edipse.pde.launch=true

edipze. product=com.novel.vnos. product

edipse. startTime=1243564193455

file.encoding=Cp 1252

file.encoding. pkg=sun.io

file.separator =Y,

java.awt.graphicseny =sun.awt. Win32GraphicsEnvironment

java.awt. printerjob=sun.awt. windows. \WPrinter Job
java.dass.path=C:\WMM_Developmentiedipse 3. 4'plugins\org.edipse. eguinox. launcher 1.0, 100,+20080502-1800.5:
java.dass. version=50.0
java.endorsed.dirs=C:\WMM_Developmentijdk1.6.0_0&Yrelib\endorsed

< |

| Copy to Cliphoard
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3.1.2 Welcome Page Buttons

The following buttons are available on the Welcome page:

¢ “Overview” on page 33
¢ “Latest Features” on page 34

¢ “Manage Your VMs” on page 35

Overview

The Overview button provides the following information:

Figure 3-2 Welcome Page Overview

il plateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Welcome

ﬁn Overview WOLWe

PlateSpin® Orchestrate VM Client is a tool that Home

- administrators and architects use to manage Overview
the life cycle of the virtual machines in their Latest Features
enterprise. PlateSpin Orchestrate lets you Manage Your VMs

better align IT to your business, control costs,
and minimize risks across all VM platforms in
the data center.

N PlateSpin Orchestrate VM Client Basics
Learn about what VM Client does, its target
user, and its benefits.

N PlateSpin Orchestrate Overview
New to PlateSpin Orchestrate? Get a quick
overview of PlateSpin Orchestrate and its
functionality.

| @ Orchestrate | 8 version Info | Show/Hide Progr

To navigate to the other locations on the Welcome page, you can use the links in the upper right of the
Overview page.
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Latest Features
The Latest Features button provides the following information:

Figure 3-3 Welcome Page Latest Features

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Welcome

Latest Features WOOLe

Here are the latest features of PlateSpin® Home_
Orchestrate VM Client. With the PlateSpin Overview
Orchestrate VM Client, you can increase the Latest Features

functionality of your data center by fully Manage Your VMs
leveraging VMs as a usable resource. You gain
the following abilities:

« Manage VMs on several different
virtualization host types, including SLES
Xen, VMware ESX Server, and Microsoft
Windows Server 2008 with Hyper-V

« Manage the complete life cycle of Vms,
including creating, starting, stopping,
migrating, and deleting

« Edit VM definitions

« Get quick access to monitoring data about
each managed node in your data center

| & Orchestrate | 18 yersion Info | Show/Hide Progress View
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Manage Your VMs

The Manage Your VMs button opens the VM Client Login dialog box:

Figure 3-4 The VM Client Login Dialog Box

£ VM Client Login M =13

The PlateSpin Orchestrate VM Client needs credentials to access
network-based resources and services,
Please log in.

Server:
userD: [
password: [

s

For more information on logging in to the VM Client, see Section 2.3, “Logging In to Another
Virtualization Grid,” on page 21.

3.2 Understanding the VM Client Window

Review the following sections for an understanding of the VM Client window:

¢ Section 3.2.1, “Multiple VM Operator Logins,” on page 36

¢ Section 3.2.2, “Customizing the VM Client Sections,” on page 37
¢ Section 3.2.3, “Navigating the VM Client Window,” on page 40

¢ Section 3.2.4, “Sorting, Searching, and Filtering Lists,” on page 51

¢ Section 3.2.5, “Viewing Additional Information in Fields or Cells,” on page 57

Understanding the VM Client Interface
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3.2.1

Multiple VM Operator Logins

Multiple VM operators can each be running an instance of the VM Client that is logged in to the same
VM virtualization grid. In other words, multiple VM operators can simultaneously manage the VMs
on a particular virtualization grid. When any VM operator performs an action against a VM Client
object, all VM Clients that are opened to that virtualization grid are updated accordingly.

Because multiple VM operators can be performing actions independently of each other, the VM
Client interface automatically updates the appropriate locations in its window, such as displaying a
new VM in everyone’s VM Client when it is created by one VM operator.

Various functions in the VM Client have set polling intervals for displaying new information. These
polling intervals determine how quickly one VM operator’s VM Client instance shows another VM
operator’s actions. For example, starting a VM displays that action in the Progress View section in just
a few seconds, while it might take up to 30 seconds to show the start action for the VM in the other
VM operators’ Virtual Machines list.

For information on creating multiple login IDs for VM operators, see Appendix D, “Adding User
Logins for VM Operators,” on page 201.
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3.2.2 Customizing the VM Client Sections

You can do several things to customize the sections in the VM Client. Any changes you make are
remembered the next time you start the VM Client.

¢ Tiling: Multiple editors can be open at the same time. Select the status bar of an editor and drag
it to a different position in the VM Client window to create the tiling effect. This can provide
quicker access when you revisit an editor. For example:

£ plateSpin Orchestrate VM Client

ELE EDIT A VIEW HELP

Inventory Virtual Machines

Virtual Machines E3)

~ Host Servers

Discovered [1]

Name Status a5
32bitc1 u SUSE Linux Enterprise
32bitTemplate
MyPXE
RHat-C1

Notes
« Storage

xen3d

SUSE Linux Enterprise

Templates SUSE Linux Enterprise

Other operating syste
RHat-T1
RHEL5
sled10-32bit

Other operating syste
Other operating syste
Other operating syste
SLES32bit SUSE Linux Enterprise
slesfdbit SUSE Linux Enterprise
sles1032-test SUSE Linux Enterprise

sles1032bit-2 SUSE Linux Enterprise

test-32bit SUSE Linux Enterprise

Error Log - Workspace Log

e fier exd]

Message Plug-in
@ Could not locate the running profile instance org.edipse.equinox.p2.ui.sdk 2009-06-02 11:36:56.923

Progress View

Object Name Action Status User Elapsed Time % Complete

| T VersionInfo | Show/Hide Progre:
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¢ Maximizing Views: You can maximize a details tab view by double-clicking the VM or host
server’s name that is located just above the buttons. For example, click here:

‘il plateSpin Orchestrate VM Client
FILE EDIT ACTIONS

Inventory i SLES32 [Running]

= \firtual Machines

MNotes

10

CPU
~ Host Servers

Discovered [1] Memory

¢ Storage

Templates Type Datastore Capacity MAC Address NIC Type

Hard Disk O5disk 8GB 0o rtuali

| 1 Version Info | Show/Hide Progress View

to display:
il PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW

f SLES32bit [Running]

Summary Manitoring

erver 10

® nja ® N
® N2 ® N

Type Datastore Capacdity MAC Address MNIC Type

Hard Disk OSdisk 8GB 00: 1 3 Paravirtualized

| 18 VersionInfo | Show/Hide Progress View

To return to the previous unmaximized view, double-click the VM or host server’s name again.
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You can also maximize or minimize the Progress View or Error Log sections by double-clicking in
the white area next to the Error Log or Progress View section’s title:

£ PlateSpin Orchestrate VM Client

ELE EDIT

(Workspace Log

Error Log - Workspace Log

=s—— Double-click in this area ——M88M8M8M™M==

type filter text] |
Message Plug-in Date
& Could not locate the running profile instance org.edipse.equinox.p2.ui.sdk 2009-06-02 11:36:56.923

¢ Dragging: You can drag sections (such as Progress View or Error Log) out of the VM Client
window to another position on your desktop. You can also drag sections to different locations
within the VM Client window. For example, the following illustrates that the Error Log section
has been dragged outside of the VM Client window:

Error Log - Workspace Log

[Workspace Log

lvoe fitertexd] |
Message Plug-in Date
& Could not locate the running profile instance org.edipse.equinox.p2.ui.sdk 2009-04-21 14:37:54. 187

EDIm

Inventory

1]

Storage

Templates

Virtual Machines

b Host Servers

VIEW  HER

Virtual Ma

Status Notes Host os CPU Memory
v SUSE Linux Enterprise Sen
evdl v SUSE Linux Enterprise Sen
evd1 - uidevs Unknown
Hew Virtual Machine - Windows_Server_20 Unknown

OpenSuseil v opensSUSE 11
ric1 [ 2 uidevd SUSE Linux Enterprise Sen
ric2 [ 2 uidevi SUSE Linux Enterprise Sen

3
i
4l

SUSE Linux Enterprise Ser

SLED11 v SUSE Linux Enterprise Ser
Sles10sp2 [ 2 Windows_Server_20 Unknown
sles11.1 ] Unknown
Progress View
Object Name Action Status User Elapsed Time % Complete

| & Orchestrate | 1l v

sionInfo |
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3.2.3

To move sections around, click in the white area and drag the section to its new location, either
within the VM Client window, or outside of it:

Progress View

Object Hame Action Status User Elapsed Time % Complete

Click here to drag back into the VM Client window

You can close a view that has been dragged outside of the main VM Client window by clicking
the (3 in the upper-right corner of the window. To close a view that is contained within the VM
Client window, click View > Close Progress View or click View > Close Error Log.

Returning to Defaults: To reset any changes that you have made to the positions of sections,
click View > Reset Perspective, which returns everything to the default organization of the VM

Client window.

+ Keystrokes and Mouse Clicks: The following functions are available in the VM Client:

Function Action

Minimize or maximize of a section + Double-click the status bar

in the VM Client window
+ Press the Spacebar or Enter key

+ Press the Left-arrow or Right-arrow key

Go to the next or previous node * Press the Left-arrow or Right-arrow key

Go to the next or previous sibling ¢ Press the Tab or Shift+Tab keys

node

Open further details on a clickable * Double-click a details item, such as a line in the Event

details item Log tab that has the [i]icon, to view further details on the
event entry.

NOTE: When you make a change to a field in the VM Client, then exit the field by pressing Enter or
changing focus to another field or option, the change made to the field is automatically saved. This is
different from the Orchestration Console, where you must click File > Save to retain changes to fields.

Navigating the VM Client Window

Review the following to understand the two main VM Client views:

¢ “Inventory Lists” on page 41

¢ “Inventory Details” on page 49

For information on the Progress View and Error Log sections, see Section 3.4, “Using the Progress
View,” on page 63 and Section 3.3, “Using the Error Log,” on page 59.
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Inventory Lists

When you first log in to the VM Client, the following view is displayed:

Figure 3-5 The VM Client Inventory Panel - Initial View

il PlateSpin Orchestrate VM Client

ACTIOMS VIEW HELP

Inventory Virtual Machines
FEO® |
Host Servers

Storage
Status Notes

| " NotConnected | 18 yersion Info | Show/Hide Progre

The Inventory panel on the left contains four links in its navigation area:

* Virtual Machines
* Host Servers
¢ Storage

¢ Templates

Each of these four links lists the available items, such as known VMs, known host servers, known
repositories, and any templates that you have created from the VMs. By default, the Virtual Machines
list is initially displayed when you log in.

When you double-click an item in a list, its details tabs are displayed (see “Inventory Details” on
page 49), usually with the Summary tab selected. However, if you click an item that has one of the
following states, its Event Log tab is selected instead:

¢ In progress (« icon). This icon represents that an action is currently ongoing, such as those
described in Section 5.3, “Virtual Machine Actions,” on page 98.
¢ Installing (= icon). Used to indicate that a VM is being installed.

¢ Unknown (7 icon). Indicates that the VM Client and Orchestration Server are out of sync, so that
the VM’s state is unknown. You need to resynchronize the VM.
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The following describes the various features of the VM Client window:

¢ Inventory item’s title area: This area provides information for what is being viewed, including

an icon to indicate which type of resource is being viewed, and square brackets to indicate any
action or viewing condition that is in effect. For example, the following indicates where the
Inventory item’s title area is located:

i' PlateSpin Orchestrate YM Client

VIEW

Inventory i evdl

= \Virtual Machines

Summary

ik NS DemovM

® na

Memary ® N

Type Datastore

MAC Address NIC Type

Hard Disk 0O5disk 00:16 3:57 Paravirtualized
Host Servers

b Storage
Templates

| & orchestrate | i version Info | ShowHide Progress View

In this case, the H icon indicates that evdl is a VM name, and [Down] indicates its current status.
Other icons that can appear in this title area:

u Host server
E Repository
:'1' Template

If a list is being filtered, [Filtered] is displayed.
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¢ Groups: Each of the four Inventory panel items can have groups listed under them:

Inventory
F Virtual Machines

Host Servers

wendd
hyperv groups

Templates
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icon indicates that one or more groups exist. Click the icon to display the groups. For more
information on using groups, see Chapter 9, “Managing with Groups,” on page 171.

When you first log in to the VM Client, the Virtual Machines or Host Servers sections are
automatically expanded to display a Discovered group if there are newly discovered VMs or host
servers that you have not yet accepted into the virtualization grid. Click the group to show the
candidates in the right panel. For information on managing them, see Section 2.4, “Registering
VM Hosts,” on page 22.

Available Options: For each of the Inventory sections, items listed in the right panel have
various main menu options, right-click menu options, and function buttons displayed, not
displayed, enabled, or disabled according to the item’s status.

£ plateSpin Orchestrate VM Client

ACTIONS VIEW

Inventor

~ Host 5¢
Discc  Move..

Name Status Hotes 05

 Storag " - -
32bitc1 SUSE Linux Enterprise
xen3  ResyncState F5 Java EE Tools » i
32bitTemplate SUSE Linux Enterprise
Delete... Show Details
Temploccs MyPXE SUSE Linux Enterprise

RHat-C1 Start

Other operating syste

RHat-T1
RHELS
B . sled10-32bit
Main Menu Options
SLES32bit
sles6dbit

Other operating syste
Other operating syste
Other operating syste
SUSE Linux Enterprise
SUSE Linux Enterprise
sles1032-test
sles1032bit-2

5USE Linux Enterprise

Edit... SUSE Linux Enterprise

test-32bit Create Template. .. SUSE Linux Enterprise
Resync State
Move...

Right-Click Menu Options

Delete
Install Agent

New VM...

| & Orchestrate | 8 version Info | Show/Hide Progress View

¢ Column Sorting: You can sort the various columns of information alphanumerically. Simply

click a column heading to sort it in ascending or descending order. The .. or - arrows indicate
which column was last sorted and whether it was sorted in ascending or descending order. For
more information, see “Sorting Lists” on page 52.

Logging In/Out: Mouse over the Orchestrate icon to display which host server you are logged in
to:

Connected to 137.65, 167,241 as admin
Double-dick to log out

L _ L
: ol Gl Ll | il e rwgress View

.
® Orchestrate
™
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Double-click the icon to log out of that host server and the VM Client:

¥ Logout

Select connections for logout.

Server

123.45.67.234

Cancel

This option is always available.

¢ Version Information: To access the Version Compatibility dialog box, double-click the Version
Info icon:

1
g-dick to view version information
® Orchestrate | ™ Version Info | ShowHide Progress View
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This is the same dialog box that clicking Help > Version Information accesses:

¥ Version Compatibility Information |Z|@@

k The following version information has been obtained and chedked for compatibility.
L. Hover over a row for details.

WM Client Yersion Status
PlateSpin Orchestrate WM Client 2.0, 2. qualifier @ VM Client needs upgrade

Server Version
137.65.167. 241 2.0,2_70528

Warning: Using PlateSpin Orchestrate VM Client with wersion incompatibilities might result in
application errars.

This option is also available for the Inventory details views.
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Inventory Details

In each of the four Inventory sections you can display detailed information by either double-clicking
an item or right-clicking it and selecting Show Details. For example, double-clicking a VM displays its
details tabs:

Figure 3-6 Virtual Machines Details Tabs

i plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory # 32bitc1 [Down]

= Virtual Machines |?| |?| |T| |T|

32bitTemplate

My

Summary Monitoring Event Log

. [ Gows |
g Groups
RHat-T1 X Enterprise Server 10
RHELS 512MB
led10-32bit

T
m
w
1%

woWw oW o 0

]

W @ m @

da
]
=

ot

® nja
Memory @ nja
/A

~ Host Servers
Discovered [1]

~ Storage
xen30

Templates Type Datastore Capacity MAC Address NIC Type

Hard Disk OSdisk 8GB 00:16:3e:76:ec:03 Paravirtualized

| 18 yersion Info | Show/Hide Progress View

In the Figure 3-6 example, the VMs that were listed to the right of the Inventory panel are now listed
on the left within the panel. The details tabs that are displayed are for the VM that is selected in the
Inventory panel list. This allows you to navigate the details tabs per VM more quickly.

This same functionality exists for the other three Inventory items.
You can easily navigate between the different Inventory types’ details tabs. For example:

¢ While viewing the details of a VM, you can double-click a host server or repository name that is
listed in the first section on the VM’s Summary tab to display the details tabs for the host or
repository instead of the VM’s tabs. The Inventory panel on the left remains unchanged. This
allows you to return to the VM’s details tabs by simply clicking the VM name in the Inventory
panel list.

¢ Conversely, you can view the details of a host server or a repository, then double-click a VM's
name in the details to display the VM’s details tabs. You can return to the host or repository by
simply clicking its name in the Inventory panel list.

You can navigate through the details for each Inventory item by using the tabs, such as those
illustrated in Figure 3-6. Each Inventory type has the Summary and Event Log tabs plus other tabs
particular to its own details.
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Tab viewing is sticky, meaning the last tab that you viewed for an item is displayed again when you
return to that item.

The Event Log tab provides access to details on the status of any jobs that have been run or are
running, no matter which VM operator initiated the action. You can open multiple views for logging
information. Figure 3-7 and Figure 3-8 provide some examples:

Figure 3-7 Event Log Tab with Event Log Dialog Box and Mouse-Over Display of Detailed Information

VIEW HELP

Inventory # sles1032bit-2 [Running]

~  Virtual Machines [ (o] (] N e v Ji
MyPXE
ST Summary Monitoring Eventlog
32bitct

32bitTemplate

Status User Start Time Elapsed .

RHat-C1 © shutdown complete system  2009-06-01 15
RHat-T1 © VM Active (no agent connection) system  2009-06-02 16:44:34 0:00:00:19
RHELS

sled10-32bit
SLES32bit

slesGdbit

il Event Log for action 'Provision’

- ) e Click on an item to additional details.

Time Message

2009/06/02 04:44:3 WM provision/frestore initiated by 'system’
Waiting for vmhost assignment.
VM has been assigned the vmhost: 'da112.provo.novell.com_x sing repository ‘OfficeRepo’

© Provisioning | [provisioning job started to provision vm 'sles 1032hit-2]
WEL LRI start_event requested by 'system' for vmInstance 'sles1032bit-2' on

ot 'da112.provo.novell.com_xen30',

becae Ll da112.provo.novell.com] Mode: start

2005/08, 14453 VEREY=iRG] [d2 112, provo. novell, com] getXenUUID{vm=Domain-0)
da112.provo.novell.com] start{vm=sles 1032hit-2)
da112.provo.novel.com] discoveryMState(vm=sles 1032hit-2)
da112.provo.novell.com] getXenUUID{vm=Domain-0)
da112.provo.novell.com] Getting vm status with xm tool
da112.provo.novell.com] vmstate=down

da112.provo.novell.com] Executing: fusr/sbin/xm new

fum/sles 1032bit-2/config. xen name =sles 1032bit-2 on_crash=destroy
on_poweroff=destroy on_reboot=restart

da112.provo.novell.com] Using config file “fvmsles 1032bit-2/config.xen”,
da112.provo.novell.com] Executing: fusr/shin/xm start sles1032bit-2
da112.provo.novell.com] getVNCPort{vm=sles1032bit-2)
da112.provo.novell.com] getXenUUID{vm=sles1032bit-Z)

| & Orchestrate | 18 yersion Info | Show/Hide Progress
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Figure 3-8 Ewvent Log Tab with Event Log and Event Log Details Dialog Boxes

ACTIONS VIEW HELP

Inventory i sles1032bit-2 [Running]
(o ] Cax RN vicw via Ji[_edic [ Higrate Ji[ Console ]

= \irtual Machines

MyPXE

E itari EventL
sles1032bit-2 Summary Monitoring ventLog
32bitct

32bitTemplate

User Start Time Elapsed ...

RHat-C1

Rzt §1 0 vM Active {no agent connection)
RHELS

sled10-32bit

SLES32bit f' Event Log Details for VM 'sles1032bit-2'

'. g jo . ¥ &' submitted to perform 'Pr

- ) ani etails. [provisioning job started to provision vm 'sles 1032bi
start_event requested by 'system’ for vmInstance 'sles1032 on 'da112,provo.novell.com_
Il.com] Mode: start
Il nUUID (vm

Message ovo. Il:corn] discoverVMState{vm

VM provisionfrestore S

Waiting ft host 2

2 4434 VM has been assigne it-2/config. xen name=sles1032bit-2

2009/06/02 04:44: 34 Provisioning job 'sys 3 vo.no ing 5 -
Waiting for provision o : z

Starting VM.

WM Active (no agent il ] ing VNC for sle: with xm tool

[da112.provo.no

| Copyto Cupbqa'd

| & Orchestrate | 18 yersion Info | Show/Hide Progress Vi

For more information, see “Using Feedback to Manage VMs” on page 87.

For information on using and editing information in each of the details tabs, see the applicable
sections in:

*

Section 4.2, “Viewing and Editing Host Server Details,” on page 69

*

Section 5.1, “Viewing and Editing VM Details,” on page 83

*

Section 6.2, “Viewing and Editing Storage Details,” on page 136

*

Section 7.1, “Viewing and Editing Template Details,” on page 149

Sorting, Searching, and Filtering Lists

You can manage information in the VM Client by using lists in the following ways:

¢ “Sorting Lists” on page 52
¢ “Filtering Lists” on page 54

¢ “Locating Items in a List” on page 55
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Sorting Lists

Any list in the VM Client can be sorted alphanumerically in an ascending or descending order by
clicking the column heading. You can sort rows of information by any column. Most lists default to
sorting alphabetically on the first column. For example:

Figure 3-9 VMs Sorted by Name

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Virtual Machines

Virtual Machines

¥ Host Servers
]

Storage

Templates Name Status Notes Host os CPU Memory
32bitc1 | SUSE Linux Enterprise
32bitTemplate | SUSE Linux Enterprise
MyPXE - ZRE&4bit SUSE Linux Enterprise
RHat-C1 | Other operating syste
RHat-T1 u Other operating syste
RHELS | Other operating syste
sled10-32bit | Other operating syste
SLES32bit | SUSE Linux Enterprise
sles64bit | SUSE Linux Enterprise
sles1032-test | SUSE Linux Enterprise
sles1032bit-2 - da112.provo.nov SUSE Linux Enterprise
test-32bit | SUSE Linux Enterprise

| & Orchestrate | 18 versionInfo | Show/Hide Progress View

VMs, host servers, repositories, and templates are sorted alphanumerically by default. If there are
multiple VM operators and one of them adds new objects to a list, the items are correctly sorted
according to each VM operator’s preference.

For all lists, the most recently sorted column displays its current sort order with an arrow (. or «).
This is per instance of the VM Client; VM operators do not see each others’ sorting changes.
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Sorting in the VM Client provides benefits such as the following;:

+ Technology groups: Sorting is available wherever lists exist in the VM Client. You can sort any
listed information by various technology groups.

¢ Virtual Machines’ Status column: Sorting allows you to group the VMs by their status type
icons in the following order:

I
Status

an) 1|

¢ Virtual Machines’ Host column: Sorting is a quick way to determine which VMs are running or
in a progress state. It also quickly indicates which servers are hosting VMs.

¢ Host Servers’ Active VMs column: Sorting is a quick way to determine the most and least
active host servers.

¢ Host Servers’ CPU or Memory columns: Sorting is a quick way to determine your host servers’
utilization if the Orchestration Agent and Monitoring Agent are installed and running on them.

¢ Storage’s Stored VMs, Type, Capacity, and Free columns: Sorting might help you in selecting
repositories for new VMs, viewing how many repositories you have by type, and determining
which repositories are most or least utilized.

¢ Templates’ # Clones column: Sorting can show which templates have clones when you have
more templates than can be listed in the window.

¢ Templates’ Location column: Sorting can show the location that most templates are using.
+ Templates’ OS column: Sorting helps you to find templates by their defined operating system.

¢ Templates’ Technology column: Sorting shows which technologies are used most by the
templates.

¢ Templates’ CPUs and Memory columns: Sorting orders templates by their capacities.

¢ Event Log’s Action column: Sorting allows you to group actions so that you can more quickly
find a particular action in a long list of actions.

¢ Event Log's Status column: Sorting allows you to more quickly locate a particular status in a
long list of statuses.

¢ Event Log’s User column: Sorting allows you to view log entries by the user who initiated the
actions.

¢ Event Log’s Start Time column: Sorting allows you to view the list from either the latest or
earliest log posts.

¢ Event Log's Elapsed Time column: Sorting makes it easier to locate time-consuming events.
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¢ Progress View section’s Action column: Sorting allows you to group actions so that you can
find a particular action.

¢ Progress View section’s Status column: Sorting allows you to group statuses so that you can
quickly discover problem statuses.

¢ Progress View section’s User column: Sorting makes it easier to discover how many actions are
being initiated by each user.

¢ Progress View section’s Elapsed Time column: Sorting helps you to discover actions that might
be taking too long.

¢ Progress View section’s % Complete column: Sorting shows which actions have longer to
complete.

Filtering Lists

You can shorten any list by filtering on its items. This function is best used when you have a very long
list and some of the items contain the same characters. This way, you can display only the few items
that you want to focus on. For example, you might have a list of VMs similar to the following:

Figure 3-10 VM Client Showing the Filter Field

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Virtual Machines

Virtual Machines

¥ Host Servers
]

Storage

Templates Name Status Notes Host 05 CPU Memory
32bitc1 | SUSE Linux Enterprise
32bitTemplate | SUSE Linux Enterprise
MyPXE - ZRE&4bit SUSE Linux Enterprise
RHat-C1 | Other operating syste
RHat-T1 [ | Other operating syste
RHELS | Other operating syste
sled10-32bit | Other operating syste
SLES32bit | SUSE Linux Enterprise
sles64bit | SUSE Linux Enterprise
sles1032-test | SUSE Linux Enterprise
sles1032bit-2 - da112.provo.nov SUSE Linux Enterprise
test-32bit | SUSE Linux Enterprise

| & Orchestrate | 18 yersion Info | Show/Hide Progress View

The field circled in the above example is the filter field. This is where you type characters to create the
filter. The filter string is not case-sensitive.

You must place the mouse pointer’s focus in the filter field in order to use this feature. If you start
typing characters when the mouse pointer’s focus is on a listed item, the locator pop-up is displayed
instead.
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For example, to display just the VMs containing the letters s1es in one or more of the columns, type
the characters in the field as depicted in Figure 3-11:

Figure 3-11 Using the Filter Field in the VM Client

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Virtual Machines [Filtered]
L
¥ Host Servers

F  Storage

Templates Name Status Notes 0s

SLES32bit | SUSE Linux Enterprise

sles64bit SUSE Linux Enterprise

u
sles1032-test | SUSE Linux Enterprise
-

sles1032bit-2 da112.provo.nov SUSE Linux Enterprise

| & Orchestrate | 18 yersion Info | ShowHide Progres

The list is automatically updated to reflect all VMs that have characters in any of their rows that
match what you are typing.

If the list is long, it might take a few seconds to display the filtered hits. You don’t need to click
somewhere else or press the Enter key to make the listed items change. You can continue to type
characters to refine the filter with each character you type in the filter field. If you press Enter, the
typed filter is executed, but the mouse pointer’s focus remains within the field.

If you enter a string that has no match, the list is empty. To display the full list again, click the i icon
to clear the filter string, or manually delete the filter string. Because the filter string is dynamically
read, you can delete recently typed characters to display previous hits.

For any list in the VM Client, the filter strings that you enter are remembered when you return to
those lists. This allows you to set up filter strings for various lists so that you do not need to refilter
the lists each time you return to them, even if you log out and log back in to the VM Client.

To show you whether a list is filtered, [Filtered] is displayed above the action buttons, as shown in
Figure 3-11 on page 55.

When you double-click a VM that is in a filtered list, the details tabs for the VM are displayed and the
filtered VMs list is now displayed in the Inventory panel.

Locating Items in a List

You can use the locator pop-up to move quickly to a specific item, or to identify all relative items in a
list of VM, host servers, storage items, or templates, or in any other kind of list in the VM Client. Hits
are based on any of the entries in any column. The hits are based on exact matches to the string that
you type. The strings are not case-sensitive.

To use this feature, click anywhere in a list, then begin typing characters. The locator pop-up is
automatically displayed, showing the characters that you are typing:

Figure 3-12 Locator Pop-Up with String Field, Arrows, and Number Hits

r & 11 hits
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Focus is immediately moved to the first item in the list that matches what you have typed. (If this
does not happen immediately, click the down-arrow on the locator pop-up.) You can continue to type
characters in the locator pop-up to refine the filter:

Figure 3-13 Virtual Machines List with a Located Item Highlighted

- PlateSpin Orchestrate YM Client ! E
=
Inventory
-
F  Host Servers
¢ Storage
Templates Name = Status Notes Host as CPU Memory
32bitct u SUSE Linux Enterprise
32bitTemplate n SUSE Linux Enterprise
MyPXE L g ZRE64bit SUSE Linux Enterprise
Ha R
RHat-T1 | Other operating syste
RHEL5 n Other operating syste
sled10-32bit | | Other operating syste
SLES32bit | ] SUSE Linux Enterprise
slesfdbit ] SUSE Linux Enterprise
sles1032-test n USE Linux Enterprise
sles1032bit-2 [ dal12.provo.nov SUSE'Hpux Enterprise
test-32bit ] SUSE Linux r|.|m| T s

If there are no matches for your string, nothing is highlighted; or, if there are no further matches, the
last hit remains highlighted.

The up-arrow and down-arrow in the locator pop-up allow you to move from hit to hit in the list. The
arrow keys on the keyboard also perform this action when the locator pop-up is visible. This arrow
action is very useful in long lists where the hits might not all occur together. For example, typing
start might find hits that are scattered across an Event Log. The arrows can help you to quickly
locate them.

The locator pop-up dynamically displays how many of the items in the list match the characters that
you have typed thus far. This lets you know how many hits you can move to by using arrows.

The locator pop-up closes after a brief pause if no further action is taken. To close the locator
immediately, click outside of it, or press the Enter key.

When you close the locator pop-up, its content is cleared and is not remembered.
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3.2.5

Viewing Additional Information in Fields or Cells

To view more information for any entry in a field or an entry in a table cell, simply mouse over the
field or cell. For example:

Figure 3-14 Mousing Over a Cell

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Storage
Virtual Machines |_T__| |E| |E| |Z| | | I

¥ Host Servers

» Storage

Templates

Name Stored VMs
da111 0 Local

dat12.provo.novell.com 1 Local

Notes Capacity

OfficeRepo 12 - Network Att:
32bitcl

0% o RHat-T1 datagrid backed repository Datagrid
. REHL5_template
ZR64bit o test-30hit Local
RHELS
SLES32hit
32bitTemplate
slesa4bit
sled10-32bit
RHat-C1
sles1032hit-2
MyPXE

Login successful. Connected to server: 137.65.167.241 | & Orchestrate | 18 yersion Info | Show/Hide Progress View

This example shows that 12 VMs are stored in this repository.

Following are examples of the kind of useful information that you can view by mousing over fields or
entries in table cells:
¢ General viewing functionality:
¢ Notes column: Displays the full text of the note.

¢ Status column on the Event Log tab: For any entry with the [i icon, displays the same
information that you can view by double-clicking the entry to open the Event Log dialog
box. This is just a quicker way to view that information. However, the dialog box remains
open, but the mouse-over information disappears when you change the mouse’s focus.

¢ Progress View section:

¢ Status column: Displays the same status log information that is in the Event Log dialog box
(right-click the entry in the Status column and select Show Log).

¢ Virtual Machines view:
¢ Name column: Displays the VM’s name, its host, and its repository.

¢ Status column: Displays the VM'’s status. For the in-progress status (x), it shows the action
name, action detail, start time, elapsed time, a progress bar, and the latest three log entries
(which are updated dynamically).

¢ Host column: Displays the VM’s host’s DNS name or IP address, the type of hypervisor
being used, and the repository.

¢ Host Servers view:
¢ Name column: Displays either the host server’s DNS name or IP address.

¢ Active VMs column: Displays the names of the VMs that are actively using the host.
Nothing is displayed if the count is zero.
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¢ Virtualization Technology column: Displays the virtualization type and its source.

¢ Stored VMs column on the Summary tab: Displays the names of the VMs that are
assigned to the repository, even if they are not running. Nothing is displayed if the count is
Zero.

¢ Status column on the Summary tab: Displays the VM’s status. For the in-progress status
(#), it shows the action name, action detail, start time, elapsed time, a progress bar, and the
latest three log entries (which are updated dynamically).

¢ Storage view:

¢ Stored VMs column: Displays the names of the VMs that are assigned to the repository,
even if they are not running. Nothing is displayed if the count is zero.

¢ Status column on the Virtual Machines tab: Displays the VM'’s status. For the in-progress
status (:), it shows the action name, action detail, start time, elapsed time, a progress bar,
and the latest three log entries (which are updated dynamically).

¢ Active VMs column on Hosts tab: Displays the names of the VMs that are actively using
the host. Nothing is displayed if the count is zero.

¢ Virtualization Technology column on Hosts tab: Displays the virtualization type and its
source.

¢ Templates view:

¢ # Clones column: Displays the names of the VMs that were cloned from the template.
Nothing is displayed if the count is zero.

¢ Hypervisor: Displays the hypervisor type and its source.

¢+ Name column on the Summary tab: Displays the cloned VM’s name, its host, and its
repository.

¢ Status column on the Summary tab: Displays the cloned VM'’s status. For the in-progress
status (), it shows the action name, action detail, start time, elapsed time, a progress bar,
and the latest three log entries (which are updated dynamically).

¢ Host column on the Summary tab: Displays the cloned VM’s host’s DNS name or IP
address, the type of hypervisor being used, and the repository.
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3.3

Using the Error Log

The Error Log section is displayed at the bottom of the interface window when you click View > Show
Error Log. You can also double-click an error message in the lower left of the VM Client window to
open this view.

Both the Error Log and Progress View sections use the same position in the VM Client window. You can
drag them to other positions or toggle between them by using the View menu options.

Figure 3-15 Detached Error Log Section

Error Log - Workspace Log
Warkspace Log
ftype filter tex |
Message - Plug-in Date
€3 Could not create color factory, org.edipse, ui 2009-06-03 11:13:12.437
@ Could not create color factory, org.edipse, ui 2009-06-03 11:13:19.437
& Plugin com.novell,vnas, extension org. edipse.ui.ther org.edipse.ui 2009-06-03 11:13:19.437
3 Plugin com.novell, vnas, extension org. edipse.ui.ther org.edipse.ui 2009-06-03 11:13:19.437
@ null argument: org.edipse.ui.workbench 2009-06-03 11:13:19.437
'EW null argument: org.edipse,ui,workbench 2009-06-03 11:13:19.437

You can double-click in the Error Log section’s title area to expand it to use the entire VM Client
window, or the entire computer monitor window if it is detached. Double-click again to return it to
its previous size and location.
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You can right-click a log entry for access to the same options that are available in the upper right
corner of the Error Log section. Included in the right-click menu is the Event Details option:

Figure 3-16 Right-Click Menu Options for Error Log Entries

il plateSpin Orchestrate VM Client

FILE EDIT AC VIEW HELP

Inventory Virtual Machines

Virtual Machines [a] |

¥ Host Servers
]

Storage

Templates Name Status Notes Host os CPU Memory
32bitc1 | SUSE Linux Enterprise
32bitTemplate SUSE Linux Enterprise

MyPXE
RHat-C1

SUSE Linux Enterprise
Other operating syste
RHat-T1
RHEL5
sled10-32bit

Other operating syste
Other operating syste
Other operating syste
SLES32bit SUSE Linux Enterprise
slesfdbit SUSE Linux Enterprise
sles1032-test SUSE Linux Enterprise

sles1032bit-2 dat12.provo.nov SUSE Linux Enterprise

H ¥ E B BB BN EgAN

test-32bit SUSE Linux Enterprise

Error Log - Workspace Log

|type filter text

Plug-in Date

Could not create colgefaciy org.edipse.ui 009-06-03 11:
@ Could not create coh Copy org.edipse.ui 2009-06-03 11:
@ Plugin com.novell.vn ) er org.edipse.ui 2009-06-03 11:
@ Plugin com.novell.vn e Clear Log Viewer er org.edipse.ui 2009-06-03 11:
Q] null argument: ¥ Delete Log org.edlipse. ui.workbench 2009-06-03 11:
Open Log org.edipse.ui.workbench 2009-06-03 11:
Restore Log

Message

@ nul argument:

Export Log...

_ [ Event Details = "
Could not crea ctory. | ® Orchestrate | ™ Version Info

Show Hide Progress
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Use these menu options to do the following;:

Table 3-1 Right-Click Menu Options for the Error Log Section

Option

Function

Copy

Clear Log Viewer

Delete Log

Open Log

Restore Log

Export Log

Import Log

Export Entry

Event Details

Copies information about the error entry that you right-click to your
computer’s clipboard.

Clears all entries from the Error Log section.

Clears all entries from the Error Log section and deletes the log file. It cannot
be recovered.

Same functionality as the Restore Log option. Because the VM Client uses a
hard-coded log file on the host server the you are logged in to, an Open
dialog box is not displayed.

Restores all entries to the Error Log section from an existing log.
Exports the complete log to a file that you specify.

Same functionality as the Restore Log option. This option is not used in the
VM Client because a hard-coded log file located on the host server that you
are logged in to is used for logging.

Exports only the selected error log entry to a file that you specify.

Provides more detail on the error. See Figure 3-17 on page 62.
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The Event Details option displays the following dialog box:

Figure 3-17 Ewvent Details Dialog Box

i Event Details |Z| |E| fE

Date: 2009-06-03 11:13:19.437
Severity: 'Ef| Error

Message: | qull argument:

(2] (]

Jr{ylr

Exception Stack Trace:

at org.edipse.ui
at org.edipse.ui
at org.edipse.ui
at org.edipse. ui
at org.edipse. ui
at org.edipse. ui
at org.edipse.ui
at org.edipse.ui
at org.edipse.ui
at org.edipse. Ui
at org.edipse. Ui

org. edipse.core,
at org.edipse.core.runtime, Assert.isMotMull{Assert. java: 86)

at org.edipse.core.runtime, Assert.isMotMull{Assert. java: 74)

at org.edipse.jface.resource. StringConverter.asString (StringConverter . java: 800)

Jinternal. themes. ThemeR.egistryReader. checkColorFactory{ThemeReqistryR
Jnternal. themes. ThemeR.egistryReader.getColorValue (ThemeRegistryReads
Jinternal, themes. ThemeRegistryReader.readColor (ThemeRegistryReader.ja
Jinternal, themes. ThemeR egistryReader.readElement{ThemeRegistryReader
Jinternal. registry.ReqgistryReader. readElements(RegistryReader.java: 1449)
Jinternal . reqgistry.ReqgistryReader. readExtension{RegistryReader . java: 155)
Jinternal . reqgistry.ReqgistryReader. readR eqistry(RegistryReader . java: 17a)
Jinternal, themes. ThemeR egistryReader.readThemes{ThemeR egistryReader
Jnternal, themes. WorkbenchThemeManager . updateThemes{(\WorkbenchTher
Jnternal, themes. WorkbenchThemeManager. accesss0{WarkbenchThemeMal
Jnternal, themes. WorkbenchThemeManager 3. handleEvent{WorkbenchThe

runtime. AssertionFailedException: null argument:

(3

at org.edipse.swt.widgets.EventTable. sendEvent{EveniTable.java:54)
at org.edipse.swt.widgets. Display.sendEvent{Display.java: 3959)

at org.edipse.swt.widgets. Display.runSettings{Display.java: 3360)

at org.edipse.swt. widgets. Display.messageProc(Display.java: 3039)

£ |

[l
[

Session Data:

QK

The VM Client is based on Eclipse and uses the standard Eclipse Error Log view. For more
information, see Error Log (http://help.eclipse.org/ganymede/topic/org.eclipse.pde.doc.user/guide/
tools/views/error_log.htm).
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3.4

Using the Progress View

The Progress View section is useful for when you have actions occurring simultaneously for multiple
VMs because you can keep track of which ones are still running. The Progress View section is
displayed at the bottom of the interface window. When is not displayed, you click View > Show
Progress View or double-click Show/Hide Progress View in the lower right of the VM Client window:

Figure 3-18 Show/Hide Progress View Option

il PlateSpin Orchestrate VM Client

ACTIONS VIEW HAP

Inventory Virtual Machines

Virtual Machines (=] (=] (] (=]

¥ Host Servers
]

Storage

Templates Name Status Notes Host os CPU Memory
32bitc1 | SUSE Linux Enterprise
J2bitTemplate u SUSE Linux Enterprise
» SUSE Linux Enterprise
RHat-C1 | Other operating syste
RHat-T1 | Other operating syste
RHEL5 | Other operating syste
sled10-32bit | Other operating syste
SLES32bit | SUSE Linux Enterprise
slesfdbit | SUSE Linux Enterprise
sles1032-test | SUSE Linux Enterprise
sles1032bit-2 - dat112.provo.nov SUSE Linux Enterprise
test-32bit | SUSE Linux Enterprise
Progress View
Object Hame Action User Elapsed Time % Complete

| @ Orchestrate | 8 version Info | Show/Hide Progr

The Progress View section can be both opened and closed by double-clicking Show/Hide Progress View.

Both the Progress View and Error Log sections use the same position in the VM Client window. You can
double-click in the Progress View section’s title area to expand it to use the entire VM Client window,
or the entire computer monitor window if it is detached. Double-click again to return it to its
previous size and location.

You can also drag the sections to other positions, including to their own window on the desktop
(detached), or use the View menu options to toggle between them inside the VM Client window. The
following illustrates the Progress View section as a detached window:

Figure 3-19 Detached Progress View Section

E)

Progress View

Object Name Action Status User Elapsed Time % Complete
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To stop an event that is in progress, select the event, then click the [l icon located in the upper right of
the view. The icon is dimmed when an event is not selected.

3.5 Resetting the VM Client Perspectives

You can reset the various perspectives to their original configuration:

1 In the VM Client, click View > Reset Perspective.
The following dialog box is displayed:

?' Reset Perspective |:|@@

I Do you want to reset the VMM perspective to its defaults?

/

Cancel

2 Click OK to reset the perspectives:

¢ The Inventory panel is reset to its original size and location, to the left of the VM Client
window.

¢ The Details lists and editors are reset to their original location, to the right of the Inventory
panel.

¢ If the Error Log or Progress View section is open, it is reset to the lower right portion of the
window.

This action cannot be undone. You can reconfigure the perspectives again as needed.
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3.6 Changing the VM Client Theme

The default theme is Black Pearl. Following are examples of the available themes:

+ Black Pearl

£ PlateSpin Orchestrate VM Client

FILE EDIT Al VIEW HELP

Inventory Virtual Machines

Virtual Machines m] (=]

= Host Servers

Discovered [1]

Name Status Notes Host as CPU Memory
» Storage 32bitct n SUSE Linux Enterprise
Templates 32bitTemplate n SUSE Linux Enterprise
MyPXE L d ZRG4bit SUSE Linux Enterprise
RHat-C1 ] Other operating syste
RHat-T1 ] Other operating syste
RHELS ] Other operating syste
sled10-32bit ] Other operating syste
SLES32bit u SUSE Linux Enterprise
sles64bit ] SUSE Linux Enterprise
sles1032-test ] SUSE Linux Enterprise
sles1032bit-2 - dat12.provo.nov SUSE Linux Enterprise
test-32bit ] SUSE Linux Enterprise
Progress View
Object Name Action Status User Elapsed Time % Complete

Login successful. Connected to se

+ Tahiti Ocean Classic

£ plateSpin Orchestrate VM Client

PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Virtual Machines

Host Servers

Discovered [1]
Name Status Notes Host 0s CPU Memory
Storage 32bitcd u SUSE Linux Enterprise
Templates 32bitTemplate n SUSE Linux Enterprise
MyPXE - ZRE4bit SUSE Linux Enterprise
RHat-C1 | Other operating syste
RHat-T1 n Other operating syste
RHELS | Other operating syste
sled10-32bit n Other operating syste
SLES32bit | SUSE Linux Enterprise
slesG4bit n SUSE Linux Enterprise
sles1032-test | SUSE Linux Enterprise
sles1032bit-2 - dat12.provo.nov SUSE Linux Enterprise
test-32bit u SUSE Linux Enterprise
Progress View
DObject Name Action Status User Elapsed Time % Complete
1 @ Orchestrate | l@ Version Info |  Show/Hide Progress View
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¢ Graphite Moon

£ PlateSpin Orchestrate VM Client

PlateSpin Orchestrate VM Client
FILE EDIT ACTIONS VIEW HELP N
Inventory Virtual Machines
cooo | o
- Host Servers
Discovered [1]
Name Status Notes Host as CPU Memory
» Storage 32bitct n SUSE Linux Enterprise
Templates 32bitTemplate n SUSE Linux Enterprise
MyPXE - ZR64bit SUSE Linux Enterprise
RHat-C1 | | Other operating syste
RHat-T1 | | Other operating syste
RHELS | | Other operating syste
sled10-32bit n Other operating syste
SLES32bit | SUSE Linux Enterprise
sles64bit n SUSE Linux Enterprise
sles1032-test | SUSE Linux Enterprise
sles1032bit-2 - dat12.provo.nov SUSE Linux Enterprise
test-32bit | SUSE Linux Enterprise
Progress View
Object Name Action Status User Elapsed Time % Complete
Login successful. Connected to server: 137.65.167.241 1 e Orchestrate | l@ Version Info |  ShowjHide Progress View

To change the VM Client’s color theme:

1 In the VM Client, click View > Change Theme to display the Change Theme dialog box:

Black Pearl {current) w

Bladk Pearl

Tahiti Ocean Classic
Graphite Moon

The currently selected theme has (current) next to its name.

This option is available on both the Welcome page as well as in the Inventory sections, so you
can change the theme on the Welcome page before logging in to a host.
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2 In the drop-down list, select a theme and click OK to display the Restart VM Client dialog box:

" Restart VM Client (=) 3

I For proper application of the new theme the VM

/

Client must be restarted.

ﬁ Restart the VM Client now?

If you select the theme with (current) next to its name and click OK, the Restart VM Client
dialog box is not displayed because you have not selected to change the theme.

3 To make the theme change take effect, click Yes to restart the VM Client.
You must log in to your host server again when the client restarts.
If you click No, the theme change takes effect the next time you reopen the VM Client.

Logging in and out of a host server does not make the theme change take effect.
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4.1

4.2

Managing VM Host Servers

You can do the following with VM host servers:

¢ Section 4.1, “Understanding VM Host Servers,” on page 69

¢ Section 4.2, “Viewing and Editing Host Server Details,” on page 69
¢ Section 4.3, “Using Feedback to Manage Host Servers,” on page 79
¢ Section 4.4, “Accessing a Host Server’s Console,” on page 80

¢ Section 4.5, “Resynchronizing a Host Server’s State,” on page 80

Understanding VM Host Servers

VM host servers are generally separate machines from the Orchestration Server, because the
Orchestration Server is highly utilized by the Orchestration functions. Host servers’ main function is
to manage and run virtual machines, which can also create high utilization.

VM host servers provide the capability to run virtual machines in their RAM. They are also used to
store and manage VM files and templates in their local or shared repositories.

Machines must have the following installed on them to qualify as VM host servers:

¢ The Xen kernel, Hyper-V, or VMware vSphere, which provides the hypervisor capability

¢ The Orchestration Agent, which provides access to the Orchestration Server in order to work
with VMs in the virtualization grid

For more information on setting up VM host servers, see Section 2.4, “Registering VM Hosts,” on
page 22.

Viewing and Editing Host Server Details

Review the following sections for information on the details views:

¢ Section 4.2.1, “Accessing Host Server Details,” on page 70

¢ Section 4.2.2, “Using the Details Tabs,” on page 70
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4.2.1 Accessing Host Server Details

The details for each host server consist of a summary, configuration information, monitoring
information, and an event log.

1 In the VM Client, click the Host Servers view.

The host servers are displayed:

f' PlateSpin Orchestrate VM Client

EILE EDIT

Inventory Host Servers
Virtual Machines

Discovered[1]

Hame Status Active VMs Hotes Technelogy cPU Memory
+ Storage VMWare101 ] L] VMWare uSphere
s
VMWare106 [ | 1 VMWare uSphere
VMWare112 ] L] VMWare uSphere
zos105 L L] XEM 3.x L] 12
zos107 - o XEM 3.x L] 13
zos111 - L] XEH 3.x L] N 38
zos113 - L] XEM 3.x L] D63
zos17 L L] XEM 3.x L] 12
zos119 - o XEM 3.x L] "5
zos120 - L] XEH 3.x L] 12
zos121 - L] XEM 3.x L] 12
zos122 L L] XEM 3.x L] 19
& Orchestrate | 18 yersion Info | ShowiHide Pros

2 Do one of the following:

¢ Double-click one of the host servers.
¢ Right-click one of the host servers, then select Show Details.

The tabs for the selected host are displayed.

3 For details on the tabs, see:

¢ “Summary Tab” on page 71

¢ “Configuration Tab” on page 72
¢ “Monitoring Tab” on page 74

¢ “Event Log Tab” on page 78

4 To close the details view, click the view name in the Inventory perspective panel.

4.2.2  Using the Details Tabs

The following sections provide information on the various details tabs:

*

*

*

“Summary Tab” on page 71
“Configuration Tab” on page 72
“Monitoring Tab” on page 74
“Event Log Tab” on page 78
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Summary Tab

This details tab is used by each Inventory panel type:

Figure 4-1 Summary Tab for Host Servers

i PlateSpin Orchestrate VM Client

ELLE EDIT ACTIONS ! HELP

Inventory 105 [Agent Running
Virtual Machines | | I ]

~ Host Servers
VIMWare101
VMWare103
VMWare106
VMWare112
=T
zos107
zos1i1

Summary Corfiguration Monikaring Ewent Log

zos113
zosTT
zos119
zos120
zos121

zos122

MAC Address Metwork.

Discovered[1]

¥ Storage
Templates

Status

WM Mame Memary

You can do the following with the Summary tab for host servers:

¢ In the first section, right-click a group name under Groups, then select Remove to revoke the host
server’s membership in the group.

+ In the Notes section, enter and edit notes for the host server.
¢ View basic information about the host server, including;:
¢ The host server’s operating system
¢ The virtual machine technology being used by the host server
¢ Percentage of CPU and memory in use
* [P address and DNS name, if it is not DHCP

¢ Storage items being used by the host server, including how many VMs are using each
repository, the type of network access to the repository, and each repository’s capacity and
percent free

¢ Alist of VMs being hosted by this server
¢ The host server’s MAC address
¢ Right-click a listed storage item, then select either Remove Repository or Associate Repository.

¢ Double-click a listed storage item to view its details tabs.

Managing VM Host Servers 71



¢ Right-click a listed VM, then select any of the available menu options. These are the same right-
click menu options that are available for the VM in the Virtual Machines Inventory list.

+ Double-click a listed VM to view its details tabs.

Wherever N/A appears in the details, it means that the information is not available.

Configuration Tab

This details tab is used only by host servers. You use information available in the tab to effectively
manage the existing VMs hosted on the VM hosts. For example, you can decide to stop a VM when
the memory utilization is high. You can also effectively utilize the VM host by deploying additional
VM, if required, and you can install applications on the VMs.

You can do the following with this tab:

¢ Click Processors to view information about the processors on the host server. This is the default
view:

f PlateSpin Orchestrate ¥M Client [Z|E|E|

EILE EDIT

Inventory I 205105 [Agent Running]

Virtual Machines [ New v |
~ Host Servers

VIMWare101

VIMWare103

VIMWare106

VMWare112
=T

zos10T

zos111

zos113

zos117

zos119

zos120

Genuinelntel

zos121
705122

Discovered[1]

¥ Storage
Templates

| W8 yersion Info | Sh
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¢ Click Memory to view information about memory usage on the host server:

it PlateSpin Orchestrate YM Client

FILE EDIT ACTI HELP

Inventory | 205105 [Agent Running]
Virtual Machines =) = ‘
= Host Servers
VIMWare101
VIMWare103
VIMWare106
VMWare112
T
zos107
zos111
zos113
zos11T
zos119
zos120
zos121
zos122

Discovered [1]

¥ Storage
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f' PlateSpin Orchestrate YM Client

EILE EDIT ACTI HELF

Inventory | zos105 [Agent Running]
Virtual Machines ( = |
- Host Servers
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¥ Storage
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¢ Click DNS and Routing to view the computer name and domain name for the host server:

it PlateSpin Orchestrate YM Client

FILE EDIT ACTIONS WIEW HELP

Inventory I 205105 [Agent Running]

Virtual Machines =] =] ] =] ‘ [ I )

+ Host Servers -

VIMWare101 Surnmary Canfiguration Manitoring Event Lag
VIMWare103
VIMWare106

VIMWare112

zos 10T
zos111
zos 113
zos 117
zos119
zos120
zos121
zos122
Discovered [1]

¥ Storage
Templates

Monitoring Tab

This details tab allows you to monitor many elements of both the virtual machines and physical host
machines, aiding you in the overall management of your data center.

The Monitoring Agent must be installed on the device in order for this tab to show any information.
For instructions to install the agent manually, see Section 5.7, “Installing the Monitoring Agent on a
VM,” on page 120.

Review the following to understand the Monitoring tab and how to access and use it:

¢ “Understanding Monitoring” on page 75
¢ “Monitoring VMs and Host Servers” on page 76
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Understanding Monitoring

The Monitoring tab displays information about the VM or host server that you can use to monitor
whether it is performing correctly, is overused or underused, its history, and details about its
capacities.

The default window size for the VM Client only allows one column of graphics to be displayed. The
following is an example of the Monitoring tab’s information:

Figure 4-2 Monitoring Tab for a Host Server Showing Default Single Column View of Graphics

i plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory

Virtual Machines

~ Host Servers
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The following example shows that graphics can be displayed side-by-side when you expand the
width of the VM Client window.

Figure 4-3 Monitoring Tab for a Host Server Showing Multiple Column View of Graphics

£ PlateSpin Orchestrate VM Client

FLE enrT ACTIONS HELP

Inventory 1l ZR64bit [Agent Running]
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Monitoring VMs and Host Servers
1 Inthe VM Client, click the Virtual Machines view or the Host Servers view, then double-click a VM
or host server that you want to monitor.
Wherever N/A appears in the details, it means that this information is not available.
2 Click the Monitoring tab to display the Monitoring view.
If you are requested to provide credentials, enter the Monitoring login name and password.

4 To set the time interval for which you want the data displayed (hour/day/week/month/year), go
to the Last field and select the time from the drop-down options.
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5 To maximize the Monitoring tab view in the VM Client window, double-click the VM or Host

name located in the Inventory item’s title area just above the action buttons:

‘I plateSpin Orchestrate VM Client

ACTIONS VIEW

Inventory
Virtual Machines
~ Host Servers
dai11

dai12.provo.novell.com

F  Storage

Templates

I ZR64bit [Agent Running]
priie=er TP 1| Add Repo

Monitoring

Wed, 03 Jun 2009 13:08:41

This host is up and running.

The following illustrates the Monitoring tab maximized in the VM Client Window:

‘il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW

Surnmary Configuration Monitoring Event Log

Wed, 03 Jun 2009 13:13:42

Last

151.155.168.99 Load Llast hour
2.0 ]

Event Log

Get Fresh Data

Load/Procs

LT

12:28 12: 48 13: 08
O1-min Load M CPUs M Running Processes

151.155.168.99 Memory last hour
.

0.0
12:20 12: 40 13:00
W Mcmory Used
O Memory Buffered
W Total In-Core Memory

M HMcmory Shared

E Memory Cached
W Memory Swapped

151.155.168.99 CPU last hour

Percent

)

12:30 12: 4@ 13: 00

B User CPU  [OMNice CPU W System CPU [ WAIT CPU

0 Idle CPU

| & Orchestrate | i version Info | Show/Hide Progress View
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Double-click the item’s title again to return the tab to its previous view.
6 To refresh the graphics, click the Get Fresh Data button.

You can refresh the view at any time.

Event Log Tab

This details tab is used by VMs and host servers:

Figure 4-4 Event Log Tab for VMs
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This tab provides information from both the resource log messages and the action status history log,
intermingled based on start times. Therefore, the log provides both information on the host server as
well as actions for any VMs it is currently hosting. Double-click the [l icon to display the host’s Event
Log Details dialog box.
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4.3

You can do the following with this tab:

¢ View the Event Log information.

¢ Double-click an event item that contains the [i]icon to view the details of the event as reported
by the Orchestration Server. The following is an example of an event’s details:

{' Event Log Details for Host ‘ZR64bit’ M=

' Details for item: VM Host Disco

/

Provisioning job started for discovery of ¥M host 'ZR&4bit_xen30'

discoverVmHost_event requested by 'system’ to discover vm's on hosts [ZR&4bit_xen307.
[ZR.54bi VEr

[Z

[Z

[Z

[Z _

[Z i g Xen s em info'

[ i g} X_para_memory : 1451

[ZR.64bi g ¥en ma : 1439

[z . :

[Z

: xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x

: xen-3.0-x86_564 wen-3.0-x86_32p

F
enabled, version: 3.3, bits: 64, hvm: True
ting migration support...
ration iz enabled
it] XEM_VYMBuilderService is enabled.
[ZRE4bit] Getting vm list with xm tool
host_status_discovered_event for host 'ZR64bit_xen30'

| Copy to Clipboard

Using Feedback to Manage Host Servers

The VM Client is integrated with the Orchestration Server and the Orchestration Console to provide
event details for the host servers that are listed in the VM Client. This integration with the
Orchestration Server resource log enables you to see details on any jobs run on each host. You do not
need to open the Orchestration Console to discover the events for the host servers that are listed in
the VM Client.

The Event Log tab for a host server shows all jobs that have been run for VMs hosted by that server.
This allows you to view all provisioning and life cycle actions that are being or have been run on that
host server.

Some actions for a host server that are not yet associated with a resource in the system, such as
Accept Pending Registration for the host, can be reviewed for that host after the action has been
completed. You can click any of the [i] icons in the Additional Information column of the Event Log tab
for that host to obtain the details of any registration event. For example, the Accept Pending
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4.4

4.5

Registration action runs multiple jobs on the Orchestration Server, causing multiple events to be
logged. Each of those job-related entries in the Event Log tab might have further information, as
indicated by the [{]icon.

Accessing a Host Server’s Console

In order to access a host server’s console using VNG, it first must be configured on the server, then set
up and configured in the Orchestration Console. This is normally done when you install and
configure the Orchestration Server. For more information, see “Setting Up Orchestration VNC for a
VM Managed by vSphere” in the NetIQ Cloud Manager 2.1 Orchestration Installation Guide.
1 In the VM Client, click the Host Servers view.
2 Do one of the following:
+ Select the host, then click the button.
* Select the host, then click View > Show Console.
¢ Right-click the host, then select Show Console.
3 Provide the VNC password, then click OK.

When attempting to make a VNC connection, VNC tests for a fully qualified domain name
(FQDN), simple host name, or IP address.

Resynchronizing a Host Server’s State

The Orchestration Server is automatically updated to list the state of the hosted VMs after every
provisioning action. However, the state of the hosted VMs is not automatically updated if the VM
state is changed by any third-party tool. You must manually synchronize the state of the hosted VMs
in the Orchestration Server to reflect the current state of the host server’s VMs.

When a host server is resynchronized, the VM Client in conjunction with the Orchestration Server
does the following;:

¢ Runs the provisioning adapter to discover jobs

¢ Discovers what is enabled with each host

¢ Discovers the host’s capabilities

¢ Updates the state of active and known VMs

¢ Detects the types of its hosted VMs

¢ Does not sync up the states of the host's VMs

¢ Removes association with any VMs that cannot be found on the host

¢ Does not discover any VMs that might be on the host’s disks

Resynchronizing a host server can be useful when a VM hypervisor has changed and the
Orchestration Server needs to be aware of the changes.

IMPORTANT: When a VM is on shared storage, resynchronization is only tried on the host server
where the VM was last running.
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To resynchronize a host server:

1 In the VM Client, click the Host Servers view.

2 Right-click the host server to be resynchronized, then select Resync State.
This resynchronizes the state of all VMs hosted by the host server.
You can resynchronize only one host server at a time.

3 You can view the progress in any of the following ways:

¢ Double-click the host being synchronized, click the Event Log tab, then double-click the
entry related to the process that has the [i]icon next to it. The Event Log Details dialog box
is displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.

¢ View the synchronization progress in the Jobs tab of the Orchestration Console.
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Managing Virtual Machines

You can do the following for hands-on management of virtual machines (VMs) in the Cloud Manager
VM Client:

*

*

*

*

Section 5.1, “Viewing and Editing VM Details,” on page 83

Section 5.2, “Using Feedback to Manage VMs,” on page 87

Section 5.3, “Virtual Machine Actions,” on page 98

Section 5.4, “Creating a Xen VM,” on page 105

Section 5.5, “Installing a VM,” on page 117

Section 5.6, “Installing the Orchestration Agent on a VM,” on page 119
Section 5.7, “Installing the Monitoring Agent on a VM,” on page 120
Section 5.8, “Editing VMs,” on page 120

Section 5.9, “Moving VMs,” on page 128

Section 5.10, “Migrating VMs,” on page 130

Section 5.11, “Deleting VMs,” on page 134

5.1 Viewing and Editing VM Details

Review the following sections for information on the Details views:

*

*

Section 5.1.1, “Accessing VM Details,” on page 84
Section 5.1.2, “Using the Details Tabs,” on page 84
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5.1.1 Accessing VM Details

The details for each VM consist of a summary, monitoring information, and an event log.

1 In the VM Client, click the Virtual Machines view.
The VMs are displayed:

£ PlateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory Virtual Machines

Virtual Machines =] =] 0] Edit | [ Migrate | |

F Host Servers
3

Storage

Name Status Notes Host 0s CPU Memory
test-32bit SUSE Linux Enterprise
=le=s1032bit-2

Templates

dat112.provo.nov. SUSE Linux Enterprise

sles1032-test SUSE Linux Enterprise

sles64bit SUSE Linux Enterprise
SLES32bit SUSE Linux Enterprise
sled10-32bit
RHELS

RHat-T1

Other operating syste
Other operating syste
Other operating syste
RHat-C1
MyPXE
JZbitTemplate
32bitcd

Other operating syste
ZR64bit SUSE Linux Enterprise
SUSE Linux Enterprise

H B vy R E R EEENEBRjQJ

SUSE Linux Enterprise

| ® Orchestrate | W version Info | Show/Hide Progres

2 Do one of the following:
¢ Double-click one of the VMs.
¢ Right-click one of the VMs, then select Show Details.
The tabs for the selected VM are displayed.
3 For details on the tabs, see:
¢ “Summary Tab” on page 71
¢ “Monitoring Tab” on page 74
¢ “Event Log Tab” on page 78

4 To close the details view, click the view name in the Inventory perspective panel.

5.1.2  Using the Details Tabs

The following sections provide information on the various details tabs:

¢ “Summary Tab” on page 85
¢ “Monitoring Tab” on page 86
¢+ “Event Log Tab” on page 86
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Summary Tab

This details tab is used by each Inventory panel type:

Figure 5-1 Summary Tab for Virtual Machines

i plateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory # sles1032bit-2 [Running]

« Virtual Machines (m] |?| |ﬁ| (=] |

Summary Monitoring Event Log

Notes

Linux Enterprise Server 10

32bitTemplate

32bitc1

¥ Host Servers

F  Storage
Templates Memory

Type Datastore Capacdity Free MAC Address MIC Type

Hard Disk OSdisk 8GB 00:16:3e:15:4f:07  Paravirtualized

| & Orchestrate | 8 yersion Info | Show/Hide Progress View

You can do the following with the Summary tab for VMs:
¢ In the first section, right-click a group name under Groups, then select Remove to revoke the
VM’s membership in the group.
+ In the Notes section, enter and edit notes for the VM.
¢ View basic information about the VM:
¢ The VM’s operating system
¢ The virtual machine technology being used by the VM

¢ CPU and memory, including how it is used by the guest and host and the percentage of the
host memory being used

+ P address and DNS name, if it is not DHCP

¢ Storage names and types associated with the host, storage capacity information, and how
many VMs are stored on the host per storage name

¢ The VM’s MAC address and NIC type (paravirtualized)
¢ Hosted VMs and their operating status, name, OS type, and CPU/memory statuses
Some of the above items are only applicable if the Orchestration Agent is installed on the VM.
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¢ Double-click the Host entry to view that host server’s details tabs.

¢ Double-click the Repository entry to view that storage item’s details tabs.

Wherever N/A appears in the details, it means that the information is not available.

Monitoring Tab

For information on the Monitoring tab, see “Monitoring Tab” on page 74, which documents this tab
for host servers. The functionality is the same for VMs, although the information displayed can be
different.

Event Log Tab

This details tab is used by VMs and host servers:

Figure 5-2 Event Log Tab for VMs

i plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory # sles1032bit-2 [Running]

« Virtual Machines (m] |?| |ﬁ| (=] |

test-32bit

EventLog

User Start Time Elapsed
mplete

gent connection)

32bitTemplate

32bitc1

¥ Host Servers

b Storage

Templates

| & Orchestrate | 18 yersion Info | Show/Hide Progress View
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5.2

You can do the following with this tab:

¢ View the Event Log information.

¢ Double-click an event item that contains the [i]icon to view the details of the event as reported
by the Orchestration Server. The following is an example of an event’s details:

i Event Log for action ‘Check Status’ |:|E]

Double Click an an item to show additional details.

2009/06/01 VM status chedk initiated by 'system’.

2009/06/01 @ Provisioning job 'system.xen30.65 submitted to perform 'Chedk Status' action

20090601 Waiting for provision adapter to start to perform 'Chedk Status’ action.
2009/06/01 Resyncng VM status,
2009f06/01 WM discovery reported VM as 'down’

2009/06/01 Shutdown complete.

Using Feedback to Manage VMs

The VM Client is integrated with the Orchestration Server and the Orchestration Console to provide
details from any Orchestration jobs that are started by actions you take in the VM Client. This
provisioning log integration enables you to see the current status on jobs that are running and to
review the status of jobs that are finished. The information is provided in three levels: actions taken,
provisioning logs, and job logs. You do not need to open the Orchestration Console to discover the
status of jobs started in the VM Client.

The = icon is displayed in Status columns when a VM is in a progress state. The Status column can be
viewed in the Virtual Machines view and in the VMs sections of the Summary tabs for host servers and
templates.

Other actions cannot be performed on a VM when it is in a progress state (the « icon) because
Orchestration jobs are run sequentially per VM.

If you double-click a VM that is in a progress state, its Event Log tab is immediately displayed.

All logging information is dynamically updated so that you do not need to refresh or return to a view
to see event changes.

Even if you log in and log out of the VM Client, all logs are maintained and continue to progress so
that you can still monitor an action after logging back in to the VM Client.

You can view the progress of any action, including error information, using the following features:

¢ Section 5.2.1, “Progress View,” on page 88

¢ Section 5.2.2, “Progress Bar for Details Views,” on page 90
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*

Section 5.2.3,
Section 5.2.4,
Section 5.2.5,
Section 5.2.6,

*

*

*

5.2.1

“Progress Bar in a Tool Tip,” on page 92
“Event Log Tab,” on page 94

“Event Logs,” on page 94

“Error Log,” on page 97

Progress View

The Progress View displays the progress of all VM actions initiated by any VM operator. To use the

Progress View:

1 The Progress View section is displayed by default; if it is not being displayed, do one of the

following:

¢ In the VM Client, click View > Show Progress View.

¢ In the VM Client, double-click Show/Hide Progress View in the lower right corner of the VM
Client window.

The following view is displayed:

£ plateSpin Orchestrate YM Client

Inventory

13
»

Host Servers

Storage

Templates

Virtual Machines

VIEW HELP

Virtual Machines

=] =) 01 =]

Name Status Notes Host as CPU Memory
test-32bit u SUSE Linux Enterprise
sles1032bit-2 - dat112.provo.nov SUSE Linux Enterprise
sles1032-test | | SUSE Linux Enterprise
sles64bit | | SUSE Linux Enterprise
SLES32bit #* SUSE Linux Enterprise
sled10-32bit | Other operating syste
RHELS n Other operating syste
RHat-T1 | Other operating syste
RHat-C1 n Other operating syste
MyPXE - ZRG64bit SUSE Linux Enterprise
J2bifTemplate n SUSE Linux Enterprise
32bitct | SUSE Linux Enterprise
Progress View
Object Name Action Status User Elapsed Time % Complete
SLES32bit Provision Starting VM system 0:00:00:05 [CEECC | |
& Orchestrate | 1 Version Info | Show/Hide Progres:
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2 For another view of the progress bar with other information, mouse-over the [flicon in the Status
column for the Inventory item:

f' PlateSpin Orchestrate VM Client

ELE EpIT Al TEW HELP

Inventory

Virtual Machines

b Host Servers
»

Storage

Templates Name Status Notes Host 0s CPU Memory

test-32bit u SUSE Linux Enterprise

sles1032bit-2

da112.provo.nov SUSE Linux Enterprise
sles1032-test

slesG4bit

SUSE Linux Enterprise
SUSE Linux Enterprise

Action: Provision
Action Detail: Starting VM
Start Time: 2009-06-03 13:29:17
Elapsed Time: 0:00:00:08

e LT —
Brief Log: 2009,/06/03 01:29:22 Provisioning job 'system. xen30, 100" submitted to perform Provision’ action
2009/06,03 01:29:22 Waiting for provision adapter to start to perform 'Provision’ action,
2002,06/03 01:28:22 Starting VM.
SUSE CINOX ENTETOISe

sled10-32bit
RHELS

RHat-T1
RHat-C1
MyPXE
32bitTemplate
32bitc1

HE E Y EEEEEIEE Y

Progress View
Object Hame Action Status User Elapsed Time
SLES32bit Provision Starting VM system 0:00:00:06

% Complete

For more information, see Section 5.2.3, “Progress Bar in a Tool Tip,” on page 92.

3 To view information specific to a progress task, mouse-over the name in the Status column of the
Progress View section:

f| PlateSpin Orchestrate VM Client

FILE EDIT AC VIEW HELP

Inventory Virtual Machines

b Host Servers

» Storage
Templates Status Notes Host o8 CPU Memory
test-32bit [ | SUSE Linux Enterprise
sles1032bit-2 - dat12.provo.nov SUSE Linux Enterprise
sles1032-test [ | SUSE Linux Enterprise
slesB4bit [ ] SUSE Linux Enterprise
SLES32bit * SUSE Linux Enterprise
sled10-32bit [ | Other operating syste
RHELS [ ] Other operating syste
RHat-T1 [ | Other operating syste
RHat-C1 [ ] Other operating syste
MyPXE - ZRe4bit SUSE Linux Enterprise
32bitTemplate [ | SUSE Linux Enterprise
32bitc1 [ ] SUSE Linux Enterprise
Progress View
‘Object Name Action Status User Elapsed Time % Complete

SLES32bit Provision Starting VI svstem 0:00:00:07 L[ T11] | |
2009/06/03 01:33:19 VM provision/frestore initiated by 'system’

2009/06/03 01:33:19 Waiting for vmhost assignment.

20090603 01:33:22 VM has been assigned the vmhost: 'dai1l_xen30' using repository
‘OfficeRepo’

2009/06/03 01:33:22 Provisioning job ‘system.xen30, 102' submitted to perform Provision'
action

For more information, see Section 5.2.5, “Event Logs,” on page 94.
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5.2.2 Progress Bar for Details Views

If you start an action on a VM from within a details view, a progress bar is displayed in the upper

right of the VM Client window. To view it:

1 To get a VM in an action state, in the host server’s Summary tab, right-click a VM and select an

action.

2 To view a progress bar on the host server’s details tab view, mouse over the VM:

‘il plateSpin Orchestrate VM Client

FLE EpIT ACTIONS VIEW HELP

Inventory 1 dai12.provo.novell.com
Virtual Machines (&) (o) |

= Host Servers

datit Summary Configuration

da112.provo.novell.com
ZRB4bit
Discovered [1]

F  Storage

Templates

Memory

Storage Name Stored ...

Ls

Monitaring

Type

[Agent Running]

Event Log

Notes

Capadty Free Mame = MAC Address Metwork

al

grid

Network At

Status
*

Notes

Action:
Action Detail:
Start Time:
Elapsed Time:
% Complete:
Brief Log:
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Suspend

Suspending VM
2009-06-03 13:36:39
0:00:00:34

E—)

2005/06/03 01:36:40 Provisioning job 'system.xen30. 105 submitted to perform ‘Suspend’ action
2005/06/03 01:36:40 Waiting for provision adapter to start to perform 'Suspend' action.
2009/06/03 01:36:40 Suspending VM.

| & Orchestrate ] il Version Info | Show/Hide Progress View




3 In the Virtual Machines view, double-click the VM.

This changes the to details view to of the VM and displays the progress bar and progress
description in the upper right of the VM Client window:

il PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory sles1032bit-2 [In Progress: Suspending VM]
~ \irtual Machines (=] (=] (1] ) | |
test-32bit

sles1032bit-2 Summary Monitoring EventLog

sles1032-test

slesG4bit
SLES32bit

Action User Start Time

2bitTemplate
2

3
2

bitcd

~ Host Servers
Discovered [1]

»  Storage

Templates

Orchestrate | i version Info |  ShowHide Progr

The progress bar shows the percentage completed. It only displays for a selected VM that has an
action in progress.

4 To view the log information, do one of the following:

¢ Single-click the text to the left of the progress bar:

¥ sles1032bit-2 [In Progr Suspending VM]
EEEFE | e

Summary Monitoring Ewvent Log Suspending VM
Click to see details...

Status User Start Time Elapsed ...
Shutdown complete systern  2009-06-01 15:50:28 0:00:00:02

VM ¢ agent connection)

Summary i VM shutting down
Double dick to see details...

User Start Time

2005-06-01 1
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This opens the Event Log dialog box:

i Event Log for action ‘Check Status’ |:|E]

Double Click an an item to show additional details.

2009/06/01 VM status chedk initiated by 'system’.

2009/06/01 @ Provisioning job 'system.xen30.65 submitted to perform 'Chedk Status' action

2009/06/01 Waiting for provision adapter to start to perform 'Chedk Status' action.
2009/06/01 Resyncng VM status,

20090801 VM discovery reported VM as 'down'

2009/06,/01 Shutdown complete.

You can click any [i] icons that are displayed for more detailed log information.

5.2.3 Progress Bar in a Tool Tip

There are two places where you can use the mouse-over function to view progress information:

* You can view the progress of an action by mousing over its = icon in the Status column of the
Virtual Machines view, or the Status column of the Summary tabs for host servers and templates:

L PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Virtual Machines

= Host Servers

Discovered [1]

Name Status Notes Host 0s CPU Memory
test-32bit ] SUSE Linux Enterprise
sles1032bit-2
sles1032-test
slesG4bit
SLES32bit
sled10-32bit

¥ Storage

Templates

SUSE Linux Enterprise

SUSE Linux Enterprise
dal11 SUSE Linux Enterprise
SUSE Linux Enterprise
Other operating syste

Other anerating evete
Action: Provision

RHat-T1
T Action Detail: Starting YM

Start Time: 2009-06-03 13:52:24
MyPXE Elapsed Time: 0:00:00:03
32bitTemplate

H E vy E EEJE E Y E O

R T —

Brief Log: 2009/06/03 01:52: 26 Provisioning job 'system.xen30.111' submitted to perform Provision’ action
2009/06/03 01:52: 26 Waiting for provision adapter to start to perform 'Provision’ action.
2009/06/03 01:52: 25 Starting VM.

32bitc1

Progress View

Object Name Action Status User Elapsed Time % Complete

RHELS Provision Starting VM system 0:00:00:03 [CECTT | |

| ® orchestrate | il VersionInfo | Show/Hide Progre:
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* You can view the status log of the action by mousing over the entry in the Status column in the
Progress View:

f| PlateSpin Orchestrate VM Client

HELP

Inventory Virtual Machines

rtual Machines (a] |

~ Host Servers

Discovered [1]

Name Status Notes Host 0s CPU Memory
} Storage test-32bit n SUSE Linux Enterprise
Templates sles1032bit2 o SUSE Linux Enterprise
sles1032-test [ | SUSE Linux Enterprize
#* SUSE Linux Enterprise
SLES32bit [ | SUSE Linux Enterprise
sled10-32bit | | Other operating syste
RHELS [ | Other operating syste
RHat-T1 [ | Other operating syste
RHat-C1 [ | Other operating syste
MyPXE [ ] ZRE4bit SUSE Linux Enterprise
32bitTemplate [ | SUSE Linux Enterprise
32bitc1 [ | SUSE Linux Enterprise
Progress View
Object Hame Action Status User Elapsed Time % Complete

slesB4bit Provision Starting

2003/06/03 01:51: 28 VM provision restore initiated by 'system’

2005/05/03 01: 51: 28 Waiting for vmhost assignment.

2003/05/03 01:51: 30 VM has been assigned the vmhost: 'da111_xen30' using repository
'OfficeRepa’

2009/05/03 01: 51:30 Provisioning job 'system.xen30, 110" submitted to perform Provision'
action
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5.2.4 Event Log Tab

You can view the progress of all actions for a VM by viewing its Event Log tab:
1 Inthe VM Client, click Virtual Machines to display the VMs, then do one of the following to open
its details views:
¢ Double-click the VM, then click the Event Log tab.
¢ Right-click the VM, select Show Details, then click the Event Log tab.
The following view is displayed:

‘i plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory i sles64bit [Running]

() (=]0) @

= \firtual Machines

test-32bit
sles1032bit-2 Summary Moritaring Eventlog

sles1032-test

SLES32hit

sled10-32bit

RHEL5
Hat-T1
Hat-C1
MyPXE
32bitTemplate Provision
32bitc shutdo

User Start Time

n from template

~ Host Servers

Discovered [1]

b Storage

Templates

& Orchestrate | T8 VersionInfo | Show/Hide Progress View

2 To view the information in a different order, click any column to sort by that column.
Click the column again to reverse the sorting order.

3 To quickly locate specific information, click anywhere in the list, then begin typing a search
string.

This opens the locator pop-up and selects the first match. You can modify the string to refine the
search, and you can use the up-arrow and down-arrow to move from match to match.

4 To view more detailed information for an entry, double-click its [i] icon.

For more information, see Section 5.2.5, “Event Logs,” on page 94.

5.2.5 EventLogs

You can view the progress of an action by accessing its individual event logs:

1 In the VM Client, do one of the following to open the Progress View section:
¢ In the VM Client, click View > Show Progress View.

¢ In the VM Client, double-click Show/Hide Progress View in the lower right corner of the VM
Client window.

94 NetlQ Cloud Manager 2.1 VM Client Guide and Reference



The following view is opened:

£ PlateSpin Orchestrate VM Client

VIEW HELP

Inventory Virtual Machines

Virtual Machines

F Host Servers
3

Storage

Templates Name Status Notes Host 0s CPU Memory
test-32bit | | SUSE Linux Enterprise
sles1032bit-2 - dat112.provo.nov. SUSE Linux Enterprise
sles1032-test n SUSE Linux Enterprise
sles64bit | SUSE Linux Enterprise
SLES32bit #* SUSE Linux Enterprise
sled10-32bit | Other operating syste
RHELS n Other operating syste
RHat-T1 | Other operating syste
RHat-C1 u Other operating syste
MyPXE - ZR64bit SUSE Linux Enterprise
32bitTemplate u SUSE Linux Enterprise
32bitct | | SUSE Linux Enterprise
Progress View
DObject Name Action Status User Elapsed Time % Complete
SLES32bit Provision Starting VM system 0:00:00:05 (I |

| & orchestrate | 18 yersion Info | Show/Hide Progress View

2 In the Progress View section, do one of the following:

¢ Double-click the entry that is displayed in the Status column.

¢ Right-click the entry that is displayed in the Status column and select Show Log.
The following dialog box is displayed:

i Event Log for action ‘Check Status’ |:|E]

Double Click an an item to show additional details.

2009/06/01 VM status chedk initiated by 'system’.

2009/06/01 @ Provisioning job 'system.xen30.65 submitted to perform 'Chedk Status' action

2009/06/01 Waiting for provision adapter to start to perform 'Chedk Status' action.
2009/06/01 Resyncng VM status,
2009f06/01 WM discovery reported VM as 'down’

2009/06/01 Shutdown complete.
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These events are logged dynamically in the Event Log dialog box. Events with the [l icon
provide further detail (see Step 5).

You can also view this dialog box for VMs that are in an unknown state (the 7 icon).
3 To view the information in a different order, click any column to sort by that column.
Click the column again to reverse the sorting order.

4 To quickly locate specific information, click anywhere in the list, then begin typing a search
string.

This opens the locator pop-up and selects the first match. You can modify the string to refine the
search, and you can use the up-arrow and down-arrow to move from match to match.

5 For further job details on an event, double-click its [i] icon:

{' Event Log Details for Host ‘ZR64bit’ M=

' Details for item: VM Host

/

Provisioning job started for discovery of ¥M host 'ZR&4bit_xen30'

discoverVmHost_event requested by 'system’ to discover vm's on hosts [ZR&4bit_xen307.
» discover
rer_mode: hostState

erHostState(vmhost=ZR64bit_xen30)

erHo

aq 1 info’

g ¥enmax_para_memory ine: max_para_memory : 1451
g _hwm_memory line: max_hvm_memory : 1439
g Xen Major version:

: wen-3.0-x86_64 wen-3.0-x86_32p hvm-3.0-x86_32

_64 xen-3.0-x86_32p

it] XEM_VMBuilder is enabled.
[ZRA4bit] Getting ist with xm toal
host_status_discovered_event for host 'ZR64bit_xen30'

| Copy to Clipboard

These details are logged dynamically in the Event Log Details dialog box.

Only the Event Log entries that have further job information available have the [i] icon in the
Additional Information column.

You can have multiple Event Log Details dialog boxes open simultaneously to monitor multiple
tasks for the same VM or for multiple VMs.

The Event Log Details dialog box provides the same information as the Job Details dialog box in
the Orchestration Console.
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5.2.6

Error Log

To use the Error Log section:

1 In the VM Client, click View > Show Error Log to display the Error Log section:

PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS ! HELP

Inventory ' slesb4bit [Running]
~ \irtual Machines (a) [ | |

test-32bit

sles1032bit-2

sles1032-test

SLES32bit

sled10-32bit

RHEL5S

RHat-T1

RHat-C1

MyPXE

Summary Monitoring Event Log

Status
0 shutdown complete

User Start Time Elapsed ...

32bitTemplate
32bitct

~ Host Servers
Discovered [1]

b Storage Progress View

Templates

Object Name Action Status User Elapzed Time % Complete

Error Log - Workspace Log

Norkspace Log
type filter text

Message Plug-in Date

| ® oOrchestrate | 18 yersion Info | Show/Hide Progress View
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2 To view further information on an error, double-click the error to display its Event Details dialog
box:

' Event Details El El r's—_<|

Date: 2008-06-03 11:13:19.437
Severity: '@1 Errar

Message: | null argument:
Y
4|3

org. edipse.core.runtime. AssertionFailedException: null argument: ~
at org.edipse.core.runtime, Assert. ishothull{Assert.java: 36) F
at org.edipse,core.runtime. Assert.isMotMull{Assert.java: 74

at org.edipse.jface.resource. StringConverter.asString(StringConver ter. java: 300)

at org.edipse,ui.internal. themes. ThemeReqistryReader . checkColorFactory(ThemeRegistryR
at org.edipse.ui.internal. themes, ThemeR egistryReader . getColorValue{ThemeR egistryR.ead:
at org.edipse,ui.internal, themes, ThemeRegistryReader . readColor{ThemeR eqgistryReader.ja
at org.edipse,ui.internal. themes, ThemeReqistryReader . readElement(ThemeReqistryReader
at org.edipse.ui.internal registry.RegistryReader .readElements(RegistryReader.java: 144)
at org.edipse,ui.internal . registry.RegistryReader .readExtension(RegistryReader. java: 155)
at org.edipse.ui.internal.registry.RegistryReader.readReqistry(RegistryReader. java: 176)
at org.edipse.ui.internal, themes, ThemeRegistryReader . readThemes{ThemeR eqgistryR.eader
at org.edipse,ui.internal. themes. WorkbenchThemeManager .updateThemes{(WorkbenchTher
at org.edipse,ui.internal, themes, WaorkbenchThemeManager. access $0{(WorkbenchThemeMa
at org.edipse,ui.internal. themes. WorkbenchThemeManager 53, handleEvent{WorkbenchThe:
at org.edipse,swt.widgets.EventTable.sendEvent(EventTable java:&84)

at org.edipse.swt.widgets. Display. sendEvent{Display. java: 3952)

at org.edipse,swt. widgets.Display.runSettings(Display. java: 3860)

at org.edipse.swt.widgets. Display. messageProc(Display.java: 3033) bl
£ | p

Exception Stack Trace:

Session Data:

5.3 Virtual Machine Actions

All of the actions that you can perform on a VM can be tracked during execution by viewing the
logging messages in the Event Log tab for the VM, and in the Event Log and Event Details dialog
boxes (see Section 5.2, “Using Feedback to Manage VMs,” on page 87). These logs provide a history
of all VM actions.

You can also see which VM operator initiated an action. The VM operator’s login name is displayed
in the User column of the Event Log details tab for the VM. For information on setting up different VM
operator login names, see Appendix D, “Adding User Logins for VM Operators,” on page 201.
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53.1

Even if you log in and log out of the VM Client, all logs are maintained and continue to progress so

that you can still monitor an action after logging back in to the VM Client.

You can do the following for hands-on management of VMs:

*

*

*

Section 5.3.1, “Understanding a VM’s Status,” on page 99

Section 5.3.2, “Canceling a VM’s In-Progress Action,” on page 100
Section 5.3.3, “Starting a VM,” on page 100
Section 5.3.4, “Shutting Down a VM,” on page 102

Section 5.3.5, “Accessing a VM’s Console,” on page 103

Section 5.3.6, “Pausing a VM,” on page 103

Section 5.3.7, “Resuming a Paused VM,” on page 103

Section 5.3.8, “Suspending a VM,” on page 104

Section 5.3.9, “Resuming a Suspended VM,” on page 104

Section 5.3.10, “Resynchronizing a VM’s State,” on page 105

Understanding a VM's Status

In the Virtual Machines view, the Status column indicates the state of each VM:

Table 5-1 VM Status Icons

Icon VM's Status Enabled Actions for the Selected VM
o Has been defined oris  Show Details, Install, Edit, Resync State, Delete, New VM, and Remove
being defined. from Group.
The VM is eligible to be installed.
Has an action that is in  Other actions cannot be run against this VM until the current action has
progress. finished.
[ Is running. Show Details, Restart, Suspend, Pause, Shut Down, Edit, Resync
State, Migrate, New VM, Show Console, and Remove from Group.
[ ] Is down. Show Details, Start, Edit, Create Template, Resync State, Move, Delete,
Install Agent, New VM, and Remove from Group.
i Is paused. Show Details, Resume, Edit, Resync State, Delete, New VM, and
Remove from Group.
o Is suspended. Show Details, Resume, Edit, Resync State, Move, Delete, New VM, and
Remove from Group.
7 The state is unknown.  Show Details, Edit, Resync State, Delete, New VM, and Remove from

Group.

For information on making an unknown state known, see Section 4.5,
“Resynchronizing a Host Server’s State,” on page 80 and
Section 5.3.10, “Resynchronizing a VM's State,” on page 105.

VM statuses are updated globally; they show any status change that is made in your local instance of
the VM Client and any change made from other VM Client instances being run by other VM
operators.
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You can tell whether a VM or host server has the Orchestration Agent installed on it by whether there
are pie charts in its CPU and Memory columns, but only if the VM or host is running at the time.

5.3.2 Canceling a VM's In-Progress Action

Sometimes the progress hangs for an action taken on a VM, or you might change your mind about
continuing with the action. You can do the following;:

¢ To determine whether an action is progressing normally, double-click the « icon to open the
Event Log tab for the VM and review the log entries.
For more information, see Section 5.2, “Using Feedback to Manage VMs,” on page 87.

¢ To cancel an action in the VM Client, right-click the VM in the Virtual Machines view, then select
Cancel Action.

¢ To cancel an action in the Orchestration Console, go to the Explorer tree view. Under the
Resources subsection, locate the VM in one of the Resources subsections (such as VMs), right-click
the VM, then select Cancel Action.

In the VM Client window, the Status column should now show the previous state of the VM.

5.3.3 Startinga VM

In order to start a VM on a host server, the following conditions must exist:

¢ The VM'’s files and image must be either:
¢ Stored locally on the host server.
or
¢ Stored in a shared repository accessible by the host server.

¢ The host server and VM must have the same architecture (such as 32-bit or 64-bit), mount points,
and routing of network connections to the virtual network.

For example, a 64-bit paravirtualized guest created on a 64-bit hypervisor can be started on a
host server running a 64-bit hypervisor, but not a 32-bit hypervisor. Or, a 32-bit VM created on a
64-bit hypervisor can be started on a 64-bit hypervisor host. In other words, you cannot start a
VM on a host that has a different architecture from the host where the VM was created.

¢ The host server cannot be fully utilized, because it would be incapable of hosting the VM.

+ The host server cannot have met its maximum allowable VMs. This value is set in the
Orchestration Console in the Max Hosted VMs field. The default is 8. It does not matter whether
the maximum VMs that the host server is already hosting are fully utilizing it.

¢ The VM cannot be disabled by having its Resource Enabled check box deselected in the
Orchestration Console. By default, this check box is enabled.

¢ The VM cannot be out of sync, which can occur if it is manually accessed or manipulated via a
third-party tool. For example, you could manually start the VM on the physical host machine.
However, you can resynchronize the VM with the Orchestration Server.

Host servers are only available if they are not out of sync.
These conditions are automatically enforced with constraints.

If the above criteria are met by the VM and only one host server, then the VM is automatically started
on that host server, provided the VM’s files reside on that server or in a shared repository.
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If the criteria are met by multiple host servers and the VM's files reside in a shared repository, you
can start the VM by selecting any host server, or by selecting to have the Orchestration Server
automatically select the host server.

If no host servers meet these requirements, or if the VM does not meet its requirements, the No Start
Target Available dialog box is displayed, indicating that you need to resolve the issues to continue.

You can start any VM that is not running. However, starting a paused or suspended VM can cause its
previously saved state to be lost. For more information on paused or suspended VMs, see
Section 5.3.6, “Pausing a VM,” on page 103 and Section 5.3.8, “Suspending a VM,” on page 104.

To start a VM:

1 In the VM Client, click the Virtual Machines view.

2 Do one of the following:
¢ Click the VM that you want to start, then click the I button.
¢ Click the VM that you want to start, then click Action > Start.
¢ Right-click the VM that you want to start, then select Start.

If only one host server is available, it is automatically used if the VM’s files are either stored on
that server or in a shared repository.

If there are two or more target host candidates, the following dialog box is displayed if the VM’s
files are stored in a shared repository:

i Select Host to Start the VM "SLES32bit’
MName: SLES32bit Host: NJA  Reposi

criteria are
to automatical

Mame Status Active YMs | Notes Technology CPU Memary

dal1l - 0 @0 &
da112.provo.novell.com . 9o [ "B

Auto-select the target host

3 Select a host server, or select the Auto-Select the Target Host check box.

The Auto-Select the Target Host option allows the Orchestration Server to automatically select a
host server from those that are available by using ranking criteria such as architecture similarity
and available CPU and RAM resources. For example, hosts are selected that meet the
architecture requirements, the cost of moving information is then considered, and if there is still
no clear winner, then the least loaded machine is selected. The ranking criteria can be affected by
policies that you might have set in the Orchestration Console.

The VM starts, using the processes for the operating system it is running. You can use the Show
Console menu option to authenticate if you want to view its console and log in to the operating
system.
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If there is no available host server for starting the VM, the following dialog box is displayed:

i No Available Host Targets |;|EJ®

targets found to migrate the VM %
planation for each host in the tabl

#ofVMs | Explanation Virtuglization Technology CPU Memory

as insuffident virtual memory for guest VM XEN 3.2 [ T}l & 22
3 WM host has insuffident virtual memory for guest VM XEN 3.2 90 [ O

4 Review the issues, resolve them, then repeat from Step 2.
5 You can view the startup progress in any of the following ways:

¢ Double-click the VM being started, click the Event Log tab, then double-click the entry
related to the starting process that has the [{]icon next to it. The Event Log Details dialog
box is displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.

¢ View its progress in the Jobs tab of the Orchestration Console.

5.3.4  Shutting Down a VM

Shutting down a VM is the same as shutting down any computer. Its current state is not saved. If you
want to retain a VM'’s state, use one of the following options instead:

¢ Section 5.3.6, “Pausing a VM,” on page 103

¢ Section 5.3.8, “Suspending a VM,” on page 104

To shut down a VM:

1 In the VM Client, click the Virtual Machines view.
2 Do one of the following:
+ Select the VMs to be shut down, then click the I button.
* Select the VMs to be shut down, then click Actions > Shut Down.
¢ Right-click each VM to be shut down, then select Shut Down.
The selected VMs are shut down. Their current state is not saved.
3 You can view the shutdown progress in any of the following ways:

¢ Double-click the VM being shut down, click the Event Log tab, then double-click the entry
related to the process that has the [i] icon next to it. The Event Log Details dialog box is
displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.
¢ View its progress in the Jobs tab of the Orchestration Console.

4 To restart a VM that is shut down, continue with Section 5.3.3, “Starting a VM,” on page 100.
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5.3.5 Accessing a VM's Console

1 In the VM Client, click the Virtual Machines view.
2 Do one of the following:
+ Select the VM, then click the button.
* Select the VM, then click View > Show Console.
¢ Right-click the VM, then select Show Console.
3 Provide the VNC password, then click OK.

5.3.6 PausingaVM

If you need to free up CPU cycles on the host machine, you can pause some of the VMs. This option
writes the current state of the VM to the host machine’s RAM so that it can be recovered by resuming
the VM. A paused VM can also be moved to a suspended state without resuming it first.
1 In the VM Client, click the Virtual Machines view.
2 Do one of the following:
¢ Select the VMs to be paused, then click the Il button.
¢ Select the VMs to be paused, then click Actions > Pause.
¢ Right-click the VMs to be paused, then select Pause.
Each VM’s state is saved to RAM on the host machine.

WARNING: If you use the Restart option to reboot a VM, its previous state is lost. If you want to
recover its previous state, use the Resume option, which reads the VM information from the host
machine’s RAM.

Also, if you reboot the host machine, the VM'’s state is lost, because it was saved to the host
machine’s RAM. To prevent the loss of a VM’s state when you need to reboot the host machine,
first use the Suspend option to suspend the VM.

5.3.7 Resuming a Paused VM

1 In the VM Client, click the Virtual Machines view.

2 Do one of the following:
¢ Select the VMs to start again, then click the I button.
¢ Select the VMs to start again, then click Actions > Resume.
¢ Right-click the VMs to start again, then select Resume.

The previous state of the VM is restored from the information that was written to the host
machine’s RAM when the Pause option was used.

If the VM'’s console was open, it reopens automatically.
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5.3.8 Suspending a VM

If you need to temporarily free up RAM on your host machine, or to save the state of any VMs
running when you reboot the host machine, use the Suspend menu option. This option writes the
current state of the VM to the host machine’s hard drive so that it can be recovered by resuming the
VM.
1 In the VM Client, click the Virtual Machines view.
2 Do one of the following:
¢ Select the VMs to be suspended, then click the IE) button.
¢ Select the VMs to be suspended, then click Actions > Suspend.
¢ Right-click the VMs to be suspended, then select Suspend.

When you select multiple VMs, each suspend operation is done according to how jobs are
handled by Orchestration Server.

WARNING: If you use the Restart option to reboot the VM, its previous state is lost. If you want
to recover its previous state, use the Resume option, which reads that information from the host
machine’s hard drive.

3 You can view the progress in any of the following ways:

¢ Double-click the VM being suspended, click the Event Log tab, then double-click the entry
related to the process that has the [i] icon next to it. The Event Log Details dialog box is
displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.

¢ View its progress in the Jobs tab of the Orchestration Console.

5.3.9 Resuming a Suspended VM

1 In the VM Client, click the Virtual Machines view.

2 Do one of the following:
¢ Select the VMs to start again, then click the I button.
¢ Select the VMs to start again, then click Actions > Resume.
¢ Right-click the VMs to start again, then select Resume.

The previous state of the VM is restored from the information that was written to the host
machine’s hard drive when the Suspend option was used.

If you had the VM's console open, you need to reopen it by using the Show Console menu option.
3 You can view the progress in any of the following ways:

¢ Double-click the VM being resumed, click the Event Log tab, then double-click the entry
related to the process that has the [i] icon next to it. The Event Log Details dialog box is
displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.

¢ View its progress in the Jobs tab of the Orchestration Console.
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5.3.10 Resynchronizing a VM's State

The Orchestration Server is automatically updated to show the VM's state after every provisioning
action. However, the VM's state is not automatically updated in the Orchestration Server if the VM
state is changed by any third-party tool or by manually manipulating the VM on the physical host
machine (for example, if you use virt-man or XM, or if some process dies). You must manually
synchronize the VM's state in the Orchestration Server to reflect the VM’s current state.

Resynchronizing a VM allows the Orchestration Server to determine the state of the VM and update
the Orchestration Server with that state.

To resynchronize a VM:

1 In the VM Client, click the Virtual Machines view.
2 Right-click the VM to be resynchronized, then select Resync State.
You cannot select multiple VMs for this operation.

If the resync state is not automatically updated for the VM, open the VM’s details page for the
VM in either of the following ways to get the updated status.

¢ Double-click the VM.
¢ Right-click the VMs, then click Show Details.
3 You can view the progress in any of the following ways:

¢ Double-click the VM being synchronized, click the Event Log tab, then double-click the
entry related to the process that has the [i] icon next to it. The Event Log Details dialog box
is displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.

¢ View the synchronization progress in the Jobs tab of the Orchestration Console.

5.4 Creating a Xen VM

Refer to the appropriate third-party documentation for how to create VMs for VMware ESX Server
and Microsoft Windows Server 2008 with Hyper-V. To bring them into the virtualization grid, see
Section 2.6, “Discovering VMs of the Registered VM Hosts,” on page 24.

To create a new Xen VM for the virtualization grid that you are logged in to, run the Virtual Machine
Properties Wizard:

1 In the VM Client, do one of the following to start the wizard:
¢ Click the HIE®RTE button in any view.
¢ Click File > New VM in any view.
¢ Press Ctrl+N in any view.

¢ Right-click any listed item in any view, then select New VM.
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The following wizard page is displayed:

il Virtual Machine Properties

Description

Enter a unique name without spaces or spedal characters

Guest Operating System
SUSE Linux Enterprise Server 10

Virtualization Mode Architecture
Paravirtualization Intel x86

Install Source
-- Select Install Source from the drop down list or enter it here —

Auto Install File
-- Select path from the drop down list or enter it here (you may use a file browser]

Additional Arguments

Required field

2 Fill in the fields to define the basic information for the VM:
VM Name: (Required) Name for the VM.
This name applies to all versions of the VM and must be unique. It cannot already exist in either
the Virtual Machines or Templates lists.
The name cannot be longer than 100 characters and cannot start with the letters “xen.”

Description: Note the purpose and any other specifics you might require of the VM. These notes
apply to all versions of this VM.

UUID: Displays the UUID for the VM. This field is view-only.

Guest Operating System: The operating system you want to install on your VM. The following
are supported:

SUSE Linux Enterprise Server 8
SUSE Linux Enterprise Server 9
SUSE Linux Enterprise Server 10
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Desktop 10
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SUSE Linux Enterprise Desktop 11
openSUSE

openSUSE 11

Novell Open Enterprise Server 2 (Linux)
Novell Open Enterprise Server 2 (NetWare)
Novell NetWare 6.5 SP6 and earlier

Red Hat Enterprise Linux 3

Red Hat Enterprise Linux 4

Red Hat Enterprise Linux 5

Solaris 9 and older

Solaris 10

Microsoft Windows NT

Microsoft Windows XP, 2000, 2003
Microsoft Windows XP, 2003 (x64)
Microsoft Windows Vista

Microsoft Windows Vista (x64)
Microsoft Windows Server 2008
Microsoft Windows Server 2008 (x64)

There is also an “(other)” option for the following;:

SUSE
Red Hat
Microsoft Windows

Virtualization Mode: Full Virtualization is hardware assisted virtualization, meaning the guest
runs on an operating system that is aware it’s being virtualized. Microsoft Virtual Server with
Hyper-V is an example of full virtualization. Paravirtualization means that the operating system
directly accesses elements of the hardware, including processor, display, memory, network
interface card, and hard drive, and uses the hypervisor to emulate other hardware interactions.
Xen is an example of a paravirtualization. However, Xen can also do full virtualization.

Paravirtualization performs much faster and with better hardware efficiency than full
virtualization. However, full virtualization enables complete decoupling of the software from
the hardware, which streamlines migration between servers.

NOTE: Refer to the SUSE Linux Enterprise Server (SLES) and Red Hat Enterprise Linux (RHEL)
documentation to verify supported platforms in each virtualization mode.

Architecture: The type of processor you want to have as the virtual processor for the VM.

Install Source: (Required, if not PXE) The path to the installation media for your guest operating
system. For a fully virtualized VM, the install source must be an ISO. For a paravirtualized VM,
an ISO or network install source is required. For more information, see Appendix A, “VM
Installation Sources,” on page 195.
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Use a PXE Install Source: This feature is only available when you select Full Virtualization in the
Virtualization Mode field, and it works only if the host server that is selected for building this VM
is on a network where PXE is running.

il Virtual Machine Properties

Description

VI

M
Storage Devices
Desc

Name
Hetwork
i riﬁmt
D ad1133f0-9afd-4f7c-83c9-10f0f0059 1

Version

Guest Operating System
SUSE Linux Enterprise Server 10 A

Virtualization Mode Architecture
Full virtualization - Intel %86

Install Source 4 Use a PXE Install Source

- Select Install Source from the drop down list or enter it here —

Required field -I Next> | Install. | Appy | Cancel

If you select this option, it disables the Install Source, Auto Install File, and Additional Arguments
fields. The installation is then done from a PXE menu that is displayed when you are
automatically connected to the target VM via VNC after you click Install.

IMPORTANT: The default timeout for the PXE menu’s autoboot might be too short because of
the time that it takes for VNC to connect with target VM. For example, if your PXE timeout is set
to 10 seconds, most of that might be used up in getting the PXE menu to display via VNC. If you
want to select the installation source from the PXE menu, we recommend that you change it to a
timeout value that works for you, such as 15 or 20 seconds.
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Auto Install File: This field applies only to paravirtual installations. The file listed here is used
to populate the answers needed during the installation of the guest operating system. Some
examples include time zone, language, firewall, and other settings given in response to the user
interactive areas of the installation. An AutoYaST file listed here can contain network settings
that are applied during the VM Builder job. For RHEL, the file is a kickstart file.

IMPORTANT: The auto install file must reside locally on the machine where you are running
the VM Client. It cannot be used from a host machine or another machine in your network.

Additional Arguments: This field applies only to paravirtual installations. These are Linux
install arguments, which are operating system parameters similar to the information entered in a
GRUB boot loader when running on bare hardware in SUSE Linux Enterprise Server (SLES) and
SUSE Linux Enterprise Desktop (SLED). Additional network installation information can be
added here, which is used during the build process to find the installation source for the VM
build process.

3 Click Next to display the following wizard page:

il Virtual Machine Properties

Hardware

Enter the password that should be used to gain access to the remote console for this WM,

Description

Storage Devices
Hetwork

Memory Size

Display Driver

@ Girrus Logic GD5446 VGA

© Paravirtualized Graphics Driver

Remote Console Password Console Password Again

Required field | =Back i I:_]!iudc} | Install... | Apply | cancel

4 Fill in the fields to define the kind of hardware to be virtualized for the VM:

Processors: The number of virtual processors the VM has.
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Memory Size: The amount of virtual RAM the VM has, or paravirtualized memory that can be
used by the VM if it is paravirtualized.

Max: The amount of virtual RAM the VM has, or paravirtualized memory that can be used by
the VM if it is paravirtualized.

Display Driver: The properties of the VM's display. If you have chosen paravirtualization for
this VM, your only option is Paravirtualized. If you have chosen full virtualization, you can select
between VESA or the on-board VGA. If you do not need a display, you can turn off the display
on a fully virtualized machine.

Remote Console Password: The password for remotely controlling the VM. Use the two fields
to verify that it is typed correctly.

5 Click Next to display the following wizard page:

il Virtual Machine Properties

Storage Devices

ation from the ¢
rces > Help :

Description

Hardware Mame  Type Source Size (GB)
1 Hard Disk file: fasdf/05disk 3G8
2 Hard Disk file: fa=df/disk2 8GB

(AddHardDisk | AddcD-ROM | - (SRS | DeleteDisk

Hard Disk

Source
Size (GB)

Read-Only Access

Required field == | [ cancel

110 NetlQ Cloud Manager 2.1 VM Client Guide and Reference



The default for the Type field is Hard Disk. The other possible types are:
¢ iSCSI:

Virtual Machine Properties

Storage Devices

disk. Valid disk < indude a disk image (fmntffile.iso), physical de
You can also select a previously entered Disk Source location from the
come from the Help menu and naw

Description

Hardware MName  Type Source Size (GB)
1 Hard Disk file: fasdfjOSdisk 8 GB
I ignziun 868

(Addrardsk [ addco-rom  (NGVEUENN (WSVESGNRN ( Deleteois

Type

Source

Size (GB)

Read-Only Access
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¢ N_Port ID Virtualized Storage (NPIV):

i Virtual Machine Properties

Storage Devices
The LUN cannot be empty

Description

Hardware MName  Type Source Size (GB)
1 Hard Disk file: fasdff0Sdisk 8GB
2 NPTV npiv: 0 bytes

(AddrardDsk [ addco-rom  (NGVEUENN  (WSVESGWRN ( Deleteoisk

N_Port ID Virtualized Storage

Fabric1d
World Wide Name UUUD]meCIUUUCICI—CDCIUU :IanDCIUUDUD
Target 14 B

LUN

Required field | =Back - - - [ cancel
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¢ Network Attached Storage (NAS):

i Virtual Machine Properties

Storage Devices

1 the Help menu and n
Description
Hardware MName  Type Source Size (GB)
1 Hard Disk file: fasdff0Sdisk 8GB
2 NAS file: fasdf/disk2 8Ge

(AddrardDsk [ addco-rom  (NGVEUENN  (WSVESGWRN ( Deleteoisk

Metwork Attached Storage

Source
Size (GB)

Read-Only Access

Required ficld 4 - Next > | Install.. | Apply | Cancel

The Storage Devices page is for defining the hard drives and CD or DVD drives that you want to
include in the VM profile. The first device must always be a hard disk that cannot be removed
unless another hard disk has been put into the first slot. This is the only disk (Disk 0) that is
stored. All other disks are virtual and are created upon launching the VM. You can add any
other storage devices you want to the VM and prioritize their use in the list.
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6 To fill in the storage device information, select a task from the following table:

Tasks Steps Additional Details
Adding aharddiskto 1. Click Add Hard Disk. The following restrictions
your VM apply per VM:

2. Fill'in the following fields:

Name: The name is the number in the order
the drive appears in its VM image list.

Type: Select the type of hard disk you want
to create on the VM:

+ Hard Disk

+ iSCsl
Not supported as the first disk.

+ N_Port ID Virtualized Storage (NPIV)
Not supported as the first disk.

* Network Attached Storage (NAS)

Source: The repository on the hard disk of
the VM.

Size (GB): The VM's hard drive size,
ranging from 0.25 GB (250 MB) to 4 TB.
This is the maximum allowable size of the
VM.

Read Only Access: Select this option to
give the hard drive Read-Only access. By
default, hard drives are writable.

Fabric ID: (Available only for N_Port ID
Virtualized Storage). Select or specify a
fabric ID that uniquely identifies a SAN
repository.

The Fabric ID drop-down list is populated
with fabric IDs of the discovered SAN
repositories.

World Wide Name: (Available only for
N_Port ID Virtualized Storage). Select or
specify a unique World Wide Name.

The World Wide Name value is
automatically assigned for the NPIV disks.
You can edit it, if required.

Target ID: (Available only for N_Port ID
Virtualized Storage). Specify the target ID of
the SAN repository.

LUN: (Available only for N_Port ID
Virtualized Storage). Specify a LUN value
between 0 and 254.

3. Click Apply.

¢ Limit of 4 fully
virtualized disks
(hda-hdd).

¢ Limit of 16
paravirtualized
disks (xvda-xvdp).

While adding an
additional NP1V disk to a
VM, ensure that the disk
values for Fabric ID,
World Wide Name,
Target ID, and LUN are
unique for each NPIV
disk of the VM.

Creation of a block-
based VM is not
supported for NPIV.

IMPORTANT: iSCSI and
NPIV can be used for
secondary disks.
However, if you add
iSCSI or NPIV as a
secondary disk, you can
change the order of the
disks and make it to be
the first disk. This is not
supported.

If you define iSCSI or
NPIV as a first disk,
when the VM is stopped
and restarted, the
configuration file that is
stored on the iSCSI or
NP1V disk is looked for in
a local repository, and
when not found, a local
repository is created for
the VM, thus losing
connection to the iSCSI
or NPIV disk.
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Tasks

Steps

Additional Details

Adding a CD-ROM or
DVD ROM to your
VM

Rearranging the
order in which each
storage device is
accessed

Deleting a storage
device

1. Click Add CD-ROM.
2. Fill'in the following fields:

Name: The name is the number in the order
the drive appears in its VM image list.

Type: Select the type of CD-ROM you want
to create on the VM:

¢+ CD-ROM
* DVD

Source: The repository on the hard disk of
the VM.

Size (GB): The size is zero and cannot be
changed.

Read Only Access: These drives can only
have Read-Only access.

. Click Apply.

. Select the storage device whose order you

want to change.

. Click Move Up or Move Down.

. Select the storage device you want to

delete.

. Click Delete.

IMPORTANT: If you add
a CD-ROM or DVD-
ROM, the VM can only
be moved, migrated, or
used to create a template
if the CD-ROM’s or DVD-
ROM’s ISO or image is
accessible through
shared storage.

The first storage device
in the list must be a hard
disk, which is the only
one actually stored in the
VM image.

Removes the selected
storage device from the
table.

WARNING: Ifthe storage
device is based on a disk
image, that could also be
deleted. To preserve the
disk image, manually
copy it to another
location before deleting
the storage device.
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7 Click Next to display the following wizard page:

il Virtual Machine Properties |.._I@
Network i’
Spedfy a Media Ac art fo in the fi of ' groupis a 2-digit f
edmal number in the ran ; . If left blank, the host

computer automatically allocates a unique MAC add

Description

Hardware M... | Driver Type MAC Address Metwork,

Fhmage Devees 1 Paravirtualized Default ethi

Driver Type
MAC Address  00:16:3e:

Metwork

Required field | =Back --I Install... .I_- Apply | cancel

The network devices are added, deleted, and defined on the Network page, where you add
specific information about your network connections or intended network connections for your
VM. You can define more detailed NIC settings in your auto-install files or when performing a
guest installation.
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8 To fill in the NIC information, select a task from the following table:

Tasks Steps

Adding aNICtoyour 1. Click Add NIC.

M 2. Fill in the following fields:

Name: The number, based on the NIC’s order in the list, automatically
assigned to the NIC.

Driver Type: Indicates whether the VM has direct access to the NIC. If
the NIC should only interface with the hypervisor, you can select the
specific type of full virtualization. You should have a paravirtualized
NIC with a paravirtualized VM.

MAC Address: Unless you have a specific MAC address you want to
assign to this VM, leave this set to Default, and Xen assigns it a unique
MAC address when you launch the VM.

Network: Select the network you want associated with the NIC.
3. Click Apply.
Rearranging the 1. Select the storage device whose order you want to change.

order in which the

2. Click Move Up or Move Down.
NICs are accessed

Deleting a NIC from 1. Select the NIC you want to remove.
your VM 2. Click Delete NIC.

9 To complete the wizard, click one of the following buttons:

¢ Install: Lists the VM in the Virtual Machines view, then immediately installs the configured
VM.

A VNC login dialog box is displayed so that you can view the progress of the installation
from the VM’s console. There is a 30-second timeout while the VNC sets up the parameters
of the VM.

You can cancel the use of VNC; however, if user interaction is necessary, you need to use the
VNC to help complete the installation. You can start the VNC for a VM being installed by
right-clicking the VM and clicking Show Console.

¢ Apply: Applies the wizard configuration and saves the new VM in the Virtual Machines
view, but does not install the VM.

Focus is returned to the Virtual Machines view after you exit the wizard, with the new VM
selected in the list.

To install the VM at a later time, see Section 5.5, “Installing a VM,” on page 117.

You can click Back to make changes before installing or applying the VM definition.

5.5 Installing a VM

To install an existing VM definition:

1 (Optional) In the VM Client, click the Virtual Machines view, right-click the VM that you want to
install, then select Edit.
If you have any changes for the VM, complete those by using the Next and Back buttons.

For more information on editing the wizard pages, see Section 5.8, “Editing VMs,” on page 120.
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2 To install the VM, do one of the following:
¢ While you are in the Edit VM wizard, click Install.

¢ In the Virtual Machines view, select the defined VM (it shows ¥ in the Status column), then
click the button.

¢ In the Virtual Machines view, right-click the defined VM (it shows ¥ in the Status column),
then select Install.

3 One of three possibilities exists for selecting the host on which to build the VM:

¢ No valid host exists: If you do not yet have a valid host server to for installing the VM, the
following dialog box is displayed:

£ No Available Host Targets ;ﬂﬁ]@

ost targets found to migrate the VM "xp_newdonel'.
failure explanation for each hostin the table below.

#of VMs | Explanation Virtualization Technology CPU Memaory
4 WM host nt virtual memory for guest VM XEN 3.2 ®0 & 22
3 M host ha: fident virtual memory for quest VM XEN 3.2 @0 @3

Review the issues, resolve them, then repeat from Step 2.
¢ Only one valid host exists: It is automatically selected, so continue with Step 5.

¢ Multiple valid hosts exist: The following dialog box is displayed if there are two or more
target host candidates:

il Select Host to Install the VM ‘rvm1"
elect one.
Hame Active VMs = Notes Virtualization Technology

1 XEN 3.2
XEN 3.2

1
] XEN 3.2
1 XEN 3.2

M 2utoselect the target host

Cancel

Do one of the following:
¢ Select the Auto-Select the Target Host check box.

The Auto-Select the Target Host option allows the Orchestration Server to automatically
select a host server from those that are available by using a ranking criteria, such as
architecture similarity and available CPU and RAM resources. For example, hosts are
selected that meet the architecture requirements, the cost of moving information is
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5.6

then considered, and if there is still no clear winner, then the least loaded machine is
selected. The ranking criteria can be affected by policies that you might have set in the
Orchestration Console.

¢ Select the VM host where you want to install the VM.
These options are mutually exclusive, meaning that selecting one disables the other.

4 Click OK when you have selected a host server or selected the Auto-Select the Target Host check
box.

5 Do one of the following:

¢ If the installation is proceeding from an installation source that requires user input, the
VNC is automatically started. Log in with the VNC password to view and interact with the
installation as it progresses on the VM’s console, then continue with Step 6.

¢ If the installation is using YaST, the VM is automatically installed without user input. You
can either manually use VNC (click View > Show Console) to view the installation’s progress,
or you can continue with Step 6.

6 You can view the installation progress in any of the following ways:
¢ Observe messages at the bottom of the VM Client interface.

¢ Click View > Show Progress View or double-click Show/Hide Progress View to open the Progress
View window. In the Progress View you can mouse over the entry in the Status column, or
right-click that entry and select Show Log, to view the log information for installing the VM.

¢ Double-click the VM being installed, click the Event Log tab, then double-click the entry
related to the installation process that has the [i{]icon next to it. The Event Log Details dialog
box is displayed and is automatically updated as events occur.

¢ View its progress in the Jobs tab of the Orchestration Console.

7 If you want to cancel the installation before it finished, do one of the following:
¢ Select the VM being installed, then click Edit > Cancel Install.
¢ Right-click the VM being installed, then select Cancel Install.

The VM'’s status is returned to being configured but not installed.

Installing the Orchestration Agent on a VM

For instructions on installing the agent on a host server, see “SLES 11 Standard Installation” in the
NetIQ Cloud Manager 2.1 Orchestration Installation Guide.

1 In the VM Client, click the Virtual Machines view, right-click the VM where you want to install
the agent, then select Shut Down.
The VM cannot be running during installation of the agent because the VM’s image is modified.
The agent cannot be installed on a template.
2 After the VM has completed shutting down, select the VM again, then do one of the following:
¢ Click Actions > Install Agent.
¢ Right-click the VM, then select Install Agent.

The agent installation begins.
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5.7

5.7.1

5.7.2

120

5.8

3 You can view the installation progress in any of the following ways:

¢ Double-click the VM being installed, click the Event Log tab, then double-click the entry
related to the installation process that has the [i{]icon next to it. The Event Log Details dialog
box is displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.
¢ View the progress in the Jobs tab of the Orchestration Console.

4 To have the VM accepted into the datagrid, follow the instructions in Section 2.7, “Registering
VMs,” on page 24.

After the Orchestration Agent has been installed on a VM, the agent begins to communicate with
the Orchestration Server. However, the VM is not yet available to the datagrid because it must be
accepted.

You can tell which VMs have the Orchestration Agent installed by whether pie charts are being
displayed in the CPU and Memory columns in the Virtual Machines view, but only if the VM is
running.

Installing the Monitoring Agent on a VM

In order to use the Monitoring feature on VMs or host servers, you must manually install the
Monitoring Agent on them, then configure the agent.

The Monitoring Agent is usually installed on host servers during installation of the Orchestration
Server product.

To install the agent manually, use the following instructions, as applicable:

¢ Section 5.7.1, “Installing the Agent in Windows,” on page 120
¢ Section 5.7.2, “Installing the Agent in Linux,” on page 120

Installing the Agent in Windows

For instructions, see “Installing the Cloud Manager Monitoring Agent On Windows Machines” in the
NetIQ Cloud Manager 2.1 Orchestration Installation Guide.

Installing the Agent in Linux

For instructions, see “Installing the Cloud Manager Monitoring Agent on Linux Servers” in the NetIQ
Cloud Manager 2.1 Orchestration Installation Guide.

Editing VMs

VMs can be edited at any time. However, the fields and sections that are displayed on each of the four
wizard pages depend on various circumstances:

¢ Which type of VM is it? Xen, VMware, or Hyper-V?

¢ What is the VM’s installed state? Defining, defined, installing, or installed?
¢ What is the VM'’s defined state? Defining or defined?
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¢ What is the run time state of the VM? Running, paused, suspended, or stopped?
¢ Is the VM state unknown?
Any combination of these factors determines which fields can be edited or shown. The displayed

fields that can’t be edited are inaccessible (dimmed), or if no fields on a wizard page are editable, the
page is not shown.

IMPORTANT: If the VM that you want to edit is running, only a few of its properties can be
changed. If you want to edit a running VM, know that any changes are only retained in RAM, so
when this instance if the VM is stopped, those edits are not kept.

The following steps include information for all possible VM fields and pages. The VM you are editing
might not have all of the fields and pages.

To edit a VM, run the Virtual Machine Properties Wizard:

1 If you want to retain your edits on a VM, click the Virtual Machines view in the VM Client, right-
click the VM that you want to edit, then select Shut Down.
2 Do one of the following to start the wizard:
* Select a VM, then click the button.
* Select a VM, then click Edit > Edit.
¢ Select a VM, then press Ctrl+E.
¢ Right-click any listed VM, then select Edit.
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The following wizard page is displayed:

i Virtual Machine Properties

Description

Enter an overall description or purpose for this VM,

Hardware
Storage Devices

Network
i Description

SLES10 SP2 64-bit, Server B

PUID  2980b4ec-3d47-9aBa-b70b-c91e33033e68 Version

Guest Operating System
SUSE Linux Enterprise Server 10 A
At Archutechis

Additional uments

Required field - I:_Lliutt > - - [ cancel

The above example is for a stopped VM.
3 Fill in the available fields:

Description: Note the purpose and any other specifics you might require of the VM. These notes
apply to all versions of this VM.

Guest Operating System: The operating system you want to install on your VM.

If the OS column on the Virtual Machines view displays Unknown for the VM you are editing, you
can select an operating system here.

Additional Arguments: This field applies only to paravirtual installations. These are Linux
install arguments, which are operating system parameters similar to the information entered in a
GRUB boot loader when running on bare hardware in SLES and SLED. Additional network
installation information can be added here, which is used during the build process to find the
installation source for the VM build process.
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4 Click Next to display the following wizard page:

i Virtual Machine Properties |Z|@
Hardware i’

Select the number of Virtual Processors you'd like the Guest Oper System to see. Ideally, any physical computer that hosts this f
VM should also have at least the spedified number of physical proc 4

Description

Storage Devices
Network

Memory Size ¥

Display Driver

Cirrus Lo
»

© Paravirtualized Graphics Driver

Remote Console Password Console Password Again

Required field

The above example is for a stopped VM.
5 Fill in the available fields to define the kind of hardware to be virtualized for the VM:
Processors: The number of virtual processors the VM has.

Memory Size: The amount of virtual RAM the VM has, or paravirtualized memory that can be
used by the VM if it is paravirtualized.

Max: The amount of virtual RAM the VM has, or paravirtualized memory that can be used by
the VM if it is paravirtualized.

Display Driver: The properties of the VM’s display. If you have chosen paravirtualization for
this VM, your only option is Paravirtualized. If you have chosen full virtualization, you can select
between VESA or the on-board VGA. If you do not need a display, you can turn off the display
on a fully virtualized machine.

Remote Console Password: The password for remotely controlling the VM. Use the two fields
to confirm that the password is typed correctly.
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6 Click Next to display the following wizard page:

i Virtual Machine Properties |:_|@

Storage Devices i’
Shows the disks currently defined for the YM. The first disk is reserved for the operating system and must be of type Hard Disk. f

Description
Hardware Mame  Type Source Size (GB)

1  Hard Disk file: fvar flib fxen/images frvmdone 1/05disk 2GB
Network

(addrardDsk [ Addcorov  (iiieieceny  (ovEBewy  (NBSSEGEEN

iard Disk

fvar flibfxenfimages/rvmdone 1/05disk

Required field

The above example is for a stopped VM. The default for the Type field is Hard Disk. The other
possible types are iSCSI, NPIV, and NAS. For more information, see Step 5 on page 110.

The Storage Devices page is for defining the hard drives and CD or DVD drives that you want to
include in the VM profile. The first device must always be a hard disk that cannot be removed
unless another hard disk has been put into the first slot. This is the only disk (Disk 0) that is
stored. All other disks are virtual and are created upon launching the VM. You can add any
other storage devices you want to the VM and prioritize their use in the list.

IMPORTANT: After installing a VM, you cannot change the disk settings for existing disks.
However, you can add and configure newer disks.
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7 To fill in the storage device information, select a task from the following table:

Tasks Steps Additional Details
Adding aharddiskto 1. Click Add Hard Disk. The following restrictions
your VM apply per VM:

2. Fill'in the following fields:

Name: The name is the number in the order
the drive appears in its VM image list.

Type: Select the type of hard disk you want

to create on the VM:
+ Hard Disk
* iSCsSI

Not supported as the first disk.
+ N_Port ID Virtualized Storage

Not supported as the first disk.
* Network Attached Storage

Source: The repository on the hard disk of

the VM.

Size (GB): The VM's hard drive size,
ranging from 0.25 GB (250 MB) to 4 TB.
This is the maximum allowable size of the

VM.

Read Only Access: Select this option to
give the hard drive Read-Only access. By
default, hard drives are writable.

Fabric ID: (Available only for the N_Port ID
virtualized storage). Select or specify a
fabric ID that uniquely identifies a SAN

repository.

The Fabric ID drop-down list is populated
with fabric IDs of the discovered SAN

repositories.

World Wide Name: (Available only for the
N_Port ID virtualized storage). Select or
specify a unique World Wide Name.

The World Wide Name value is
automatically assigned for the NPIV disks.
You can edit it, if required.

Target ID: (Available only for the N_Port ID
virtualized storage). Specify the target ID of

the SAN repository.

LUN: (Available only for the N_Port ID
virtualized storage). Specify a LUN value

between 0 and 254.
3. Click Apply.

¢ Limit of 4 fully
virtualized disks
(hda-hdd).

¢ Limit of 16
paravirtualized
disks (xvda-xvdp).

While adding an
additional NP1V disk to a
VM, ensure that the disk
values for Fabric ID,
World Wide Name,
Target ID, and LUN are
unique for each NPIV
disk of the VM.

Creation of a block-
based VM is not
supported for NPIV.

IMPORTANT: iSCSI and
NPIV can be used for
secondary disks.
However, if you add
iSCSI or NPIV as a
secondary disk, you can
change the order of the
disks and make it to be
the first disk. This is not
supported.

If you define iSCSI or
NPIV as a first disk,
when the VM is stopped
and restarted, the
configuration file that is
stored on the iSCSI or
NP1V disk is looked for in
a local repository, and
when not found, a local
repository is created for
the VM, thus losing
connection to the iSCSI
or NPIV disk.
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Tasks

Steps

Additional Details

Adding a CD-ROM or
DVD ROM to your
VM

Rearranging the
order in which each
storage device is
accessed

Deleting a storage
device

1. Click Add CD-ROM.
2. Fill'in the following fields:

Name: The name is the number in the order
the drive appears in its VM image list.

Type: Select the type of CD-ROM you want
to create on the VM:

¢+ CD-ROM
* DVD

Source: The repository on the hard disk of
the VM.

Size (GB): The size is zero and cannot be
changed.

Read Only Access: These drives can only
have Read-Only access.

. Click Apply.

. Select the storage device whose order you

want to change.

. Click Move Up or Move Down.

. Select the storage device you want to

delete.

. Click Delete.

IMPORTANT: If you add
a CD-ROM or DVD-
ROM, the VM can only
be moved, migrated, or
used to create a template
if the CD-ROM’s or DVD-
ROM’s ISO or image is
accessible through
shared storage.

The first storage device
in the list must be a hard
disk, which is the only
one actually stored in the
VM image.

Removes the selected
storage device from the
table.

WARNING: With Hyper-
V VMs, if the storage
device is based on a disk
image, the disk image is
also deleted. To preserve
the disk image, manually
copy it to another
location before deleting
the storage device. This
applies only to Hyper-V
VMs, not XEN VMs or
VMware VMs.
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8 Click Next to display the following wizard page:

il Virtual Machine Properties |Z|@

Network i’
Spedfy a Media Ac art fo in the fi of ' groupis a 2-digit f
edmal number in the ran ; . If left blank, the host
computer automatically allocates a unique MAC add
Description
Hardware M... | Driver Type MAC Address Metwork,
Fhmage Devees 1 Paravirtualized Default ethi

Driver Type
MAC Address  00:16:3e:

Metwork

Required field | =Back --I Install... .I_- Apply | cancel

The above example is for a stopped VM.

The network devices are added, deleted, and defined on the Network page, where you add
specific information about your network connections or intended network connections for your
VM. You can define more detailed NIC settings in your auto-install files or when performing a
guest installation.
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5.9

9

10

*

To fill in the NIC information, select a task from the following table:

Tasks Steps

Adding aNICtoyour 1. Click Add NIC.

M 2. Fill in the following fields:

Name: The number, based on the NIC’s order in the list, automatically
assigned to the NIC.

Driver Type: Indicates whether the VM has direct access to the NIC. If
the NIC should only interface with the hypervisor, you can select the
specific type of full virtualization. You should have a paravirtualized
NIC with a paravirtualized VM.

MAC Address: Unless you have a specific MAC address you want to
assign to this VM, leave this set to Default, and Xen assigns it a MAC
address when you launch the VM.

Network: Select the network you want associated with the NIC.
3. Click Apply.
Rearranging the 1. Select the storage device whose order you want to change.

order in which the

2. Click Move Up or Move Down.
NICs are accessed

Deleting a NIC from 1. Select the NIC you want to remove.
your VM 2. Click Delete NIC.

To complete and close the wizard, click Apply.
You can click Back to make further changes before applying the edits.
The wizard configuration changes are applied and the VM is saved in the Virtual Machines view.

Focus is returned to the Virtual Machines view after you exit the wizard, with the edited VM
selected in the list.

To install an edited VM at a later time, see Section 5.5, “Installing a VM,” on page 117.

Moving VMs

When you need to change a VM’s host server, you can either move or migrate the VM:

Moving: For host resource reallocation.

Physically moves all of the VM’s files and its image from one host server to another while the
VM is shut down. When you start the VM, it starts from its new repository.

Migrating: For host server availability. For more information, see Section 5.10, “Migrating
VMs,” on page 130.

Transfers just the VM’s instance in RAM from one host server to another (essentially keeping the
VM live), assuming that both hosts have shared access to the VM’s files and image. When you
shut down the VM and later restart it, it restarts from the new host server. In other words, its
files are not moved, but it now has a new host server association.

For issues related to a VM being moved from outside of the VM Client, such as within the
Orchestration Console, or from a command line, see “VM is out of sync in the VM Client after it was
moved” on page 192.
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Review the following sections to move a VM:

¢ Section 5.9.1, “Prerequisites,” on page 129

¢ Section 5.9.2, “Moving a VM,” on page 129

5.9.1 Prerequisites

In order for a move to work, the following conditions must exist:

¢ The provisioning adapter for the VM being moved must match the repository’s enabled

provisioning adapters. (For this information, see the Summary details tab for the repository.)

¢ The target repository’s device must have enough disk space available to hold the VM’s files and

image.

¢ If the VM has a CD-ROM or DVD-ROM defined for it, it must be accessible through shared
storage to the target host server. Otherwise, the CD-ROM or DVD-ROM is not included in the
move and the moved VM cannot start. In that case, you should remove the CD-ROM or DVD-
ROM from the VM before continuing with Section 5.9.2, “Moving a VM,” on page 129.

59.2 MovingaVM

1 In the VM Client, click the Virtual Machines view, then make sure the VM you want to move is

shut down.
2 Select the VM.
3 Do one of the following to move the VM:
¢ Click Edit > Move.
¢ Right-click the selected VM, then select Move.
The following dialog box is displayed:

i Move Virtual Machine

Name: rvm_1 Host: DemoVM  Repository: videvl

moving criteria are listed.

Available Target Repositories
Stored YMs Motes
0
u_
0 Shared Storage
1] Default ZOS datagrid backed repository

Datagrid
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5.10

5.10.1

4 Under Available Target Repositories, select a repository.

The VM hosts connected to the repository are displayed. When you select the repository, you are
selecting the host to move the VM to.

5 Click Move.
Depending on your hardware capabilities, moving the files can take a few minutes.
You can view the move progress in any of the following ways:

¢ Double-click the VM being moved, click the Event Log tab, then double-click the entry
related to the moving process that has the [i]icon next to it. The Event Log Details dialog
box is displayed and automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
¢ Click View > Show Progress View to open the Progress window.
¢ View the progress in the Jobs tab of the Orchestration Console.

6 Start the VM from its new location.

Migrating VMs
When you need to change a VM’s host server, you can either move or migrate the VM:

¢ Migrating: For host server availability.

Transfers just the VM's instance in RAM from one host server to another (essentially keeping the
VM live), assuming that both hosts have shared access to the VM’s files and image. When you
shut down the VM and later restart it, it restarts from the new host server. In other words, its
files are not moved, but it now has a new host server association.

¢ Moving: For host resource reallocation. For more information, see Section 5.9, “Moving VMs,”
on page 128.

Physically moves all of the VM’s files and its image from one host server to another while the
VM is shut down. When you start the VM, it starts from its new repository.

Hyper-V migrations are not supported.
Migration of Xen VMs with Fibre Channel SAN disks is not supported.

If you have a secondary iSCSI disk defined for a VM, migration is supported between two host
servers only if both are connected to the same iSCSI disk.

Review the following sections to migrate a VM:

¢ Section 5.10.1, “Prerequisites,” on page 130
¢ Section 5.10.2, “Migrating a VM,” on page 132

Prerequisites

In order for a migration to work, the following conditions must exist:

¢ Xen must be configured to allow for migrating its VMs. For more information setting up Xen for
a live migration, see Option 2 in Novell AppNotes (http://www.novell.com/communities/node/
5050/xen-virtual-machine-migration).
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¢ For vCenter (ESX) VM migrations, both the source and target machines must have VMotion
enabled. ESX servers with vCenter are migrated faster because VMotion allows the migration to
occur live, instead of losing some time for suspending the VM as is necessary for ESX
migrations.

¢ The two host servers involved in the migration must have access to the shared repository where
the VM’s files and image reside.

¢ Every entity involved must have the same architecture, such as 32-bit or 64-bit, mount points,
and routing of network connections to the virtual network.

For example, a 64-bit paravirtualized guest created on a 64-bit hypervisor can be migrated to
another host server running a 64-bit hypervisor, but not a 32-bit hypervisor. Or, you can create a
32-bit VM on a 64-bit hypervisor and migrate it to another 64-bit hypervisor host. In other
words, you cannot start a VM on a host that has a different architecture from the host where the
VM was created.

¢ The host server cannot be fully utilized, because it would be incapable of hosting the VM.

+ The host server cannot have met its maximum allowable VMs. This value is set in the
Orchestration Console in the Max Hosted VMs field. The default is 8. It does not matter whether
the maximum VMs it is already hosting are fully utilizing it.

¢ A host server cannot be disabled by having its Resource Enabled check box deselected in the
Orchestration Console. By default, this check box is enabled.

¢ Ahost server is only available if it is not out of sync, which can occur if it is manually accessed or
manipulated via a third-party tool. However, you can resynchronize the host server with the
Orchestration Server.

¢ If the VM has a CD-ROM or DVD-ROM defined for it, they must be accessible through shared
storage to the target host server. Otherwise, the CD-ROM or DVD-ROM will not be included in
the migration and the migrated VM cannot start again after it has been stopped. In that case, you
should remove the CD-ROM or DVD-ROM from the VM before continuing with Section 5.10.2,
“Migrating a VM,” on page 132.

Some conditions are automatically enforced with constraints, such as operating system, shared
storage, xend configuration, and possibly the architecture.

During migration:
¢ Even if the above criteria are met by only one host server, the Migrate Virtual Machine dialog
box is displayed.

¢ If the criteria are met by multiple host servers, you can either select a host server, or select to
have the VM Client automatically select the host server.

¢ If no host servers meet the requirements, the No Migrate Target Available dialog box is
displayed, indicating that you need to resolve the issues to continue.

NOTE: For ESX migrations, the VM is suspended, it is migrated from one host to another, then it is
provisioned.
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5.10.2 Migrating a VM

To migrate a VM, you need to prepare the host servers, then migrate the VM.

1 Make sure that each host has access to the shared repository to be used for the VM'’s files.

2 In the VM Client, click the Virtual Machines view, select the VM to migrate, then do one of the
following:

¢ Click the button.
¢ Click Edit > Migrate.
¢ In the Virtual Machines view, right-click the selected VM, then select Migrate.
If only one host server is available, it is automatically used and you can continue with Step 4.

Otherwise, the following dialog box is displayed if there are two or more target host candidates:

Migrate Virtual Machine

o migrate this VM. C osts that meet this YM'
o auto-select the targe check the "Au

#of VMs  HNotes

M autoselert the tarnet hnst

3 If you have multiple host servers to select from, do one of the following;:
¢ Leave the Auto-select the Target Host check box selected.

The Auto-Select the Target Host option allows the Orchestration Server to automatically select
a host server from those that are available by using a ranking criteria, such as architecture
similarity and available CPU and RAM resources. For example, hosts are selected that meet
the architecture requirements, the cost of moving information is then considered, and if
there is still no clear winner, then the least loaded machine is selected. The ranking criteria
can be affected by policies that you might have set in the Orchestration Console.

¢ Select the VM host to which you want to migrate the VM.

These options are mutually exclusive, meaning that selecting one disables the other.
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If you do not yet have a valid host server to migrate to, the following dialog box is displayed:

-
Bl
T

No Hosts Found To Test As Migration Targets |:|E]

3 Mo hosts were found to test as potential targets for migrating VM

'CloneQf_EVDTemplate1'.

In order to provide migration hosts, you must first do the following:

s Please make sure that your ¥M host is configured properly to support live
migration. Refer to the ondine documentation for additional information.

» The target host server must have identical architecture to the ¥M being
migrated.

» The target host server's file system and mount paint must be the sam
the VM being migrated.

For instructions on doing the above, see the PlateSpin Orchestrate ¥M Client
documentation.

| Copy to Clipboard

Review the issues, resolve them, then repeat from Step 1.
4 Click Migrate.

You can view the migration progress in any of the following ways:

*

*

*

*

Double-click the VM being migrated, click the Event Log tab, then double-click the entry

related to the migration process that has the [i] icon next to it. The Event Log Details dialog

box is displayed and is automatically updated as events occur.
Observe messages at the bottom of the VM Client interface.
Click View > Show Progress View to open the Progress window.

View its progress in the Jobs tab of the Orchestration Console.

When the migration has completed, the VM continues to run on its new host.

ESX migrations might take a bit longer because the ESX server must be suspended in order to
migrate its RAM content.

Managing Virtual Machines

133



5.11 Deleting VMs

Deleting a VM in the VM Client causes an Orchestration job to run that deletes all of the VM’s files in
the /etc/xen/vmand /etc/xen/images (or /var/lib/xen/images) directories.

WARNING: Deleted VMs cannot be recovered.

1 In the VM Client, click the Virtual Machines view, then select one or more VMs.
2 Do one of the following to delete the selected VMs:
¢ Click the IEEE=M button.
¢ Click Edit > Delete.
¢ In the Virtual Machines view, right-click a selected VM, then select Delete.
If a VM is running or is suspended, the deletion options are not displayed or enabled.

3 Click either Yes or No to delete the VM:

Delete [%]
This action deletes the selected ¥YM 'SLES10_32hit D',

4

n This action cannot be undone.

Are you sure you want to delete this WYM?

This completely removes the selected VMs from the Virtual Machines view, as well as all files in

the repository associated with it.
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6.1

Managing Repositories

You can do the following to manage the repositories for VM files:

¢ Section 6.1, “Understanding Repositories,” on page 135

¢ Section 6.2, “Viewing and Editing Storage Details,” on page 136

¢ Section 6.3, “Adding Repositories,” on page 140

¢ Section 6.4, “Associating Repositories to Host Servers,” on page 143
¢ Section 6.5, “Associating Host Servers to Repositories,” on page 144

¢ Section 6.6, “Removing Repositories,” on page 145

Understanding Repositories

Repositories are where VM and template files are stored. A datagrid’s repositories are displayed in
the VM Client in the Storage view.

If a VM’s files are stored on a particular host server, that VM must be run from that host server. If a
VM'’s files are stored on a shared repository, that VM can be run on any host server that has access to
the shared repository.

Host servers can have multiple repositories associated with them, and some repository types can be
associated with multiple host servers as shared repositories. A host server can be associated with
both repositories stored locally on its server and shared repositories stored on other machines.

The default size for all repositories is unlimited. To control disk space usage, you should change this
default in the Orchestration Console. For more information, see Step 9 on page 142.

Review the following table for information about the various repository types used by the VM Client:

Table 6-1 Repository Types

Repository Adapters Image File Path Description

Datagrid All grid:///vms The shared repository (named ZOS)
on the Orchestration Server that is
accessible to all host servers in the
datagrid. Each datagrid has one
shared ZOS repository.
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Repository Adapters Image File Path Description

Local All The default paths are: The default repository on a host
) _ server. Each host server starts with its
¢ Physical location: / (root), or / own local repository, which has the

var/xen/images, which is the same name as the server’s hostname.
physical location of the VM's files.

* Preferred Path: var/1ib/xen/
images, which is the relative path
from the location to search and
place VM files for moving or
cloning.

+ Configuration Search Path: /etc/
xen/vm, which is the relative path
from the location to search for VM
configuration files.

NAS All. The default paths are: An NFS mount repository that can be
(Network shared, if it is not on a host server.
Attached + Physical location: /u, or /mnt/

Storage) myshareddisk, which is the

physical location of the VM's files.
This is the mount point that is
assumed to be the same on every
host server that has a connection to
this NAS.

* Preferred Path: my._vms, which is
the relative path from the location
to search and place VM files for
moving or cloning.

+ Configuration Search Path:
my_vms, saved_vms, or null (no
path entry), each of which is the
relative path from the location to
search for VM configuration files.
Null specifies to search the whole

mount.
SAN All N/A Represents an iSCSI or Fibre Channel
(Storage SAN. Currently supported only with
Area the vsphere provisioning adapter.
Network)
Virtual Amazon N/A An externally managed VM's virtual
EC2 disk (Amazon EC2), so no path is

required.

6.2 Viewing and Editing Storage Details

Review the following sections for information on the Details views:

¢ Section 6.2.1, “Accessing Storage Details,” on page 137
¢ Section 6.2.2, “Using the Details Tabs,” on page 137
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6.2.1 Accessing Storage Details

The details for each storage item consist of a summary, VMs using this storage capacity, host servers

providing the storage space, and an event log.

1 In the VM Client, click the Storage view.

The storage items are displayed:
£ PlateSpin Orchestrate VM Client

VIEW HELP

Inventory

Storage
Virtual Machines |T| |;| |T| |T|

b Host Servers

» Storage

Templates

Name Stored VMs
datl11 o
dai12.provo.novell.com

OfficeRepo

108

ZRA4bit

2 Do one of the following:

¢ Double-click one of the storage items.

Type
Local

Notes

Local
Hetwork Att:
Default ZOS datagrid backed repository Datagrid

Local

| & orchestrate | T VersionInfo |

¢ Right-click one of the storage items, then select Show Details.

The tabs for the selected storage item are displayed.

3 For details on the tabs, see:
¢ “Summary Tab” on page 71
¢ “Virtual Machines Tab” on page 139
¢ “Hosts Tab” on page 139

4 To close the details view, click the view name in the Inventory perspective panel.

6.2.2 Using the Details Tabs

The following sections provide information on the various details tabs:

¢ “Summary Tab” on page 138

¢ “Virtual Machines Tab” on page 139
¢ “Hosts Tab” on page 139

¢ “Event Log Tab” on page 140
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Summary Tab

This details tab is used by each Inventory panel type:

Figure 6-1 Summary Tab for Storage Items

i PlateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory B OfficeRepo
Virtual Machines [ (@] (a] ] |

» Host Servers

~ Storage Summary Virtual Machines

dat11

dat 1_r.| ovo.novell.com rk Attached Storage

Notes

xeni0

Templates

Capadty

W server M Infrastructure | B=

| ® Orchestrate | 8 version Info | Show/Hide Progress View

You can do the following with the Summary tab for storage items:
¢ In the first section, the available options in the Type field are:

Network Attached Storage (NAS)
Local

Storage Area Network (SAN)
Datagrid

Virtual

However, only the first two options (NAS and Local) are selectable for repositories that are
created in the VM Client. The others are modified in the Orchestration Console.
Other fields are editable, depending on your selection in the Type field.

¢ In the first section, right-click a group name under Groups, then select Remove to revoke the
storage item’s membership in the group.

¢ In the Notes section, enter and edit notes for the storage item.
¢ View basic information about the storage item, including:
¢ The repository’s type and path information, including the ability to edit the information
¢ The repository’s capacity, including how much is being used and how much is free
¢ Which hypervisors the location can be used with, including the ability to enable or disable

them for this repository

Wherever N/A appears in the details, it means that the information is not available.
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Virtual Machines Tab

This details tab is used only by storage items:

Figure 6-2 Virtual Machines tab for Storage

i plateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory & OfficeRepo

Virtual Machines [11) ] | |
¥ Host Servers
~ Storage Summary Virtual Machines Hosts Event Log

dat11

daii2.provo.novell.com
| orfcerepo | e
OfficeRe
= 32hitcl
z0s
ZR64bit
xendl

Memory

Templates

| & Orchestrate | 18 yersion Info | Show/Hide Progress View

You can do the following with this tab:

¢ View which VMs are associated with the storage item.
¢ View the status of each associated VM.

+ Double-click a listed VM to view its details tabs.

Hosts Tab

This details tab is used only by storage items:

Figure 6-3 Hosts Tab for Storage

i plateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory & OfficeRepo

Virtual Machines =) (=] (0] (») | [ niew v [} Add Host
b Host Servers
~ Storage Summary Virtual Machines Event Log

dat11

da112.provo.novell.com N
Active V... | Motes CPU

DfficeRe
po > 1 Y ®0 @ 12

z0s . 0 ! @0 [ "B
ZRE4bit - 1 ®0 @37
xen30
Templates

| & Orchestrate | 18 yersion Info | Show/Hide Progress View
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6.3

You can do the following with this tab:

¢ View information about the host server this storage item is associated with.
¢ Double-click a listed host server to view its details tabs.

Event Log Tab

This details tab is used by all Inventory types:

Figure 6-4 Event Log Tab for Storage

i plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory OfficeRepo

Virtual Machines [(w]) (=] (] (=]

¥ Host Servers
~ Storage Summary Virtual Machines Event Log
dai11
da112.provo.novell.com
08
ZR64bit
xen30

Action Status User Start Time Elapsed ...

VI ¥ [ = ing job started for dis y of VMs on repos ystem  2009-06-01 15:49:5

Templates

| & Orchestrate | 8 yersion Info | Show/Hide Progress View

You can do the following with this tab:

¢ View actions related to the repository.
¢ View the Event Log information.

¢ Double-click an event item that contains the [i]icon to view the details of the event as reported
by the Orchestration Server.

Adding Repositories

You can add new repositories for a VM’s files, including its image. Local is the default, but the path
information is blank and must be filled in with known data.

1 On the server where you plan to specify a new repository, create the path that you plan to use
and make a note of it.
When you provide this path information in Step 6, the fields do not provide browsing.
2 Inthe VM Client, click the Storage view, then do one of the following:
* (Click the [EfE=1 button.
¢ Click File > New Repository.
¢ Press Ctrl+R.
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The following dialog box is displayed:

New Repository E

Enter the repository name.

—

S (e

3 Specify a name for the repository, then click OK.

A default local repository is created, using default paths and other information.
4 Right-click the new repository, then select Show Details.
The following is displayed:

il PlateSpin Orchestrate YM Client

ACTIONS VIEW HELP

Inventory B OfficeRepo
Virtual Machines =] (=] O] (=] ‘ ( | |

¥ Host Servers
~ Storage Summary Virtual Machines Hosts EventlLog

datt
Notes

da112.provo.novell.com

xendd

Templates

M Infrastructure | ]

| ® Orchestrate | T8 VersionInfo | Show/Hide Progress View

5 On the Summary tab, from the drop-down list for the Type field, select one of the following:
¢ Network Attached Storage
¢ Local

The following also display, but are not selectable. They must be created outside of the VM Client.
For example, the Datagrid type is created by default as ZOS for the datagrid that belongs to the
Orchestration Server.

¢ Storage Area Network
¢ Datagrid

* Virtual
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6 Fill in the fields:

Root Location: For example, “/” (root) for Local.

Preferred Path: For example, var/lib/xen/images for Local. This path does not start with a
forward slash. The root of the path is provided in the Root Location field.

Config Storage Path: For example, /etc/xen/vm for Local. Be sure to include the root of the
path, such as the forward slash.

The Number of Hosts and Number of VMs fields display only hosts and VMs that are currently
using this repository.

7 To enable one or more hypervisors for access to this repository, click the check box:

*

*

*

*

*

*

XEN 3.x

Microsoft Hyper-V
VMware ESX

VMware Server
VMware Infrastructure

VMware vSphere

At least one must be selected. Unavailable options are dimmed.

8 (Optional) Provide any useful information in the Notes field.

When you change focus from Notes field, the information that you entered is automatically
saved.

9 (Optional) Control disk space usage as necessary:

NOTE: By default, all repository sizes are set to unlimited (-1).

9a

9b
9c

9d

In the Orchestration Console, browse for the repository in the Explorer panel.
It should be listed under the Repositories section for your grid.
On the Info/Groups tab, open the Info section, then open the Repository Information section.

In the Capacity field, change the default (-1) to the desired repository limitation in
megabytes.

For example, to create a repository size limit of 20 GB, enter 20000.

Click File > Save to make the change effective.

10 To associate this repository with host servers, see:

*

*

Section 6.4, “Associating Repositories to Host Servers,” on page 143

Section 6.5, “Associating Host Servers to Repositories,” on page 144
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6.4

Associating Repositories to Host Servers

You can associate repositories with a host server, which allows VMs using the repository to then be
run by any of the host servers associated with the repository.

For information on creating new repositories, see Section 6.3, “Adding Repositories,” on page 140.

1 In the VM Client, click the Host Servers view, right-click a host machine, then select Show Details.

il PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory I da111 [Agent Running]

Virtual Machines (=] (=] [an] |

~ Host Servers

Lt ] ey (Confaeton™ (onfomat) (Sventlon

da112.provo.novell.com
Discovered [1] = 10

= Storage

Motes

xen3(

Templates

cPU ® 0

Memory & 19%

Storage Name Stored ... | Type Capacity MAaC Address

dalll = ocal
Assodate Repository
Remove Repository .
0 E= K F

VM MName

Metwork.

a5 Memory

64bit SUSE Linux Enterprise

| @ Orchestrate | 18 yersion Info | Show/Hide Progress View

2 Right-click a repository in the storage section, then select Associate Repository.

The following dialog box is displayed:

il Select Repository
Name: N/A  Host: da111.provo.novell.com  Repository: NJA

Select one or more repaosite from the list below. Press OK when done or Cancel to di iis dialog without making a selection.

If a known repository is not listed, that reposite ay not be configured to support the current host's virtualization technology.

Available Repositories
Mame Stored WMs Motes Capadty
da112.provo.novel.com
ZRe4bit

3 Select a repository, then click OK.

The repository is listed with the others for the selected host server.
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6.5 Associating Host Servers to Repositories

You can associate host servers with a repository, which allows VMs using the repository to then be
run by any of the host servers associated with the repository.

For information on creating new repositories, see Section 6.3, “Adding Repositories,” on page 140.

1 Inthe VM Client, click the Storage view, right-click a storage item, then select Show Details.

‘il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW

Inventory
Virtual Machines

~ Host Servers
Discovered [1] Summary Virtual Machines

= Storage

_ MName Active V... | Motes Technology CPU Memory
dat12.provo.novell.com dalll . 1 3 [ X [ “BL]
OfficeRepo
zo0s
ZRG4bit

xen3(

Templates

| @ Orchestrate | 18 yersion Info | Show/Hide Progress View

2 Click the Hosts tab, then click the [EEEIREE] button, or right-click any host and select Associate
Host.

The following dialog box is displayed:

4l Select Hosts

Repository: da111

If a known host is not listed, that host may not be configured to support the current repository'’s virtualization technology.

Name Status Active VMs | Notes Technology
da112 provo.novell.com 0 XEN 3¢
ZR64bit ' i XEN 3.
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If no hosts are available, the following dialog box is displayed, instead:

i Additional hosts are not available to a... :|@@

A& Additional Hosts Mot Available

Try this action later, when more hosts may be accessible
on the network.

3 Select one or more host servers, then click OK.

The host server is listed with the others for the selected storage item.

6.6 Removing Repositories

You can remove repositories from being associated with a host server, or you can remove a repository
altogether:

¢ Section 6.6.1, “Removing a Repository from a Host Server,” on page 146
¢ Section 6.6.2, “Removing a Host Server from a Repository,” on page 147

¢ Section 6.6.3, “Removing a Repository from the VM Client,” on page 147
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6.6.1 Removing a Repository from a Host Server

IMPORTANT: When you remove the repository from association with the host server, the VMs
stored in the repository can no longer be managed through this host server.

1 In the VM Client, click the Host Servers view, right-click a host server, then select Show Details.

‘& PlateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory
Virtual Machines

~ Host Servers

7RG . Motes

Discovered [1]

~ Storage
xenil

Templates

Memory

Storage Name Stored ... Type Capacity Free

dalll - = ocal
Associate Repository
Remove Repository

Marme MAC Address | Network

VM MName 0s Memory

slesg4hit SUSE Linux Enterpi

| @ Orchestrate | T8 VersionInfo | Show/Hide Progress View

2 Right-click any repository listed in the storage section, then select Remove Repository.

The repository is removed from those listed for the selected host server and is no longer
available to the host server.
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6.6.2 Removing a Host Server from a Repository

IMPORTANT: When you remove the repository from association with the host server, the VMs
stored in the repository can no longer be managed through this host server.

1 Inthe VM Client, click the Storage view, right-click a repository, then select Show Details.

£ PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory # OfficeRepo
Virtual Machines (] (@] (0] (=] | | | |

~ Host Servers
Discovered [1] Summary Virtual Machines Hosts Event Log

- Storage

dati1

Status Active V... | Motes Technalogy CPU Memory

1 XEN 3.x ®0 &
Associate Host 1 y @0 [ “BL]
Remove Host o X . @0 Q34

dat12.provo.novell.com

zo0s
ZRE4bit
xen3l

Templates

2 Click the Hosts tab, right-click a host, then select Remove Host.

The host is immediately removed from those listed for the selected repository so that it no longer
uses the repository.

6.6.3 Removing a Repository from the VM Client

WARNING: If a repository that you delete has VMs stored in it, the physical storage for the VMs’
files remains, but the files are no longer accessible to the VM Client, so the VMs can no longer be
managed.

1 In the VM Client, click the Storage view, right-click a repository, then select Delete.

£ plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Storage

Virtual Machines (=] (=] (o] (=] | L

~ Host Servers

Discovered [1]

stored VMs | Notes Capacity

xen30 Show Details
dat12.prov Local
Templates OfficeRepc Network Atti

Z0S Mew Repository Ctrl+R
ZRE4bit Mew VM....

Default ZOS datagrid backed repository Datagrid

Local

| & oOrchestrate | 18 yersion Info | Show/Hide Progress View
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The following confirmation dialog box is displayed:

?' Delete |:| @ @

lected repository 'da112.

n This action cannot be undone.

Are you sure you want to delete this repository?

2 Click Yes to delete the repository.

The repository is removed from those listed.
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7.1

7.1.1

Managing Templates

A template enables you to create multiple VMs using the same set of standard settings (guest
operating system, hardware, storage devices, and network settings). When you create (or clone) a
new VM from a template, you can personalize the settings required for the new VM.

You create templates from existing VMs. Currently, templates are supported only for Xen VMs and

VMware VMs. You cannot create a template from a Hyper-V VM.

The following sections provide information to help you create and manage templates:

¢ Section 7.1, “Viewing and Editing Template Details,” on page 149

¢ Section 7.2, “Creating a Template from a VM,” on page 152
¢ Section 7.3, “Editing Templates,” on page 154

¢ Section 7.4, “Moving a Template,” on page 163

¢ Section 7.5, “Deleting Templates,” on page 164

Viewing and Editing Template Details

Review the following sections for information on the Details views:

¢ Section 7.1.1, “Accessing Template Details,” on page 149
¢ Section 7.1.2, “Using the Details Tabs,” on page 150

Accessing Template Details

The details for each template consist of a summary and an event log.

1 In the VM Client, click the Templates view.
The templates are displayed:

£ PlateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory Templates
b Virtual Machines = =0
¥ Host Servers

¢ Storage

Templates Name #Clones  Notes Location

Template1 1 uidevd

1-Template 08
template2 shared

Template_1 shared

0s Technology CPUs Memory

SUSE Linux Entr XEN 1 512 MB

SUSE Linux Entr XEN 1 512 MB

SUSE Linux Entr XEN 1 512 MB
1

SUSE Linux Entr XEN 512 MB

| & oOrchestrate | 18 versionInfo | Show/Hide Prog
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2 Do one of the following:
¢ Double-click one of the templates.
¢ Right-click one of the templates, then select Show Detuails.
The tabs for the selected template are displayed.
3 For details on the tabs, see:
¢ “Summary Tab” on page 71
¢ “Event Log Tab” on page 78

4 To close the details view, click the view name in the Inventory perspective panel.

7.1.2  Using the Details Tabs

The following sections provide information on the various details tabs:

¢ “Summary Tab” on page 150
¢ “Event Log Tab” on page 151

Summary Tab

Figure 7-1 Summary Tab for Templates

i plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory 1 ZR64bit [Agent Running]
Virtual Machines @) =@ 0 =) |

[ J [ J
~ Host Servers

dat11 Summary Configuration Monitoring EventLog

dal12.pre

Discovered [1]

F  Storage
Templates

CFU

Memory

Storage Name Stored ... Type Capacity
ZRG4bit 0 Local
0 ata
11 Network At

WM Mame as Memory
MyPXE SUSE Linux Enterpris:

| 18 yersion Info | Show/Hide Progress View
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You can do the following with the Summary tab for templates:
¢ In the first section, right-click a group name under Groups, then select Remove to revoke the
template’s membership in the group.
¢ In the Notes section, enter and edit notes for the template.
¢ View basic information about the template:

¢ The template’s operating system

*

The virtual machine technology being used by the template

*

Number of clones of the template

IP address and DNS name, if it is not DHCP
The type of datastore and capacity

¢ The template’s MAC address

¢ The VMs it is associated with

*

*

¢ Double-click the Location entry to view the storage location’s details tabs.

+ Double-click a listed VM to view its details tabs. These are the VMs that were cloned from the
template.

¢ Right-click a listed VM, then select any of the available menu options. These are the same right-
click menu options that are available for the VM in the Virtual Machines Inventory list.

Wherever N/A appears in the details, it means that the information is not available.

Event Log Tab

Figure 7-2 Event Log Tab for Templates

il plateSpin Orchestrate VM Client

FILE EDIT ACTIONS VIEW HELP

Inventory E REHLS5_template [In Progress: Creating VM Template]

Virtual techines = = N = | [ tiew vii | Create Template -
¥ Host Servers
~ Storage Summary Event Log

xen30

~ Templates Action Status User Start Time Elapsed ...
REHLS_template Create Template © Creating VM Template system  2009-06-03 14:44:08 0:00:02:05

| @ Orchestrate | 8 yersion Info | sh de Prog
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1.2

You can do the following with this tab:

¢ View the Event Log information.

¢ Double-click an event item that contains the [i]icon to view the details of the event as reported
by the Orchestration Server. The following is an example of an event’s details:

i Event Log for action ‘Create Template'

Double Click on an item to show additional details.

Time Message
2009/06 3 VM template creation init by 'system’
2009/06 3 © Provisioning job sy .115' submitted to perform ‘Create Template' action
2009/06/1 3 Waiting for provision
2009,06/0:

Creating a Template from a VM

Templates are created from an existing VM, but it is created with some default settings so that it is not
identical to the VM. Templates allow you to quickly clone new VMs that are based on the template’s
configuration.

Currently, template creation is supported only for Xen VMs and VMware VMs. You cannot create a
template from a Hyper-V VM.

You can modify a template’s configuration. However, after you clone VMs from a template, the
template configuration can no longer be modified without first deleting or detaching the VMs that
were cloned from it. Therefore, when you create the template, plan to make all of your modifications
before using it to clone new VMs.

For information on cloning templates, see Section 8.1, “Cloning Templates,” on page 167. For
information on detaching cloned VMs from their templates, see Section 8.2, “Detaching Clones from
Templates,” on page 169.

IMPORTANT: If you define a CD-ROM or DVD-ROM in the template, it must be accessible through
shared storage to any future target host server. Otherwise, the CD-ROM or DVD-ROM might not be
included when a VM is cloned from the template and the VM will not start.

To create a template:
1 Inthe VM Client, click the Virtual Machines view, right-click the VM that you want to use to
create the template, then select Shut Down.
The VM cannot be running during creation of the template because the VM'’s image is modified.

2 In the VM Client, click the Virtual Machine view, select the VM that you want to use to create the
template, then do one of the following;:

¢ Click the EE=SEEES button.
¢ Click File > Create Template.
¢ Right-click the VM, then select Create Template.
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The following dialog box is displayed:

il Create Template

Mame: w2k3rZx86_64-zos106 Host: NfA  Repository: zos106-local-120GE

v Template Narme: |

Available Target Repositories
Stored YMs Motes Capacity
Local
Local
Local

Local

Available Target Hosts

Skatus Active ¥Ms Motes Technology: Memory

3 Specify a name in the New Template Name field.

4 Select the repository for the template from the Awvailable Target Repositories section.
Template files can be stored anywhere that provides access to them. The known repositories are
displayed.

It is preferable to use a repository for storing templates that is accessible to all host servers. The
first choice is a shared repository that provides fast access. The second choice is the ZOS
repository, which is shared; however, it is on the Orchestration server, which might have high
utilization and slower access to template files. The last choice is a repository on a particular host
server, because it might not be shared.

5 Select a host from the Available Target Hosts section.

This is the host against which the template is registered. In essence, this is the host that owns the
template.

6 Click Create Template.
You can view the progress in any of the following ways:
¢ Observe messages at the bottom of the VM Client interface.

¢ Click View > Show Progress View or double-click Show/Hide Progress View to open the Progress
View window. In the Progress View you can mouse over the entry in the Status column, or
right-click that entry and select Show Log to view the log information for creating the
template.

¢ In the Virtual Machines view, double-click the VM from which the template is being created,
click the Event Log tab, then double-click the entry related to the creation process that has
the [i] icon next to it. The Event Log Details dialog box is displayed and automatically
updated as events occur.

Managing Templates 153



¢ In the Templates view, double-click the template that is being created, click the Event Log tab,
then double-click the entry related to the creation process that has the [{] icon next to it. The
Event Log Details dialog box is displayed and is automatically updated as events occur.

¢ View its progress in the Jobs tab of the Orchestration Console.
The new template is listed in the Termplates view.

7 To modify the template to your desired specifications, continue with Section 7.3, “Editing
Templates,” on page 154.

After editing the template, you can then use it to clone new VMs. For more information, see
Section 8.1, “Cloning Templates,” on page 167.

7.3 Editing Templates

Templates can be edited at any time. However, if a template was cloned, you must first detach the
clones before you can edit it. For more information, see Section 8.2, “Detaching Clones from
Templates,” on page 169.

The following steps include information for all possible template fields and pages. Depending on VM
type, you might not be able to edit the template or the template might not have all of the fields and

pages.
To edit a template, run the Virtual Machine Properties Wizard:
1 If you want to retain your edits on a VM, click the Virtual Machines view in the VM Client, right-
click the VM that you want to edit, then select Shut Down.
2 Do one of the following in the Templates view to start the wizard:
Select a template, then click the button.
Select a template, then click Edit > Edit.

*

*

*

Select a template, then press Ctrl+E.

*

Right-click any listed template, then select Edit.

154  NetlQ Cloud Manager 2.1 VM Client Guide and Reference



The following wizard page is displayed:

i Virtual Machine Properties

Description

Enter an overall description or purpose for this VM,

Hardware
Storage Devices
Network

SLES10 SP2 64-bit, Server B

Guest Operating System
SUSE Linux Enterprise Server 10

the drop doy

Additional Aruments

Required field - I:_Lliatt > - - [ cancel
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If a template currently has cloned VMs associated with it, you cannot edit the template. The
following dialog box is displayed when you attempt to edit such a template:

Information

I’ Cannot Edit Template

4

ﬂ SLES10_64bit has the following doned VMs:
SLES10_64bit_CloneA

These YMs must be deleted in order to edit this template.

After noting which VMs are involved, click OK to close the dialog box, then determine whether
you want to detach those VMs in order to edit the template. For more information on detaching
the clones from the template in the Orchestration Console, see Section 8.2, “Detaching Clones
from Templates,” on page 169.

3 Fill in the available fields:

Description: Note the purpose and any other specifics you might require of the template. These
notes apply to all versions of this template.

Guest Operating System: The clones of the template inherit the operating system of the VM

following are supported:

SUSE Linux Enterprise Server 8

SUSE Linux Enterprise Server 9

SUSE Linux Enterprise Server 10

SUSE Linux Enterprise Server 11

SUSE Linux Enterprise Desktop 10

SUSE Linux Enterprise Desktop 11
openSUSE

openSUSE 11

Novell Open Enterprise Server 2 (Linux)
Novell Open Enterprise Server 2 (NetWare)
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Novell NetWare 6.5 SP6 and older
Red Hat Enterprise Linux 3

Red Hat Enterprise Linux 4

Red Hat Enterprise Linux 5
Solaris 9 and older

Solaris 10

Microsoft Windows NT

Microsoft Windows XP, 2000, 2003
Microsoft Windows XP, 2003 (x64)
Microsoft Windows Vista
Microsoft Windows Vista (x64)
Microsoft Windows Server 2008

Microsoft Windows Server 2008 (x64)

There is also an “(other)” option for the following;:

SUSE
Red Hat
Microsoft Windows

Additional Arguments: This field applies only to paravirtual installations. These are Linux

install arguments, which are operating system parameters similar to the information entered in a
GRUB boot loader when running on bare hardware in SUSE Linux Enterprise Server (SLES) and

SUSE Linux Enterprise Desktop (SLED). Additional network installation information can be
added here, which is used during the build process to find the installation source for the VM

build process.
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4 Click Next to display the following wizard page:

i Virtual Machine Properties |Z|@
Hardware i’

Select the number of Virtual Processors you'd like the Guest Oper System to see. Ideally, any physical computer that hosts this f
VM should also have at least the spedified number of physical proc 4

Description

Storage Devices
Network

Memory Size ¥

Display Driver

Cirrus Lo
»

© Paravirtualized Graphics Driver

Remote Console Password Console Password Again

Required field

5 Fill in the available fields to define the kind of hardware to be virtualized for the template:
Processors: The number of virtual processors the template has.

Memory Size: The amount of virtual RAM the template has, or paravirtualized memory that
can be used by the VM if it is paravirtualized.

Max: The amount of virtual RAM the template has, or paravirtualized memory that can be used
by the VM if it is paravirtualized.

Display Driver: The properties of the VM's display. If you have chosen paravirtualization for
this VM, your only option is Paravirtualized. If you have chosen full virtualization, you can select
between VESA or the on-board VGA. If you do not need a display, you can turn off the display
on a fully virtualized machine.

Remote Console Password: The password for remotely controlling the VM. Use the two fields
to confirm that the password is typed correctly.
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6 Click Next to display the following wizard page:

i Virtual Machine Properties |:_|@

Storage Devices i’
Shows the disks currently defined for the YM. The first disk is reserved for the operating system and must be of type Hard Disk. f

Description
Hardware Mame  Type Source Size (GB)

1  Hard Disk file: fvar flib fxen/images frvmdone 1/05disk 2GB
Network

(addrardDsk [ Addcorov  (iiieieceny  (ovEBewy  (NBSSEGEEN

Required field

The example shown is for a template.

The Storage Devices page is for defining the hard drives and CD or DVD drives that you want to
include in the template profile. The first device must always be a hard disk that cannot be
removed unless another hard disk has been put into the first slot. This is the only disk (Disk 0)
that is stored and version controlled. All other disks are virtual and are created upon launching
the VM. You can add any other storage devices you want to the template and move them
according to priority in the list.
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7 To fill in the storage device information, select a task from the following table:

Tasks Steps Additional Details
Adding aharddiskto 1. Click Add Hard Disk. The following restrictions
your VM apply per VM:

2. Fill'in the following fields:

Name: The name is the number in the order
the drive appears in its VM image list.

Type: Select the type of hard disk you want
to create on the VM:

+ Hard Disk
¢ iSCSI (see Warning)

+ N_Port ID Virtualized Storage (see
Warning)

+ Network Attached Storage

Source: The repository on the hard disk of
the VM.

Size (GB): The VM's hard drive size,
ranging from 0.25 GB (250 MB) to 4 TB.
This is the maximum allowable size of the
VM.

Read Only Access: Select this option to
give the hard drive Read-Only access. By
default, hard drives are writable.

Fabric ID: (Available only for the N_Port ID
virtualized storage). Select or specify a
fabric ID that uniquely identifies a SAN
repository.

The Fabric ID drop-down list is populated

with fabric IDs of the discovered SAN
repositories.

World Wide Name: (Available only for the
N_Port ID virtualized storage). Select or
specify a unique World Wide Name.

The World Wide Name value is
automatically assigned for the NPIV disks.
You can edit it, if required.

Target ID: (Available only for the N_Port ID
virtualized storage). Specify the target ID of
the SAN repository.

LUN: (Available only for the N_Port ID
virtualized storage). Specify a LUN value
between 0 and 254.

3. Click Apply.

¢ Limit of 4 fully
virtualized disks
(hda-hdd).

¢ Limit of 16
paravirtualized
disks (xvda-xvdp).

WARNING: Do not select
iISCSI or NPIV when
defining or editing a
template. This causes all
VMs cloned from the
template to use the same
iISCSI or NPIV location,
thus corrupting the disk.

While adding an
additional NP1V disk to a
VM, ensure that the disk
values for Fabric ID,
World Wide Name,
Target ID, and LUN are
unique for each NPIV
disk of the VM.

Creation of a block-
based VM is not
supported for NPIV.
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Tasks

Steps

Additional Details

Adding a CD-ROM or
DVD ROM to your
VM

Rearranging the
order in which each
storage device is
accessed

Deleting a storage
device

1. Click Add CD-ROM.
2. Fill'in the following fields:

Name: The name is the number in the order
the drive appears in its VM image list.

Type: Select the type of CD-ROM you want
to create on the VM:

¢+ CD-ROM
* DVD

Source: The repository on the hard disk of
the VM.

Size (GB): The size is zero and cannot be
changed.

Read Only Access: These drives can only
have Read-Only access.

. Click Apply.

. Select the storage device whose order you

want to change.

. Click Move Up or Move Down.

. Select the storage device you want to

delete.

. Click Delete.

IMPORTANT: If you add
a CD-ROM or DVD-
ROM, any VMs created
from this template can
only be moved, migrated,
or used to create another
template if the CD-
ROM's or DVD-ROM's
ISO or image is
accessible through
shared storage.

The first storage device
in the list must be a hard
disk, which is the only
one actually stored in the
VM image.

Removes the selected
storage device from the
table.

WARNING: Ifthe storage
device is based on a disk
image, that could also be
deleted. To preserve the
disk image, manually
copy it to another
location before deleting
the storage device.
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8 Click Next to display the following wizard page:

i Virtual Machine Properties

Network
Entered MAC address is syntactically correct.

Description
Hardware Mame  Driver Type MAC Address
o e 1 Paravirtualized 00:16:3e: 16:5czec

Name
Driver Type Paravirtualized
MAC Address  00:16:3e: [l ala

Required field

The example shown is for a template.

The network devices are added, deleted, and defined on the Network page, where you add
specific information about your network connections or intended network connections for your
template. You can define more detailed NIC settings in your auto-install files or when
performing a guest installation.
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9 To fill in the NIC information, select a task from the following table:

Tasks Steps

Adding aNICtoyour 1. Click Add NIC.

M 2. Fill in the following fields:

Name: The number, based on the NIC’s order in the list, automatically
assigned to the NIC.

Driver Type: Indicates whether the VM has direct access to the NIC. If
the NIC should only interface with the hypervisor, you can select the
specific type of full virtualization. You should have a paravirtualized
NIC with a paravirtualized VM.

MAC Address: Unless you have a specific MAC address you want to
assign to this VM, leave this set to Default, and Xen assigns it a MAC
address when you launch the VM.

Network: Select the network you want associated with the NIC.
3. Click Apply.
Rearranging the 1. Select the storage device whose order you want to change.

order in which the

2. Click Move Up or Move Down.
NICs are accessed

Deleting a NIC from 1. Select the NIC you want to remove.
your VM 2. Click Delete NIC.

10 To complete and close the wizard, click Apply.
You can click Back to make further changes before applying the edits.
Applies the wizard configuration changes and saves the template in the Templates view.

Focus is returned to the Virtual Machines view after you exit the wizard with the edited template
selected in the list.

After editing a template, you can then use it to clone new VMs. For more information, see
Section 8.1, “Cloning Templates,” on page 167.

Moving a Template

IMPORTANT: If the template has a CD-ROM or DVD-ROM defined in it, it must be accessible
through shared storage to the target host server. Otherwise, the CD-ROM or DVD-ROM is not
included in the move and any VMs cloned from the template cannot start. In that case, you should
remove the CD-ROM or DVD-ROM from the template before moving it.

If the VM you want to move has had clones made from it, you must first detach all of the clones. For
more information, see Section 8.2, “Detaching Clones from Templates,” on page 169.
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You can move a template’s files from one host server to another.

1 Inthe VM Client, click the Templates view, right-click the template to be moved, then select Move
to display the following dialog box:

i Move Template
Name: REHLS template Host: NJA  Rep y: OfficeRepo

Selectar from the following list.
Only the ri 5 that meet the move criteria for this Template are listed.

Available Target Repositories

Name = Stored WMs Motes Type

dalil Local

da112.provo.novel.com Local

Default ZOS datagrid badked repository Datagrid
Local

Z0s

TRa4bit

T e

2 Select the repository, then click Move.
The template’s files are moved to the host server where the repository resides.

Deleting Templates

Deleted templates cannot be recovered. You also cannot delete a template that has clones. However,
you can use the Orchestration Console to detach the clones from the template. For more information,

see Section 8.2, “Detaching Clones from Templates,” on page 169.
1 In the VM Client, click the Templates view, then select one or more templates.
2 Do one of the following to delete the selected templates:
¢ Click the button.

¢ Click Edit > Delete.
¢ In the Templates view, right-click the selected template, then select Delete.
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3 Click either Yes or No to delete the template:

Delete

I This action deletes the selected template 'SLES10_&4bit’,

n This action cannot be undone.

Are you sure you want to delete this template?

This completely removes the templates from the Templates view. It does not have any affect on
any VMs cloned from these templates.
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8.1

Managing Clones of Templates

You can clone templates to create new VMs. The following sections provide instructions:

¢ Section 8.1, “Cloning Templates,” on page 167

¢ Section 8.2, “Detaching Clones from Templates,” on page 169

Cloning Templates

Templates provide a method for quickly creating a new VM. Information for the new VM is taken
from the VM template. You simply personalize the VM with a new name and description.

A clone of a template contains just the differences between the template and the clone. The template’s
file contains the bulk of the VM information. Before cloning a template, you should use the
Orchestration Console to ensure that the template includes the correct information.

Because clones are so closely related to their parent template, you cannot perform actions against a
template without directly affecting its clones. So, in order to edit, delete, or move a template using the
VM Client, you must first detach or delete its clones. The detaching process creates a complete VM
image for the clone, which is then no longer considered to be a clone in the VM Client.

IMPORTANT: If a CD-ROM or DVD-ROM is configured for the template that you want to clone, it
will be included only if its ISO or image is accessible through shared storage. If it is not accessible, the
VM cloned from this template cannot start. In that case, you must remove the CD-ROM or DVD-
ROM definition from the template’s properties before cloning the template.

The following steps include information for all possible fields and pages. Depending on VM type, the
clone might not have all of the fields and pages.

To create a clone:
1 Inthe VM Client, click the Templates view, then select a template.
2 Do one of the following to clone the template:
* (Click the button.
* Click Edit > Clone.

¢ In the Templates view, right-click the selected template, then select Clone.
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The following wizard opens:

il Yirtual Machine Properties

Description

Enter a unique name without sp pecial characters
wrxpsp3-template-zos103 i zos103-local-100GE

¥M Name

Descrition

Available Repositories
Starage Mame Stored WMs Type Capacity
Lacal
Local
Local
Local

Lacal

Available Target Hosts
Mame Status Ackiv... MNaotes

151,15 0% u i

Required field - - - I__ Cancel

3 Configure the following options:

VM Name: Specify a name for the cloned VM. This name must be unique. It cannot already exist
in either the Virtual Machines or Templates lists. The name cannot be longer than 100 characters
and cannot start with the letters “xen.”

Entering a name enables the Clone button. All remaining fields and pages are optional; you can
configure them now or after the VM clone is created.

Description: Add any information you want to identify this VM.

Available Repositories: The template’s repository is automatically selected. If you do not want
to store the VM clone in this repository, select another one.

Available Target Hosts: This list displays the hosts associated with the selected repository.
Select the host that you want to run the VM when it starts.

4 Click Clone.
A cloning job is started. You can view its progress in any of the following ways:

¢ Double-click the template being cloned, click the Event Log tab, then double-click the entry
related to the cloning process that has the [{] icon next to it. The Event Log Details dialog
box is displayed and is automatically updated as events occur.

¢ Observe messages at the bottom of the VM Client interface.
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¢ Click View > Show Progress View to open the Progress window.
¢ View its progress in the Jobs tab of the Orchestration Console.

When the cloning process is complete, the VM Client’s job status is displayed in a pop-up
message, as well as in the Event Log Details dialog box. It is also listed in the Orchestration
Console as Completed.

The cloned template is now listed with the other VMs in the Virtual Machines view.

5 (Optional) Right-click the cloned VM, then select Edit to modify it as necessary.

Detaching Clones from Templates

To edit, delete, or move a template using the VM Client, you must first detach or delete its clones. The
detaching process creates a complete VM image for the clone, which is then no longer considered to

be a clone by the VM Client.

Deleting a clone is the same as deleting a VM. For more information, see Section 5.11, “Deleting
VMs,” on page 134.

To detach one or more cloned VMs:

1 In the VM Client, view the dialog box that is displayed when you attempt to edit, delete, or
move a template and note which VMs need to be detached.

2 Select Virtual Machines in the Inventory panel, then do one of the following:
* Select a VM to be detached, then click the button.
* Select a VM to be detached, then click Edit > Detach.
¢ Right-click a VM to be detached, then select Detach.
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The following dialog box is displayed:

£ Detach VM M =13

This action detaches selected VM TestClonesSize' from the template

o o ol
|_H'.'|'|'.l_..'|LE..'| .

4

n This action cannot be undone.

Are you sure you want to detach VM TestCloneSize' from the
template 'i386_SLES'?

3 Click OK to confirm the detachment of the VM from the template.

The VM is repositioned under VMs now that it is no longer related to a template.
4 To detach more VM clones, repeat Step 2 through Step 3.
5 Return to the VM Client to either edit, delete, or move the template.
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9.1

Managing with Groups

You use groups to manage the items listed in the Inventory panel:

¢ Section 9.1, “Understanding Groups,” on page 171

¢ Section 9.2, “Creating a Group,” on page 179

¢ Section 9.3, “Adding Members to an Existing Group,” on page 180
¢ Section 9.4, “Removing Members from a Group,” on page 183

¢ Section 9.5, “Deleting a Group,” on page 186

Understanding Groups

Groups allow you to better manage a view’s items when you have too many items to view on one
screen. You can create multiple groups under any of the four Inventory perspective views (Virtual
Machines, Host Servers, Storage, or Templates).

The following figure illustrates groups in the Inventory panel:

Figure 9-1 Groups in the Inventory Perspective of the VM Client

il plateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory RHEL
}  Virtual Machines NEMMM
¥  Host Servers

~ Storage

xen30 Status Notes

Templates

| @ Orchestrate | 8 yersion Info | Show Hide Prog
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The presence of the
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indicates that the Inventory type has groups within it. It changes to the _ icon when you click the
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to expand the groups list.
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To view groups and group memberships:

1 In the VM Client, click the
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icon for an Inventory’s view (Virtual Machines, Host Servers, Storage, or Templates) to expand its
existing groups.

2 To view a group’s membership, click the group’s name in the Inventory panel.

The group’s members are displayed in the details panel on the right. You can work with those
members the same way you work with the items in the view’s full listing.

You can expand as many groups as you like. A vertical scroll bar provides navigation.

9.2 Creating a Group

1 In the VM Client, do one of the following:
¢ Right-click a view in the Inventory perspective, then click New Group.
¢ Select a view in the Inventory perspective, the click File > New Group.

This opens the New Group dialog box:

New Group %]

Enter the group name

name: [

2 Specify a group name, then click OK.

The group is now displayed under the selected view:
£ PlateSpin Orchestrate VM Client |Z||E|rg|
FILE EDIT ACTIONS VIEW HELP

Inventory RHEL

~  Virtual Machines (] (@] (] [»]

RHEL

b Host Servers Status

Notes
¢ Storage

Templates

| ® Orchestrate

3 To add members to the group, continue with Section 9.3, “Adding Members to an Existing
Group,” on page 180.
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9.3 Adding Members to an Existing Group

1 In the VM Client, click a view in the Inventory perspective.
2 Click the view’s

180  NetlQ Cloud Manager 2.1 VM Client Guide and Reference



Managing with Groups 181



182

icon to expand its groups.

3 In the details panel, right-click one of the listed items (a VM, a host server, a repository, or a

template), then drag and drop it into one of the view’s existing groups:

£ PlateSpin Orchestrate VM Client

HELP

Inventory Virtual Machines

> \irtual Machines |E| |E| |E| |t|
RHEL|

b Host Servers

Hame - a5

:

~ Storage test-32bit SUSE Linux Enterprise
xendi

sles10532Zbit-2 SUSE Linux Enterprise

Templates sles1032-test SUSE Linux Enterprise

sles64bit daii1 SUSE Linux Enterprise

SLES32bit SUSE Linux Enterprise

Drag Members o i )

to the Group er operating syste
Other operating syste
Other operating syste

Other operating syste
ZR64bit SUSE Linux Enterprise
32bitTemplate SUSE Linux Enterprise

J2bitct

" vyvERIIE R Y EOBN

SUSE Linux Enterprise

| ® Orchestrate |

The item is still listed in the view if you do not have a group selected for the view. That way, you
can assign an item membership in multiple groups.

4 After copying the members into a group, click the group in the Inventory panel to view its

membership:

£ PlateSpin Orchestrate VM Client

Inventory

~ \irtual Machines

RHEL

b Host Servers

05
RHat-C1 | | Other operating syste

CPU

= Storage

xen3(

Other operating syste

Other operating syste

Templates

| ® Orchestrate | 8 VersionInfo |

Show/Hide Progress View
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9.4 Removing Members from a Group

1 In the VM Client, click a view in the Inventory perspective (Virtual Machines, Host Servers,
Storage, or Templates).

2 Click the view’s
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icon to expand its groups, then select one of the groups.
The details panel on the right now displays only the members of the group.

3 In the details panel, right-click one of the listed items (a VM, a host server, a repository, or a
template).

il PlateSpin Orchestrate VM Client

VIEW HELP

Inventory RHEL

~ Virtual Machines =] =] 1] (=]
RHEL

b Host Servers

Status Notes 05 CPU

~ Storage Other operating syste
xen3i Show Details
RHat Other operating syste
Templates RHEL Start Other operating syste
Edit...

Create Template...

Resync State
Move, .,

Delete

Install Agent

New VM...

| & Orchestrate | 18 version Info | Show/Hide Progress View

4 Click Remove from Group.

The selected item is removed from the view’s group, but not from the view’s full list.
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9.5 Deleting a Group

1 In the Inventory perspective in the VM Client, click a view’s
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icon to expand the view.

2 Right-click the group that you want to delete, then select Delete to display the Delete Group
dialog box:

f' Delete Group

l This action deletes the selected group 'RHEL'.

ﬁ This action cannot be undone.

Are you sure you want to delete group 'RHEL'?

3 Click Yes to delete the group.

The group is removed from the Inventory perspective panel. However, the members of the
group are not removed from the view’s list. They are only disassociated from the deleted group.
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10.1

VM Client Debugging and
Troubleshooting

This section includes information to help you debug and troubleshoot the NetlQ Cloud Manager VM
Client after you install it.

¢ Section 10.1, “Editing the VM Client Preferences File,” on page 189
¢ Section 10.2, “Troubleshooting the VM Client,” on page 191

¢ Section 10.3, “Accessing VMs and Host Servers,” on page 191

¢ Section 10.4, “Moving or Migrating the VMs,” on page 191

¢ Section 10.5, “Registering VM Hosts,” on page 193

Editing the VM Client Preferences File

A preferences file is created after the first time you use the VM Client. This preferences file contains
locations for storing list data, such as successful logins, installation sources, and auto-install files.
Some preference settings are for debugging that you can use with the guidance of NetlQ Support.

Following is an example of a preference file with default settings:

#Thu May 07 17:38:03 GMT 2011

Use\ Alpha=true

Login\ Info\ Sets\ Preference\
List=ml.zenworks.lab.novell.com;admin;ZOSCommunicator
Trace=false

Stale\ Update=true

Auto\ Update=true

Show\ Edit\ Running\ VM\ Warning=true
eclipse.preferences.version=1

Show\ Part\ Menu=false

To prevent issues with the VM Client and to keep it working properly, you should contact Cloud
Manager Support for help when you edit the preferences file.

¢ “Transparency of VM Client Window Causes Display Problems” on page 189

Transparency of VM Client Window Causes Display Problems
Source: The VM Client Window.

Possible Cause: When you open a dialog box, the VM Client window becomes somewhat
transparent, which can cause display issues in Windows (but not Linux) while
using VNC to view a VM or host server machine’s command line or desktop, or
when using a Web casting software to view or interact with the VM Client that is
running on another machine. This transparency is controlled by the Use\
Alpha=true setting. By default, transparency is set to be in effect (True).
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Action: Change true to false before using VNC or a Web casting software program so
that viewing is in a non-transparent mode.

1 If you have not yet opened and exited the VM Client for the first time, do
the following to establish the preferences file; otherwise, go to Step 2:
la (Conditional) Install the VM Client.
For instructions, see Section 2.1, “Installing the VM Client,” on page 13.
1b Open the VM Client.

For instructions, see Section 2.2, “Starting and Logging In to the VM
Client Interface,” on page 16.

This initializes the preference file settings.
1c Exit the VM Client.

This causes the com.novell .vnos.prefs file to be created on the
machine where you installed the client.

2 Make a backup copy of the com.novell.vnos.prefs file.
You might need this backup copy in Step 5b.
3 Open the com.novell.vnos.prefs file in a text editor.

* Windows:

installation path\VM Client
2.6\bin\workspace\ .metadata\ .plugins\org.eclipse.cor.runt
ime\.settings\com.novell.vnos.prefs

¢ Linux:

/home/user/ .novell/nvmm/workspace/.metadata/.plugins/
org.eclipse.cor.runtime/.settings/com.novell.vnos.prefs

4 Edit the preferences file as necessary.

Valid preference values are true and false.

IMPORTANT: If you edit the preferences file, do not remove any
backslashes (\) that accompany the key names, including the space after the
backslash.

5 Save the file, then reopen the VM Client.

The preferences file changes should be in effect. If not, or if the VM Client is
not working properly, do the following:

5a Exit the VM Client.

5b Replace the preferences file with the backup copy that you made in
Step 2.

5¢ Restart the VM Client.
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10.2 Troubleshooting the VM Client

The following sections provide solutions to the problems you might encounter while working with
the VM Client:

¢ “Duplicate NPIV disks are not allowed” on page 191

Duplicate NPIV disks are not allowed

Source: The VM Client.

Action: When you add an additional NPIV disk to a VM, ensure that the disk values for
Fabric ID, World Wide Name, Target ID, and LUN are unique for each NPIV
disk of the VM.

10.3 Accessing VMs and Host Servers

¢ “VM or Host server is Mot Accessible” on page 191

VM or Host server is Mot Accessible
Source: The VM Client.

Explanation: A VM or host server does not appear to be accessible for any actions. This might
be because its Enabled check box is disabled. By default, this check box is
enabled.

Action: In the Orchestration Console:

1 In the Explorer panel, expand the Resources section.
2 Browse for and select the VM or host server.

3 Click the Info tab and expand the Info section.
4

For a VM, expand its Resource Information section; for a host server, expand
its VmHost Information section.

5 For a VM, make sure the Resource Enabled check box is selected; for a host
server, make sure the Enabled check box is selected.

6 If you changed the status of the check box, click File > Save to make the
change effective.

You should now be able to perform actions against the VM or host server.

10.4 Moving or Migrating the VMs

+ “VMis out of sync in the VM Client after it was moved” on page 192

¢+ “Moving or migrating VMs between two ESX hosts that are registered to a vCenter server by
using the Orchestration Console fails” on page 192

¢ “Moving a VM from one ESX host local storage to another ESX host local storage might fail” on
page 192

¢ “A migrated VM’s Orchestration Agent loses connection with the Orchestration Server” on
page 192
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VM is out of sync in the VM Client after it was moved

Explanation: If you move a VM outside of the VM Client, such as from a command line or in
using the Orchestration Console, the VM is out of sync and cannot be used.

Possible Cause: Moving a VM outside of the VM client causes its state to be out of sync between
the VM Client and the Orchestration Server.

Action: To resynchronize the VM in the VM Client:

1 Right-click the VM that was moved, then select Resync State.

Moving or migrating VMs between two ESX hosts that are registered to a vCenter
server by using the Orchestration Console fails
Source: The VM Client.
Action: Do the following:
1 Disconnect and remove one of the ESX hosts from the vCenter server.

2 Move or migrate the VMs by using the Orchestration Console.

For more information, see Section 5.9, “Moving VMs,” on page 128 or
Section 5.10, “Migrating VMs,” on page 130.

Moving a VM from one ESX host local storage to another ESX host local storage
might fail
Source: The VM Client.

Explanation: When you try to use the VM Client to move a VM of considerable size from one
ESX host local storage to another ESX local storage, the move job might fail with
the following error message:

Job timeout, because Max elapsed time expired.

Action: In the policy associated with the VM, appropriately increase the time-out value.
For more information, see “Provisioning a Virtual Machine” in the NetIQ Cloud
Manager 2.1 VM Orchestration Reference.

A migrated VM’'s Orchestration Agent loses connection with the Orchestration
Server

Source: The VM Client.

Explanation: After you migrate a Xen VM that has the Orchestration Agent installed, the
agent might lose connection with the Orchestration Server.

Action: Restart the agent on the VM to reestablish the connection.
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10.5 Registering VM Hosts

¢ “VM Hosts are not registered to the Orchestration Server even after a considerable time” on
page 193

VM Hosts are not registered to the Orchestration Server even after a
considerable time

Source: The VM Client.
Action: In the VM Client, click Action > Discover Hosts.

The registered VM host is displayed in the Host Servers list.
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A.l

A.2

VM Installation Sources

You have two sources from which to install VMs for the NetIQ Cloud Manager VM Client:

¢ Section A.1, “Disk Installation Sources,” on page 195

¢ Section A.2, “Guest Operating System Installation Sources,” on page 195

Disk Installation Sources

To install a fully virtualized machine, you can specify an installation source that must be mounted in
such a way that the VM recognizes it as a mounted installation source. For example, FTP, HTTP, and
NEFS.

For other installation sources to use for both fully virtualized and paravirtualized installations, the
following sources can be designated to serve as virtual mount points:

¢ A disk image, such as an ISO file accessible from the local file system of the machine performing
the installation. For example: /install ISOs/slesl0sp2.iso

IMPORTANT: This ISO needs to be available on all Orchestration Servers in the virtualization
grid that were installed with the Virtual Machine Builder pattern, because a VM could access
this ISO from any of them.

+ A remote storage device specified by using the Internet SCSI (iSCSI) protocol. For example:
iscsi:ign.2001-04.com.acme:0ac47ee2-216e-452a-a341-al12624cd0225

Also, in order to add an iSCSI hard drive to a VM, the host server needs to have the iSCSI targets
discovered, or it will not create the VM.

¢ A remote storage device specified by using a Fibre Channel (NPIV) protocol. For example:
npiv:210400e08b80c40f

Both Linux and Windows operating systems can use these installation sources, as applicable.

Guest Operating System Installation Sources

You need to designate an installation source for a paravirtualized machine. The following is a list of
guest operating systems and the installation sources to use for a paravirtualized installation. The
listed sources are suggestions and examples.

¢ Section A.2.1, “SUSE,” on page 196
¢ Section A.2.2, “NetWare,” on page 196

¢ Section A.2.3, “Other Linux Installation Sources,” on page 196
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A.2.1 SUSE

¢ Aremote directory containing the install files, specified by using the HTTP protocol: The HTTPS
protocol is not supported.
http://www.domain.com/install sources/sleslOsp2/

+ A remote directory containing the install files, specified by using the FTP protocol:
ftp://www.domain.com/install sources/sleslOsp2/

¢ A remote directory containing the install files, specified by using the NFS protocol:

nfs://www.domain.com/install sources/slesl0sp2/

A.2.2 NetWare

A paravirtualized NetWare operating system can be installed by using the same installation sources
as fully virtualized VMs.

NOTE: Open Enterprise Server (OES) 2 and OES 2 Linux can be paravirtualized or fully virtualized.
NetWare 6.5 and earlier must be fully virtualized. See Section A.1, “Disk Installation Sources,” on
page 195 for instructions on fully virtualizing the guest operating system.

A.2.3 Other Linux Installation Sources

Paravirtualized operating systems other than SUSE and NetWare can be installed by using the same
installation sources as the fully virtualized VMs (see Section A.1, “Disk Installation Sources,” on
page 195).
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B NPIV Terminology

Terms associated with N_Port ID Virtualized (NPIV) Storage:

¢ Fabric ID: A unique numeric identifier of the SAN repository.

¢ LUN: Logic Unit Number. A unique number used to identify a logical unit on the disk storage.
The value can be between 0 and 254.

¢ Target ID: The port number of the storage disk provided by the SAN vendor.

¢+ WWN: World Wide Name. An 8-byte number used as a unique identifier in a Fibre Channel or
Serial Attached SCSI storage network. The first 16 digits represent the WWPN; the last 16 digits
represent the WWNN.

¢+ WWNN: World Wide Node Name. A 16-digit World Wide Name assigned to a node (an
endpoint or a device) in a Fibre Channel fabric or Serial Attached SCSI storage network.

¢+ WWPN: World Wide Port Name. A16-digit World Wide Name assigned to a port in a Fibre
Channel fabric or Serial Attached SCSI storage network.
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Uninstalling the VM Client

The NetIQ Cloud Manager VM Client program is installed on your Windows or Linux
administration machines. You can uninstall the client from these machines.

Select the appropriate platform:

¢ Section C.1, “Uninstalling the VM Client from the Windows Operating System,” on page 199

¢ Section C.2, “Uninstalling the VM Client in a Linux Environment,” on page 199

C.1 Uninstalling the VM Client from the Windows Operating
System

1 On the Windows machine where the client is installed, click Start > Settings > Control Panel > Add
or Remove Programs.

2 Select Cloud Manager VM Client, then click Remove to open the InstallAnyWhere utility, which
displays the first wizard page:

3 Click Next to display the Uninstall Options page:
4 Click Next to display the Uninstalling page:

This removes all installation files and registry settings.

After the installation has completed, the Uninstall Complete page is displayed:
5 Click Done to complete the uninstallation.

If you receive a message after the client is uninstalled indicating that some folders could not be
removed, you must delete them manually.

C.2 Uninstalling the VM Client in a Linux Environment

1 Run the following command:

/opt/novell/zenworks/vmmanagement /Uninstall PlateSpin VMM/
Uninstall PlateSpin Orchestrate VM Client 2.6.0

This opens the InstallAnyWhere utility, which displays the first wizard page:
2 Click Next to display the Uninstall Options page:
3 Click Next to display the Uninstalling page:

This removes all installation files.
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After the installation has completed, the Uninstall Complete page is displayed:
4 Click Done to complete the uninstallation.

If you receive a message after the client is uninstalled indicating that some folders could not be
removed, you must delete them manually.
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Adding User Logins for VM
Operators

In a default setup, the Orchestration infrastructure administrator is the only user who can log in to
the VM Client and manage VMs. This section explains how you can add individual VM operator
login IDs, so that they can also log in to and use the VM Client to manage VMs.

The login names that you create are displayed in the User column for event logs in the VM Client. For
example:

Figure D-1 Event Log Tab for a VM Showing the User Column

i plateSpin Orchestrate VM Client

ACTIONS VIEW HELP

Inventory # sles1032bit-2 [Running]

~ Virtual Machines ala @ J[_edic ][ vrigrate |\ Console ]

User

EventLog

Start Time Elapsed ...
@ shutdow

@ VM Active (no agent connection)

¥ Host Servers
F  Storage
Templates

| & Orchestrate | 8 yersion Info | Show/Hide Progress View

In this example, systemis displayed as the user who initiated the actions because the VM operator
logged in to the grid as the default administrator user.

When you provide individual login names for VM operators, their login names are displayed so that
anyone logged in to the VM Client can see who initiated each action.
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To add individual user login IDs:

1 In the Orchestration Console, click Actions > Create User.

This opens the Create a New User dialog box:

@ Create a new User

=
Mews User Marne

Target Groups Source Groups

Object Object

@ administrators @ all
3 svstern

Caunt 1 Count 2

Close

2 In the New User Name field, specify the login name.
3 Make sure that the Target Groups section contains administrators.
If not, select administrators in the Source Groups section, then click the Add button.

When you add this user to the administrators group, the user can use the VM Client to
administer life cycle operations on virtual machines.

4 Click Create > Close.
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5 In the Explorer panel, browse to the new user:

PlateSpin Orchestrate Development Client

Eile Edit Wiew Actions Provision Serwver indows Help

[ -0

IJobs Eesources Users

& &

WM Hosts  Provisioner

=]

Scheduler

Explorer | Palic

Orchestrate Servers
-2 daz41_grid
o tszend_Grid

= User v wvmopl

¢ lﬂtszens_crid m f Info f Croups r_ﬁ Palicies rﬁf Health Debugger T/-D- Constraints J Facts |

& B server Adrmin
L %Jobs
o % Resources
o~ B Repositaries
¢ @ Users (23
[ @ adrninistratars (1)

57 Info

[v] Show Inherited Fact Yalues From Policies & Groups)

[> User Information

7 Personal Information

- vmopl | First Mame | |
¥ @ a@” @ Last Mame \ |
0 \?:;ZT Fassward \"""""""" |
o 6 system (1) B | Email |
@ system P City | |
o 3 policies i State | |
o & public JDL Libraries Country | |
L @ Computed Facts Site \ |
o & Evems & MNarme Walue
o & Matrics :

Environment E

[> Iob Information
D- Accounting Information

[> Iob Cantrol

[> Quota Infarmation

[ Groups

|Current server is: [ tszens _Crid tszens . provo.nowvell.com: Orchestrate_Server (rmiffts2ens. provo.novell.com: 1095, M1 versian: 2.0.1_§1007

| ®

6 On the Info/Groups tab, expand the Info section, then fill in the fields in the other subsections as

necessary.

IMPORTANT: In the Password field in the Personal Information subsection, the default password
is the one that you created for the administrator login when you installed the Orchestration
Server software. Be sure to change this default password to another password for this new user.
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7 Expand the Groups section and confirm that administrators is displayed in the User Group ID

list:

=

D) PlateSpin @rchestrate Development Client

File Edit Yiew Actions Provision ZServer Windows Help

a &

WM Hosts  Provisioner

=

Scheduler

@

Explorer | Poticy | &
Qrchestrate Servers ) UseriD: wmopl
o daz41_grid
0= o tszend _Grid
? [ tszen5 _Grid 3

Infa f Groups g Folicies | #F Healh Debugger r-D- Constraints f Facts |
o @Semer Admin

- @ Joks W info
o~ B Resourcas i
L % Fepositaries
s @ Users (33
o @9 administrators (1)

Show Inherited Fact Walues (From Policies & Croups)

[ User Information

D Fersanal Information

= wrnopl | i
e @ al @ [> lob Information
B sustem : . .
= wmopl ; D Accounting Infarmatian
+ @ Sévstem w B : [> lob Cortrol
Systerm g
b B Falicies D Quata Information

o & Public JDL Libraries
o B Computed Facts

o ﬁ Ewents i
o & Metrics Caunt: 2

=7 Croups

& User Group 1D

@ administrators

@

|Currem server is: [ 1szens _Grid 1szens. provo.novell.com: Orchestrate_Server (rmi/jt1sZens. provo.novell.com: 1099, [MI) versian: 2.0.1_§1007

If the administrators group is not listed, click Choose to add it.

8 Click File > Save to save the new user’s information.

9 Repeat Step 1 through Step 8 for each new VM operator login that you want to create.
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VM Client Documentation Quick

Index

This short index is designed to provide quick access to hard-to-find information in the Cloud Manager
VM Client Reference and Guide. Some index entries access other Cloud Manager guides for information

related to managing VMs.

An extensive index is not intended here, so most of the section titles that are visible on the Contents

page for this manual are not included.

Agent, Monitoring

Agent, Orchestration

Canceling a VM installation
Configuration Details dialog box
Configuration details tab

Orchestration Server Console

Discovered (#) group for host servers
Enabled check box in the orchestration Console
Error Log

Event logs

Event Log details tab

Filtering lists

Groups

Guest operating systems

Hosts details tab

Installing the VM Client

Locator pop-up

Login IDs

Logs

Migrating VMs

Moving VMs

Monitoring Agent

Monitoring details tab

Mouse-over information

Multiple VM operator logins
Orchestration Agent

Polling intervals for displaying new information
Progress bars

Provisioning adapter policies
Provisioning in the Orchestration Console
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PXE

Repositories, adding

Repositories, associating

Repositories, managing in the Server Console
Repositories, removing

Reset Perspective menu option

Saving changes

Searching: filtering lists; locating items in a list
Sorting

Summary details tab

Themes (skins)

Tool tips

Transparency

Version Information dialog box

Virtual Machines details tab

Virtualization host types

VM technologies and actions

VNC

Windows VM installation source

We encourage you to use the User Comment feature on the NetIQ Cloud Manager documentation
Web site (http://www.novell.com/documentation/cloudmanager2/) to help us keep this index up-to-
date and useful for you.

To use the feature, simply access this Index section (http://www.novell.com/documentation/
cloudmanager2/ncm2_vmclient/data/bj2pd1o) on the documentation Web site and suggest new
entries or corrections to existing entries in the User Comment field there.

Please include the following information:
¢ The new entry’s label and the URL to the section containing the related information.

The proper URL can be obtained by right-clicking on the Web page link to that section, saving it
to your operating system’s clipboard, then pasting it into the User Comment.

¢ The existing entry’s label and the correction for it.
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