DXMLBase Namespace

A Sandcastle Documented Class Library
DXMLBase Namespace

[Missing <summary> documentation for "N:DXMLBase"]

Classes
 | Class | Description
Public class | AtomCache |
Public class | ClassFilter |
Public class | DOMWriter |
Public class | DriverFilter |
Public class | DXMLUtil |
Public class | ExpandedQName |
Public class | LocalizedMessageSource |
Public class | Trace |
Public class | Trace_DOMWriter |
Public class | Trace_DOMWriterAttributeEntry |
Public class | Trace_DOMWriterElementEntry |
Public class | XdsDN |
Public class | XdsDNDNComponent |
Interfaces
 | Interface | Description
Public interface | IDriverShim |
Public interface | IMessageSource |
Public interface | IPublicationShim |
Public interface | ISubscriptionShim |
Public interface | ITrace |
Public interface | IXmlCommandProcessor |
Public interface | IXmlQueryProcessor |
Enumerations
 | Enumeration | Description
Public enumeration | XdsDNForm |
Public enumeration | XdsDNScope |


AtomCache Class

AtomCache Class

[Missing <summary> documentation for "T:DXMLBase.AtomCache"]

Inheritance Hierarchy
SystemObject
DXMLBaseAtomCache

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AtomCache
Public Class AtomCache
public ref class AtomCache
type AtomCache =  class end

The AtomCache type exposes the following members.

Constructors
 | Name | Description
Public method | AtomCache | Initializes a new instance of the AtomCache class
Public method | AtomCache(Int32) | Initializes a new instance of the AtomCache class
Public method | AtomCache(IDictionaryString, Int32, Int32) | Initializes a new instance of the AtomCache class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNumber |
Public method | getString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DXMLBase Namespace


AtomCache Constructor

AtomCache Constructor
Overload List
 | Name | Description
Public method | AtomCache | Initializes a new instance of the AtomCache class
Public method | AtomCache(Int32) | Initializes a new instance of the AtomCache class
Public method | AtomCache(IDictionaryString, Int32, Int32) | Initializes a new instance of the AtomCache class
Top
See Also

Reference

AtomCache Class
DXMLBase Namespace


AtomCache Constructor

AtomCache Constructor
Initializes a new instance of the AtomCache class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AtomCache()
Public Sub New
public:
AtomCache()
new : unit -> AtomCache
See Also

Reference

AtomCache Class
AtomCache Overload
DXMLBase Namespace


AtomCache Constructor (Int32)

AtomCache Constructor (Int32)
Initializes a new instance of the AtomCache class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AtomCache(
    int cacheSize
)
Public Sub New (
    cacheSize As Integer
)
public:
AtomCache(
    int cacheSize
)
new :
        cacheSize : int -> AtomCache

Parameters

cacheSize
Type: SystemInt32

[Missing <param name="cacheSize"/> documentation for "M:DXMLBase.AtomCache.#ctor(System.Int32)"]

See Also

Reference

AtomCache Class
AtomCache Overload
DXMLBase Namespace


AtomCache Constructor (IDictionary(String, Int32), Int32)

AtomCache Constructor (IDictionaryString, Int32, Int32)
Initializes a new instance of the AtomCache class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AtomCache(
    IDictionary<string, int> mapImpl,
    int cacheSize
)
Public Sub New (
    mapImpl As IDictionary(Of String, Integer),
    cacheSize As Integer
)
public:
AtomCache(
    IDictionary<String^, int>^ mapImpl,
    int cacheSize
)
new :
        mapImpl : IDictionary<string, int> *
        cacheSize : int -> AtomCache

Parameters

mapImpl
Type: System.Collections.GenericIDictionary String, Int32

[Missing <param name="mapImpl"/> documentation for "M:DXMLBase.AtomCache.#ctor(System.Collections.Generic.IDictionary{System.String,System.Int32},System.Int32)"]

cacheSize
Type: SystemInt32

[Missing <param name="cacheSize"/> documentation for "M:DXMLBase.AtomCache.#ctor(System.Collections.Generic.IDictionary{System.String,System.Int32},System.Int32)"]

See Also

Reference

AtomCache Class
AtomCache Overload
DXMLBase Namespace


AtomCache Methods

AtomCache Methods

The AtomCache type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNumber |
Public method | getString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtomCache Class
DXMLBase Namespace


AtomCache.getNumber Method

AtomCachegetNumber Method

[Missing <summary> documentation for "M:DXMLBase.AtomCache.getNumber(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int getNumber(
    string str
)
Public Overridable Function getNumber (
    str As String
) As Integer
public:
virtual int getNumber(
    String^ str
)
abstract getNumber :
        str : string -> int
override getNumber :
        str : string -> int

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:DXMLBase.AtomCache.getNumber(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.AtomCache.getNumber(System.String)"]

See Also

Reference

AtomCache Class
DXMLBase Namespace


AtomCache.getString Method

AtomCachegetString Method

[Missing <summary> documentation for "M:DXMLBase.AtomCache.getString(System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string getString(
    int number
)
Public Overridable Function getString (
    number As Integer
) As String
public:
virtual String^ getString(
    int number
)
abstract getString :
        number : int -> string
override getString :
        number : int -> string

Parameters

number
Type: SystemInt32

[Missing <param name="number"/> documentation for "M:DXMLBase.AtomCache.getString(System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.AtomCache.getString(System.Int32)"]

See Also

Reference

AtomCache Class
DXMLBase Namespace


ClassFilter Class

ClassFilter Class

[Missing <summary> documentation for "T:DXMLBase.ClassFilter"]

Inheritance Hierarchy
SystemObject
DXMLBaseClassFilter

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClassFilter
Public Class ClassFilter
public ref class ClassFilter
type ClassFilter =  class end

The ClassFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | passAttribute |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DXMLBase Namespace


ClassFilter Methods

ClassFilter Methods

The ClassFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | passAttribute |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClassFilter Class
DXMLBase Namespace


ClassFilter.passAttribute Method

ClassFilterpassAttribute Method

[Missing <summary> documentation for "M:DXMLBase.ClassFilter.passAttribute(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool passAttribute(
    string attributeName
)
Public Function passAttribute (
    attributeName As String
) As Boolean
public:
bool passAttribute(
    String^ attributeName
)
member passAttribute :
        attributeName : string -> bool

Parameters

attributeName
Type: SystemString

[Missing <param name="attributeName"/> documentation for "M:DXMLBase.ClassFilter.passAttribute(System.String)"]

Return Value

Type: Boolean
true if in filter, false otherwise
See Also

Reference

ClassFilter Class
DXMLBase Namespace


DOMWriter Class

DOMWriter Class

[Missing <summary> documentation for "T:DXMLBase.DOMWriter"]

Inheritance Hierarchy
SystemObject
DXMLBaseDOMWriter
DXMLBaseTrace_DOMWriter

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DOMWriter
Public Class DOMWriter
public ref class DOMWriter
type DOMWriter =  class end

The DOMWriter type exposes the following members.

Constructors
 | Name | Description
Public method | DOMWriter(XmlNode, TextWriter) | Initializes a new instance of the DOMWriter class
Public method | DOMWriter(XmlNode, StringBuilder) | Initializes a new instance of the DOMWriter class
Public method | DOMWriter(XmlNode, Stream, String) | Initializes a new instance of the DOMWriter class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | write | Serialize a DOM subtree as XML
Protected method | writeDTD |
Protected method | writeTree |
Top
Properties
 | Name | Description
Public property | BaseIndentLevel |
Public property | DoctypePublic |
Public property | DoctypeSystem |
Public property | Encoding |
Public property | Indent |
Public property | IndentString |
Public property | Standalone |
Public property | WriteDeclaration |
Top
See Also

Reference

DXMLBase Namespace


DOMWriter Constructor

DOMWriter Constructor
Overload List
 | Name | Description
Public method | DOMWriter(XmlNode, TextWriter) | Initializes a new instance of the DOMWriter class
Public method | DOMWriter(XmlNode, StringBuilder) | Initializes a new instance of the DOMWriter class
Public method | DOMWriter(XmlNode, Stream, String) | Initializes a new instance of the DOMWriter class
Top
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter Constructor (XmlNode, TextWriter)

DOMWriter Constructor (XmlNode, TextWriter)
Initializes a new instance of the DOMWriter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DOMWriter(
    XmlNode node,
    TextWriter output
)
Public Sub New (
    node As XmlNode,
    output As TextWriter
)
public:
DOMWriter(
    XmlNode^ node,
    TextWriter^ output
)
new :
        node : XmlNode *
        output : TextWriter -> DOMWriter

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.IO.TextWriter)"]

output
Type: System.IOTextWriter

[Missing <param name="output"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.IO.TextWriter)"]

See Also

Reference

DOMWriter Class
DOMWriter Overload
DXMLBase Namespace


DOMWriter Constructor (XmlNode, StringBuilder)

DOMWriter Constructor (XmlNode, StringBuilder)
Initializes a new instance of the DOMWriter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DOMWriter(
    XmlNode node,
    StringBuilder output
)
Public Sub New (
    node As XmlNode,
    output As StringBuilder
)
public:
DOMWriter(
    XmlNode^ node,
    StringBuilder^ output
)
new :
        node : XmlNode *
        output : StringBuilder -> DOMWriter

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.Text.StringBuilder)"]

output
Type: System.TextStringBuilder

[Missing <param name="output"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.Text.StringBuilder)"]

See Also

Reference

DOMWriter Class
DOMWriter Overload
DXMLBase Namespace


DOMWriter Constructor (XmlNode, Stream, String)

DOMWriter Constructor (XmlNode, Stream, String)
Initializes a new instance of the DOMWriter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DOMWriter(
    XmlNode node,
    Stream output,
    string encoding
)
Public Sub New (
    node As XmlNode,
    output As Stream,
    encoding As String
)
public:
DOMWriter(
    XmlNode^ node,
    Stream^ output,
    String^ encoding
)
new :
        node : XmlNode *
        output : Stream *
        encoding : string -> DOMWriter

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.IO.Stream,System.String)"]

output
Type: System.IOStream

[Missing <param name="output"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.IO.Stream,System.String)"]

encoding
Type: SystemString

[Missing <param name="encoding"/> documentation for "M:DXMLBase.DOMWriter.#ctor(System.Xml.XmlNode,System.IO.Stream,System.String)"]

See Also

Reference

DOMWriter Class
DOMWriter Overload
DXMLBase Namespace


DOMWriter Methods

DOMWriter Methods

The DOMWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | write | Serialize a DOM subtree as XML
Protected method | writeDTD |
Protected method | writeTree |
Top
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.write Method

DOMWriterwrite Method
Serialize a DOM subtree as XML

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void write()
Public Overridable Sub write
public:
virtual void write()
abstract write : unit -> unit
override write : unit -> unit
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.writeDTD Method

DOMWriterwriteDTD Method

[Missing <summary> documentation for "M:DXMLBase.DOMWriter.writeDTD(System.Xml.XmlDocument,System.Xml.XmlWriter)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void writeDTD(
    XmlDocument node,
    XmlWriter xWriter
)
Protected Overridable Sub writeDTD (
    node As XmlDocument,
    xWriter As XmlWriter
)
protected:
virtual void writeDTD(
    XmlDocument^ node,
    XmlWriter^ xWriter
)
abstract writeDTD :
        node : XmlDocument *
        xWriter : XmlWriter -> unit
override writeDTD :
        node : XmlDocument *
        xWriter : XmlWriter -> unit

Parameters

node
Type: System.XmlXmlDocument

[Missing <param name="node"/> documentation for "M:DXMLBase.DOMWriter.writeDTD(System.Xml.XmlDocument,System.Xml.XmlWriter)"]

xWriter
Type: System.XmlXmlWriter

[Missing <param name="xWriter"/> documentation for "M:DXMLBase.DOMWriter.writeDTD(System.Xml.XmlDocument,System.Xml.XmlWriter)"]

See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.writeTree Method

DOMWriterwriteTree Method

[Missing <summary> documentation for "M:DXMLBase.DOMWriter.writeTree(System.Xml.XmlNode,System.Xml.XmlWriter)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void writeTree(
    XmlNode node,
    XmlWriter xWriter
)
Protected Overridable Sub writeTree (
    node As XmlNode,
    xWriter As XmlWriter
)
protected:
virtual void writeTree(
    XmlNode^ node,
    XmlWriter^ xWriter
)
abstract writeTree :
        node : XmlNode *
        xWriter : XmlWriter -> unit
override writeTree :
        node : XmlNode *
        xWriter : XmlWriter -> unit

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.DOMWriter.writeTree(System.Xml.XmlNode,System.Xml.XmlWriter)"]

xWriter
Type: System.XmlXmlWriter

[Missing <param name="xWriter"/> documentation for "M:DXMLBase.DOMWriter.writeTree(System.Xml.XmlNode,System.Xml.XmlWriter)"]

See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter Properties

DOMWriter Properties

The DOMWriter type exposes the following members.

Properties
 | Name | Description
Public property | BaseIndentLevel |
Public property | DoctypePublic |
Public property | DoctypeSystem |
Public property | Encoding |
Public property | Indent |
Public property | IndentString |
Public property | Standalone |
Public property | WriteDeclaration |
Top
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.BaseIndentLevel Property

DOMWriterBaseIndentLevel Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.BaseIndentLevel"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BaseIndentLevel { set; }
Public Overridable WriteOnly Property BaseIndentLevel As Integer
    Set
public:
virtual property int BaseIndentLevel {
    void set (int value);
}
abstract BaseIndentLevel : int with set
override BaseIndentLevel : int with set

Property Value

Type: Int32
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.DoctypePublic Property

DOMWriterDoctypePublic Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.DoctypePublic"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DoctypePublic { get; set; }
Public Overridable Property DoctypePublic As String
    Get
    Set
public:
virtual property String^ DoctypePublic {
    String^ get ();
    void set (String^ value);
}
abstract DoctypePublic : string with get, set
override DoctypePublic : string with get, set

Property Value

Type: String
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.DoctypeSystem Property

DOMWriterDoctypeSystem Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.DoctypeSystem"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DoctypeSystem { get; set; }
Public Overridable Property DoctypeSystem As String
    Get
    Set
public:
virtual property String^ DoctypeSystem {
    String^ get ();
    void set (String^ value);
}
abstract DoctypeSystem : string with get, set
override DoctypeSystem : string with get, set

Property Value

Type: String
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.Encoding Property

DOMWriterEncoding Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.Encoding"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Encoding { get; set; }
Public Overridable Property Encoding As String
    Get
    Set
public:
virtual property String^ Encoding {
    String^ get ();
    void set (String^ value);
}
abstract Encoding : string with get, set
override Encoding : string with get, set

Property Value

Type: String
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.Indent Property

DOMWriterIndent Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.Indent"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Indent { get; set; }
Public Overridable Property Indent As Boolean
    Get
    Set
public:
virtual property bool Indent {
    bool get ();
    void set (bool value);
}
abstract Indent : bool with get, set
override Indent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.IndentString Property

DOMWriterIndentString Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.IndentString"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string IndentString { get; set; }
Public Overridable Property IndentString As String
    Get
    Set
public:
virtual property String^ IndentString {
    String^ get ();
    void set (String^ value);
}
abstract IndentString : string with get, set
override IndentString : string with get, set

Property Value

Type: String
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.Standalone Property

DOMWriterStandalone Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.Standalone"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Standalone { get; set; }
Public Overridable Property Standalone As Boolean
    Get
    Set
public:
virtual property bool Standalone {
    bool get ();
    void set (bool value);
}
abstract Standalone : bool with get, set
override Standalone : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DOMWriter.WriteDeclaration Property

DOMWriterWriteDeclaration Property

[Missing <summary> documentation for "P:DXMLBase.DOMWriter.WriteDeclaration"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool WriteDeclaration { get; set; }
Public Overridable Property WriteDeclaration As Boolean
    Get
    Set
public:
virtual property bool WriteDeclaration {
    bool get ();
    void set (bool value);
}
abstract WriteDeclaration : bool with get, set
override WriteDeclaration : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DOMWriter Class
DXMLBase Namespace


DriverFilter Class

DriverFilter Class

[Missing <summary> documentation for "T:DXMLBase.DriverFilter"]

Inheritance Hierarchy
SystemObject
DXMLBaseDriverFilter

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DriverFilter
Public Class DriverFilter
public ref class DriverFilter
type DriverFilter =  class end

The DriverFilter type exposes the following members.

Constructors
 | Name | Description
Public method | DriverFilter | Initializes a new instance of the DriverFilter class
Public method | DriverFilter(XmlElement) | Initializes a new instance of the DriverFilter class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getClassFilter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | passClass |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DXMLBase Namespace


DriverFilter Constructor

DriverFilter Constructor
Overload List
 | Name | Description
Public method | DriverFilter | Initializes a new instance of the DriverFilter class
Public method | DriverFilter(XmlElement) | Initializes a new instance of the DriverFilter class
Top
See Also

Reference

DriverFilter Class
DXMLBase Namespace


DriverFilter Constructor

DriverFilter Constructor
Initializes a new instance of the DriverFilter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DriverFilter()
Public Sub New
public:
DriverFilter()
new : unit -> DriverFilter
See Also

Reference

DriverFilter Class
DriverFilter Overload
DXMLBase Namespace


DriverFilter Constructor (XmlElement)

DriverFilter Constructor (XmlElement)
Initializes a new instance of the DriverFilter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DriverFilter(
    XmlElement filterElement
)
Public Sub New (
    filterElement As XmlElement
)
public:
DriverFilter(
    XmlElement^ filterElement
)
new :
        filterElement : XmlElement -> DriverFilter

Parameters

filterElement
Type: System.XmlXmlElement
The DOM element containing the filter information
See Also

Reference

DriverFilter Class
DriverFilter Overload
DXMLBase Namespace


DriverFilter Methods

DriverFilter Methods

The DriverFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getClassFilter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | passClass |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DriverFilter Class
DXMLBase Namespace


DriverFilter.getClassFilter Method

DriverFiltergetClassFilter Method

[Missing <summary> documentation for "M:DXMLBase.DriverFilter.getClassFilter(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClassFilter getClassFilter(
    string className
)
Public Function getClassFilter (
    className As String
) As ClassFilter
public:
ClassFilter^ getClassFilter(
    String^ className
)
member getClassFilter :
        className : string -> ClassFilter

Parameters

className
Type: SystemString

[Missing <param name="className"/> documentation for "M:DXMLBase.DriverFilter.getClassFilter(System.String)"]

Return Value

Type: ClassFilter
ClassFilter for the class name (null if it doesn't exist)
See Also

Reference

DriverFilter Class
DXMLBase Namespace


DriverFilter.passClass Method

DriverFilterpassClass Method

[Missing <summary> documentation for "M:DXMLBase.DriverFilter.passClass(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool passClass(
    string className
)
Public Function passClass (
    className As String
) As Boolean
public:
bool passClass(
    String^ className
)
member passClass :
        className : string -> bool

Parameters

className
Type: SystemString

[Missing <param name="className"/> documentation for "M:DXMLBase.DriverFilter.passClass(System.String)"]

Return Value

Type: Boolean
true if in filter, false otherwise
See Also

Reference

DriverFilter Class
DXMLBase Namespace


DXMLUtil Class

DXMLUtil Class

[Missing <summary> documentation for "T:DXMLBase.DXMLUtil"]

Inheritance Hierarchy
SystemObject
DXMLBaseDXMLUtil

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DXMLUtil
Public MustInherit Class DXMLUtil
public ref class DXMLUtil abstract
[<AbstractClassAttribute>]
type DXMLUtil =  class end

The DXMLUtil type exposes the following members.

Constructors
 | Name | Description
Protected method | DXMLUtil | Initializes a new instance of the DXMLUtil class
Top
Methods
 | Name | Description
 | ByteArraysEqual |
 | ByteArraysStartsWith |
 | CharArraysEqual |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DXMLBase Namespace


DXMLUtil Constructor

DXMLUtil Constructor
Initializes a new instance of the DXMLUtil class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected DXMLUtil()
Protected Sub New
protected:
DXMLUtil()
new : unit -> DXMLUtil
See Also

Reference

DXMLUtil Class
DXMLBase Namespace


DXMLUtil Methods

DXMLUtil Methods

The DXMLUtil type exposes the following members.

Methods
 | Name | Description
 | ByteArraysEqual |
 | ByteArraysStartsWith |
 | CharArraysEqual |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DXMLUtil Class
DXMLBase Namespace


DXMLUtil.ByteArraysEqual Method

DXMLUtilByteArraysEqual Method

[Missing <summary> documentation for "M:DXMLBase.DXMLUtil.ByteArraysEqual(System.Byte[],System.Byte[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ByteArraysEqual(
    byte[] a1,
    byte[] a2
)
Public Shared Function ByteArraysEqual (
    a1 As Byte(),
    a2 As Byte()
) As Boolean
public:
static bool ByteArraysEqual(
    array<unsigned char>^ a1,
    array<unsigned char>^ a2
)
static member ByteArraysEqual :
        a1 : byte[] *
        a2 : byte[] -> bool

Parameters

a1
Type: SystemByte

[Missing <param name="a1"/> documentation for "M:DXMLBase.DXMLUtil.ByteArraysEqual(System.Byte[],System.Byte[])"]

a2
Type: SystemByte

[Missing <param name="a2"/> documentation for "M:DXMLBase.DXMLUtil.ByteArraysEqual(System.Byte[],System.Byte[])"]

Return Value

Type: Boolean
true if the arrays are equal, false otherwise
See Also

Reference

DXMLUtil Class
DXMLBase Namespace


DXMLUtil.ByteArraysStartsWith Method

DXMLUtilByteArraysStartsWith Method

[Missing <summary> documentation for "M:DXMLBase.DXMLUtil.ByteArraysStartsWith(System.Byte[],System.Byte[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ByteArraysStartsWith(
    byte[] one,
    byte[] theother
)
Public Shared Function ByteArraysStartsWith (
    one As Byte(),
    theother As Byte()
) As Boolean
public:
static bool ByteArraysStartsWith(
    array<unsigned char>^ one,
    array<unsigned char>^ theother
)
static member ByteArraysStartsWith :
        one : byte[] *
        theother : byte[] -> bool

Parameters

one
Type: SystemByte

[Missing <param name="one"/> documentation for "M:DXMLBase.DXMLUtil.ByteArraysStartsWith(System.Byte[],System.Byte[])"]

theother
Type: SystemByte

[Missing <param name="theother"/> documentation for "M:DXMLBase.DXMLUtil.ByteArraysStartsWith(System.Byte[],System.Byte[])"]

Return Value

Type: Boolean
true if the one starts with theother, false otherwise
See Also

Reference

DXMLUtil Class
DXMLBase Namespace


DXMLUtil.CharArraysEqual Method

DXMLUtilCharArraysEqual Method

[Missing <summary> documentation for "M:DXMLBase.DXMLUtil.CharArraysEqual(System.Char[],System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CharArraysEqual(
    char[] a1,
    char[] a2
)
Public Shared Function CharArraysEqual (
    a1 As Char(),
    a2 As Char()
) As Boolean
public:
static bool CharArraysEqual(
    array<wchar_t>^ a1,
    array<wchar_t>^ a2
)
static member CharArraysEqual :
        a1 : char[] *
        a2 : char[] -> bool

Parameters

a1
Type: SystemChar

[Missing <param name="a1"/> documentation for "M:DXMLBase.DXMLUtil.CharArraysEqual(System.Char[],System.Char[])"]

a2
Type: SystemChar

[Missing <param name="a2"/> documentation for "M:DXMLBase.DXMLUtil.CharArraysEqual(System.Char[],System.Char[])"]

Return Value

Type: Boolean
true if the arrays are equal, false otherwise
See Also

Reference

DXMLUtil Class
DXMLBase Namespace


ExpandedQName Class

ExpandedQName Class

[Missing <summary> documentation for "T:DXMLBase.ExpandedQName"]

Inheritance Hierarchy
SystemObject
DXMLBaseExpandedQName

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpandedQName
Public Class ExpandedQName
public ref class ExpandedQName
type ExpandedQName =  class end

The ExpandedQName type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandedQName(XmlNode) | Initializes a new instance of the ExpandedQName class
Public method | ExpandedQName(String, String) | Initializes a new instance of the ExpandedQName class
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LocalName |
Public property | Uri |
Top
See Also

Reference

DXMLBase Namespace


ExpandedQName Constructor

ExpandedQName Constructor
Overload List
 | Name | Description
Public method | ExpandedQName(XmlNode) | Initializes a new instance of the ExpandedQName class
Public method | ExpandedQName(String, String) | Initializes a new instance of the ExpandedQName class
Top
See Also

Reference

ExpandedQName Class
DXMLBase Namespace


ExpandedQName Constructor (XmlNode)

ExpandedQName Constructor (XmlNode)
Initializes a new instance of the ExpandedQName class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpandedQName(
    XmlNode node
)
Public Sub New (
    node As XmlNode
)
public:
ExpandedQName(
    XmlNode^ node
)
new :
        node : XmlNode -> ExpandedQName

Parameters

node
Type: System.XmlXmlNode
XmlNode
See Also

Reference

ExpandedQName Class
ExpandedQName Overload
DXMLBase Namespace


ExpandedQName Constructor (String, String)

ExpandedQName Constructor (String, String)
Initializes a new instance of the ExpandedQName class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpandedQName(
    string uri,
    string localName
)
Public Sub New (
    uri As String,
    localName As String
)
public:
ExpandedQName(
    String^ uri,
    String^ localName
)
new :
        uri : string *
        localName : string -> ExpandedQName

Parameters

uri
Type: SystemString

[Missing <param name="uri"/> documentation for "M:DXMLBase.ExpandedQName.#ctor(System.String,System.String)"]

localName
Type: SystemString
local name
See Also

Reference

ExpandedQName Class
ExpandedQName Overload
DXMLBase Namespace


ExpandedQName Methods

ExpandedQName Methods

The ExpandedQName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExpandedQName Class
DXMLBase Namespace


ExpandedQName.Equals Method

ExpandedQNameEquals Method

[Missing <summary> documentation for "M:DXMLBase.ExpandedQName.Equals(System.Object)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:DXMLBase.ExpandedQName.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.ExpandedQName.Equals(System.Object)"]

See Also

Reference

ExpandedQName Class
DXMLBase Namespace


ExpandedQName.GetHashCode Method

ExpandedQNameGetHashCode Method

[Missing <summary> documentation for "M:DXMLBase.ExpandedQName.GetHashCode"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.ExpandedQName.GetHashCode"]

See Also

Reference

ExpandedQName Class
DXMLBase Namespace


ExpandedQName Properties

ExpandedQName Properties

The ExpandedQName type exposes the following members.

Properties
 | Name | Description
Public property | LocalName |
Public property | Uri |
Top
See Also

Reference

ExpandedQName Class
DXMLBase Namespace


ExpandedQName.LocalName Property

ExpandedQNameLocalName Property

[Missing <summary> documentation for "P:DXMLBase.ExpandedQName.LocalName"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LocalName { get; }
Public ReadOnly Property LocalName As String
    Get
public:
property String^ LocalName {
    String^ get ();
}
member LocalName : string with get

Property Value

Type: String
See Also

Reference

ExpandedQName Class
DXMLBase Namespace


ExpandedQName.Uri Property

ExpandedQNameUri Property

[Missing <summary> documentation for "P:DXMLBase.ExpandedQName.Uri"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Uri { get; }
Public ReadOnly Property Uri As String
    Get
public:
property String^ Uri {
    String^ get ();
}
member Uri : string with get

Property Value

Type: String
See Also

Reference

ExpandedQName Class
DXMLBase Namespace


IDriverShim Interface

IDriverShim Interface

[Missing <summary> documentation for "T:DXMLBase.IDriverShim"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDriverShim
Public Interface IDriverShim
public interface class IDriverShim
type IDriverShim =  interface end

The IDriverShim type exposes the following members.

Methods
 | Name | Description
Public method | getPublicationShim |
Public method | getSchema |
Public method | getSubscriptionShim |
Public method | init |
Public method | shutdown |
Top
See Also

Reference

DXMLBase Namespace
IPublicationShim


IDriverShim Methods

IDriverShim Methods

The IDriverShim type exposes the following members.

Methods
 | Name | Description
Public method | getPublicationShim |
Public method | getSchema |
Public method | getSubscriptionShim |
Public method | init |
Public method | shutdown |
Top
See Also

Reference

IDriverShim Interface
DXMLBase Namespace


IDriverShim.getPublicationShim Method

IDriverShimgetPublicationShim Method

[Missing <summary> documentation for "M:DXMLBase.IDriverShim.getPublicationShim"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPublicationShim getPublicationShim()
Function getPublicationShim As IPublicationShim
IPublicationShim^ getPublicationShim()
abstract getPublicationShim : unit -> IPublicationShim

Return Value

Type: IPublicationShim
the shim's implementation of IPublicationShim
See Also

Reference

IDriverShim Interface
DXMLBase Namespace


IDriverShim.getSchema Method

IDriverShimgetSchema Method

[Missing <summary> documentation for "M:DXMLBase.IDriverShim.getSchema(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument getSchema(
    XmlDocument initParameters
)
Function getSchema (
    initParameters As XmlDocument
) As XmlDocument
XmlDocument^ getSchema(
    XmlDocument^ initParameters
)
abstract getSchema :
        initParameters : XmlDocument -> XmlDocument

Parameters

initParameters
Type: System.XmlXmlDocument

[Missing <param name="initParameters"/> documentation for "M:DXMLBase.IDriverShim.getSchema(System.Xml.XmlDocument)"]

Return Value

Type: XmlDocument
an XML document containing the application schema data, or an error status return if no schema available
See Also

Reference

IDriverShim Interface
DXMLBase Namespace


IDriverShim.getSubscriptionShim Method

IDriverShimgetSubscriptionShim Method

[Missing <summary> documentation for "M:DXMLBase.IDriverShim.getSubscriptionShim"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISubscriptionShim getSubscriptionShim()
Function getSubscriptionShim As ISubscriptionShim
ISubscriptionShim^ getSubscriptionShim()
abstract getSubscriptionShim : unit -> ISubscriptionShim

Return Value

Type: ISubscriptionShim
the shim's implementation of ISubscriptionShim
See Also

Reference

IDriverShim Interface
DXMLBase Namespace


IDriverShim.init Method

IDriverShiminit Method

[Missing <summary> documentation for "M:DXMLBase.IDriverShim.init(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument init(
    XmlDocument initParameters
)
Function init (
    initParameters As XmlDocument
) As XmlDocument
XmlDocument^ init(
    XmlDocument^ initParameters
)
abstract init :
        initParameters : XmlDocument -> XmlDocument

Parameters

initParameters
Type: System.XmlXmlDocument

[Missing <param name="initParameters"/> documentation for "M:DXMLBase.IDriverShim.init(System.Xml.XmlDocument)"]

Return Value

Type: XmlDocument
null or an XML document indicating the result of the initialization operation
See Also

Reference

IDriverShim Interface
DXMLBase Namespace


IDriverShim.shutdown Method

IDriverShimshutdown Method

[Missing <summary> documentation for "M:DXMLBase.IDriverShim.shutdown(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument shutdown(
    XmlDocument reason
)
Function shutdown (
    reason As XmlDocument
) As XmlDocument
XmlDocument^ shutdown(
    XmlDocument^ reason
)
abstract shutdown :
        reason : XmlDocument -> XmlDocument

Parameters

reason
Type: System.XmlXmlDocument

[Missing <param name="reason"/> documentation for "M:DXMLBase.IDriverShim.shutdown(System.Xml.XmlDocument)"]

Return Value

Type: XmlDocument
null or an XML document containing the result of the shutting down
See Also

Reference

IDriverShim Interface
DXMLBase Namespace


IMessageSource Interface

IMessageSource Interface

[Missing <summary> documentation for "T:DXMLBase.IMessageSource"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMessageSource
Public Interface IMessageSource
public interface class IMessageSource
type IMessageSource =  interface end

The IMessageSource type exposes the following members.

Methods
 | Name | Description
Public method | getMessage |
Top
See Also

Reference

DXMLBase Namespace


IMessageSource Methods

IMessageSource Methods

The IMessageSource type exposes the following members.

Methods
 | Name | Description
Public method | getMessage |
Top
See Also

Reference

IMessageSource Interface
DXMLBase Namespace


IMessageSource.getMessage Method

IMessageSourcegetMessage Method

[Missing <summary> documentation for "M:DXMLBase.IMessageSource.getMessage(System.String,System.Object[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string getMessage(
    string msgID,
    Object[] parms
)
Function getMessage (
    msgID As String,
    parms As Object()
) As String
String^ getMessage(
    String^ msgID,
    array<Object^>^ parms
)
abstract getMessage :
        msgID : string *
        parms : Object[] -> string

Parameters

msgID
Type: SystemString

[Missing <param name="msgID"/> documentation for "M:DXMLBase.IMessageSource.getMessage(System.String,System.Object[])"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.IMessageSource.getMessage(System.String,System.Object[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.IMessageSource.getMessage(System.String,System.Object[])"]

See Also

Reference

IMessageSource Interface
DXMLBase Namespace


IPublicationShim Interface

IPublicationShim Interface

[Missing <summary> documentation for "T:DXMLBase.IPublicationShim"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPublicationShim
Public Interface IPublicationShim
public interface class IPublicationShim
type IPublicationShim =  interface end

The IPublicationShim type exposes the following members.

Methods
 | Name | Description
Public method | init |
Public method | start |
Top
See Also

Reference

DXMLBase Namespace


IPublicationShim Methods

IPublicationShim Methods

The IPublicationShim type exposes the following members.

Methods
 | Name | Description
Public method | init |
Public method | start |
Top
See Also

Reference

IPublicationShim Interface
DXMLBase Namespace


IPublicationShim.init Method

IPublicationShiminit Method

[Missing <summary> documentation for "M:DXMLBase.IPublicationShim.init(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument init(
    XmlDocument initParameters
)
Function init (
    initParameters As XmlDocument
) As XmlDocument
XmlDocument^ init(
    XmlDocument^ initParameters
)
abstract init :
        initParameters : XmlDocument -> XmlDocument

Parameters

initParameters
Type: System.XmlXmlDocument

[Missing <param name="initParameters"/> documentation for "M:DXMLBase.IPublicationShim.init(System.Xml.XmlDocument)"]

Return Value

Type: XmlDocument
null or an XML document indicating the result of the initialization operation
See Also

Reference

IPublicationShim Interface
DXMLBase Namespace


IPublicationShim.start Method

IPublicationShimstart Method

[Missing <summary> documentation for "M:DXMLBase.IPublicationShim.start(DXMLBase.IXmlCommandProcessor)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument start(
    IXmlCommandProcessor execute
)
Function start (
    execute As IXmlCommandProcessor
) As XmlDocument
XmlDocument^ start(
    IXmlCommandProcessor^ execute
)
abstract start :
        execute : IXmlCommandProcessor -> XmlDocument

Parameters

execute
Type: DXMLBaseIXmlCommandProcessor

[Missing <param name="execute"/> documentation for "M:DXMLBase.IPublicationShim.start(DXMLBase.IXmlCommandProcessor)"]

Return Value

Type: XmlDocument

[Missing <returns> documentation for "M:DXMLBase.IPublicationShim.start(DXMLBase.IXmlCommandProcessor)"]

See Also

Reference

IPublicationShim Interface
DXMLBase Namespace
IDriverShim.shutdown


ISubscriptionShim Interface

ISubscriptionShim Interface

[Missing <summary> documentation for "T:DXMLBase.ISubscriptionShim"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISubscriptionShim
Public Interface ISubscriptionShim
public interface class ISubscriptionShim
type ISubscriptionShim =  interface end

The ISubscriptionShim type exposes the following members.

Methods
 | Name | Description
Public method | execute |
Public method | init |
Top
See Also

Reference

DXMLBase Namespace


ISubscriptionShim Methods

ISubscriptionShim Methods

The ISubscriptionShim type exposes the following members.

Methods
 | Name | Description
Public method | execute |
Public method | init |
Top
See Also

Reference

ISubscriptionShim Interface
DXMLBase Namespace


ISubscriptionShim.execute Method

ISubscriptionShimexecute Method

[Missing <summary> documentation for "M:DXMLBase.ISubscriptionShim.execute(System.Xml.XmlDocument,DXMLBase.IXmlQueryProcessor)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument execute(
    XmlDocument doc,
    IXmlQueryProcessor query
)
Function execute (
    doc As XmlDocument,
    query As IXmlQueryProcessor
) As XmlDocument
XmlDocument^ execute(
    XmlDocument^ doc,
    IXmlQueryProcessor^ query
)
abstract execute :
        doc : XmlDocument *
        query : IXmlQueryProcessor -> XmlDocument

Parameters

doc
Type: System.XmlXmlDocument

[Missing <param name="doc"/> documentation for "M:DXMLBase.ISubscriptionShim.execute(System.Xml.XmlDocument,DXMLBase.IXmlQueryProcessor)"]

query
Type: DXMLBaseIXmlQueryProcessor

[Missing <param name="query"/> documentation for "M:DXMLBase.ISubscriptionShim.execute(System.Xml.XmlDocument,DXMLBase.IXmlQueryProcessor)"]

Return Value

Type: XmlDocument
an XML output document containing the results of processing the commands (null is allowed but discouraged)
See Also

Reference

ISubscriptionShim Interface
DXMLBase Namespace


ISubscriptionShim.init Method

ISubscriptionShiminit Method

[Missing <summary> documentation for "M:DXMLBase.ISubscriptionShim.init(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument init(
    XmlDocument initParameters
)
Function init (
    initParameters As XmlDocument
) As XmlDocument
XmlDocument^ init(
    XmlDocument^ initParameters
)
abstract init :
        initParameters : XmlDocument -> XmlDocument

Parameters

initParameters
Type: System.XmlXmlDocument

[Missing <param name="initParameters"/> documentation for "M:DXMLBase.ISubscriptionShim.init(System.Xml.XmlDocument)"]

Return Value

Type: XmlDocument
null or an XML document indicating the result of the initialization operation
See Also

Reference

ISubscriptionShim Interface
DXMLBase Namespace


ITrace Interface

ITrace Interface

[Missing <summary> documentation for "T:DXMLBase.ITrace"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITrace
Public Interface ITrace
public interface class ITrace
type ITrace =  interface end

The ITrace type exposes the following members.

Methods
 | Name | Description
Public method | trace(Int32, String) |
Public method | trace(Int32, XmlDocument) |
Top
Properties
 | Name | Description
Public property | Level |
Top
See Also

Reference

DXMLBase Namespace


ITrace Methods

ITrace Methods
Methods
 | Name | Description
Public method | trace(Int32, String) |
Public method | trace(Int32, XmlDocument) |
Top
See Also

Reference

ITrace Interface
DXMLBase Namespace


ITrace.trace Method

ITracetrace Method
Overload List
 | Name | Description
Public method | trace(Int32, String) |
Public method | trace(Int32, XmlDocument) |
Top
See Also

Reference

ITrace Interface
DXMLBase Namespace


ITrace.trace Method (Int32, String)

ITracetrace Method (Int32, String)

[Missing <summary> documentation for "M:DXMLBase.ITrace.trace(System.Int32,System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void trace(
    int level,
    string message
)
Sub trace (
    level As Integer,
    message As String
)
void trace(
    int level,
    String^ message
)
abstract trace :
        level : int *
        message : string -> unit

Parameters

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.ITrace.trace(System.Int32,System.String)"]

message
Type: SystemString
trace message
See Also

Reference

ITrace Interface
trace Overload
DXMLBase Namespace


ITrace.trace Method (Int32, XmlDocument)

ITracetrace Method (Int32, XmlDocument)

[Missing <summary> documentation for "M:DXMLBase.ITrace.trace(System.Int32,System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void trace(
    int level,
    XmlDocument document
)
Sub trace (
    level As Integer,
    document As XmlDocument
)
void trace(
    int level,
    XmlDocument^ document
)
abstract trace :
        level : int *
        document : XmlDocument -> unit

Parameters

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.ITrace.trace(System.Int32,System.Xml.XmlDocument)"]

document
Type: System.XmlXmlDocument
XML document to trace
See Also

Reference

ITrace Interface
trace Overload
DXMLBase Namespace


ITrace Properties

ITrace Properties

The ITrace type exposes the following members.

Properties
 | Name | Description
Public property | Level |
Top
See Also

Reference

ITrace Interface
DXMLBase Namespace


ITrace.Level Property

ITraceLevel Property

[Missing <summary> documentation for "P:DXMLBase.ITrace.Level"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Level { get; }
ReadOnly Property Level As Integer
    Get
property int Level {
    int get ();
}
abstract Level : int with get

Property Value

Type: Int32
See Also

Reference

ITrace Interface
DXMLBase Namespace


IXmlCommandProcessor Interface

IXmlCommandProcessor Interface

[Missing <summary> documentation for "T:DXMLBase.IXmlCommandProcessor"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IXmlCommandProcessor
Public Interface IXmlCommandProcessor
public interface class IXmlCommandProcessor
type IXmlCommandProcessor =  interface end

The IXmlCommandProcessor type exposes the following members.

Methods
 | Name | Description
Public method | execute |
Top
See Also

Reference

DXMLBase Namespace
IPublicationShimstart(IXmlCommandProcessor)


IXmlCommandProcessor Methods

IXmlCommandProcessor Methods

The IXmlCommandProcessor type exposes the following members.

Methods
 | Name | Description
Public method | execute |
Top
See Also

Reference

IXmlCommandProcessor Interface
DXMLBase Namespace


IXmlCommandProcessor.execute Method

IXmlCommandProcessorexecute Method

[Missing <summary> documentation for "M:DXMLBase.IXmlCommandProcessor.execute(System.Xml.XmlDocument,DXMLBase.IXmlQueryProcessor)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument execute(
    XmlDocument doc,
    IXmlQueryProcessor query
)
Function execute (
    doc As XmlDocument,
    query As IXmlQueryProcessor
) As XmlDocument
XmlDocument^ execute(
    XmlDocument^ doc,
    IXmlQueryProcessor^ query
)
abstract execute :
        doc : XmlDocument *
        query : IXmlQueryProcessor -> XmlDocument

Parameters

doc
Type: System.XmlXmlDocument

[Missing <param name="doc"/> documentation for "M:DXMLBase.IXmlCommandProcessor.execute(System.Xml.XmlDocument,DXMLBase.IXmlQueryProcessor)"]

query
Type: DXMLBaseIXmlQueryProcessor

[Missing <param name="query"/> documentation for "M:DXMLBase.IXmlCommandProcessor.execute(System.Xml.XmlDocument,DXMLBase.IXmlQueryProcessor)"]

Return Value

Type: XmlDocument
an XML document that contains the result of executing the XML-encoded command
See Also

Reference

IXmlCommandProcessor Interface
DXMLBase Namespace


IXmlQueryProcessor Interface

IXmlQueryProcessor Interface

[Missing <summary> documentation for "T:DXMLBase.IXmlQueryProcessor"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IXmlQueryProcessor
Public Interface IXmlQueryProcessor
public interface class IXmlQueryProcessor
type IXmlQueryProcessor =  interface end

The IXmlQueryProcessor type exposes the following members.

Methods
 | Name | Description
Public method | query |
Top
See Also

Reference

DXMLBase Namespace


IXmlQueryProcessor Methods

IXmlQueryProcessor Methods

The IXmlQueryProcessor type exposes the following members.

Methods
 | Name | Description
Public method | query |
Top
See Also

Reference

IXmlQueryProcessor Interface
DXMLBase Namespace


IXmlQueryProcessor.query Method

IXmlQueryProcessorquery Method

[Missing <summary> documentation for "M:DXMLBase.IXmlQueryProcessor.query(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlDocument query(
    XmlDocument doc
)
Function query (
    doc As XmlDocument
) As XmlDocument
XmlDocument^ query(
    XmlDocument^ doc
)
abstract query :
        doc : XmlDocument -> XmlDocument

Parameters

doc
Type: System.XmlXmlDocument

[Missing <param name="doc"/> documentation for "M:DXMLBase.IXmlQueryProcessor.query(System.Xml.XmlDocument)"]

Return Value

Type: XmlDocument
the results of the query
See Also

Reference

IXmlQueryProcessor Interface
DXMLBase Namespace


LocalizedMessageSource Class

LocalizedMessageSource Class

[Missing <summary> documentation for "T:DXMLBase.LocalizedMessageSource"]

Inheritance Hierarchy
SystemObject
DXMLBaseLocalizedMessageSource

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocalizedMessageSource : IMessageSource
Public Class LocalizedMessageSource
    Implements IMessageSource
public ref class LocalizedMessageSource : IMessageSource
type LocalizedMessageSource =
    class
        interface IMessageSource
    end

The LocalizedMessageSource type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizedMessageSource | Initializes a new instance of the LocalizedMessageSource class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getMessage |
Public method | getMessageString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | bundle | ResourceBundle from which to obtain message strings.
Protected field | parent |
Top
See Also

Reference

DXMLBase Namespace


LocalizedMessageSource Constructor

LocalizedMessageSource Constructor
Initializes a new instance of the LocalizedMessageSource class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalizedMessageSource(
    ResourceManager bundle
)
Public Sub New (
    bundle As ResourceManager
)
public:
LocalizedMessageSource(
    ResourceManager^ bundle
)
new :
        bundle : ResourceManager -> LocalizedMessageSource

Parameters

bundle
Type: System.ResourcesResourceManager

[Missing <param name="bundle"/> documentation for "M:DXMLBase.LocalizedMessageSource.#ctor(System.Resources.ResourceManager)"]

See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


LocalizedMessageSource Fields

LocalizedMessageSource Fields

The LocalizedMessageSource type exposes the following members.

Fields
 | Name | Description
Protected field | bundle | ResourceBundle from which to obtain message strings.
Protected field | parent |
Top
See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


LocalizedMessageSource.bundle Field

LocalizedMessageSourcebundle Field
ResourceBundle from which to obtain message strings.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ResourceManager bundle
Protected bundle As ResourceManager
protected:
ResourceManager^ bundle
val mutable bundle: ResourceManager

Field Value

Type: ResourceManager
See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


LocalizedMessageSource.parent Field

LocalizedMessageSourceparent Field

[Missing <summary> documentation for "F:DXMLBase.LocalizedMessageSource.parent"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected LocalizedMessageSource parent
Protected parent As LocalizedMessageSource
protected:
LocalizedMessageSource^ parent
val mutable parent: LocalizedMessageSource

Field Value

Type: LocalizedMessageSource
See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


LocalizedMessageSource Methods

LocalizedMessageSource Methods

The LocalizedMessageSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getMessage |
Public method | getMessageString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


LocalizedMessageSource.getMessage Method

LocalizedMessageSourcegetMessage Method

[Missing <summary> documentation for "M:DXMLBase.LocalizedMessageSource.getMessage(System.String,System.Object[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string getMessage(
    string msgID,
    Object[] parms
)
Public Overridable Function getMessage (
    msgID As String,
    parms As Object()
) As String
public:
virtual String^ getMessage(
    String^ msgID,
    array<Object^>^ parms
)
abstract getMessage :
        msgID : string *
        parms : Object[] -> string
override getMessage :
        msgID : string *
        parms : Object[] -> string

Parameters

msgID
Type: SystemString

[Missing <param name="msgID"/> documentation for "M:DXMLBase.LocalizedMessageSource.getMessage(System.String,System.Object[])"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.LocalizedMessageSource.getMessage(System.String,System.Object[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.LocalizedMessageSource.getMessage(System.String,System.Object[])"]

Implements

IMessageSourcegetMessage(String, Object)
See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


LocalizedMessageSource.getMessageString Method

LocalizedMessageSourcegetMessageString Method

[Missing <summary> documentation for "M:DXMLBase.LocalizedMessageSource.getMessageString(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string getMessageString(
    string msgID
)
Public Overridable Function getMessageString (
    msgID As String
) As String
public:
virtual String^ getMessageString(
    String^ msgID
)
abstract getMessageString :
        msgID : string -> string
override getMessageString :
        msgID : string -> string

Parameters

msgID
Type: SystemString

[Missing <param name="msgID"/> documentation for "M:DXMLBase.LocalizedMessageSource.getMessageString(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.LocalizedMessageSource.getMessageString(System.String)"]

See Also

Reference

LocalizedMessageSource Class
DXMLBase Namespace


Trace Class

Trace Class

[Missing <summary> documentation for "T:DXMLBase.Trace"]

Inheritance Hierarchy
SystemObject
DXMLBaseTrace

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Trace
Public Class Trace
public ref class Trace
type Trace =  class end

The Trace type exposes the following members.

Constructors
 | Name | Description
Public method | Trace | Initializes a new instance of the Trace class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | popIndent |
Public method | pushIndent |
 | registerImpl |
Public method | resetIndent | Reset the indent level to 0 regardless of any pushed levels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | trace(String) |
Public method | trace(XmlDocument) |
Public method | trace(String, IMessageSource) |
Public method | trace(String, Int32) |
Public method | trace(XmlDocument, Int32) |
Public method | trace(String, IMessageSource, Int32) |
Public method | trace(String, IMessageSource, Object) |
Public method | trace(String, IMessageSource, Object) |
Public method | trace(String, IMessageSource, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object) |
Public method | trace(String, IMessageSource, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object, Object) |
Public method | trace(String, IMessageSource, Object, Object, Object, Int32) |
Top
Fields
Name | Description
DEFAULT_TRACE |
NO_TRACE | Constant corresponding to no trace messages level
XML_TRACE |
Top
Properties
 | Name | Description
Public property | TraceLevel |
Top
See Also

Reference

DXMLBase Namespace


Trace Constructor

Trace Constructor
Initializes a new instance of the Trace class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Trace(
    string identifier
)
Public Sub New (
    identifier As String
)
public:
Trace(
    String^ identifier
)
new :
        identifier : string -> Trace

Parameters

identifier
Type: SystemString
A String that is prepended to trace messages for identification purposes
See Also

Reference

Trace Class
DXMLBase Namespace


Trace Fields

Trace Fields

The Trace type exposes the following members.

Fields
Name | Description
DEFAULT_TRACE |
NO_TRACE | Constant corresponding to no trace messages level
XML_TRACE |
Top
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.DEFAULT_TRACE Field

TraceDEFAULT_TRACE Field

[Missing <summary> documentation for "F:DXMLBase.Trace.DEFAULT_TRACE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DEFAULT_TRACE
Public Const DEFAULT_TRACE As Integer
public:
literal int DEFAULT_TRACE
static val mutable DEFAULT_TRACE: int

Field Value

Type: Int32
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.NO_TRACE Field

TraceNO_TRACE Field
Constant corresponding to no trace messages level

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int NO_TRACE
Public Const NO_TRACE As Integer
public:
literal int NO_TRACE
static val mutable NO_TRACE: int

Field Value

Type: Int32
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.XML_TRACE Field

TraceXML_TRACE Field

[Missing <summary> documentation for "F:DXMLBase.Trace.XML_TRACE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int XML_TRACE
Public Const XML_TRACE As Integer
public:
literal int XML_TRACE
static val mutable XML_TRACE: int

Field Value

Type: Int32
See Also

Reference

Trace Class
DXMLBase Namespace


Trace Methods

Trace Methods

The Trace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | popIndent |
Public method | pushIndent |
 | registerImpl |
Public method | resetIndent | Reset the indent level to 0 regardless of any pushed levels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | trace(String) |
Public method | trace(XmlDocument) |
Public method | trace(String, IMessageSource) |
Public method | trace(String, Int32) |
Public method | trace(XmlDocument, Int32) |
Public method | trace(String, IMessageSource, Int32) |
Public method | trace(String, IMessageSource, Object) |
Public method | trace(String, IMessageSource, Object) |
Public method | trace(String, IMessageSource, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object) |
Public method | trace(String, IMessageSource, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object, Object) |
Public method | trace(String, IMessageSource, Object, Object, Object, Int32) |
Top
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.popIndent Method

TracepopIndent Method

[Missing <summary> documentation for "M:DXMLBase.Trace.popIndent"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void popIndent()
Public Overridable Sub popIndent
public:
virtual void popIndent()
abstract popIndent : unit -> unit
override popIndent : unit -> unit
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.pushIndent Method

TracepushIndent Method

[Missing <summary> documentation for "M:DXMLBase.Trace.pushIndent(System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void pushIndent(
    int tabCount
)
Public Overridable Sub pushIndent (
    tabCount As Integer
)
public:
virtual void pushIndent(
    int tabCount
)
abstract pushIndent :
        tabCount : int -> unit
override pushIndent :
        tabCount : int -> unit

Parameters

tabCount
Type: SystemInt32

[Missing <param name="tabCount"/> documentation for "M:DXMLBase.Trace.pushIndent(System.Int32)"]

See Also

Reference

Trace Class
DXMLBase Namespace


Trace.registerImpl Method

TraceregisterImpl Method

[Missing <summary> documentation for "M:DXMLBase.Trace.registerImpl(System.Type,System.Double)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void registerImpl(
    Type implementation,
    double priority
)
Public Shared Sub registerImpl (
    implementation As Type,
    priority As Double
)
public:
static void registerImpl(
    Type^ implementation,
    double priority
)
static member registerImpl :
        implementation : Type *
        priority : float -> unit

Parameters

implementation
Type: SystemType

[Missing <param name="implementation"/> documentation for "M:DXMLBase.Trace.registerImpl(System.Type,System.Double)"]

priority
Type: SystemDouble

[Missing <param name="priority"/> documentation for "M:DXMLBase.Trace.registerImpl(System.Type,System.Double)"]

See Also

Reference

Trace Class
DXMLBase Namespace


Trace.resetIndent Method

TraceresetIndent Method
Reset the indent level to 0 regardless of any pushed levels

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void resetIndent()
Public Overridable Sub resetIndent
public:
virtual void resetIndent()
abstract resetIndent : unit -> unit
override resetIndent : unit -> unit
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.trace Method

Tracetrace Method
Overload List
 | Name | Description
Public method | trace(String) |
Public method | trace(XmlDocument) |
Public method | trace(String, IMessageSource) |
Public method | trace(String, Int32) |
Public method | trace(XmlDocument, Int32) |
Public method | trace(String, IMessageSource, Int32) |
Public method | trace(String, IMessageSource, Object) |
Public method | trace(String, IMessageSource, Object) |
Public method | trace(String, IMessageSource, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object) |
Public method | trace(String, IMessageSource, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object, Int32) |
Public method | trace(String, IMessageSource, Object, Object, Object) |
Public method | trace(String, IMessageSource, Object, Object, Object, Int32) |
Top
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.trace Method (String)

Tracetrace Method (String)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string message
)
Public Overridable Sub trace (
    message As String
)
public:
virtual void trace(
    String^ message
)
abstract trace :
        message : string -> unit
override trace :
        message : string -> unit

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Trace.trace(System.String)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (XmlDocument)

Tracetrace Method (XmlDocument)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.Xml.XmlDocument)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    XmlDocument document
)
Public Overridable Sub trace (
    document As XmlDocument
)
public:
virtual void trace(
    XmlDocument^ document
)
abstract trace :
        document : XmlDocument -> unit
override trace :
        document : XmlDocument -> unit

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:DXMLBase.Trace.trace(System.Xml.XmlDocument)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource)

Tracetrace Method (String, IMessageSource)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, Int32)

Tracetrace Method (String, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string message,
    int level
)
Public Overridable Sub trace (
    message As String,
    level As Integer
)
public:
virtual void trace(
    String^ message,
    int level
)
abstract trace :
        message : string *
        level : int -> unit
override trace :
        message : string *
        level : int -> unit

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Trace.trace(System.String,System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.String,System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (XmlDocument, Int32)

Tracetrace Method (XmlDocument, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.Xml.XmlDocument,System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    XmlDocument document,
    int level
)
Public Overridable Sub trace (
    document As XmlDocument,
    level As Integer
)
public:
virtual void trace(
    XmlDocument^ document,
    int level
)
abstract trace :
        document : XmlDocument *
        level : int -> unit
override trace :
        document : XmlDocument *
        level : int -> unit

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:DXMLBase.Trace.trace(System.Xml.XmlDocument,System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.Xml.XmlDocument,System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Int32)

Tracetrace Method (String, IMessageSource, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string msgID,
    IMessageSource messageSource,
    int level
)
Public Overridable Sub trace (
    msgID As String,
    messageSource As IMessageSource,
    level As Integer
)
public:
virtual void trace(
    String^ msgID,
    IMessageSource^ messageSource,
    int level
)
abstract trace :
        msgID : string *
        messageSource : IMessageSource *
        level : int -> unit
override trace :
        msgID : string *
        messageSource : IMessageSource *
        level : int -> unit

Parameters

msgID
Type: SystemString

[Missing <param name="msgID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Int32)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object)

Tracetrace Method (String, IMessageSource, Object)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object parm1
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parm1 As Object
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    Object^ parm1
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object)"]

parm1
Type: SystemObject

[Missing <param name="parm1"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object[])

Tracetrace Method (String, IMessageSource, Object)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object[] parms
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parms As Object()
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    array<Object^>^ parms
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parms : Object[] -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parms : Object[] -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[])"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[])"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[])"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object, Int32)

Tracetrace Method (String, IMessageSource, Object, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object parm1,
    int level
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parm1 As Object,
    level As Integer
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    Object^ parm1,
    int level
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        level : int -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        level : int -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Int32)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Int32)"]

parm1
Type: SystemObject

[Missing <param name="parm1"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object, Object)

Tracetrace Method (String, IMessageSource, Object, Object)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object parm1,
    Object parm2
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parm1 As Object,
    parm2 As Object
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    Object^ parm1,
    Object^ parm2
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object)"]

parm1
Type: SystemObject

[Missing <param name="parm1"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object)"]

parm2
Type: SystemObject

[Missing <param name="parm2"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object[], Int32)

Tracetrace Method (String, IMessageSource, Object, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[],System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object[] parms,
    int level
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parms As Object(),
    level As Integer
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    array<Object^>^ parms,
    int level
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parms : Object[] *
        level : int -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parms : Object[] *
        level : int -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[],System.Int32)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[],System.Int32)"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[],System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object[],System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object, Object, Int32)

Tracetrace Method (String, IMessageSource, Object, Object, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object parm1,
    Object parm2,
    int level
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parm1 As Object,
    parm2 As Object,
    level As Integer
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    Object^ parm1,
    Object^ parm2,
    int level
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object *
        level : int -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object *
        level : int -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Int32)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Int32)"]

parm1
Type: SystemObject

[Missing <param name="parm1"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Int32)"]

parm2
Type: SystemObject

[Missing <param name="parm2"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object, Object, Object)

Tracetrace Method (String, IMessageSource, Object, Object, Object)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object parm1,
    Object parm2,
    Object parm3
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parm1 As Object,
    parm2 As Object,
    parm3 As Object
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    Object^ parm1,
    Object^ parm2,
    Object^ parm3
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object *
        parm3 : Object -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object *
        parm3 : Object -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object)"]

parm1
Type: SystemObject

[Missing <param name="parm1"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object)"]

parm2
Type: SystemObject

[Missing <param name="parm2"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object)"]

parm3
Type: SystemObject

[Missing <param name="parm3"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace.trace Method (String, IMessageSource, Object, Object, Object, Int32)

Tracetrace Method (String, IMessageSource, Object, Object, Object, Int32)

[Missing <summary> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void trace(
    string messageID,
    IMessageSource messageSource,
    Object parm1,
    Object parm2,
    Object parm3,
    int level
)
Public Overridable Sub trace (
    messageID As String,
    messageSource As IMessageSource,
    parm1 As Object,
    parm2 As Object,
    parm3 As Object,
    level As Integer
)
public:
virtual void trace(
    String^ messageID,
    IMessageSource^ messageSource,
    Object^ parm1,
    Object^ parm2,
    Object^ parm3,
    int level
)
abstract trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object *
        parm3 : Object *
        level : int -> unit
override trace :
        messageID : string *
        messageSource : IMessageSource *
        parm1 : Object *
        parm2 : Object *
        parm3 : Object *
        level : int -> unit

Parameters

messageID
Type: SystemString

[Missing <param name="messageID"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

messageSource
Type: DXMLBaseIMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

parm1
Type: SystemObject

[Missing <param name="parm1"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

parm2
Type: SystemObject

[Missing <param name="parm2"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

parm3
Type: SystemObject

[Missing <param name="parm3"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

level
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:DXMLBase.Trace.trace(System.String,DXMLBase.IMessageSource,System.Object,System.Object,System.Object,System.Int32)"]

See Also

Reference

Trace Class
trace Overload
DXMLBase Namespace


Trace Properties

Trace Properties

The Trace type exposes the following members.

Properties
 | Name | Description
Public property | TraceLevel |
Top
See Also

Reference

Trace Class
DXMLBase Namespace


Trace.TraceLevel Property

TraceTraceLevel Property

[Missing <summary> documentation for "P:DXMLBase.Trace.TraceLevel"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int TraceLevel { get; }
Public Overridable ReadOnly Property TraceLevel As Integer
    Get
public:
virtual property int TraceLevel {
    int get ();
}
abstract TraceLevel : int with get
override TraceLevel : int with get

Property Value

Type: Int32
See Also

Reference

Trace Class
DXMLBase Namespace


Trace_DOMWriter Class

Trace_DOMWriter Class

[Missing <summary> documentation for "T:DXMLBase.Trace_DOMWriter"]

Inheritance Hierarchy
SystemObject
DXMLBaseDOMWriter
DXMLBaseTrace_DOMWriter

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Trace_DOMWriter : DOMWriter
Public Class Trace_DOMWriter
    Inherits DOMWriter
public ref class Trace_DOMWriter : public DOMWriter
type Trace_DOMWriter =
    class
        inherit DOMWriter
    end

The Trace_DOMWriter type exposes the following members.

Constructors
 | Name | Description
Public method | Trace_DOMWriter(XmlNode, TextWriter) | Initializes a new instance of the Trace_DOMWriter class
Public method | Trace_DOMWriter(XmlNode, StringBuilder) | Initializes a new instance of the Trace_DOMWriter class
Public method | Trace_DOMWriter(XmlNode, Stream, String) | Initializes a new instance of the Trace_DOMWriter class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | isSensitive |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | write | Serialize a DOM subtree as XML (Inherited from DOMWriter.)
Protected method | writeDTD | (Inherited from DOMWriter.)
Protected method | writeTree | (Overrides DOMWriterwriteTree(XmlNode, XmlWriter).)
Top
Properties
 | Name | Description
Public property | BaseIndentLevel | (Inherited from DOMWriter.)
Public property | DoctypePublic | (Inherited from DOMWriter.)
Public property | DoctypeSystem | (Inherited from DOMWriter.)
Public property | Encoding | (Inherited from DOMWriter.)
Public property | Indent | (Inherited from DOMWriter.)
Public property | IndentString | (Inherited from DOMWriter.)
Public property | SensitiveElements |
Public property | Standalone | (Inherited from DOMWriter.)
Public property | WriteDeclaration | (Inherited from DOMWriter.)
Top
See Also

Reference

DXMLBase Namespace


Trace_DOMWriter Constructor

Trace_DOMWriter Constructor
Overload List
 | Name | Description
Public method | Trace_DOMWriter(XmlNode, TextWriter) | Initializes a new instance of the Trace_DOMWriter class
Public method | Trace_DOMWriter(XmlNode, StringBuilder) | Initializes a new instance of the Trace_DOMWriter class
Public method | Trace_DOMWriter(XmlNode, Stream, String) | Initializes a new instance of the Trace_DOMWriter class
Top
See Also

Reference

Trace_DOMWriter Class
DXMLBase Namespace


Trace_DOMWriter Constructor (XmlNode, TextWriter)

Trace_DOMWriter Constructor (XmlNode, TextWriter)
Initializes a new instance of the Trace_DOMWriter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Trace_DOMWriter(
    XmlNode node,
    TextWriter output
)
Public Sub New (
    node As XmlNode,
    output As TextWriter
)
public:
Trace_DOMWriter(
    XmlNode^ node,
    TextWriter^ output
)
new :
        node : XmlNode *
        output : TextWriter -> Trace_DOMWriter

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.IO.TextWriter)"]

output
Type: System.IOTextWriter

[Missing <param name="output"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.IO.TextWriter)"]

See Also

Reference

Trace_DOMWriter Class
Trace_DOMWriter Overload
DXMLBase Namespace


Trace_DOMWriter Constructor (XmlNode, StringBuilder)

Trace_DOMWriter Constructor (XmlNode, StringBuilder)
Initializes a new instance of the Trace_DOMWriter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Trace_DOMWriter(
    XmlNode node,
    StringBuilder output
)
Public Sub New (
    node As XmlNode,
    output As StringBuilder
)
public:
Trace_DOMWriter(
    XmlNode^ node,
    StringBuilder^ output
)
new :
        node : XmlNode *
        output : StringBuilder -> Trace_DOMWriter

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.Text.StringBuilder)"]

output
Type: System.TextStringBuilder

[Missing <param name="output"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.Text.StringBuilder)"]

See Also

Reference

Trace_DOMWriter Class
Trace_DOMWriter Overload
DXMLBase Namespace


Trace_DOMWriter Constructor (XmlNode, Stream, String)

Trace_DOMWriter Constructor (XmlNode, Stream, String)
Initializes a new instance of the Trace_DOMWriter class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Trace_DOMWriter(
    XmlNode node,
    Stream output,
    string encoding
)
Public Sub New (
    node As XmlNode,
    output As Stream,
    encoding As String
)
public:
Trace_DOMWriter(
    XmlNode^ node,
    Stream^ output,
    String^ encoding
)
new :
        node : XmlNode *
        output : Stream *
        encoding : string -> Trace_DOMWriter

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.IO.Stream,System.String)"]

output
Type: System.IOStream

[Missing <param name="output"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.IO.Stream,System.String)"]

encoding
Type: SystemString

[Missing <param name="encoding"/> documentation for "M:DXMLBase.Trace_DOMWriter.#ctor(System.Xml.XmlNode,System.IO.Stream,System.String)"]

See Also

Reference

Trace_DOMWriter Class
Trace_DOMWriter Overload
DXMLBase Namespace


Trace_DOMWriter Methods

Trace_DOMWriter Methods

The Trace_DOMWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | isSensitive |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | write | Serialize a DOM subtree as XML (Inherited from DOMWriter.)
Protected method | writeDTD | (Inherited from DOMWriter.)
Protected method | writeTree | (Overrides DOMWriterwriteTree(XmlNode, XmlWriter).)
Top
See Also

Reference

Trace_DOMWriter Class
DXMLBase Namespace


Trace_DOMWriter.isSensitive Method

Trace_DOMWriterisSensitive Method

[Missing <summary> documentation for "M:DXMLBase.Trace_DOMWriter.isSensitive(System.Xml.XmlNode)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual bool isSensitive(
    XmlNode node
)
Protected Overridable Function isSensitive (
    node As XmlNode
) As Boolean
protected:
virtual bool isSensitive(
    XmlNode^ node
)
abstract isSensitive :
        node : XmlNode -> bool
override isSensitive :
        node : XmlNode -> bool

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Trace_DOMWriter.isSensitive(System.Xml.XmlNode)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Trace_DOMWriter.isSensitive(System.Xml.XmlNode)"]

See Also

Reference

Trace_DOMWriter Class
DXMLBase Namespace


Trace_DOMWriter.writeTree Method

Trace_DOMWriterwriteTree Method

[Missing <summary> documentation for "M:DXMLBase.Trace_DOMWriter.writeTree(System.Xml.XmlNode,System.Xml.XmlWriter)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void writeTree(
    XmlNode node,
    XmlWriter xWriter
)
Protected Overrides Sub writeTree (
    node As XmlNode,
    xWriter As XmlWriter
)
protected:
virtual void writeTree(
    XmlNode^ node,
    XmlWriter^ xWriter
) override
abstract writeTree :
        node : XmlNode *
        xWriter : XmlWriter -> unit
override writeTree :
        node : XmlNode *
        xWriter : XmlWriter -> unit

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Trace_DOMWriter.writeTree(System.Xml.XmlNode,System.Xml.XmlWriter)"]

xWriter
Type: System.XmlXmlWriter
XmlWriter to write to
See Also

Reference

Trace_DOMWriter Class
DXMLBase Namespace


Trace_DOMWriter Properties

Trace_DOMWriter Properties

The Trace_DOMWriter type exposes the following members.

Properties
 | Name | Description
Public property | BaseIndentLevel | (Inherited from DOMWriter.)
Public property | DoctypePublic | (Inherited from DOMWriter.)
Public property | DoctypeSystem | (Inherited from DOMWriter.)
Public property | Encoding | (Inherited from DOMWriter.)
Public property | Indent | (Inherited from DOMWriter.)
Public property | IndentString | (Inherited from DOMWriter.)
Public property | SensitiveElements |
Public property | Standalone | (Inherited from DOMWriter.)
Public property | WriteDeclaration | (Inherited from DOMWriter.)
Top
See Also

Reference

Trace_DOMWriter Class
DXMLBase Namespace


Trace_DOMWriter.SensitiveElements Property

Trace_DOMWriterSensitiveElements Property

[Missing <summary> documentation for "P:DXMLBase.Trace_DOMWriter.SensitiveElements"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IDictionary<ExpandedQName, Trace_DOMWriterElementEntry> SensitiveElements { set; }
Public Overridable WriteOnly Property SensitiveElements As IDictionary(Of ExpandedQName, Trace_DOMWriterElementEntry)
    Set
public:
virtual property IDictionary<ExpandedQName^, Trace_DOMWriterElementEntry^>^ SensitiveElements {
    void set (IDictionary<ExpandedQName^, Trace_DOMWriterElementEntry^>^ value);
}
abstract SensitiveElements : IDictionary<ExpandedQName, Trace_DOMWriterElementEntry> with set
override SensitiveElements : IDictionary<ExpandedQName, Trace_DOMWriterElementEntry> with set

Property Value

Type: IDictionary ExpandedQName, Trace_DOMWriterElementEntry
See Also

Reference

Trace_DOMWriter Class
DXMLBase Namespace


Trace_DOMWriter.AttributeEntry Class

Trace_DOMWriterAttributeEntry Class

[Missing <summary> documentation for "T:DXMLBase.Trace_DOMWriter.AttributeEntry"]

Inheritance Hierarchy
SystemObject
DXMLBaseTrace_DOMWriterAttributeEntry

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AttributeEntry
Public Class AttributeEntry
public ref class AttributeEntry
type AttributeEntry =  class end

The Trace_DOMWriterAttributeEntry type exposes the following members.

Constructors
 | Name | Description
Public method | Trace_DOMWriterAttributeEntry | Initializes a new instance of the Trace_DOMWriterAttributeEntry class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Return the attribute name
Public property | Value | Return the attribute value
Top
See Also

Reference

DXMLBase Namespace


Trace_DOMWriter.AttributeEntry Constructor

Trace_DOMWriterAttributeEntry Constructor
Initializes a new instance of the Trace_DOMWriterAttributeEntry class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AttributeEntry(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
AttributeEntry(
    String^ name,
    String^ value
)
new :
        name : string *
        value : string -> AttributeEntry

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Trace_DOMWriter.AttributeEntry.#ctor(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Trace_DOMWriter.AttributeEntry.#ctor(System.String,System.String)"]

See Also

Reference

Trace_DOMWriterAttributeEntry Class
DXMLBase Namespace


AttributeEntry Methods

AttributeEntry Methods

The Trace_DOMWriterAttributeEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Trace_DOMWriterAttributeEntry Class
DXMLBase Namespace


AttributeEntry Properties

AttributeEntry Properties

The Trace_DOMWriterAttributeEntry type exposes the following members.

Properties
 | Name | Description
Public property | Name | Return the attribute name
Public property | Value | Return the attribute value
Top
See Also

Reference

Trace_DOMWriterAttributeEntry Class
DXMLBase Namespace


Trace_DOMWriter.AttributeEntry.Name Property

Trace_DOMWriterAttributeEntryName Property
Return the attribute name

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
See Also

Reference

Trace_DOMWriterAttributeEntry Class
DXMLBase Namespace


Trace_DOMWriter.AttributeEntry.Value Property

Trace_DOMWriterAttributeEntryValue Property
Return the attribute value

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Value { get; }
Public Overridable ReadOnly Property Value As String
    Get
public:
virtual property String^ Value {
    String^ get ();
}
abstract Value : string with get
override Value : string with get

Property Value

Type: String
See Also

Reference

Trace_DOMWriterAttributeEntry Class
DXMLBase Namespace


Trace_DOMWriter.ElementEntry Class

Trace_DOMWriterElementEntry Class

[Missing <summary> documentation for "T:DXMLBase.Trace_DOMWriter.ElementEntry"]

Inheritance Hierarchy
SystemObject
DXMLBaseTrace_DOMWriterElementEntry

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementEntry
Public Class ElementEntry
public ref class ElementEntry
type ElementEntry =  class end

The Trace_DOMWriterElementEntry type exposes the following members.

Constructors
 | Name | Description
Public method | Trace_DOMWriterElementEntry | Initializes a new instance of the Trace_DOMWriterElementEntry class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

DXMLBase Namespace


Trace_DOMWriter.ElementEntry Constructor

Trace_DOMWriterElementEntry Constructor
Initializes a new instance of the Trace_DOMWriterElementEntry class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementEntry(
    ExpandedQName name,
    Trace_DOMWriterAttributeEntry[] attrs
)
Public Sub New (
    name As ExpandedQName,
    attrs As Trace_DOMWriterAttributeEntry()
)
public:
ElementEntry(
    ExpandedQName^ name,
    array<Trace_DOMWriterAttributeEntry^>^ attrs
)
new :
        name : ExpandedQName *
        attrs : Trace_DOMWriterAttributeEntry[] -> ElementEntry

Parameters

name
Type: DXMLBaseExpandedQName

[Missing <param name="name"/> documentation for "M:DXMLBase.Trace_DOMWriter.ElementEntry.#ctor(DXMLBase.ExpandedQName,DXMLBase.Trace_DOMWriter.AttributeEntry[])"]

attrs
Type: DXMLBaseTrace_DOMWriterAttributeEntry

[Missing <param name="attrs"/> documentation for "M:DXMLBase.Trace_DOMWriter.ElementEntry.#ctor(DXMLBase.ExpandedQName,DXMLBase.Trace_DOMWriter.AttributeEntry[])"]

See Also

Reference

Trace_DOMWriterElementEntry Class
DXMLBase Namespace


ElementEntry Methods

ElementEntry Methods

The Trace_DOMWriterElementEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Trace_DOMWriterElementEntry Class
DXMLBase Namespace


ElementEntry Properties

ElementEntry Properties

The Trace_DOMWriterElementEntry type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

Trace_DOMWriterElementEntry Class
DXMLBase Namespace


Trace_DOMWriter.ElementEntry.Name Property

Trace_DOMWriterElementEntryName Property

[Missing <summary> documentation for "P:DXMLBase.Trace_DOMWriter.ElementEntry.Name"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ExpandedQName Name { get; }
Public Overridable ReadOnly Property Name As ExpandedQName
    Get
public:
virtual property ExpandedQName^ Name {
    ExpandedQName^ get ();
}
abstract Name : ExpandedQName with get
override Name : ExpandedQName with get

Property Value

Type: ExpandedQName
See Also

Reference

Trace_DOMWriterElementEntry Class
DXMLBase Namespace


XdsDN Class

XdsDN Class

[Missing <summary> documentation for "T:DXMLBase.XdsDN"]

Inheritance Hierarchy
SystemObject
DXMLBaseXdsDN

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsDN
Public Class XdsDN
public ref class XdsDN
type XdsDN =  class end

The XdsDN type exposes the following members.

Constructors
 | Name | Description
Public method | XdsDN(XdsDN) | Initializes a new instance of the XdsDN class
Public method | XdsDN(String, Char) | Initializes a new instance of the XdsDN class
Top
Methods
 | Name | Description
 | appendComponent |
Public method | checkScope |
Public method | copyTreeName |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(XdsDN) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getDelims(String) |
 | getDelims(XdsDNForm) |
Public method | getDN |
Public method | getDNFragment |
 | getFormString(Char) |
 | getFormString(XdsDNForm) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getName |
Public method | getRDN |
Public method | getRelativeDN |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasAncestor |
Public method | matchComponent |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDN |
 | quote |
Public method | removeTreeName |
Public method | split |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | validateDelims |
Top
Fields
Name Description
DELIM_CFG_FALSE
DELIM_CFG_TRUE
DI_CFG_ESC_STRINGS
DI_CFG_TYPED
DI_DV
DI_ESC
DI_EXTRA_QUOTED
DI_RDN
DI_REL
DI_SIZE
DI_VALUE
DI_WILD
DOT_DELIMS
Delimiter set for
Copy
"dot"
DN format.
ERR_INVALID_CHAR
ERR_NONE
ILLEGAL_CHARS
LDAP_DELIMS
Delimiter set for
Copy
"ldap"
DN format.
QDOT_DELIMS
Delimiter set for
Copy
"qualified-dot"
DN format.
QSLASH_DELIMS
Delimiter set for
Copy
"qualified-slash"
DN format.
SLASH_DELIMS
Delimiter set for "
Copy
slash"
DN format.
Top
Properties
 | Name | Description
Public property | ComponentCount |
Public property | Components |
Public property | HasTreeName |
Public property | Item |
Public property | ParseErr |
Public property | TreeName |
Top
See Also

Reference

DXMLBase Namespace


XdsDN Constructor

XdsDN Constructor
Overload List
 | Name | Description
Public method | XdsDN(XdsDN) | Initializes a new instance of the XdsDN class
Public method | XdsDN(String, Char) | Initializes a new instance of the XdsDN class
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN Constructor (XdsDN)

XdsDN Constructor (XdsDN)
Initializes a new instance of the XdsDN class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDN(
    XdsDN original
)
Public Sub New (
    original As XdsDN
)
public:
XdsDN(
    XdsDN^ original
)
new :
        original : XdsDN -> XdsDN

Parameters

original
Type: DXMLBaseXdsDN

[Missing <param name="original"/> documentation for "M:DXMLBase.XdsDN.#ctor(DXMLBase.XdsDN)"]

See Also

Reference

XdsDN Class
XdsDN Overload
DXMLBase Namespace


XdsDN Constructor (String, Char[])

XdsDN Constructor (String, Char)
Initializes a new instance of the XdsDN class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDN(
    string srcDN,
    char[] delims
)
Public Sub New (
    srcDN As String,
    delims As Char()
)
public:
XdsDN(
    String^ srcDN,
    array<wchar_t>^ delims
)
new :
        srcDN : string *
        delims : char[] -> XdsDN

Parameters

srcDN
Type: SystemString

[Missing <param name="srcDN"/> documentation for "M:DXMLBase.XdsDN.#ctor(System.String,System.Char[])"]

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.#ctor(System.String,System.Char[])"]

See Also

Reference

XdsDN Class
XdsDN Overload
DXMLBase Namespace


XdsDN Fields

XdsDN Fields

The XdsDN type exposes the following members.

Fields
Name Description
DELIM_CFG_FALSE
DELIM_CFG_TRUE
DI_CFG_ESC_STRINGS
DI_CFG_TYPED
DI_DV
DI_ESC
DI_EXTRA_QUOTED
DI_RDN
DI_REL
DI_SIZE
DI_VALUE
DI_WILD
DOT_DELIMS
Delimiter set for
Copy
"dot"
DN format.
ERR_INVALID_CHAR
ERR_NONE
ILLEGAL_CHARS
LDAP_DELIMS
Delimiter set for
Copy
"ldap"
DN format.
QDOT_DELIMS
Delimiter set for
Copy
"qualified-dot"
DN format.
QSLASH_DELIMS
Delimiter set for
Copy
"qualified-slash"
DN format.
SLASH_DELIMS
Delimiter set for "
Copy
slash"
DN format.
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DELIM_CFG_FALSE Field

XdsDNDELIM_CFG_FALSE Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DELIM_CFG_FALSE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char DELIM_CFG_FALSE
Public Const DELIM_CFG_FALSE As Char
public:
literal wchar_t DELIM_CFG_FALSE
static val mutable DELIM_CFG_FALSE: char

Field Value

Type: Char
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DELIM_CFG_TRUE Field

XdsDNDELIM_CFG_TRUE Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DELIM_CFG_TRUE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char DELIM_CFG_TRUE
Public Const DELIM_CFG_TRUE As Char
public:
literal wchar_t DELIM_CFG_TRUE
static val mutable DELIM_CFG_TRUE: char

Field Value

Type: Char
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_CFG_ESC_STRINGS Field

XdsDNDI_CFG_ESC_STRINGS Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_CFG_ESC_STRINGS"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_CFG_ESC_STRINGS
Public Const DI_CFG_ESC_STRINGS As Integer
public:
literal int DI_CFG_ESC_STRINGS
static val mutable DI_CFG_ESC_STRINGS: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_CFG_TYPED Field

XdsDNDI_CFG_TYPED Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_CFG_TYPED"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_CFG_TYPED
Public Const DI_CFG_TYPED As Integer
public:
literal int DI_CFG_TYPED
static val mutable DI_CFG_TYPED: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_DV Field

XdsDNDI_DV Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_DV"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_DV
Public Const DI_DV As Integer
public:
literal int DI_DV
static val mutable DI_DV: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_ESC Field

XdsDNDI_ESC Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_ESC"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_ESC
Public Const DI_ESC As Integer
public:
literal int DI_ESC
static val mutable DI_ESC: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_EXTRA_QUOTED Field

XdsDNDI_EXTRA_QUOTED Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_EXTRA_QUOTED"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_EXTRA_QUOTED
Public Const DI_EXTRA_QUOTED As Integer
public:
literal int DI_EXTRA_QUOTED
static val mutable DI_EXTRA_QUOTED: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_RDN Field

XdsDNDI_RDN Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_RDN"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_RDN
Public Const DI_RDN As Integer
public:
literal int DI_RDN
static val mutable DI_RDN: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_REL Field

XdsDNDI_REL Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_REL"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_REL
Public Const DI_REL As Integer
public:
literal int DI_REL
static val mutable DI_REL: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_SIZE Field

XdsDNDI_SIZE Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_SIZE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_SIZE
Public Const DI_SIZE As Integer
public:
literal int DI_SIZE
static val mutable DI_SIZE: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_VALUE Field

XdsDNDI_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_VALUE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_VALUE
Public Const DI_VALUE As Integer
public:
literal int DI_VALUE
static val mutable DI_VALUE: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DI_WILD Field

XdsDNDI_WILD Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.DI_WILD"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DI_WILD
Public Const DI_WILD As Integer
public:
literal int DI_WILD
static val mutable DI_WILD: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DOT_DELIMS Field

XdsDNDOT_DELIMS Field
Delimiter set for
Copy
"dot"
DN format.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DOT_DELIMS
Public Const DOT_DELIMS As String
public:
literal String^ DOT_DELIMS
static val mutable DOT_DELIMS: string

Field Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.ERR_INVALID_CHAR Field

XdsDNERR_INVALID_CHAR Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.ERR_INVALID_CHAR"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_CHAR
Public Const ERR_INVALID_CHAR As Integer
public:
literal int ERR_INVALID_CHAR
static val mutable ERR_INVALID_CHAR: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.ERR_NONE Field

XdsDNERR_NONE Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.ERR_NONE"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_NONE
Public Const ERR_NONE As Integer
public:
literal int ERR_NONE
static val mutable ERR_NONE: int

Field Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.ILLEGAL_CHARS Field

XdsDNILLEGAL_CHARS Field

[Missing <summary> documentation for "F:DXMLBase.XdsDN.ILLEGAL_CHARS"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ILLEGAL_CHARS
Public Const ILLEGAL_CHARS As String
public:
literal String^ ILLEGAL_CHARS
static val mutable ILLEGAL_CHARS: string

Field Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.LDAP_DELIMS Field

XdsDNLDAP_DELIMS Field
Delimiter set for
Copy
"ldap"
DN format.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string LDAP_DELIMS
Public Const LDAP_DELIMS As String
public:
literal String^ LDAP_DELIMS
static val mutable LDAP_DELIMS: string

Field Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.QDOT_DELIMS Field

XdsDNQDOT_DELIMS Field
Delimiter set for
Copy
"qualified-dot"
DN format.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string QDOT_DELIMS
Public Const QDOT_DELIMS As String
public:
literal String^ QDOT_DELIMS
static val mutable QDOT_DELIMS: string

Field Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.QSLASH_DELIMS Field

XdsDNQSLASH_DELIMS Field
Delimiter set for
Copy
"qualified-slash"
DN format.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string QSLASH_DELIMS
Public Const QSLASH_DELIMS As String
public:
literal String^ QSLASH_DELIMS
static val mutable QSLASH_DELIMS: string

Field Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.SLASH_DELIMS Field

XdsDNSLASH_DELIMS Field
Delimiter set for "
Copy
slash"
DN format.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string SLASH_DELIMS
Public Const SLASH_DELIMS As String
public:
literal String^ SLASH_DELIMS
static val mutable SLASH_DELIMS: string

Field Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN Methods

XdsDN Methods

The XdsDN type exposes the following members.

Methods
 | Name | Description
 | appendComponent |
Public method | checkScope |
Public method | copyTreeName |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(XdsDN) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getDelims(String) |
 | getDelims(XdsDNForm) |
Public method | getDN |
Public method | getDNFragment |
 | getFormString(Char) |
 | getFormString(XdsDNForm) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getName |
Public method | getRDN |
Public method | getRelativeDN |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasAncestor |
Public method | matchComponent |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDN |
 | quote |
Public method | removeTreeName |
Public method | split |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | validateDelims |
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.appendComponent Method

XdsDNappendComponent Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.appendComponent(System.Text.StringBuilder,DXMLBase.XdsDN.DNComponent,System.Char[],System.Boolean)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void appendComponent(
    StringBuilder sb,
    XdsDNDNComponent component,
    char[] delims,
    bool typed
)
Public Shared Sub appendComponent (
    sb As StringBuilder,
    component As XdsDNDNComponent,
    delims As Char(),
    typed As Boolean
)
public:
static void appendComponent(
    StringBuilder^ sb,
    XdsDNDNComponent^ component,
    array<wchar_t>^ delims,
    bool typed
)
static member appendComponent :
        sb : StringBuilder *
        component : XdsDNDNComponent *
        delims : char[] *
        typed : bool -> unit

Parameters

sb
Type: System.TextStringBuilder

[Missing <param name="sb"/> documentation for "M:DXMLBase.XdsDN.appendComponent(System.Text.StringBuilder,DXMLBase.XdsDN.DNComponent,System.Char[],System.Boolean)"]

component
Type: DXMLBaseXdsDNDNComponent

[Missing <param name="component"/> documentation for "M:DXMLBase.XdsDN.appendComponent(System.Text.StringBuilder,DXMLBase.XdsDN.DNComponent,System.Char[],System.Boolean)"]

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.appendComponent(System.Text.StringBuilder,DXMLBase.XdsDN.DNComponent,System.Char[],System.Boolean)"]

typed
Type: SystemBoolean

[Missing <param name="typed"/> documentation for "M:DXMLBase.XdsDN.appendComponent(System.Text.StringBuilder,DXMLBase.XdsDN.DNComponent,System.Char[],System.Boolean)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.checkScope Method

XdsDNcheckScope Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.checkScope(DXMLBase.XdsDN,DXMLBase.XdsDN.Scope)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool checkScope(
    XdsDN baseDN,
    XdsDNScope scope
)
Public Function checkScope (
    baseDN As XdsDN,
    scope As XdsDNScope
) As Boolean
public:
bool checkScope(
    XdsDN^ baseDN,
    XdsDNScope scope
)
member checkScope :
        baseDN : XdsDN *
        scope : XdsDNScope -> bool

Parameters

baseDN
Type: DXMLBaseXdsDN

[Missing <param name="baseDN"/> documentation for "M:DXMLBase.XdsDN.checkScope(DXMLBase.XdsDN,DXMLBase.XdsDN.Scope)"]

scope
Type: DXMLBaseXdsDNScope

[Missing <param name="scope"/> documentation for "M:DXMLBase.XdsDN.checkScope(DXMLBase.XdsDN,DXMLBase.XdsDN.Scope)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.XdsDN.checkScope(DXMLBase.XdsDN,DXMLBase.XdsDN.Scope)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.copyTreeName Method

XdsDNcopyTreeName Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.copyTreeName(DXMLBase.XdsDN)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void copyTreeName(
    XdsDN src
)
Public Sub copyTreeName (
    src As XdsDN
)
public:
void copyTreeName(
    XdsDN^ src
)
member copyTreeName :
        src : XdsDN -> unit

Parameters

src
Type: DXMLBaseXdsDN

[Missing <param name="src"/> documentation for "M:DXMLBase.XdsDN.copyTreeName(DXMLBase.XdsDN)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.Equals Method

XdsDNEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(XdsDN) |
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.Equals Method (XdsDN)

XdsDNEquals Method (XdsDN)

[Missing <summary> documentation for "M:DXMLBase.XdsDN.Equals(DXMLBase.XdsDN)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    XdsDN dn
)
Public Function Equals (
    dn As XdsDN
) As Boolean
public:
bool Equals(
    XdsDN^ dn
)
member Equals :
        dn : XdsDN -> bool

Parameters

dn
Type: DXMLBaseXdsDN

[Missing <param name="dn"/> documentation for "M:DXMLBase.XdsDN.Equals(DXMLBase.XdsDN)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.XdsDN.Equals(DXMLBase.XdsDN)"]

See Also

Reference

XdsDN Class
Equals Overload
DXMLBase Namespace


XdsDN.getDelims Method

XdsDNgetDelims Method
Overload List
Name | Description
getDelims(String) |
getDelims(XdsDNForm) |
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.getDelims Method (String)

XdsDNgetDelims Method (String)

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getDelims(System.String)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getDelims(
    string dnForm
)
Public Shared Function getDelims (
    dnForm As String
) As String
public:
static String^ getDelims(
    String^ dnForm
)
static member getDelims :
        dnForm : string -> string

Parameters

dnForm
Type: SystemString

[Missing <param name="dnForm"/> documentation for "M:DXMLBase.XdsDN.getDelims(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getDelims(System.String)"]

See Also

Reference

XdsDN Class
getDelims Overload
DXMLBase Namespace


XdsDN.getDelims Method (XdsDN.Form)

XdsDNgetDelims Method (XdsDNForm)

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getDelims(DXMLBase.XdsDN.Form)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getDelims(
    XdsDNForm dnForm
)
Public Shared Function getDelims (
    dnForm As XdsDNForm
) As String
public:
static String^ getDelims(
    XdsDNForm dnForm
)
static member getDelims :
        dnForm : XdsDNForm -> string

Parameters

dnForm
Type: DXMLBaseXdsDNForm

[Missing <param name="dnForm"/> documentation for "M:DXMLBase.XdsDN.getDelims(DXMLBase.XdsDN.Form)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getDelims(DXMLBase.XdsDN.Form)"]

See Also

Reference

XdsDN Class
getDelims Overload
DXMLBase Namespace


XdsDN.getDN Method

XdsDNgetDN Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getDN(System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string getDN(
    char[] delims
)
Public Function getDN (
    delims As Char()
) As String
public:
String^ getDN(
    array<wchar_t>^ delims
)
member getDN :
        delims : char[] -> string

Parameters

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.getDN(System.Char[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getDN(System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.getDNFragment Method

XdsDNgetDNFragment Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getDNFragment(System.Char[],System.Int32,System.Int32,System.Boolean)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string getDNFragment(
    char[] delims,
    int loIndex,
    int count,
    bool includeRoot
)
Public Function getDNFragment (
    delims As Char(),
    loIndex As Integer,
    count As Integer,
    includeRoot As Boolean
) As String
public:
String^ getDNFragment(
    array<wchar_t>^ delims,
    int loIndex,
    int count,
    bool includeRoot
)
member getDNFragment :
        delims : char[] *
        loIndex : int *
        count : int *
        includeRoot : bool -> string

Parameters

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.getDNFragment(System.Char[],System.Int32,System.Int32,System.Boolean)"]

loIndex
Type: SystemInt32

[Missing <param name="loIndex"/> documentation for "M:DXMLBase.XdsDN.getDNFragment(System.Char[],System.Int32,System.Int32,System.Boolean)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:DXMLBase.XdsDN.getDNFragment(System.Char[],System.Int32,System.Int32,System.Boolean)"]

includeRoot
Type: SystemBoolean

[Missing <param name="includeRoot"/> documentation for "M:DXMLBase.XdsDN.getDNFragment(System.Char[],System.Int32,System.Int32,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getDNFragment(System.Char[],System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.getFormString Method

XdsDNgetFormString Method
Overload List
Name | Description
getFormString(Char) |
getFormString(XdsDNForm) |
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.getFormString Method (Char[])

XdsDNgetFormString Method (Char)

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getFormString(System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getFormString(
    char[] delims
)
Public Shared Function getFormString (
    delims As Char()
) As String
public:
static String^ getFormString(
    array<wchar_t>^ delims
)
static member getFormString :
        delims : char[] -> string

Parameters

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.getFormString(System.Char[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getFormString(System.Char[])"]

See Also

Reference

XdsDN Class
getFormString Overload
DXMLBase Namespace


XdsDN.getFormString Method (XdsDN.Form)

XdsDNgetFormString Method (XdsDNForm)

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getFormString(DXMLBase.XdsDN.Form)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getFormString(
    XdsDNForm dnForm
)
Public Shared Function getFormString (
    dnForm As XdsDNForm
) As String
public:
static String^ getFormString(
    XdsDNForm dnForm
)
static member getFormString :
        dnForm : XdsDNForm -> string

Parameters

dnForm
Type: DXMLBaseXdsDNForm

[Missing <param name="dnForm"/> documentation for "M:DXMLBase.XdsDN.getFormString(DXMLBase.XdsDN.Form)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getFormString(DXMLBase.XdsDN.Form)"]

See Also

Reference

XdsDN Class
getFormString Overload
DXMLBase Namespace


XdsDN.getName Method

XdsDNgetName Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getName(System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string getName(
    char[] delims
)
Public Function getName (
    delims As Char()
) As String
public:
String^ getName(
    array<wchar_t>^ delims
)
member getName :
        delims : char[] -> string

Parameters

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.getName(System.Char[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getName(System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.getRDN Method

XdsDNgetRDN Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getRDN(System.Char[],System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string getRDN(
    char[] delims,
    int count
)
Public Function getRDN (
    delims As Char(),
    count As Integer
) As String
public:
String^ getRDN(
    array<wchar_t>^ delims,
    int count
)
member getRDN :
        delims : char[] *
        count : int -> string

Parameters

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.getRDN(System.Char[],System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:DXMLBase.XdsDN.getRDN(System.Char[],System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getRDN(System.Char[],System.Int32)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.getRelativeDN Method

XdsDNgetRelativeDN Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.getRelativeDN(DXMLBase.XdsDN,System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string getRelativeDN(
    XdsDN baseDN,
    char[] delims
)
Public Function getRelativeDN (
    baseDN As XdsDN,
    delims As Char()
) As String
public:
String^ getRelativeDN(
    XdsDN^ baseDN,
    array<wchar_t>^ delims
)
member getRelativeDN :
        baseDN : XdsDN *
        delims : char[] -> string

Parameters

baseDN
Type: DXMLBaseXdsDN

[Missing <param name="baseDN"/> documentation for "M:DXMLBase.XdsDN.getRelativeDN(DXMLBase.XdsDN,System.Char[])"]

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.getRelativeDN(DXMLBase.XdsDN,System.Char[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.getRelativeDN(DXMLBase.XdsDN,System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.hasAncestor Method

XdsDNhasAncestor Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.hasAncestor(DXMLBase.XdsDN)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool hasAncestor(
    XdsDN root
)
Public Function hasAncestor (
    root As XdsDN
) As Boolean
public:
bool hasAncestor(
    XdsDN^ root
)
member hasAncestor :
        root : XdsDN -> bool

Parameters

root
Type: DXMLBaseXdsDN

[Missing <param name="root"/> documentation for "M:DXMLBase.XdsDN.hasAncestor(DXMLBase.XdsDN)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.XdsDN.hasAncestor(DXMLBase.XdsDN)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.matchComponent Method

XdsDNmatchComponent Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.matchComponent(DXMLBase.XdsDN.DNComponent,DXMLBase.XdsDN.DNComponent)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool matchComponent(
    XdsDNDNComponent c1,
    XdsDNDNComponent c2
)
Public Function matchComponent (
    c1 As XdsDNDNComponent,
    c2 As XdsDNDNComponent
) As Boolean
public:
bool matchComponent(
    XdsDNDNComponent^ c1,
    XdsDNDNComponent^ c2
)
member matchComponent :
        c1 : XdsDNDNComponent *
        c2 : XdsDNDNComponent -> bool

Parameters

c1
Type: DXMLBaseXdsDNDNComponent

[Missing <param name="c1"/> documentation for "M:DXMLBase.XdsDN.matchComponent(DXMLBase.XdsDN.DNComponent,DXMLBase.XdsDN.DNComponent)"]

c2
Type: DXMLBaseXdsDNDNComponent

[Missing <param name="c2"/> documentation for "M:DXMLBase.XdsDN.matchComponent(DXMLBase.XdsDN.DNComponent,DXMLBase.XdsDN.DNComponent)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.XdsDN.matchComponent(DXMLBase.XdsDN.DNComponent,DXMLBase.XdsDN.DNComponent)"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.parseDN Method

XdsDNparseDN Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.parseDN(System.String,System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected int parseDN(
    string dn,
    char[] delims
)
Protected Function parseDN (
    dn As String,
    delims As Char()
) As Integer
protected:
int parseDN(
    String^ dn,
    array<wchar_t>^ delims
)
member parseDN :
        dn : string *
        delims : char[] -> int

Parameters

dn
Type: SystemString

[Missing <param name="dn"/> documentation for "M:DXMLBase.XdsDN.parseDN(System.String,System.Char[])"]

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.parseDN(System.String,System.Char[])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.XdsDN.parseDN(System.String,System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.quote Method

XdsDNquote Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.quote(System.String,System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string quote(
    string str,
    char[] d
)
Public Shared Function quote (
    str As String,
    d As Char()
) As String
public:
static String^ quote(
    String^ str,
    array<wchar_t>^ d
)
static member quote :
        str : string *
        d : char[] -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:DXMLBase.XdsDN.quote(System.String,System.Char[])"]

d
Type: SystemChar

[Missing <param name="d"/> documentation for "M:DXMLBase.XdsDN.quote(System.String,System.Char[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.quote(System.String,System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.removeTreeName Method

XdsDNremoveTreeName Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.removeTreeName"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void removeTreeName()
Public Sub removeTreeName
public:
void removeTreeName()
member removeTreeName : unit -> unit
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.split Method

XdsDNsplit Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.split(System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] split(
    char[] delims
)
Public Function split (
    delims As Char()
) As String()
public:
array<String^>^ split(
    array<wchar_t>^ delims
)
member split :
        delims : char[] -> string[]

Parameters

delims
Type: SystemChar

[Missing <param name="delims"/> documentation for "M:DXMLBase.XdsDN.split(System.Char[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.XdsDN.split(System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.validateDelims Method

XdsDNvalidateDelims Method

[Missing <summary> documentation for "M:DXMLBase.XdsDN.validateDelims(System.Char[])"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool validateDelims(
    char[] d
)
Public Shared Function validateDelims (
    d As Char()
) As Boolean
public:
static bool validateDelims(
    array<wchar_t>^ d
)
static member validateDelims :
        d : char[] -> bool

Parameters

d
Type: SystemChar

[Missing <param name="d"/> documentation for "M:DXMLBase.XdsDN.validateDelims(System.Char[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.XdsDN.validateDelims(System.Char[])"]

See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN Properties

XdsDN Properties

The XdsDN type exposes the following members.

Properties
 | Name | Description
Public property | ComponentCount |
Public property | Components |
Public property | HasTreeName |
Public property | Item |
Public property | ParseErr |
Public property | TreeName |
Top
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.ComponentCount Property

XdsDNComponentCount Property

[Missing <summary> documentation for "P:DXMLBase.XdsDN.ComponentCount"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ComponentCount { get; }
Public ReadOnly Property ComponentCount As Integer
    Get
public:
property int ComponentCount {
    int get ();
}
member ComponentCount : int with get

Property Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.Components Property

XdsDNComponents Property

[Missing <summary> documentation for "P:DXMLBase.XdsDN.Components"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsDNDNComponent> Components { get; }
Public ReadOnly Property Components As IEnumerable(Of XdsDNDNComponent)
    Get
public:
property IEnumerable<XdsDNDNComponent^>^ Components {
    IEnumerable<XdsDNDNComponent^>^ get ();
}
member Components : IEnumerable<XdsDNDNComponent> with get

Property Value

Type: IEnumerable XdsDNDNComponent
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.HasTreeName Property

XdsDNHasTreeName Property

[Missing <summary> documentation for "P:DXMLBase.XdsDN.HasTreeName"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasTreeName { get; }
Public ReadOnly Property HasTreeName As Boolean
    Get
public:
property bool HasTreeName {
    bool get ();
}
member HasTreeName : bool with get

Property Value

Type: Boolean
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.Item Property

XdsDNItem Property

[Missing <summary> documentation for "P:DXMLBase.XdsDN.Item(System.Int32)"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDNDNComponent this[
    int n
] { get; }
Public ReadOnly Default Property Item (
    n As Integer
) As XdsDNDNComponent
    Get
public:
property XdsDNDNComponent^ default[int n] {
    XdsDNDNComponent^ get (int n);
}
member Item : XdsDNDNComponent with get

Parameters

n
Type: SystemInt32

Property Value

Type: XdsDNDNComponent
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.ParseErr Property

XdsDNParseErr Property

[Missing <summary> documentation for "P:DXMLBase.XdsDN.ParseErr"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ParseErr { get; }
Public ReadOnly Property ParseErr As Integer
    Get
public:
property int ParseErr {
    int get ();
}
member ParseErr : int with get

Property Value

Type: Int32
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.TreeName Property

XdsDNTreeName Property

[Missing <summary> documentation for "P:DXMLBase.XdsDN.TreeName"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TreeName { get; set; }
Public Property TreeName As String
    Get
    Set
public:
property String^ TreeName {
    String^ get ();
    void set (String^ value);
}
member TreeName : string with get, set

Property Value

Type: String
See Also

Reference

XdsDN Class
DXMLBase Namespace


XdsDN.DNComponent Class

XdsDNDNComponent Class

[Missing <summary> documentation for "T:DXMLBase.XdsDN.DNComponent"]

Inheritance Hierarchy
SystemObject
DXMLBaseXdsDNDNComponent

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DNComponent
Public Class DNComponent
public ref class DNComponent
type DNComponent =  class end

The XdsDNDNComponent type exposes the following members.

Constructors
 | Name | Description
Public method | XdsDNDNComponent(XdsDNDNComponent) | Initializes a new instance of the XdsDNDNComponent class
Public method | XdsDNDNComponent(String, String) | Initializes a new instance of the XdsDNDNComponent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Next | Get the next name/value pair for the component.
Public property | Type | Get the type qualifier for the component.
Public property | Value | Get the value for the component.
Top
See Also

Reference

DXMLBase Namespace


DNComponent Constructor

DNComponent Constructor
Overload List
 | Name | Description
Public method | XdsDNDNComponent(XdsDNDNComponent) | Initializes a new instance of the XdsDNDNComponent class
Public method | XdsDNDNComponent(String, String) | Initializes a new instance of the XdsDNDNComponent class
Top
See Also

Reference

XdsDNDNComponent Class
DXMLBase Namespace


XdsDN.DNComponent Constructor (XdsDN.DNComponent)

XdsDNDNComponent Constructor (XdsDNDNComponent)
Initializes a new instance of the XdsDNDNComponent class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DNComponent(
    XdsDNDNComponent copy
)
Public Sub New (
    copy As XdsDNDNComponent
)
public:
DNComponent(
    XdsDNDNComponent^ copy
)
new :
        copy : XdsDNDNComponent -> DNComponent

Parameters

copy
Type: DXMLBaseXdsDNDNComponent

[Missing <param name="copy"/> documentation for "M:DXMLBase.XdsDN.DNComponent.#ctor(DXMLBase.XdsDN.DNComponent)"]

See Also

Reference

XdsDNDNComponent Class
XdsDNDNComponent Overload
DXMLBase Namespace


XdsDN.DNComponent Constructor (String, String)

XdsDNDNComponent Constructor (String, String)
Initializes a new instance of the XdsDNDNComponent class

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DNComponent(
    string t,
    string v
)
Public Sub New (
    t As String,
    v As String
)
public:
DNComponent(
    String^ t,
    String^ v
)
new :
        t : string *
        v : string -> DNComponent

Parameters

t
Type: SystemString

[Missing <param name="t"/> documentation for "M:DXMLBase.XdsDN.DNComponent.#ctor(System.String,System.String)"]

v
Type: SystemString

[Missing <param name="v"/> documentation for "M:DXMLBase.XdsDN.DNComponent.#ctor(System.String,System.String)"]

See Also

Reference

XdsDNDNComponent Class
XdsDNDNComponent Overload
DXMLBase Namespace


DNComponent Methods

DNComponent Methods

The XdsDNDNComponent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsDNDNComponent Class
DXMLBase Namespace


DNComponent Properties

DNComponent Properties

The XdsDNDNComponent type exposes the following members.

Properties
 | Name | Description
Public property | Next | Get the next name/value pair for the component.
Public property | Type | Get the type qualifier for the component.
Public property | Value | Get the value for the component.
Top
See Also

Reference

XdsDNDNComponent Class
DXMLBase Namespace


XdsDN.DNComponent.Next Property

XdsDNDNComponentNext Property
Get the next name/value pair for the component.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDNDNComponent Next { get; set; }
Public Property Next As XdsDNDNComponent
    Get
    Set
public:
property XdsDNDNComponent^ Next {
    XdsDNDNComponent^ get ();
    void set (XdsDNDNComponent^ value);
}
member Next : XdsDNDNComponent with get, set

Property Value

Type: XdsDNDNComponent
See Also

Reference

XdsDNDNComponent Class
DXMLBase Namespace


XdsDN.DNComponent.Type Property

XdsDNDNComponentType Property
Get the type qualifier for the component.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

XdsDNDNComponent Class
DXMLBase Namespace


XdsDN.DNComponent.Value Property

XdsDNDNComponentValue Property
Get the value for the component.

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

XdsDNDNComponent Class
DXMLBase Namespace


XdsDN.Form Enumeration

XdsDNForm Enumeration

[Missing <summary> documentation for "T:DXMLBase.XdsDN.Form"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Form
Public Enumeration Form
public enum class Form
type Form
Members
Member name Value Description
SLASH_FORM 0 Integer constant representing DN
Copy
"slash"
format.
QSLASH_FORM 1 Integer constant representing DN
Copy
"qualified-slash"
format.
DOT_FORM 2 Integer constant representing DN
Copy
"dot"
format.
QDOT_FORM 3 Integer constant representing DN
Copy
"qualified-dot"
format.
LDAP_FORM 4 Integer constant representing DN
Copy
"ldap"
format.
CUSTOM_FORM 5 Integer constant representing DN
Copy
"custom"
format.
See Also

Reference

DXMLBase Namespace


XdsDN.Scope Enumeration

XdsDNScope Enumeration

[Missing <summary> documentation for "T:DXMLBase.XdsDN.Scope"]

Namespace: DXMLBase
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Scope
Public Enumeration Scope
public enum class Scope
type Scope
Members
Member name | Value | Description
SCOPE_SUBTREE | 0 |
SCOPE_SUBORDINATES | 1 |
SCOPE_ENTRY | 2 |
See Also

Reference

DXMLBase Namespace


DXMLBase.Gcv Namespace

DXMLBase.Gcv Namespace

[Missing <summary> documentation for "N:DXMLBase.Gcv"]

Classes
Class | Description
Public class | GCBooleanValue
Public class | GCDefinitions
Public class | GCDnRefValue
Public class | GCDNValue
Public class | GCEnumValue
Public class GCEnumValueEnumChoice
Class representing a single enum choice.
Public class | GCGroup
Public class | GCHeader
Public class | GCIntegerValue
Public class | GCList
Public class | GCListValue
Public class | GCParent
Public class | GCPasswordRefValue
Public class | GCRealValue
Public class | GCStringValue
Public class | GCStructuredValue
Public class GCStructuredValueInstance
Class representing an instance of a
Copy
GCStructuredValue
's template.
Public class GCStructuredValueTemplate
Class representing the template definitions for a
Copy
GCStructuredValue
.
Public class | GCSubordinates
Public class | GCTest
Public class GCValue
Base class for all Global Configuration Value types.
Public class GCValueComment
Class for representing XML comments.
Public class | GCValueIllegalCloneStateException
Public class GCValueProcessingInstruction
Class for representing XML processing instructions.
Public class GCValueXmlItem
Abstract class for representing XML processing instructions and comments.
Public class | GCValueNotFoundException
Public class | GCValueParseException
Public class | GCVArgumentException
Public class | GCVDtd
Public class | GCVException
Public class | GCVRef
Public class | GCVStateException
Public class | GCVXmlParseException
Public class | ShimParams
Public class ShimParamsNoSuchReferenceException
GCVException indicating a gcv-ref or password reference wasn't found.
Interfaces
 | Interface | Description
Public interface | GCPasswordRefValueIPasswordResolver |
Public interface | IConfigElement | Interface for items that may be read from or written to an XML configuration document.
Public interface | IGCOwner | Interface for objects that "own" control values.
Public interface | ShimParamsReferenceResolver |
Enumerations
 | Enumeration | Description
Public enumeration | GCDNValueDnSpace |
Public enumeration | GCDNValueDnType |
Public enumeration | GCValueValueType |


GCBooleanValue Class

GCBooleanValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCBooleanValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCBooleanValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCBooleanValue : GCValue
Public Class GCBooleanValue
    Inherits GCValue
public ref class GCBooleanValue : public GCValue
type GCBooleanValue =
    class
        inherit GCValue
    end

The GCBooleanValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property | BooleanValue
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCBooleanValue Fields

GCBooleanValue Fields

The GCBooleanValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCBooleanValue Methods

GCBooleanValue Methods

The GCBooleanValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCBooleanValue.cloneValue Method

GCBooleanValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCBooleanValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCBooleanValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCBooleanValue.cloneValue(System.String)"]

See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCBooleanValue.parseValue Method

GCBooleanValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCBooleanValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCBooleanValue.parseValue(System.String)"]

See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCBooleanValue Properties

GCBooleanValue Properties

The GCBooleanValue type exposes the following members.

Properties
Name | Description
Public property | BooleanValue
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCBooleanValue.BooleanValue Property

GCBooleanValueBooleanValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCBooleanValue.BooleanValue"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BooleanValue { get; set; }
Public Overridable Property BooleanValue As Boolean
    Get
    Set
public:
virtual property bool BooleanValue {
    bool get ();
    void set (bool value);
}
abstract BooleanValue : bool with get, set
override BooleanValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCBooleanValue.Value Property

GCBooleanValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCBooleanValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCBooleanValue Class
DXMLBase.Gcv Namespace


GCDefinitions Class

GCDefinitions Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCDefinitions"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCList
DXMLBase.GcvGCDefinitions
DXMLBase.GcvShimParams

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCDefinitions : GCList,
    IConfigElement, IGCOwner
Public Class GCDefinitions
    Inherits GCList
    Implements IConfigElement, IGCOwner
public ref class GCDefinitions : public GCList,
    IConfigElement, IGCOwner
type GCDefinitions =
    class
        inherit GCList
        interface IConfigElement
        interface IGCOwner
    end

The GCDefinitions type exposes the following members.

Constructors
 | Name | Description
Public method | GCDefinitions | Initializes a new instance of the GCDefinitions class
Top
Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Inherited from GCList.)
Public method | apply(String) |
Public method | apply(XmlNode) |
Public method | checkAllowedType | (Overrides GCListcheckAllowedType(GCValueValueType).)
 | construct(XmlDocument) |
 | construct(XmlNode) |
 | construct(Byte, String) |
 | construct(XmlNode, GCDefinitions) |
 | construct(Byte, GCDefinitions, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCList.)
Public method | insertValue(GCValue, String) | (Inherited from GCList.)
Public method | isNameAllowed | (Inherited from GCList.)
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | merge |
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Inherited from GCList.)
Public method | removeValue(GCValue) | (Inherited from GCList.)
Public method | replaceValue | (Inherited from GCList.)
Public method | resetModified | (Inherited from GCList.)
Public method | toBytes |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml |
Public method | toXML |
Top
Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCDefinitions Constructor

GCDefinitions Constructor
Initializes a new instance of the GCDefinitions class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCDefinitions()
Public Sub New
public:
GCDefinitions()
new : unit -> GCDefinitions
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions Fields

GCDefinitions Fields

The GCDefinitions type exposes the following members.

Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions Methods

GCDefinitions Methods

The GCDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Inherited from GCList.)
Public method | apply(String) |
Public method | apply(XmlNode) |
Public method | checkAllowedType | (Overrides GCListcheckAllowedType(GCValueValueType).)
 | construct(XmlDocument) |
 | construct(XmlNode) |
 | construct(Byte, String) |
 | construct(XmlNode, GCDefinitions) |
 | construct(Byte, GCDefinitions, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCList.)
Public method | insertValue(GCValue, String) | (Inherited from GCList.)
Public method | isNameAllowed | (Inherited from GCList.)
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | merge |
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Inherited from GCList.)
Public method | removeValue(GCValue) | (Inherited from GCList.)
Public method | replaceValue | (Inherited from GCList.)
Public method | resetModified | (Inherited from GCList.)
Public method | toBytes |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml |
Public method | toXML |
Top
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.apply Method

GCDefinitionsapply Method
Overload List
 | Name | Description
Public method | apply(String) |
Public method | apply(XmlNode) |
Top
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.apply Method (String[])

GCDefinitionsapply Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.apply(System.String[])"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool apply(
    string[] target
)
Public Overridable Function apply (
    target As String()
) As Boolean
public:
virtual bool apply(
    array<String^>^ target
)
abstract apply :
        target : string[] -> bool
override apply :
        target : string[] -> bool

Parameters

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.apply(System.String[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.apply(System.String[])"]

See Also

Reference

GCDefinitions Class
apply Overload
DXMLBase.Gcv Namespace


GCDefinitions.apply Method (XmlNode)

GCDefinitionsapply Method (XmlNode)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.apply(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool apply(
    XmlNode target
)
Public Overridable Function apply (
    target As XmlNode
) As Boolean
public:
virtual bool apply(
    XmlNode^ target
)
abstract apply :
        target : XmlNode -> bool
override apply :
        target : XmlNode -> bool

Parameters

target
Type: System.XmlXmlNode

[Missing <param name="target"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.apply(System.Xml.XmlNode)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.apply(System.Xml.XmlNode)"]

See Also

Reference

GCDefinitions Class
apply Overload
DXMLBase.Gcv Namespace


GCDefinitions.checkAllowedType Method

GCDefinitionscheckAllowedType Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool checkAllowedType(
    GCValueValueType type
)
Public Overrides Function checkAllowedType (
    type As GCValueValueType
) As Boolean
public:
virtual bool checkAllowedType(
    GCValueValueType type
) override
abstract checkAllowedType :
        type : GCValueValueType -> bool
override checkAllowedType :
        type : GCValueValueType -> bool

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Implements

IGCOwnercheckAllowedType(GCValueValueType)
IGCOwnercheckAllowedType(GCValueValueType)
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.construct Method

GCDefinitionsconstruct Method
Overload List
Name | Description
construct(XmlDocument) |
construct(XmlNode) |
construct(Byte, String) |
construct(XmlNode, GCDefinitions) |
construct(Byte, GCDefinitions, String) |
Top
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.construct Method (XmlDocument)

GCDefinitionsconstruct Method (XmlDocument)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlDocument)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCDefinitions construct(
    XmlDocument document
)
Public Shared Function construct (
    document As XmlDocument
) As GCDefinitions
public:
static GCDefinitions^ construct(
    XmlDocument^ document
)
static member construct :
        document : XmlDocument -> GCDefinitions

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlDocument)"]

Return Value

Type: GCDefinitions

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlDocument)"]

See Also

Reference

GCDefinitions Class
construct Overload
DXMLBase.Gcv Namespace


GCDefinitions.construct Method (XmlNode)

GCDefinitionsconstruct Method (XmlNode)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCDefinitions construct(
    XmlNode parent
)
Public Shared Function construct (
    parent As XmlNode
) As GCDefinitions
public:
static GCDefinitions^ construct(
    XmlNode^ parent
)
static member construct :
        parent : XmlNode -> GCDefinitions

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode)"]

Return Value

Type: GCDefinitions

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode)"]

See Also

Reference

GCDefinitions Class
construct Overload
DXMLBase.Gcv Namespace


GCDefinitions.construct Method (Byte[], String)

GCDefinitionsconstruct Method (Byte, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCDefinitions construct(
    byte[] bytes,
    string baseURI
)
Public Shared Function construct (
    bytes As Byte(),
    baseURI As String
) As GCDefinitions
public:
static GCDefinitions^ construct(
    array<unsigned char>^ bytes,
    String^ baseURI
)
static member construct :
        bytes : byte[] *
        baseURI : string -> GCDefinitions

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],System.String)"]

baseURI
Type: SystemString

[Missing <param name="baseURI"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],System.String)"]

Return Value

Type: GCDefinitions

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],System.String)"]

See Also

Reference

GCDefinitions Class
construct Overload
DXMLBase.Gcv Namespace


GCDefinitions.construct Method (XmlNode, GCDefinitions)

GCDefinitionsconstruct Method (XmlNode, GCDefinitions)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode,DXMLBase.Gcv.GCDefinitions)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static GCDefinitions construct(
    XmlNode parent,
    GCDefinitions definitions
)
Protected Shared Function construct (
    parent As XmlNode,
    definitions As GCDefinitions
) As GCDefinitions
protected:
static GCDefinitions^ construct(
    XmlNode^ parent,
    GCDefinitions^ definitions
)
static member construct :
        parent : XmlNode *
        definitions : GCDefinitions -> GCDefinitions

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode,DXMLBase.Gcv.GCDefinitions)"]

definitions
Type: DXMLBase.GcvGCDefinitions

[Missing <param name="definitions"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode,DXMLBase.Gcv.GCDefinitions)"]

Return Value

Type: GCDefinitions

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Xml.XmlNode,DXMLBase.Gcv.GCDefinitions)"]

See Also

Reference

GCDefinitions Class
construct Overload
DXMLBase.Gcv Namespace


GCDefinitions.construct Method (Byte[], GCDefinitions, String)

GCDefinitionsconstruct Method (Byte, GCDefinitions, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],DXMLBase.Gcv.GCDefinitions,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static GCDefinitions construct(
    byte[] bytes,
    GCDefinitions definitions,
    string baseURI
)
Protected Shared Function construct (
    bytes As Byte(),
    definitions As GCDefinitions,
    baseURI As String
) As GCDefinitions
protected:
static GCDefinitions^ construct(
    array<unsigned char>^ bytes,
    GCDefinitions^ definitions,
    String^ baseURI
)
static member construct :
        bytes : byte[] *
        definitions : GCDefinitions *
        baseURI : string -> GCDefinitions

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],DXMLBase.Gcv.GCDefinitions,System.String)"]

definitions
Type: DXMLBase.GcvGCDefinitions

[Missing <param name="definitions"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],DXMLBase.Gcv.GCDefinitions,System.String)"]

baseURI
Type: SystemString

[Missing <param name="baseURI"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],DXMLBase.Gcv.GCDefinitions,System.String)"]

Return Value

Type: GCDefinitions

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.construct(System.Byte[],DXMLBase.Gcv.GCDefinitions,System.String)"]

See Also

Reference

GCDefinitions Class
construct Overload
DXMLBase.Gcv Namespace


GCDefinitions.localize Method

GCDefinitionslocalize Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.localize(DXMLBase.LocalizedMessageSource)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void localize(
    LocalizedMessageSource messageSource
)
Public Overridable Sub localize (
    messageSource As LocalizedMessageSource
)
public:
virtual void localize(
    LocalizedMessageSource^ messageSource
)
abstract localize :
        messageSource : LocalizedMessageSource -> unit
override localize :
        messageSource : LocalizedMessageSource -> unit

Parameters

messageSource
Type: DXMLBaseLocalizedMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.localize(DXMLBase.LocalizedMessageSource)"]

See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.merge Method

GCDefinitionsmerge Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.merge(DXMLBase.Gcv.GCDefinitions)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void merge(
    GCDefinitions other
)
Public Overridable Sub merge (
    other As GCDefinitions
)
public:
virtual void merge(
    GCDefinitions^ other
)
abstract merge :
        other : GCDefinitions -> unit
override merge :
        other : GCDefinitions -> unit

Parameters

other
Type: DXMLBase.GcvGCDefinitions

[Missing <param name="other"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.merge(DXMLBase.Gcv.GCDefinitions)"]

See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.toBytes Method

GCDefinitionstoBytes Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.toBytes"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual byte[] toBytes()
Public Overridable Function toBytes As Byte()
public:
virtual array<unsigned char>^ toBytes()
abstract toBytes : unit -> byte[]
override toBytes : unit -> byte[]

Return Value

Type: Byte

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.toBytes"]

See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.toXml Method

GCDefinitionstoXml Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.toXml"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlDocument toXml()
Public Overridable Function toXml As XmlDocument
public:
virtual XmlDocument^ toXml()
abstract toXml : unit -> XmlDocument
override toXml : unit -> XmlDocument

Return Value

Type: XmlDocument

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.toXml"]

See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions.toXML Method

GCDefinitionstoXML Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDefinitions.toXML(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement toXML(
    XmlNode parent
)
Public Overridable Function toXML (
    parent As XmlNode
) As XmlElement
public:
virtual XmlElement^ toXML(
    XmlNode^ parent
)
abstract toXML :
        parent : XmlNode -> XmlElement
override toXML :
        parent : XmlNode -> XmlElement

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.GCDefinitions.toXML(System.Xml.XmlNode)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDefinitions.toXML(System.Xml.XmlNode)"]

Implements

IConfigElementtoXML(XmlNode)
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDefinitions Properties

GCDefinitions Properties

The GCDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Top
See Also

Reference

GCDefinitions Class
DXMLBase.Gcv Namespace


GCDnRefValue Class

GCDnRefValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCDnRefValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCDnRefValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCDnRefValue : GCValue
Public Class GCDnRefValue
    Inherits GCValue
public ref class GCDnRefValue : public GCValue
type GCDnRefValue =
    class
        inherit GCValue
    end

The GCDnRefValue type exposes the following members.

Constructors
 | Name | Description
Public method | GCDnRefValue | Initializes a new instance of the GCDnRefValue class
Top
Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property | AttrName
Public property | AuxClassName
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCDnRefValue Constructor

GCDnRefValue Constructor
Initializes a new instance of the GCDnRefValue class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCDnRefValue(
    string name
)
Public Sub New (
    name As String
)
public:
GCDnRefValue(
    String^ name
)
new :
        name : string -> GCDnRefValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCDnRefValue.#ctor(System.String)"]

See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue Fields

GCDnRefValue Fields

The GCDnRefValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue Methods

GCDnRefValue Methods

The GCDnRefValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue.cloneValue Method

GCDnRefValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDnRefValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCDnRefValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDnRefValue.cloneValue(System.String)"]

See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue.parseValue Method

GCDnRefValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDnRefValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value_Renamed
)
Public Overrides Sub parseValue (
    value_Renamed As String
)
public:
virtual void parseValue(
    String^ value_Renamed
) override
abstract parseValue :
        value_Renamed : string -> unit
override parseValue :
        value_Renamed : string -> unit

Parameters

value_Renamed
Type: SystemString

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCDnRefValue.parseValue(System.String)"]

See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue Properties

GCDnRefValue Properties

The GCDnRefValue type exposes the following members.

Properties
Name | Description
Public property | AttrName
Public property | AuxClassName
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue.AttrName Property

GCDnRefValueAttrName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCDnRefValue.AttrName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string AttrName { get; set; }
Public Overridable Property AttrName As String
    Get
    Set
public:
virtual property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
abstract AttrName : string with get, set
override AttrName : string with get, set

Property Value

Type: String
See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue.AuxClassName Property

GCDnRefValueAuxClassName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCDnRefValue.AuxClassName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string AuxClassName { get; set; }
Public Overridable Property AuxClassName As String
    Get
    Set
public:
virtual property String^ AuxClassName {
    String^ get ();
    void set (String^ value);
}
abstract AuxClassName : string with get, set
override AuxClassName : string with get, set

Property Value

Type: String
See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDnRefValue.Value Property

GCDnRefValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCDnRefValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCDnRefValue Class
DXMLBase.Gcv Namespace


GCDNValue Class

GCDNValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCDNValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCDNValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCDNValue : GCValue
Public Class GCDNValue
    Inherits GCValue
public ref class GCDNValue : public GCValue
type GCDNValue =
    class
        inherit GCValue
    end

The GCDNValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
Name | Description
MIN_DELIMS_LENGTH
Length of delimiter string for
Copy
"custom"
DN type.
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property | CustomDNType
Public property | Delims
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property DNSpace
Get or set the enum corresponding to the DN space for this value.
Public property DNType
Get or set the enum value corresponding to DN type.
Public property DNTypeString
Get the string representing the DN type.
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCDNValue Fields

GCDNValue Fields

The GCDNValue type exposes the following members.

Fields
Name | Description
MIN_DELIMS_LENGTH
Length of delimiter string for
Copy
"custom"
DN type.
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.MIN_DELIMS_LENGTH Field

GCDNValueMIN_DELIMS_LENGTH Field
Length of delimiter string for
Copy
"custom"
DN type.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int MIN_DELIMS_LENGTH
Public Const MIN_DELIMS_LENGTH As Integer
public:
literal int MIN_DELIMS_LENGTH
static val mutable MIN_DELIMS_LENGTH: int

Field Value

Type: Int32
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue Methods

GCDNValue Methods

The GCDNValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.cloneValue Method

GCDNValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDNValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCDNValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCDNValue.cloneValue(System.String)"]

See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.parseValue Method

GCDNValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCDNValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value_Renamed
)
Public Overrides Sub parseValue (
    value_Renamed As String
)
public:
virtual void parseValue(
    String^ value_Renamed
) override
abstract parseValue :
        value_Renamed : string -> unit
override parseValue :
        value_Renamed : string -> unit

Parameters

value_Renamed
Type: SystemString

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCDNValue.parseValue(System.String)"]

See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue Properties

GCDNValue Properties

The GCDNValue type exposes the following members.

Properties
Name | Description
Public property | CustomDNType
Public property | Delims
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property DNSpace
Get or set the enum corresponding to the DN space for this value.
Public property DNType
Get or set the enum value corresponding to DN type.
Public property DNTypeString
Get the string representing the DN type.
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.CustomDNType Property

GCDNValueCustomDNType Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCDNValue.CustomDNType"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string CustomDNType { set; }
Public Overridable WriteOnly Property CustomDNType As String
    Set
public:
virtual property String^ CustomDNType {
    void set (String^ value);
}
abstract CustomDNType : string with set
override CustomDNType : string with set

Property Value

Type: String
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.Delims Property

GCDNValueDelims Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCDNValue.Delims"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Delims { get; }
Public Overridable ReadOnly Property Delims As String
    Get
public:
virtual property String^ Delims {
    String^ get ();
}
abstract Delims : string with get
override Delims : string with get

Property Value

Type: String
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.DNSpace Property

GCDNValueDNSpace Property
Get or set the enum corresponding to the DN space for this value.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCDNValueDnSpace DNSpace { get; set; }
Public Overridable Property DNSpace As GCDNValueDnSpace
    Get
    Set
public:
virtual property GCDNValueDnSpace DNSpace {
    GCDNValueDnSpace get ();
    void set (GCDNValueDnSpace value);
}
abstract DNSpace : GCDNValueDnSpace with get, set
override DNSpace : GCDNValueDnSpace with get, set

Property Value

Type: GCDNValueDnSpace
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.DNType Property

GCDNValueDNType Property
Get or set the enum value corresponding to DN type.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCDNValueDnType DNType { get; set; }
Public Overridable Property DNType As GCDNValueDnType
    Get
    Set
public:
virtual property GCDNValueDnType DNType {
    GCDNValueDnType get ();
    void set (GCDNValueDnType value);
}
abstract DNType : GCDNValueDnType with get, set
override DNType : GCDNValueDnType with get, set

Property Value

Type: GCDNValueDnType
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.DNTypeString Property

GCDNValueDNTypeString Property
Get the string representing the DN type.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DNTypeString { get; }
Public Overridable ReadOnly Property DNTypeString As String
    Get
public:
virtual property String^ DNTypeString {
    String^ get ();
}
abstract DNTypeString : string with get
override DNTypeString : string with get

Property Value

Type: String
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.Value Property

GCDNValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCDNValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCDNValue Class
DXMLBase.Gcv Namespace


GCDNValue.DnSpace Enumeration

GCDNValueDnSpace Enumeration

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCDNValue.DnSpace"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DnSpace
Public Enumeration DnSpace
public enum class DnSpace
type DnSpace
Members
Member name | Value | Description
DN_SPACE_UNSPECIFIED | -1 | Integer constant indicating DN space isn't specified.
DN_SPACE_DIRXML 0 Integer constant representing DN space
Copy
"dirxml"
.
DN_SPACE_APPLICATION 1 Integer constant representing DN space
Copy
"application"
.
See Also

Reference

DXMLBase.Gcv Namespace


GCDNValue.DnType Enumeration

GCDNValueDnType Enumeration

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCDNValue.DnType"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DnType
Public Enumeration DnType
public enum class DnType
type DnType
Members
Member name | Value | Description
DN_TYPE_INVALID | -1
DN_TYPE_LDAP 0 Integer constant representing DN type
Copy
"ldap"
.
DN_TYPE_SLASH 1 Integer constant representing DN type
Copy
"slash"
.
DN_TYPE_QSLASH 2 Integer constant representing DN type
Copy
"qualified-slash"
.
DN_TYPE_DOT 3 Integer constant representing DN type
Copy
"dot"
.
DN_TYPE_QDOT 4 Integer constant representing DN type
Copy
"qualified-dot"
.
DN_TYPE_CUSTOM 5 Integer constant representing DN type
Copy
"custom"
.
See Also

Reference

DXMLBase.Gcv Namespace


GCEnumValue Class

GCEnumValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCEnumValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCEnumValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCEnumValue : GCValue
Public Class GCEnumValue
    Inherits GCValue
public ref class GCEnumValue : public GCValue
type GCEnumValue =
    class
        inherit GCValue
    end

The GCEnumValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendEnumChoice(GCEnumValueEnumChoice) |
Public method | appendEnumChoice(String, String) |
Public method | appendEnumChoice(String, String, String) |
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getEnumChoice |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Overrides GCValuehasBeenModified.)
Public method | insertEnumChoice(GCEnumValueEnumChoice, GCEnumValueEnumChoice) |
Public method | insertEnumChoice(String, String, String) |
Public method | insertEnumChoice(String, String, String, String) |
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | removeEnumChoice(String) |
Public method | removeEnumChoice(GCEnumValueEnumChoice) |
Public method | resetModified | (Overrides GCValueresetModified.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property | EnumChoices
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCEnumValue Fields

GCEnumValue Fields

The GCEnumValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue Methods

GCEnumValue Methods

The GCEnumValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendEnumChoice(GCEnumValueEnumChoice) |
Public method | appendEnumChoice(String, String) |
Public method | appendEnumChoice(String, String, String) |
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getEnumChoice |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Overrides GCValuehasBeenModified.)
Public method | insertEnumChoice(GCEnumValueEnumChoice, GCEnumValueEnumChoice) |
Public method | insertEnumChoice(String, String, String) |
Public method | insertEnumChoice(String, String, String, String) |
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | removeEnumChoice(String) |
Public method | removeEnumChoice(GCEnumValueEnumChoice) |
Public method | resetModified | (Overrides GCValueresetModified.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.appendEnumChoice Method

GCEnumValueappendEnumChoice Method
Overload List
 | Name | Description
Public method | appendEnumChoice(GCEnumValueEnumChoice) |
Public method | appendEnumChoice(String, String) |
Public method | appendEnumChoice(String, String, String) |
Top
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.appendEnumChoice Method (GCEnumValue.EnumChoice)

GCEnumValueappendEnumChoice Method (GCEnumValueEnumChoice)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void appendEnumChoice(
    GCEnumValueEnumChoice enumChoice
)
Public Overridable Sub appendEnumChoice (
    enumChoice As GCEnumValueEnumChoice
)
public:
virtual void appendEnumChoice(
    GCEnumValueEnumChoice^ enumChoice
)
abstract appendEnumChoice :
        enumChoice : GCEnumValueEnumChoice -> unit
override appendEnumChoice :
        enumChoice : GCEnumValueEnumChoice -> unit

Parameters

enumChoice
Type: DXMLBase.GcvGCEnumValueEnumChoice

[Missing <param name="enumChoice"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

See Also

Reference

GCEnumValue Class
appendEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.appendEnumChoice Method (String, String)

GCEnumValueappendEnumChoice Method (String, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void appendEnumChoice(
    string enumString,
    string displayName
)
Public Overridable Sub appendEnumChoice (
    enumString As String,
    displayName As String
)
public:
virtual void appendEnumChoice(
    String^ enumString,
    String^ displayName
)
abstract appendEnumChoice :
        enumString : string *
        displayName : string -> unit
override appendEnumChoice :
        enumString : string *
        displayName : string -> unit

Parameters

enumString
Type: SystemString

[Missing <param name="enumString"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String)"]

See Also

Reference

GCEnumValue Class
appendEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.appendEnumChoice Method (String, String, String)

GCEnumValueappendEnumChoice Method (String, String, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void appendEnumChoice(
    string enumString,
    string displayName,
    string displayNameRef
)
Public Overridable Sub appendEnumChoice (
    enumString As String,
    displayName As String,
    displayNameRef As String
)
public:
virtual void appendEnumChoice(
    String^ enumString,
    String^ displayName,
    String^ displayNameRef
)
abstract appendEnumChoice :
        enumString : string *
        displayName : string *
        displayNameRef : string -> unit
override appendEnumChoice :
        enumString : string *
        displayName : string *
        displayNameRef : string -> unit

Parameters

enumString
Type: SystemString

[Missing <param name="enumString"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String,System.String)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String,System.String)"]

displayNameRef
Type: SystemString

[Missing <param name="displayNameRef"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.appendEnumChoice(System.String,System.String,System.String)"]

See Also

Reference

GCEnumValue Class
appendEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.cloneValue Method

GCEnumValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.cloneValue(System.String)"]

See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.getEnumChoice Method

GCEnumValuegetEnumChoice Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.getEnumChoice(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCEnumValueEnumChoice getEnumChoice(
    string enumString
)
Public Overridable Function getEnumChoice (
    enumString As String
) As GCEnumValueEnumChoice
public:
virtual GCEnumValueEnumChoice^ getEnumChoice(
    String^ enumString
)
abstract getEnumChoice :
        enumString : string -> GCEnumValueEnumChoice
override getEnumChoice :
        enumString : string -> GCEnumValueEnumChoice

Parameters

enumString
Type: SystemString

[Missing <param name="enumString"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.getEnumChoice(System.String)"]

Return Value

Type: GCEnumValueEnumChoice

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.getEnumChoice(System.String)"]

See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.hasBeenModified Method

GCEnumValuehasBeenModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.hasBeenModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool hasBeenModified()
Public Overrides Function hasBeenModified As Boolean
public:
virtual bool hasBeenModified() override
abstract hasBeenModified : unit -> bool
override hasBeenModified : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.hasBeenModified"]

Implements

IConfigElementhasBeenModified
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.insertEnumChoice Method

GCEnumValueinsertEnumChoice Method
Overload List
 | Name | Description
Public method | insertEnumChoice(GCEnumValueEnumChoice, GCEnumValueEnumChoice) |
Public method | insertEnumChoice(String, String, String) |
Public method | insertEnumChoice(String, String, String, String) |
Top
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.insertEnumChoice Method (GCEnumValue.EnumChoice, GCEnumValue.EnumChoice)

GCEnumValueinsertEnumChoice Method (GCEnumValueEnumChoice, GCEnumValueEnumChoice)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice,DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertEnumChoice(
    GCEnumValueEnumChoice enumChoice,
    GCEnumValueEnumChoice insertionPoint
)
Public Overridable Sub insertEnumChoice (
    enumChoice As GCEnumValueEnumChoice,
    insertionPoint As GCEnumValueEnumChoice
)
public:
virtual void insertEnumChoice(
    GCEnumValueEnumChoice^ enumChoice,
    GCEnumValueEnumChoice^ insertionPoint
)
abstract insertEnumChoice :
        enumChoice : GCEnumValueEnumChoice *
        insertionPoint : GCEnumValueEnumChoice -> unit
override insertEnumChoice :
        enumChoice : GCEnumValueEnumChoice *
        insertionPoint : GCEnumValueEnumChoice -> unit

Parameters

enumChoice
Type: DXMLBase.GcvGCEnumValueEnumChoice

[Missing <param name="enumChoice"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice,DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

insertionPoint
Type: DXMLBase.GcvGCEnumValueEnumChoice

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice,DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

See Also

Reference

GCEnumValue Class
insertEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.insertEnumChoice Method (String, String, String)

GCEnumValueinsertEnumChoice Method (String, String, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertEnumChoice(
    string enumString,
    string displayName,
    string insertionPoint
)
Public Overridable Sub insertEnumChoice (
    enumString As String,
    displayName As String,
    insertionPoint As String
)
public:
virtual void insertEnumChoice(
    String^ enumString,
    String^ displayName,
    String^ insertionPoint
)
abstract insertEnumChoice :
        enumString : string *
        displayName : string *
        insertionPoint : string -> unit
override insertEnumChoice :
        enumString : string *
        displayName : string *
        insertionPoint : string -> unit

Parameters

enumString
Type: SystemString

[Missing <param name="enumString"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String)"]

insertionPoint
Type: SystemString

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String)"]

See Also

Reference

GCEnumValue Class
insertEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.insertEnumChoice Method (String, String, String, String)

GCEnumValueinsertEnumChoice Method (String, String, String, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertEnumChoice(
    string enumString,
    string displayName,
    string displayNameRef,
    string insertionPoint
)
Public Overridable Sub insertEnumChoice (
    enumString As String,
    displayName As String,
    displayNameRef As String,
    insertionPoint As String
)
public:
virtual void insertEnumChoice(
    String^ enumString,
    String^ displayName,
    String^ displayNameRef,
    String^ insertionPoint
)
abstract insertEnumChoice :
        enumString : string *
        displayName : string *
        displayNameRef : string *
        insertionPoint : string -> unit
override insertEnumChoice :
        enumString : string *
        displayName : string *
        displayNameRef : string *
        insertionPoint : string -> unit

Parameters

enumString
Type: SystemString

[Missing <param name="enumString"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String,System.String)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String,System.String)"]

displayNameRef
Type: SystemString

[Missing <param name="displayNameRef"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String,System.String)"]

insertionPoint
Type: SystemString

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.insertEnumChoice(System.String,System.String,System.String,System.String)"]

See Also

Reference

GCEnumValue Class
insertEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.localize Method

GCEnumValuelocalize Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.localize(DXMLBase.LocalizedMessageSource)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void localize(
    LocalizedMessageSource messageSource
)
Public Overridable Sub localize (
    messageSource As LocalizedMessageSource
)
public:
virtual void localize(
    LocalizedMessageSource^ messageSource
)
abstract localize :
        messageSource : LocalizedMessageSource -> unit
override localize :
        messageSource : LocalizedMessageSource -> unit

Parameters

messageSource
Type: DXMLBaseLocalizedMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.localize(DXMLBase.LocalizedMessageSource)"]

See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.parseValue Method

GCEnumValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.parseValue(System.String)"]

See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.removeEnumChoice Method

GCEnumValueremoveEnumChoice Method
Overload List
 | Name | Description
Public method | removeEnumChoice(String) |
Public method | removeEnumChoice(GCEnumValueEnumChoice) |
Top
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.removeEnumChoice Method (String)

GCEnumValueremoveEnumChoice Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.removeEnumChoice(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeEnumChoice(
    string enumValue
)
Public Overridable Function removeEnumChoice (
    enumValue As String
) As Boolean
public:
virtual bool removeEnumChoice(
    String^ enumValue
)
abstract removeEnumChoice :
        enumValue : string -> bool
override removeEnumChoice :
        enumValue : string -> bool

Parameters

enumValue
Type: SystemString

[Missing <param name="enumValue"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.removeEnumChoice(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.removeEnumChoice(System.String)"]

See Also

Reference

GCEnumValue Class
removeEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.removeEnumChoice Method (GCEnumValue.EnumChoice)

GCEnumValueremoveEnumChoice Method (GCEnumValueEnumChoice)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.removeEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeEnumChoice(
    GCEnumValueEnumChoice enumChoice
)
Public Overridable Function removeEnumChoice (
    enumChoice As GCEnumValueEnumChoice
) As Boolean
public:
virtual bool removeEnumChoice(
    GCEnumValueEnumChoice^ enumChoice
)
abstract removeEnumChoice :
        enumChoice : GCEnumValueEnumChoice -> bool
override removeEnumChoice :
        enumChoice : GCEnumValueEnumChoice -> bool

Parameters

enumChoice
Type: DXMLBase.GcvGCEnumValueEnumChoice

[Missing <param name="enumChoice"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.removeEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.removeEnumChoice(DXMLBase.Gcv.GCEnumValue.EnumChoice)"]

See Also

Reference

GCEnumValue Class
removeEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.resetModified Method

GCEnumValueresetModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.resetModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void resetModified()
Public Overrides Sub resetModified
public:
virtual void resetModified() override
abstract resetModified : unit -> unit
override resetModified : unit -> unit

Implements

IConfigElementresetModified
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue Properties

GCEnumValue Properties

The GCEnumValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property | EnumChoices
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoices Property

GCEnumValueEnumChoices Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCEnumValue.EnumChoices"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<GCEnumValueEnumChoice> EnumChoices { get; }
Public ReadOnly Property EnumChoices As IEnumerable(Of GCEnumValueEnumChoice)
    Get
public:
property IEnumerable<GCEnumValueEnumChoice^>^ EnumChoices {
    IEnumerable<GCEnumValueEnumChoice^>^ get ();
}
member EnumChoices : IEnumerable<GCEnumValueEnumChoice> with get

Property Value

Type: IEnumerable GCEnumValueEnumChoice
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.Value Property

GCEnumValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCEnumValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCEnumValue Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice Class

GCEnumValueEnumChoice Class
Class representing a single enum choice.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCEnumValueEnumChoice

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnumChoice : IComparable
Public Class EnumChoice
    Implements IComparable
public ref class EnumChoice : IComparable
type EnumChoice =
    class
        interface IComparable
    end

The GCEnumValueEnumChoice type exposes the following members.

Constructors
 | Name | Description
Public method | GCEnumValueEnumChoice(String, String) | Initializes a new instance of the GCEnumValueEnumChoice class
Public method | GCEnumValueEnumChoice(String, String, String) | Initializes a new instance of the GCEnumValueEnumChoice class
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasBeenModified |
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | resetModified |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayName |
Public property | DisplayNameRef |
Public property | Value |
Top
See Also

Reference

DXMLBase.Gcv Namespace


EnumChoice Constructor

EnumChoice Constructor
Overload List
 | Name | Description
Public method | GCEnumValueEnumChoice(String, String) | Initializes a new instance of the GCEnumValueEnumChoice class
Public method | GCEnumValueEnumChoice(String, String, String) | Initializes a new instance of the GCEnumValueEnumChoice class
Top
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice Constructor (String, String)

GCEnumValueEnumChoice Constructor (String, String)
Initializes a new instance of the GCEnumValueEnumChoice class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnumChoice(
    string value,
    string displayName
)
Public Sub New (
    value As String,
    displayName As String
)
public:
EnumChoice(
    String^ value,
    String^ displayName
)
new :
        value : string *
        displayName : string -> EnumChoice

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.#ctor(System.String,System.String)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.#ctor(System.String,System.String)"]

See Also

Reference

GCEnumValueEnumChoice Class
GCEnumValueEnumChoice Overload
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice Constructor (String, String, String)

GCEnumValueEnumChoice Constructor (String, String, String)
Initializes a new instance of the GCEnumValueEnumChoice class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnumChoice(
    string value,
    string displayName,
    string displayNameRef
)
Public Sub New (
    value As String,
    displayName As String,
    displayNameRef As String
)
public:
EnumChoice(
    String^ value,
    String^ displayName,
    String^ displayNameRef
)
new :
        value : string *
        displayName : string *
        displayNameRef : string -> EnumChoice

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.#ctor(System.String,System.String,System.String)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.#ctor(System.String,System.String,System.String)"]

displayNameRef
Type: SystemString

[Missing <param name="displayNameRef"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.#ctor(System.String,System.String,System.String)"]

See Also

Reference

GCEnumValueEnumChoice Class
GCEnumValueEnumChoice Overload
DXMLBase.Gcv Namespace


EnumChoice Methods

EnumChoice Methods

The GCEnumValueEnumChoice type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasBeenModified |
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | resetModified |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.CompareTo Method

GCEnumValueEnumChoiceCompareTo Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.CompareTo(System.Object)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CompareTo(
    Object o
)
Public Overridable Function CompareTo (
    o As Object
) As Integer
public:
virtual int CompareTo(
    Object^ o
)
abstract CompareTo :
        o : Object -> int
override CompareTo :
        o : Object -> int

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.Equals Method

GCEnumValueEnumChoiceEquals Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.Equals(System.Object)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.Equals(System.Object)"]

See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.GetHashCode Method

GCEnumValueEnumChoiceGetHashCode Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.GetHashCode"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.GetHashCode"]

See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.hasBeenModified Method

GCEnumValueEnumChoicehasBeenModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.hasBeenModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool hasBeenModified()
Public Overridable Function hasBeenModified As Boolean
public:
virtual bool hasBeenModified()
abstract hasBeenModified : unit -> bool
override hasBeenModified : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.hasBeenModified"]

See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.localize Method

GCEnumValueEnumChoicelocalize Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.localize(DXMLBase.LocalizedMessageSource)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void localize(
    LocalizedMessageSource messageSource
)
Public Overridable Sub localize (
    messageSource As LocalizedMessageSource
)
public:
virtual void localize(
    LocalizedMessageSource^ messageSource
)
abstract localize :
        messageSource : LocalizedMessageSource -> unit
override localize :
        messageSource : LocalizedMessageSource -> unit

Parameters

messageSource
Type: DXMLBaseLocalizedMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.localize(DXMLBase.LocalizedMessageSource)"]

See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.resetModified Method

GCEnumValueEnumChoiceresetModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCEnumValue.EnumChoice.resetModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void resetModified()
Public Overridable Sub resetModified
public:
virtual void resetModified()
abstract resetModified : unit -> unit
override resetModified : unit -> unit
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


EnumChoice Properties

EnumChoice Properties

The GCEnumValueEnumChoice type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | DisplayNameRef |
Public property | Value |
Top
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.DisplayName Property

GCEnumValueEnumChoiceDisplayName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCEnumValue.EnumChoice.DisplayName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DisplayName { get; }
Public Overridable ReadOnly Property DisplayName As String
    Get
public:
virtual property String^ DisplayName {
    String^ get ();
}
abstract DisplayName : string with get
override DisplayName : string with get

Property Value

Type: String
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.DisplayNameRef Property

GCEnumValueEnumChoiceDisplayNameRef Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCEnumValue.EnumChoice.DisplayNameRef"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DisplayNameRef { get; }
Public Overridable ReadOnly Property DisplayNameRef As String
    Get
public:
virtual property String^ DisplayNameRef {
    String^ get ();
}
abstract DisplayNameRef : string with get
override DisplayNameRef : string with get

Property Value

Type: String
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCEnumValue.EnumChoice.Value Property

GCEnumValueEnumChoiceValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCEnumValue.EnumChoice.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Value { get; }
Public Overridable ReadOnly Property Value As String
    Get
public:
virtual property String^ Value {
    String^ get ();
}
abstract Value : string with get
override Value : string with get

Property Value

Type: String
See Also

Reference

GCEnumValueEnumChoice Class
DXMLBase.Gcv Namespace


GCGroup Class

GCGroup Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCGroup"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCParent
DXMLBase.GcvGCGroup

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCGroup : GCParent
Public Class GCGroup
    Inherits GCParent
public ref class GCGroup : public GCParent
type GCGroup =
    class
        inherit GCParent
    end

The GCGroup type exposes the following members.

Constructors
 | Name | Description
Protected method | GCGroup(IGCOwner) | Initializes a new instance of the GCGroup class
Protected method | GCGroup(XmlElement, IGCOwner) | Initializes a new instance of the GCGroup class
Top
Methods
 | Name | Description
Public method | addName | (Inherited from GCParent.)
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendValue | (Inherited from GCParent.)
Public method | checkAllowedType | (Inherited from GCParent.)
Protected method | cloneCommon | (Inherited from GCParent.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCParent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCParent.)
Public method | insertValue(GCValue, String) | (Inherited from GCParent.)
Public method | isNameAllowed | (Inherited from GCParent.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Inherited from GCParent.)
Public method | removeName | (Inherited from GCParent.)
Public method | removeValue(String) | (Inherited from GCParent.)
Public method | removeValue(GCValue) | (Inherited from GCParent.)
Public method | replaceValue | (Inherited from GCParent.)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | cloning | (Inherited from GCParent.)
Protected field | modified | (Inherited from GCValue.)
Protected field | owner | (Inherited from GCParent.)
Top
Properties
Name | Description
Public property | Children | (Inherited from GCParent.)
Public property | Descendants | (Inherited from GCParent.)
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | Leader
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Inherited from GCParent.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCGroup Constructor

GCGroup Constructor
Overload List
 | Name | Description
Protected method | GCGroup(IGCOwner) | Initializes a new instance of the GCGroup class
Protected method | GCGroup(XmlElement, IGCOwner) | Initializes a new instance of the GCGroup class
Top
See Also

Reference

GCGroup Class
DXMLBase.Gcv Namespace


GCGroup Constructor (IGCOwner)

GCGroup Constructor (IGCOwner)
Initializes a new instance of the GCGroup class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCGroup(
    IGCOwner owner
)
Protected Sub New (
    owner As IGCOwner
)
protected:
GCGroup(
    IGCOwner^ owner
)
new :
        owner : IGCOwner -> GCGroup

Parameters

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCGroup.#ctor(DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCGroup Class
GCGroup Overload
DXMLBase.Gcv Namespace


GCGroup Constructor (XmlElement, IGCOwner)

GCGroup Constructor (XmlElement, IGCOwner)
Initializes a new instance of the GCGroup class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCGroup(
    XmlElement definition,
    IGCOwner owner
)
Protected Sub New (
    definition As XmlElement,
    owner As IGCOwner
)
protected:
GCGroup(
    XmlElement^ definition,
    IGCOwner^ owner
)
new :
        definition : XmlElement *
        owner : IGCOwner -> GCGroup

Parameters

definition
Type: System.XmlXmlElement

[Missing <param name="definition"/> documentation for "M:DXMLBase.Gcv.GCGroup.#ctor(System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCGroup.#ctor(System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCGroup Class
GCGroup Overload
DXMLBase.Gcv Namespace


GCGroup Fields

GCGroup Fields

The GCGroup type exposes the following members.

Fields
 | Name | Description
Protected field | cloning | (Inherited from GCParent.)
Protected field | modified | (Inherited from GCValue.)
Protected field | owner | (Inherited from GCParent.)
Top
See Also

Reference

GCGroup Class
DXMLBase.Gcv Namespace


GCGroup Methods

GCGroup Methods

The GCGroup type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCParent.)
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendValue | (Inherited from GCParent.)
Public method | checkAllowedType | (Inherited from GCParent.)
Protected method | cloneCommon | (Inherited from GCParent.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCParent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCParent.)
Public method | insertValue(GCValue, String) | (Inherited from GCParent.)
Public method | isNameAllowed | (Inherited from GCParent.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Inherited from GCParent.)
Public method | removeName | (Inherited from GCParent.)
Public method | removeValue(String) | (Inherited from GCParent.)
Public method | removeValue(GCValue) | (Inherited from GCParent.)
Public method | replaceValue | (Inherited from GCParent.)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCGroup Class
DXMLBase.Gcv Namespace


GCGroup.cloneValue Method

GCGroupcloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCGroup.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCGroup.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCGroup.cloneValue(System.String)"]

See Also

Reference

GCGroup Class
DXMLBase.Gcv Namespace


GCGroup Properties

GCGroup Properties

The GCGroup type exposes the following members.

Properties
Name | Description
Public property | Children | (Inherited from GCParent.)
Public property | Descendants | (Inherited from GCParent.)
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | Leader
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Inherited from GCParent.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCGroup Class
DXMLBase.Gcv Namespace


GCGroup.Leader Property

GCGroupLeader Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCGroup.Leader"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCValue Leader { get; }
Public Overridable ReadOnly Property Leader As GCValue
    Get
public:
virtual property GCValue^ Leader {
    GCValue^ get ();
}
abstract Leader : GCValue with get
override Leader : GCValue with get

Property Value

Type: GCValue
See Also

Reference

GCGroup Class
DXMLBase.Gcv Namespace


GCHeader Class

GCHeader Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCHeader"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCHeader

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCHeader : GCValue
Public Class GCHeader
    Inherits GCValue
public ref class GCHeader : public GCValue
type GCHeader =
    class
        inherit GCValue
    end

The GCHeader type exposes the following members.

Constructors
 | Name | Description
Public method | GCHeader | Initializes a new instance of the GCHeader class
Top
Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCHeader Constructor

GCHeader Constructor
Initializes a new instance of the GCHeader class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCHeader()
Public Sub New
public:
GCHeader()
new : unit -> GCHeader
See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCHeader Fields

GCHeader Fields

The GCHeader type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCHeader Methods

GCHeader Methods

The GCHeader type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCHeader.cloneValue Method

GCHeadercloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCHeader.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCHeader.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCHeader.cloneValue(System.String)"]

See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCHeader.parseValue Method

GCHeaderparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCHeader.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value_Renamed
)
Public Overrides Sub parseValue (
    value_Renamed As String
)
public:
virtual void parseValue(
    String^ value_Renamed
) override
abstract parseValue :
        value_Renamed : string -> unit
override parseValue :
        value_Renamed : string -> unit

Parameters

value_Renamed
Type: SystemString

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCHeader.parseValue(System.String)"]

See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCHeader Properties

GCHeader Properties

The GCHeader type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCHeader.Value Property

GCHeaderValue Property
Override, does nothing.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCHeader Class
DXMLBase.Gcv Namespace


GCIntegerValue Class

GCIntegerValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCIntegerValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCIntegerValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCIntegerValue : GCValue
Public Class GCIntegerValue
    Inherits GCValue
public ref class GCIntegerValue : public GCValue
type GCIntegerValue =
    class
        inherit GCValue
    end

The GCIntegerValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | IntegerValue
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | RangeHi
Public property | RangeHiString
Public property | RangeLo
Public property | RangeLoString
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCIntegerValue Fields

GCIntegerValue Fields

The GCIntegerValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue Methods

GCIntegerValue Methods

The GCIntegerValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.cloneValue Method

GCIntegerValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCIntegerValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCIntegerValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCIntegerValue.cloneValue(System.String)"]

See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.parseValue Method

GCIntegerValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCIntegerValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCIntegerValue.parseValue(System.String)"]

See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue Properties

GCIntegerValue Properties

The GCIntegerValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | IntegerValue
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | RangeHi
Public property | RangeHiString
Public property | RangeLo
Public property | RangeLoString
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.IntegerValue Property

GCIntegerValueIntegerValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCIntegerValue.IntegerValue"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IntegerValue { get; }
Public Overridable ReadOnly Property IntegerValue As Integer
    Get
public:
virtual property int IntegerValue {
    int get ();
}
abstract IntegerValue : int with get
override IntegerValue : int with get

Property Value

Type: Int32
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.RangeHi Property

GCIntegerValueRangeHi Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCIntegerValue.RangeHi"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RangeHi { get; set; }
Public Overridable Property RangeHi As Integer
    Get
    Set
public:
virtual property int RangeHi {
    int get ();
    void set (int value);
}
abstract RangeHi : int with get, set
override RangeHi : int with get, set

Property Value

Type: Int32
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.RangeHiString Property

GCIntegerValueRangeHiString Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCIntegerValue.RangeHiString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string RangeHiString { get; set; }
Public Overridable Property RangeHiString As String
    Get
    Set
public:
virtual property String^ RangeHiString {
    String^ get ();
    void set (String^ value);
}
abstract RangeHiString : string with get, set
override RangeHiString : string with get, set

Property Value

Type: String
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.RangeLo Property

GCIntegerValueRangeLo Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCIntegerValue.RangeLo"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RangeLo { get; set; }
Public Overridable Property RangeLo As Integer
    Get
    Set
public:
virtual property int RangeLo {
    int get ();
    void set (int value);
}
abstract RangeLo : int with get, set
override RangeLo : int with get, set

Property Value

Type: Int32
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.RangeLoString Property

GCIntegerValueRangeLoString Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCIntegerValue.RangeLoString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string RangeLoString { get; set; }
Public Overridable Property RangeLoString As String
    Get
    Set
public:
virtual property String^ RangeLoString {
    String^ get ();
    void set (String^ value);
}
abstract RangeLoString : string with get, set
override RangeLoString : string with get, set

Property Value

Type: String
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCIntegerValue.Value Property

GCIntegerValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCIntegerValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCIntegerValue Class
DXMLBase.Gcv Namespace


GCList Class

GCList Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCList"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCList
DXMLBase.GcvGCDefinitions
DXMLBase.GcvGCStructuredValueInstance
DXMLBase.GcvGCStructuredValueTemplate

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCList : IGCOwner
Public Class GCList
    Implements IGCOwner
public ref class GCList : IGCOwner
type GCList =
    class
        interface IGCOwner
    end

The GCList type exposes the following members.

Methods
 | Name | Description
 | _construct |
Public method | addName |
Public method | appendValue |
Public method | checkAllowedType |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue |
Public method | hasBeenModified |
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Public method | isNameAllowed |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeName |
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Public method | replaceValue |
Public method | resetModified |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | defsList |
Protected field | modified |
Top
Properties
 | Name | Description
Public property | Children |
Public property | Descendants |
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCList Fields

GCList Fields

The GCList type exposes the following members.

Fields
 | Name | Description
Protected field | defsList |
Protected field | modified |
Top
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.defsList Field

GCListdefsList Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCList.defsList"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected List<GCValue> defsList
Protected defsList As List(Of GCValue)
protected:
List<GCValue^>^ defsList
val mutable defsList: List<GCValue>

Field Value

Type: List GCValue
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.modified Field

GCListmodified Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCList.modified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool modified
Protected modified As Boolean
protected:
bool modified
val mutable modified: bool

Field Value

Type: Boolean
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList Methods

GCList Methods

The GCList type exposes the following members.

Methods
 | Name | Description
 | _construct |
Public method | addName |
Public method | appendValue |
Public method | checkAllowedType |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue |
Public method | hasBeenModified |
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Public method | isNameAllowed |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeName |
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Public method | replaceValue |
Public method | resetModified |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList._construct Method

GCList_construct Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList._construct(System.Xml.XmlElement,DXMLBase.Gcv.GCList)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static GCList _construct(
    XmlElement element,
    GCList list
)
Protected Shared Function _construct (
    element As XmlElement,
    list As GCList
) As GCList
protected:
static GCList^ _construct(
    XmlElement^ element,
    GCList^ list
)
static member _construct :
        element : XmlElement *
        list : GCList -> GCList

Parameters

element
Type: System.XmlXmlElement

[Missing <param name="element"/> documentation for "M:DXMLBase.Gcv.GCList._construct(System.Xml.XmlElement,DXMLBase.Gcv.GCList)"]

list
Type: DXMLBase.GcvGCList

[Missing <param name="list"/> documentation for "M:DXMLBase.Gcv.GCList._construct(System.Xml.XmlElement,DXMLBase.Gcv.GCList)"]

Return Value

Type: GCList

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList._construct(System.Xml.XmlElement,DXMLBase.Gcv.GCList)"]

See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.addName Method

GCListaddName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.addName(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void addName(
    GCValue newValue
)
Public Overridable Sub addName (
    newValue As GCValue
)
public:
virtual void addName(
    GCValue^ newValue
)
abstract addName :
        newValue : GCValue -> unit
override addName :
        newValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCList.addName(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwneraddName(GCValue)
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.appendValue Method

GCListappendValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.appendValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void appendValue(
    GCValue value_Renamed
)
Public Overridable Sub appendValue (
    value_Renamed As GCValue
)
public:
virtual void appendValue(
    GCValue^ value_Renamed
)
abstract appendValue :
        value_Renamed : GCValue -> unit
override appendValue :
        value_Renamed : GCValue -> unit

Parameters

value_Renamed
Type: DXMLBase.GcvGCValue

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCList.appendValue(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerappendValue(GCValue)
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.checkAllowedType Method

GCListcheckAllowedType Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool checkAllowedType(
    GCValueValueType type
)
Public Overridable Function checkAllowedType (
    type As GCValueValueType
) As Boolean
public:
virtual bool checkAllowedType(
    GCValueValueType type
)
abstract checkAllowedType :
        type : GCValueValueType -> bool
override checkAllowedType :
        type : GCValueValueType -> bool

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCList.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Implements

IGCOwnercheckAllowedType(GCValueValueType)
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.getChildValue Method

GCListgetChildValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.getChildValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCValue getChildValue(
    string name
)
Public Overridable Function getChildValue (
    name As String
) As GCValue
public:
virtual GCValue^ getChildValue(
    String^ name
)
abstract getChildValue :
        name : string -> GCValue
override getChildValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCList.getChildValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.getChildValue(System.String)"]

See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.getValue Method

GCListgetValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.getValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCValue getValue(
    string name
)
Public Overridable Function getValue (
    name As String
) As GCValue
public:
virtual GCValue^ getValue(
    String^ name
)
abstract getValue :
        name : string -> GCValue
override getValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCList.getValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.getValue(System.String)"]

See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.hasBeenModified Method

GCListhasBeenModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.hasBeenModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool hasBeenModified()
Public Overridable Function hasBeenModified As Boolean
public:
virtual bool hasBeenModified()
abstract hasBeenModified : unit -> bool
override hasBeenModified : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.hasBeenModified"]

See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.insertValue Method

GCListinsertValue Method
Overload List
 | Name | Description
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Top
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.insertValue Method (GCValue, GCValue)

GCListinsertValue Method (GCValue, GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertValue(
    GCValue newValue,
    GCValue insertionPoint
)
Public Overridable Sub insertValue (
    newValue As GCValue,
    insertionPoint As GCValue
)
public:
virtual void insertValue(
    GCValue^ newValue,
    GCValue^ insertionPoint
)
abstract insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit
override insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCList.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

insertionPoint
Type: DXMLBase.GcvGCValue

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCList.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerinsertValue(GCValue, GCValue)
See Also

Reference

GCList Class
insertValue Overload
DXMLBase.Gcv Namespace


GCList.insertValue Method (GCValue, String)

GCListinsertValue Method (GCValue, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertValue(
    GCValue newValue,
    string insertionPoint
)
Public Overridable Sub insertValue (
    newValue As GCValue,
    insertionPoint As String
)
public:
virtual void insertValue(
    GCValue^ newValue,
    String^ insertionPoint
)
abstract insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit
override insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCList.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

insertionPoint
Type: SystemString

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCList.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Implements

IGCOwnerinsertValue(GCValue, String)
See Also

Reference

GCList Class
insertValue Overload
DXMLBase.Gcv Namespace


GCList.isNameAllowed Method

GCListisNameAllowed Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.isNameAllowed(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool isNameAllowed(
    string name
)
Public Overridable Function isNameAllowed (
    name As String
) As Boolean
public:
virtual bool isNameAllowed(
    String^ name
)
abstract isNameAllowed :
        name : string -> bool
override isNameAllowed :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCList.isNameAllowed(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.isNameAllowed(System.String)"]

Implements

IGCOwnerisNameAllowed(String)
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.removeName Method

GCListremoveName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.removeName(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void removeName(
    GCValue oldValue
)
Public Overridable Sub removeName (
    oldValue As GCValue
)
public:
virtual void removeName(
    GCValue^ oldValue
)
abstract removeName :
        oldValue : GCValue -> unit
override removeName :
        oldValue : GCValue -> unit

Parameters

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.GCList.removeName(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerremoveName(GCValue)
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.removeValue Method

GCListremoveValue Method
Overload List
 | Name | Description
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Top
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.removeValue Method (String)

GCListremoveValue Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.removeValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeValue(
    string name
)
Public Overridable Function removeValue (
    name As String
) As Boolean
public:
virtual bool removeValue(
    String^ name
)
abstract removeValue :
        name : string -> bool
override removeValue :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCList.removeValue(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.removeValue(System.String)"]

Implements

IGCOwnerremoveValue(String)
See Also

Reference

GCList Class
removeValue Overload
DXMLBase.Gcv Namespace


GCList.removeValue Method (GCValue)

GCListremoveValue Method (GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.removeValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeValue(
    GCValue value
)
Public Overridable Function removeValue (
    value As GCValue
) As Boolean
public:
virtual bool removeValue(
    GCValue^ value
)
abstract removeValue :
        value : GCValue -> bool
override removeValue :
        value : GCValue -> bool

Parameters

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCList.removeValue(DXMLBase.Gcv.GCValue)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCList.removeValue(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerremoveValue(GCValue)
See Also

Reference

GCList Class
removeValue Overload
DXMLBase.Gcv Namespace


GCList.replaceValue Method

GCListreplaceValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void replaceValue(
    GCValue newValue,
    GCValue oldValue
)
Public Overridable Sub replaceValue (
    newValue As GCValue,
    oldValue As GCValue
)
public:
virtual void replaceValue(
    GCValue^ newValue,
    GCValue^ oldValue
)
abstract replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit
override replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCList.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.GCList.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerreplaceValue(GCValue, GCValue)
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.resetModified Method

GCListresetModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCList.resetModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void resetModified()
Public Overridable Sub resetModified
public:
virtual void resetModified()
abstract resetModified : unit -> unit
override resetModified : unit -> unit
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList Properties

GCList Properties

The GCList type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | Descendants |
Top
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.Children Property

GCListChildren Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCList.Children"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValue> Children { get; }
Public Overridable ReadOnly Property Children As IEnumerable(Of GCValue)
    Get
public:
virtual property IEnumerable<GCValue^>^ Children {
    IEnumerable<GCValue^>^ get ();
}
abstract Children : IEnumerable<GCValue> with get
override Children : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue

Implements

IGCOwnerChildren
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCList.Descendants Property

GCListDescendants Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCList.Descendants"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValue> Descendants { get; }
Public Overridable ReadOnly Property Descendants As IEnumerable(Of GCValue)
    Get
public:
virtual property IEnumerable<GCValue^>^ Descendants {
    IEnumerable<GCValue^>^ get ();
}
abstract Descendants : IEnumerable<GCValue> with get
override Descendants : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue

Implements

IGCOwnerDescendants
See Also

Reference

GCList Class
DXMLBase.Gcv Namespace


GCListValue Class

GCListValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCListValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCListValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCListValue : GCValue
Public Class GCListValue
    Inherits GCValue
public ref class GCListValue : public GCValue
type GCListValue =
    class
        inherit GCValue
    end

The GCListValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendListItem |
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Overrides GCValuegetXMLValue(XmlDocument).)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertListItem |
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | removeListItem(Int32) |
Public method | removeListItem(String, Boolean) |
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
 | DEFAULT_SEPARATOR |
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | Items
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Separator
Public property | Type | (Inherited from GCValue.)
Public property | TypeHint
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCListValue Fields

GCListValue Fields

The GCListValue type exposes the following members.

Fields
 | Name | Description
 | DEFAULT_SEPARATOR |
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.DEFAULT_SEPARATOR Field

GCListValueDEFAULT_SEPARATOR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCListValue.DEFAULT_SEPARATOR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DEFAULT_SEPARATOR
Public Const DEFAULT_SEPARATOR As String
public:
literal String^ DEFAULT_SEPARATOR
static val mutable DEFAULT_SEPARATOR: string

Field Value

Type: String
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue Methods

GCListValue Methods

The GCListValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendListItem |
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Overrides GCValuegetXMLValue(XmlDocument).)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertListItem |
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | removeListItem(Int32) |
Public method | removeListItem(String, Boolean) |
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.appendListItem Method

GCListValueappendListItem Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.appendListItem(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void appendListItem(
    string item
)
Public Overridable Sub appendListItem (
    item As String
)
public:
virtual void appendListItem(
    String^ item
)
abstract appendListItem :
        item : string -> unit
override appendListItem :
        item : string -> unit

Parameters

item
Type: SystemString

[Missing <param name="item"/> documentation for "M:DXMLBase.Gcv.GCListValue.appendListItem(System.String)"]

See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.cloneValue Method

GCListValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCListValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCListValue.cloneValue(System.String)"]

See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.getXMLValue Method

GCListValuegetXMLValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.getXMLValue(System.Xml.XmlDocument)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override XmlNode getXMLValue(
    XmlDocument document
)
Public Overrides Function getXMLValue (
    document As XmlDocument
) As XmlNode
public:
virtual XmlNode^ getXMLValue(
    XmlDocument^ document
) override
abstract getXMLValue :
        document : XmlDocument -> XmlNode
override getXMLValue :
        document : XmlDocument -> XmlNode

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:DXMLBase.Gcv.GCListValue.getXMLValue(System.Xml.XmlDocument)"]

Return Value

Type: XmlNode

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCListValue.getXMLValue(System.Xml.XmlDocument)"]

See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.insertListItem Method

GCListValueinsertListItem Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.insertListItem(System.String,System.Int32)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertListItem(
    string item,
    int insertionPoint
)
Public Overridable Sub insertListItem (
    item As String,
    insertionPoint As Integer
)
public:
virtual void insertListItem(
    String^ item,
    int insertionPoint
)
abstract insertListItem :
        item : string *
        insertionPoint : int -> unit
override insertListItem :
        item : string *
        insertionPoint : int -> unit

Parameters

item
Type: SystemString

[Missing <param name="item"/> documentation for "M:DXMLBase.Gcv.GCListValue.insertListItem(System.String,System.Int32)"]

insertionPoint
Type: SystemInt32

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCListValue.insertListItem(System.String,System.Int32)"]

See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.parseValue Method

GCListValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCListValue.parseValue(System.String)"]

See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.removeListItem Method

GCListValueremoveListItem Method
Overload List
 | Name | Description
Public method | removeListItem(Int32) |
Public method | removeListItem(String, Boolean) |
Top
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.removeListItem Method (Int32)

GCListValueremoveListItem Method (Int32)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.Int32)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeListItem(
    int index
)
Public Overridable Function removeListItem (
    index As Integer
) As Boolean
public:
virtual bool removeListItem(
    int index
)
abstract removeListItem :
        index : int -> bool
override removeListItem :
        index : int -> bool

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.Int32)"]

See Also

Reference

GCListValue Class
removeListItem Overload
DXMLBase.Gcv Namespace


GCListValue.removeListItem Method (String, Boolean)

GCListValueremoveListItem Method (String, Boolean)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.String,System.Boolean)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeListItem(
    string item,
    bool removeAll
)
Public Overridable Function removeListItem (
    item As String,
    removeAll As Boolean
) As Boolean
public:
virtual bool removeListItem(
    String^ item,
    bool removeAll
)
abstract removeListItem :
        item : string *
        removeAll : bool -> bool
override removeListItem :
        item : string *
        removeAll : bool -> bool

Parameters

item
Type: SystemString

[Missing <param name="item"/> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.String,System.Boolean)"]

removeAll
Type: SystemBoolean

[Missing <param name="removeAll"/> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCListValue.removeListItem(System.String,System.Boolean)"]

See Also

Reference

GCListValue Class
removeListItem Overload
DXMLBase.Gcv Namespace


GCListValue Properties

GCListValue Properties

The GCListValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | Items
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Separator
Public property | Type | (Inherited from GCValue.)
Public property | TypeHint
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.Items Property

GCListValueItems Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCListValue.Items"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<string> Items { get; }
Public Overridable ReadOnly Property Items As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ Items {
    IEnumerable<String^>^ get ();
}
abstract Items : IEnumerable<string> with get
override Items : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.Separator Property

GCListValueSeparator Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCListValue.Separator"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Separator { get; set; }
Public Overridable Property Separator As String
    Get
    Set
public:
virtual property String^ Separator {
    String^ get ();
    void set (String^ value);
}
abstract Separator : string with get, set
override Separator : string with get, set

Property Value

Type: String
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.TypeHint Property

GCListValueTypeHint Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCListValue.TypeHint"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string TypeHint { get; set; }
Public Overridable Property TypeHint As String
    Get
    Set
public:
virtual property String^ TypeHint {
    String^ get ();
    void set (String^ value);
}
abstract TypeHint : string with get, set
override TypeHint : string with get, set

Property Value

Type: String
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCListValue.Value Property

GCListValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCListValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCListValue Class
DXMLBase.Gcv Namespace


GCParent Class

GCParent Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCParent"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCParent
DXMLBase.GcvGCGroup
DXMLBase.GcvGCSubordinates

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class GCParent : GCValue,
    IGCOwner
Public MustInherit Class GCParent
    Inherits GCValue
    Implements IGCOwner
public ref class GCParent abstract : public GCValue,
    IGCOwner
[<AbstractClassAttribute>]
type GCParent =
    class
        inherit GCValue
        interface IGCOwner
    end

The GCParent type exposes the following members.

Constructors
 | Name | Description
Protected method | GCParent(GCValueValueType, IGCOwner) | Initializes a new instance of the GCParent class
Protected method | GCParent(GCValueValueType, XmlElement, IGCOwner) | Initializes a new instance of the GCParent class
Top
Methods
 | Name | Description
Public method | addName |
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendValue |
Public method | checkAllowedType |
Protected method | cloneCommon | (Overrides GCValuecloneCommon(GCValue).)
Public method | cloneValue | (Inherited from GCValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Overrides GCValuegetOwner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Public method | isNameAllowed |
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | removeName |
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Public method | replaceValue |
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | cloning |
Protected field | modified | (Inherited from GCValue.)
Protected field | owner |
Top
Properties
Name | Description
Public property | Children
Public property | Descendants
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCParent Constructor

GCParent Constructor
Overload List
 | Name | Description
Protected method | GCParent(GCValueValueType, IGCOwner) | Initializes a new instance of the GCParent class
Protected method | GCParent(GCValueValueType, XmlElement, IGCOwner) | Initializes a new instance of the GCParent class
Top
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent Constructor (GCValue.ValueType, IGCOwner)

GCParent Constructor (GCValueValueType, IGCOwner)
Initializes a new instance of the GCParent class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCParent(
    GCValueValueType type,
    IGCOwner owner
)
Protected Sub New (
    type As GCValueValueType,
    owner As IGCOwner
)
protected:
GCParent(
    GCValueValueType type,
    IGCOwner^ owner
)
new :
        type : GCValueValueType *
        owner : IGCOwner -> GCParent

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCParent.#ctor(DXMLBase.Gcv.GCValue.ValueType,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCParent.#ctor(DXMLBase.Gcv.GCValue.ValueType,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCParent Class
GCParent Overload
DXMLBase.Gcv Namespace


GCParent Constructor (GCValue.ValueType, XmlElement, IGCOwner)

GCParent Constructor (GCValueValueType, XmlElement, IGCOwner)
Initializes a new instance of the GCParent class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCParent(
    GCValueValueType type,
    XmlElement definition,
    IGCOwner owner
)
Protected Sub New (
    type As GCValueValueType,
    definition As XmlElement,
    owner As IGCOwner
)
protected:
GCParent(
    GCValueValueType type,
    XmlElement^ definition,
    IGCOwner^ owner
)
new :
        type : GCValueValueType *
        definition : XmlElement *
        owner : IGCOwner -> GCParent

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCParent.#ctor(DXMLBase.Gcv.GCValue.ValueType,System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

definition
Type: System.XmlXmlElement

[Missing <param name="definition"/> documentation for "M:DXMLBase.Gcv.GCParent.#ctor(DXMLBase.Gcv.GCValue.ValueType,System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCParent.#ctor(DXMLBase.Gcv.GCValue.ValueType,System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCParent Class
GCParent Overload
DXMLBase.Gcv Namespace


GCParent Fields

GCParent Fields

The GCParent type exposes the following members.

Fields
 | Name | Description
Protected field | cloning |
Protected field | modified | (Inherited from GCValue.)
Protected field | owner |
Top
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.cloning Field

GCParentcloning Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCParent.cloning"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool cloning
Protected cloning As Boolean
protected:
bool cloning
val mutable cloning: bool

Field Value

Type: Boolean
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.owner Field

GCParentowner Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCParent.owner"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected IGCOwner owner
Protected owner As IGCOwner
protected:
IGCOwner^ owner
val mutable owner: IGCOwner

Field Value

Type: IGCOwner
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent Methods

GCParent Methods

The GCParent type exposes the following members.

Methods
 | Name | Description
Public method | addName |
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendValue |
Public method | checkAllowedType |
Protected method | cloneCommon | (Overrides GCValuecloneCommon(GCValue).)
Public method | cloneValue | (Inherited from GCValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Overrides GCValuegetOwner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Public method | isNameAllowed |
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | removeName |
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Public method | replaceValue |
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.addName Method

GCParentaddName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.addName(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void addName(
    GCValue newValue
)
Public Overridable Sub addName (
    newValue As GCValue
)
public:
virtual void addName(
    GCValue^ newValue
)
abstract addName :
        newValue : GCValue -> unit
override addName :
        newValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCParent.addName(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwneraddName(GCValue)
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.appendValue Method

GCParentappendValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.appendValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void appendValue(
    GCValue value
)
Public Overridable Sub appendValue (
    value As GCValue
)
public:
virtual void appendValue(
    GCValue^ value
)
abstract appendValue :
        value : GCValue -> unit
override appendValue :
        value : GCValue -> unit

Parameters

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCParent.appendValue(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerappendValue(GCValue)
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.checkAllowedType Method

GCParentcheckAllowedType Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool checkAllowedType(
    GCValueValueType type
)
Public Overridable Function checkAllowedType (
    type As GCValueValueType
) As Boolean
public:
virtual bool checkAllowedType(
    GCValueValueType type
)
abstract checkAllowedType :
        type : GCValueValueType -> bool
override checkAllowedType :
        type : GCValueValueType -> bool

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCParent.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCParent.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Implements

IGCOwnercheckAllowedType(GCValueValueType)
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.cloneCommon Method

GCParentcloneCommon Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.cloneCommon(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void cloneCommon(
    GCValue newValue
)
Protected Overrides Sub cloneCommon (
    newValue As GCValue
)
protected:
virtual void cloneCommon(
    GCValue^ newValue
) override
abstract cloneCommon :
        newValue : GCValue -> unit
override cloneCommon :
        newValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCParent.cloneCommon(DXMLBase.Gcv.GCValue)"]

See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.getOwner Method

GCParentgetOwner Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.getOwner"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IGCOwner getOwner()
Public Overrides Function getOwner As IGCOwner
public:
virtual IGCOwner^ getOwner() override
abstract getOwner : unit -> IGCOwner
override getOwner : unit -> IGCOwner

Return Value

Type: IGCOwner

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCParent.getOwner"]

See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.insertValue Method

GCParentinsertValue Method
Overload List
 | Name | Description
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Top
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.insertValue Method (GCValue, GCValue)

GCParentinsertValue Method (GCValue, GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertValue(
    GCValue newValue,
    GCValue insertionPoint
)
Public Overridable Sub insertValue (
    newValue As GCValue,
    insertionPoint As GCValue
)
public:
virtual void insertValue(
    GCValue^ newValue,
    GCValue^ insertionPoint
)
abstract insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit
override insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCParent.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

insertionPoint
Type: DXMLBase.GcvGCValue

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCParent.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerinsertValue(GCValue, GCValue)
See Also

Reference

GCParent Class
insertValue Overload
DXMLBase.Gcv Namespace


GCParent.insertValue Method (GCValue, String)

GCParentinsertValue Method (GCValue, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void insertValue(
    GCValue newValue,
    string insertionPoint
)
Public Overridable Sub insertValue (
    newValue As GCValue,
    insertionPoint As String
)
public:
virtual void insertValue(
    GCValue^ newValue,
    String^ insertionPoint
)
abstract insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit
override insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCParent.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

insertionPoint
Type: SystemString

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCParent.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Implements

IGCOwnerinsertValue(GCValue, String)
See Also

Reference

GCParent Class
insertValue Overload
DXMLBase.Gcv Namespace


GCParent.isNameAllowed Method

GCParentisNameAllowed Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.isNameAllowed(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool isNameAllowed(
    string name
)
Public Overridable Function isNameAllowed (
    name As String
) As Boolean
public:
virtual bool isNameAllowed(
    String^ name
)
abstract isNameAllowed :
        name : string -> bool
override isNameAllowed :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCParent.isNameAllowed(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCParent.isNameAllowed(System.String)"]

Implements

IGCOwnerisNameAllowed(String)
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.parseValue Method

GCParentparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value_Renamed
)
Public Overrides Sub parseValue (
    value_Renamed As String
)
public:
virtual void parseValue(
    String^ value_Renamed
) override
abstract parseValue :
        value_Renamed : string -> unit
override parseValue :
        value_Renamed : string -> unit

Parameters

value_Renamed
Type: SystemString

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCParent.parseValue(System.String)"]

See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.removeName Method

GCParentremoveName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.removeName(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void removeName(
    GCValue oldValue
)
Public Overridable Sub removeName (
    oldValue As GCValue
)
public:
virtual void removeName(
    GCValue^ oldValue
)
abstract removeName :
        oldValue : GCValue -> unit
override removeName :
        oldValue : GCValue -> unit

Parameters

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.GCParent.removeName(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerremoveName(GCValue)
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.removeValue Method

GCParentremoveValue Method
Overload List
 | Name | Description
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Top
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.removeValue Method (String)

GCParentremoveValue Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.removeValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeValue(
    string name
)
Public Overridable Function removeValue (
    name As String
) As Boolean
public:
virtual bool removeValue(
    String^ name
)
abstract removeValue :
        name : string -> bool
override removeValue :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCParent.removeValue(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCParent.removeValue(System.String)"]

Implements

IGCOwnerremoveValue(String)
See Also

Reference

GCParent Class
removeValue Overload
DXMLBase.Gcv Namespace


GCParent.removeValue Method (GCValue)

GCParentremoveValue Method (GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.removeValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool removeValue(
    GCValue value
)
Public Overridable Function removeValue (
    value As GCValue
) As Boolean
public:
virtual bool removeValue(
    GCValue^ value
)
abstract removeValue :
        value : GCValue -> bool
override removeValue :
        value : GCValue -> bool

Parameters

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCParent.removeValue(DXMLBase.Gcv.GCValue)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCParent.removeValue(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerremoveValue(GCValue)
See Also

Reference

GCParent Class
removeValue Overload
DXMLBase.Gcv Namespace


GCParent.replaceValue Method

GCParentreplaceValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCParent.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void replaceValue(
    GCValue newValue,
    GCValue oldValue
)
Public Overridable Sub replaceValue (
    newValue As GCValue,
    oldValue As GCValue
)
public:
virtual void replaceValue(
    GCValue^ newValue,
    GCValue^ oldValue
)
abstract replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit
override replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCParent.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.GCParent.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerreplaceValue(GCValue, GCValue)
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent Properties

GCParent Properties

The GCParent type exposes the following members.

Properties
Name | Description
Public property | Children
Public property | Descendants
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.Children Property

GCParentChildren Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCParent.Children"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValue> Children { get; }
Public Overridable ReadOnly Property Children As IEnumerable(Of GCValue)
    Get
public:
virtual property IEnumerable<GCValue^>^ Children {
    IEnumerable<GCValue^>^ get ();
}
abstract Children : IEnumerable<GCValue> with get
override Children : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue

Implements

IGCOwnerChildren
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.Descendants Property

GCParentDescendants Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCParent.Descendants"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValue> Descendants { get; }
Public Overridable ReadOnly Property Descendants As IEnumerable(Of GCValue)
    Get
public:
virtual property IEnumerable<GCValue^>^ Descendants {
    IEnumerable<GCValue^>^ get ();
}
abstract Descendants : IEnumerable<GCValue> with get
override Descendants : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue

Implements

IGCOwnerDescendants
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCParent.Value Property

GCParentValue Property
Override, does nothing.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCParent Class
DXMLBase.Gcv Namespace


GCPasswordRefValue Class

GCPasswordRefValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCPasswordRefValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCPasswordRefValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCPasswordRefValue : GCValue
Public Class GCPasswordRefValue
    Inherits GCValue
public ref class GCPasswordRefValue : public GCValue
type GCPasswordRefValue =
    class
        inherit GCValue
    end

The GCPasswordRefValue type exposes the following members.

Constructors
 | Name | Description
Public method | GCPasswordRefValue | Initializes a new instance of the GCPasswordRefValue class
Top
Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Resolver
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCPasswordRefValue Constructor

GCPasswordRefValue Constructor
Initializes a new instance of the GCPasswordRefValue class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCPasswordRefValue(
    string name
)
Public Sub New (
    name As String
)
public:
GCPasswordRefValue(
    String^ name
)
new :
        name : string -> GCPasswordRefValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.#ctor(System.String)"]

See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue Fields

GCPasswordRefValue Fields

The GCPasswordRefValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue Methods

GCPasswordRefValue Methods

The GCPasswordRefValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue.cloneValue Method

GCPasswordRefValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.cloneValue(System.String)"]

See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue.parseValue Method

GCPasswordRefValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.parseValue(System.String)"]

See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue Properties

GCPasswordRefValue Properties

The GCPasswordRefValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Resolver
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue.Resolver Property

GCPasswordRefValueResolver Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCPasswordRefValue.Resolver"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCPasswordRefValueIPasswordResolver Resolver { get; set; }
Public Overridable Property Resolver As GCPasswordRefValueIPasswordResolver
    Get
    Set
public:
virtual property GCPasswordRefValueIPasswordResolver^ Resolver {
    GCPasswordRefValueIPasswordResolver^ get ();
    void set (GCPasswordRefValueIPasswordResolver^ value);
}
abstract Resolver : GCPasswordRefValueIPasswordResolver with get, set
override Resolver : GCPasswordRefValueIPasswordResolver with get, set

Property Value

Type: GCPasswordRefValueIPasswordResolver
See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue.Value Property

GCPasswordRefValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCPasswordRefValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCPasswordRefValue Class
DXMLBase.Gcv Namespace


GCPasswordRefValue.IPasswordResolver Interface

GCPasswordRefValueIPasswordResolver Interface

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCPasswordRefValue.IPasswordResolver"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPasswordResolver
Public Interface IPasswordResolver
public interface class IPasswordResolver
type IPasswordResolver =  interface end

The GCPasswordRefValueIPasswordResolver type exposes the following members.

Methods
 | Name | Description
Public method | getPasswordValue |
Top
See Also

Reference

DXMLBase.Gcv Namespace


IPasswordResolver Methods

IPasswordResolver Methods

The GCPasswordRefValueIPasswordResolver type exposes the following members.

Methods
 | Name | Description
Public method | getPasswordValue |
Top
See Also

Reference

GCPasswordRefValueIPasswordResolver Interface
DXMLBase.Gcv Namespace


GCPasswordRefValue.IPasswordResolver.getPasswordValue Method

GCPasswordRefValueIPasswordResolvergetPasswordValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.IPasswordResolver.getPasswordValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string getPasswordValue(
    string name
)
Function getPasswordValue (
    name As String
) As String
String^ getPasswordValue(
    String^ name
)
abstract getPasswordValue :
        name : string -> string

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.IPasswordResolver.getPasswordValue(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCPasswordRefValue.IPasswordResolver.getPasswordValue(System.String)"]

See Also

Reference

GCPasswordRefValueIPasswordResolver Interface
DXMLBase.Gcv Namespace


GCRealValue Class

GCRealValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCRealValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCRealValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCRealValue : GCValue
Public Class GCRealValue
    Inherits GCValue
public ref class GCRealValue : public GCValue
type GCRealValue =
    class
        inherit GCValue
    end

The GCRealValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | RangeHi
Public property | RangeHiString
Public property | RangeLo
Public property | RangeLoString
Public property | RealValue
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCRealValue Fields

GCRealValue Fields

The GCRealValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue Methods

GCRealValue Methods

The GCRealValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.cloneValue Method

GCRealValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCRealValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCRealValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCRealValue.cloneValue(System.String)"]

See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.parseValue Method

GCRealValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCRealValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCRealValue.parseValue(System.String)"]

See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue Properties

GCRealValue Properties

The GCRealValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | RangeHi
Public property | RangeHiString
Public property | RangeLo
Public property | RangeLoString
Public property | RealValue
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.RangeHi Property

GCRealValueRangeHi Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCRealValue.RangeHi"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double RangeHi { get; set; }
Public Overridable Property RangeHi As Double
    Get
    Set
public:
virtual property double RangeHi {
    double get ();
    void set (double value);
}
abstract RangeHi : float with get, set
override RangeHi : float with get, set

Property Value

Type: Double
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.RangeHiString Property

GCRealValueRangeHiString Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCRealValue.RangeHiString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string RangeHiString { get; set; }
Public Overridable Property RangeHiString As String
    Get
    Set
public:
virtual property String^ RangeHiString {
    String^ get ();
    void set (String^ value);
}
abstract RangeHiString : string with get, set
override RangeHiString : string with get, set

Property Value

Type: String
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.RangeLo Property

GCRealValueRangeLo Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCRealValue.RangeLo"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double RangeLo { get; set; }
Public Overridable Property RangeLo As Double
    Get
    Set
public:
virtual property double RangeLo {
    double get ();
    void set (double value);
}
abstract RangeLo : float with get, set
override RangeLo : float with get, set

Property Value

Type: Double
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.RangeLoString Property

GCRealValueRangeLoString Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCRealValue.RangeLoString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string RangeLoString { get; set; }
Public Overridable Property RangeLoString As String
    Get
    Set
public:
virtual property String^ RangeLoString {
    String^ get ();
    void set (String^ value);
}
abstract RangeLoString : string with get, set
override RangeLoString : string with get, set

Property Value

Type: String
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.RealValue Property

GCRealValueRealValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCRealValue.RealValue"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double RealValue { get; set; }
Public Overridable Property RealValue As Double
    Get
    Set
public:
virtual property double RealValue {
    double get ();
    void set (double value);
}
abstract RealValue : float with get, set
override RealValue : float with get, set

Property Value

Type: Double
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCRealValue.Value Property

GCRealValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCRealValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCRealValue Class
DXMLBase.Gcv Namespace


GCStringValue Class

GCStringValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCStringValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCStringValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCStringValue : GCValue
Public Class GCStringValue
    Inherits GCValue
public ref class GCStringValue : public GCValue
type GCStringValue =
    class
        inherit GCValue
    end

The GCStringValue type exposes the following members.

Constructors
 | Name | Description
Public method | GCStringValue | Initializes a new instance of the GCStringValue class
Top
Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Multiline
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCStringValue Constructor

GCStringValue Constructor
Initializes a new instance of the GCStringValue class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCStringValue(
    string name
)
Public Sub New (
    name As String
)
public:
GCStringValue(
    String^ name
)
new :
        name : string -> GCStringValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCStringValue.#ctor(System.String)"]

See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue Fields

GCStringValue Fields

The GCStringValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue Methods

GCStringValue Methods

The GCStringValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue.cloneValue Method

GCStringValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStringValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCStringValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStringValue.cloneValue(System.String)"]

See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue.parseValue Method

GCStringValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStringValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCStringValue.parseValue(System.String)"]

See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue Properties

GCStringValue Properties

The GCStringValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Multiline
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue.Multiline Property

GCStringValueMultiline Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStringValue.Multiline"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Multiline { get; set; }
Public Overridable Property Multiline As Boolean
    Get
    Set
public:
virtual property bool Multiline {
    bool get ();
    void set (bool value);
}
abstract Multiline : bool with get, set
override Multiline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStringValue.Value Property

GCStringValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStringValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCStringValue Class
DXMLBase.Gcv Namespace


GCStructuredValue Class

GCStructuredValue Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCStructuredValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCStructuredValue

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCStructuredValue : GCValue
Public Class GCStructuredValue
    Inherits GCValue
public ref class GCStructuredValue : public GCValue
type GCStructuredValue =
    class
        inherit GCValue
    end

The GCStructuredValue type exposes the following members.

Methods
 | Name | Description
Public method | addInstance |
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | appendInstance |
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | Return the owner of this instance. (Overrides GCValuegetOwner.)
Public method | getTemplate |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Overrides GCValuehasBeenModified.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
 | DEFAULT_INSTANCE_SEPARATOR |
 | DEFAULT_VALUE_SEPARATOR |
Protected field | instances |
Protected field | modified | (Inherited from GCValue.)
Protected field | owner |
Protected field | template |
Top
Properties
Name | Description
Public property | Children
Public property | Descendants
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | Instances
Public property | InstanceSeparator
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | ValueSeparator
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCStructuredValue Fields

GCStructuredValue Fields

The GCStructuredValue type exposes the following members.

Fields
 | Name | Description
 | DEFAULT_INSTANCE_SEPARATOR |
 | DEFAULT_VALUE_SEPARATOR |
Protected field | instances |
Protected field | modified | (Inherited from GCValue.)
Protected field | owner |
Protected field | template |
Top
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.DEFAULT_INSTANCE_SEPARATOR Field

GCStructuredValueDEFAULT_INSTANCE_SEPARATOR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCStructuredValue.DEFAULT_INSTANCE_SEPARATOR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DEFAULT_INSTANCE_SEPARATOR
Public Const DEFAULT_INSTANCE_SEPARATOR As String
public:
literal String^ DEFAULT_INSTANCE_SEPARATOR
static val mutable DEFAULT_INSTANCE_SEPARATOR: string

Field Value

Type: String
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.DEFAULT_VALUE_SEPARATOR Field

GCStructuredValueDEFAULT_VALUE_SEPARATOR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCStructuredValue.DEFAULT_VALUE_SEPARATOR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DEFAULT_VALUE_SEPARATOR
Public Const DEFAULT_VALUE_SEPARATOR As String
public:
literal String^ DEFAULT_VALUE_SEPARATOR
static val mutable DEFAULT_VALUE_SEPARATOR: string

Field Value

Type: String
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.instances Field

GCStructuredValueinstances Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCStructuredValue.instances"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected List<GCStructuredValueInstance> instances
Protected instances As List(Of GCStructuredValueInstance)
protected:
List<GCStructuredValueInstance^>^ instances
val mutable instances: List<GCStructuredValueInstance>

Field Value

Type: List GCStructuredValueInstance
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.owner Field

GCStructuredValueowner Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCStructuredValue.owner"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected IGCOwner owner
Protected owner As IGCOwner
protected:
IGCOwner^ owner
val mutable owner: IGCOwner

Field Value

Type: IGCOwner
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.template Field

GCStructuredValuetemplate Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCStructuredValue.template"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCStructuredValueTemplate template
Protected template As GCStructuredValueTemplate
protected:
GCStructuredValueTemplate^ template
val mutable template: GCStructuredValueTemplate

Field Value

Type: GCStructuredValueTemplate
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue Methods

GCStructuredValue Methods

The GCStructuredValue type exposes the following members.

Methods
 | Name | Description
Public method | addInstance |
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | appendInstance |
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | Return the owner of this instance. (Overrides GCValuegetOwner.)
Public method | getTemplate |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Overrides GCValuehasBeenModified.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.addInstance Method

GCStructuredValueaddInstance Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.addInstance"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCStructuredValueInstance addInstance()
Public Overridable Function addInstance As GCStructuredValueInstance
public:
virtual GCStructuredValueInstance^ addInstance()
abstract addInstance : unit -> GCStructuredValueInstance
override addInstance : unit -> GCStructuredValueInstance

Return Value

Type: GCStructuredValueInstance

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.addInstance"]

See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.appendInstance Method

GCStructuredValueappendInstance Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.appendInstance(DXMLBase.Gcv.GCStructuredValue.Instance)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void appendInstance(
    GCStructuredValueInstance newInstance
)
Protected Overridable Sub appendInstance (
    newInstance As GCStructuredValueInstance
)
protected:
virtual void appendInstance(
    GCStructuredValueInstance^ newInstance
)
abstract appendInstance :
        newInstance : GCStructuredValueInstance -> unit
override appendInstance :
        newInstance : GCStructuredValueInstance -> unit

Parameters

newInstance
Type: DXMLBase.GcvGCStructuredValueInstance

[Missing <param name="newInstance"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.appendInstance(DXMLBase.Gcv.GCStructuredValue.Instance)"]

See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.cloneValue Method

GCStructuredValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.cloneValue(System.String)"]

See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.getOwner Method

GCStructuredValuegetOwner Method
Return the owner of this instance.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IGCOwner getOwner()
Public Overrides Function getOwner As IGCOwner
public:
virtual IGCOwner^ getOwner() override
abstract getOwner : unit -> IGCOwner
override getOwner : unit -> IGCOwner

Return Value

Type: IGCOwner

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.getOwner"]

See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.getTemplate Method

GCStructuredValuegetTemplate Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.getTemplate"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCStructuredValueTemplate getTemplate()
Public Overridable Function getTemplate As GCStructuredValueTemplate
public:
virtual GCStructuredValueTemplate^ getTemplate()
abstract getTemplate : unit -> GCStructuredValueTemplate
override getTemplate : unit -> GCStructuredValueTemplate

Return Value

Type: GCStructuredValueTemplate

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.getTemplate"]

See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.hasBeenModified Method

GCStructuredValuehasBeenModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.hasBeenModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool hasBeenModified()
Public Overrides Function hasBeenModified As Boolean
public:
virtual bool hasBeenModified() override
abstract hasBeenModified : unit -> bool
override hasBeenModified : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.hasBeenModified"]

Implements

IConfigElementhasBeenModified
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.parseValue Method

GCStructuredValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value
)
Public Overrides Sub parseValue (
    value As String
)
public:
virtual void parseValue(
    String^ value
) override
abstract parseValue :
        value : string -> unit
override parseValue :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.parseValue(System.String)"]

See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue Properties

GCStructuredValue Properties

The GCStructuredValue type exposes the following members.

Properties
Name | Description
Public property | Children
Public property | Descendants
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property | Instances
Public property | InstanceSeparator
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | ValueSeparator
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.Children Property

GCStructuredValueChildren Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.Children"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValue> Children { get; }
Public Overridable ReadOnly Property Children As IEnumerable(Of GCValue)
    Get
public:
virtual property IEnumerable<GCValue^>^ Children {
    IEnumerable<GCValue^>^ get ();
}
abstract Children : IEnumerable<GCValue> with get
override Children : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.Descendants Property

GCStructuredValueDescendants Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.Descendants"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValue> Descendants { get; }
Public Overridable ReadOnly Property Descendants As IEnumerable(Of GCValue)
    Get
public:
virtual property IEnumerable<GCValue^>^ Descendants {
    IEnumerable<GCValue^>^ get ();
}
abstract Descendants : IEnumerable<GCValue> with get
override Descendants : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.Instances Property

GCStructuredValueInstances Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.Instances"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCStructuredValueInstance> Instances { get; }
Public Overridable ReadOnly Property Instances As IEnumerable(Of GCStructuredValueInstance)
    Get
public:
virtual property IEnumerable<GCStructuredValueInstance^>^ Instances {
    IEnumerable<GCStructuredValueInstance^>^ get ();
}
abstract Instances : IEnumerable<GCStructuredValueInstance> with get
override Instances : IEnumerable<GCStructuredValueInstance> with get

Property Value

Type: IEnumerable GCStructuredValueInstance
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.InstanceSeparator Property

GCStructuredValueInstanceSeparator Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.InstanceSeparator"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string InstanceSeparator { get; set; }
Public Overridable Property InstanceSeparator As String
    Get
    Set
public:
virtual property String^ InstanceSeparator {
    String^ get ();
    void set (String^ value);
}
abstract InstanceSeparator : string with get, set
override InstanceSeparator : string with get, set

Property Value

Type: String
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.Value Property

GCStructuredValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.ValueSeparator Property

GCStructuredValueValueSeparator Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.ValueSeparator"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ValueSeparator { get; set; }
Public Overridable Property ValueSeparator As String
    Get
    Set
public:
virtual property String^ ValueSeparator {
    String^ get ();
    void set (String^ value);
}
abstract ValueSeparator : string with get, set
override ValueSeparator : string with get, set

Property Value

Type: String
See Also

Reference

GCStructuredValue Class
DXMLBase.Gcv Namespace


GCStructuredValue.Instance Class

GCStructuredValueInstance Class
Class representing an instance of a
Copy
GCStructuredValue
's template.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCList
DXMLBase.GcvGCStructuredValueInstance

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Instance : GCList
Public Class Instance
    Inherits GCList
public ref class Instance : public GCList
type Instance =
    class
        inherit GCList
    end

The GCStructuredValueInstance type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Inherited from GCList.)
Public method | checkAllowedType | (Overrides GCListcheckAllowedType(GCValueValueType).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCList.)
Public method | insertValue(GCValue, String) | (Inherited from GCList.)
Public method | isNameAllowed | (Inherited from GCList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Inherited from GCList.)
Public method | removeValue(GCValue) | (Inherited from GCList.)
Public method | replaceValue | (Inherited from GCList.)
Public method | resetModified | (Inherited from GCList.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml |
Top
Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


Instance Fields

Instance Fields

The GCStructuredValueInstance type exposes the following members.

Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
See Also

Reference

GCStructuredValueInstance Class
DXMLBase.Gcv Namespace


Instance Methods

Instance Methods

The GCStructuredValueInstance type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Inherited from GCList.)
Public method | checkAllowedType | (Overrides GCListcheckAllowedType(GCValueValueType).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCList.)
Public method | insertValue(GCValue, String) | (Inherited from GCList.)
Public method | isNameAllowed | (Inherited from GCList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Inherited from GCList.)
Public method | removeValue(GCValue) | (Inherited from GCList.)
Public method | replaceValue | (Inherited from GCList.)
Public method | resetModified | (Inherited from GCList.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml |
Top
See Also

Reference

GCStructuredValueInstance Class
DXMLBase.Gcv Namespace


GCStructuredValue.Instance.checkAllowedType Method

GCStructuredValueInstancecheckAllowedType Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Instance.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool checkAllowedType(
    GCValueValueType type
)
Public Overrides Function checkAllowedType (
    type As GCValueValueType
) As Boolean
public:
virtual bool checkAllowedType(
    GCValueValueType type
) override
abstract checkAllowedType :
        type : GCValueValueType -> bool
override checkAllowedType :
        type : GCValueValueType -> bool

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Instance.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Instance.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Implements

IGCOwnercheckAllowedType(GCValueValueType)
See Also

Reference

GCStructuredValueInstance Class
DXMLBase.Gcv Namespace


GCStructuredValue.Instance.toXml Method

GCStructuredValueInstancetoXml Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Instance.toXml(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement toXml(
    XmlNode parent
)
Public Overridable Function toXml (
    parent As XmlNode
) As XmlElement
public:
virtual XmlElement^ toXml(
    XmlNode^ parent
)
abstract toXml :
        parent : XmlNode -> XmlElement
override toXml :
        parent : XmlNode -> XmlElement

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Instance.toXml(System.Xml.XmlNode)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Instance.toXml(System.Xml.XmlNode)"]

See Also

Reference

GCStructuredValueInstance Class
DXMLBase.Gcv Namespace


Instance Properties

Instance Properties

The GCStructuredValueInstance type exposes the following members.

Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Top
See Also

Reference

GCStructuredValueInstance Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template Class

GCStructuredValueTemplate Class
Class representing the template definitions for a
Copy
GCStructuredValue
.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCList
DXMLBase.GcvGCStructuredValueTemplate

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Template : GCList
Public Class Template
    Inherits GCList
public ref class Template : public GCList
type Template =
    class
        inherit GCList
    end

The GCStructuredValueTemplate type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Overrides GCListappendValue(GCValue).)
Public method | checkAllowedType | (Overrides GCListcheckAllowedType(GCValueValueType).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Overrides GCListinsertValue(GCValue, GCValue).)
Public method | insertValue(GCValue, String) | (Overrides GCListinsertValue(GCValue, String).)
Public method | isNameAllowed | (Inherited from GCList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Overrides GCListremoveValue(String).)
Public method | removeValue(GCValue) | (Overrides GCListremoveValue(GCValue).)
Public method | replaceValue | (Overrides GCListreplaceValue(GCValue, GCValue).)
Public method | resetModified | (Inherited from GCList.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Public property | MaxCount |
Public property | MinCount |
Top
See Also

Reference

DXMLBase.Gcv Namespace


Template Fields

Template Fields

The GCStructuredValueTemplate type exposes the following members.

Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


Template Methods

Template Methods

The GCStructuredValueTemplate type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Overrides GCListappendValue(GCValue).)
Public method | checkAllowedType | (Overrides GCListcheckAllowedType(GCValueValueType).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Overrides GCListinsertValue(GCValue, GCValue).)
Public method | insertValue(GCValue, String) | (Overrides GCListinsertValue(GCValue, String).)
Public method | isNameAllowed | (Inherited from GCList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Overrides GCListremoveValue(String).)
Public method | removeValue(GCValue) | (Overrides GCListremoveValue(GCValue).)
Public method | replaceValue | (Overrides GCListreplaceValue(GCValue, GCValue).)
Public method | resetModified | (Inherited from GCList.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template.appendValue Method

GCStructuredValueTemplateappendValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.appendValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void appendValue(
    GCValue value
)
Public Overrides Sub appendValue (
    value As GCValue
)
public:
virtual void appendValue(
    GCValue^ value
) override
abstract appendValue :
        value : GCValue -> unit
override appendValue :
        value : GCValue -> unit

Parameters

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.appendValue(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerappendValue(GCValue)
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template.checkAllowedType Method

GCStructuredValueTemplatecheckAllowedType Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool checkAllowedType(
    GCValueValueType type
)
Public Overrides Function checkAllowedType (
    type As GCValueValueType
) As Boolean
public:
virtual bool checkAllowedType(
    GCValueValueType type
) override
abstract checkAllowedType :
        type : GCValueValueType -> bool
override checkAllowedType :
        type : GCValueValueType -> bool

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Implements

IGCOwnercheckAllowedType(GCValueValueType)
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


Template.insertValue Method

TemplateinsertValue Method
Overload List
 | Name | Description
Public method | insertValue(GCValue, GCValue) | (Overrides GCListinsertValue(GCValue, GCValue).)
Public method | insertValue(GCValue, String) | (Overrides GCListinsertValue(GCValue, String).)
Top
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template.insertValue Method (GCValue, GCValue)

GCStructuredValueTemplateinsertValue Method (GCValue, GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void insertValue(
    GCValue newValue,
    GCValue insertionPoint
)
Public Overrides Sub insertValue (
    newValue As GCValue,
    insertionPoint As GCValue
)
public:
virtual void insertValue(
    GCValue^ newValue,
    GCValue^ insertionPoint
) override
abstract insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit
override insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

insertionPoint
Type: DXMLBase.GcvGCValue

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerinsertValue(GCValue, GCValue)
See Also

Reference

GCStructuredValueTemplate Class
insertValue Overload
DXMLBase.Gcv Namespace


GCStructuredValue.Template.insertValue Method (GCValue, String)

GCStructuredValueTemplateinsertValue Method (GCValue, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void insertValue(
    GCValue newValue,
    string insertionPoint
)
Public Overrides Sub insertValue (
    newValue As GCValue,
    insertionPoint As String
)
public:
virtual void insertValue(
    GCValue^ newValue,
    String^ insertionPoint
) override
abstract insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit
override insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

insertionPoint
Type: SystemString

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Implements

IGCOwnerinsertValue(GCValue, String)
See Also

Reference

GCStructuredValueTemplate Class
insertValue Overload
DXMLBase.Gcv Namespace


Template.removeValue Method

TemplateremoveValue Method
Overload List
 | Name | Description
Public method | removeValue(String) | (Overrides GCListremoveValue(String).)
Public method | removeValue(GCValue) | (Overrides GCListremoveValue(GCValue).)
Top
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template.removeValue Method (String)

GCStructuredValueTemplateremoveValue Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.removeValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool removeValue(
    string name
)
Public Overrides Function removeValue (
    name As String
) As Boolean
public:
virtual bool removeValue(
    String^ name
) override
abstract removeValue :
        name : string -> bool
override removeValue :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.removeValue(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.removeValue(System.String)"]

Implements

IGCOwnerremoveValue(String)
See Also

Reference

GCStructuredValueTemplate Class
removeValue Overload
DXMLBase.Gcv Namespace


GCStructuredValue.Template.removeValue Method (GCValue)

GCStructuredValueTemplateremoveValue Method (GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.removeValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool removeValue(
    GCValue value_Renamed
)
Public Overrides Function removeValue (
    value_Renamed As GCValue
) As Boolean
public:
virtual bool removeValue(
    GCValue^ value_Renamed
) override
abstract removeValue :
        value_Renamed : GCValue -> bool
override removeValue :
        value_Renamed : GCValue -> bool

Parameters

value_Renamed
Type: DXMLBase.GcvGCValue

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.removeValue(DXMLBase.Gcv.GCValue)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.removeValue(DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerremoveValue(GCValue)
See Also

Reference

GCStructuredValueTemplate Class
removeValue Overload
DXMLBase.Gcv Namespace


GCStructuredValue.Template.replaceValue Method

GCStructuredValueTemplatereplaceValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void replaceValue(
    GCValue newValue,
    GCValue oldValue
)
Public Overrides Sub replaceValue (
    newValue As GCValue,
    oldValue As GCValue
)
public:
virtual void replaceValue(
    GCValue^ newValue,
    GCValue^ oldValue
) override
abstract replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit
override replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.GCStructuredValue.Template.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Implements

IGCOwnerreplaceValue(GCValue, GCValue)
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


Template Properties

Template Properties

The GCStructuredValueTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Public property | MaxCount |
Public property | MinCount |
Top
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template.MaxCount Property

GCStructuredValueTemplateMaxCount Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.Template.MaxCount"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MaxCount { get; set; }
Public Overridable Property MaxCount As Integer
    Get
    Set
public:
virtual property int MaxCount {
    int get ();
    void set (int value);
}
abstract MaxCount : int with get, set
override MaxCount : int with get, set

Property Value

Type: Int32
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCStructuredValue.Template.MinCount Property

GCStructuredValueTemplateMinCount Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCStructuredValue.Template.MinCount"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MinCount { get; set; }
Public Overridable Property MinCount As Integer
    Get
    Set
public:
virtual property int MinCount {
    int get ();
    void set (int value);
}
abstract MinCount : int with get, set
override MinCount : int with get, set

Property Value

Type: Int32
See Also

Reference

GCStructuredValueTemplate Class
DXMLBase.Gcv Namespace


GCSubordinates Class

GCSubordinates Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCSubordinates"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCParent
DXMLBase.GcvGCSubordinates

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCSubordinates : GCParent
Public Class GCSubordinates
    Inherits GCParent
public ref class GCSubordinates : public GCParent
type GCSubordinates =
    class
        inherit GCParent
    end

The GCSubordinates type exposes the following members.

Constructors
 | Name | Description
Protected method | GCSubordinates(String, IGCOwner) | Initializes a new instance of the GCSubordinates class
Protected method | GCSubordinates(XmlElement, IGCOwner) | Initializes a new instance of the GCSubordinates class
Top
Methods
 | Name | Description
Public method | addName | (Inherited from GCParent.)
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendValue | (Inherited from GCParent.)
Public method | checkAllowedType | (Inherited from GCParent.)
Protected method | cloneCommon | (Inherited from GCParent.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCParent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCParent.)
Public method | insertValue(GCValue, String) | (Inherited from GCParent.)
Public method | isNameAllowed | (Inherited from GCParent.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Inherited from GCParent.)
Public method | removeName | (Inherited from GCParent.)
Public method | removeValue(String) | (Inherited from GCParent.)
Public method | removeValue(GCValue) | (Inherited from GCParent.)
Public method | replaceValue | (Inherited from GCParent.)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Protected method | validateActiveValue |
Top
Fields
 | Name | Description
Protected field | cloning | (Inherited from GCParent.)
Protected field | modified | (Inherited from GCValue.)
Protected field | owner | (Inherited from GCParent.)
Top
Properties
Name | Description
Public property | ActiveValue
Public property | Children | (Inherited from GCParent.)
Public property | Descendants | (Inherited from GCParent.)
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Inherited from GCParent.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCSubordinates Constructor

GCSubordinates Constructor
Overload List
 | Name | Description
Protected method | GCSubordinates(String, IGCOwner) | Initializes a new instance of the GCSubordinates class
Protected method | GCSubordinates(XmlElement, IGCOwner) | Initializes a new instance of the GCSubordinates class
Top
See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCSubordinates Constructor (String, IGCOwner)

GCSubordinates Constructor (String, IGCOwner)
Initializes a new instance of the GCSubordinates class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCSubordinates(
    string activeValue,
    IGCOwner owner
)
Protected Sub New (
    activeValue As String,
    owner As IGCOwner
)
protected:
GCSubordinates(
    String^ activeValue,
    IGCOwner^ owner
)
new :
        activeValue : string *
        owner : IGCOwner -> GCSubordinates

Parameters

activeValue
Type: SystemString

[Missing <param name="activeValue"/> documentation for "M:DXMLBase.Gcv.GCSubordinates.#ctor(System.String,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCSubordinates.#ctor(System.String,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCSubordinates Class
GCSubordinates Overload
DXMLBase.Gcv Namespace


GCSubordinates Constructor (XmlElement, IGCOwner)

GCSubordinates Constructor (XmlElement, IGCOwner)
Initializes a new instance of the GCSubordinates class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCSubordinates(
    XmlElement definition,
    IGCOwner owner
)
Protected Sub New (
    definition As XmlElement,
    owner As IGCOwner
)
protected:
GCSubordinates(
    XmlElement^ definition,
    IGCOwner^ owner
)
new :
        definition : XmlElement *
        owner : IGCOwner -> GCSubordinates

Parameters

definition
Type: System.XmlXmlElement

[Missing <param name="definition"/> documentation for "M:DXMLBase.Gcv.GCSubordinates.#ctor(System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCSubordinates.#ctor(System.Xml.XmlElement,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCSubordinates Class
GCSubordinates Overload
DXMLBase.Gcv Namespace


GCSubordinates Fields

GCSubordinates Fields

The GCSubordinates type exposes the following members.

Fields
 | Name | Description
Protected field | cloning | (Inherited from GCParent.)
Protected field | modified | (Inherited from GCValue.)
Protected field | owner | (Inherited from GCParent.)
Top
See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCSubordinates Methods

GCSubordinates Methods

The GCSubordinates type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCParent.)
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Public method | appendValue | (Inherited from GCParent.)
Public method | checkAllowedType | (Inherited from GCParent.)
Protected method | cloneCommon | (Inherited from GCParent.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCParent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCParent.)
Public method | insertValue(GCValue, String) | (Inherited from GCParent.)
Public method | isNameAllowed | (Inherited from GCParent.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Inherited from GCParent.)
Public method | removeName | (Inherited from GCParent.)
Public method | removeValue(String) | (Inherited from GCParent.)
Public method | removeValue(GCValue) | (Inherited from GCParent.)
Public method | replaceValue | (Inherited from GCParent.)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Protected method | validateActiveValue |
Top
See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCSubordinates.cloneValue Method

GCSubordinatescloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCSubordinates.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCSubordinates.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCSubordinates.cloneValue(System.String)"]

See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCSubordinates.validateActiveValue Method

GCSubordinatesvalidateActiveValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCSubordinates.validateActiveValue"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual bool validateActiveValue()
Protected Overridable Function validateActiveValue As Boolean
protected:
virtual bool validateActiveValue()
abstract validateActiveValue : unit -> bool
override validateActiveValue : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCSubordinates.validateActiveValue"]

See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCSubordinates Properties

GCSubordinates Properties

The GCSubordinates type exposes the following members.

Properties
Name | Description
Public property | ActiveValue
Public property | Children | (Inherited from GCParent.)
Public property | Descendants | (Inherited from GCParent.)
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property Value
Override, does nothing.
(Inherited from GCParent.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCSubordinates.ActiveValue Property

GCSubordinatesActiveValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCSubordinates.ActiveValue"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ActiveValue { get; set; }
Public Overridable Property ActiveValue As String
    Get
    Set
public:
virtual property String^ ActiveValue {
    String^ get ();
    void set (String^ value);
}
abstract ActiveValue : string with get, set
override ActiveValue : string with get, set

Property Value

Type: String
See Also

Reference

GCSubordinates Class
DXMLBase.Gcv Namespace


GCTest Class

GCTest Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCTest"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCTest

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GCTest
Public NotInheritable Class GCTest
public ref class GCTest abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GCTest =  class end

The GCTest type exposes the following members.

Methods
Name | Description
Main |
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCTest Methods

GCTest Methods

The GCTest type exposes the following members.

Methods
Name | Description
Main |
Top
See Also

Reference

GCTest Class
DXMLBase.Gcv Namespace


GCTest.Main Method

GCTestMain Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCTest.Main(System.String[])"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Main(
    string[] args
)
Public Shared Sub Main (
    args As String()
)
public:
static void Main(
    array<String^>^ args
)
static member Main :
        args : string[] -> unit

Parameters

args
Type: SystemString

[Missing <param name="args"/> documentation for "M:DXMLBase.Gcv.GCTest.Main(System.String[])"]

See Also

Reference

GCTest Class
DXMLBase.Gcv Namespace


GCValue Class

GCValue Class
Base class for all Global Configuration Value types.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
More...

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class GCValue : IConfigElement
Public MustInherit Class GCValue
    Implements IConfigElement
public ref class GCValue abstract : IConfigElement
[<AbstractClassAttribute>]
type GCValue =
    class
        interface IConfigElement
    end

The GCValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment |
Protected method | addXmlItems |
Public method | addXmlProcessingInstruction |
Protected method | cloneCommon |
Public method | cloneValue |
 | construct(String, String, GCValueValueType) |
 | construct(String, String, String, GCValueValueType) |
 | constructGCVRef(String) |
 | constructGCVRef(String, String) |
 | constructGroup |
 | constructHeader |
 | constructStructuredValue |
 | constructSubordinates |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue |
Public method | hasBeenModified |
 | isValidName |
 | isValidText |
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue |
Public method | resetModified |
Protected method | setParent |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML |
 | typeFromString |
Top
Fields
 | Name | Description
Protected field | modified |
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
Public property DescriptionRef
Get or set the description localization reference. May return null.
Public property | DisplayName
Public property | DisplayNameRef
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
Public property | Name
Public property | Parent
Public property | Type
Public property | TypeString
Public property | Value
Public property | XmlItems
Top
See Also

Reference

DXMLBase.Gcv Namespace
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCBooleanValue
DXMLBase.GcvGCDnRefValue
DXMLBase.GcvGCDNValue
DXMLBase.GcvGCEnumValue
DXMLBase.GcvGCHeader
DXMLBase.GcvGCIntegerValue
DXMLBase.GcvGCListValue
DXMLBase.GcvGCParent
DXMLBase.GcvGCPasswordRefValue
DXMLBase.GcvGCRealValue
DXMLBase.GcvGCStringValue
DXMLBase.GcvGCStructuredValue
DXMLBase.GcvGCVRef


GCValue Fields

GCValue Fields

The GCValue type exposes the following members.

Fields
 | Name | Description
Protected field | modified |
Top
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.modified Field

GCValuemodified Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCValue.modified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool modified
Protected modified As Boolean
protected:
bool modified
val mutable modified: bool

Field Value

Type: Boolean
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue Methods

GCValue Methods

The GCValue type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment |
Protected method | addXmlItems |
Public method | addXmlProcessingInstruction |
Protected method | cloneCommon |
Public method | cloneValue |
 | construct(String, String, GCValueValueType) |
 | construct(String, String, String, GCValueValueType) |
 | constructGCVRef(String) |
 | constructGCVRef(String, String) |
 | constructGroup |
 | constructHeader |
 | constructStructuredValue |
 | constructSubordinates |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue |
Public method | hasBeenModified |
 | isValidName |
 | isValidText |
Public method | localize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue |
Public method | resetModified |
Protected method | setParent |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML |
 | typeFromString |
Top
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.addXmlComment Method

GCValueaddXmlComment Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.addXmlComment(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void addXmlComment(
    string data
)
Public Overridable Sub addXmlComment (
    data As String
)
public:
virtual void addXmlComment(
    String^ data
)
abstract addXmlComment :
        data : string -> unit
override addXmlComment :
        data : string -> unit

Parameters

data
Type: SystemString

[Missing <param name="data"/> documentation for "M:DXMLBase.Gcv.GCValue.addXmlComment(System.String)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.addXmlItems Method

GCValueaddXmlItems Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.addXmlItems(System.Xml.XmlElement)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void addXmlItems(
    XmlElement definition
)
Protected Overridable Sub addXmlItems (
    definition As XmlElement
)
protected:
virtual void addXmlItems(
    XmlElement^ definition
)
abstract addXmlItems :
        definition : XmlElement -> unit
override addXmlItems :
        definition : XmlElement -> unit

Parameters

definition
Type: System.XmlXmlElement

[Missing <param name="definition"/> documentation for "M:DXMLBase.Gcv.GCValue.addXmlItems(System.Xml.XmlElement)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.addXmlProcessingInstruction Method

GCValueaddXmlProcessingInstruction Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.addXmlProcessingInstruction(System.String,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void addXmlProcessingInstruction(
    string target,
    string data
)
Public Overridable Sub addXmlProcessingInstruction (
    target As String,
    data As String
)
public:
virtual void addXmlProcessingInstruction(
    String^ target,
    String^ data
)
abstract addXmlProcessingInstruction :
        target : string *
        data : string -> unit
override addXmlProcessingInstruction :
        target : string *
        data : string -> unit

Parameters

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:DXMLBase.Gcv.GCValue.addXmlProcessingInstruction(System.String,System.String)"]

data
Type: SystemString

[Missing <param name="data"/> documentation for "M:DXMLBase.Gcv.GCValue.addXmlProcessingInstruction(System.String,System.String)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.cloneCommon Method

GCValuecloneCommon Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.cloneCommon(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void cloneCommon(
    GCValue newValue
)
Protected Overridable Sub cloneCommon (
    newValue As GCValue
)
protected:
virtual void cloneCommon(
    GCValue^ newValue
)
abstract cloneCommon :
        newValue : GCValue -> unit
override cloneCommon :
        newValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.GCValue.cloneCommon(DXMLBase.Gcv.GCValue)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.cloneValue Method

GCValuecloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract GCValue cloneValue(
    string name
)
Public MustOverride Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) abstract
abstract cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.cloneValue(System.String)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.construct Method

GCValueconstruct Method
Overload List
Name | Description
construct(String, String, GCValueValueType) |
construct(String, String, String, GCValueValueType) |
Top
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.construct Method (String, String, GCValue.ValueType)

GCValueconstruct Method (String, String, GCValueValueType)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue construct(
    string name,
    string displayName,
    GCValueValueType type
)
Public Shared Function construct (
    name As String,
    displayName As String,
    type As GCValueValueType
) As GCValue
public:
static GCValue^ construct(
    String^ name,
    String^ displayName,
    GCValueValueType type
)
static member construct :
        name : string *
        displayName : string *
        type : GCValueValueType -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

See Also

Reference

GCValue Class
construct Overload
DXMLBase.Gcv Namespace


GCValue.construct Method (String, String, String, GCValue.ValueType)

GCValueconstruct Method (String, String, String, GCValueValueType)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue construct(
    string name,
    string displayName,
    string displayNameRef,
    GCValueValueType type
)
Public Shared Function construct (
    name As String,
    displayName As String,
    displayNameRef As String,
    type As GCValueValueType
) As GCValue
public:
static GCValue^ construct(
    String^ name,
    String^ displayName,
    String^ displayNameRef,
    GCValueValueType type
)
static member construct :
        name : string *
        displayName : string *
        displayNameRef : string *
        type : GCValueValueType -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

displayNameRef
Type: SystemString

[Missing <param name="displayNameRef"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.construct(System.String,System.String,System.String,DXMLBase.Gcv.GCValue.ValueType)"]

See Also

Reference

GCValue Class
construct Overload
DXMLBase.Gcv Namespace


GCValue.constructGCVRef Method

GCValueconstructGCVRef Method
Overload List
Name | Description
constructGCVRef(String) |
constructGCVRef(String, String) |
Top
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.constructGCVRef Method (String)

GCValueconstructGCVRef Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue constructGCVRef(
    string name
)
Public Shared Function constructGCVRef (
    name As String
) As GCValue
public:
static GCValue^ constructGCVRef(
    String^ name
)
static member constructGCVRef :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String)"]

See Also

Reference

GCValue Class
constructGCVRef Overload
DXMLBase.Gcv Namespace


GCValue.constructGCVRef Method (String, String)

GCValueconstructGCVRef Method (String, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue constructGCVRef(
    string name,
    string driverParamName
)
Public Shared Function constructGCVRef (
    name As String,
    driverParamName As String
) As GCValue
public:
static GCValue^ constructGCVRef(
    String^ name,
    String^ driverParamName
)
static member constructGCVRef :
        name : string *
        driverParamName : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String,System.String)"]

driverParamName
Type: SystemString

[Missing <param name="driverParamName"/> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String,System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.constructGCVRef(System.String,System.String)"]

See Also

Reference

GCValue Class
constructGCVRef Overload
DXMLBase.Gcv Namespace


GCValue.constructGroup Method

GCValueconstructGroup Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.constructGroup(DXMLBase.Gcv.IGCOwner)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue constructGroup(
    IGCOwner owner
)
Public Shared Function constructGroup (
    owner As IGCOwner
) As GCValue
public:
static GCValue^ constructGroup(
    IGCOwner^ owner
)
static member constructGroup :
        owner : IGCOwner -> GCValue

Parameters

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCValue.constructGroup(DXMLBase.Gcv.IGCOwner)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.constructGroup(DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.constructHeader Method

GCValueconstructHeader Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.constructHeader(System.String,DXMLBase.Gcv.IGCOwner)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue constructHeader(
    string displayName,
    IGCOwner owner
)
Public Shared Function constructHeader (
    displayName As String,
    owner As IGCOwner
) As GCValue
public:
static GCValue^ constructHeader(
    String^ displayName,
    IGCOwner^ owner
)
static member constructHeader :
        displayName : string *
        owner : IGCOwner -> GCValue

Parameters

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCValue.constructHeader(System.String,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCValue.constructHeader(System.String,DXMLBase.Gcv.IGCOwner)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.constructHeader(System.String,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.constructStructuredValue Method

GCValueconstructStructuredValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.constructStructuredValue(System.String,System.String,DXMLBase.Gcv.IGCOwner)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue constructStructuredValue(
    string name,
    string displayName,
    IGCOwner owner
)
Public Shared Function constructStructuredValue (
    name As String,
    displayName As String,
    owner As IGCOwner
) As GCValue
public:
static GCValue^ constructStructuredValue(
    String^ name,
    String^ displayName,
    IGCOwner^ owner
)
static member constructStructuredValue :
        name : string *
        displayName : string *
        owner : IGCOwner -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.constructStructuredValue(System.String,System.String,DXMLBase.Gcv.IGCOwner)"]

displayName
Type: SystemString

[Missing <param name="displayName"/> documentation for "M:DXMLBase.Gcv.GCValue.constructStructuredValue(System.String,System.String,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCValue.constructStructuredValue(System.String,System.String,DXMLBase.Gcv.IGCOwner)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.constructStructuredValue(System.String,System.String,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.constructSubordinates Method

GCValueconstructSubordinates Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.constructSubordinates(System.String,DXMLBase.Gcv.IGCOwner)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValue constructSubordinates(
    string activeValue,
    IGCOwner owner
)
Public Shared Function constructSubordinates (
    activeValue As String,
    owner As IGCOwner
) As GCValue
public:
static GCValue^ constructSubordinates(
    String^ activeValue,
    IGCOwner^ owner
)
static member constructSubordinates :
        activeValue : string *
        owner : IGCOwner -> GCValue

Parameters

activeValue
Type: SystemString

[Missing <param name="activeValue"/> documentation for "M:DXMLBase.Gcv.GCValue.constructSubordinates(System.String,DXMLBase.Gcv.IGCOwner)"]

owner
Type: DXMLBase.GcvIGCOwner

[Missing <param name="owner"/> documentation for "M:DXMLBase.Gcv.GCValue.constructSubordinates(System.String,DXMLBase.Gcv.IGCOwner)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.constructSubordinates(System.String,DXMLBase.Gcv.IGCOwner)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.getOwner Method

GCValuegetOwner Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.getOwner"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IGCOwner getOwner()
Public Overridable Function getOwner As IGCOwner
public:
virtual IGCOwner^ getOwner()
abstract getOwner : unit -> IGCOwner
override getOwner : unit -> IGCOwner

Return Value

Type: IGCOwner

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.getOwner"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.getXMLValue Method

GCValuegetXMLValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.getXMLValue(System.Xml.XmlDocument)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlNode getXMLValue(
    XmlDocument document
)
Public Overridable Function getXMLValue (
    document As XmlDocument
) As XmlNode
public:
virtual XmlNode^ getXMLValue(
    XmlDocument^ document
)
abstract getXMLValue :
        document : XmlDocument -> XmlNode
override getXMLValue :
        document : XmlDocument -> XmlNode

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:DXMLBase.Gcv.GCValue.getXMLValue(System.Xml.XmlDocument)"]

Return Value

Type: XmlNode

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.getXMLValue(System.Xml.XmlDocument)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.hasBeenModified Method

GCValuehasBeenModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.hasBeenModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool hasBeenModified()
Public Overridable Function hasBeenModified As Boolean
public:
virtual bool hasBeenModified()
abstract hasBeenModified : unit -> bool
override hasBeenModified : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.hasBeenModified"]

Implements

IConfigElementhasBeenModified
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.isValidName Method

GCValueisValidName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.isValidName(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isValidName(
    string name
)
Protected Shared Function isValidName (
    name As String
) As Boolean
protected:
static bool isValidName(
    String^ name
)
static member isValidName :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCValue.isValidName(System.String)"]

Return Value

Type: Boolean
true or false
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.isValidText Method

GCValueisValidText Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.isValidText(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isValidText(
    string text
)
Protected Shared Function isValidText (
    text As String
) As Boolean
protected:
static bool isValidText(
    String^ text
)
static member isValidText :
        text : string -> bool

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:DXMLBase.Gcv.GCValue.isValidText(System.String)"]

Return Value

Type: Boolean
true or false
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.localize Method

GCValuelocalize Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.localize(DXMLBase.LocalizedMessageSource)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void localize(
    LocalizedMessageSource messageSource
)
Public Overridable Sub localize (
    messageSource As LocalizedMessageSource
)
public:
virtual void localize(
    LocalizedMessageSource^ messageSource
)
abstract localize :
        messageSource : LocalizedMessageSource -> unit
override localize :
        messageSource : LocalizedMessageSource -> unit

Parameters

messageSource
Type: DXMLBaseLocalizedMessageSource

[Missing <param name="messageSource"/> documentation for "M:DXMLBase.Gcv.GCValue.localize(DXMLBase.LocalizedMessageSource)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.parseValue Method

GCValueparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void parseValue(
    string value_Renamed
)
Public MustOverride Sub parseValue (
    value_Renamed As String
)
public:
virtual void parseValue(
    String^ value_Renamed
) abstract
abstract parseValue :
        value_Renamed : string -> unit

Parameters

value_Renamed
Type: SystemString

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCValue.parseValue(System.String)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.resetModified Method

GCValueresetModified Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.resetModified"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void resetModified()
Public Overridable Sub resetModified
public:
virtual void resetModified()
abstract resetModified : unit -> unit
override resetModified : unit -> unit

Implements

IConfigElementresetModified
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.setParent Method

GCValuesetParent Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.setParent(DXMLBase.Gcv.GCParent)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void setParent(
    GCParent newParent
)
Protected Overridable Sub setParent (
    newParent As GCParent
)
protected:
virtual void setParent(
    GCParent^ newParent
)
abstract setParent :
        newParent : GCParent -> unit
override setParent :
        newParent : GCParent -> unit

Parameters

newParent
Type: DXMLBase.GcvGCParent
The new parent (may be null).
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.toXML Method

GCValuetoXML Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.toXML(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement toXML(
    XmlNode parent
)
Public Overridable Function toXML (
    parent As XmlNode
) As XmlElement
public:
virtual XmlElement^ toXML(
    XmlNode^ parent
)
abstract toXML :
        parent : XmlNode -> XmlElement
override toXML :
        parent : XmlNode -> XmlElement

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.GCValue.toXML(System.Xml.XmlNode)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.toXML(System.Xml.XmlNode)"]

Implements

IConfigElementtoXML(XmlNode)
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.typeFromString Method

GCValuetypeFromString Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.typeFromString(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GCValueValueType typeFromString(
    string typeString
)
Public Shared Function typeFromString (
    typeString As String
) As GCValueValueType
public:
static GCValueValueType typeFromString(
    String^ typeString
)
static member typeFromString :
        typeString : string -> GCValueValueType

Parameters

typeString
Type: SystemString

[Missing <param name="typeString"/> documentation for "M:DXMLBase.Gcv.GCValue.typeFromString(System.String)"]

Return Value

Type: GCValueValueType

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.typeFromString(System.String)"]

See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue Properties

GCValue Properties

The GCValue type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
Public property DescriptionRef
Get or set the description localization reference. May return null.
Public property | DisplayName
Public property | DisplayNameRef
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
Public property | Name
Public property | Parent
Public property | Type
Public property | TypeString
Public property | Value
Public property | XmlItems
Top
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Description Property

GCValueDescription Property
Get or set the description of this value. May return
Copy
null
, or an empty string.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.DescriptionRef Property

GCValueDescriptionRef Property
Get or set the description localization reference. May return null.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DescriptionRef { get; set; }
Public Overridable Property DescriptionRef As String
    Get
    Set
public:
virtual property String^ DescriptionRef {
    String^ get ();
    void set (String^ value);
}
abstract DescriptionRef : string with get, set
override DescriptionRef : string with get, set

Property Value

Type: String
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.DisplayName Property

GCValueDisplayName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.DisplayName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DisplayName { get; set; }
Public Overridable Property DisplayName As String
    Get
    Set
public:
virtual property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
abstract DisplayName : string with get, set
override DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.DisplayNameRef Property

GCValueDisplayNameRef Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.DisplayNameRef"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DisplayNameRef { get; set; }
Public Overridable Property DisplayNameRef As String
    Get
    Set
public:
virtual property String^ DisplayNameRef {
    String^ get ();
    void set (String^ value);
}
abstract DisplayNameRef : string with get, set
override DisplayNameRef : string with get, set

Property Value

Type: String
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Hidden Property

GCValueHidden Property
Get or set whether this GCV should be hidden in the user interface.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Hidden { get; set; }
Public Overridable Property Hidden As Boolean
    Get
    Set
public:
virtual property bool Hidden {
    bool get ();
    void set (bool value);
}
abstract Hidden : bool with get, set
override Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Mandatory Property

GCValueMandatory Property
Get or set whether the UI should require that a value be entered for this GCV.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Mandatory { get; set; }
Public Overridable Property Mandatory As Boolean
    Get
    Set
public:
virtual property bool Mandatory {
    bool get ();
    void set (bool value);
}
abstract Mandatory : bool with get, set
override Mandatory : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Name Property

GCValueName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.Name"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get

Return Value

Type: String
name
Copy
String
(never
Copy
null
).
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Parent Property

GCValueParent Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.Parent"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCParent Parent { get; }
Public Overridable ReadOnly Property Parent As GCParent
    Get
public:
virtual property GCParent^ Parent {
    GCParent^ get ();
}
abstract Parent : GCParent with get
override Parent : GCParent with get

Return Value

Type: GCParent
parent (may be
Copy
null
)
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Type Property

GCValueType Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.Type"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GCValueValueType Type { get; }
Public Overridable ReadOnly Property Type As GCValueValueType
    Get
public:
virtual property GCValueValueType Type {
    GCValueValueType get ();
}
abstract Type : GCValueValueType with get
override Type : GCValueValueType with get

Return Value

Type: GCValueValueType
Copy
ValueType.TYPE_STRING
,
Copy
ValueType.TYPE_BOOLEAN
, etc.
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.TypeString Property

GCValueTypeString Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.TypeString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string TypeString { get; }
Public Overridable ReadOnly Property TypeString As String
    Get
public:
virtual property String^ TypeString {
    String^ get ();
}
abstract TypeString : string with get
override TypeString : string with get

Return Value

Type: String
"string", "boolean", etc. (never
Copy
null
).
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Value Property

GCValueValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract string Value { get; set; }
Public MustOverride Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () abstract;
    void set (String^ value) abstract;
}
abstract Value : string with get, set

Property Value

Type: String
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.XmlItems Property

GCValueXmlItems Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.XmlItems"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<GCValueXmlItem> XmlItems { get; }
Public Overridable ReadOnly Property XmlItems As IEnumerable(Of GCValueXmlItem)
    Get
public:
virtual property IEnumerable<GCValueXmlItem^>^ XmlItems {
    IEnumerable<GCValueXmlItem^>^ get ();
}
abstract XmlItems : IEnumerable<GCValueXmlItem> with get
override XmlItems : IEnumerable<GCValueXmlItem> with get

Property Value

Type: IEnumerable GCValueXmlItem
See Also

Reference

GCValue Class
DXMLBase.Gcv Namespace


GCValue.Comment Class

GCValueComment Class
Class for representing XML comments.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValueXmlItem
DXMLBase.GcvGCValueComment

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Comment : GCValueXmlItem
Public Class Comment
    Inherits GCValueXmlItem
public ref class Comment : public GCValueXmlItem
type Comment =
    class
        inherit GCValueXmlItem
    end

The GCValueComment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Data |
Top
See Also

Reference

DXMLBase.Gcv Namespace


Comment Methods

Comment Methods

The GCValueComment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

GCValueComment Class
DXMLBase.Gcv Namespace


GCValue.Comment.ToString Method

GCValueCommentToString Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.Comment.ToString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.Comment.ToString"]

See Also

Reference

GCValueComment Class
DXMLBase.Gcv Namespace


Comment Properties

Comment Properties

The GCValueComment type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Top
See Also

Reference

GCValueComment Class
DXMLBase.Gcv Namespace


GCValue.Comment.Data Property

GCValueCommentData Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.Comment.Data"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Data { get; }
Public Overridable ReadOnly Property Data As String
    Get
public:
virtual property String^ Data {
    String^ get ();
}
abstract Data : string with get
override Data : string with get

Property Value

Type: String
See Also

Reference

GCValueComment Class
DXMLBase.Gcv Namespace


GCValue.IllegalCloneStateException Class

GCValueIllegalCloneStateException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCValue.IllegalCloneStateException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCValueIllegalCloneStateException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IllegalCloneStateException : Exception
Public Class IllegalCloneStateException
    Inherits Exception
public ref class IllegalCloneStateException : public Exception
type IllegalCloneStateException =
    class
        inherit Exception
    end

The GCValueIllegalCloneStateException type exposes the following members.

Constructors
 | Name | Description
Public method | GCValueIllegalCloneStateException | Initializes a new instance of the GCValueIllegalCloneStateException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCValue.IllegalCloneStateException Constructor

GCValueIllegalCloneStateException Constructor
Initializes a new instance of the GCValueIllegalCloneStateException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IllegalCloneStateException(
    Exception cause
)
Public Sub New (
    cause As Exception
)
public:
IllegalCloneStateException(
    Exception^ cause
)
new :
        cause : Exception -> IllegalCloneStateException

Parameters

cause
Type: SystemException

[Missing <param name="cause"/> documentation for "M:DXMLBase.Gcv.GCValue.IllegalCloneStateException.#ctor(System.Exception)"]

See Also

Reference

GCValueIllegalCloneStateException Class
DXMLBase.Gcv Namespace


IllegalCloneStateException Methods

IllegalCloneStateException Methods

The GCValueIllegalCloneStateException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueIllegalCloneStateException Class
DXMLBase.Gcv Namespace


IllegalCloneStateException Properties

IllegalCloneStateException Properties

The GCValueIllegalCloneStateException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueIllegalCloneStateException Class
DXMLBase.Gcv Namespace


IllegalCloneStateException Events

IllegalCloneStateException Events

The GCValueIllegalCloneStateException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueIllegalCloneStateException Class
DXMLBase.Gcv Namespace


GCValue.ProcessingInstruction Class

GCValueProcessingInstruction Class
Class for representing XML processing instructions.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValueXmlItem
DXMLBase.GcvGCValueProcessingInstruction

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProcessingInstruction : GCValueXmlItem
Public Class ProcessingInstruction
    Inherits GCValueXmlItem
public ref class ProcessingInstruction : public GCValueXmlItem
type ProcessingInstruction =
    class
        inherit GCValueXmlItem
    end

The GCValueProcessingInstruction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Data |
Public property | Target |
Top
See Also

Reference

DXMLBase.Gcv Namespace


ProcessingInstruction Methods

ProcessingInstruction Methods

The GCValueProcessingInstruction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

GCValueProcessingInstruction Class
DXMLBase.Gcv Namespace


GCValue.ProcessingInstruction.ToString Method

GCValueProcessingInstructionToString Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCValue.ProcessingInstruction.ToString"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCValue.ProcessingInstruction.ToString"]

See Also

Reference

GCValueProcessingInstruction Class
DXMLBase.Gcv Namespace


ProcessingInstruction Properties

ProcessingInstruction Properties

The GCValueProcessingInstruction type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Public property | Target |
Top
See Also

Reference

GCValueProcessingInstruction Class
DXMLBase.Gcv Namespace


GCValue.ProcessingInstruction.Data Property

GCValueProcessingInstructionData Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.ProcessingInstruction.Data"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Data { get; }
Public Overridable ReadOnly Property Data As String
    Get
public:
virtual property String^ Data {
    String^ get ();
}
abstract Data : string with get
override Data : string with get

Property Value

Type: String
See Also

Reference

GCValueProcessingInstruction Class
DXMLBase.Gcv Namespace


GCValue.ProcessingInstruction.Target Property

GCValueProcessingInstructionTarget Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValue.ProcessingInstruction.Target"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Target { get; }
Public Overridable ReadOnly Property Target As String
    Get
public:
virtual property String^ Target {
    String^ get ();
}
abstract Target : string with get
override Target : string with get

Property Value

Type: String
See Also

Reference

GCValueProcessingInstruction Class
DXMLBase.Gcv Namespace


GCValue.ValueType Enumeration

GCValueValueType Enumeration

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCValue.ValueType"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ValueType
Public Enumeration ValueType
public enum class ValueType
type ValueType
Members
Member name | Value | Description
TYPE_INVALID | -1 | Represents an invalid type.
TYPE_STRING 0 Integer constant representing
Copy
"string"
value type
TYPE_BOOLEAN 1 Integer constant representing
Copy
"boolean"
value type
TYPE_INTEGER 2 Integer constant representing
Copy
"integer"
value type
TYPE_REAL 3 Integer constant representing
Copy
"real"
value type
TYPE_DN 4 Integer constant representing
Copy
"dn"
value type
TYPE_ENUM 5 Integer constant representing
Copy
"enum"
value type
TYPE_PASSWORD_REF 6 Integer constant representing
Copy
"password-ref"
value type
TYPE_GCV_REF 7 Integer constant representing
Copy
"gcv-ref"
element
TYPE_HEADER 8 Integer constant representing
Copy
"header"
element
TYPE_GROUP 9 Integer constant representing
Copy
"group"
element
TYPE_SUBORDINATES 10 Integer constant representing
Copy
"subordinates"
element
TYPE_LIST 11 Integer constant representing
Copy
"list"
value type
TYPE_DN_REF 12 Integer constant representing
Copy
"dn-ref"
value type
TYPE_STRUCTURED 13 Integer constant representing
Copy
"structured"
value type
See Also

Reference

DXMLBase.Gcv Namespace


GCValue.XmlItem Class

GCValueXmlItem Class
Abstract class for representing XML processing instructions and comments.
Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValueXmlItem
DXMLBase.GcvGCValueComment
DXMLBase.GcvGCValueProcessingInstruction

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class XmlItem
Public MustInherit Class XmlItem
public ref class XmlItem abstract
[<AbstractClassAttribute>]
type XmlItem =  class end

The GCValueXmlItem type exposes the following members.

Constructors
 | Name | Description
Protected method | GCValueXmlItem | Initializes a new instance of the GCValueXmlItem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCValue.XmlItem Constructor

GCValueXmlItem Constructor
Initializes a new instance of the GCValueXmlItem class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XmlItem()
Protected Sub New
protected:
XmlItem()
new : unit -> XmlItem
See Also

Reference

GCValueXmlItem Class
DXMLBase.Gcv Namespace


XmlItem Methods

XmlItem Methods

The GCValueXmlItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GCValueXmlItem Class
DXMLBase.Gcv Namespace


GCValueNotFoundException Class

GCValueNotFoundException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCValueNotFoundException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvGCValueNotFoundException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GCValueNotFoundException : GCVException
<SerializableAttribute>
Public Class GCValueNotFoundException
    Inherits GCVException
[SerializableAttribute]
public ref class GCValueNotFoundException : public GCVException
[<SerializableAttribute>]
type GCValueNotFoundException =
    class
        inherit GCVException
    end

The GCValueNotFoundException type exposes the following members.

Constructors
 | Name | Description
Public method | GCValueNotFoundException | Initializes a new instance of the GCValueNotFoundException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DocumentURI |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LineNumber |
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Overrides GCVExceptionValueName.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCValueNotFoundException Constructor

GCValueNotFoundException Constructor
Initializes a new instance of the GCValueNotFoundException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCValueNotFoundException(
    string valueName,
    XmlNode node
)
Public Sub New (
    valueName As String,
    node As XmlNode
)
public:
GCValueNotFoundException(
    String^ valueName,
    XmlNode^ node
)
new :
        valueName : string *
        node : XmlNode -> GCValueNotFoundException

Parameters

valueName
Type: SystemString

[Missing <param name="valueName"/> documentation for "M:DXMLBase.Gcv.GCValueNotFoundException.#ctor(System.String,System.Xml.XmlNode)"]

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Gcv.GCValueNotFoundException.#ctor(System.String,System.Xml.XmlNode)"]

See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueNotFoundException Methods

GCValueNotFoundException Methods

The GCValueNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueNotFoundException Properties

GCValueNotFoundException Properties

The GCValueNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DocumentURI |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LineNumber |
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Overrides GCVExceptionValueName.)
Top
See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueNotFoundException.DocumentURI Property

GCValueNotFoundExceptionDocumentURI Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValueNotFoundException.DocumentURI"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DocumentURI { get; }
Public Overridable ReadOnly Property DocumentURI As String
    Get
public:
virtual property String^ DocumentURI {
    String^ get ();
}
abstract DocumentURI : string with get
override DocumentURI : string with get

Property Value

Type: String
See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueNotFoundException.LineNumber Property

GCValueNotFoundExceptionLineNumber Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValueNotFoundException.LineNumber"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineNumber { get; }
Public Overridable ReadOnly Property LineNumber As Integer
    Get
public:
virtual property int LineNumber {
    int get ();
}
abstract LineNumber : int with get
override LineNumber : int with get

Property Value

Type: Int32
See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueNotFoundException.ValueName Property

GCValueNotFoundExceptionValueName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValueNotFoundException.ValueName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ValueName { get; }
Public Overrides ReadOnly Property ValueName As String
    Get
public:
virtual property String^ ValueName {
    String^ get () override;
}
abstract ValueName : string with get
override ValueName : string with get

Property Value

Type: String
See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueNotFoundException Events

GCValueNotFoundException Events

The GCValueNotFoundException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueNotFoundException Class
DXMLBase.Gcv Namespace


GCValueParseException Class

GCValueParseException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCValueParseException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvGCValueParseException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GCValueParseException : GCVException
<SerializableAttribute>
Public Class GCValueParseException
    Inherits GCVException
[SerializableAttribute]
public ref class GCValueParseException : public GCVException
[<SerializableAttribute>]
type GCValueParseException =
    class
        inherit GCVException
    end

The GCValueParseException type exposes the following members.

Constructors
 | Name | Description
Public method | GCValueParseException(Int32) | Initializes a new instance of the GCValueParseException class
Public method | GCValueParseException(Int32, GCValue) | Initializes a new instance of the GCValueParseException class
Public method | GCValueParseException(Int32, Int32) | Initializes a new instance of the GCValueParseException class
Public method | GCValueParseException(Int32, Int32, GCValue) | Initializes a new instance of the GCValueParseException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrIndex |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCValueParseException Constructor

GCValueParseException Constructor
Overload List
 | Name | Description
Public method | GCValueParseException(Int32) | Initializes a new instance of the GCValueParseException class
Public method | GCValueParseException(Int32, GCValue) | Initializes a new instance of the GCValueParseException class
Public method | GCValueParseException(Int32, Int32) | Initializes a new instance of the GCValueParseException class
Public method | GCValueParseException(Int32, Int32, GCValue) | Initializes a new instance of the GCValueParseException class
Top
See Also

Reference

GCValueParseException Class
DXMLBase.Gcv Namespace


GCValueParseException Constructor (Int32)

GCValueParseException Constructor (Int32)
Initializes a new instance of the GCValueParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCValueParseException(
    int code
)
Public Sub New (
    code As Integer
)
public:
GCValueParseException(
    int code
)
new :
        code : int -> GCValueParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32)"]

See Also

Reference

GCValueParseException Class
GCValueParseException Overload
DXMLBase.Gcv Namespace


GCValueParseException Constructor (Int32, GCValue)

GCValueParseException Constructor (Int32, GCValue)
Initializes a new instance of the GCValueParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCValueParseException(
    int code,
    GCValue value
)
Public Sub New (
    code As Integer,
    value As GCValue
)
public:
GCValueParseException(
    int code,
    GCValue^ value
)
new :
        code : int *
        value : GCValue -> GCValueParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,DXMLBase.Gcv.GCValue)"]

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,DXMLBase.Gcv.GCValue)"]

See Also

Reference

GCValueParseException Class
GCValueParseException Overload
DXMLBase.Gcv Namespace


GCValueParseException Constructor (Int32, Int32)

GCValueParseException Constructor (Int32, Int32)
Initializes a new instance of the GCValueParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCValueParseException(
    int code,
    int errIndex
)
Public Sub New (
    code As Integer,
    errIndex As Integer
)
public:
GCValueParseException(
    int code,
    int errIndex
)
new :
        code : int *
        errIndex : int -> GCValueParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,System.Int32)"]

errIndex
Type: SystemInt32

[Missing <param name="errIndex"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,System.Int32)"]

See Also

Reference

GCValueParseException Class
GCValueParseException Overload
DXMLBase.Gcv Namespace


GCValueParseException Constructor (Int32, Int32, GCValue)

GCValueParseException Constructor (Int32, Int32, GCValue)
Initializes a new instance of the GCValueParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCValueParseException(
    int code,
    int errIndex,
    GCValue value
)
Public Sub New (
    code As Integer,
    errIndex As Integer,
    value As GCValue
)
public:
GCValueParseException(
    int code,
    int errIndex,
    GCValue^ value
)
new :
        code : int *
        errIndex : int *
        value : GCValue -> GCValueParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,System.Int32,DXMLBase.Gcv.GCValue)"]

errIndex
Type: SystemInt32

[Missing <param name="errIndex"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,System.Int32,DXMLBase.Gcv.GCValue)"]

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCValueParseException.#ctor(System.Int32,System.Int32,DXMLBase.Gcv.GCValue)"]

See Also

Reference

GCValueParseException Class
GCValueParseException Overload
DXMLBase.Gcv Namespace


GCValueParseException Methods

GCValueParseException Methods

The GCValueParseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueParseException Class
DXMLBase.Gcv Namespace


GCValueParseException Properties

GCValueParseException Properties

The GCValueParseException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrIndex |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
See Also

Reference

GCValueParseException Class
DXMLBase.Gcv Namespace


GCValueParseException.ErrIndex Property

GCValueParseExceptionErrIndex Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCValueParseException.ErrIndex"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ErrIndex { get; }
Public Overridable ReadOnly Property ErrIndex As Integer
    Get
public:
virtual property int ErrIndex {
    int get ();
}
abstract ErrIndex : int with get
override ErrIndex : int with get

Property Value

Type: Int32
See Also

Reference

GCValueParseException Class
DXMLBase.Gcv Namespace


GCValueParseException Events

GCValueParseException Events

The GCValueParseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCValueParseException Class
DXMLBase.Gcv Namespace


GCVArgumentException Class

GCVArgumentException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCVArgumentException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvGCVArgumentException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GCVArgumentException : GCVException
<SerializableAttribute>
Public Class GCVArgumentException
    Inherits GCVException
[SerializableAttribute]
public ref class GCVArgumentException : public GCVException
[<SerializableAttribute>]
type GCVArgumentException =
    class
        inherit GCVException
    end

The GCVArgumentException type exposes the following members.

Constructors
 | Name | Description
Public method | GCVArgumentException(Int32) | Initializes a new instance of the GCVArgumentException class
Public method | GCVArgumentException(Int32, GCValue) | Initializes a new instance of the GCVArgumentException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCVArgumentException Constructor

GCVArgumentException Constructor
Overload List
 | Name | Description
Public method | GCVArgumentException(Int32) | Initializes a new instance of the GCVArgumentException class
Public method | GCVArgumentException(Int32, GCValue) | Initializes a new instance of the GCVArgumentException class
Top
See Also

Reference

GCVArgumentException Class
DXMLBase.Gcv Namespace


GCVArgumentException Constructor (Int32)

GCVArgumentException Constructor (Int32)
Initializes a new instance of the GCVArgumentException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVArgumentException(
    int code
)
Public Sub New (
    code As Integer
)
public:
GCVArgumentException(
    int code
)
new :
        code : int -> GCVArgumentException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVArgumentException.#ctor(System.Int32)"]

See Also

Reference

GCVArgumentException Class
GCVArgumentException Overload
DXMLBase.Gcv Namespace


GCVArgumentException Constructor (Int32, GCValue)

GCVArgumentException Constructor (Int32, GCValue)
Initializes a new instance of the GCVArgumentException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVArgumentException(
    int code,
    GCValue value
)
Public Sub New (
    code As Integer,
    value As GCValue
)
public:
GCVArgumentException(
    int code,
    GCValue^ value
)
new :
        code : int *
        value : GCValue -> GCVArgumentException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVArgumentException.#ctor(System.Int32,DXMLBase.Gcv.GCValue)"]

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCVArgumentException.#ctor(System.Int32,DXMLBase.Gcv.GCValue)"]

See Also

Reference

GCVArgumentException Class
GCVArgumentException Overload
DXMLBase.Gcv Namespace


GCVArgumentException Methods

GCVArgumentException Methods

The GCVArgumentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCVArgumentException Class
DXMLBase.Gcv Namespace


GCVArgumentException Properties

GCVArgumentException Properties

The GCVArgumentException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
See Also

Reference

GCVArgumentException Class
DXMLBase.Gcv Namespace


GCVArgumentException Events

GCVArgumentException Events

The GCVArgumentException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCVArgumentException Class
DXMLBase.Gcv Namespace


GCVDtd Class

GCVDtd Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCVDtd"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCVDtd

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class GCVDtd
Public MustInherit Class GCVDtd
public ref class GCVDtd abstract
[<AbstractClassAttribute>]
type GCVDtd =  class end

The GCVDtd type exposes the following members.

Constructors
 | Name | Description
Protected method | GCVDtd | Initializes a new instance of the GCVDtd class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ATTR_ACTIVE_VALUE |
ATTR_ATTR_NAME |
ATTR_AUX_CLASS_NAME |
ATTR_DESCRIPTION_REF |
ATTR_DISPLAY_NAME |
ATTR_DISPLAY_NAME_REF |
ATTR_DN_DELIMS |
ATTR_DN_SPACE |
ATTR_DN_TYPE |
ATTR_DRIVER_PARAM_NAME |
ATTR_HIDE |
ATTR_INSTANCE_SEPARATOR |
ATTR_ITEM_SEPARATOR |
ATTR_MANDATORY |
ATTR_MAX_COUNT |
ATTR_MIN_COUNT |
ATTR_MULTILINE |
ATTR_NAME |
ATTR_RANGE_HI |
ATTR_RANGE_LO |
ATTR_TYPE |
ATTR_TYPE_HINT |
ATTR_VALUE_SEPARATOR |
ATTR_XML_SPACE |
TAG_CONFIGURATION_VALUES |
TAG_DEFINITION |
TAG_DEFINITIONS |
TAG_DESCRIPTION |
TAG_ENUM_CHOICE |
TAG_GCV_REF |
TAG_GROUP |
TAG_HEADER |
TAG_INSTANCE |
TAG_ITEM |
TAG_LIST |
TAG_SUBORDINATES |
TAG_TARGET_CLASS |
TAG_TEMPLATE |
TAG_VALUE |
VAL_APPLICATION |
VAL_BOOLEAN |
VAL_CUSTOM |
VAL_DIRXML |
VAL_DN |
VAL_DN_REF |
VAL_DOT |
VAL_ENUM |
VAL_FALSE |
VAL_INTEGER |
VAL_LDAP |
VAL_LIST |
VAL_PASSWORD_REF |
VAL_PRESERVE |
VAL_QUALIFIED_DOT |
VAL_QUALIFIED_SLASH |
VAL_REAL |
VAL_SLASH |
VAL_STRING |
VAL_STRUCTURED |
VAL_TRUE |
XML_NAMESPACE |
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCVDtd Constructor

GCVDtd Constructor
Initializes a new instance of the GCVDtd class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected GCVDtd()
Protected Sub New
protected:
GCVDtd()
new : unit -> GCVDtd
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd Fields

GCVDtd Fields

The GCVDtd type exposes the following members.

Fields
Name | Description
ATTR_ACTIVE_VALUE |
ATTR_ATTR_NAME |
ATTR_AUX_CLASS_NAME |
ATTR_DESCRIPTION_REF |
ATTR_DISPLAY_NAME |
ATTR_DISPLAY_NAME_REF |
ATTR_DN_DELIMS |
ATTR_DN_SPACE |
ATTR_DN_TYPE |
ATTR_DRIVER_PARAM_NAME |
ATTR_HIDE |
ATTR_INSTANCE_SEPARATOR |
ATTR_ITEM_SEPARATOR |
ATTR_MANDATORY |
ATTR_MAX_COUNT |
ATTR_MIN_COUNT |
ATTR_MULTILINE |
ATTR_NAME |
ATTR_RANGE_HI |
ATTR_RANGE_LO |
ATTR_TYPE |
ATTR_TYPE_HINT |
ATTR_VALUE_SEPARATOR |
ATTR_XML_SPACE |
TAG_CONFIGURATION_VALUES |
TAG_DEFINITION |
TAG_DEFINITIONS |
TAG_DESCRIPTION |
TAG_ENUM_CHOICE |
TAG_GCV_REF |
TAG_GROUP |
TAG_HEADER |
TAG_INSTANCE |
TAG_ITEM |
TAG_LIST |
TAG_SUBORDINATES |
TAG_TARGET_CLASS |
TAG_TEMPLATE |
TAG_VALUE |
VAL_APPLICATION |
VAL_BOOLEAN |
VAL_CUSTOM |
VAL_DIRXML |
VAL_DN |
VAL_DN_REF |
VAL_DOT |
VAL_ENUM |
VAL_FALSE |
VAL_INTEGER |
VAL_LDAP |
VAL_LIST |
VAL_PASSWORD_REF |
VAL_PRESERVE |
VAL_QUALIFIED_DOT |
VAL_QUALIFIED_SLASH |
VAL_REAL |
VAL_SLASH |
VAL_STRING |
VAL_STRUCTURED |
VAL_TRUE |
XML_NAMESPACE |
Top
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_ACTIVE_VALUE Field

GCVDtdATTR_ACTIVE_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_ACTIVE_VALUE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_ACTIVE_VALUE
Public Const ATTR_ACTIVE_VALUE As String
public:
literal String^ ATTR_ACTIVE_VALUE
static val mutable ATTR_ACTIVE_VALUE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_ATTR_NAME Field

GCVDtdATTR_ATTR_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_ATTR_NAME"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_ATTR_NAME
Public Const ATTR_ATTR_NAME As String
public:
literal String^ ATTR_ATTR_NAME
static val mutable ATTR_ATTR_NAME: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_AUX_CLASS_NAME Field

GCVDtdATTR_AUX_CLASS_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_AUX_CLASS_NAME"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_AUX_CLASS_NAME
Public Const ATTR_AUX_CLASS_NAME As String
public:
literal String^ ATTR_AUX_CLASS_NAME
static val mutable ATTR_AUX_CLASS_NAME: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DESCRIPTION_REF Field

GCVDtdATTR_DESCRIPTION_REF Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DESCRIPTION_REF"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DESCRIPTION_REF
Public Const ATTR_DESCRIPTION_REF As String
public:
literal String^ ATTR_DESCRIPTION_REF
static val mutable ATTR_DESCRIPTION_REF: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DISPLAY_NAME Field

GCVDtdATTR_DISPLAY_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DISPLAY_NAME"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DISPLAY_NAME
Public Const ATTR_DISPLAY_NAME As String
public:
literal String^ ATTR_DISPLAY_NAME
static val mutable ATTR_DISPLAY_NAME: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DISPLAY_NAME_REF Field

GCVDtdATTR_DISPLAY_NAME_REF Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DISPLAY_NAME_REF"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DISPLAY_NAME_REF
Public Const ATTR_DISPLAY_NAME_REF As String
public:
literal String^ ATTR_DISPLAY_NAME_REF
static val mutable ATTR_DISPLAY_NAME_REF: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DN_DELIMS Field

GCVDtdATTR_DN_DELIMS Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DN_DELIMS"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DN_DELIMS
Public Const ATTR_DN_DELIMS As String
public:
literal String^ ATTR_DN_DELIMS
static val mutable ATTR_DN_DELIMS: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DN_SPACE Field

GCVDtdATTR_DN_SPACE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DN_SPACE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DN_SPACE
Public Const ATTR_DN_SPACE As String
public:
literal String^ ATTR_DN_SPACE
static val mutable ATTR_DN_SPACE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DN_TYPE Field

GCVDtdATTR_DN_TYPE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DN_TYPE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DN_TYPE
Public Const ATTR_DN_TYPE As String
public:
literal String^ ATTR_DN_TYPE
static val mutable ATTR_DN_TYPE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_DRIVER_PARAM_NAME Field

GCVDtdATTR_DRIVER_PARAM_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_DRIVER_PARAM_NAME"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DRIVER_PARAM_NAME
Public Const ATTR_DRIVER_PARAM_NAME As String
public:
literal String^ ATTR_DRIVER_PARAM_NAME
static val mutable ATTR_DRIVER_PARAM_NAME: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_HIDE Field

GCVDtdATTR_HIDE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_HIDE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_HIDE
Public Const ATTR_HIDE As String
public:
literal String^ ATTR_HIDE
static val mutable ATTR_HIDE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_INSTANCE_SEPARATOR Field

GCVDtdATTR_INSTANCE_SEPARATOR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_INSTANCE_SEPARATOR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_INSTANCE_SEPARATOR
Public Const ATTR_INSTANCE_SEPARATOR As String
public:
literal String^ ATTR_INSTANCE_SEPARATOR
static val mutable ATTR_INSTANCE_SEPARATOR: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_ITEM_SEPARATOR Field

GCVDtdATTR_ITEM_SEPARATOR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_ITEM_SEPARATOR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_ITEM_SEPARATOR
Public Const ATTR_ITEM_SEPARATOR As String
public:
literal String^ ATTR_ITEM_SEPARATOR
static val mutable ATTR_ITEM_SEPARATOR: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_MANDATORY Field

GCVDtdATTR_MANDATORY Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_MANDATORY"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_MANDATORY
Public Const ATTR_MANDATORY As String
public:
literal String^ ATTR_MANDATORY
static val mutable ATTR_MANDATORY: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_MAX_COUNT Field

GCVDtdATTR_MAX_COUNT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_MAX_COUNT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_MAX_COUNT
Public Const ATTR_MAX_COUNT As String
public:
literal String^ ATTR_MAX_COUNT
static val mutable ATTR_MAX_COUNT: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_MIN_COUNT Field

GCVDtdATTR_MIN_COUNT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_MIN_COUNT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_MIN_COUNT
Public Const ATTR_MIN_COUNT As String
public:
literal String^ ATTR_MIN_COUNT
static val mutable ATTR_MIN_COUNT: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_MULTILINE Field

GCVDtdATTR_MULTILINE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_MULTILINE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_MULTILINE
Public Const ATTR_MULTILINE As String
public:
literal String^ ATTR_MULTILINE
static val mutable ATTR_MULTILINE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_NAME Field

GCVDtdATTR_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_NAME"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_NAME
Public Const ATTR_NAME As String
public:
literal String^ ATTR_NAME
static val mutable ATTR_NAME: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_RANGE_HI Field

GCVDtdATTR_RANGE_HI Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_RANGE_HI"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_RANGE_HI
Public Const ATTR_RANGE_HI As String
public:
literal String^ ATTR_RANGE_HI
static val mutable ATTR_RANGE_HI: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_RANGE_LO Field

GCVDtdATTR_RANGE_LO Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_RANGE_LO"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_RANGE_LO
Public Const ATTR_RANGE_LO As String
public:
literal String^ ATTR_RANGE_LO
static val mutable ATTR_RANGE_LO: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_TYPE Field

GCVDtdATTR_TYPE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_TYPE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_TYPE
Public Const ATTR_TYPE As String
public:
literal String^ ATTR_TYPE
static val mutable ATTR_TYPE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_TYPE_HINT Field

GCVDtdATTR_TYPE_HINT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_TYPE_HINT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_TYPE_HINT
Public Const ATTR_TYPE_HINT As String
public:
literal String^ ATTR_TYPE_HINT
static val mutable ATTR_TYPE_HINT: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_VALUE_SEPARATOR Field

GCVDtdATTR_VALUE_SEPARATOR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_VALUE_SEPARATOR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_VALUE_SEPARATOR
Public Const ATTR_VALUE_SEPARATOR As String
public:
literal String^ ATTR_VALUE_SEPARATOR
static val mutable ATTR_VALUE_SEPARATOR: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.ATTR_XML_SPACE Field

GCVDtdATTR_XML_SPACE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.ATTR_XML_SPACE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_XML_SPACE
Public Const ATTR_XML_SPACE As String
public:
literal String^ ATTR_XML_SPACE
static val mutable ATTR_XML_SPACE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_CONFIGURATION_VALUES Field

GCVDtdTAG_CONFIGURATION_VALUES Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_CONFIGURATION_VALUES"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_CONFIGURATION_VALUES
Public Const TAG_CONFIGURATION_VALUES As String
public:
literal String^ TAG_CONFIGURATION_VALUES
static val mutable TAG_CONFIGURATION_VALUES: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_DEFINITION Field

GCVDtdTAG_DEFINITION Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_DEFINITION"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_DEFINITION
Public Const TAG_DEFINITION As String
public:
literal String^ TAG_DEFINITION
static val mutable TAG_DEFINITION: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_DEFINITIONS Field

GCVDtdTAG_DEFINITIONS Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_DEFINITIONS"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_DEFINITIONS
Public Const TAG_DEFINITIONS As String
public:
literal String^ TAG_DEFINITIONS
static val mutable TAG_DEFINITIONS: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_DESCRIPTION Field

GCVDtdTAG_DESCRIPTION Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_DESCRIPTION"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_DESCRIPTION
Public Const TAG_DESCRIPTION As String
public:
literal String^ TAG_DESCRIPTION
static val mutable TAG_DESCRIPTION: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_ENUM_CHOICE Field

GCVDtdTAG_ENUM_CHOICE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_ENUM_CHOICE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ENUM_CHOICE
Public Const TAG_ENUM_CHOICE As String
public:
literal String^ TAG_ENUM_CHOICE
static val mutable TAG_ENUM_CHOICE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_GCV_REF Field

GCVDtdTAG_GCV_REF Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_GCV_REF"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_GCV_REF
Public Const TAG_GCV_REF As String
public:
literal String^ TAG_GCV_REF
static val mutable TAG_GCV_REF: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_GROUP Field

GCVDtdTAG_GROUP Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_GROUP"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_GROUP
Public Const TAG_GROUP As String
public:
literal String^ TAG_GROUP
static val mutable TAG_GROUP: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_HEADER Field

GCVDtdTAG_HEADER Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_HEADER"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_HEADER
Public Const TAG_HEADER As String
public:
literal String^ TAG_HEADER
static val mutable TAG_HEADER: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_INSTANCE Field

GCVDtdTAG_INSTANCE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_INSTANCE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_INSTANCE
Public Const TAG_INSTANCE As String
public:
literal String^ TAG_INSTANCE
static val mutable TAG_INSTANCE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_ITEM Field

GCVDtdTAG_ITEM Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_ITEM"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ITEM
Public Const TAG_ITEM As String
public:
literal String^ TAG_ITEM
static val mutable TAG_ITEM: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_LIST Field

GCVDtdTAG_LIST Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_LIST"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_LIST
Public Const TAG_LIST As String
public:
literal String^ TAG_LIST
static val mutable TAG_LIST: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_SUBORDINATES Field

GCVDtdTAG_SUBORDINATES Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_SUBORDINATES"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SUBORDINATES
Public Const TAG_SUBORDINATES As String
public:
literal String^ TAG_SUBORDINATES
static val mutable TAG_SUBORDINATES: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_TARGET_CLASS Field

GCVDtdTAG_TARGET_CLASS Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_TARGET_CLASS"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_TARGET_CLASS
Public Const TAG_TARGET_CLASS As String
public:
literal String^ TAG_TARGET_CLASS
static val mutable TAG_TARGET_CLASS: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_TEMPLATE Field

GCVDtdTAG_TEMPLATE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_TEMPLATE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_TEMPLATE
Public Const TAG_TEMPLATE As String
public:
literal String^ TAG_TEMPLATE
static val mutable TAG_TEMPLATE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.TAG_VALUE Field

GCVDtdTAG_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.TAG_VALUE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_VALUE
Public Const TAG_VALUE As String
public:
literal String^ TAG_VALUE
static val mutable TAG_VALUE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_APPLICATION Field

GCVDtdVAL_APPLICATION Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_APPLICATION"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_APPLICATION
Public Const VAL_APPLICATION As String
public:
literal String^ VAL_APPLICATION
static val mutable VAL_APPLICATION: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_BOOLEAN Field

GCVDtdVAL_BOOLEAN Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_BOOLEAN"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_BOOLEAN
Public Const VAL_BOOLEAN As String
public:
literal String^ VAL_BOOLEAN
static val mutable VAL_BOOLEAN: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_CUSTOM Field

GCVDtdVAL_CUSTOM Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_CUSTOM"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_CUSTOM
Public Const VAL_CUSTOM As String
public:
literal String^ VAL_CUSTOM
static val mutable VAL_CUSTOM: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_DIRXML Field

GCVDtdVAL_DIRXML Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_DIRXML"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DIRXML
Public Const VAL_DIRXML As String
public:
literal String^ VAL_DIRXML
static val mutable VAL_DIRXML: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_DN Field

GCVDtdVAL_DN Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_DN"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DN
Public Const VAL_DN As String
public:
literal String^ VAL_DN
static val mutable VAL_DN: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_DN_REF Field

GCVDtdVAL_DN_REF Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_DN_REF"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DN_REF
Public Const VAL_DN_REF As String
public:
literal String^ VAL_DN_REF
static val mutable VAL_DN_REF: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_DOT Field

GCVDtdVAL_DOT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_DOT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DOT
Public Const VAL_DOT As String
public:
literal String^ VAL_DOT
static val mutable VAL_DOT: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_ENUM Field

GCVDtdVAL_ENUM Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_ENUM"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_ENUM
Public Const VAL_ENUM As String
public:
literal String^ VAL_ENUM
static val mutable VAL_ENUM: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_FALSE Field

GCVDtdVAL_FALSE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_FALSE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_FALSE
Public Const VAL_FALSE As String
public:
literal String^ VAL_FALSE
static val mutable VAL_FALSE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_INTEGER Field

GCVDtdVAL_INTEGER Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_INTEGER"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_INTEGER
Public Const VAL_INTEGER As String
public:
literal String^ VAL_INTEGER
static val mutable VAL_INTEGER: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_LDAP Field

GCVDtdVAL_LDAP Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_LDAP"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_LDAP
Public Const VAL_LDAP As String
public:
literal String^ VAL_LDAP
static val mutable VAL_LDAP: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_LIST Field

GCVDtdVAL_LIST Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_LIST"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_LIST
Public Const VAL_LIST As String
public:
literal String^ VAL_LIST
static val mutable VAL_LIST: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_PASSWORD_REF Field

GCVDtdVAL_PASSWORD_REF Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_PASSWORD_REF"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_PASSWORD_REF
Public Const VAL_PASSWORD_REF As String
public:
literal String^ VAL_PASSWORD_REF
static val mutable VAL_PASSWORD_REF: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_PRESERVE Field

GCVDtdVAL_PRESERVE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_PRESERVE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_PRESERVE
Public Const VAL_PRESERVE As String
public:
literal String^ VAL_PRESERVE
static val mutable VAL_PRESERVE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_QUALIFIED_DOT Field

GCVDtdVAL_QUALIFIED_DOT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_QUALIFIED_DOT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_QUALIFIED_DOT
Public Const VAL_QUALIFIED_DOT As String
public:
literal String^ VAL_QUALIFIED_DOT
static val mutable VAL_QUALIFIED_DOT: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_QUALIFIED_SLASH Field

GCVDtdVAL_QUALIFIED_SLASH Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_QUALIFIED_SLASH"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_QUALIFIED_SLASH
Public Const VAL_QUALIFIED_SLASH As String
public:
literal String^ VAL_QUALIFIED_SLASH
static val mutable VAL_QUALIFIED_SLASH: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_REAL Field

GCVDtdVAL_REAL Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_REAL"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_REAL
Public Const VAL_REAL As String
public:
literal String^ VAL_REAL
static val mutable VAL_REAL: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_SLASH Field

GCVDtdVAL_SLASH Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_SLASH"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_SLASH
Public Const VAL_SLASH As String
public:
literal String^ VAL_SLASH
static val mutable VAL_SLASH: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_STRING Field

GCVDtdVAL_STRING Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_STRING"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_STRING
Public Const VAL_STRING As String
public:
literal String^ VAL_STRING
static val mutable VAL_STRING: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_STRUCTURED Field

GCVDtdVAL_STRUCTURED Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_STRUCTURED"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_STRUCTURED
Public Const VAL_STRUCTURED As String
public:
literal String^ VAL_STRUCTURED
static val mutable VAL_STRUCTURED: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.VAL_TRUE Field

GCVDtdVAL_TRUE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.VAL_TRUE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_TRUE
Public Const VAL_TRUE As String
public:
literal String^ VAL_TRUE
static val mutable VAL_TRUE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd.XML_NAMESPACE Field

GCVDtdXML_NAMESPACE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVDtd.XML_NAMESPACE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XML_NAMESPACE
Public Const XML_NAMESPACE As String
public:
literal String^ XML_NAMESPACE
static val mutable XML_NAMESPACE: string

Field Value

Type: String
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVDtd Methods

GCVDtd Methods

The GCVDtd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GCVDtd Class
DXMLBase.Gcv Namespace


GCVException Class

GCVException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCVException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
More...

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GCVException : Exception
<SerializableAttribute>
Public Class GCVException
    Inherits Exception
[SerializableAttribute]
public ref class GCVException : public Exception
[<SerializableAttribute>]
type GCVException =
    class
        inherit Exception
    end

The GCVException type exposes the following members.

Constructors
 | Name | Description
Public method | GCVException(Int32) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, GCValue) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, Object) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, XmlNode) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, GCValue, XmlNode) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, Object, XmlNode) | Initializes a new instance of the GCVException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
Name Description
ERR_BAD_DN_DELIMS
ERR_BAD_DN_FORMAT
Code indicating that the specified DN format is not valid.
ERR_BAD_DN_SPACE
Code indicating that the specified DN space is not valid.
ERR_BAD_RANGE_VALUE
ERR_BAD_XML
Code indicating some error was found in the XML representation of GCVs.
ERR_DUPLICATE_ENUM_CHOICE
ERR_DUPLICATE_VALUE_NAME
ERR_HEADER_NOT_ALLOWED_HERE
Code indicating a header was found in an invalid location in the XML.
ERR_INSERTION_POINT_NOT_FOUND
ERR_INVALID_ACTIVE_VALUE
ERR_INVALID_GROUP_LEADER
ERR_INVALID_INSTANCE_COUNT
Code indicating too few or too many <instance> elements were found in a structured value definition
ERR_INVALID_INSTANCE_VALUE
Code indicating that a value in an instance doesn't match the template in a structured value
ERR_INVALID_NAME
Code indicating that a value name does not match the lexical rules for a value name.
ERR_INVALID_TYPE_SPECIFIER
Code indicating that the type specifier for a GCV is invalid.
ERR_MISSING_ACTIVE_VALUE
Code indicating a subordinates section active-value is missing.
ERR_MISSING_DEFINITIONS_ELEMENT
ERR_MISSING_DISPLAY_NAME
Code indicating a GCV instance does not have the required display name.
ERR_MISSING_DOCUMENT_ELEMENT
ERR_MISSING_ENUM_CHOICES
Code indicating that an enum GCV has no enum choices.
ERR_MISSING_INSTANCE_VALUE
Code indicating that an instance doesn't have one or more values in the structured value template
ERR_MISSING_TEMPLATE
Code indicating no <template> element was found in a structured value definition
ERR_MULTIPLE_DEFINITIONS_ELEMENT
ERR_MUST_BE_TRUE_OR_FALSE
Code indicating an XML attribute value must be
Copy
"true"
or
Copy
"false"
ERR_REFERENCE_NOT_ALLOWED_HERE
Code indicating a gcv-ref was found in an invalid location in the XML.
ERR_SUBORDINATE_NOT_ALLOWED
ERR_TYPE_NOT_ALLOWED_HERE
ERR_VALUE_INCOMPLETE
Code indicating a GCV value is not lexically complete.
ERR_VALUE_INVALID_CHAR
ERR_VALUE_NULL
ERR_VALUE_OUT_OF_RANGE
ERR_VALUE_REFERENCE_NOT_FOUND
messageSource
Top
Properties
 | Name | Description
Public property | Code |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName |
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace
Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvGCValueNotFoundException
DXMLBase.GcvGCValueParseException
DXMLBase.GcvGCVArgumentException
DXMLBase.GcvGCVStateException
DXMLBase.GcvGCVXmlParseException
DXMLBase.GcvShimParamsNoSuchReferenceException


GCVException Constructor

GCVException Constructor
Overload List
 | Name | Description
Public method | GCVException(Int32) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, GCValue) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, Object) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, XmlNode) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, GCValue, XmlNode) | Initializes a new instance of the GCVException class
Public method | GCVException(Int32, Object, XmlNode) | Initializes a new instance of the GCVException class
Top
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException Constructor (Int32)

GCVException Constructor (Int32)
Initializes a new instance of the GCVException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVException(
    int code
)
Public Sub New (
    code As Integer
)
public:
GCVException(
    int code
)
new :
        code : int -> GCVException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32)"]

See Also

Reference

GCVException Class
GCVException Overload
DXMLBase.Gcv Namespace


GCVException Constructor (Int32, GCValue)

GCVException Constructor (Int32, GCValue)
Initializes a new instance of the GCVException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVException(
    int code,
    GCValue value
)
Public Sub New (
    code As Integer,
    value As GCValue
)
public:
GCVException(
    int code,
    GCValue^ value
)
new :
        code : int *
        value : GCValue -> GCVException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,DXMLBase.Gcv.GCValue)"]

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,DXMLBase.Gcv.GCValue)"]

See Also

Reference

GCVException Class
GCVException Overload
DXMLBase.Gcv Namespace


GCVException Constructor (Int32, Object[])

GCVException Constructor (Int32, Object)
Initializes a new instance of the GCVException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVException(
    int code,
    Object[] parms
)
Public Sub New (
    code As Integer,
    parms As Object()
)
public:
GCVException(
    int code,
    array<Object^>^ parms
)
new :
        code : int *
        parms : Object[] -> GCVException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Object[])"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Object[])"]

See Also

Reference

GCVException Class
GCVException Overload
DXMLBase.Gcv Namespace


GCVException Constructor (Int32, XmlNode)

GCVException Constructor (Int32, XmlNode)
Initializes a new instance of the GCVException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVException(
    int code,
    XmlNode node
)
Public Sub New (
    code As Integer,
    node As XmlNode
)
public:
GCVException(
    int code,
    XmlNode^ node
)
new :
        code : int *
        node : XmlNode -> GCVException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Xml.XmlNode)"]

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Xml.XmlNode)"]

See Also

Reference

GCVException Class
GCVException Overload
DXMLBase.Gcv Namespace


GCVException Constructor (Int32, GCValue, XmlNode)

GCVException Constructor (Int32, GCValue, XmlNode)
Initializes a new instance of the GCVException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVException(
    int code,
    GCValue value,
    XmlNode node
)
Public Sub New (
    code As Integer,
    value As GCValue,
    node As XmlNode
)
public:
GCVException(
    int code,
    GCValue^ value,
    XmlNode^ node
)
new :
        code : int *
        value : GCValue *
        node : XmlNode -> GCVException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,DXMLBase.Gcv.GCValue,System.Xml.XmlNode)"]

value
Type: DXMLBase.GcvGCValue

[Missing <param name="value"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,DXMLBase.Gcv.GCValue,System.Xml.XmlNode)"]

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,DXMLBase.Gcv.GCValue,System.Xml.XmlNode)"]

See Also

Reference

GCVException Class
GCVException Overload
DXMLBase.Gcv Namespace


GCVException Constructor (Int32, Object[], XmlNode)

GCVException Constructor (Int32, Object, XmlNode)
Initializes a new instance of the GCVException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVException(
    int code,
    Object[] parms,
    XmlNode node
)
Public Sub New (
    code As Integer,
    parms As Object(),
    node As XmlNode
)
public:
GCVException(
    int code,
    array<Object^>^ parms,
    XmlNode^ node
)
new :
        code : int *
        parms : Object[] *
        node : XmlNode -> GCVException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Object[],System.Xml.XmlNode)"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Object[],System.Xml.XmlNode)"]

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Gcv.GCVException.#ctor(System.Int32,System.Object[],System.Xml.XmlNode)"]

See Also

Reference

GCVException Class
GCVException Overload
DXMLBase.Gcv Namespace


GCVException Fields

GCVException Fields

The GCVException type exposes the following members.

Fields
Name Description
ERR_BAD_DN_DELIMS
ERR_BAD_DN_FORMAT
Code indicating that the specified DN format is not valid.
ERR_BAD_DN_SPACE
Code indicating that the specified DN space is not valid.
ERR_BAD_RANGE_VALUE
ERR_BAD_XML
Code indicating some error was found in the XML representation of GCVs.
ERR_DUPLICATE_ENUM_CHOICE
ERR_DUPLICATE_VALUE_NAME
ERR_HEADER_NOT_ALLOWED_HERE
Code indicating a header was found in an invalid location in the XML.
ERR_INSERTION_POINT_NOT_FOUND
ERR_INVALID_ACTIVE_VALUE
ERR_INVALID_GROUP_LEADER
ERR_INVALID_INSTANCE_COUNT
Code indicating too few or too many <instance> elements were found in a structured value definition
ERR_INVALID_INSTANCE_VALUE
Code indicating that a value in an instance doesn't match the template in a structured value
ERR_INVALID_NAME
Code indicating that a value name does not match the lexical rules for a value name.
ERR_INVALID_TYPE_SPECIFIER
Code indicating that the type specifier for a GCV is invalid.
ERR_MISSING_ACTIVE_VALUE
Code indicating a subordinates section active-value is missing.
ERR_MISSING_DEFINITIONS_ELEMENT
ERR_MISSING_DISPLAY_NAME
Code indicating a GCV instance does not have the required display name.
ERR_MISSING_DOCUMENT_ELEMENT
ERR_MISSING_ENUM_CHOICES
Code indicating that an enum GCV has no enum choices.
ERR_MISSING_INSTANCE_VALUE
Code indicating that an instance doesn't have one or more values in the structured value template
ERR_MISSING_TEMPLATE
Code indicating no <template> element was found in a structured value definition
ERR_MULTIPLE_DEFINITIONS_ELEMENT
ERR_MUST_BE_TRUE_OR_FALSE
Code indicating an XML attribute value must be
Copy
"true"
or
Copy
"false"
ERR_REFERENCE_NOT_ALLOWED_HERE
Code indicating a gcv-ref was found in an invalid location in the XML.
ERR_SUBORDINATE_NOT_ALLOWED
ERR_TYPE_NOT_ALLOWED_HERE
ERR_VALUE_INCOMPLETE
Code indicating a GCV value is not lexically complete.
ERR_VALUE_INVALID_CHAR
ERR_VALUE_NULL
ERR_VALUE_OUT_OF_RANGE
ERR_VALUE_REFERENCE_NOT_FOUND
messageSource
Top
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_BAD_DN_DELIMS Field

GCVExceptionERR_BAD_DN_DELIMS Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_BAD_DN_DELIMS"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_BAD_DN_DELIMS
Public Const ERR_BAD_DN_DELIMS As Integer
public:
literal int ERR_BAD_DN_DELIMS
static val mutable ERR_BAD_DN_DELIMS: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_BAD_DN_FORMAT Field

GCVExceptionERR_BAD_DN_FORMAT Field
Code indicating that the specified DN format is not valid.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_BAD_DN_FORMAT
Public Const ERR_BAD_DN_FORMAT As Integer
public:
literal int ERR_BAD_DN_FORMAT
static val mutable ERR_BAD_DN_FORMAT: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_BAD_DN_SPACE Field

GCVExceptionERR_BAD_DN_SPACE Field
Code indicating that the specified DN space is not valid.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_BAD_DN_SPACE
Public Const ERR_BAD_DN_SPACE As Integer
public:
literal int ERR_BAD_DN_SPACE
static val mutable ERR_BAD_DN_SPACE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_BAD_RANGE_VALUE Field

GCVExceptionERR_BAD_RANGE_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_BAD_RANGE_VALUE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_BAD_RANGE_VALUE
Public Const ERR_BAD_RANGE_VALUE As Integer
public:
literal int ERR_BAD_RANGE_VALUE
static val mutable ERR_BAD_RANGE_VALUE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_BAD_XML Field

GCVExceptionERR_BAD_XML Field
Code indicating some error was found in the XML representation of GCVs.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_BAD_XML
Public Const ERR_BAD_XML As Integer
public:
literal int ERR_BAD_XML
static val mutable ERR_BAD_XML: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_DUPLICATE_ENUM_CHOICE Field

GCVExceptionERR_DUPLICATE_ENUM_CHOICE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_DUPLICATE_ENUM_CHOICE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_DUPLICATE_ENUM_CHOICE
Public Const ERR_DUPLICATE_ENUM_CHOICE As Integer
public:
literal int ERR_DUPLICATE_ENUM_CHOICE
static val mutable ERR_DUPLICATE_ENUM_CHOICE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_DUPLICATE_VALUE_NAME Field

GCVExceptionERR_DUPLICATE_VALUE_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_DUPLICATE_VALUE_NAME"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_DUPLICATE_VALUE_NAME
Public Const ERR_DUPLICATE_VALUE_NAME As Integer
public:
literal int ERR_DUPLICATE_VALUE_NAME
static val mutable ERR_DUPLICATE_VALUE_NAME: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_HEADER_NOT_ALLOWED_HERE Field

GCVExceptionERR_HEADER_NOT_ALLOWED_HERE Field
Code indicating a header was found in an invalid location in the XML.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_HEADER_NOT_ALLOWED_HERE
Public Const ERR_HEADER_NOT_ALLOWED_HERE As Integer
public:
literal int ERR_HEADER_NOT_ALLOWED_HERE
static val mutable ERR_HEADER_NOT_ALLOWED_HERE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INSERTION_POINT_NOT_FOUND Field

GCVExceptionERR_INSERTION_POINT_NOT_FOUND Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_INSERTION_POINT_NOT_FOUND"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INSERTION_POINT_NOT_FOUND
Public Const ERR_INSERTION_POINT_NOT_FOUND As Integer
public:
literal int ERR_INSERTION_POINT_NOT_FOUND
static val mutable ERR_INSERTION_POINT_NOT_FOUND: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INVALID_ACTIVE_VALUE Field

GCVExceptionERR_INVALID_ACTIVE_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_INVALID_ACTIVE_VALUE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_ACTIVE_VALUE
Public Const ERR_INVALID_ACTIVE_VALUE As Integer
public:
literal int ERR_INVALID_ACTIVE_VALUE
static val mutable ERR_INVALID_ACTIVE_VALUE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INVALID_GROUP_LEADER Field

GCVExceptionERR_INVALID_GROUP_LEADER Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_INVALID_GROUP_LEADER"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_GROUP_LEADER
Public Const ERR_INVALID_GROUP_LEADER As Integer
public:
literal int ERR_INVALID_GROUP_LEADER
static val mutable ERR_INVALID_GROUP_LEADER: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INVALID_INSTANCE_COUNT Field

GCVExceptionERR_INVALID_INSTANCE_COUNT Field
Code indicating too few or too many <instance> elements were found in a structured value definition

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_INSTANCE_COUNT
Public Const ERR_INVALID_INSTANCE_COUNT As Integer
public:
literal int ERR_INVALID_INSTANCE_COUNT
static val mutable ERR_INVALID_INSTANCE_COUNT: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INVALID_INSTANCE_VALUE Field

GCVExceptionERR_INVALID_INSTANCE_VALUE Field
Code indicating that a value in an instance doesn't match the template in a structured value

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_INSTANCE_VALUE
Public Const ERR_INVALID_INSTANCE_VALUE As Integer
public:
literal int ERR_INVALID_INSTANCE_VALUE
static val mutable ERR_INVALID_INSTANCE_VALUE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INVALID_NAME Field

GCVExceptionERR_INVALID_NAME Field
Code indicating that a value name does not match the lexical rules for a value name.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_NAME
Public Const ERR_INVALID_NAME As Integer
public:
literal int ERR_INVALID_NAME
static val mutable ERR_INVALID_NAME: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_INVALID_TYPE_SPECIFIER Field

GCVExceptionERR_INVALID_TYPE_SPECIFIER Field
Code indicating that the type specifier for a GCV is invalid.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_INVALID_TYPE_SPECIFIER
Public Const ERR_INVALID_TYPE_SPECIFIER As Integer
public:
literal int ERR_INVALID_TYPE_SPECIFIER
static val mutable ERR_INVALID_TYPE_SPECIFIER: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_ACTIVE_VALUE Field

GCVExceptionERR_MISSING_ACTIVE_VALUE Field
Code indicating a subordinates section active-value is missing.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_ACTIVE_VALUE
Public Const ERR_MISSING_ACTIVE_VALUE As Integer
public:
literal int ERR_MISSING_ACTIVE_VALUE
static val mutable ERR_MISSING_ACTIVE_VALUE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_DEFINITIONS_ELEMENT Field

GCVExceptionERR_MISSING_DEFINITIONS_ELEMENT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_MISSING_DEFINITIONS_ELEMENT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_DEFINITIONS_ELEMENT
Public Const ERR_MISSING_DEFINITIONS_ELEMENT As Integer
public:
literal int ERR_MISSING_DEFINITIONS_ELEMENT
static val mutable ERR_MISSING_DEFINITIONS_ELEMENT: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_DISPLAY_NAME Field

GCVExceptionERR_MISSING_DISPLAY_NAME Field
Code indicating a GCV instance does not have the required display name.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_DISPLAY_NAME
Public Const ERR_MISSING_DISPLAY_NAME As Integer
public:
literal int ERR_MISSING_DISPLAY_NAME
static val mutable ERR_MISSING_DISPLAY_NAME: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_DOCUMENT_ELEMENT Field

GCVExceptionERR_MISSING_DOCUMENT_ELEMENT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_MISSING_DOCUMENT_ELEMENT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_DOCUMENT_ELEMENT
Public Const ERR_MISSING_DOCUMENT_ELEMENT As Integer
public:
literal int ERR_MISSING_DOCUMENT_ELEMENT
static val mutable ERR_MISSING_DOCUMENT_ELEMENT: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_ENUM_CHOICES Field

GCVExceptionERR_MISSING_ENUM_CHOICES Field
Code indicating that an enum GCV has no enum choices.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_ENUM_CHOICES
Public Const ERR_MISSING_ENUM_CHOICES As Integer
public:
literal int ERR_MISSING_ENUM_CHOICES
static val mutable ERR_MISSING_ENUM_CHOICES: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_INSTANCE_VALUE Field

GCVExceptionERR_MISSING_INSTANCE_VALUE Field
Code indicating that an instance doesn't have one or more values in the structured value template

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_INSTANCE_VALUE
Public Const ERR_MISSING_INSTANCE_VALUE As Integer
public:
literal int ERR_MISSING_INSTANCE_VALUE
static val mutable ERR_MISSING_INSTANCE_VALUE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MISSING_TEMPLATE Field

GCVExceptionERR_MISSING_TEMPLATE Field
Code indicating no <template> element was found in a structured value definition

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MISSING_TEMPLATE
Public Const ERR_MISSING_TEMPLATE As Integer
public:
literal int ERR_MISSING_TEMPLATE
static val mutable ERR_MISSING_TEMPLATE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MULTIPLE_DEFINITIONS_ELEMENT Field

GCVExceptionERR_MULTIPLE_DEFINITIONS_ELEMENT Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_MULTIPLE_DEFINITIONS_ELEMENT"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MULTIPLE_DEFINITIONS_ELEMENT
Public Const ERR_MULTIPLE_DEFINITIONS_ELEMENT As Integer
public:
literal int ERR_MULTIPLE_DEFINITIONS_ELEMENT
static val mutable ERR_MULTIPLE_DEFINITIONS_ELEMENT: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_MUST_BE_TRUE_OR_FALSE Field

GCVExceptionERR_MUST_BE_TRUE_OR_FALSE Field
Code indicating an XML attribute value must be
Copy
"true"
or
Copy
"false"

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_MUST_BE_TRUE_OR_FALSE
Public Const ERR_MUST_BE_TRUE_OR_FALSE As Integer
public:
literal int ERR_MUST_BE_TRUE_OR_FALSE
static val mutable ERR_MUST_BE_TRUE_OR_FALSE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_REFERENCE_NOT_ALLOWED_HERE Field

GCVExceptionERR_REFERENCE_NOT_ALLOWED_HERE Field
Code indicating a gcv-ref was found in an invalid location in the XML.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_REFERENCE_NOT_ALLOWED_HERE
Public Const ERR_REFERENCE_NOT_ALLOWED_HERE As Integer
public:
literal int ERR_REFERENCE_NOT_ALLOWED_HERE
static val mutable ERR_REFERENCE_NOT_ALLOWED_HERE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_SUBORDINATE_NOT_ALLOWED Field

GCVExceptionERR_SUBORDINATE_NOT_ALLOWED Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_SUBORDINATE_NOT_ALLOWED"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_SUBORDINATE_NOT_ALLOWED
Public Const ERR_SUBORDINATE_NOT_ALLOWED As Integer
public:
literal int ERR_SUBORDINATE_NOT_ALLOWED
static val mutable ERR_SUBORDINATE_NOT_ALLOWED: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_TYPE_NOT_ALLOWED_HERE Field

GCVExceptionERR_TYPE_NOT_ALLOWED_HERE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_TYPE_NOT_ALLOWED_HERE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_TYPE_NOT_ALLOWED_HERE
Public Const ERR_TYPE_NOT_ALLOWED_HERE As Integer
public:
literal int ERR_TYPE_NOT_ALLOWED_HERE
static val mutable ERR_TYPE_NOT_ALLOWED_HERE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_VALUE_INCOMPLETE Field

GCVExceptionERR_VALUE_INCOMPLETE Field
Code indicating a GCV value is not lexically complete.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_VALUE_INCOMPLETE
Public Const ERR_VALUE_INCOMPLETE As Integer
public:
literal int ERR_VALUE_INCOMPLETE
static val mutable ERR_VALUE_INCOMPLETE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_VALUE_INVALID_CHAR Field

GCVExceptionERR_VALUE_INVALID_CHAR Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_VALUE_INVALID_CHAR"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_VALUE_INVALID_CHAR
Public Const ERR_VALUE_INVALID_CHAR As Integer
public:
literal int ERR_VALUE_INVALID_CHAR
static val mutable ERR_VALUE_INVALID_CHAR: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_VALUE_NULL Field

GCVExceptionERR_VALUE_NULL Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_VALUE_NULL"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_VALUE_NULL
Public Const ERR_VALUE_NULL As Integer
public:
literal int ERR_VALUE_NULL
static val mutable ERR_VALUE_NULL: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_VALUE_OUT_OF_RANGE Field

GCVExceptionERR_VALUE_OUT_OF_RANGE Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_VALUE_OUT_OF_RANGE"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_VALUE_OUT_OF_RANGE
Public Const ERR_VALUE_OUT_OF_RANGE As Integer
public:
literal int ERR_VALUE_OUT_OF_RANGE
static val mutable ERR_VALUE_OUT_OF_RANGE: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ERR_VALUE_REFERENCE_NOT_FOUND Field

GCVExceptionERR_VALUE_REFERENCE_NOT_FOUND Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.ERR_VALUE_REFERENCE_NOT_FOUND"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ERR_VALUE_REFERENCE_NOT_FOUND
Public Const ERR_VALUE_REFERENCE_NOT_FOUND As Integer
public:
literal int ERR_VALUE_REFERENCE_NOT_FOUND
static val mutable ERR_VALUE_REFERENCE_NOT_FOUND: int

Field Value

Type: Int32
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.messageSource Field

GCVExceptionmessageSource Field

[Missing <summary> documentation for "F:DXMLBase.Gcv.GCVException.messageSource"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static LocalizedMessageSource messageSource
Protected Shared messageSource As LocalizedMessageSource
protected:
static LocalizedMessageSource^ messageSource
static val mutable messageSource: LocalizedMessageSource

Field Value

Type: LocalizedMessageSource
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException Methods

GCVException Methods

The GCVException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException Properties

GCVException Properties

The GCVException type exposes the following members.

Properties
 | Name | Description
Public property | Code |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName |
Top
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.Code Property

GCVExceptionCode Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCVException.Code"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Code { get; }
Public Overridable ReadOnly Property Code As Integer
    Get
public:
virtual property int Code {
    int get ();
}
abstract Code : int with get
override Code : int with get

Return Value

Type: Int32
code
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.Node Property

GCVExceptionNode Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCVException.Node"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlNode Node { get; }
Public Overridable ReadOnly Property Node As XmlNode
    Get
public:
virtual property XmlNode^ Node {
    XmlNode^ get ();
}
abstract Node : XmlNode with get
override Node : XmlNode with get

Property Value

Type: XmlNode
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException.ValueName Property

GCVExceptionValueName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCVException.ValueName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ValueName { get; }
Public Overridable ReadOnly Property ValueName As String
    Get
public:
virtual property String^ ValueName {
    String^ get ();
}
abstract ValueName : string with get
override ValueName : string with get

Property Value

Type: String
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVException Events

GCVException Events

The GCVException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCVException Class
DXMLBase.Gcv Namespace


GCVRef Class

GCVRef Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCVRef"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCValue
DXMLBase.GcvGCVRef

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GCVRef : GCValue
Public Class GCVRef
    Inherits GCValue
public ref class GCVRef : public GCValue
type GCVRef =
    class
        inherit GCValue
    end

The GCVRef type exposes the following members.

Constructors
 | Name | Description
Public method | GCVRef(String) | Initializes a new instance of the GCVRef class
Public method | GCVRef(String, String) | Initializes a new instance of the GCVRef class
Top
Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property | DriverParamName
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCVRef Constructor

GCVRef Constructor
Overload List
 | Name | Description
Public method | GCVRef(String) | Initializes a new instance of the GCVRef class
Public method | GCVRef(String, String) | Initializes a new instance of the GCVRef class
Top
See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef Constructor (String)

GCVRef Constructor (String)
Initializes a new instance of the GCVRef class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVRef(
    string name
)
Public Sub New (
    name As String
)
public:
GCVRef(
    String^ name
)
new :
        name : string -> GCVRef

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCVRef.#ctor(System.String)"]

See Also

Reference

GCVRef Class
GCVRef Overload
DXMLBase.Gcv Namespace


GCVRef Constructor (String, String)

GCVRef Constructor (String, String)
Initializes a new instance of the GCVRef class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVRef(
    string name,
    string driverParamName
)
Public Sub New (
    name As String,
    driverParamName As String
)
public:
GCVRef(
    String^ name,
    String^ driverParamName
)
new :
        name : string *
        driverParamName : string -> GCVRef

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCVRef.#ctor(System.String,System.String)"]

driverParamName
Type: SystemString

[Missing <param name="driverParamName"/> documentation for "M:DXMLBase.Gcv.GCVRef.#ctor(System.String,System.String)"]

See Also

Reference

GCVRef Class
GCVRef Overload
DXMLBase.Gcv Namespace


GCVRef Fields

GCVRef Fields

The GCVRef type exposes the following members.

Fields
 | Name | Description
Protected field | modified | (Inherited from GCValue.)
Top
See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef Methods

GCVRef Methods

The GCVRef type exposes the following members.

Methods
 | Name | Description
Public method | addXmlComment | (Inherited from GCValue.)
Protected method | addXmlItems | (Inherited from GCValue.)
Public method | addXmlProcessingInstruction | (Inherited from GCValue.)
Protected method | cloneCommon | (Inherited from GCValue.)
Public method | cloneValue | (Overrides GCValuecloneValue(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getOwner | (Inherited from GCValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getXMLValue | (Inherited from GCValue.)
Public method | hasBeenModified | (Inherited from GCValue.)
Public method | localize | (Inherited from GCValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseValue | (Overrides GCValueparseValue(String).)
Public method | resetModified | (Inherited from GCValue.)
Protected method | setParent | (Inherited from GCValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXML | (Inherited from GCValue.)
Top
See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef.cloneValue Method

GCVRefcloneValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCVRef.cloneValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override GCValue cloneValue(
    string name
)
Public Overrides Function cloneValue (
    name As String
) As GCValue
public:
virtual GCValue^ cloneValue(
    String^ name
) override
abstract cloneValue :
        name : string -> GCValue
override cloneValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.GCVRef.cloneValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.GCVRef.cloneValue(System.String)"]

See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef.parseValue Method

GCVRefparseValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.GCVRef.parseValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void parseValue(
    string value_Renamed
)
Public Overrides Sub parseValue (
    value_Renamed As String
)
public:
virtual void parseValue(
    String^ value_Renamed
) override
abstract parseValue :
        value_Renamed : string -> unit
override parseValue :
        value_Renamed : string -> unit

Parameters

value_Renamed
Type: SystemString

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.GCVRef.parseValue(System.String)"]

See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef Properties

GCVRef Properties

The GCVRef type exposes the following members.

Properties
Name | Description
Public property Description
Get or set the description of this value. May return
Copy
null
, or an empty string.
(Inherited from GCValue.)
Public property DescriptionRef
Get or set the description localization reference. May return null.
(Inherited from GCValue.)
Public property | DisplayName | (Inherited from GCValue.)
Public property | DisplayNameRef | (Inherited from GCValue.)
Public property | DriverParamName
Public property Hidden
Get or set whether this GCV should be hidden in the user interface.
(Inherited from GCValue.)
Public property Mandatory
Get or set whether the UI should require that a value be entered for this GCV.
(Inherited from GCValue.)
Public property | Name | (Inherited from GCValue.)
Public property | Parent | (Inherited from GCValue.)
Public property | Type | (Inherited from GCValue.)
Public property | TypeString | (Inherited from GCValue.)
Public property | Value | (Overrides GCValueValue.)
Public property | XmlItems | (Inherited from GCValue.)
Top
See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef.DriverParamName Property

GCVRefDriverParamName Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCVRef.DriverParamName"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DriverParamName { get; set; }
Public Overridable Property DriverParamName As String
    Get
    Set
public:
virtual property String^ DriverParamName {
    String^ get ();
    void set (String^ value);
}
abstract DriverParamName : string with get, set
override DriverParamName : string with get, set

Property Value

Type: String
See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVRef.Value Property

GCVRefValue Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.GCVRef.Value"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

GCVRef Class
DXMLBase.Gcv Namespace


GCVStateException Class

GCVStateException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCVStateException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvGCVStateException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GCVStateException : GCVException
<SerializableAttribute>
Public Class GCVStateException
    Inherits GCVException
[SerializableAttribute]
public ref class GCVStateException : public GCVException
[<SerializableAttribute>]
type GCVStateException =
    class
        inherit GCVException
    end

The GCVStateException type exposes the following members.

Constructors
 | Name | Description
Public method | GCVStateException | Initializes a new instance of the GCVStateException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCVStateException Constructor

GCVStateException Constructor
Initializes a new instance of the GCVStateException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVStateException(
    int code
)
Public Sub New (
    code As Integer
)
public:
GCVStateException(
    int code
)
new :
        code : int -> GCVStateException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVStateException.#ctor(System.Int32)"]

See Also

Reference

GCVStateException Class
DXMLBase.Gcv Namespace


GCVStateException Methods

GCVStateException Methods

The GCVStateException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCVStateException Class
DXMLBase.Gcv Namespace


GCVStateException Properties

GCVStateException Properties

The GCVStateException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
See Also

Reference

GCVStateException Class
DXMLBase.Gcv Namespace


GCVStateException Events

GCVStateException Events

The GCVStateException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCVStateException Class
DXMLBase.Gcv Namespace


GCVXmlParseException Class

GCVXmlParseException Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.GCVXmlParseException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvGCVXmlParseException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GCVXmlParseException : GCVException
<SerializableAttribute>
Public Class GCVXmlParseException
    Inherits GCVException
[SerializableAttribute]
public ref class GCVXmlParseException : public GCVException
[<SerializableAttribute>]
type GCVXmlParseException =
    class
        inherit GCVException
    end

The GCVXmlParseException type exposes the following members.

Constructors
 | Name | Description
Public method | GCVXmlParseException(Int32) | Initializes a new instance of the GCVXmlParseException class
Public method | GCVXmlParseException(Int32, Object) | Initializes a new instance of the GCVXmlParseException class
Public method | GCVXmlParseException(Int32, XmlNode) | Initializes a new instance of the GCVXmlParseException class
Public method | GCVXmlParseException(Int32, Object, XmlNode) | Initializes a new instance of the GCVXmlParseException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


GCVXmlParseException Constructor

GCVXmlParseException Constructor
Overload List
 | Name | Description
Public method | GCVXmlParseException(Int32) | Initializes a new instance of the GCVXmlParseException class
Public method | GCVXmlParseException(Int32, Object) | Initializes a new instance of the GCVXmlParseException class
Public method | GCVXmlParseException(Int32, XmlNode) | Initializes a new instance of the GCVXmlParseException class
Public method | GCVXmlParseException(Int32, Object, XmlNode) | Initializes a new instance of the GCVXmlParseException class
Top
See Also

Reference

GCVXmlParseException Class
DXMLBase.Gcv Namespace


GCVXmlParseException Constructor (Int32)

GCVXmlParseException Constructor (Int32)
Initializes a new instance of the GCVXmlParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVXmlParseException(
    int code
)
Public Sub New (
    code As Integer
)
public:
GCVXmlParseException(
    int code
)
new :
        code : int -> GCVXmlParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32)"]

See Also

Reference

GCVXmlParseException Class
GCVXmlParseException Overload
DXMLBase.Gcv Namespace


GCVXmlParseException Constructor (Int32, Object[])

GCVXmlParseException Constructor (Int32, Object)
Initializes a new instance of the GCVXmlParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVXmlParseException(
    int code,
    Object[] parms
)
Public Sub New (
    code As Integer,
    parms As Object()
)
public:
GCVXmlParseException(
    int code,
    array<Object^>^ parms
)
new :
        code : int *
        parms : Object[] -> GCVXmlParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Object[])"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Object[])"]

See Also

Reference

GCVXmlParseException Class
GCVXmlParseException Overload
DXMLBase.Gcv Namespace


GCVXmlParseException Constructor (Int32, XmlNode)

GCVXmlParseException Constructor (Int32, XmlNode)
Initializes a new instance of the GCVXmlParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVXmlParseException(
    int code,
    XmlNode node
)
Public Sub New (
    code As Integer,
    node As XmlNode
)
public:
GCVXmlParseException(
    int code,
    XmlNode^ node
)
new :
        code : int *
        node : XmlNode -> GCVXmlParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Xml.XmlNode)"]

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Xml.XmlNode)"]

See Also

Reference

GCVXmlParseException Class
GCVXmlParseException Overload
DXMLBase.Gcv Namespace


GCVXmlParseException Constructor (Int32, Object[], XmlNode)

GCVXmlParseException Constructor (Int32, Object, XmlNode)
Initializes a new instance of the GCVXmlParseException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GCVXmlParseException(
    int code,
    Object[] parms,
    XmlNode node
)
Public Sub New (
    code As Integer,
    parms As Object(),
    node As XmlNode
)
public:
GCVXmlParseException(
    int code,
    array<Object^>^ parms,
    XmlNode^ node
)
new :
        code : int *
        parms : Object[] *
        node : XmlNode -> GCVXmlParseException

Parameters

code
Type: SystemInt32

[Missing <param name="code"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Object[],System.Xml.XmlNode)"]

parms
Type: SystemObject

[Missing <param name="parms"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Object[],System.Xml.XmlNode)"]

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:DXMLBase.Gcv.GCVXmlParseException.#ctor(System.Int32,System.Object[],System.Xml.XmlNode)"]

See Also

Reference

GCVXmlParseException Class
GCVXmlParseException Overload
DXMLBase.Gcv Namespace


GCVXmlParseException Methods

GCVXmlParseException Methods

The GCVXmlParseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GCVXmlParseException Class
DXMLBase.Gcv Namespace


GCVXmlParseException Properties

GCVXmlParseException Properties

The GCVXmlParseException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
See Also

Reference

GCVXmlParseException Class
DXMLBase.Gcv Namespace


GCVXmlParseException Events

GCVXmlParseException Events

The GCVXmlParseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GCVXmlParseException Class
DXMLBase.Gcv Namespace


IConfigElement Interface

IConfigElement Interface
Interface for items that may be read from or written to an XML configuration document.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConfigElement
Public Interface IConfigElement
public interface class IConfigElement
type IConfigElement =  interface end

The IConfigElement type exposes the following members.

Methods
Name | Description
Public method hasBeenModified
Return
Copy
true
if this instance has been modified. The instance is considered to have been modified if a change was made that affects the persistent representation since: The instance was constructed from an XML representation.
Copy
resetModified()
was last called
Public method resetModified
Reset the modified flag for this instance such that
Copy
hasBeenModified()
will return
Copy
false
.
Public method | toXML
Top
See Also

Reference

DXMLBase.Gcv Namespace


IConfigElement Methods

IConfigElement Methods

The IConfigElement type exposes the following members.

Methods
Name | Description
Public method hasBeenModified
Return
Copy
true
if this instance has been modified. The instance is considered to have been modified if a change was made that affects the persistent representation since: The instance was constructed from an XML representation.
Copy
resetModified()
was last called
Public method resetModified
Reset the modified flag for this instance such that
Copy
hasBeenModified()
will return
Copy
false
.
Public method | toXML
Top
See Also

Reference

IConfigElement Interface
DXMLBase.Gcv Namespace


IConfigElement.hasBeenModified Method

IConfigElementhasBeenModified Method
Return
Copy
true
if this instance has been modified. The instance is considered to have been modified if a change was made that affects the persistent representation since: The instance was constructed from an XML representation.
Copy
resetModified()
was last called

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool hasBeenModified()
Function hasBeenModified As Boolean
bool hasBeenModified()
abstract hasBeenModified : unit -> bool

Return Value

Type: Boolean
true if this instance has been modified.
See Also

Reference

IConfigElement Interface
DXMLBase.Gcv Namespace


IConfigElement.resetModified Method

IConfigElementresetModified Method
Reset the modified flag for this instance such that
Copy
hasBeenModified()
will return
Copy
false
.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void resetModified()
Sub resetModified
void resetModified()
abstract resetModified : unit -> unit
See Also

Reference

IConfigElement Interface
DXMLBase.Gcv Namespace


IConfigElement.toXML Method

IConfigElementtoXML Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IConfigElement.toXML(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XmlElement toXML(
    XmlNode parent
)
Function toXML (
    parent As XmlNode
) As XmlElement
XmlElement^ toXML(
    XmlNode^ parent
)
abstract toXML :
        parent : XmlNode -> XmlElement

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.IConfigElement.toXML(System.Xml.XmlNode)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Gcv.IConfigElement.toXML(System.Xml.XmlNode)"]

See Also

Reference

IConfigElement Interface
DXMLBase.Gcv Namespace


IGCOwner Interface

IGCOwner Interface
Interface for objects that "own" control values.

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IGCOwner
Public Interface IGCOwner
public interface class IGCOwner
type IGCOwner =  interface end

The IGCOwner type exposes the following members.

Methods
 | Name | Description
Public method | addName |
Public method | appendValue |
Public method | checkAllowedType |
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Public method | isNameAllowed |
Public method | removeName |
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Public method | replaceValue |
Top
Properties
 | Name | Description
Public property | Children |
Public property | Descendants |
Top
See Also

Reference

DXMLBase.Gcv Namespace


IGCOwner Methods

IGCOwner Methods

The IGCOwner type exposes the following members.

Methods
 | Name | Description
Public method | addName |
Public method | appendValue |
Public method | checkAllowedType |
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Public method | isNameAllowed |
Public method | removeName |
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Public method | replaceValue |
Top
See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.addName Method

IGCOwneraddName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.addName(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void addName(
    GCValue newValue
)
Sub addName (
    newValue As GCValue
)
void addName(
    GCValue^ newValue
)
abstract addName :
        newValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.IGCOwner.addName(DXMLBase.Gcv.GCValue)"]

See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.appendValue Method

IGCOwnerappendValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.appendValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void appendValue(
    GCValue value_Renamed
)
Sub appendValue (
    value_Renamed As GCValue
)
void appendValue(
    GCValue^ value_Renamed
)
abstract appendValue :
        value_Renamed : GCValue -> unit

Parameters

value_Renamed
Type: DXMLBase.GcvGCValue

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.IGCOwner.appendValue(DXMLBase.Gcv.GCValue)"]

See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.checkAllowedType Method

IGCOwnercheckAllowedType Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool checkAllowedType(
    GCValueValueType type
)
Function checkAllowedType (
    type As GCValueValueType
) As Boolean
bool checkAllowedType(
    GCValueValueType type
)
abstract checkAllowedType :
        type : GCValueValueType -> bool

Parameters

type
Type: DXMLBase.GcvGCValueValueType

[Missing <param name="type"/> documentation for "M:DXMLBase.Gcv.IGCOwner.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.IGCOwner.checkAllowedType(DXMLBase.Gcv.GCValue.ValueType)"]

See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.insertValue Method

IGCOwnerinsertValue Method
Overload List
 | Name | Description
Public method | insertValue(GCValue, GCValue) |
Public method | insertValue(GCValue, String) |
Top
See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.insertValue Method (GCValue, GCValue)

IGCOwnerinsertValue Method (GCValue, GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void insertValue(
    GCValue newValue,
    GCValue insertionPoint
)
Sub insertValue (
    newValue As GCValue,
    insertionPoint As GCValue
)
void insertValue(
    GCValue^ newValue,
    GCValue^ insertionPoint
)
abstract insertValue :
        newValue : GCValue *
        insertionPoint : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.IGCOwner.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

insertionPoint
Type: DXMLBase.GcvGCValue

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.IGCOwner.insertValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

See Also

Reference

IGCOwner Interface
insertValue Overload
DXMLBase.Gcv Namespace


IGCOwner.insertValue Method (GCValue, String)

IGCOwnerinsertValue Method (GCValue, String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void insertValue(
    GCValue newValue,
    string insertionPoint
)
Sub insertValue (
    newValue As GCValue,
    insertionPoint As String
)
void insertValue(
    GCValue^ newValue,
    String^ insertionPoint
)
abstract insertValue :
        newValue : GCValue *
        insertionPoint : string -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.IGCOwner.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

insertionPoint
Type: SystemString

[Missing <param name="insertionPoint"/> documentation for "M:DXMLBase.Gcv.IGCOwner.insertValue(DXMLBase.Gcv.GCValue,System.String)"]

See Also

Reference

IGCOwner Interface
insertValue Overload
DXMLBase.Gcv Namespace


IGCOwner.isNameAllowed Method

IGCOwnerisNameAllowed Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.isNameAllowed(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool isNameAllowed(
    string name
)
Function isNameAllowed (
    name As String
) As Boolean
bool isNameAllowed(
    String^ name
)
abstract isNameAllowed :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.IGCOwner.isNameAllowed(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.IGCOwner.isNameAllowed(System.String)"]

See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.removeName Method

IGCOwnerremoveName Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.removeName(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void removeName(
    GCValue oldValue
)
Sub removeName (
    oldValue As GCValue
)
void removeName(
    GCValue^ oldValue
)
abstract removeName :
        oldValue : GCValue -> unit

Parameters

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.IGCOwner.removeName(DXMLBase.Gcv.GCValue)"]

See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.removeValue Method

IGCOwnerremoveValue Method
Overload List
 | Name | Description
Public method | removeValue(String) |
Public method | removeValue(GCValue) |
Top
See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.removeValue Method (String)

IGCOwnerremoveValue Method (String)

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.removeValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool removeValue(
    string name
)
Function removeValue (
    name As String
) As Boolean
bool removeValue(
    String^ name
)
abstract removeValue :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.IGCOwner.removeValue(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.IGCOwner.removeValue(System.String)"]

See Also

Reference

IGCOwner Interface
removeValue Overload
DXMLBase.Gcv Namespace


IGCOwner.removeValue Method (GCValue)

IGCOwnerremoveValue Method (GCValue)

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.removeValue(DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool removeValue(
    GCValue value_Renamed
)
Function removeValue (
    value_Renamed As GCValue
) As Boolean
bool removeValue(
    GCValue^ value_Renamed
)
abstract removeValue :
        value_Renamed : GCValue -> bool

Parameters

value_Renamed
Type: DXMLBase.GcvGCValue

[Missing <param name="value_Renamed"/> documentation for "M:DXMLBase.Gcv.IGCOwner.removeValue(DXMLBase.Gcv.GCValue)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Gcv.IGCOwner.removeValue(DXMLBase.Gcv.GCValue)"]

See Also

Reference

IGCOwner Interface
removeValue Overload
DXMLBase.Gcv Namespace


IGCOwner.replaceValue Method

IGCOwnerreplaceValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.IGCOwner.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void replaceValue(
    GCValue newValue,
    GCValue oldValue
)
Sub replaceValue (
    newValue As GCValue,
    oldValue As GCValue
)
void replaceValue(
    GCValue^ newValue,
    GCValue^ oldValue
)
abstract replaceValue :
        newValue : GCValue *
        oldValue : GCValue -> unit

Parameters

newValue
Type: DXMLBase.GcvGCValue

[Missing <param name="newValue"/> documentation for "M:DXMLBase.Gcv.IGCOwner.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

oldValue
Type: DXMLBase.GcvGCValue

[Missing <param name="oldValue"/> documentation for "M:DXMLBase.Gcv.IGCOwner.replaceValue(DXMLBase.Gcv.GCValue,DXMLBase.Gcv.GCValue)"]

See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner Properties

IGCOwner Properties

The IGCOwner type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | Descendants |
Top
See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.Children Property

IGCOwnerChildren Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.IGCOwner.Children"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<GCValue> Children { get; }
ReadOnly Property Children As IEnumerable(Of GCValue)
    Get
property IEnumerable<GCValue^>^ Children {
    IEnumerable<GCValue^>^ get ();
}
abstract Children : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue
See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


IGCOwner.Descendants Property

IGCOwnerDescendants Property

[Missing <summary> documentation for "P:DXMLBase.Gcv.IGCOwner.Descendants"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<GCValue> Descendants { get; }
ReadOnly Property Descendants As IEnumerable(Of GCValue)
    Get
property IEnumerable<GCValue^>^ Descendants {
    IEnumerable<GCValue^>^ get ();
}
abstract Descendants : IEnumerable<GCValue> with get

Property Value

Type: IEnumerable GCValue
See Also

Reference

IGCOwner Interface
DXMLBase.Gcv Namespace


ShimParams Class

ShimParams Class

[Missing <summary> documentation for "T:DXMLBase.Gcv.ShimParams"]

Inheritance Hierarchy
SystemObject
DXMLBase.GcvGCList
DXMLBase.GcvGCDefinitions
DXMLBase.GcvShimParams

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ShimParams : GCDefinitions
Public Class ShimParams
    Inherits GCDefinitions
public ref class ShimParams : public GCDefinitions
type ShimParams =
    class
        inherit GCDefinitions
    end

The ShimParams type exposes the following members.

Constructors
 | Name | Description
Public method | ShimParams | Initializes a new instance of the ShimParams class
Top
Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Inherited from GCList.)
Public method | apply(String) | (Inherited from GCDefinitions.)
Public method | apply(XmlNode) | (Inherited from GCDefinitions.)
Public method | checkAllowedType | (Inherited from GCDefinitions.)
 | constructShimParams(Byte) |
 | constructShimParams(XmlNode) |
Public method | convertReferences |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCList.)
Public method | insertValue(GCValue, String) | (Inherited from GCList.)
Public method | isNameAllowed | (Inherited from GCList.)
Public method | localize | (Inherited from GCDefinitions.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | merge | (Inherited from GCDefinitions.)
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Inherited from GCList.)
Public method | removeValue(GCValue) | (Inherited from GCList.)
Public method | replaceValue | (Inherited from GCList.)
Public method | resetModified | (Inherited from GCList.)
Public method | toBytes | (Inherited from GCDefinitions.)
Public method | toShimInitParams |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml | (Inherited from GCDefinitions.)
Public method | toXML | (Inherited from GCDefinitions.)
Top
Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


ShimParams Constructor

ShimParams Constructor
Initializes a new instance of the ShimParams class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShimParams()
Public Sub New
public:
ShimParams()
new : unit -> ShimParams
See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams Fields

ShimParams Fields

The ShimParams type exposes the following members.

Fields
 | Name | Description
Protected field | defsList | (Inherited from GCList.)
Protected field | modified | (Inherited from GCList.)
Top
See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams Methods

ShimParams Methods

The ShimParams type exposes the following members.

Methods
 | Name | Description
Public method | addName | (Inherited from GCList.)
Public method | appendValue | (Inherited from GCList.)
Public method | apply(String) | (Inherited from GCDefinitions.)
Public method | apply(XmlNode) | (Inherited from GCDefinitions.)
Public method | checkAllowedType | (Inherited from GCDefinitions.)
 | constructShimParams(Byte) |
 | constructShimParams(XmlNode) |
Public method | convertReferences |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildValue | (Inherited from GCList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getValue | (Inherited from GCList.)
Public method | hasBeenModified | (Inherited from GCList.)
Public method | insertValue(GCValue, GCValue) | (Inherited from GCList.)
Public method | insertValue(GCValue, String) | (Inherited from GCList.)
Public method | isNameAllowed | (Inherited from GCList.)
Public method | localize | (Inherited from GCDefinitions.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | merge | (Inherited from GCDefinitions.)
Public method | removeName | (Inherited from GCList.)
Public method | removeValue(String) | (Inherited from GCList.)
Public method | removeValue(GCValue) | (Inherited from GCList.)
Public method | replaceValue | (Inherited from GCList.)
Public method | resetModified | (Inherited from GCList.)
Public method | toBytes | (Inherited from GCDefinitions.)
Public method | toShimInitParams |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml | (Inherited from GCDefinitions.)
Public method | toXML | (Inherited from GCDefinitions.)
Top
See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams.constructShimParams Method

ShimParamsconstructShimParams Method
Overload List
Name | Description
constructShimParams(Byte) |
constructShimParams(XmlNode) |
Top
See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams.constructShimParams Method (Byte[])

ShimParamsconstructShimParams Method (Byte)

[Missing <summary> documentation for "M:DXMLBase.Gcv.ShimParams.constructShimParams(System.Byte[])"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ShimParams constructShimParams(
    byte[] bytes
)
Public Shared Function constructShimParams (
    bytes As Byte()
) As ShimParams
public:
static ShimParams^ constructShimParams(
    array<unsigned char>^ bytes
)
static member constructShimParams :
        bytes : byte[] -> ShimParams

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:DXMLBase.Gcv.ShimParams.constructShimParams(System.Byte[])"]

Return Value

Type: ShimParams

[Missing <returns> documentation for "M:DXMLBase.Gcv.ShimParams.constructShimParams(System.Byte[])"]

See Also

Reference

ShimParams Class
constructShimParams Overload
DXMLBase.Gcv Namespace


ShimParams.constructShimParams Method (XmlNode)

ShimParamsconstructShimParams Method (XmlNode)

[Missing <summary> documentation for "M:DXMLBase.Gcv.ShimParams.constructShimParams(System.Xml.XmlNode)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ShimParams constructShimParams(
    XmlNode parent
)
Public Shared Function constructShimParams (
    parent As XmlNode
) As ShimParams
public:
static ShimParams^ constructShimParams(
    XmlNode^ parent
)
static member constructShimParams :
        parent : XmlNode -> ShimParams

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.ShimParams.constructShimParams(System.Xml.XmlNode)"]

Return Value

Type: ShimParams

[Missing <returns> documentation for "M:DXMLBase.Gcv.ShimParams.constructShimParams(System.Xml.XmlNode)"]

See Also

Reference

ShimParams Class
constructShimParams Overload
DXMLBase.Gcv Namespace


ShimParams.convertReferences Method

ShimParamsconvertReferences Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.ShimParams.convertReferences(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement convertReferences(
    XmlNode parent,
    ShimParamsReferenceResolver refResolver
)
Public Overridable Function convertReferences (
    parent As XmlNode,
    refResolver As ShimParamsReferenceResolver
) As XmlElement
public:
virtual XmlElement^ convertReferences(
    XmlNode^ parent,
    ShimParamsReferenceResolver^ refResolver
)
abstract convertReferences :
        parent : XmlNode *
        refResolver : ShimParamsReferenceResolver -> XmlElement
override convertReferences :
        parent : XmlNode *
        refResolver : ShimParamsReferenceResolver -> XmlElement

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.ShimParams.convertReferences(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

refResolver
Type: DXMLBase.GcvShimParamsReferenceResolver

[Missing <param name="refResolver"/> documentation for "M:DXMLBase.Gcv.ShimParams.convertReferences(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Gcv.ShimParams.convertReferences(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams.toShimInitParams Method

ShimParamstoShimInitParams Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.ShimParams.toShimInitParams(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement toShimInitParams(
    XmlNode parent,
    ShimParamsReferenceResolver refResolver
)
Public Overridable Function toShimInitParams (
    parent As XmlNode,
    refResolver As ShimParamsReferenceResolver
) As XmlElement
public:
virtual XmlElement^ toShimInitParams(
    XmlNode^ parent,
    ShimParamsReferenceResolver^ refResolver
)
abstract toShimInitParams :
        parent : XmlNode *
        refResolver : ShimParamsReferenceResolver -> XmlElement
override toShimInitParams :
        parent : XmlNode *
        refResolver : ShimParamsReferenceResolver -> XmlElement

Parameters

parent
Type: System.XmlXmlNode

[Missing <param name="parent"/> documentation for "M:DXMLBase.Gcv.ShimParams.toShimInitParams(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

refResolver
Type: DXMLBase.GcvShimParamsReferenceResolver

[Missing <param name="refResolver"/> documentation for "M:DXMLBase.Gcv.ShimParams.toShimInitParams(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Gcv.ShimParams.toShimInitParams(System.Xml.XmlNode,DXMLBase.Gcv.ShimParams.ReferenceResolver)"]

See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams Properties

ShimParams Properties

The ShimParams type exposes the following members.

Properties
 | Name | Description
Public property | Children | (Inherited from GCList.)
Public property | Descendants | (Inherited from GCList.)
Top
See Also

Reference

ShimParams Class
DXMLBase.Gcv Namespace


ShimParams.NoSuchReferenceException Class

ShimParamsNoSuchReferenceException Class
GCVException indicating a gcv-ref or password reference wasn't found.
Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.GcvGCVException
DXMLBase.GcvShimParamsNoSuchReferenceException

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class NoSuchReferenceException : GCVException
<SerializableAttribute>
Public Class NoSuchReferenceException
    Inherits GCVException
[SerializableAttribute]
public ref class NoSuchReferenceException : public GCVException
[<SerializableAttribute>]
type NoSuchReferenceException =
    class
        inherit GCVException
    end

The ShimParamsNoSuchReferenceException type exposes the following members.

Constructors
 | Name | Description
Public method | ShimParamsNoSuchReferenceException | Initializes a new instance of the ShimParamsNoSuchReferenceException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Gcv Namespace


ShimParams.NoSuchReferenceException Constructor

ShimParamsNoSuchReferenceException Constructor
Initializes a new instance of the ShimParamsNoSuchReferenceException class

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NoSuchReferenceException(
    string referenceName,
    XmlNode location
)
Public Sub New (
    referenceName As String,
    location As XmlNode
)
public:
NoSuchReferenceException(
    String^ referenceName,
    XmlNode^ location
)
new :
        referenceName : string *
        location : XmlNode -> NoSuchReferenceException

Parameters

referenceName
Type: SystemString

[Missing <param name="referenceName"/> documentation for "M:DXMLBase.Gcv.ShimParams.NoSuchReferenceException.#ctor(System.String,System.Xml.XmlNode)"]

location
Type: System.XmlXmlNode

[Missing <param name="location"/> documentation for "M:DXMLBase.Gcv.ShimParams.NoSuchReferenceException.#ctor(System.String,System.Xml.XmlNode)"]

See Also

Reference

ShimParamsNoSuchReferenceException Class
DXMLBase.Gcv Namespace


NoSuchReferenceException Methods

NoSuchReferenceException Methods

The ShimParamsNoSuchReferenceException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ShimParamsNoSuchReferenceException Class
DXMLBase.Gcv Namespace


NoSuchReferenceException Properties

NoSuchReferenceException Properties

The ShimParamsNoSuchReferenceException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from GCVException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Node | (Inherited from GCVException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValueName | (Inherited from GCVException.)
Top
See Also

Reference

ShimParamsNoSuchReferenceException Class
DXMLBase.Gcv Namespace


NoSuchReferenceException Events

NoSuchReferenceException Events

The ShimParamsNoSuchReferenceException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ShimParamsNoSuchReferenceException Class
DXMLBase.Gcv Namespace


ShimParams.ReferenceResolver Interface

ShimParamsReferenceResolver Interface

[Missing <summary> documentation for "T:DXMLBase.Gcv.ShimParams.ReferenceResolver"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ReferenceResolver
Public Interface ReferenceResolver
public interface class ReferenceResolver
type ReferenceResolver =  interface end

The ShimParamsReferenceResolver type exposes the following members.

Methods
 | Name | Description
Public method | getReferencedValue |
Top
See Also

Reference

DXMLBase.Gcv Namespace


ReferenceResolver Methods

ReferenceResolver Methods

The ShimParamsReferenceResolver type exposes the following members.

Methods
 | Name | Description
Public method | getReferencedValue |
Top
See Also

Reference

ShimParamsReferenceResolver Interface
DXMLBase.Gcv Namespace


ShimParams.ReferenceResolver.getReferencedValue Method

ShimParamsReferenceResolvergetReferencedValue Method

[Missing <summary> documentation for "M:DXMLBase.Gcv.ShimParams.ReferenceResolver.getReferencedValue(System.String)"]

Namespace: DXMLBase.Gcv
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
GCValue getReferencedValue(
    string name
)
Function getReferencedValue (
    name As String
) As GCValue
GCValue^ getReferencedValue(
    String^ name
)
abstract getReferencedValue :
        name : string -> GCValue

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:DXMLBase.Gcv.ShimParams.ReferenceResolver.getReferencedValue(System.String)"]

Return Value

Type: GCValue

[Missing <returns> documentation for "M:DXMLBase.Gcv.ShimParams.ReferenceResolver.getReferencedValue(System.String)"]

See Also

Reference

ShimParamsReferenceResolver Interface
DXMLBase.Gcv Namespace


DXMLBase.Xds Namespace

DXMLBase.Xds Namespace

[Missing <summary> documentation for "N:DXMLBase.Xds"]

Classes
 | Class | Description
Public class | XdsAdd |
Public class | XdsAddAssociation |
Public class | XdsAddAttr |
Public class | XdsAddValue |
Public class | XdsAttr |
Public class | XdsAuthenticationInfo |
Public class | XdsCheckObjectPassword |
Public class | XdsComponent |
Public class | XdsCustomOperation |
Public class | XdsDelete |
Public class | XdsDriverOptions |
Public class | XdsDtd |
Public class | XdsElement |
Public class | XdsErrorException |
Public class | XdsFatalException |
Public class | XdsInitParams |
Public class | XdsInput |
Public class | XdsInstance |
Public class | XdsModify |
Public class | XdsModifyAttr |
Public class | XdsModifyPasswd |
Public class | XdsOperation |
Public class | XdsOpParent |
Public class | XdsOutput |
Public class | XdsPassword |
Public class | XdsPublisherOptions |
Public class | XdsQuery |
Public class | XdsQuerySchema |
Public class | XdsReadAttr |
Public class | XdsReferentialValue |
Public class | XdsRemoveAllValues |
Public class | XdsRemoveValue |
Public class | XdsRename |
Public class | XdsRetryException |
Public class | XdsSearchAttr |
Public class | XdsSearchClass |
Public class | XdsShimOptions |
Public class | XdsStatus |
Public class | XdsStatusException |
Public class | XdsStatusReport |
Public class | XdsSubscriberOptions |
Public class | XdsUtil | A collection of utility methods for dealing with the XDS vocabulary of XML.
Public class | XdsValue |
Public class | XdsValueBase |
Public class | XdsValueParent |
Public class | XdsWarningException |
Structures
 | Structure | Description
Public structure | XdsDtdSupportedFeature |
Enumerations
 | Enumeration | Description
Public enumeration | XdsOperationOpType |
Public enumeration | XdsQueryScopeValue |
Public enumeration | XdsStatusReportLevelValue |
Public enumeration | XdsValueBaseContentType |


XdsAdd Class

XdsAdd Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsAdd"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsAdd

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsAdd : XdsOperation
Public Class XdsAdd
    Inherits XdsOperation
public ref class XdsAdd : public XdsOperation
type XdsAdd =
    class
        inherit XdsOperation
    end

The XdsAdd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAddAttr |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddAttrs |
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | TemplateDN |
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsAdd Methods

XdsAdd Methods

The XdsAdd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAddAttr |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsAdd Class
DXMLBase.Xds Namespace


XdsAdd.newAddAttr Method

XdsAddnewAddAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsAdd.newAddAttr(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsAddAttr newAddAttr(
    string attrName
)
Public Function newAddAttr (
    attrName As String
) As XdsAddAttr
public:
XdsAddAttr^ newAddAttr(
    String^ attrName
)
member newAddAttr :
        attrName : string -> XdsAddAttr

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsAdd.newAddAttr(System.String)"]

Return Value

Type: XdsAddAttr

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsAdd.newAddAttr(System.String)"]

See Also

Reference

XdsAdd Class
DXMLBase.Xds Namespace


XdsAdd Properties

XdsAdd Properties

The XdsAdd type exposes the following members.

Properties
 | Name | Description
Public property | AddAttrs |
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | TemplateDN |
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsAdd Class
DXMLBase.Xds Namespace


XdsAdd.AddAttrs Property

XdsAddAddAttrs Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAdd.AddAttrs"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsAddAttr> AddAttrs { get; }
Public ReadOnly Property AddAttrs As IEnumerable(Of XdsAddAttr)
    Get
public:
property IEnumerable<XdsAddAttr^>^ AddAttrs {
    IEnumerable<XdsAddAttr^>^ get ();
}
member AddAttrs : IEnumerable<XdsAddAttr> with get

Property Value

Type: IEnumerable XdsAddAttr
See Also

Reference

XdsAdd Class
DXMLBase.Xds Namespace


XdsAdd.Password Property

XdsAddPassword Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAdd.Password"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

XdsAdd Class
DXMLBase.Xds Namespace


XdsAdd.TemplateDN Property

XdsAddTemplateDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAdd.TemplateDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TemplateDN { get; set; }
Public Property TemplateDN As String
    Get
    Set
public:
property String^ TemplateDN {
    String^ get ();
    void set (String^ value);
}
member TemplateDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsAdd Class
DXMLBase.Xds Namespace


XdsAddAssociation Class

XdsAddAssociation Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsAddAssociation"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsAddAssociation

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsAddAssociation : XdsOperation
Public Class XdsAddAssociation
    Inherits XdsOperation
public ref class XdsAddAssociation : public XdsOperation
type XdsAddAssociation =
    class
        inherit XdsOperation
    end

The XdsAddAssociation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Overrides XdsOperationAssociation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | DestEntryID |
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsAddAssociation Methods

XdsAddAssociation Methods

The XdsAddAssociation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsAddAssociation Class
DXMLBase.Xds Namespace


XdsAddAssociation Properties

XdsAddAssociation Properties

The XdsAddAssociation type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Overrides XdsOperationAssociation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | DestEntryID |
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsAddAssociation Class
DXMLBase.Xds Namespace


XdsAddAssociation.Association Property

XdsAddAssociationAssociation Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAddAssociation.Association"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Association { get; set; }
Public Overrides Property Association As String
    Get
    Set
public:
virtual property String^ Association {
    String^ get () override;
    void set (String^ value) override;
}
abstract Association : string with get, set
override Association : string with get, set

Property Value

Type: String
See Also

Reference

XdsAddAssociation Class
DXMLBase.Xds Namespace


XdsAddAssociation.DestEntryID Property

XdsAddAssociationDestEntryID Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAddAssociation.DestEntryID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DestEntryID { get; set; }
Public Property DestEntryID As String
    Get
    Set
public:
property String^ DestEntryID {
    String^ get ();
    void set (String^ value);
}
member DestEntryID : string with get, set

Property Value

Type: String
See Also

Reference

XdsAddAssociation Class
DXMLBase.Xds Namespace


XdsAddAttr Class

XdsAddAttr Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsAddAttr"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsAddAttr

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsAddAttr : XdsValueParent
Public Class XdsAddAttr
    Inherits XdsValueParent
public ref class XdsAddAttr : public XdsValueParent
type XdsAddAttr =
    class
        inherit XdsValueParent
    end

The XdsAddAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsAddAttr Methods

XdsAddAttr Methods

The XdsAddAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsAddAttr Class
DXMLBase.Xds Namespace


XdsAddAttr Properties

XdsAddAttr Properties

The XdsAddAttr type exposes the following members.

Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsAddAttr Class
DXMLBase.Xds Namespace


XdsAddAttr.AttrName Property

XdsAddAttrAttrName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAddAttr.AttrName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Property Value

Type: String
See Also

Reference

XdsAddAttr Class
DXMLBase.Xds Namespace


XdsAddValue Class

XdsAddValue Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsAddValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsAddValue

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsAddValue : XdsValueParent
Public Class XdsAddValue
    Inherits XdsValueParent
public ref class XdsAddValue : public XdsValueParent
type XdsAddValue =
    class
        inherit XdsValueParent
    end

The XdsAddValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsAddValue Methods

XdsAddValue Methods

The XdsAddValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsAddValue Class
DXMLBase.Xds Namespace


XdsAddValue Properties

XdsAddValue Properties

The XdsAddValue type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsAddValue Class
DXMLBase.Xds Namespace


XdsAttr Class

XdsAttr Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsAttr"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsAttr

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsAttr : XdsValueParent
Public Class XdsAttr
    Inherits XdsValueParent
public ref class XdsAttr : public XdsValueParent
type XdsAttr =
    class
        inherit XdsValueParent
    end

The XdsAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsAttr Methods

XdsAttr Methods

The XdsAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsAttr Class
DXMLBase.Xds Namespace


XdsAttr Properties

XdsAttr Properties

The XdsAttr type exposes the following members.

Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsAttr Class
DXMLBase.Xds Namespace


XdsAttr.AttrName Property

XdsAttrAttrName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAttr.AttrName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Property Value

Type: String
See Also

Reference

XdsAttr Class
DXMLBase.Xds Namespace


XdsAuthenticationInfo Class

XdsAuthenticationInfo Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsAuthenticationInfo"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsAuthenticationInfo

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsAuthenticationInfo : XdsElement
Public Class XdsAuthenticationInfo
    Inherits XdsElement
public ref class XdsAuthenticationInfo : public XdsElement
type XdsAuthenticationInfo =
    class
        inherit XdsElement
    end

The XdsAuthenticationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | Server |
Public property | User |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsAuthenticationInfo Methods

XdsAuthenticationInfo Methods

The XdsAuthenticationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsAuthenticationInfo Class
DXMLBase.Xds Namespace


XdsAuthenticationInfo Properties

XdsAuthenticationInfo Properties

The XdsAuthenticationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | Server |
Public property | User |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsAuthenticationInfo Class
DXMLBase.Xds Namespace


XdsAuthenticationInfo.Password Property

XdsAuthenticationInfoPassword Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAuthenticationInfo.Password"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

XdsAuthenticationInfo Class
DXMLBase.Xds Namespace


XdsAuthenticationInfo.Server Property

XdsAuthenticationInfoServer Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAuthenticationInfo.Server"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

XdsAuthenticationInfo Class
DXMLBase.Xds Namespace


XdsAuthenticationInfo.User Property

XdsAuthenticationInfoUser Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsAuthenticationInfo.User"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Property Value

Type: String
See Also

Reference

XdsAuthenticationInfo Class
DXMLBase.Xds Namespace


XdsCheckObjectPassword Class

XdsCheckObjectPassword Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsCheckObjectPassword"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsCheckObjectPassword

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsCheckObjectPassword : XdsOperation
Public Class XdsCheckObjectPassword
    Inherits XdsOperation
public ref class XdsCheckObjectPassword : public XdsOperation
type XdsCheckObjectPassword =
    class
        inherit XdsOperation
    end

The XdsCheckObjectPassword type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsCheckObjectPassword Methods

XdsCheckObjectPassword Methods

The XdsCheckObjectPassword type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsCheckObjectPassword Class
DXMLBase.Xds Namespace


XdsCheckObjectPassword Properties

XdsCheckObjectPassword Properties

The XdsCheckObjectPassword type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsCheckObjectPassword Class
DXMLBase.Xds Namespace


XdsCheckObjectPassword.Password Property

XdsCheckObjectPasswordPassword Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsCheckObjectPassword.Password"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}
member Password : string with get

Property Value

Type: String
See Also

Reference

XdsCheckObjectPassword Class
DXMLBase.Xds Namespace


XdsComponent Class

XdsComponent Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsComponent"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueBase
DXMLBase.XdsXdsComponent

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsComponent : XdsValueBase
Public Class XdsComponent
    Inherits XdsValueBase
public ref class XdsComponent : public XdsValueBase
type XdsComponent =
    class
        inherit XdsValueBase
    end

The XdsComponent type exposes the following members.

Constructors
 | Name | Description
Public method | XdsComponent | Initializes a new instance of the XdsComponent class
Top
Methods
 | Name | Description
Public method | clearValue | (Inherited from XdsValueBase.)
Protected method | convertValueToBool | (Inherited from XdsValueBase.)
Protected method | convertValueToInt | (Inherited from XdsValueBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Protected method | stringToType | (Inherited from XdsValueBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssociationRef | (Inherited from XdsValueBase.)
Public property | CountValue | (Inherited from XdsValueBase.)
Public property | IntervalValue | (Inherited from XdsValueBase.)
Public property | IntValue | (Inherited from XdsValueBase.)
Public property | Name | (Inherited from XdsElement.)
Public property | OctetValue | (Inherited from XdsValueBase.)
Public property | ReferentialValue | (Inherited from XdsValueBase.)
Public property | StateValue | (Inherited from XdsValueBase.)
Public property | StringValue | (Inherited from XdsValueBase.)
Public property | Type | (Inherited from XdsValueBase.)
Public property | Value | (Inherited from XdsValueBase.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsComponent Constructor

XdsComponent Constructor
Initializes a new instance of the XdsComponent class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsComponent(
    XmlElement componentElement
)
Public Sub New (
    componentElement As XmlElement
)
public:
XdsComponent(
    XmlElement^ componentElement
)
new :
        componentElement : XmlElement -> XdsComponent

Parameters

componentElement
Type: System.XmlXmlElement

[Missing <param name="componentElement"/> documentation for "M:DXMLBase.Xds.XdsComponent.#ctor(System.Xml.XmlElement)"]

See Also

Reference

XdsComponent Class
DXMLBase.Xds Namespace


XdsComponent Methods

XdsComponent Methods

The XdsComponent type exposes the following members.

Methods
 | Name | Description
Public method | clearValue | (Inherited from XdsValueBase.)
Protected method | convertValueToBool | (Inherited from XdsValueBase.)
Protected method | convertValueToInt | (Inherited from XdsValueBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Protected method | stringToType | (Inherited from XdsValueBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsComponent Class
DXMLBase.Xds Namespace


XdsComponent Properties

XdsComponent Properties

The XdsComponent type exposes the following members.

Properties
 | Name | Description
Public property | AssociationRef | (Inherited from XdsValueBase.)
Public property | CountValue | (Inherited from XdsValueBase.)
Public property | IntervalValue | (Inherited from XdsValueBase.)
Public property | IntValue | (Inherited from XdsValueBase.)
Public property | Name | (Inherited from XdsElement.)
Public property | OctetValue | (Inherited from XdsValueBase.)
Public property | ReferentialValue | (Inherited from XdsValueBase.)
Public property | StateValue | (Inherited from XdsValueBase.)
Public property | StringValue | (Inherited from XdsValueBase.)
Public property | Type | (Inherited from XdsValueBase.)
Public property | Value | (Inherited from XdsValueBase.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsComponent Class
DXMLBase.Xds Namespace


XdsCustomOperation Class

XdsCustomOperation Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsCustomOperation"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsCustomOperation

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsCustomOperation : XdsOperation
Public Class XdsCustomOperation
    Inherits XdsOperation
public ref class XdsCustomOperation : public XdsOperation
type XdsCustomOperation =
    class
        inherit XdsOperation
    end

The XdsCustomOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsCustomOperation Methods

XdsCustomOperation Methods

The XdsCustomOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsCustomOperation Class
DXMLBase.Xds Namespace


XdsCustomOperation Properties

XdsCustomOperation Properties

The XdsCustomOperation type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsCustomOperation Class
DXMLBase.Xds Namespace


XdsDelete Class

XdsDelete Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsDelete"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsDelete

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsDelete : XdsOperation
Public Class XdsDelete
    Inherits XdsOperation
public ref class XdsDelete : public XdsOperation
type XdsDelete =
    class
        inherit XdsOperation
    end

The XdsDelete type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsDelete Methods

XdsDelete Methods

The XdsDelete type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsDelete Class
DXMLBase.Xds Namespace


XdsDelete Properties

XdsDelete Properties

The XdsDelete type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsDelete Class
DXMLBase.Xds Namespace


XdsDriverOptions Class

XdsDriverOptions Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsDriverOptions"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsShimOptions
DXMLBase.XdsXdsDriverOptions

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsDriverOptions : XdsShimOptions
Public Class XdsDriverOptions
    Inherits XdsShimOptions
public ref class XdsDriverOptions : public XdsShimOptions
type XdsDriverOptions =
    class
        inherit XdsShimOptions
    end

The XdsDriverOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams | (Inherited from XdsShimOptions.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsDriverOptions Methods

XdsDriverOptions Methods

The XdsDriverOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsDriverOptions Class
DXMLBase.Xds Namespace


XdsDriverOptions Properties

XdsDriverOptions Properties

The XdsDriverOptions type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams | (Inherited from XdsShimOptions.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsDriverOptions Class
DXMLBase.Xds Namespace


XdsDtd Class

XdsDtd Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsDtd"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsDtd

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsDtd
Public Class XdsDtd
public ref class XdsDtd
type XdsDtd =  class end

The XdsDtd type exposes the following members.

Constructors
 | Name | Description
Public method | XdsDtd(String, String, String, String) | Initializes a new instance of the XdsDtd class
Public method | XdsDtd(String, String, String, String, String) | Initializes a new instance of the XdsDtd class
Top
Methods
 | Name | Description
Public method | addDriverIdentification |
Public method | addStatus |
Public method | createInputDocument |
Public method | createOutputDocument |
Public method | createStatusDocument |
Public method | createSuccessDocument |
Public method | createXdsDocument |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
 | ATTR_APPLICATION_NAME |
 | ATTR_ASSOCIATION_REF |
 | ATTR_ATTR_NAME |
 | ATTR_BUILD |
 | ATTR_CASE_SENSITIVE |
 | ATTR_CLASS_NAME |
 | ATTR_DEST_DN |
 | ATTR_DEST_ENTRY_ID |
 | ATTR_DISPLAY_NAME |
 | ATTR_DTDVERSION |
 | ATTR_EVENT_ID |
 | ATTR_FROM_MERGE |
 | ATTR_FROM_RESET |
 | ATTR_HIERARCHICAL |
 | ATTR_INSTANCE |
 | ATTR_LEVEL |
 | ATTR_MULTI_VALUED |
 | ATTR_NAMING |
 | ATTR_OLD_SRC_DN |
 | ATTR_QUALIFIED_OLD_SRC_DN |
 | ATTR_QUALIFIED_SRC_DN |
 | ATTR_READ_ONLY |
 | ATTR_REMOVE_OLD_NAME |
 | ATTR_REQUIRED |
 | ATTR_SCOPE |
 | ATTR_SRC_DN |
 | ATTR_SRC_ENTRY_ID |
 | ATTR_TEMPLATE_DN |
 | ATTR_TYPE |
 | ATTR_VERSION |
Public field | buildDate |
Public field | contact |
Public field | DTD_VERSION_STRING |
Public field | instance |
Public field | productName |
 | TAG_ADD |
 | TAG_ADD_ASSOCIATION |
 | TAG_ADD_ATTR |
 | TAG_ADD_VALUE |
 | TAG_ASSOCIATION |
 | TAG_ATTR |
 | TAG_ATTR_DEF |
 | TAG_AUTHENTICATION_INFO |
 | TAG_CHECK_OBJECT_PASSWORD |
 | TAG_CHECK_PASSWORD |
 | TAG_CLASS_DEF |
 | TAG_COMPONENT |
 | TAG_CONTACT |
 | TAG_DELETE |
 | TAG_DRIVER_OPTIONS |
 | TAG_DRIVER_STATE |
 | TAG_GENERATED_PASSWORD |
 | TAG_GET_NAMED_PASSWORD |
 | TAG_INIT_PARAMS |
 | TAG_INPUT |
 | TAG_INSTANCE |
 | TAG_MODIFY |
 | TAG_MODIFY_ASSOCIATION |
 | TAG_MODIFY_ATTR |
 | TAG_MODIFY_PASSWORD |
 | TAG_MOVE |
 | TAG_NDS |
 | TAG_NEW_NAME |
 | TAG_OUTPUT |
 | TAG_PASSWORD |
 | TAG_PRODUCT |
 | TAG_PUBLISHER_OPTIONS |
 | TAG_PUBLISHER_STATE |
 | TAG_QUERY |
 | TAG_QUERY_EX |
 | TAG_QUERY_SCHEMA |
 | TAG_QUERY_TOKEN |
 | TAG_READ_ATTR |
 | TAG_READ_PARENT |
 | TAG_REMOVE_ALL_VALUES |
 | TAG_REMOVE_ASSOCIATION |
 | TAG_REMOVE_VALUE |
 | TAG_RENAME |
 | TAG_SCHEMA_DEF |
 | TAG_SEARCH_ATTR |
 | TAG_SEARCH_CLASS |
 | TAG_SERVER |
 | TAG_SOURCE |
 | TAG_STATUS |
 | TAG_SUBSCRIBER_OPTIONS |
 | TAG_SUBSCRIBER_STATE |
 | TAG_SYNC |
 | TAG_USER |
 | TAG_VALUE |
 | VAL_CLASSNAME |
 | VAL_COUNT |
 | VAL_DN |
 | VAL_DRIVER_ID |
 | VAL_DRIVER_IDENTIFICATION_CLASS |
 | VAL_DRIVER_VERSION |
 | VAL_ENTRY |
 | VAL_ERROR |
 | VAL_FALSE |
 | VAL_FATAL |
 | VAL_INT |
 | VAL_INTERVAL |
 | VAL_MIN_ACTIVATION_VERSION |
 | VAL_OCTET |
 | VAL_PASSWORD_REF |
 | VAL_QUERY_EX_SUPPORTED |
 | VAL_RETRY |
 | VAL_STATE |
 | VAL_STRING |
 | VAL_STRUCTURED |
 | VAL_SUBORDINATES |
 | VAL_SUBTREE |
 | VAL_SUCCESS |
 | VAL_TELENUMBER |
 | VAL_TRUE |
 | VAL_WARNING |
Public field | version |
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsDtd Constructor

XdsDtd Constructor
Overload List
 | Name | Description
Public method | XdsDtd(String, String, String, String) | Initializes a new instance of the XdsDtd class
Public method | XdsDtd(String, String, String, String, String) | Initializes a new instance of the XdsDtd class
Top
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd Constructor (String, String, String, String)

XdsDtd Constructor (String, String, String, String)
Initializes a new instance of the XdsDtd class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDtd(
    string productName,
    string instance,
    string version,
    string contact
)
Public Sub New (
    productName As String,
    instance As String,
    version As String,
    contact As String
)
public:
XdsDtd(
    String^ productName,
    String^ instance,
    String^ version,
    String^ contact
)
new :
        productName : string *
        instance : string *
        version : string *
        contact : string -> XdsDtd

Parameters

productName
Type: SystemString

[Missing <param name="productName"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String)"]

instance
Type: SystemString

[Missing <param name="instance"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String)"]

version
Type: SystemString

[Missing <param name="version"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String)"]

contact
Type: SystemString

[Missing <param name="contact"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String)"]

See Also

Reference

XdsDtd Class
XdsDtd Overload
DXMLBase.Xds Namespace


XdsDtd Constructor (String, String, String, String, String)

XdsDtd Constructor (String, String, String, String, String)
Initializes a new instance of the XdsDtd class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDtd(
    string productName,
    string instance,
    string version,
    string contact,
    string buildDate
)
Public Sub New (
    productName As String,
    instance As String,
    version As String,
    contact As String,
    buildDate As String
)
public:
XdsDtd(
    String^ productName,
    String^ instance,
    String^ version,
    String^ contact,
    String^ buildDate
)
new :
        productName : string *
        instance : string *
        version : string *
        contact : string *
        buildDate : string -> XdsDtd

Parameters

productName
Type: SystemString

[Missing <param name="productName"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String,System.String)"]

instance
Type: SystemString

[Missing <param name="instance"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String,System.String)"]

version
Type: SystemString

[Missing <param name="version"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String,System.String)"]

contact
Type: SystemString

[Missing <param name="contact"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String,System.String)"]

buildDate
Type: SystemString

[Missing <param name="buildDate"/> documentation for "M:DXMLBase.Xds.XdsDtd.#ctor(System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

XdsDtd Class
XdsDtd Overload
DXMLBase.Xds Namespace


XdsDtd Fields

XdsDtd Fields

The XdsDtd type exposes the following members.

Fields
 | Name | Description
 | ATTR_APPLICATION_NAME |
 | ATTR_ASSOCIATION_REF |
 | ATTR_ATTR_NAME |
 | ATTR_BUILD |
 | ATTR_CASE_SENSITIVE |
 | ATTR_CLASS_NAME |
 | ATTR_DEST_DN |
 | ATTR_DEST_ENTRY_ID |
 | ATTR_DISPLAY_NAME |
 | ATTR_DTDVERSION |
 | ATTR_EVENT_ID |
 | ATTR_FROM_MERGE |
 | ATTR_FROM_RESET |
 | ATTR_HIERARCHICAL |
 | ATTR_INSTANCE |
 | ATTR_LEVEL |
 | ATTR_MULTI_VALUED |
 | ATTR_NAMING |
 | ATTR_OLD_SRC_DN |
 | ATTR_QUALIFIED_OLD_SRC_DN |
 | ATTR_QUALIFIED_SRC_DN |
 | ATTR_READ_ONLY |
 | ATTR_REMOVE_OLD_NAME |
 | ATTR_REQUIRED |
 | ATTR_SCOPE |
 | ATTR_SRC_DN |
 | ATTR_SRC_ENTRY_ID |
 | ATTR_TEMPLATE_DN |
 | ATTR_TYPE |
 | ATTR_VERSION |
Public field | buildDate |
Public field | contact |
Public field | DTD_VERSION_STRING |
Public field | instance |
Public field | productName |
 | TAG_ADD |
 | TAG_ADD_ASSOCIATION |
 | TAG_ADD_ATTR |
 | TAG_ADD_VALUE |
 | TAG_ASSOCIATION |
 | TAG_ATTR |
 | TAG_ATTR_DEF |
 | TAG_AUTHENTICATION_INFO |
 | TAG_CHECK_OBJECT_PASSWORD |
 | TAG_CHECK_PASSWORD |
 | TAG_CLASS_DEF |
 | TAG_COMPONENT |
 | TAG_CONTACT |
 | TAG_DELETE |
 | TAG_DRIVER_OPTIONS |
 | TAG_DRIVER_STATE |
 | TAG_GENERATED_PASSWORD |
 | TAG_GET_NAMED_PASSWORD |
 | TAG_INIT_PARAMS |
 | TAG_INPUT |
 | TAG_INSTANCE |
 | TAG_MODIFY |
 | TAG_MODIFY_ASSOCIATION |
 | TAG_MODIFY_ATTR |
 | TAG_MODIFY_PASSWORD |
 | TAG_MOVE |
 | TAG_NDS |
 | TAG_NEW_NAME |
 | TAG_OUTPUT |
 | TAG_PASSWORD |
 | TAG_PRODUCT |
 | TAG_PUBLISHER_OPTIONS |
 | TAG_PUBLISHER_STATE |
 | TAG_QUERY |
 | TAG_QUERY_EX |
 | TAG_QUERY_SCHEMA |
 | TAG_QUERY_TOKEN |
 | TAG_READ_ATTR |
 | TAG_READ_PARENT |
 | TAG_REMOVE_ALL_VALUES |
 | TAG_REMOVE_ASSOCIATION |
 | TAG_REMOVE_VALUE |
 | TAG_RENAME |
 | TAG_SCHEMA_DEF |
 | TAG_SEARCH_ATTR |
 | TAG_SEARCH_CLASS |
 | TAG_SERVER |
 | TAG_SOURCE |
 | TAG_STATUS |
 | TAG_SUBSCRIBER_OPTIONS |
 | TAG_SUBSCRIBER_STATE |
 | TAG_SYNC |
 | TAG_USER |
 | TAG_VALUE |
 | VAL_CLASSNAME |
 | VAL_COUNT |
 | VAL_DN |
 | VAL_DRIVER_ID |
 | VAL_DRIVER_IDENTIFICATION_CLASS |
 | VAL_DRIVER_VERSION |
 | VAL_ENTRY |
 | VAL_ERROR |
 | VAL_FALSE |
 | VAL_FATAL |
 | VAL_INT |
 | VAL_INTERVAL |
 | VAL_MIN_ACTIVATION_VERSION |
 | VAL_OCTET |
 | VAL_PASSWORD_REF |
 | VAL_QUERY_EX_SUPPORTED |
 | VAL_RETRY |
 | VAL_STATE |
 | VAL_STRING |
 | VAL_STRUCTURED |
 | VAL_SUBORDINATES |
 | VAL_SUBTREE |
 | VAL_SUCCESS |
 | VAL_TELENUMBER |
 | VAL_TRUE |
 | VAL_WARNING |
Public field | version |
Top
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_APPLICATION_NAME Field

XdsDtdATTR_APPLICATION_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_APPLICATION_NAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_APPLICATION_NAME
Public Const ATTR_APPLICATION_NAME As String
public:
literal String^ ATTR_APPLICATION_NAME
static val mutable ATTR_APPLICATION_NAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_ASSOCIATION_REF Field

XdsDtdATTR_ASSOCIATION_REF Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_ASSOCIATION_REF"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_ASSOCIATION_REF
Public Const ATTR_ASSOCIATION_REF As String
public:
literal String^ ATTR_ASSOCIATION_REF
static val mutable ATTR_ASSOCIATION_REF: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_ATTR_NAME Field

XdsDtdATTR_ATTR_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_ATTR_NAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_ATTR_NAME
Public Const ATTR_ATTR_NAME As String
public:
literal String^ ATTR_ATTR_NAME
static val mutable ATTR_ATTR_NAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_BUILD Field

XdsDtdATTR_BUILD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_BUILD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_BUILD
Public Const ATTR_BUILD As String
public:
literal String^ ATTR_BUILD
static val mutable ATTR_BUILD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_CASE_SENSITIVE Field

XdsDtdATTR_CASE_SENSITIVE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_CASE_SENSITIVE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_CASE_SENSITIVE
Public Const ATTR_CASE_SENSITIVE As String
public:
literal String^ ATTR_CASE_SENSITIVE
static val mutable ATTR_CASE_SENSITIVE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_CLASS_NAME Field

XdsDtdATTR_CLASS_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_CLASS_NAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_CLASS_NAME
Public Const ATTR_CLASS_NAME As String
public:
literal String^ ATTR_CLASS_NAME
static val mutable ATTR_CLASS_NAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_DEST_DN Field

XdsDtdATTR_DEST_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_DEST_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DEST_DN
Public Const ATTR_DEST_DN As String
public:
literal String^ ATTR_DEST_DN
static val mutable ATTR_DEST_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_DEST_ENTRY_ID Field

XdsDtdATTR_DEST_ENTRY_ID Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_DEST_ENTRY_ID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DEST_ENTRY_ID
Public Const ATTR_DEST_ENTRY_ID As String
public:
literal String^ ATTR_DEST_ENTRY_ID
static val mutable ATTR_DEST_ENTRY_ID: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_DISPLAY_NAME Field

XdsDtdATTR_DISPLAY_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_DISPLAY_NAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DISPLAY_NAME
Public Const ATTR_DISPLAY_NAME As String
public:
literal String^ ATTR_DISPLAY_NAME
static val mutable ATTR_DISPLAY_NAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_DTDVERSION Field

XdsDtdATTR_DTDVERSION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_DTDVERSION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_DTDVERSION
Public Const ATTR_DTDVERSION As String
public:
literal String^ ATTR_DTDVERSION
static val mutable ATTR_DTDVERSION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_EVENT_ID Field

XdsDtdATTR_EVENT_ID Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_EVENT_ID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_EVENT_ID
Public Const ATTR_EVENT_ID As String
public:
literal String^ ATTR_EVENT_ID
static val mutable ATTR_EVENT_ID: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_FROM_MERGE Field

XdsDtdATTR_FROM_MERGE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_FROM_MERGE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_FROM_MERGE
Public Const ATTR_FROM_MERGE As String
public:
literal String^ ATTR_FROM_MERGE
static val mutable ATTR_FROM_MERGE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_FROM_RESET Field

XdsDtdATTR_FROM_RESET Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_FROM_RESET"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_FROM_RESET
Public Const ATTR_FROM_RESET As String
public:
literal String^ ATTR_FROM_RESET
static val mutable ATTR_FROM_RESET: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_HIERARCHICAL Field

XdsDtdATTR_HIERARCHICAL Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_HIERARCHICAL"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_HIERARCHICAL
Public Const ATTR_HIERARCHICAL As String
public:
literal String^ ATTR_HIERARCHICAL
static val mutable ATTR_HIERARCHICAL: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_INSTANCE Field

XdsDtdATTR_INSTANCE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_INSTANCE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_INSTANCE
Public Const ATTR_INSTANCE As String
public:
literal String^ ATTR_INSTANCE
static val mutable ATTR_INSTANCE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_LEVEL Field

XdsDtdATTR_LEVEL Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_LEVEL"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_LEVEL
Public Const ATTR_LEVEL As String
public:
literal String^ ATTR_LEVEL
static val mutable ATTR_LEVEL: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_MULTI_VALUED Field

XdsDtdATTR_MULTI_VALUED Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_MULTI_VALUED"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_MULTI_VALUED
Public Const ATTR_MULTI_VALUED As String
public:
literal String^ ATTR_MULTI_VALUED
static val mutable ATTR_MULTI_VALUED: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_NAMING Field

XdsDtdATTR_NAMING Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_NAMING"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_NAMING
Public Const ATTR_NAMING As String
public:
literal String^ ATTR_NAMING
static val mutable ATTR_NAMING: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_OLD_SRC_DN Field

XdsDtdATTR_OLD_SRC_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_OLD_SRC_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_OLD_SRC_DN
Public Const ATTR_OLD_SRC_DN As String
public:
literal String^ ATTR_OLD_SRC_DN
static val mutable ATTR_OLD_SRC_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_QUALIFIED_OLD_SRC_DN Field

XdsDtdATTR_QUALIFIED_OLD_SRC_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_QUALIFIED_OLD_SRC_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_QUALIFIED_OLD_SRC_DN
Public Const ATTR_QUALIFIED_OLD_SRC_DN As String
public:
literal String^ ATTR_QUALIFIED_OLD_SRC_DN
static val mutable ATTR_QUALIFIED_OLD_SRC_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_QUALIFIED_SRC_DN Field

XdsDtdATTR_QUALIFIED_SRC_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_QUALIFIED_SRC_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_QUALIFIED_SRC_DN
Public Const ATTR_QUALIFIED_SRC_DN As String
public:
literal String^ ATTR_QUALIFIED_SRC_DN
static val mutable ATTR_QUALIFIED_SRC_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_READ_ONLY Field

XdsDtdATTR_READ_ONLY Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_READ_ONLY"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_READ_ONLY
Public Const ATTR_READ_ONLY As String
public:
literal String^ ATTR_READ_ONLY
static val mutable ATTR_READ_ONLY: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_REMOVE_OLD_NAME Field

XdsDtdATTR_REMOVE_OLD_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_REMOVE_OLD_NAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_REMOVE_OLD_NAME
Public Const ATTR_REMOVE_OLD_NAME As String
public:
literal String^ ATTR_REMOVE_OLD_NAME
static val mutable ATTR_REMOVE_OLD_NAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_REQUIRED Field

XdsDtdATTR_REQUIRED Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_REQUIRED"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_REQUIRED
Public Const ATTR_REQUIRED As String
public:
literal String^ ATTR_REQUIRED
static val mutable ATTR_REQUIRED: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_SCOPE Field

XdsDtdATTR_SCOPE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_SCOPE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_SCOPE
Public Const ATTR_SCOPE As String
public:
literal String^ ATTR_SCOPE
static val mutable ATTR_SCOPE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_SRC_DN Field

XdsDtdATTR_SRC_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_SRC_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_SRC_DN
Public Const ATTR_SRC_DN As String
public:
literal String^ ATTR_SRC_DN
static val mutable ATTR_SRC_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_SRC_ENTRY_ID Field

XdsDtdATTR_SRC_ENTRY_ID Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_SRC_ENTRY_ID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_SRC_ENTRY_ID
Public Const ATTR_SRC_ENTRY_ID As String
public:
literal String^ ATTR_SRC_ENTRY_ID
static val mutable ATTR_SRC_ENTRY_ID: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_TEMPLATE_DN Field

XdsDtdATTR_TEMPLATE_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_TEMPLATE_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_TEMPLATE_DN
Public Const ATTR_TEMPLATE_DN As String
public:
literal String^ ATTR_TEMPLATE_DN
static val mutable ATTR_TEMPLATE_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_TYPE Field

XdsDtdATTR_TYPE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_TYPE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_TYPE
Public Const ATTR_TYPE As String
public:
literal String^ ATTR_TYPE
static val mutable ATTR_TYPE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.ATTR_VERSION Field

XdsDtdATTR_VERSION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.ATTR_VERSION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ATTR_VERSION
Public Const ATTR_VERSION As String
public:
literal String^ ATTR_VERSION
static val mutable ATTR_VERSION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.buildDate Field

XdsDtdbuildDate Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.buildDate"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string buildDate
Public buildDate As String
public:
String^ buildDate
val mutable buildDate: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.contact Field

XdsDtdcontact Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.contact"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string contact
Public contact As String
public:
String^ contact
val mutable contact: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.DTD_VERSION_STRING Field

XdsDtdDTD_VERSION_STRING Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.DTD_VERSION_STRING"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DTD_VERSION_STRING
Public DTD_VERSION_STRING As String
public:
String^ DTD_VERSION_STRING
val mutable DTD_VERSION_STRING: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.instance Field

XdsDtdinstance Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.instance"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string instance
Public instance As String
public:
String^ instance
val mutable instance: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.productName Field

XdsDtdproductName Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.productName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string productName
Public productName As String
public:
String^ productName
val mutable productName: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ADD Field

XdsDtdTAG_ADD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ADD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ADD
Public Const TAG_ADD As String
public:
literal String^ TAG_ADD
static val mutable TAG_ADD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ADD_ASSOCIATION Field

XdsDtdTAG_ADD_ASSOCIATION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ADD_ASSOCIATION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ADD_ASSOCIATION
Public Const TAG_ADD_ASSOCIATION As String
public:
literal String^ TAG_ADD_ASSOCIATION
static val mutable TAG_ADD_ASSOCIATION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ADD_ATTR Field

XdsDtdTAG_ADD_ATTR Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ADD_ATTR"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ADD_ATTR
Public Const TAG_ADD_ATTR As String
public:
literal String^ TAG_ADD_ATTR
static val mutable TAG_ADD_ATTR: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ADD_VALUE Field

XdsDtdTAG_ADD_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ADD_VALUE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ADD_VALUE
Public Const TAG_ADD_VALUE As String
public:
literal String^ TAG_ADD_VALUE
static val mutable TAG_ADD_VALUE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ASSOCIATION Field

XdsDtdTAG_ASSOCIATION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ASSOCIATION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ASSOCIATION
Public Const TAG_ASSOCIATION As String
public:
literal String^ TAG_ASSOCIATION
static val mutable TAG_ASSOCIATION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ATTR Field

XdsDtdTAG_ATTR Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ATTR"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ATTR
Public Const TAG_ATTR As String
public:
literal String^ TAG_ATTR
static val mutable TAG_ATTR: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_ATTR_DEF Field

XdsDtdTAG_ATTR_DEF Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_ATTR_DEF"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_ATTR_DEF
Public Const TAG_ATTR_DEF As String
public:
literal String^ TAG_ATTR_DEF
static val mutable TAG_ATTR_DEF: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_AUTHENTICATION_INFO Field

XdsDtdTAG_AUTHENTICATION_INFO Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_AUTHENTICATION_INFO"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_AUTHENTICATION_INFO
Public Const TAG_AUTHENTICATION_INFO As String
public:
literal String^ TAG_AUTHENTICATION_INFO
static val mutable TAG_AUTHENTICATION_INFO: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_CHECK_OBJECT_PASSWORD Field

XdsDtdTAG_CHECK_OBJECT_PASSWORD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_CHECK_OBJECT_PASSWORD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_CHECK_OBJECT_PASSWORD
Public Const TAG_CHECK_OBJECT_PASSWORD As String
public:
literal String^ TAG_CHECK_OBJECT_PASSWORD
static val mutable TAG_CHECK_OBJECT_PASSWORD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_CHECK_PASSWORD Field

XdsDtdTAG_CHECK_PASSWORD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_CHECK_PASSWORD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_CHECK_PASSWORD
Public Const TAG_CHECK_PASSWORD As String
public:
literal String^ TAG_CHECK_PASSWORD
static val mutable TAG_CHECK_PASSWORD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_CLASS_DEF Field

XdsDtdTAG_CLASS_DEF Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_CLASS_DEF"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_CLASS_DEF
Public Const TAG_CLASS_DEF As String
public:
literal String^ TAG_CLASS_DEF
static val mutable TAG_CLASS_DEF: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_COMPONENT Field

XdsDtdTAG_COMPONENT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_COMPONENT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_COMPONENT
Public Const TAG_COMPONENT As String
public:
literal String^ TAG_COMPONENT
static val mutable TAG_COMPONENT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_CONTACT Field

XdsDtdTAG_CONTACT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_CONTACT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_CONTACT
Public Const TAG_CONTACT As String
public:
literal String^ TAG_CONTACT
static val mutable TAG_CONTACT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_DELETE Field

XdsDtdTAG_DELETE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_DELETE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_DELETE
Public Const TAG_DELETE As String
public:
literal String^ TAG_DELETE
static val mutable TAG_DELETE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_DRIVER_OPTIONS Field

XdsDtdTAG_DRIVER_OPTIONS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_DRIVER_OPTIONS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_DRIVER_OPTIONS
Public Const TAG_DRIVER_OPTIONS As String
public:
literal String^ TAG_DRIVER_OPTIONS
static val mutable TAG_DRIVER_OPTIONS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_DRIVER_STATE Field

XdsDtdTAG_DRIVER_STATE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_DRIVER_STATE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_DRIVER_STATE
Public Const TAG_DRIVER_STATE As String
public:
literal String^ TAG_DRIVER_STATE
static val mutable TAG_DRIVER_STATE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_GENERATED_PASSWORD Field

XdsDtdTAG_GENERATED_PASSWORD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_GENERATED_PASSWORD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_GENERATED_PASSWORD
Public Const TAG_GENERATED_PASSWORD As String
public:
literal String^ TAG_GENERATED_PASSWORD
static val mutable TAG_GENERATED_PASSWORD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_GET_NAMED_PASSWORD Field

XdsDtdTAG_GET_NAMED_PASSWORD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_GET_NAMED_PASSWORD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_GET_NAMED_PASSWORD
Public Const TAG_GET_NAMED_PASSWORD As String
public:
literal String^ TAG_GET_NAMED_PASSWORD
static val mutable TAG_GET_NAMED_PASSWORD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_INIT_PARAMS Field

XdsDtdTAG_INIT_PARAMS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_INIT_PARAMS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_INIT_PARAMS
Public Const TAG_INIT_PARAMS As String
public:
literal String^ TAG_INIT_PARAMS
static val mutable TAG_INIT_PARAMS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_INPUT Field

XdsDtdTAG_INPUT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_INPUT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_INPUT
Public Const TAG_INPUT As String
public:
literal String^ TAG_INPUT
static val mutable TAG_INPUT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_INSTANCE Field

XdsDtdTAG_INSTANCE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_INSTANCE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_INSTANCE
Public Const TAG_INSTANCE As String
public:
literal String^ TAG_INSTANCE
static val mutable TAG_INSTANCE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_MODIFY Field

XdsDtdTAG_MODIFY Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_MODIFY"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_MODIFY
Public Const TAG_MODIFY As String
public:
literal String^ TAG_MODIFY
static val mutable TAG_MODIFY: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_MODIFY_ASSOCIATION Field

XdsDtdTAG_MODIFY_ASSOCIATION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_MODIFY_ASSOCIATION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_MODIFY_ASSOCIATION
Public Const TAG_MODIFY_ASSOCIATION As String
public:
literal String^ TAG_MODIFY_ASSOCIATION
static val mutable TAG_MODIFY_ASSOCIATION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_MODIFY_ATTR Field

XdsDtdTAG_MODIFY_ATTR Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_MODIFY_ATTR"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_MODIFY_ATTR
Public Const TAG_MODIFY_ATTR As String
public:
literal String^ TAG_MODIFY_ATTR
static val mutable TAG_MODIFY_ATTR: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_MODIFY_PASSWORD Field

XdsDtdTAG_MODIFY_PASSWORD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_MODIFY_PASSWORD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_MODIFY_PASSWORD
Public Const TAG_MODIFY_PASSWORD As String
public:
literal String^ TAG_MODIFY_PASSWORD
static val mutable TAG_MODIFY_PASSWORD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_MOVE Field

XdsDtdTAG_MOVE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_MOVE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_MOVE
Public Const TAG_MOVE As String
public:
literal String^ TAG_MOVE
static val mutable TAG_MOVE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_NDS Field

XdsDtdTAG_NDS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_NDS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_NDS
Public Const TAG_NDS As String
public:
literal String^ TAG_NDS
static val mutable TAG_NDS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_NEW_NAME Field

XdsDtdTAG_NEW_NAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_NEW_NAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_NEW_NAME
Public Const TAG_NEW_NAME As String
public:
literal String^ TAG_NEW_NAME
static val mutable TAG_NEW_NAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_OUTPUT Field

XdsDtdTAG_OUTPUT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_OUTPUT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_OUTPUT
Public Const TAG_OUTPUT As String
public:
literal String^ TAG_OUTPUT
static val mutable TAG_OUTPUT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_PASSWORD Field

XdsDtdTAG_PASSWORD Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_PASSWORD"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_PASSWORD
Public Const TAG_PASSWORD As String
public:
literal String^ TAG_PASSWORD
static val mutable TAG_PASSWORD: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_PRODUCT Field

XdsDtdTAG_PRODUCT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_PRODUCT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_PRODUCT
Public Const TAG_PRODUCT As String
public:
literal String^ TAG_PRODUCT
static val mutable TAG_PRODUCT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_PUBLISHER_OPTIONS Field

XdsDtdTAG_PUBLISHER_OPTIONS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_PUBLISHER_OPTIONS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_PUBLISHER_OPTIONS
Public Const TAG_PUBLISHER_OPTIONS As String
public:
literal String^ TAG_PUBLISHER_OPTIONS
static val mutable TAG_PUBLISHER_OPTIONS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_PUBLISHER_STATE Field

XdsDtdTAG_PUBLISHER_STATE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_PUBLISHER_STATE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_PUBLISHER_STATE
Public Const TAG_PUBLISHER_STATE As String
public:
literal String^ TAG_PUBLISHER_STATE
static val mutable TAG_PUBLISHER_STATE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_QUERY Field

XdsDtdTAG_QUERY Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_QUERY"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_QUERY
Public Const TAG_QUERY As String
public:
literal String^ TAG_QUERY
static val mutable TAG_QUERY: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_QUERY_EX Field

XdsDtdTAG_QUERY_EX Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_QUERY_EX"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_QUERY_EX
Public Const TAG_QUERY_EX As String
public:
literal String^ TAG_QUERY_EX
static val mutable TAG_QUERY_EX: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_QUERY_SCHEMA Field

XdsDtdTAG_QUERY_SCHEMA Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_QUERY_SCHEMA"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_QUERY_SCHEMA
Public Const TAG_QUERY_SCHEMA As String
public:
literal String^ TAG_QUERY_SCHEMA
static val mutable TAG_QUERY_SCHEMA: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_QUERY_TOKEN Field

XdsDtdTAG_QUERY_TOKEN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_QUERY_TOKEN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_QUERY_TOKEN
Public Const TAG_QUERY_TOKEN As String
public:
literal String^ TAG_QUERY_TOKEN
static val mutable TAG_QUERY_TOKEN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_READ_ATTR Field

XdsDtdTAG_READ_ATTR Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_READ_ATTR"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_READ_ATTR
Public Const TAG_READ_ATTR As String
public:
literal String^ TAG_READ_ATTR
static val mutable TAG_READ_ATTR: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_READ_PARENT Field

XdsDtdTAG_READ_PARENT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_READ_PARENT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_READ_PARENT
Public Const TAG_READ_PARENT As String
public:
literal String^ TAG_READ_PARENT
static val mutable TAG_READ_PARENT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_REMOVE_ALL_VALUES Field

XdsDtdTAG_REMOVE_ALL_VALUES Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_REMOVE_ALL_VALUES"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_REMOVE_ALL_VALUES
Public Const TAG_REMOVE_ALL_VALUES As String
public:
literal String^ TAG_REMOVE_ALL_VALUES
static val mutable TAG_REMOVE_ALL_VALUES: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_REMOVE_ASSOCIATION Field

XdsDtdTAG_REMOVE_ASSOCIATION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_REMOVE_ASSOCIATION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_REMOVE_ASSOCIATION
Public Const TAG_REMOVE_ASSOCIATION As String
public:
literal String^ TAG_REMOVE_ASSOCIATION
static val mutable TAG_REMOVE_ASSOCIATION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_REMOVE_VALUE Field

XdsDtdTAG_REMOVE_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_REMOVE_VALUE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_REMOVE_VALUE
Public Const TAG_REMOVE_VALUE As String
public:
literal String^ TAG_REMOVE_VALUE
static val mutable TAG_REMOVE_VALUE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_RENAME Field

XdsDtdTAG_RENAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_RENAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_RENAME
Public Const TAG_RENAME As String
public:
literal String^ TAG_RENAME
static val mutable TAG_RENAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SCHEMA_DEF Field

XdsDtdTAG_SCHEMA_DEF Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SCHEMA_DEF"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SCHEMA_DEF
Public Const TAG_SCHEMA_DEF As String
public:
literal String^ TAG_SCHEMA_DEF
static val mutable TAG_SCHEMA_DEF: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SEARCH_ATTR Field

XdsDtdTAG_SEARCH_ATTR Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SEARCH_ATTR"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SEARCH_ATTR
Public Const TAG_SEARCH_ATTR As String
public:
literal String^ TAG_SEARCH_ATTR
static val mutable TAG_SEARCH_ATTR: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SEARCH_CLASS Field

XdsDtdTAG_SEARCH_CLASS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SEARCH_CLASS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SEARCH_CLASS
Public Const TAG_SEARCH_CLASS As String
public:
literal String^ TAG_SEARCH_CLASS
static val mutable TAG_SEARCH_CLASS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SERVER Field

XdsDtdTAG_SERVER Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SERVER"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SERVER
Public Const TAG_SERVER As String
public:
literal String^ TAG_SERVER
static val mutable TAG_SERVER: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SOURCE Field

XdsDtdTAG_SOURCE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SOURCE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SOURCE
Public Const TAG_SOURCE As String
public:
literal String^ TAG_SOURCE
static val mutable TAG_SOURCE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_STATUS Field

XdsDtdTAG_STATUS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_STATUS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_STATUS
Public Const TAG_STATUS As String
public:
literal String^ TAG_STATUS
static val mutable TAG_STATUS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SUBSCRIBER_OPTIONS Field

XdsDtdTAG_SUBSCRIBER_OPTIONS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SUBSCRIBER_OPTIONS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SUBSCRIBER_OPTIONS
Public Const TAG_SUBSCRIBER_OPTIONS As String
public:
literal String^ TAG_SUBSCRIBER_OPTIONS
static val mutable TAG_SUBSCRIBER_OPTIONS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SUBSCRIBER_STATE Field

XdsDtdTAG_SUBSCRIBER_STATE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SUBSCRIBER_STATE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SUBSCRIBER_STATE
Public Const TAG_SUBSCRIBER_STATE As String
public:
literal String^ TAG_SUBSCRIBER_STATE
static val mutable TAG_SUBSCRIBER_STATE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_SYNC Field

XdsDtdTAG_SYNC Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_SYNC"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_SYNC
Public Const TAG_SYNC As String
public:
literal String^ TAG_SYNC
static val mutable TAG_SYNC: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_USER Field

XdsDtdTAG_USER Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_USER"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_USER
Public Const TAG_USER As String
public:
literal String^ TAG_USER
static val mutable TAG_USER: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.TAG_VALUE Field

XdsDtdTAG_VALUE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.TAG_VALUE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_VALUE
Public Const TAG_VALUE As String
public:
literal String^ TAG_VALUE
static val mutable TAG_VALUE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_CLASSNAME Field

XdsDtdVAL_CLASSNAME Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_CLASSNAME"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_CLASSNAME
Public Const VAL_CLASSNAME As String
public:
literal String^ VAL_CLASSNAME
static val mutable VAL_CLASSNAME: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_COUNT Field

XdsDtdVAL_COUNT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_COUNT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_COUNT
Public Const VAL_COUNT As String
public:
literal String^ VAL_COUNT
static val mutable VAL_COUNT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_DN Field

XdsDtdVAL_DN Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_DN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DN
Public Const VAL_DN As String
public:
literal String^ VAL_DN
static val mutable VAL_DN: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_DRIVER_ID Field

XdsDtdVAL_DRIVER_ID Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_DRIVER_ID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DRIVER_ID
Public Const VAL_DRIVER_ID As String
public:
literal String^ VAL_DRIVER_ID
static val mutable VAL_DRIVER_ID: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_DRIVER_IDENTIFICATION_CLASS Field

XdsDtdVAL_DRIVER_IDENTIFICATION_CLASS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_DRIVER_IDENTIFICATION_CLASS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DRIVER_IDENTIFICATION_CLASS
Public Const VAL_DRIVER_IDENTIFICATION_CLASS As String
public:
literal String^ VAL_DRIVER_IDENTIFICATION_CLASS
static val mutable VAL_DRIVER_IDENTIFICATION_CLASS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_DRIVER_VERSION Field

XdsDtdVAL_DRIVER_VERSION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_DRIVER_VERSION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_DRIVER_VERSION
Public Const VAL_DRIVER_VERSION As String
public:
literal String^ VAL_DRIVER_VERSION
static val mutable VAL_DRIVER_VERSION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_ENTRY Field

XdsDtdVAL_ENTRY Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_ENTRY"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_ENTRY
Public Const VAL_ENTRY As String
public:
literal String^ VAL_ENTRY
static val mutable VAL_ENTRY: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_ERROR Field

XdsDtdVAL_ERROR Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_ERROR"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_ERROR
Public Const VAL_ERROR As String
public:
literal String^ VAL_ERROR
static val mutable VAL_ERROR: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_FALSE Field

XdsDtdVAL_FALSE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_FALSE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_FALSE
Public Const VAL_FALSE As String
public:
literal String^ VAL_FALSE
static val mutable VAL_FALSE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_FATAL Field

XdsDtdVAL_FATAL Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_FATAL"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_FATAL
Public Const VAL_FATAL As String
public:
literal String^ VAL_FATAL
static val mutable VAL_FATAL: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_INT Field

XdsDtdVAL_INT Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_INT"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_INT
Public Const VAL_INT As String
public:
literal String^ VAL_INT
static val mutable VAL_INT: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_INTERVAL Field

XdsDtdVAL_INTERVAL Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_INTERVAL"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_INTERVAL
Public Const VAL_INTERVAL As String
public:
literal String^ VAL_INTERVAL
static val mutable VAL_INTERVAL: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_MIN_ACTIVATION_VERSION Field

XdsDtdVAL_MIN_ACTIVATION_VERSION Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_MIN_ACTIVATION_VERSION"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_MIN_ACTIVATION_VERSION
Public Const VAL_MIN_ACTIVATION_VERSION As String
public:
literal String^ VAL_MIN_ACTIVATION_VERSION
static val mutable VAL_MIN_ACTIVATION_VERSION: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_OCTET Field

XdsDtdVAL_OCTET Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_OCTET"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_OCTET
Public Const VAL_OCTET As String
public:
literal String^ VAL_OCTET
static val mutable VAL_OCTET: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_PASSWORD_REF Field

XdsDtdVAL_PASSWORD_REF Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_PASSWORD_REF"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_PASSWORD_REF
Public Const VAL_PASSWORD_REF As String
public:
literal String^ VAL_PASSWORD_REF
static val mutable VAL_PASSWORD_REF: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_QUERY_EX_SUPPORTED Field

XdsDtdVAL_QUERY_EX_SUPPORTED Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_QUERY_EX_SUPPORTED"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_QUERY_EX_SUPPORTED
Public Const VAL_QUERY_EX_SUPPORTED As String
public:
literal String^ VAL_QUERY_EX_SUPPORTED
static val mutable VAL_QUERY_EX_SUPPORTED: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_RETRY Field

XdsDtdVAL_RETRY Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_RETRY"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_RETRY
Public Const VAL_RETRY As String
public:
literal String^ VAL_RETRY
static val mutable VAL_RETRY: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_STATE Field

XdsDtdVAL_STATE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_STATE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_STATE
Public Const VAL_STATE As String
public:
literal String^ VAL_STATE
static val mutable VAL_STATE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_STRING Field

XdsDtdVAL_STRING Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_STRING"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_STRING
Public Const VAL_STRING As String
public:
literal String^ VAL_STRING
static val mutable VAL_STRING: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_STRUCTURED Field

XdsDtdVAL_STRUCTURED Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_STRUCTURED"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_STRUCTURED
Public Const VAL_STRUCTURED As String
public:
literal String^ VAL_STRUCTURED
static val mutable VAL_STRUCTURED: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_SUBORDINATES Field

XdsDtdVAL_SUBORDINATES Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_SUBORDINATES"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_SUBORDINATES
Public Const VAL_SUBORDINATES As String
public:
literal String^ VAL_SUBORDINATES
static val mutable VAL_SUBORDINATES: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_SUBTREE Field

XdsDtdVAL_SUBTREE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_SUBTREE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_SUBTREE
Public Const VAL_SUBTREE As String
public:
literal String^ VAL_SUBTREE
static val mutable VAL_SUBTREE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_SUCCESS Field

XdsDtdVAL_SUCCESS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_SUCCESS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_SUCCESS
Public Const VAL_SUCCESS As String
public:
literal String^ VAL_SUCCESS
static val mutable VAL_SUCCESS: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_TELENUMBER Field

XdsDtdVAL_TELENUMBER Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_TELENUMBER"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_TELENUMBER
Public Const VAL_TELENUMBER As String
public:
literal String^ VAL_TELENUMBER
static val mutable VAL_TELENUMBER: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_TRUE Field

XdsDtdVAL_TRUE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_TRUE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_TRUE
Public Const VAL_TRUE As String
public:
literal String^ VAL_TRUE
static val mutable VAL_TRUE: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.VAL_WARNING Field

XdsDtdVAL_WARNING Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.VAL_WARNING"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VAL_WARNING
Public Const VAL_WARNING As String
public:
literal String^ VAL_WARNING
static val mutable VAL_WARNING: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.version Field

XdsDtdversion Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.version"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string version
Public version As String
public:
String^ version
val mutable version: string

Field Value

Type: String
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd Methods

XdsDtd Methods

The XdsDtd type exposes the following members.

Methods
 | Name | Description
Public method | addDriverIdentification |
Public method | addStatus |
Public method | createInputDocument |
Public method | createOutputDocument |
Public method | createStatusDocument |
Public method | createSuccessDocument |
Public method | createXdsDocument |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.addDriverIdentification Method

XdsDtdaddDriverIdentification Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.addDriverIdentification(System.Xml.XmlElement,System.String,System.String,System.String,System.Collections.Generic.List{DXMLBase.Xds.XdsDtd.SupportedFeature})"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void addDriverIdentification(
    XmlElement output,
    string driverID,
    string driverVersion,
    string driverMinActivationLevel,
    List<XdsDtdSupportedFeature> features
)
Public Sub addDriverIdentification (
    output As XmlElement,
    driverID As String,
    driverVersion As String,
    driverMinActivationLevel As String,
    features As List(Of XdsDtdSupportedFeature)
)
public:
void addDriverIdentification(
    XmlElement^ output,
    String^ driverID,
    String^ driverVersion,
    String^ driverMinActivationLevel,
    List<XdsDtdSupportedFeature>^ features
)
member addDriverIdentification :
        output : XmlElement *
        driverID : string *
        driverVersion : string *
        driverMinActivationLevel : string *
        features : List<XdsDtdSupportedFeature> -> unit

Parameters

output
Type: System.XmlXmlElement

[Missing <param name="output"/> documentation for "M:DXMLBase.Xds.XdsDtd.addDriverIdentification(System.Xml.XmlElement,System.String,System.String,System.String,System.Collections.Generic.List{DXMLBase.Xds.XdsDtd.SupportedFeature})"]

driverID
Type: SystemString

[Missing <param name="driverID"/> documentation for "M:DXMLBase.Xds.XdsDtd.addDriverIdentification(System.Xml.XmlElement,System.String,System.String,System.String,System.Collections.Generic.List{DXMLBase.Xds.XdsDtd.SupportedFeature})"]

driverVersion
Type: SystemString

[Missing <param name="driverVersion"/> documentation for "M:DXMLBase.Xds.XdsDtd.addDriverIdentification(System.Xml.XmlElement,System.String,System.String,System.String,System.Collections.Generic.List{DXMLBase.Xds.XdsDtd.SupportedFeature})"]

driverMinActivationLevel
Type: SystemString

[Missing <param name="driverMinActivationLevel"/> documentation for "M:DXMLBase.Xds.XdsDtd.addDriverIdentification(System.Xml.XmlElement,System.String,System.String,System.String,System.Collections.Generic.List{DXMLBase.Xds.XdsDtd.SupportedFeature})"]

features
Type: System.Collections.GenericList XdsDtdSupportedFeature
feature support to report to engine
See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.addStatus Method

XdsDtdaddStatus Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.addStatus(System.Xml.XmlElement,DXMLBase.Xds.XdsStatusReport)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement addStatus(
    XmlElement parent,
    XdsStatusReport xdsStatus
)
Public Overridable Function addStatus (
    parent As XmlElement,
    xdsStatus As XdsStatusReport
) As XmlElement
public:
virtual XmlElement^ addStatus(
    XmlElement^ parent,
    XdsStatusReport^ xdsStatus
)
abstract addStatus :
        parent : XmlElement *
        xdsStatus : XdsStatusReport -> XmlElement
override addStatus :
        parent : XmlElement *
        xdsStatus : XdsStatusReport -> XmlElement

Parameters

parent
Type: System.XmlXmlElement

[Missing <param name="parent"/> documentation for "M:DXMLBase.Xds.XdsDtd.addStatus(System.Xml.XmlElement,DXMLBase.Xds.XdsStatusReport)"]

xdsStatus
Type: DXMLBase.XdsXdsStatusReport

[Missing <param name="xdsStatus"/> documentation for "M:DXMLBase.Xds.XdsDtd.addStatus(System.Xml.XmlElement,DXMLBase.Xds.XdsStatusReport)"]

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsDtd.addStatus(System.Xml.XmlElement,DXMLBase.Xds.XdsStatusReport)"]

See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.createInputDocument Method

XdsDtdcreateInputDocument Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.createInputDocument"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement createInputDocument()
Public Overridable Function createInputDocument As XmlElement
public:
virtual XmlElement^ createInputDocument()
abstract createInputDocument : unit -> XmlElement
override createInputDocument : unit -> XmlElement

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsDtd.createInputDocument"]

See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.createOutputDocument Method

XdsDtdcreateOutputDocument Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.createOutputDocument"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement createOutputDocument()
Public Overridable Function createOutputDocument As XmlElement
public:
virtual XmlElement^ createOutputDocument()
abstract createOutputDocument : unit -> XmlElement
override createOutputDocument : unit -> XmlElement

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsDtd.createOutputDocument"]

See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.createStatusDocument Method

XdsDtdcreateStatusDocument Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.createStatusDocument(DXMLBase.Xds.XdsStatusReport)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlDocument createStatusDocument(
    XdsStatusReport xdsStatus
)
Public Overridable Function createStatusDocument (
    xdsStatus As XdsStatusReport
) As XmlDocument
public:
virtual XmlDocument^ createStatusDocument(
    XdsStatusReport^ xdsStatus
)
abstract createStatusDocument :
        xdsStatus : XdsStatusReport -> XmlDocument
override createStatusDocument :
        xdsStatus : XdsStatusReport -> XmlDocument

Parameters

xdsStatus
Type: DXMLBase.XdsXdsStatusReport

[Missing <param name="xdsStatus"/> documentation for "M:DXMLBase.Xds.XdsDtd.createStatusDocument(DXMLBase.Xds.XdsStatusReport)"]

Return Value

Type: XmlDocument

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsDtd.createStatusDocument(DXMLBase.Xds.XdsStatusReport)"]

See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.createSuccessDocument Method

XdsDtdcreateSuccessDocument Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.createSuccessDocument"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlDocument createSuccessDocument()
Public Overridable Function createSuccessDocument As XmlDocument
public:
virtual XmlDocument^ createSuccessDocument()
abstract createSuccessDocument : unit -> XmlDocument
override createSuccessDocument : unit -> XmlDocument

Return Value

Type: XmlDocument

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsDtd.createSuccessDocument"]

See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.createXdsDocument Method

XdsDtdcreateXdsDocument Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsDtd.createXdsDocument"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement createXdsDocument()
Public Overridable Function createXdsDocument As XmlElement
public:
virtual XmlElement^ createXdsDocument()
abstract createXdsDocument : unit -> XmlElement
override createXdsDocument : unit -> XmlElement

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsDtd.createXdsDocument"]

See Also

Reference

XdsDtd Class
DXMLBase.Xds Namespace


XdsDtd.SupportedFeature Structure

XdsDtdSupportedFeature Structure

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsDtd.SupportedFeature"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct SupportedFeature
Public Structure SupportedFeature
public value class SupportedFeature
[<SealedAttribute>]
type SupportedFeature =  struct end

The XdsDtdSupportedFeature type exposes the following members.

Constructors
 | Name | Description
Public method | XdsDtdSupportedFeature | Initializes a new instance of the XdsDtdSupportedFeature class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | featureName |
Public field | supported |
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsDtd.SupportedFeature Constructor

XdsDtdSupportedFeature Constructor
Initializes a new instance of the XdsDtdSupportedFeature class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SupportedFeature(
    string featureName,
    bool supported
)
Public Sub New (
    featureName As String,
    supported As Boolean
)
public:
SupportedFeature(
    String^ featureName,
    bool supported
)
new :
        featureName : string *
        supported : bool -> SupportedFeature

Parameters

featureName
Type: SystemString

[Missing <param name="featureName"/> documentation for "M:DXMLBase.Xds.XdsDtd.SupportedFeature.#ctor(System.String,System.Boolean)"]

supported
Type: SystemBoolean

[Missing <param name="supported"/> documentation for "M:DXMLBase.Xds.XdsDtd.SupportedFeature.#ctor(System.String,System.Boolean)"]

See Also

Reference

XdsDtdSupportedFeature Structure
DXMLBase.Xds Namespace


SupportedFeature Fields

SupportedFeature Fields

The XdsDtdSupportedFeature type exposes the following members.

Fields
 | Name | Description
Public field | featureName |
Public field | supported |
Top
See Also

Reference

XdsDtdSupportedFeature Structure
DXMLBase.Xds Namespace


XdsDtd.SupportedFeature.featureName Field

XdsDtdSupportedFeaturefeatureName Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.SupportedFeature.featureName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string featureName
Public featureName As String
public:
String^ featureName
val mutable featureName: string

Field Value

Type: String
See Also

Reference

XdsDtdSupportedFeature Structure
DXMLBase.Xds Namespace


XdsDtd.SupportedFeature.supported Field

XdsDtdSupportedFeaturesupported Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsDtd.SupportedFeature.supported"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool supported
Public supported As Boolean
public:
bool supported
val mutable supported: bool

Field Value

Type: Boolean
See Also

Reference

XdsDtdSupportedFeature Structure
DXMLBase.Xds Namespace


SupportedFeature Methods

SupportedFeature Methods

The XdsDtdSupportedFeature type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

XdsDtdSupportedFeature Structure
DXMLBase.Xds Namespace


XdsElement Class

XdsElement Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsElement"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
More...

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsElement
Public Class XdsElement
public ref class XdsElement
type XdsElement =  class end

The XdsElement type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsElement | Initializes a new instance of the XdsElement class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr |
Protected method | getBoolAttr |
Protected method | getChildContent |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr |
Protected method | setBoolAttr |
Protected method | setChildContent |
Protected method | setXmlElement |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | XmlElement |
Top
See Also

Reference

DXMLBase.Xds Namespace
Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsAuthenticationInfo
DXMLBase.XdsXdsInitParams
DXMLBase.XdsXdsModifyAttr
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsOpParent
DXMLBase.XdsXdsPassword
DXMLBase.XdsXdsRemoveAllValues
DXMLBase.XdsXdsSearchClass
DXMLBase.XdsXdsShimOptions
DXMLBase.XdsXdsStatus
DXMLBase.XdsXdsValueBase
DXMLBase.XdsXdsValueParent


XdsElement Constructor

XdsElement Constructor
Initializes a new instance of the XdsElement class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsElement(
    XmlElement xdsElement
)
Protected Sub New (
    xdsElement As XmlElement
)
protected:
XdsElement(
    XmlElement^ xdsElement
)
new :
        xdsElement : XmlElement -> XdsElement

Parameters

xdsElement
Type: System.XmlXmlElement
The base element
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement Methods

XdsElement Methods

The XdsElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr |
Protected method | getBoolAttr |
Protected method | getChildContent |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr |
Protected method | setBoolAttr |
Protected method | setChildContent |
Protected method | setXmlElement |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.getAttr Method

XdsElementgetAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.getAttr(System.String,System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected string getAttr(
    string attrName,
    string defaultValue
)
Protected Function getAttr (
    attrName As String,
    defaultValue As String
) As String
protected:
String^ getAttr(
    String^ attrName,
    String^ defaultValue
)
member getAttr :
        attrName : string *
        defaultValue : string -> string

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsElement.getAttr(System.String,System.String)"]

defaultValue
Type: SystemString

[Missing <param name="defaultValue"/> documentation for "M:DXMLBase.Xds.XdsElement.getAttr(System.String,System.String)"]

Return Value

Type: String
The attribute value if it exists on the operation element, otherwise the default value.
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.getBoolAttr Method

XdsElementgetBoolAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.getBoolAttr(System.String,System.Boolean)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool getBoolAttr(
    string attrName,
    bool defaultValue
)
Protected Function getBoolAttr (
    attrName As String,
    defaultValue As Boolean
) As Boolean
protected:
bool getBoolAttr(
    String^ attrName,
    bool defaultValue
)
member getBoolAttr :
        attrName : string *
        defaultValue : bool -> bool

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsElement.getBoolAttr(System.String,System.Boolean)"]

defaultValue
Type: SystemBoolean

[Missing <param name="defaultValue"/> documentation for "M:DXMLBase.Xds.XdsElement.getBoolAttr(System.String,System.Boolean)"]

Return Value

Type: Boolean
The attribute value if it exists on the element, otherwise the default value.
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.getChildContent Method

XdsElementgetChildContent Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.getChildContent(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected string getChildContent(
    string childTagName
)
Protected Function getChildContent (
    childTagName As String
) As String
protected:
String^ getChildContent(
    String^ childTagName
)
member getChildContent :
        childTagName : string -> string

Parameters

childTagName
Type: SystemString

[Missing <param name="childTagName"/> documentation for "M:DXMLBase.Xds.XdsElement.getChildContent(System.String)"]

Return Value

Type: String
The content, or String.Empty if no such child element.
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.setAttr Method

XdsElementsetAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.setAttr(System.String,System.String,System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void setAttr(
    string attrName,
    string value,
    string defaultValue
)
Protected Sub setAttr (
    attrName As String,
    value As String,
    defaultValue As String
)
protected:
void setAttr(
    String^ attrName,
    String^ value,
    String^ defaultValue
)
member setAttr :
        attrName : string *
        value : string *
        defaultValue : string -> unit

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsElement.setAttr(System.String,System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:DXMLBase.Xds.XdsElement.setAttr(System.String,System.String,System.String)"]

defaultValue
Type: SystemString
The default value for the attribute (may be empty, may not be null).
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.setBoolAttr Method

XdsElementsetBoolAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.setBoolAttr(System.String,System.Boolean,System.Boolean)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void setBoolAttr(
    string attrName,
    bool value,
    bool defaultValue
)
Protected Sub setBoolAttr (
    attrName As String,
    value As Boolean,
    defaultValue As Boolean
)
protected:
void setBoolAttr(
    String^ attrName,
    bool value,
    bool defaultValue
)
member setBoolAttr :
        attrName : string *
        value : bool *
        defaultValue : bool -> unit

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsElement.setBoolAttr(System.String,System.Boolean,System.Boolean)"]

value
Type: SystemBoolean

[Missing <param name="value"/> documentation for "M:DXMLBase.Xds.XdsElement.setBoolAttr(System.String,System.Boolean,System.Boolean)"]

defaultValue
Type: SystemBoolean
The default value for the attribute.
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.setChildContent Method

XdsElementsetChildContent Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.setChildContent(System.String,System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void setChildContent(
    string childTagName,
    string content
)
Protected Sub setChildContent (
    childTagName As String,
    content As String
)
protected:
void setChildContent(
    String^ childTagName,
    String^ content
)
member setChildContent :
        childTagName : string *
        content : string -> unit

Parameters

childTagName
Type: SystemString

[Missing <param name="childTagName"/> documentation for "M:DXMLBase.Xds.XdsElement.setChildContent(System.String,System.String)"]

content
Type: SystemString
The content to set.
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.setXmlElement Method

XdsElementsetXmlElement Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsElement.setXmlElement(System.Xml.XmlElement)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void setXmlElement(
    XmlElement newElement
)
Protected Sub setXmlElement (
    newElement As XmlElement
)
protected:
void setXmlElement(
    XmlElement^ newElement
)
member setXmlElement :
        newElement : XmlElement -> unit

Parameters

newElement
Type: System.XmlXmlElement
The new element.
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement Properties

XdsElement Properties

The XdsElement type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | XmlElement |
Top
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.Name Property

XdsElementName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsElement.Name"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsElement.XmlElement Property

XdsElementXmlElement Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsElement.XmlElement"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement XmlElement { get; }
Public ReadOnly Property XmlElement As XmlElement
    Get
public:
property XmlElement^ XmlElement {
    XmlElement^ get ();
}
member XmlElement : XmlElement with get

Property Value

Type: XmlElement
See Also

Reference

XdsElement Class
DXMLBase.Xds Namespace


XdsErrorException Class

XdsErrorException Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsErrorException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.XdsXdsStatusException
DXMLBase.XdsXdsErrorException

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsErrorException : XdsStatusException
Public Class XdsErrorException
    Inherits XdsStatusException
public ref class XdsErrorException : public XdsStatusException
type XdsErrorException =
    class
        inherit XdsStatusException
    end

The XdsErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | XdsErrorException(String) | Initializes a new instance of the XdsErrorException class
Public method | XdsErrorException(String, Exception) | Initializes a new instance of the XdsErrorException class
Top
Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsErrorException Constructor

XdsErrorException Constructor
Overload List
 | Name | Description
Public method | XdsErrorException(String) | Initializes a new instance of the XdsErrorException class
Public method | XdsErrorException(String, Exception) | Initializes a new instance of the XdsErrorException class
Top
See Also

Reference

XdsErrorException Class
DXMLBase.Xds Namespace


XdsErrorException Constructor (String)

XdsErrorException Constructor (String)
Initializes a new instance of the XdsErrorException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsErrorException(
    string message
)
Public Sub New (
    message As String
)
public:
XdsErrorException(
    String^ message
)
new :
        message : string -> XdsErrorException

Parameters

message
Type: SystemString
The message.
See Also

Reference

XdsErrorException Class
XdsErrorException Overload
DXMLBase.Xds Namespace


XdsErrorException Constructor (String, Exception)

XdsErrorException Constructor (String, Exception)
Initializes a new instance of the XdsErrorException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsErrorException(
    string message,
    Exception cause
)
Public Sub New (
    message As String,
    cause As Exception
)
public:
XdsErrorException(
    String^ message,
    Exception^ cause
)
new :
        message : string *
        cause : Exception -> XdsErrorException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Xds.XdsErrorException.#ctor(System.String,System.Exception)"]

cause
Type: SystemException
The underlying exception.
See Also

Reference

XdsErrorException Class
XdsErrorException Overload
DXMLBase.Xds Namespace


XdsErrorException Methods

XdsErrorException Methods

The XdsErrorException type exposes the following members.

Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsErrorException Class
DXMLBase.Xds Namespace


XdsErrorException Properties

XdsErrorException Properties

The XdsErrorException type exposes the following members.

Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsErrorException Class
DXMLBase.Xds Namespace


XdsErrorException Events

XdsErrorException Events

The XdsErrorException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

XdsErrorException Class
DXMLBase.Xds Namespace


XdsFatalException Class

XdsFatalException Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsFatalException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.XdsXdsStatusException
DXMLBase.XdsXdsFatalException

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsFatalException : XdsStatusException
Public Class XdsFatalException
    Inherits XdsStatusException
public ref class XdsFatalException : public XdsStatusException
type XdsFatalException =
    class
        inherit XdsStatusException
    end

The XdsFatalException type exposes the following members.

Constructors
 | Name | Description
Public method | XdsFatalException(String) | Initializes a new instance of the XdsFatalException class
Public method | XdsFatalException(String, Exception) | Initializes a new instance of the XdsFatalException class
Top
Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsFatalException Constructor

XdsFatalException Constructor
Overload List
 | Name | Description
Public method | XdsFatalException(String) | Initializes a new instance of the XdsFatalException class
Public method | XdsFatalException(String, Exception) | Initializes a new instance of the XdsFatalException class
Top
See Also

Reference

XdsFatalException Class
DXMLBase.Xds Namespace


XdsFatalException Constructor (String)

XdsFatalException Constructor (String)
Initializes a new instance of the XdsFatalException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsFatalException(
    string message
)
Public Sub New (
    message As String
)
public:
XdsFatalException(
    String^ message
)
new :
        message : string -> XdsFatalException

Parameters

message
Type: SystemString
The message.
See Also

Reference

XdsFatalException Class
XdsFatalException Overload
DXMLBase.Xds Namespace


XdsFatalException Constructor (String, Exception)

XdsFatalException Constructor (String, Exception)
Initializes a new instance of the XdsFatalException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsFatalException(
    string message,
    Exception cause
)
Public Sub New (
    message As String,
    cause As Exception
)
public:
XdsFatalException(
    String^ message,
    Exception^ cause
)
new :
        message : string *
        cause : Exception -> XdsFatalException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Xds.XdsFatalException.#ctor(System.String,System.Exception)"]

cause
Type: SystemException
The underlying exception.
See Also

Reference

XdsFatalException Class
XdsFatalException Overload
DXMLBase.Xds Namespace


XdsFatalException Methods

XdsFatalException Methods

The XdsFatalException type exposes the following members.

Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsFatalException Class
DXMLBase.Xds Namespace


XdsFatalException Properties

XdsFatalException Properties

The XdsFatalException type exposes the following members.

Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsFatalException Class
DXMLBase.Xds Namespace


XdsFatalException Events

XdsFatalException Events

The XdsFatalException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

XdsFatalException Class
DXMLBase.Xds Namespace


XdsInitParams Class

XdsInitParams Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsInitParams"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsInitParams

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsInitParams : XdsElement
Public Class XdsInitParams
    Inherits XdsElement
public ref class XdsInitParams : public XdsElement
type XdsInitParams =
    class
        inherit XdsElement
    end

The XdsInitParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAuthenticationInfo |
Public method | newDriverOptions |
Public method | newDriverState |
Public method | newPublisherOptions |
Public method | newPublisherState |
Public method | newSubscriberOptions |
Public method | newSubscriberState |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AuthenticationInfo |
Public property | DriverOptions |
Public property | DriverState |
Public property | Name | (Inherited from XdsElement.)
Public property | PublisherOptions |
Public property | PublisherState |
Public property | SrcDN |
Public property | SubscriberOptions |
Public property | SubscriberState |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsInitParams Methods

XdsInitParams Methods

The XdsInitParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAuthenticationInfo |
Public method | newDriverOptions |
Public method | newDriverState |
Public method | newPublisherOptions |
Public method | newPublisherState |
Public method | newSubscriberOptions |
Public method | newSubscriberState |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newAuthenticationInfo Method

XdsInitParamsnewAuthenticationInfo Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newAuthenticationInfo"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsAuthenticationInfo newAuthenticationInfo()
Public Function newAuthenticationInfo As XdsAuthenticationInfo
public:
XdsAuthenticationInfo^ newAuthenticationInfo()
member newAuthenticationInfo : unit -> XdsAuthenticationInfo

Return Value

Type: XdsAuthenticationInfo
<authentication-info> child element.
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newDriverOptions Method

XdsInitParamsnewDriverOptions Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newDriverOptions"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDriverOptions newDriverOptions()
Public Function newDriverOptions As XdsDriverOptions
public:
XdsDriverOptions^ newDriverOptions()
member newDriverOptions : unit -> XdsDriverOptions

Return Value

Type: XdsDriverOptions

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsInitParams.newDriverOptions"]

See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newDriverState Method

XdsInitParamsnewDriverState Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newDriverState"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement newDriverState()
Public Function newDriverState As XmlElement
public:
XmlElement^ newDriverState()
member newDriverState : unit -> XmlElement

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsInitParams.newDriverState"]

See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newPublisherOptions Method

XdsInitParamsnewPublisherOptions Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newPublisherOptions"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsPublisherOptions newPublisherOptions()
Public Function newPublisherOptions As XdsPublisherOptions
public:
XdsPublisherOptions^ newPublisherOptions()
member newPublisherOptions : unit -> XdsPublisherOptions

Return Value

Type: XdsPublisherOptions

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsInitParams.newPublisherOptions"]

See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newPublisherState Method

XdsInitParamsnewPublisherState Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newPublisherState"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement newPublisherState()
Public Function newPublisherState As XmlElement
public:
XmlElement^ newPublisherState()
member newPublisherState : unit -> XmlElement

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsInitParams.newPublisherState"]

See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newSubscriberOptions Method

XdsInitParamsnewSubscriberOptions Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newSubscriberOptions"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsSubscriberOptions newSubscriberOptions()
Public Function newSubscriberOptions As XdsSubscriberOptions
public:
XdsSubscriberOptions^ newSubscriberOptions()
member newSubscriberOptions : unit -> XdsSubscriberOptions

Return Value

Type: XdsSubscriberOptions

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsInitParams.newSubscriberOptions"]

See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.newSubscriberState Method

XdsInitParamsnewSubscriberState Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInitParams.newSubscriberState"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement newSubscriberState()
Public Function newSubscriberState As XmlElement
public:
XmlElement^ newSubscriberState()
member newSubscriberState : unit -> XmlElement

Return Value

Type: XmlElement

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsInitParams.newSubscriberState"]

See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams Properties

XdsInitParams Properties

The XdsInitParams type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationInfo |
Public property | DriverOptions |
Public property | DriverState |
Public property | Name | (Inherited from XdsElement.)
Public property | PublisherOptions |
Public property | PublisherState |
Public property | SrcDN |
Public property | SubscriberOptions |
Public property | SubscriberState |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.AuthenticationInfo Property

XdsInitParamsAuthenticationInfo Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.AuthenticationInfo"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsAuthenticationInfo AuthenticationInfo { get; }
Public ReadOnly Property AuthenticationInfo As XdsAuthenticationInfo
    Get
public:
property XdsAuthenticationInfo^ AuthenticationInfo {
    XdsAuthenticationInfo^ get ();
}
member AuthenticationInfo : XdsAuthenticationInfo with get

Property Value

Type: XdsAuthenticationInfo
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.DriverOptions Property

XdsInitParamsDriverOptions Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.DriverOptions"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsDriverOptions DriverOptions { get; }
Public ReadOnly Property DriverOptions As XdsDriverOptions
    Get
public:
property XdsDriverOptions^ DriverOptions {
    XdsDriverOptions^ get ();
}
member DriverOptions : XdsDriverOptions with get

Property Value

Type: XdsDriverOptions
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.DriverState Property

XdsInitParamsDriverState Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.DriverState"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement DriverState { get; }
Public ReadOnly Property DriverState As XmlElement
    Get
public:
property XmlElement^ DriverState {
    XmlElement^ get ();
}
member DriverState : XmlElement with get

Property Value

Type: XmlElement
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.PublisherOptions Property

XdsInitParamsPublisherOptions Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.PublisherOptions"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsPublisherOptions PublisherOptions { get; }
Public ReadOnly Property PublisherOptions As XdsPublisherOptions
    Get
public:
property XdsPublisherOptions^ PublisherOptions {
    XdsPublisherOptions^ get ();
}
member PublisherOptions : XdsPublisherOptions with get

Property Value

Type: XdsPublisherOptions
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.PublisherState Property

XdsInitParamsPublisherState Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.PublisherState"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement PublisherState { get; }
Public ReadOnly Property PublisherState As XmlElement
    Get
public:
property XmlElement^ PublisherState {
    XmlElement^ get ();
}
member PublisherState : XmlElement with get

Property Value

Type: XmlElement
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.SrcDN Property

XdsInitParamsSrcDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.SrcDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SrcDN { get; set; }
Public Property SrcDN As String
    Get
    Set
public:
property String^ SrcDN {
    String^ get ();
    void set (String^ value);
}
member SrcDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.SubscriberOptions Property

XdsInitParamsSubscriberOptions Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.SubscriberOptions"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsSubscriberOptions SubscriberOptions { get; }
Public ReadOnly Property SubscriberOptions As XdsSubscriberOptions
    Get
public:
property XdsSubscriberOptions^ SubscriberOptions {
    XdsSubscriberOptions^ get ();
}
member SubscriberOptions : XdsSubscriberOptions with get

Property Value

Type: XdsSubscriberOptions
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInitParams.SubscriberState Property

XdsInitParamsSubscriberState Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInitParams.SubscriberState"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement SubscriberState { get; }
Public ReadOnly Property SubscriberState As XmlElement
    Get
public:
property XmlElement^ SubscriberState {
    XmlElement^ get ();
}
member SubscriberState : XmlElement with get

Property Value

Type: XmlElement
See Also

Reference

XdsInitParams Class
DXMLBase.Xds Namespace


XdsInput Class

XdsInput Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsInput"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOpParent
DXMLBase.XdsXdsInput

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsInput : XdsOpParent
Public Class XdsInput
    Inherits XdsOpParent
public ref class XdsInput : public XdsOpParent
type XdsInput =
    class
        inherit XdsOpParent
    end

The XdsInput type exposes the following members.

Constructors
 | Name | Description
Public method | XdsInput(XmlDocument) | Initializes a new instance of the XdsInput class
Public method | XdsInput(XmlElement) | Initializes a new instance of the XdsInput class
Public method | XdsInput(XdsDtd) | Initializes a new instance of the XdsInput class
Top
Methods
 | Name | Description
Public method | addStatus | (Inherited from XdsOpParent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newInitParams | (Inherited from XdsOpParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AnyNonSuccess | (Inherited from XdsOpParent.)
Public property | ErrorCount | (Inherited from XdsOpParent.)
Public property | FatalCount | (Inherited from XdsOpParent.)
Public property | InitParams | (Inherited from XdsOpParent.)
Public property | Name | (Inherited from XdsElement.)
Public property | Operations | (Inherited from XdsOpParent.)
Public property | RetryCount | (Inherited from XdsOpParent.)
Public property | StatusList | (Inherited from XdsOpParent.)
Public property | SuccessCount | (Inherited from XdsOpParent.)
Public property | WarningCount | (Inherited from XdsOpParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsInput Constructor

XdsInput Constructor
Overload List
 | Name | Description
Public method | XdsInput(XmlDocument) | Initializes a new instance of the XdsInput class
Public method | XdsInput(XmlElement) | Initializes a new instance of the XdsInput class
Public method | XdsInput(XdsDtd) | Initializes a new instance of the XdsInput class
Top
See Also

Reference

XdsInput Class
DXMLBase.Xds Namespace


XdsInput Constructor (XmlDocument)

XdsInput Constructor (XmlDocument)
Initializes a new instance of the XdsInput class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsInput(
    XmlDocument xdsDocument
)
Public Sub New (
    xdsDocument As XmlDocument
)
public:
XdsInput(
    XmlDocument^ xdsDocument
)
new :
        xdsDocument : XmlDocument -> XdsInput

Parameters

xdsDocument
Type: System.XmlXmlDocument

[Missing <param name="xdsDocument"/> documentation for "M:DXMLBase.Xds.XdsInput.#ctor(System.Xml.XmlDocument)"]

See Also

Reference

XdsInput Class
XdsInput Overload
DXMLBase.Xds Namespace


XdsInput Constructor (XmlElement)

XdsInput Constructor (XmlElement)
Initializes a new instance of the XdsInput class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsInput(
    XmlElement inputElement
)
Public Sub New (
    inputElement As XmlElement
)
public:
XdsInput(
    XmlElement^ inputElement
)
new :
        inputElement : XmlElement -> XdsInput

Parameters

inputElement
Type: System.XmlXmlElement
The XDS <input> element.
See Also

Reference

XdsInput Class
XdsInput Overload
DXMLBase.Xds Namespace


XdsInput Constructor (XdsDtd)

XdsInput Constructor (XdsDtd)
Initializes a new instance of the XdsInput class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsInput(
    XdsDtd ndsDtd
)
Public Sub New (
    ndsDtd As XdsDtd
)
public:
XdsInput(
    XdsDtd^ ndsDtd
)
new :
        ndsDtd : XdsDtd -> XdsInput

Parameters

ndsDtd
Type: DXMLBase.XdsXdsDtd
The NdsDtd instance to use to create the document.
See Also

Reference

XdsInput Class
XdsInput Overload
DXMLBase.Xds Namespace


XdsInput Methods

XdsInput Methods

The XdsInput type exposes the following members.

Methods
 | Name | Description
Public method | addStatus | (Inherited from XdsOpParent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newInitParams | (Inherited from XdsOpParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsInput Class
DXMLBase.Xds Namespace


XdsInput Properties

XdsInput Properties

The XdsInput type exposes the following members.

Properties
 | Name | Description
Public property | AnyNonSuccess | (Inherited from XdsOpParent.)
Public property | ErrorCount | (Inherited from XdsOpParent.)
Public property | FatalCount | (Inherited from XdsOpParent.)
Public property | InitParams | (Inherited from XdsOpParent.)
Public property | Name | (Inherited from XdsElement.)
Public property | Operations | (Inherited from XdsOpParent.)
Public property | RetryCount | (Inherited from XdsOpParent.)
Public property | StatusList | (Inherited from XdsOpParent.)
Public property | SuccessCount | (Inherited from XdsOpParent.)
Public property | WarningCount | (Inherited from XdsOpParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsInput Class
DXMLBase.Xds Namespace


XdsInstance Class

XdsInstance Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsInstance"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsInstance

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsInstance : XdsOperation
Public Class XdsInstance
    Inherits XdsOperation
public ref class XdsInstance : public XdsOperation
type XdsInstance =
    class
        inherit XdsOperation
    end

The XdsInstance type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsAttr |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | Attrs |
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsInstance Methods

XdsInstance Methods

The XdsInstance type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsAttr |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsInstance Class
DXMLBase.Xds Namespace


XdsInstance.newXdsAttr Method

XdsInstancenewXdsAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsInstance.newXdsAttr(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsAttr newXdsAttr(
    string attrName
)
Public Function newXdsAttr (
    attrName As String
) As XdsAttr
public:
XdsAttr^ newXdsAttr(
    String^ attrName
)
member newXdsAttr :
        attrName : string -> XdsAttr

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsInstance.newXdsAttr(System.String)"]

Return Value

Type: XdsAttr
A new or previously existing <attr>.
See Also

Reference

XdsInstance Class
DXMLBase.Xds Namespace


XdsInstance Properties

XdsInstance Properties

The XdsInstance type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | Attrs |
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsInstance Class
DXMLBase.Xds Namespace


XdsInstance.Attrs Property

XdsInstanceAttrs Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsInstance.Attrs"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsAttr> Attrs { get; }
Public ReadOnly Property Attrs As IEnumerable(Of XdsAttr)
    Get
public:
property IEnumerable<XdsAttr^>^ Attrs {
    IEnumerable<XdsAttr^>^ get ();
}
member Attrs : IEnumerable<XdsAttr> with get

Property Value

Type: IEnumerable XdsAttr
See Also

Reference

XdsInstance Class
DXMLBase.Xds Namespace


XdsModify Class

XdsModify Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsModify"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsModify

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsModify : XdsOperation
Public Class XdsModify
    Inherits XdsOperation
public ref class XdsModify : public XdsOperation
type XdsModify =
    class
        inherit XdsOperation
    end

The XdsModify type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newModifyAttr |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | fromMerge |
Public property | fromReset |
Public property | ModifyAttrs |
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsModify Methods

XdsModify Methods

The XdsModify type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newModifyAttr |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsModify Class
DXMLBase.Xds Namespace


XdsModify.newModifyAttr Method

XdsModifynewModifyAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsModify.newModifyAttr(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsModifyAttr newModifyAttr(
    string attrName
)
Public Function newModifyAttr (
    attrName As String
) As XdsModifyAttr
public:
XdsModifyAttr^ newModifyAttr(
    String^ attrName
)
member newModifyAttr :
        attrName : string -> XdsModifyAttr

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsModify.newModifyAttr(System.String)"]

Return Value

Type: XdsModifyAttr
A new or existing <modify-attr>.
See Also

Reference

XdsModify Class
DXMLBase.Xds Namespace


XdsModify Properties

XdsModify Properties

The XdsModify type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | fromMerge |
Public property | fromReset |
Public property | ModifyAttrs |
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsModify Class
DXMLBase.Xds Namespace


XdsModify.fromMerge Property

XdsModifyfromMerge Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsModify.fromMerge"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool fromMerge { get; }
Public ReadOnly Property fromMerge As Boolean
    Get
public:
property bool fromMerge {
    bool get ();
}
member fromMerge : bool with get

Property Value

Type: Boolean
See Also

Reference

XdsModify Class
DXMLBase.Xds Namespace


XdsModify.fromReset Property

XdsModifyfromReset Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsModify.fromReset"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool fromReset { get; }
Public ReadOnly Property fromReset As Boolean
    Get
public:
property bool fromReset {
    bool get ();
}
member fromReset : bool with get

Property Value

Type: Boolean
See Also

Reference

XdsModify Class
DXMLBase.Xds Namespace


XdsModify.ModifyAttrs Property

XdsModifyModifyAttrs Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsModify.ModifyAttrs"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsModifyAttr> ModifyAttrs { get; }
Public ReadOnly Property ModifyAttrs As IEnumerable(Of XdsModifyAttr)
    Get
public:
property IEnumerable<XdsModifyAttr^>^ ModifyAttrs {
    IEnumerable<XdsModifyAttr^>^ get ();
}
member ModifyAttrs : IEnumerable<XdsModifyAttr> with get

Property Value

Type: IEnumerable XdsModifyAttr
See Also

Reference

XdsModify Class
DXMLBase.Xds Namespace


XdsModifyAttr Class

XdsModifyAttr Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsModifyAttr"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsModifyAttr

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsModifyAttr : XdsElement
Public Class XdsModifyAttr
    Inherits XdsElement
public ref class XdsModifyAttr : public XdsElement
type XdsModifyAttr =
    class
        inherit XdsElement
    end

The XdsModifyAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAddValue |
Public method | newRemoveAllValues |
Public method | newRemoveValue |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | ValueModifications |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsModifyAttr Methods

XdsModifyAttr Methods

The XdsModifyAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAddValue |
Public method | newRemoveAllValues |
Public method | newRemoveValue |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyAttr.newAddValue Method

XdsModifyAttrnewAddValue Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsModifyAttr.newAddValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsAddValue newAddValue()
Public Function newAddValue As XdsAddValue
public:
XdsAddValue^ newAddValue()
member newAddValue : unit -> XdsAddValue

Return Value

Type: XdsAddValue
The new element.
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyAttr.newRemoveAllValues Method

XdsModifyAttrnewRemoveAllValues Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsModifyAttr.newRemoveAllValues"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsRemoveAllValues newRemoveAllValues()
Public Function newRemoveAllValues As XdsRemoveAllValues
public:
XdsRemoveAllValues^ newRemoveAllValues()
member newRemoveAllValues : unit -> XdsRemoveAllValues

Return Value

Type: XdsRemoveAllValues
The new element.
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyAttr.newRemoveValue Method

XdsModifyAttrnewRemoveValue Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsModifyAttr.newRemoveValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsRemoveValue newRemoveValue()
Public Function newRemoveValue As XdsRemoveValue
public:
XdsRemoveValue^ newRemoveValue()
member newRemoveValue : unit -> XdsRemoveValue

Return Value

Type: XdsRemoveValue
The new element.
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyAttr Properties

XdsModifyAttr Properties

The XdsModifyAttr type exposes the following members.

Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | ValueModifications |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyAttr.AttrName Property

XdsModifyAttrAttrName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsModifyAttr.AttrName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Property Value

Type: String
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyAttr.ValueModifications Property

XdsModifyAttrValueModifications Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsModifyAttr.ValueModifications"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsElement> ValueModifications { get; }
Public ReadOnly Property ValueModifications As IEnumerable(Of XdsElement)
    Get
public:
property IEnumerable<XdsElement^>^ ValueModifications {
    IEnumerable<XdsElement^>^ get ();
}
member ValueModifications : IEnumerable<XdsElement> with get

Property Value

Type: IEnumerable XdsElement
See Also

Reference

XdsModifyAttr Class
DXMLBase.Xds Namespace


XdsModifyPasswd Class

XdsModifyPasswd Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsModifyPasswd"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsModifyPasswd

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsModifyPasswd : XdsOperation
Public Class XdsModifyPasswd
    Inherits XdsOperation
public ref class XdsModifyPasswd : public XdsOperation
type XdsModifyPasswd =
    class
        inherit XdsOperation
    end

The XdsModifyPasswd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsModifyPasswd Methods

XdsModifyPasswd Methods

The XdsModifyPasswd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsModifyPasswd Class
DXMLBase.Xds Namespace


XdsModifyPasswd Properties

XdsModifyPasswd Properties

The XdsModifyPasswd type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsModifyPasswd Class
DXMLBase.Xds Namespace


XdsModifyPasswd.Password Property

XdsModifyPasswdPassword Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsModifyPasswd.Password"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

XdsModifyPasswd Class
DXMLBase.Xds Namespace


XdsOperation Class

XdsOperation Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsOperation"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
More...

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsOperation : XdsElement
Public Class XdsOperation
    Inherits XdsElement
public ref class XdsOperation : public XdsElement
type XdsOperation =
    class
        inherit XdsElement
    end

The XdsOperation type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsOperation | Initializes a new instance of the XdsOperation class
Top
Methods
 | Name | Description
 | construct(XmlElement) |
 | construct(XmlElement, XdsOperationOpType) |
 | construct(XdsOpParent, XdsOperationOpType) |
 | construct(XmlElement, String, String) |
 | construct(XdsOpParent, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association |
Public property | ClassName |
Public property | DestDN |
Public property | EventID |
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN |
Public property | SrcDN |
Public property | SrcEntryID |
Public property | Type |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace
Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsAdd
DXMLBase.XdsXdsAddAssociation
DXMLBase.XdsXdsCheckObjectPassword
DXMLBase.XdsXdsCustomOperation
DXMLBase.XdsXdsDelete
DXMLBase.XdsXdsInstance
DXMLBase.XdsXdsModify
DXMLBase.XdsXdsModifyPasswd
DXMLBase.XdsXdsQuery
DXMLBase.XdsXdsQuerySchema
DXMLBase.XdsXdsRename


XdsOperation Constructor

XdsOperation Constructor
Initializes a new instance of the XdsOperation class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsOperation(
    XmlElement opElement,
    XdsOperationOpType type
)
Protected Sub New (
    opElement As XmlElement,
    type As XdsOperationOpType
)
protected:
XdsOperation(
    XmlElement^ opElement,
    XdsOperationOpType type
)
new :
        opElement : XmlElement *
        type : XdsOperationOpType -> XdsOperation

Parameters

opElement
Type: System.XmlXmlElement

[Missing <param name="opElement"/> documentation for "M:DXMLBase.Xds.XdsOperation.#ctor(System.Xml.XmlElement,DXMLBase.Xds.XdsOperation.OpType)"]

type
Type: DXMLBase.XdsXdsOperationOpType

[Missing <param name="type"/> documentation for "M:DXMLBase.Xds.XdsOperation.#ctor(System.Xml.XmlElement,DXMLBase.Xds.XdsOperation.OpType)"]

See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation Methods

XdsOperation Methods

The XdsOperation type exposes the following members.

Methods
 | Name | Description
 | construct(XmlElement) |
 | construct(XmlElement, XdsOperationOpType) |
 | construct(XdsOpParent, XdsOperationOpType) |
 | construct(XmlElement, String, String) |
 | construct(XdsOpParent, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.construct Method

XdsOperationconstruct Method
Overload List
Name | Description
construct(XmlElement) |
construct(XmlElement, XdsOperationOpType) |
construct(XdsOpParent, XdsOperationOpType) |
construct(XmlElement, String, String) |
construct(XdsOpParent, String, String) |
Top
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.construct Method (XmlElement)

XdsOperationconstruct Method (XmlElement)

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsOperation construct(
    XmlElement opElement
)
Public Shared Function construct (
    opElement As XmlElement
) As XdsOperation
public:
static XdsOperation^ construct(
    XmlElement^ opElement
)
static member construct :
        opElement : XmlElement -> XdsOperation

Parameters

opElement
Type: System.XmlXmlElement

[Missing <param name="opElement"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement)"]

Return Value

Type: XdsOperation

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement)"]

See Also

Reference

XdsOperation Class
construct Overload
DXMLBase.Xds Namespace


XdsOperation.construct Method (XmlElement, XdsOperation.OpType)

XdsOperationconstruct Method (XmlElement, XdsOperationOpType)

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,DXMLBase.Xds.XdsOperation.OpType)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsOperation construct(
    XmlElement parent,
    XdsOperationOpType type
)
Public Shared Function construct (
    parent As XmlElement,
    type As XdsOperationOpType
) As XdsOperation
public:
static XdsOperation^ construct(
    XmlElement^ parent,
    XdsOperationOpType type
)
static member construct :
        parent : XmlElement *
        type : XdsOperationOpType -> XdsOperation

Parameters

parent
Type: System.XmlXmlElement

[Missing <param name="parent"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,DXMLBase.Xds.XdsOperation.OpType)"]

type
Type: DXMLBase.XdsXdsOperationOpType

[Missing <param name="type"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,DXMLBase.Xds.XdsOperation.OpType)"]

Return Value

Type: XdsOperation

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,DXMLBase.Xds.XdsOperation.OpType)"]

See Also

Reference

XdsOperation Class
construct Overload
DXMLBase.Xds Namespace


XdsOperation.construct Method (XdsOpParent, XdsOperation.OpType)

XdsOperationconstruct Method (XdsOpParent, XdsOperationOpType)

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,DXMLBase.Xds.XdsOperation.OpType)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsOperation construct(
    XdsOpParent parent,
    XdsOperationOpType type
)
Public Shared Function construct (
    parent As XdsOpParent,
    type As XdsOperationOpType
) As XdsOperation
public:
static XdsOperation^ construct(
    XdsOpParent^ parent,
    XdsOperationOpType type
)
static member construct :
        parent : XdsOpParent *
        type : XdsOperationOpType -> XdsOperation

Parameters

parent
Type: DXMLBase.XdsXdsOpParent

[Missing <param name="parent"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,DXMLBase.Xds.XdsOperation.OpType)"]

type
Type: DXMLBase.XdsXdsOperationOpType

[Missing <param name="type"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,DXMLBase.Xds.XdsOperation.OpType)"]

Return Value

Type: XdsOperation

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,DXMLBase.Xds.XdsOperation.OpType)"]

See Also

Reference

XdsOperation Class
construct Overload
DXMLBase.Xds Namespace


XdsOperation.construct Method (XmlElement, String, String)

XdsOperationconstruct Method (XmlElement, String, String)

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,System.String,System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsOperation construct(
    XmlElement parent,
    string namespaceURI,
    string tagName
)
Public Shared Function construct (
    parent As XmlElement,
    namespaceURI As String,
    tagName As String
) As XdsOperation
public:
static XdsOperation^ construct(
    XmlElement^ parent,
    String^ namespaceURI,
    String^ tagName
)
static member construct :
        parent : XmlElement *
        namespaceURI : string *
        tagName : string -> XdsOperation

Parameters

parent
Type: System.XmlXmlElement

[Missing <param name="parent"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,System.String,System.String)"]

namespaceURI
Type: SystemString

[Missing <param name="namespaceURI"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,System.String,System.String)"]

tagName
Type: SystemString

[Missing <param name="tagName"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,System.String,System.String)"]

Return Value

Type: XdsOperation

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsOperation.construct(System.Xml.XmlElement,System.String,System.String)"]

See Also

Reference

XdsOperation Class
construct Overload
DXMLBase.Xds Namespace


XdsOperation.construct Method (XdsOpParent, String, String)

XdsOperationconstruct Method (XdsOpParent, String, String)

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,System.String,System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsOperation construct(
    XdsOpParent parent,
    string namespaceURI,
    string tagName
)
Public Shared Function construct (
    parent As XdsOpParent,
    namespaceURI As String,
    tagName As String
) As XdsOperation
public:
static XdsOperation^ construct(
    XdsOpParent^ parent,
    String^ namespaceURI,
    String^ tagName
)
static member construct :
        parent : XdsOpParent *
        namespaceURI : string *
        tagName : string -> XdsOperation

Parameters

parent
Type: DXMLBase.XdsXdsOpParent

[Missing <param name="parent"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,System.String,System.String)"]

namespaceURI
Type: SystemString

[Missing <param name="namespaceURI"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,System.String,System.String)"]

tagName
Type: SystemString

[Missing <param name="tagName"/> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,System.String,System.String)"]

Return Value

Type: XdsOperation

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsOperation.construct(DXMLBase.Xds.XdsOpParent,System.String,System.String)"]

See Also

Reference

XdsOperation Class
construct Overload
DXMLBase.Xds Namespace


XdsOperation.getType Method

XdsOperationgetType Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOperation.getType(System.Xml.XmlElement)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsOperationOpType getType(
    XmlElement opElement
)
Public Shared Function getType (
    opElement As XmlElement
) As XdsOperationOpType
public:
static XdsOperationOpType getType(
    XmlElement^ opElement
)
static member getType :
        opElement : XmlElement -> XdsOperationOpType

Parameters

opElement
Type: System.XmlXmlElement

[Missing <param name="opElement"/> documentation for "M:DXMLBase.Xds.XdsOperation.getType(System.Xml.XmlElement)"]

Return Value

Type: XdsOperationOpType

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsOperation.getType(System.Xml.XmlElement)"]

See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation Properties

XdsOperation Properties

The XdsOperation type exposes the following members.

Properties
 | Name | Description
Public property | Association |
Public property | ClassName |
Public property | DestDN |
Public property | EventID |
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN |
Public property | SrcDN |
Public property | SrcEntryID |
Public property | Type |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.Association Property

XdsOperationAssociation Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.Association"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Association { get; set; }
Public Overridable Property Association As String
    Get
    Set
public:
virtual property String^ Association {
    String^ get ();
    void set (String^ value);
}
abstract Association : string with get, set
override Association : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.ClassName Property

XdsOperationClassName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.ClassName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.DestDN Property

XdsOperationDestDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.DestDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DestDN { get; set; }
Public Property DestDN As String
    Get
    Set
public:
property String^ DestDN {
    String^ get ();
    void set (String^ value);
}
member DestDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.EventID Property

XdsOperationEventID Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.EventID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EventID { get; set; }
Public Property EventID As String
    Get
    Set
public:
property String^ EventID {
    String^ get ();
    void set (String^ value);
}
member EventID : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.QualifiedSrcDN Property

XdsOperationQualifiedSrcDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.QualifiedSrcDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string QualifiedSrcDN { get; set; }
Public Property QualifiedSrcDN As String
    Get
    Set
public:
property String^ QualifiedSrcDN {
    String^ get ();
    void set (String^ value);
}
member QualifiedSrcDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.SrcDN Property

XdsOperationSrcDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.SrcDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SrcDN { get; set; }
Public Property SrcDN As String
    Get
    Set
public:
property String^ SrcDN {
    String^ get ();
    void set (String^ value);
}
member SrcDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.SrcEntryID Property

XdsOperationSrcEntryID Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.SrcEntryID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SrcEntryID { get; set; }
Public Property SrcEntryID As String
    Get
    Set
public:
property String^ SrcEntryID {
    String^ get ();
    void set (String^ value);
}
member SrcEntryID : string with get, set

Property Value

Type: String
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.Type Property

XdsOperationType Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOperation.Type"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsOperationOpType Type { get; }
Public ReadOnly Property Type As XdsOperationOpType
    Get
public:
property XdsOperationOpType Type {
    XdsOperationOpType get ();
}
member Type : XdsOperationOpType with get

Property Value

Type: XdsOperationOpType
See Also

Reference

XdsOperation Class
DXMLBase.Xds Namespace


XdsOperation.OpType Enumeration

XdsOperationOpType Enumeration

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsOperation.OpType"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OpType
Public Enumeration OpType
public enum class OpType
type OpType
Members
Member name | Value | Description
Add | 0 |
Modify | 1 |
Delete | 2 |
Rename | 3 |
Move | 4 |
Query | 5 |
QueryEx | 6 |
QuerySchema | 7 |
AddAssociation | 8 |
ModifyAssociation | 9 |
RemoveAssociation | 10 |
InitParams | 11 |
Status | 12 |
CheckPassword | 13 |
ModifyPassword | 14 |
CheckObjectPassword | 15 |
Sync | 16 |
GetNamedPassword | 17 |
GeneratedPassword | 18 |
Password | 19 |
QueryToken | 20 |
Instance | 21 |
Custom | 22 |
See Also

Reference

DXMLBase.Xds Namespace


XdsOpParent Class

XdsOpParent Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsOpParent"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOpParent
DXMLBase.XdsXdsInput
DXMLBase.XdsXdsOutput

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class XdsOpParent : XdsElement
Public MustInherit Class XdsOpParent
    Inherits XdsElement
public ref class XdsOpParent abstract : public XdsElement
[<AbstractClassAttribute>]
type XdsOpParent =
    class
        inherit XdsElement
    end

The XdsOpParent type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsOpParent(XmlElement, Boolean) | Initializes a new instance of the XdsOpParent class
Protected method | XdsOpParent(XmlDocument, String, Boolean) | Initializes a new instance of the XdsOpParent class
Top
Methods
 | Name | Description
Public method | addStatus |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newInitParams |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AnyNonSuccess |
Public property | ErrorCount |
Public property | FatalCount |
Public property | InitParams |
Public property | Name | (Inherited from XdsElement.)
Public property | Operations |
Public property | RetryCount |
Public property | StatusList |
Public property | SuccessCount |
Public property | WarningCount |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsOpParent Constructor

XdsOpParent Constructor
Overload List
 | Name | Description
Protected method | XdsOpParent(XmlElement, Boolean) | Initializes a new instance of the XdsOpParent class
Protected method | XdsOpParent(XmlDocument, String, Boolean) | Initializes a new instance of the XdsOpParent class
Top
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent Constructor (XmlElement, Boolean)

XdsOpParent Constructor (XmlElement, Boolean)
Initializes a new instance of the XdsOpParent class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsOpParent(
    XmlElement opParent,
    bool initStatus
)
Protected Sub New (
    opParent As XmlElement,
    initStatus As Boolean
)
protected:
XdsOpParent(
    XmlElement^ opParent,
    bool initStatus
)
new :
        opParent : XmlElement *
        initStatus : bool -> XdsOpParent

Parameters

opParent
Type: System.XmlXmlElement

[Missing <param name="opParent"/> documentation for "M:DXMLBase.Xds.XdsOpParent.#ctor(System.Xml.XmlElement,System.Boolean)"]

initStatus
Type: SystemBoolean
true if child status element should be searched for.
See Also

Reference

XdsOpParent Class
XdsOpParent Overload
DXMLBase.Xds Namespace


XdsOpParent Constructor (XmlDocument, String, Boolean)

XdsOpParent Constructor (XmlDocument, String, Boolean)
Initializes a new instance of the XdsOpParent class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsOpParent(
    XmlDocument xdsDocument,
    string tagName,
    bool initStatus
)
Protected Sub New (
    xdsDocument As XmlDocument,
    tagName As String,
    initStatus As Boolean
)
protected:
XdsOpParent(
    XmlDocument^ xdsDocument,
    String^ tagName,
    bool initStatus
)
new :
        xdsDocument : XmlDocument *
        tagName : string *
        initStatus : bool -> XdsOpParent

Parameters

xdsDocument
Type: System.XmlXmlDocument

[Missing <param name="xdsDocument"/> documentation for "M:DXMLBase.Xds.XdsOpParent.#ctor(System.Xml.XmlDocument,System.String,System.Boolean)"]

tagName
Type: SystemString

[Missing <param name="tagName"/> documentation for "M:DXMLBase.Xds.XdsOpParent.#ctor(System.Xml.XmlDocument,System.String,System.Boolean)"]

initStatus
Type: SystemBoolean

[Missing <param name="initStatus"/> documentation for "M:DXMLBase.Xds.XdsOpParent.#ctor(System.Xml.XmlDocument,System.String,System.Boolean)"]

See Also

Reference

XdsOpParent Class
XdsOpParent Overload
DXMLBase.Xds Namespace


XdsOpParent Methods

XdsOpParent Methods

The XdsOpParent type exposes the following members.

Methods
 | Name | Description
Public method | addStatus |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newInitParams |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.addStatus Method

XdsOpParentaddStatus Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOpParent.addStatus(DXMLBase.Xds.XdsStatusReport)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement addStatus(
    XdsStatusReport status
)
Public Function addStatus (
    status As XdsStatusReport
) As XmlElement
public:
XmlElement^ addStatus(
    XdsStatusReport^ status
)
member addStatus :
        status : XdsStatusReport -> XmlElement

Parameters

status
Type: DXMLBase.XdsXdsStatusReport

[Missing <param name="status"/> documentation for "M:DXMLBase.Xds.XdsOpParent.addStatus(DXMLBase.Xds.XdsStatusReport)"]

Return Value

Type: XmlElement
The element appended to the underlying XmlElement.
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.newInitParams Method

XdsOpParentnewInitParams Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOpParent.newInitParams"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsInitParams newInitParams()
Public Function newInitParams As XdsInitParams
public:
XdsInitParams^ newInitParams()
member newInitParams : unit -> XdsInitParams

Return Value

Type: XdsInitParams
A new child <init-params> element.
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent Properties

XdsOpParent Properties

The XdsOpParent type exposes the following members.

Properties
 | Name | Description
Public property | AnyNonSuccess |
Public property | ErrorCount |
Public property | FatalCount |
Public property | InitParams |
Public property | Name | (Inherited from XdsElement.)
Public property | Operations |
Public property | RetryCount |
Public property | StatusList |
Public property | SuccessCount |
Public property | WarningCount |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.AnyNonSuccess Property

XdsOpParentAnyNonSuccess Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.AnyNonSuccess"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AnyNonSuccess { get; }
Public ReadOnly Property AnyNonSuccess As Boolean
    Get
public:
property bool AnyNonSuccess {
    bool get ();
}
member AnyNonSuccess : bool with get

Property Value

Type: Boolean
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.ErrorCount Property

XdsOpParentErrorCount Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.ErrorCount"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ErrorCount { get; }
Public ReadOnly Property ErrorCount As Integer
    Get
public:
property int ErrorCount {
    int get ();
}
member ErrorCount : int with get

Property Value

Type: Int32
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.FatalCount Property

XdsOpParentFatalCount Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.FatalCount"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FatalCount { get; }
Public ReadOnly Property FatalCount As Integer
    Get
public:
property int FatalCount {
    int get ();
}
member FatalCount : int with get

Property Value

Type: Int32
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.InitParams Property

XdsOpParentInitParams Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.InitParams"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsInitParams InitParams { get; }
Public ReadOnly Property InitParams As XdsInitParams
    Get
public:
property XdsInitParams^ InitParams {
    XdsInitParams^ get ();
}
member InitParams : XdsInitParams with get

Property Value

Type: XdsInitParams
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.Operations Property

XdsOpParentOperations Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.Operations"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsOperation> Operations { get; }
Public ReadOnly Property Operations As IEnumerable(Of XdsOperation)
    Get
public:
property IEnumerable<XdsOperation^>^ Operations {
    IEnumerable<XdsOperation^>^ get ();
}
member Operations : IEnumerable<XdsOperation> with get

Property Value

Type: IEnumerable XdsOperation
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.RetryCount Property

XdsOpParentRetryCount Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.RetryCount"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RetryCount { get; }
Public ReadOnly Property RetryCount As Integer
    Get
public:
property int RetryCount {
    int get ();
}
member RetryCount : int with get

Property Value

Type: Int32
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.StatusList Property

XdsOpParentStatusList Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.StatusList"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<XdsStatusReport> StatusList { get; }
Public ReadOnly Property StatusList As ICollection(Of XdsStatusReport)
    Get
public:
property ICollection<XdsStatusReport^>^ StatusList {
    ICollection<XdsStatusReport^>^ get ();
}
member StatusList : ICollection<XdsStatusReport> with get

Property Value

Type: ICollection XdsStatusReport
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.SuccessCount Property

XdsOpParentSuccessCount Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.SuccessCount"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SuccessCount { get; }
Public ReadOnly Property SuccessCount As Integer
    Get
public:
property int SuccessCount {
    int get ();
}
member SuccessCount : int with get

Property Value

Type: Int32
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOpParent.WarningCount Property

XdsOpParentWarningCount Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsOpParent.WarningCount"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int WarningCount { get; }
Public ReadOnly Property WarningCount As Integer
    Get
public:
property int WarningCount {
    int get ();
}
member WarningCount : int with get

Property Value

Type: Int32
See Also

Reference

XdsOpParent Class
DXMLBase.Xds Namespace


XdsOutput Class

XdsOutput Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsOutput"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOpParent
DXMLBase.XdsXdsOutput

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsOutput : XdsOpParent
Public Class XdsOutput
    Inherits XdsOpParent
public ref class XdsOutput : public XdsOpParent
type XdsOutput =
    class
        inherit XdsOpParent
    end

The XdsOutput type exposes the following members.

Constructors
 | Name | Description
Public method | XdsOutput(XmlDocument) | Initializes a new instance of the XdsOutput class
Public method | XdsOutput(XmlElement) | Initializes a new instance of the XdsOutput class
Public method | XdsOutput(XdsDtd) | Initializes a new instance of the XdsOutput class
Top
Methods
 | Name | Description
Public method | addStatus | (Inherited from XdsOpParent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAddAssociation |
Public method | newInitParams | (Inherited from XdsOpParent.)
Public method | newXdsInstance |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AnyNonSuccess | (Inherited from XdsOpParent.)
Public property | ErrorCount | (Inherited from XdsOpParent.)
Public property | FatalCount | (Inherited from XdsOpParent.)
Public property | InitParams | (Inherited from XdsOpParent.)
Public property | Name | (Inherited from XdsElement.)
Public property | Operations | (Inherited from XdsOpParent.)
Public property | RetryCount | (Inherited from XdsOpParent.)
Public property | StatusList | (Inherited from XdsOpParent.)
Public property | SuccessCount | (Inherited from XdsOpParent.)
Public property | WarningCount | (Inherited from XdsOpParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsOutput Constructor

XdsOutput Constructor
Overload List
 | Name | Description
Public method | XdsOutput(XmlDocument) | Initializes a new instance of the XdsOutput class
Public method | XdsOutput(XmlElement) | Initializes a new instance of the XdsOutput class
Public method | XdsOutput(XdsDtd) | Initializes a new instance of the XdsOutput class
Top
See Also

Reference

XdsOutput Class
DXMLBase.Xds Namespace


XdsOutput Constructor (XmlDocument)

XdsOutput Constructor (XmlDocument)
Initializes a new instance of the XdsOutput class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsOutput(
    XmlDocument xdsDocument
)
Public Sub New (
    xdsDocument As XmlDocument
)
public:
XdsOutput(
    XmlDocument^ xdsDocument
)
new :
        xdsDocument : XmlDocument -> XdsOutput

Parameters

xdsDocument
Type: System.XmlXmlDocument

[Missing <param name="xdsDocument"/> documentation for "M:DXMLBase.Xds.XdsOutput.#ctor(System.Xml.XmlDocument)"]

See Also

Reference

XdsOutput Class
XdsOutput Overload
DXMLBase.Xds Namespace


XdsOutput Constructor (XmlElement)

XdsOutput Constructor (XmlElement)
Initializes a new instance of the XdsOutput class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsOutput(
    XmlElement outputElement
)
Public Sub New (
    outputElement As XmlElement
)
public:
XdsOutput(
    XmlElement^ outputElement
)
new :
        outputElement : XmlElement -> XdsOutput

Parameters

outputElement
Type: System.XmlXmlElement
The XDS <output> element.
See Also

Reference

XdsOutput Class
XdsOutput Overload
DXMLBase.Xds Namespace


XdsOutput Constructor (XdsDtd)

XdsOutput Constructor (XdsDtd)
Initializes a new instance of the XdsOutput class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsOutput(
    XdsDtd ndsDtd
)
Public Sub New (
    ndsDtd As XdsDtd
)
public:
XdsOutput(
    XdsDtd^ ndsDtd
)
new :
        ndsDtd : XdsDtd -> XdsOutput

Parameters

ndsDtd
Type: DXMLBase.XdsXdsDtd
The NdsDtd instance to use to create the document.
See Also

Reference

XdsOutput Class
XdsOutput Overload
DXMLBase.Xds Namespace


XdsOutput Methods

XdsOutput Methods

The XdsOutput type exposes the following members.

Methods
 | Name | Description
Public method | addStatus | (Inherited from XdsOpParent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newAddAssociation |
Public method | newInitParams | (Inherited from XdsOpParent.)
Public method | newXdsInstance |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsOutput Class
DXMLBase.Xds Namespace


XdsOutput.newAddAssociation Method

XdsOutputnewAddAssociation Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOutput.newAddAssociation"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsAddAssociation newAddAssociation()
Public Function newAddAssociation As XdsAddAssociation
public:
XdsAddAssociation^ newAddAssociation()
member newAddAssociation : unit -> XdsAddAssociation

Return Value

Type: XdsAddAssociation
The newly-created object.
See Also

Reference

XdsOutput Class
DXMLBase.Xds Namespace


XdsOutput.newXdsInstance Method

XdsOutputnewXdsInstance Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsOutput.newXdsInstance"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsInstance newXdsInstance()
Public Function newXdsInstance As XdsInstance
public:
XdsInstance^ newXdsInstance()
member newXdsInstance : unit -> XdsInstance

Return Value

Type: XdsInstance
The newly-created object.
See Also

Reference

XdsOutput Class
DXMLBase.Xds Namespace


XdsOutput Properties

XdsOutput Properties

The XdsOutput type exposes the following members.

Properties
 | Name | Description
Public property | AnyNonSuccess | (Inherited from XdsOpParent.)
Public property | ErrorCount | (Inherited from XdsOpParent.)
Public property | FatalCount | (Inherited from XdsOpParent.)
Public property | InitParams | (Inherited from XdsOpParent.)
Public property | Name | (Inherited from XdsElement.)
Public property | Operations | (Inherited from XdsOpParent.)
Public property | RetryCount | (Inherited from XdsOpParent.)
Public property | StatusList | (Inherited from XdsOpParent.)
Public property | SuccessCount | (Inherited from XdsOpParent.)
Public property | WarningCount | (Inherited from XdsOpParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsOutput Class
DXMLBase.Xds Namespace


XdsPassword Class

XdsPassword Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsPassword"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsPassword

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsPassword : XdsElement
Public Class XdsPassword
    Inherits XdsElement
public ref class XdsPassword : public XdsElement
type XdsPassword =
    class
        inherit XdsElement
    end

The XdsPassword type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsPassword Methods

XdsPassword Methods

The XdsPassword type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsPassword Class
DXMLBase.Xds Namespace


XdsPassword Properties

XdsPassword Properties

The XdsPassword type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | Password |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsPassword Class
DXMLBase.Xds Namespace


XdsPassword.Password Property

XdsPasswordPassword Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsPassword.Password"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

XdsPassword Class
DXMLBase.Xds Namespace


XdsPublisherOptions Class

XdsPublisherOptions Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsPublisherOptions"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsShimOptions
DXMLBase.XdsXdsPublisherOptions

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsPublisherOptions : XdsShimOptions
Public Class XdsPublisherOptions
    Inherits XdsShimOptions
public ref class XdsPublisherOptions : public XdsShimOptions
type XdsPublisherOptions =
    class
        inherit XdsShimOptions
    end

The XdsPublisherOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams | (Inherited from XdsShimOptions.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsPublisherOptions Methods

XdsPublisherOptions Methods

The XdsPublisherOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsPublisherOptions Class
DXMLBase.Xds Namespace


XdsPublisherOptions Properties

XdsPublisherOptions Properties

The XdsPublisherOptions type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams | (Inherited from XdsShimOptions.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsPublisherOptions Class
DXMLBase.Xds Namespace


XdsQuery Class

XdsQuery Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsQuery"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsQuery

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsQuery : XdsOperation
Public Class XdsQuery
    Inherits XdsOperation
public ref class XdsQuery : public XdsOperation
type XdsQuery =
    class
        inherit XdsOperation
    end

The XdsQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newReadAttr |
Public method | newSearchAttr |
Public method | newSearchClass |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | ReadAll |
Public property | ReadAttrNames |
Public property | ReadAttrs |
Public property | ReadNone |
Public property | ReadParent |
Public property | Scope |
Public property | SearchAttrs |
Public property | SearchClasses |
Public property | SearchClassNames |
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsQuery Methods

XdsQuery Methods

The XdsQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newReadAttr |
Public method | newSearchAttr |
Public method | newSearchClass |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.newReadAttr Method

XdsQuerynewReadAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsQuery.newReadAttr(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsReadAttr newReadAttr(
    string attrName
)
Public Function newReadAttr (
    attrName As String
) As XdsReadAttr
public:
XdsReadAttr^ newReadAttr(
    String^ attrName
)
member newReadAttr :
        attrName : string -> XdsReadAttr

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsQuery.newReadAttr(System.String)"]

Return Value

Type: XdsReadAttr
A new or existing <read-attr>.
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.newSearchAttr Method

XdsQuerynewSearchAttr Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsQuery.newSearchAttr(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsSearchAttr newSearchAttr(
    string attrName
)
Public Function newSearchAttr (
    attrName As String
) As XdsSearchAttr
public:
XdsSearchAttr^ newSearchAttr(
    String^ attrName
)
member newSearchAttr :
        attrName : string -> XdsSearchAttr

Parameters

attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xds.XdsQuery.newSearchAttr(System.String)"]

Return Value

Type: XdsSearchAttr
A new or existing <search-attr>.
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.newSearchClass Method

XdsQuerynewSearchClass Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsQuery.newSearchClass(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsSearchClass newSearchClass(
    string className
)
Public Function newSearchClass (
    className As String
) As XdsSearchClass
public:
XdsSearchClass^ newSearchClass(
    String^ className
)
member newSearchClass :
        className : string -> XdsSearchClass

Parameters

className
Type: SystemString

[Missing <param name="className"/> documentation for "M:DXMLBase.Xds.XdsQuery.newSearchClass(System.String)"]

Return Value

Type: XdsSearchClass
A new or existing <search-class>
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery Properties

XdsQuery Properties

The XdsQuery type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | ReadAll |
Public property | ReadAttrNames |
Public property | ReadAttrs |
Public property | ReadNone |
Public property | ReadParent |
Public property | Scope |
Public property | SearchAttrs |
Public property | SearchClasses |
Public property | SearchClassNames |
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.ReadAll Property

XdsQueryReadAll Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.ReadAll"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadAll { get; set; }
Public Property ReadAll As Boolean
    Get
    Set
public:
property bool ReadAll {
    bool get ();
    void set (bool value);
}
member ReadAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.ReadAttrNames Property

XdsQueryReadAttrNames Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.ReadAttrNames"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ReadAttrNames { get; }
Public ReadOnly Property ReadAttrNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ ReadAttrNames {
    IEnumerable<String^>^ get ();
}
member ReadAttrNames : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.ReadAttrs Property

XdsQueryReadAttrs Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.ReadAttrs"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsReadAttr> ReadAttrs { get; }
Public ReadOnly Property ReadAttrs As IEnumerable(Of XdsReadAttr)
    Get
public:
property IEnumerable<XdsReadAttr^>^ ReadAttrs {
    IEnumerable<XdsReadAttr^>^ get ();
}
member ReadAttrs : IEnumerable<XdsReadAttr> with get

Property Value

Type: IEnumerable XdsReadAttr
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.ReadNone Property

XdsQueryReadNone Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.ReadNone"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadNone { get; set; }
Public Property ReadNone As Boolean
    Get
    Set
public:
property bool ReadNone {
    bool get ();
    void set (bool value);
}
member ReadNone : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.ReadParent Property

XdsQueryReadParent Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.ReadParent"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadParent { get; set; }
Public Property ReadParent As Boolean
    Get
    Set
public:
property bool ReadParent {
    bool get ();
    void set (bool value);
}
member ReadParent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.Scope Property

XdsQueryScope Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.Scope"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsQueryScopeValue Scope { get; set; }
Public Property Scope As XdsQueryScopeValue
    Get
    Set
public:
property XdsQueryScopeValue Scope {
    XdsQueryScopeValue get ();
    void set (XdsQueryScopeValue value);
}
member Scope : XdsQueryScopeValue with get, set

Property Value

Type: XdsQueryScopeValue
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.SearchAttrs Property

XdsQuerySearchAttrs Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.SearchAttrs"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsSearchAttr> SearchAttrs { get; }
Public ReadOnly Property SearchAttrs As IEnumerable(Of XdsSearchAttr)
    Get
public:
property IEnumerable<XdsSearchAttr^>^ SearchAttrs {
    IEnumerable<XdsSearchAttr^>^ get ();
}
member SearchAttrs : IEnumerable<XdsSearchAttr> with get

Property Value

Type: IEnumerable XdsSearchAttr
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.SearchClasses Property

XdsQuerySearchClasses Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.SearchClasses"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsSearchClass> SearchClasses { get; }
Public ReadOnly Property SearchClasses As IEnumerable(Of XdsSearchClass)
    Get
public:
property IEnumerable<XdsSearchClass^>^ SearchClasses {
    IEnumerable<XdsSearchClass^>^ get ();
}
member SearchClasses : IEnumerable<XdsSearchClass> with get

Property Value

Type: IEnumerable XdsSearchClass
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.SearchClassNames Property

XdsQuerySearchClassNames Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsQuery.SearchClassNames"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> SearchClassNames { get; }
Public ReadOnly Property SearchClassNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ SearchClassNames {
    IEnumerable<String^>^ get ();
}
member SearchClassNames : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

XdsQuery Class
DXMLBase.Xds Namespace


XdsQuery.ScopeValue Enumeration

XdsQueryScopeValue Enumeration

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsQuery.ScopeValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScopeValue
Public Enumeration ScopeValue
public enum class ScopeValue
type ScopeValue
Members
Member name | Value | Description
Entry | 0 |
Subordinates | 1 |
Subtree | 2 |
See Also

Reference

DXMLBase.Xds Namespace


XdsQuerySchema Class

XdsQuerySchema Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsQuerySchema"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsQuerySchema

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsQuerySchema : XdsOperation
Public Class XdsQuerySchema
    Inherits XdsOperation
public ref class XdsQuerySchema : public XdsOperation
type XdsQuerySchema =
    class
        inherit XdsOperation
    end

The XdsQuerySchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsQuerySchema Methods

XdsQuerySchema Methods

The XdsQuerySchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsQuerySchema Class
DXMLBase.Xds Namespace


XdsQuerySchema Properties

XdsQuerySchema Properties

The XdsQuerySchema type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsQuerySchema Class
DXMLBase.Xds Namespace


XdsReadAttr Class

XdsReadAttr Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsReadAttr"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsReadAttr

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsReadAttr : XdsValueParent
Public Class XdsReadAttr
    Inherits XdsValueParent
public ref class XdsReadAttr : public XdsValueParent
type XdsReadAttr =
    class
        inherit XdsValueParent
    end

The XdsReadAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AttrName |
Public property | IsReadNone |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Type |
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsReadAttr Methods

XdsReadAttr Methods

The XdsReadAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsReadAttr Class
DXMLBase.Xds Namespace


XdsReadAttr Properties

XdsReadAttr Properties

The XdsReadAttr type exposes the following members.

Properties
 | Name | Description
Public property | AttrName |
Public property | IsReadNone |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Type |
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsReadAttr Class
DXMLBase.Xds Namespace


XdsReadAttr.AttrName Property

XdsReadAttrAttrName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsReadAttr.AttrName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Property Value

Type: String
See Also

Reference

XdsReadAttr Class
DXMLBase.Xds Namespace


XdsReadAttr.IsReadNone Property

XdsReadAttrIsReadNone Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsReadAttr.IsReadNone"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadNone { get; }
Public ReadOnly Property IsReadNone As Boolean
    Get
public:
property bool IsReadNone {
    bool get ();
}
member IsReadNone : bool with get

Property Value

Type: Boolean
See Also

Reference

XdsReadAttr Class
DXMLBase.Xds Namespace


XdsReadAttr.Type Property

XdsReadAttrType Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsReadAttr.Type"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

XdsReadAttr Class
DXMLBase.Xds Namespace


XdsReferentialValue Class

XdsReferentialValue Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsReferentialValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsReferentialValue

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsReferentialValue
Public Class XdsReferentialValue
public ref class XdsReferentialValue
type XdsReferentialValue =  class end

The XdsReferentialValue type exposes the following members.

Constructors
 | Name | Description
Public method | XdsReferentialValue(String) | Initializes a new instance of the XdsReferentialValue class
Public method | XdsReferentialValue(String, String) | Initializes a new instance of the XdsReferentialValue class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToNormalizedString |
Public method | ToString | (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Association |
Public property | ObjectName |
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsReferentialValue Constructor

XdsReferentialValue Constructor
Overload List
 | Name | Description
Public method | XdsReferentialValue(String) | Initializes a new instance of the XdsReferentialValue class
Public method | XdsReferentialValue(String, String) | Initializes a new instance of the XdsReferentialValue class
Top
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsReferentialValue Constructor (String)

XdsReferentialValue Constructor (String)
Initializes a new instance of the XdsReferentialValue class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsReferentialValue(
    string value
)
Public Sub New (
    value As String
)
public:
XdsReferentialValue(
    String^ value
)
new :
        value : string -> XdsReferentialValue

Parameters

value
Type: SystemString
The delimited value.
See Also

Reference

XdsReferentialValue Class
XdsReferentialValue Overload
DXMLBase.Xds Namespace


XdsReferentialValue Constructor (String, String)

XdsReferentialValue Constructor (String, String)
Initializes a new instance of the XdsReferentialValue class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsReferentialValue(
    string association,
    string objectName
)
Public Sub New (
    association As String,
    objectName As String
)
public:
XdsReferentialValue(
    String^ association,
    String^ objectName
)
new :
        association : string *
        objectName : string -> XdsReferentialValue

Parameters

association
Type: SystemString

[Missing <param name="association"/> documentation for "M:DXMLBase.Xds.XdsReferentialValue.#ctor(System.String,System.String)"]

objectName
Type: SystemString
The object name or DN.
See Also

Reference

XdsReferentialValue Class
XdsReferentialValue Overload
DXMLBase.Xds Namespace


XdsReferentialValue Methods

XdsReferentialValue Methods

The XdsReferentialValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToNormalizedString |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsReferentialValue.ToNormalizedString Method

XdsReferentialValueToNormalizedString Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsReferentialValue.ToNormalizedString"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ToNormalizedString()
Public Function ToNormalizedString As String
public:
String^ ToNormalizedString()
member ToNormalizedString : unit -> string

Return Value

Type: String
A normalized referential value string.
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsReferentialValue.ToString Method

XdsReferentialValueToString Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsReferentialValue.ToString"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A delimited string.
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsReferentialValue Properties

XdsReferentialValue Properties

The XdsReferentialValue type exposes the following members.

Properties
 | Name | Description
Public property | Association |
Public property | ObjectName |
Top
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsReferentialValue.Association Property

XdsReferentialValueAssociation Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsReferentialValue.Association"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Association { get; set; }
Public Property Association As String
    Get
    Set
public:
property String^ Association {
    String^ get ();
    void set (String^ value);
}
member Association : string with get, set

Property Value

Type: String
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsReferentialValue.ObjectName Property

XdsReferentialValueObjectName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsReferentialValue.ObjectName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ObjectName { get; set; }
Public Property ObjectName As String
    Get
    Set
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}
member ObjectName : string with get, set

Property Value

Type: String
See Also

Reference

XdsReferentialValue Class
DXMLBase.Xds Namespace


XdsRemoveAllValues Class

XdsRemoveAllValues Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsRemoveAllValues"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsRemoveAllValues

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsRemoveAllValues : XdsElement
Public Class XdsRemoveAllValues
    Inherits XdsElement
public ref class XdsRemoveAllValues : public XdsElement
type XdsRemoveAllValues =
    class
        inherit XdsElement
    end

The XdsRemoveAllValues type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsRemoveAllValues Methods

XdsRemoveAllValues Methods

The XdsRemoveAllValues type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsRemoveAllValues Class
DXMLBase.Xds Namespace


XdsRemoveAllValues Properties

XdsRemoveAllValues Properties

The XdsRemoveAllValues type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsRemoveAllValues Class
DXMLBase.Xds Namespace


XdsRemoveValue Class

XdsRemoveValue Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsRemoveValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsRemoveValue

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsRemoveValue : XdsValueParent
Public Class XdsRemoveValue
    Inherits XdsValueParent
public ref class XdsRemoveValue : public XdsValueParent
type XdsRemoveValue =
    class
        inherit XdsValueParent
    end

The XdsRemoveValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsRemoveValue Methods

XdsRemoveValue Methods

The XdsRemoveValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsRemoveValue Class
DXMLBase.Xds Namespace


XdsRemoveValue Properties

XdsRemoveValue Properties

The XdsRemoveValue type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsRemoveValue Class
DXMLBase.Xds Namespace


XdsRename Class

XdsRename Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsRename"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsOperation
DXMLBase.XdsXdsRename

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsRename : XdsOperation
Public Class XdsRename
    Inherits XdsOperation
public ref class XdsRename : public XdsOperation
type XdsRename =
    class
        inherit XdsOperation
    end

The XdsRename type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | NewName |
Public property | OldSrcDN |
Public property | QualifiedOldSrcDN |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | RemoveOldName |
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsRename Methods

XdsRename Methods

The XdsRename type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsRename Class
DXMLBase.Xds Namespace


XdsRename Properties

XdsRename Properties

The XdsRename type exposes the following members.

Properties
 | Name | Description
Public property | Association | (Inherited from XdsOperation.)
Public property | ClassName | (Inherited from XdsOperation.)
Public property | DestDN | (Inherited from XdsOperation.)
Public property | EventID | (Inherited from XdsOperation.)
Public property | Name | (Inherited from XdsElement.)
Public property | NewName |
Public property | OldSrcDN |
Public property | QualifiedOldSrcDN |
Public property | QualifiedSrcDN | (Inherited from XdsOperation.)
Public property | RemoveOldName |
Public property | SrcDN | (Inherited from XdsOperation.)
Public property | SrcEntryID | (Inherited from XdsOperation.)
Public property | Type | (Inherited from XdsOperation.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsRename Class
DXMLBase.Xds Namespace


XdsRename.NewName Property

XdsRenameNewName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsRename.NewName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NewName { get; set; }
Public Property NewName As String
    Get
    Set
public:
property String^ NewName {
    String^ get ();
    void set (String^ value);
}
member NewName : string with get, set

Property Value

Type: String
See Also

Reference

XdsRename Class
DXMLBase.Xds Namespace


XdsRename.OldSrcDN Property

XdsRenameOldSrcDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsRename.OldSrcDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OldSrcDN { get; set; }
Public Property OldSrcDN As String
    Get
    Set
public:
property String^ OldSrcDN {
    String^ get ();
    void set (String^ value);
}
member OldSrcDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsRename Class
DXMLBase.Xds Namespace


XdsRename.QualifiedOldSrcDN Property

XdsRenameQualifiedOldSrcDN Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsRename.QualifiedOldSrcDN"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string QualifiedOldSrcDN { get; set; }
Public Property QualifiedOldSrcDN As String
    Get
    Set
public:
property String^ QualifiedOldSrcDN {
    String^ get ();
    void set (String^ value);
}
member QualifiedOldSrcDN : string with get, set

Property Value

Type: String
See Also

Reference

XdsRename Class
DXMLBase.Xds Namespace


XdsRename.RemoveOldName Property

XdsRenameRemoveOldName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsRename.RemoveOldName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveOldName { get; set; }
Public Property RemoveOldName As Boolean
    Get
    Set
public:
property bool RemoveOldName {
    bool get ();
    void set (bool value);
}
member RemoveOldName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XdsRename Class
DXMLBase.Xds Namespace


XdsRetryException Class

XdsRetryException Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsRetryException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.XdsXdsStatusException
DXMLBase.XdsXdsRetryException

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsRetryException : XdsStatusException
Public Class XdsRetryException
    Inherits XdsStatusException
public ref class XdsRetryException : public XdsStatusException
type XdsRetryException =
    class
        inherit XdsStatusException
    end

The XdsRetryException type exposes the following members.

Constructors
 | Name | Description
Public method | XdsRetryException(String) | Initializes a new instance of the XdsRetryException class
Public method | XdsRetryException(String, Exception) | Initializes a new instance of the XdsRetryException class
Top
Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsRetryException Constructor

XdsRetryException Constructor
Overload List
 | Name | Description
Public method | XdsRetryException(String) | Initializes a new instance of the XdsRetryException class
Public method | XdsRetryException(String, Exception) | Initializes a new instance of the XdsRetryException class
Top
See Also

Reference

XdsRetryException Class
DXMLBase.Xds Namespace


XdsRetryException Constructor (String)

XdsRetryException Constructor (String)
Initializes a new instance of the XdsRetryException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsRetryException(
    string message
)
Public Sub New (
    message As String
)
public:
XdsRetryException(
    String^ message
)
new :
        message : string -> XdsRetryException

Parameters

message
Type: SystemString
The message.
See Also

Reference

XdsRetryException Class
XdsRetryException Overload
DXMLBase.Xds Namespace


XdsRetryException Constructor (String, Exception)

XdsRetryException Constructor (String, Exception)
Initializes a new instance of the XdsRetryException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsRetryException(
    string message,
    Exception cause
)
Public Sub New (
    message As String,
    cause As Exception
)
public:
XdsRetryException(
    String^ message,
    Exception^ cause
)
new :
        message : string *
        cause : Exception -> XdsRetryException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Xds.XdsRetryException.#ctor(System.String,System.Exception)"]

cause
Type: SystemException
The underlying exception.
See Also

Reference

XdsRetryException Class
XdsRetryException Overload
DXMLBase.Xds Namespace


XdsRetryException Methods

XdsRetryException Methods

The XdsRetryException type exposes the following members.

Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsRetryException Class
DXMLBase.Xds Namespace


XdsRetryException Properties

XdsRetryException Properties

The XdsRetryException type exposes the following members.

Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsRetryException Class
DXMLBase.Xds Namespace


XdsRetryException Events

XdsRetryException Events

The XdsRetryException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

XdsRetryException Class
DXMLBase.Xds Namespace


XdsSearchAttr Class

XdsSearchAttr Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsSearchAttr"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsSearchAttr

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsSearchAttr : XdsValueParent
Public Class XdsSearchAttr
    Inherits XdsValueParent
public ref class XdsSearchAttr : public XdsValueParent
type XdsSearchAttr =
    class
        inherit XdsValueParent
    end

The XdsSearchAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsSearchAttr Methods

XdsSearchAttr Methods

The XdsSearchAttr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue | (Inherited from XdsValueParent.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsSearchAttr Class
DXMLBase.Xds Namespace


XdsSearchAttr Properties

XdsSearchAttr Properties

The XdsSearchAttr type exposes the following members.

Properties
 | Name | Description
Public property | AttrName |
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues | (Inherited from XdsValueParent.)
Public property | Values | (Inherited from XdsValueParent.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsSearchAttr Class
DXMLBase.Xds Namespace


XdsSearchAttr.AttrName Property

XdsSearchAttrAttrName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsSearchAttr.AttrName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Property Value

Type: String
See Also

Reference

XdsSearchAttr Class
DXMLBase.Xds Namespace


XdsSearchClass Class

XdsSearchClass Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsSearchClass"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsSearchClass

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsSearchClass : XdsElement
Public Class XdsSearchClass
    Inherits XdsElement
public ref class XdsSearchClass : public XdsElement
type XdsSearchClass =
    class
        inherit XdsElement
    end

The XdsSearchClass type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ClassName |
Public property | Name | (Inherited from XdsElement.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsSearchClass Methods

XdsSearchClass Methods

The XdsSearchClass type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsSearchClass Class
DXMLBase.Xds Namespace


XdsSearchClass Properties

XdsSearchClass Properties

The XdsSearchClass type exposes the following members.

Properties
 | Name | Description
Public property | ClassName |
Public property | Name | (Inherited from XdsElement.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsSearchClass Class
DXMLBase.Xds Namespace


XdsSearchClass.ClassName Property

XdsSearchClassClassName Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsSearchClass.ClassName"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
See Also

Reference

XdsSearchClass Class
DXMLBase.Xds Namespace


XdsShimOptions Class

XdsShimOptions Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsShimOptions"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsShimOptions
DXMLBase.XdsXdsDriverOptions
DXMLBase.XdsXdsPublisherOptions
DXMLBase.XdsXdsSubscriberOptions

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsShimOptions : XdsElement
Public Class XdsShimOptions
    Inherits XdsElement
public ref class XdsShimOptions : public XdsElement
type XdsShimOptions =
    class
        inherit XdsElement
    end

The XdsShimOptions type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsShimOptions | Initializes a new instance of the XdsShimOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsShimOptions Constructor

XdsShimOptions Constructor
Initializes a new instance of the XdsShimOptions class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsShimOptions(
    XmlElement xdsOptionsElement
)
Protected Sub New (
    xdsOptionsElement As XmlElement
)
protected:
XdsShimOptions(
    XmlElement^ xdsOptionsElement
)
new :
        xdsOptionsElement : XmlElement -> XdsShimOptions

Parameters

xdsOptionsElement
Type: System.XmlXmlElement

[Missing <param name="xdsOptionsElement"/> documentation for "M:DXMLBase.Xds.XdsShimOptions.#ctor(System.Xml.XmlElement)"]

See Also

Reference

XdsShimOptions Class
DXMLBase.Xds Namespace


XdsShimOptions Methods

XdsShimOptions Methods

The XdsShimOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsShimOptions Class
DXMLBase.Xds Namespace


XdsShimOptions Properties

XdsShimOptions Properties

The XdsShimOptions type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsShimOptions Class
DXMLBase.Xds Namespace


XdsShimOptions.ShimParams Property

XdsShimOptionsShimParams Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsShimOptions.ShimParams"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShimParams ShimParams { get; }
Public ReadOnly Property ShimParams As ShimParams
    Get
public:
property ShimParams^ ShimParams {
    ShimParams^ get ();
}
member ShimParams : ShimParams with get

Property Value

Type: ShimParams
See Also

Reference

XdsShimOptions Class
DXMLBase.Xds Namespace


XdsStatus Class

XdsStatus Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsStatus"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsStatus

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsStatus : XdsElement
Public Class XdsStatus
    Inherits XdsElement
public ref class XdsStatus : public XdsElement
type XdsStatus =
    class
        inherit XdsElement
    end

The XdsStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Info |
Public property | Name | (Inherited from XdsElement.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsStatus Methods

XdsStatus Methods

The XdsStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsStatus Class
DXMLBase.Xds Namespace


XdsStatus Properties

XdsStatus Properties

The XdsStatus type exposes the following members.

Properties
 | Name | Description
Public property | Info |
Public property | Name | (Inherited from XdsElement.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsStatus Class
DXMLBase.Xds Namespace


XdsStatus.Info Property

XdsStatusInfo Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatus.Info"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReport Info { get; set; }
Public Property Info As XdsStatusReport
    Get
    Set
public:
property XdsStatusReport^ Info {
    XdsStatusReport^ get ();
    void set (XdsStatusReport^ value);
}
member Info : XdsStatusReport with get, set

Property Value

Type: XdsStatusReport
See Also

Reference

XdsStatus Class
DXMLBase.Xds Namespace


XdsStatusException Class

XdsStatusException Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsStatusException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.XdsXdsStatusException
DXMLBase.XdsXdsErrorException
DXMLBase.XdsXdsFatalException
DXMLBase.XdsXdsRetryException
DXMLBase.XdsXdsWarningException

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class XdsStatusException : Exception
Public MustInherit Class XdsStatusException
    Inherits Exception
public ref class XdsStatusException abstract : public Exception
[<AbstractClassAttribute>]
type XdsStatusException =
    class
        inherit Exception
    end

The XdsStatusException type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsStatusException(XdsStatusReportLevelValue, String) | Initializes a new instance of the XdsStatusException class
Protected method | XdsStatusException(XdsStatusReportLevelValue, String, Exception) | Initializes a new instance of the XdsStatusException class
Top
Methods
 | Name | Description
Public method | addToChain |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Chain |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level |
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsStatusException Constructor

XdsStatusException Constructor
Overload List
 | Name | Description
Protected method | XdsStatusException(XdsStatusReportLevelValue, String) | Initializes a new instance of the XdsStatusException class
Protected method | XdsStatusException(XdsStatusReportLevelValue, String, Exception) | Initializes a new instance of the XdsStatusException class
Top
See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusException Constructor (XdsStatusReport.LevelValue, String)

XdsStatusException Constructor (XdsStatusReportLevelValue, String)
Initializes a new instance of the XdsStatusException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsStatusException(
    XdsStatusReportLevelValue level,
    string message
)
Protected Sub New (
    level As XdsStatusReportLevelValue,
    message As String
)
protected:
XdsStatusException(
    XdsStatusReportLevelValue level,
    String^ message
)
new :
        level : XdsStatusReportLevelValue *
        message : string -> XdsStatusException

Parameters

level
Type: DXMLBase.XdsXdsStatusReportLevelValue

[Missing <param name="level"/> documentation for "M:DXMLBase.Xds.XdsStatusException.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.String)"]

message
Type: SystemString
The message
See Also

Reference

XdsStatusException Class
XdsStatusException Overload
DXMLBase.Xds Namespace


XdsStatusException Constructor (XdsStatusReport.LevelValue, String, Exception)

XdsStatusException Constructor (XdsStatusReportLevelValue, String, Exception)
Initializes a new instance of the XdsStatusException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsStatusException(
    XdsStatusReportLevelValue level,
    string message,
    Exception cause
)
Protected Sub New (
    level As XdsStatusReportLevelValue,
    message As String,
    cause As Exception
)
protected:
XdsStatusException(
    XdsStatusReportLevelValue level,
    String^ message,
    Exception^ cause
)
new :
        level : XdsStatusReportLevelValue *
        message : string *
        cause : Exception -> XdsStatusException

Parameters

level
Type: DXMLBase.XdsXdsStatusReportLevelValue

[Missing <param name="level"/> documentation for "M:DXMLBase.Xds.XdsStatusException.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.String,System.Exception)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Xds.XdsStatusException.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.String,System.Exception)"]

cause
Type: SystemException
The exception that is the reason this instance is being thrown.
See Also

Reference

XdsStatusException Class
XdsStatusException Overload
DXMLBase.Xds Namespace


XdsStatusException Methods

XdsStatusException Methods

The XdsStatusException type exposes the following members.

Methods
 | Name | Description
Public method | addToChain |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusException.addToChain Method

XdsStatusExceptionaddToChain Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsStatusException.addToChain(DXMLBase.Xds.XdsStatusException)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void addToChain(
    XdsStatusException end
)
Public Sub addToChain (
    end As XdsStatusException
)
public:
void addToChain(
    XdsStatusException^ end
)
member addToChain :
        end : XdsStatusException -> unit

Parameters

end
Type: DXMLBase.XdsXdsStatusException

[Missing <param name="end"/> documentation for "M:DXMLBase.Xds.XdsStatusException.addToChain(DXMLBase.Xds.XdsStatusException)"]

See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusException Properties

XdsStatusException Properties

The XdsStatusException type exposes the following members.

Properties
 | Name | Description
Public property | Chain |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level |
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusException.Chain Property

XdsStatusExceptionChain Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusException.Chain"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsStatusException> Chain { get; }
Public ReadOnly Property Chain As IEnumerable(Of XdsStatusException)
    Get
public:
property IEnumerable<XdsStatusException^>^ Chain {
    IEnumerable<XdsStatusException^>^ get ();
}
member Chain : IEnumerable<XdsStatusException> with get

Return Value

Type: IEnumerable XdsStatusException
An enumerator.
See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusException.Level Property

XdsStatusExceptionLevel Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusException.Level"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReportLevelValue Level { get; }
Public ReadOnly Property Level As XdsStatusReportLevelValue
    Get
public:
property XdsStatusReportLevelValue Level {
    XdsStatusReportLevelValue get ();
}
member Level : XdsStatusReportLevelValue with get

Property Value

Type: XdsStatusReportLevelValue
See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusException Events

XdsStatusException Events

The XdsStatusException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

XdsStatusException Class
DXMLBase.Xds Namespace


XdsStatusReport Class

XdsStatusReport Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsStatusReport"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsStatusReport

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsStatusReport
Public Class XdsStatusReport
public ref class XdsStatusReport
type XdsStatusReport =  class end

The XdsStatusReport type exposes the following members.

Constructors
 | Name | Description
Public method | XdsStatusReport(XmlElement) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(Exception, String, String) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(XdsStatusReportLevelValue, Exception, String, String) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(XdsStatusReportLevelValue, String, String, String) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(XdsStatusReportLevelValue, XmlNode, String, String) | Initializes a new instance of the XdsStatusReport class
Top
Methods
 | Name | Description
Public method | addToChain |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | levelToString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | stringToLevel |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml |
Top
Fields
Name | Description
SUCCESS |
TAG_EXCEPTION_TYPE |
TAG_MESSAGE |
TAG_STACK_TRACE |
Top
Properties
 | Name | Description
Public property | Chain |
Public property | Content |
Public property | EventID |
Public property | Level |
Public property | LevelString |
Public property | Message |
Public property | Type |
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsStatusReport Constructor

XdsStatusReport Constructor
Overload List
 | Name | Description
Public method | XdsStatusReport(XmlElement) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(Exception, String, String) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(XdsStatusReportLevelValue, Exception, String, String) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(XdsStatusReportLevelValue, String, String, String) | Initializes a new instance of the XdsStatusReport class
Public method | XdsStatusReport(XdsStatusReportLevelValue, XmlNode, String, String) | Initializes a new instance of the XdsStatusReport class
Top
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport Constructor (XmlElement)

XdsStatusReport Constructor (XmlElement)
Initializes a new instance of the XdsStatusReport class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReport(
    XmlElement statusElement
)
Public Sub New (
    statusElement As XmlElement
)
public:
XdsStatusReport(
    XmlElement^ statusElement
)
new :
        statusElement : XmlElement -> XdsStatusReport

Parameters

statusElement
Type: System.XmlXmlElement

[Missing <param name="statusElement"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(System.Xml.XmlElement)"]

Exceptions
Exception | Condition
ArgumentException | Thrown if the passed element isn't a status element.
See Also

Reference

XdsStatusReport Class
XdsStatusReport Overload
DXMLBase.Xds Namespace


XdsStatusReport Constructor (Exception, String, String)

XdsStatusReport Constructor (Exception, String, String)
Initializes a new instance of the XdsStatusReport class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReport(
    Exception exception,
    string eventID,
    string type
)
Public Sub New (
    exception As Exception,
    eventID As String,
    type As String
)
public:
XdsStatusReport(
    Exception^ exception,
    String^ eventID,
    String^ type
)
new :
        exception : Exception *
        eventID : string *
        type : string -> XdsStatusReport

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(System.Exception,System.String,System.String)"]

eventID
Type: SystemString

[Missing <param name="eventID"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(System.Exception,System.String,System.String)"]

type
Type: SystemString

[Missing <param name="type"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(System.Exception,System.String,System.String)"]

See Also

Reference

XdsStatusReport Class
XdsStatusReport Overload
DXMLBase.Xds Namespace


XdsStatusReport Constructor (XdsStatusReport.LevelValue, Exception, String, String)

XdsStatusReport Constructor (XdsStatusReportLevelValue, Exception, String, String)
Initializes a new instance of the XdsStatusReport class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReport(
    XdsStatusReportLevelValue level,
    Exception exception,
    string eventID,
    string type
)
Public Sub New (
    level As XdsStatusReportLevelValue,
    exception As Exception,
    eventID As String,
    type As String
)
public:
XdsStatusReport(
    XdsStatusReportLevelValue level,
    Exception^ exception,
    String^ eventID,
    String^ type
)
new :
        level : XdsStatusReportLevelValue *
        exception : Exception *
        eventID : string *
        type : string -> XdsStatusReport

Parameters

level
Type: DXMLBase.XdsXdsStatusReportLevelValue

[Missing <param name="level"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.Exception,System.String,System.String)"]

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.Exception,System.String,System.String)"]

eventID
Type: SystemString

[Missing <param name="eventID"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.Exception,System.String,System.String)"]

type
Type: SystemString
The type value for the status. May be null.
See Also

Reference

XdsStatusReport Class
XdsStatusReport Overload
DXMLBase.Xds Namespace


XdsStatusReport Constructor (XdsStatusReport.LevelValue, String, String, String)

XdsStatusReport Constructor (XdsStatusReportLevelValue, String, String, String)
Initializes a new instance of the XdsStatusReport class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReport(
    XdsStatusReportLevelValue level,
    string message,
    string eventID,
    string type
)
Public Sub New (
    level As XdsStatusReportLevelValue,
    message As String,
    eventID As String,
    type As String
)
public:
XdsStatusReport(
    XdsStatusReportLevelValue level,
    String^ message,
    String^ eventID,
    String^ type
)
new :
        level : XdsStatusReportLevelValue *
        message : string *
        eventID : string *
        type : string -> XdsStatusReport

Parameters

level
Type: DXMLBase.XdsXdsStatusReportLevelValue

[Missing <param name="level"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.String,System.String,System.String)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.String,System.String,System.String)"]

eventID
Type: SystemString

[Missing <param name="eventID"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.String,System.String,System.String)"]

type
Type: SystemString
The type value for the status. May be null.
See Also

Reference

XdsStatusReport Class
XdsStatusReport Overload
DXMLBase.Xds Namespace


XdsStatusReport Constructor (XdsStatusReport.LevelValue, XmlNode, String, String)

XdsStatusReport Constructor (XdsStatusReportLevelValue, XmlNode, String, String)
Initializes a new instance of the XdsStatusReport class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReport(
    XdsStatusReportLevelValue level,
    XmlNode content,
    string eventID,
    string type
)
Public Sub New (
    level As XdsStatusReportLevelValue,
    content As XmlNode,
    eventID As String,
    type As String
)
public:
XdsStatusReport(
    XdsStatusReportLevelValue level,
    XmlNode^ content,
    String^ eventID,
    String^ type
)
new :
        level : XdsStatusReportLevelValue *
        content : XmlNode *
        eventID : string *
        type : string -> XdsStatusReport

Parameters

level
Type: DXMLBase.XdsXdsStatusReportLevelValue

[Missing <param name="level"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.Xml.XmlNode,System.String,System.String)"]

content
Type: System.XmlXmlNode

[Missing <param name="content"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.Xml.XmlNode,System.String,System.String)"]

eventID
Type: SystemString

[Missing <param name="eventID"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.#ctor(DXMLBase.Xds.XdsStatusReport.LevelValue,System.Xml.XmlNode,System.String,System.String)"]

type
Type: SystemString
The type value for the status. May be null.
See Also

Reference

XdsStatusReport Class
XdsStatusReport Overload
DXMLBase.Xds Namespace


XdsStatusReport Fields

XdsStatusReport Fields

The XdsStatusReport type exposes the following members.

Fields
Name | Description
SUCCESS |
TAG_EXCEPTION_TYPE |
TAG_MESSAGE |
TAG_STACK_TRACE |
Top
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.SUCCESS Field

XdsStatusReportSUCCESS Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsStatusReport.SUCCESS"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly XdsStatusReport SUCCESS
Public Shared ReadOnly SUCCESS As XdsStatusReport
public:
static initonly XdsStatusReport^ SUCCESS
static val SUCCESS: XdsStatusReport

Field Value

Type: XdsStatusReport
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.TAG_EXCEPTION_TYPE Field

XdsStatusReportTAG_EXCEPTION_TYPE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsStatusReport.TAG_EXCEPTION_TYPE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_EXCEPTION_TYPE
Public Const TAG_EXCEPTION_TYPE As String
public:
literal String^ TAG_EXCEPTION_TYPE
static val mutable TAG_EXCEPTION_TYPE: string

Field Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.TAG_MESSAGE Field

XdsStatusReportTAG_MESSAGE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsStatusReport.TAG_MESSAGE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_MESSAGE
Public Const TAG_MESSAGE As String
public:
literal String^ TAG_MESSAGE
static val mutable TAG_MESSAGE: string

Field Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.TAG_STACK_TRACE Field

XdsStatusReportTAG_STACK_TRACE Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsStatusReport.TAG_STACK_TRACE"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TAG_STACK_TRACE
Public Const TAG_STACK_TRACE As String
public:
literal String^ TAG_STACK_TRACE
static val mutable TAG_STACK_TRACE: string

Field Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport Methods

XdsStatusReport Methods

The XdsStatusReport type exposes the following members.

Methods
 | Name | Description
Public method | addToChain |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | levelToString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | stringToLevel |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | toXml |
Top
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.addToChain Method

XdsStatusReportaddToChain Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsStatusReport.addToChain(DXMLBase.Xds.XdsStatusReport)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void addToChain(
    XdsStatusReport end
)
Public Sub addToChain (
    end As XdsStatusReport
)
public:
void addToChain(
    XdsStatusReport^ end
)
member addToChain :
        end : XdsStatusReport -> unit

Parameters

end
Type: DXMLBase.XdsXdsStatusReport

[Missing <param name="end"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.addToChain(DXMLBase.Xds.XdsStatusReport)"]

See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.levelToString Method

XdsStatusReportlevelToString Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsStatusReport.levelToString(DXMLBase.Xds.XdsStatusReport.LevelValue)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string levelToString(
    XdsStatusReportLevelValue level
)
Public Shared Function levelToString (
    level As XdsStatusReportLevelValue
) As String
public:
static String^ levelToString(
    XdsStatusReportLevelValue level
)
static member levelToString :
        level : XdsStatusReportLevelValue -> string

Parameters

level
Type: DXMLBase.XdsXdsStatusReportLevelValue

[Missing <param name="level"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.levelToString(DXMLBase.Xds.XdsStatusReport.LevelValue)"]

Return Value

Type: String
The string value.
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.stringToLevel Method

XdsStatusReportstringToLevel Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsStatusReport.stringToLevel(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XdsStatusReportLevelValue stringToLevel(
    string levelString
)
Public Shared Function stringToLevel (
    levelString As String
) As XdsStatusReportLevelValue
public:
static XdsStatusReportLevelValue stringToLevel(
    String^ levelString
)
static member stringToLevel :
        levelString : string -> XdsStatusReportLevelValue

Parameters

levelString
Type: SystemString

[Missing <param name="levelString"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.stringToLevel(System.String)"]

Return Value

Type: XdsStatusReportLevelValue

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsStatusReport.stringToLevel(System.String)"]

See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.toXml Method

XdsStatusReporttoXml Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsStatusReport.toXml(System.Xml.XmlDocument)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlElement toXml(
    XmlDocument document
)
Public Function toXml (
    document As XmlDocument
) As XmlElement
public:
XmlElement^ toXml(
    XmlDocument^ document
)
member toXml :
        document : XmlDocument -> XmlElement

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:DXMLBase.Xds.XdsStatusReport.toXml(System.Xml.XmlDocument)"]

Return Value

Type: XmlElement
The constructed <status> element.
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport Properties

XdsStatusReport Properties

The XdsStatusReport type exposes the following members.

Properties
 | Name | Description
Public property | Chain |
Public property | Content |
Public property | EventID |
Public property | Level |
Public property | LevelString |
Public property | Message |
Public property | Type |
Top
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.Chain Property

XdsStatusReportChain Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.Chain"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsStatusReport> Chain { get; }
Public ReadOnly Property Chain As IEnumerable(Of XdsStatusReport)
    Get
public:
property IEnumerable<XdsStatusReport^>^ Chain {
    IEnumerable<XdsStatusReport^>^ get ();
}
member Chain : IEnumerable<XdsStatusReport> with get

Property Value

Type: IEnumerable XdsStatusReport
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.Content Property

XdsStatusReportContent Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.Content"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlNode Content { get; set; }
Public Property Content As XmlNode
    Get
    Set
public:
property XmlNode^ Content {
    XmlNode^ get ();
    void set (XmlNode^ value);
}
member Content : XmlNode with get, set

Property Value

Type: XmlNode
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.EventID Property

XdsStatusReportEventID Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.EventID"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EventID { get; set; }
Public Property EventID As String
    Get
    Set
public:
property String^ EventID {
    String^ get ();
    void set (String^ value);
}
member EventID : string with get, set

Property Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.Level Property

XdsStatusReportLevel Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.Level"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsStatusReportLevelValue Level { get; set; }
Public Property Level As XdsStatusReportLevelValue
    Get
    Set
public:
property XdsStatusReportLevelValue Level {
    XdsStatusReportLevelValue get ();
    void set (XdsStatusReportLevelValue value);
}
member Level : XdsStatusReportLevelValue with get, set

Property Value

Type: XdsStatusReportLevelValue
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.LevelString Property

XdsStatusReportLevelString Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.LevelString"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LevelString { get; set; }
Public Property LevelString As String
    Get
    Set
public:
property String^ LevelString {
    String^ get ();
    void set (String^ value);
}
member LevelString : string with get, set

Property Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.Message Property

XdsStatusReportMessage Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.Message"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.Type Property

XdsStatusReportType Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsStatusReport.Type"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

XdsStatusReport Class
DXMLBase.Xds Namespace


XdsStatusReport.LevelValue Enumeration

XdsStatusReportLevelValue Enumeration

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsStatusReport.LevelValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LevelValue
Public Enumeration LevelValue
public enum class LevelValue
type LevelValue
Members
Member name | Value | Description
SUCCESS | 0 |
FATAL | 1 |
ERROR | 2 |
WARNING | 3 |
RETRY | 4 |
LEVEL_COUNT | 5 |
See Also

Reference

DXMLBase.Xds Namespace


XdsSubscriberOptions Class

XdsSubscriberOptions Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsSubscriberOptions"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsShimOptions
DXMLBase.XdsXdsSubscriberOptions

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsSubscriberOptions : XdsShimOptions
Public Class XdsSubscriberOptions
    Inherits XdsShimOptions
public ref class XdsSubscriberOptions : public XdsShimOptions
type XdsSubscriberOptions =
    class
        inherit XdsShimOptions
    end

The XdsSubscriberOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams | (Inherited from XdsShimOptions.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsSubscriberOptions Methods

XdsSubscriberOptions Methods

The XdsSubscriberOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsSubscriberOptions Class
DXMLBase.Xds Namespace


XdsSubscriberOptions Properties

XdsSubscriberOptions Properties

The XdsSubscriberOptions type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | ShimParams | (Inherited from XdsShimOptions.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsSubscriberOptions Class
DXMLBase.Xds Namespace


XdsUtil Class

XdsUtil Class
A collection of utility methods for dealing with the XDS vocabulary of XML.
Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsUtil

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class XdsUtil
Public NotInheritable Class XdsUtil
public ref class XdsUtil abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XdsUtil =  class end

The XdsUtil type exposes the following members.

Methods
Name | Description
appendNode | Append a node as a child of another node. If the target and source nodes do not have the same owner document then the source is imported into the target's document. If the source is an XmlDocumentFragment then the children of the source are each appended in order to the target.
getAssociation | Get the association value string of the first child <association> element (if any) of the passed parent element.
getAttr | Utility method that returns the attribute value from an element, or a default value if the attribute isn't set on the element
getChildElementsByTagName | Get an enumeration of all of the child elements of the passed parent which match the passed element name.
getFirstChildElementByTagName | Get the first child element of the passed parent node whose name matches that passed.
getFirstChildElementByTagNameWithAttrValue | Get the first child element of a node with a particular tag name and a particular attribute/value pair (value is case sensitive)
getNullAttribute | Get an XmlElement's attribute value, returning null if the attribute value is empty.
getValues |
removeAllChildren | Remove all of the child nodes of an XmlNode.
setAttr | Utility method that sets an attribute value on an element. Will clear any existing attribute if value is null, empty, or matches the default value.
setNonEmptyAttribute | Set an XML attribute on an element only if the attribute value is non-null and non-empty. Removes any existing attribute.
Top
Properties
Name | Description
NULL_NAMESPACE | A string representing the null, or empty namespace URI.
WILDCARD_NAME | A string representing any local name part.
WILDCARD_NAMESPACE | A string representing any namespaceURI (including the null or empty URI).
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsUtil Methods

XdsUtil Methods

The XdsUtil type exposes the following members.

Methods
Name | Description
appendNode | Append a node as a child of another node. If the target and source nodes do not have the same owner document then the source is imported into the target's document. If the source is an XmlDocumentFragment then the children of the source are each appended in order to the target.
getAssociation | Get the association value string of the first child <association> element (if any) of the passed parent element.
getAttr | Utility method that returns the attribute value from an element, or a default value if the attribute isn't set on the element
getChildElementsByTagName | Get an enumeration of all of the child elements of the passed parent which match the passed element name.
getFirstChildElementByTagName | Get the first child element of the passed parent node whose name matches that passed.
getFirstChildElementByTagNameWithAttrValue | Get the first child element of a node with a particular tag name and a particular attribute/value pair (value is case sensitive)
getNullAttribute | Get an XmlElement's attribute value, returning null if the attribute value is empty.
getValues |
removeAllChildren | Remove all of the child nodes of an XmlNode.
setAttr | Utility method that sets an attribute value on an element. Will clear any existing attribute if value is null, empty, or matches the default value.
setNonEmptyAttribute | Set an XML attribute on an element only if the attribute value is non-null and non-empty. Removes any existing attribute.
Top
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.appendNode Method

XdsUtilappendNode Method
Append a node as a child of another node. If the target and source nodes do not have the same owner document then the source is imported into the target's document. If the source is an XmlDocumentFragment then the children of the source are each appended in order to the target.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XmlNode appendNode(
    XmlNode target,
    XmlNode source
)
Public Shared Function appendNode (
    target As XmlNode,
    source As XmlNode
) As XmlNode
public:
static XmlNode^ appendNode(
    XmlNode^ target,
    XmlNode^ source
)
static member appendNode :
        target : XmlNode *
        source : XmlNode -> XmlNode

Parameters

target
Type: System.XmlXmlNode
The node to which to append to source node.
source
Type: System.XmlXmlNode
The node to append to the target node.

Return Value

Type: XmlNode
The first node that was appended.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getAssociation Method

XdsUtilgetAssociation Method
Get the association value string of the first child <association> element (if any) of the passed parent element.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getAssociation(
    XmlElement opElement
)
Public Shared Function getAssociation (
    opElement As XmlElement
) As String
public:
static String^ getAssociation(
    XmlElement^ opElement
)
static member getAssociation :
        opElement : XmlElement -> string

Parameters

opElement
Type: System.XmlXmlElement
The parent element containing the <association> element.

Return Value

Type: String
The association string value, or an empty string if there is no association.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getAttr Method

XdsUtilgetAttr Method
Utility method that returns the attribute value from an element, or a default value if the attribute isn't set on the element

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getAttr(
    XmlElement element,
    string attrName,
    string defaultValue
)
Public Shared Function getAttr (
    element As XmlElement,
    attrName As String,
    defaultValue As String
) As String
public:
static String^ getAttr(
    XmlElement^ element,
    String^ attrName,
    String^ defaultValue
)
static member getAttr :
        element : XmlElement *
        attrName : string *
        defaultValue : string -> string

Parameters

element
Type: System.XmlXmlElement

[Missing <param name="element"/> documentation for "M:DXMLBase.Xds.XdsUtil.getAttr(System.Xml.XmlElement,System.String,System.String)"]

attrName
Type: SystemString
The attribute name.
defaultValue
Type: SystemString
The default value for the attribute (may be empty, may not be null).

Return Value

Type: String
The attribute value if it exists on the operation element, otherwise the default value.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getChildElementsByTagName Method

XdsUtilgetChildElementsByTagName Method
Get an enumeration of all of the child elements of the passed parent which match the passed element name.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<XmlElement> getChildElementsByTagName(
    XmlNode parent,
    string namespaceURI,
    string tagName
)
Public Shared Function getChildElementsByTagName (
    parent As XmlNode,
    namespaceURI As String,
    tagName As String
) As IEnumerable(Of XmlElement)
public:
static IEnumerable<XmlElement^>^ getChildElementsByTagName(
    XmlNode^ parent,
    String^ namespaceURI,
    String^ tagName
)
static member getChildElementsByTagName :
        parent : XmlNode *
        namespaceURI : string *
        tagName : string -> IEnumerable<XmlElement>

Parameters

parent
Type: System.XmlXmlNode
The parent node.
namespaceURI
Type: SystemString
The namespace URI (may be NULL_NAMESPACE, WILDCARD_NAMESPACE, but may not be null).
tagName
Type: SystemString
The local part of the element name (may be WILDCARD_NAME, but may not be null).

Return Value

Type: IEnumerable XmlElement
A (possibly empty) enumeration of the matching child elements.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getFirstChildElementByTagName Method

XdsUtilgetFirstChildElementByTagName Method
Get the first child element of the passed parent node whose name matches that passed.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XmlElement getFirstChildElementByTagName(
    XmlNode parent,
    string namespaceURI,
    string tagName
)
Public Shared Function getFirstChildElementByTagName (
    parent As XmlNode,
    namespaceURI As String,
    tagName As String
) As XmlElement
public:
static XmlElement^ getFirstChildElementByTagName(
    XmlNode^ parent,
    String^ namespaceURI,
    String^ tagName
)
static member getFirstChildElementByTagName :
        parent : XmlNode *
        namespaceURI : string *
        tagName : string -> XmlElement

Parameters

parent
Type: System.XmlXmlNode
The parent node.
namespaceURI
Type: SystemString
The namespace URI (may be NULL_NAMESPACE, WILDCARD_NAMESPACE, but may not be null).
tagName
Type: SystemString
The local part of the element name (may be WILDCARD_NAME, but may not be null).

Return Value

Type: XmlElement
The first matching child element, or null if there is no such child element.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getFirstChildElementByTagNameWithAttrValue Method

XdsUtilgetFirstChildElementByTagNameWithAttrValue Method
Get the first child element of a node with a particular tag name and a particular attribute/value pair (value is case sensitive)

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XmlElement getFirstChildElementByTagNameWithAttrValue(
    XmlNode parentNode,
    string namespaceURI,
    string localPart,
    string attrNamespaceURI,
    string attrLocalPart,
    string attrValue
)
Public Shared Function getFirstChildElementByTagNameWithAttrValue (
    parentNode As XmlNode,
    namespaceURI As String,
    localPart As String,
    attrNamespaceURI As String,
    attrLocalPart As String,
    attrValue As String
) As XmlElement
public:
static XmlElement^ getFirstChildElementByTagNameWithAttrValue(
    XmlNode^ parentNode,
    String^ namespaceURI,
    String^ localPart,
    String^ attrNamespaceURI,
    String^ attrLocalPart,
    String^ attrValue
)
static member getFirstChildElementByTagNameWithAttrValue :
        parentNode : XmlNode *
        namespaceURI : string *
        localPart : string *
        attrNamespaceURI : string *
        attrLocalPart : string *
        attrValue : string -> XmlElement

Parameters

parentNode
Type: System.XmlXmlNode
the parent node
namespaceURI
Type: SystemString
the namespace URI of the qualified tag name
localPart
Type: SystemString
the local part of the qualified tag name
attrNamespaceURI
Type: SystemString
the namespace URI of the attribute's qualified name
attrLocalPart
Type: SystemString
the local part of the attribute's qualified name
attrValue
Type: SystemString
the attribute value

Return Value

Type: XmlElement
the first matching child element or null if no such element exists
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getNullAttribute Method

XdsUtilgetNullAttribute Method
Get an XmlElement's attribute value, returning null if the attribute value is empty.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getNullAttribute(
    XmlElement source,
    string attrName
)
Public Shared Function getNullAttribute (
    source As XmlElement,
    attrName As String
) As String
public:
static String^ getNullAttribute(
    XmlElement^ source,
    String^ attrName
)
static member getNullAttribute :
        source : XmlElement *
        attrName : string -> string

Parameters

source
Type: System.XmlXmlElement
The XmlElement containing the attribute.
attrName
Type: SystemString
The name of the attribute.

Return Value

Type: String
The non-empty attribute value, or null.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.getValues Method

XdsUtilgetValues Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsUtil.getValues(System.Xml.XmlElement)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] getValues(
    XmlElement valueParent
)
Public Shared Function getValues (
    valueParent As XmlElement
) As String()
public:
static array<String^>^ getValues(
    XmlElement^ valueParent
)
static member getValues :
        valueParent : XmlElement -> string[]

Parameters

valueParent
Type: System.XmlXmlElement

[Missing <param name="valueParent"/> documentation for "M:DXMLBase.Xds.XdsUtil.getValues(System.Xml.XmlElement)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsUtil.getValues(System.Xml.XmlElement)"]

See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.removeAllChildren Method

XdsUtilremoveAllChildren Method
Remove all of the child nodes of an XmlNode.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void removeAllChildren(
    XmlNode parent
)
Public Shared Sub removeAllChildren (
    parent As XmlNode
)
public:
static void removeAllChildren(
    XmlNode^ parent
)
static member removeAllChildren :
        parent : XmlNode -> unit

Parameters

parent
Type: System.XmlXmlNode
The node whose children are to be removed.
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.setAttr Method

XdsUtilsetAttr Method
Utility method that sets an attribute value on an element. Will clear any existing attribute if value is null, empty, or matches the default value.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void setAttr(
    XmlElement element,
    string attrName,
    string value,
    string defaultValue
)
Public Shared Sub setAttr (
    element As XmlElement,
    attrName As String,
    value As String,
    defaultValue As String
)
public:
static void setAttr(
    XmlElement^ element,
    String^ attrName,
    String^ value,
    String^ defaultValue
)
static member setAttr :
        element : XmlElement *
        attrName : string *
        value : string *
        defaultValue : string -> unit

Parameters

element
Type: System.XmlXmlElement

[Missing <param name="element"/> documentation for "M:DXMLBase.Xds.XdsUtil.setAttr(System.Xml.XmlElement,System.String,System.String,System.String)"]

attrName
Type: SystemString
The attribute value.
value
Type: SystemString
The value to set (may be null or empty)
defaultValue
Type: SystemString
The default value for the attribute (may be empty, may not be null).
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.setNonEmptyAttribute Method

XdsUtilsetNonEmptyAttribute Method
Set an XML attribute on an element only if the attribute value is non-null and non-empty. Removes any existing attribute.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool setNonEmptyAttribute(
    XmlElement target,
    string attrName,
    string attrValue
)
Public Shared Function setNonEmptyAttribute (
    target As XmlElement,
    attrName As String,
    attrValue As String
) As Boolean
public:
static bool setNonEmptyAttribute(
    XmlElement^ target,
    String^ attrName,
    String^ attrValue
)
static member setNonEmptyAttribute :
        target : XmlElement *
        attrName : string *
        attrValue : string -> bool

Parameters

target
Type: System.XmlXmlElement
Element to receive attribute
attrName
Type: SystemString
Name of the XML attribute
attrValue
Type: SystemString
Value of the XML attribute

Return Value

Type: Boolean
true if the attribute was set, false otherwise
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil Properties

XdsUtil Properties

The XdsUtil type exposes the following members.

Properties
Name | Description
NULL_NAMESPACE | A string representing the null, or empty namespace URI.
WILDCARD_NAME | A string representing any local name part.
WILDCARD_NAMESPACE | A string representing any namespaceURI (including the null or empty URI).
Top
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.NULL_NAMESPACE Property

XdsUtilNULL_NAMESPACE Property
A string representing the null, or empty namespace URI.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NULL_NAMESPACE { get; }
Public Shared ReadOnly Property NULL_NAMESPACE As String
    Get
public:
static property String^ NULL_NAMESPACE {
    String^ get ();
}
static member NULL_NAMESPACE : string with get

Property Value

Type: String
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.WILDCARD_NAME Property

XdsUtilWILDCARD_NAME Property
A string representing any local name part.

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WILDCARD_NAME { get; }
Public Shared ReadOnly Property WILDCARD_NAME As String
    Get
public:
static property String^ WILDCARD_NAME {
    String^ get ();
}
static member WILDCARD_NAME : string with get

Property Value

Type: String
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsUtil.WILDCARD_NAMESPACE Property

XdsUtilWILDCARD_NAMESPACE Property
A string representing any namespaceURI (including the null or empty URI).

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WILDCARD_NAMESPACE { get; }
Public Shared ReadOnly Property WILDCARD_NAMESPACE As String
    Get
public:
static property String^ WILDCARD_NAMESPACE {
    String^ get ();
}
static member WILDCARD_NAMESPACE : string with get

Property Value

Type: String
See Also

Reference

XdsUtil Class
DXMLBase.Xds Namespace


XdsValue Class

XdsValue Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsValue"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueBase
DXMLBase.XdsXdsValue

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsValue : XdsValueBase
Public Class XdsValue
    Inherits XdsValueBase
public ref class XdsValue : public XdsValueBase
type XdsValue =
    class
        inherit XdsValueBase
    end

The XdsValue type exposes the following members.

Constructors
 | Name | Description
Public method | XdsValue | Initializes a new instance of the XdsValue class
Top
Methods
 | Name | Description
Public method | clearValue | (Inherited from XdsValueBase.)
Protected method | convertValueToBool | (Inherited from XdsValueBase.)
Protected method | convertValueToInt | (Inherited from XdsValueBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Protected method | stringToType | (Inherited from XdsValueBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssociationRef | (Inherited from XdsValueBase.)
Public property | CountValue | (Inherited from XdsValueBase.)
Public property | IntervalValue | (Inherited from XdsValueBase.)
Public property | IntValue | (Inherited from XdsValueBase.)
Public property | Name | (Inherited from XdsElement.)
Public property | OctetValue | (Inherited from XdsValueBase.)
Public property | ReferentialValue | (Inherited from XdsValueBase.)
Public property | StateValue | (Inherited from XdsValueBase.)
Public property | StringValue | (Inherited from XdsValueBase.)
Public property | StructuredValue |
Public property | Type | (Inherited from XdsValueBase.)
Public property | Value | (Inherited from XdsValueBase.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsValue Constructor

XdsValue Constructor
Initializes a new instance of the XdsValue class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsValue(
    XmlElement valueElement
)
Public Sub New (
    valueElement As XmlElement
)
public:
XdsValue(
    XmlElement^ valueElement
)
new :
        valueElement : XmlElement -> XdsValue

Parameters

valueElement
Type: System.XmlXmlElement
The value element.
See Also

Reference

XdsValue Class
DXMLBase.Xds Namespace


XdsValue Methods

XdsValue Methods

The XdsValue type exposes the following members.

Methods
 | Name | Description
Public method | clearValue | (Inherited from XdsValueBase.)
Protected method | convertValueToBool | (Inherited from XdsValueBase.)
Protected method | convertValueToInt | (Inherited from XdsValueBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Protected method | stringToType | (Inherited from XdsValueBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsValue Class
DXMLBase.Xds Namespace


XdsValue Properties

XdsValue Properties

The XdsValue type exposes the following members.

Properties
 | Name | Description
Public property | AssociationRef | (Inherited from XdsValueBase.)
Public property | CountValue | (Inherited from XdsValueBase.)
Public property | IntervalValue | (Inherited from XdsValueBase.)
Public property | IntValue | (Inherited from XdsValueBase.)
Public property | Name | (Inherited from XdsElement.)
Public property | OctetValue | (Inherited from XdsValueBase.)
Public property | ReferentialValue | (Inherited from XdsValueBase.)
Public property | StateValue | (Inherited from XdsValueBase.)
Public property | StringValue | (Inherited from XdsValueBase.)
Public property | StructuredValue |
Public property | Type | (Inherited from XdsValueBase.)
Public property | Value | (Inherited from XdsValueBase.)
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsValue Class
DXMLBase.Xds Namespace


XdsValue.StructuredValue Property

XdsValueStructuredValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValue.StructuredValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsComponent> StructuredValue { get; set; }
Public Property StructuredValue As IEnumerable(Of XdsComponent)
    Get
    Set
public:
property IEnumerable<XdsComponent^>^ StructuredValue {
    IEnumerable<XdsComponent^>^ get ();
    void set (IEnumerable<XdsComponent^>^ value);
}
member StructuredValue : IEnumerable<XdsComponent> with get, set

Property Value

Type: IEnumerable XdsComponent
See Also

Reference

XdsValue Class
DXMLBase.Xds Namespace


XdsValueBase Class

XdsValueBase Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsValueBase"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueBase
DXMLBase.XdsXdsComponent
DXMLBase.XdsXdsValue

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class XdsValueBase : XdsElement
Public MustInherit Class XdsValueBase
    Inherits XdsElement
public ref class XdsValueBase abstract : public XdsElement
[<AbstractClassAttribute>]
type XdsValueBase =
    class
        inherit XdsElement
    end

The XdsValueBase type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsValueBase | Initializes a new instance of the XdsValueBase class
Top
Methods
 | Name | Description
Public method | clearValue |
Protected method | convertValueToBool |
Protected method | convertValueToInt |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Protected method | stringToType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | typeToString |
Top
Fields
Name | Description
contentTypeToString |
stringToContentType |
Top
Properties
 | Name | Description
Public property | AssociationRef |
Public property | CountValue |
Public property | IntervalValue |
Public property | IntValue |
Public property | Name | (Inherited from XdsElement.)
Public property | OctetValue |
Public property | ReferentialValue |
Public property | StateValue |
Public property | StringValue |
Public property | Type |
Public property | Value |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsValueBase Constructor

XdsValueBase Constructor
Initializes a new instance of the XdsValueBase class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsValueBase(
    XmlElement holderElement
)
Protected Sub New (
    holderElement As XmlElement
)
protected:
XdsValueBase(
    XmlElement^ holderElement
)
new :
        holderElement : XmlElement -> XdsValueBase

Parameters

holderElement
Type: System.XmlXmlElement
A value or component element.
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase Fields

XdsValueBase Fields

The XdsValueBase type exposes the following members.

Fields
Name | Description
contentTypeToString |
stringToContentType |
Top
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.contentTypeToString Field

XdsValueBasecontentTypeToString Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsValueBase.contentTypeToString"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static string[] contentTypeToString
Protected Shared contentTypeToString As String()
protected:
static array<String^>^ contentTypeToString
static val mutable contentTypeToString: string[]

Field Value

Type: String
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.stringToContentType Field

XdsValueBasestringToContentType Field

[Missing <summary> documentation for "F:DXMLBase.Xds.XdsValueBase.stringToContentType"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected static Dictionary<string, XdsValueBaseContentType> stringToContentType
Protected Shared stringToContentType As Dictionary(Of String, XdsValueBaseContentType)
protected:
static Dictionary<String^, XdsValueBaseContentType>^ stringToContentType
static val mutable stringToContentType: Dictionary<string, XdsValueBaseContentType>

Field Value

Type: Dictionary String, XdsValueBaseContentType
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase Methods

XdsValueBase Methods

The XdsValueBase type exposes the following members.

Methods
 | Name | Description
Public method | clearValue |
Protected method | convertValueToBool |
Protected method | convertValueToInt |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Protected method | stringToType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | typeToString |
Top
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.clearValue Method

XdsValueBaseclearValue Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsValueBase.clearValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void clearValue()
Public Overridable Sub clearValue
public:
virtual void clearValue()
abstract clearValue : unit -> unit
override clearValue : unit -> unit
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.convertValueToBool Method

XdsValueBaseconvertValueToBool Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsValueBase.convertValueToBool"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool convertValueToBool()
Protected Function convertValueToBool As Boolean
protected:
bool convertValueToBool()
member convertValueToBool : unit -> bool

Return Value

Type: Boolean
The boolean equivalent of Value.
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.convertValueToInt Method

XdsValueBaseconvertValueToInt Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsValueBase.convertValueToInt"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected int convertValueToInt()
Protected Function convertValueToInt As Integer
protected:
int convertValueToInt()
member convertValueToInt : unit -> int

Return Value

Type: Int32
The int value.
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.stringToType Method

XdsValueBasestringToType Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsValueBase.stringToType(System.String)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual XdsValueBaseContentType stringToType(
    string stringValue
)
Protected Overridable Function stringToType (
    stringValue As String
) As XdsValueBaseContentType
protected:
virtual XdsValueBaseContentType stringToType(
    String^ stringValue
)
abstract stringToType :
        stringValue : string -> XdsValueBaseContentType
override stringToType :
        stringValue : string -> XdsValueBaseContentType

Parameters

stringValue
Type: SystemString

[Missing <param name="stringValue"/> documentation for "M:DXMLBase.Xds.XdsValueBase.stringToType(System.String)"]

Return Value

Type: XdsValueBaseContentType
The corresponding index.
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.typeToString Method

XdsValueBasetypeToString Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsValueBase.typeToString(DXMLBase.Xds.XdsValueBase.ContentType)"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string typeToString(
    XdsValueBaseContentType contentType
)
Public Shared Function typeToString (
    contentType As XdsValueBaseContentType
) As String
public:
static String^ typeToString(
    XdsValueBaseContentType contentType
)
static member typeToString :
        contentType : XdsValueBaseContentType -> string

Parameters

contentType
Type: DXMLBase.XdsXdsValueBaseContentType

[Missing <param name="contentType"/> documentation for "M:DXMLBase.Xds.XdsValueBase.typeToString(DXMLBase.Xds.XdsValueBase.ContentType)"]

Return Value

Type: String
The corresponding string value.
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase Properties

XdsValueBase Properties

The XdsValueBase type exposes the following members.

Properties
 | Name | Description
Public property | AssociationRef |
Public property | CountValue |
Public property | IntervalValue |
Public property | IntValue |
Public property | Name | (Inherited from XdsElement.)
Public property | OctetValue |
Public property | ReferentialValue |
Public property | StateValue |
Public property | StringValue |
Public property | Type |
Public property | Value |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.AssociationRef Property

XdsValueBaseAssociationRef Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.AssociationRef"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssociationRef { get; set; }
Public Property AssociationRef As String
    Get
    Set
public:
property String^ AssociationRef {
    String^ get ();
    void set (String^ value);
}
member AssociationRef : string with get, set

Property Value

Type: String
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.CountValue Property

XdsValueBaseCountValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.CountValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CountValue { get; set; }
Public Overridable Property CountValue As Integer
    Get
    Set
public:
virtual property int CountValue {
    int get ();
    void set (int value);
}
abstract CountValue : int with get, set
override CountValue : int with get, set

Property Value

Type: Int32
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.IntervalValue Property

XdsValueBaseIntervalValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.IntervalValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IntervalValue { get; set; }
Public Overridable Property IntervalValue As Integer
    Get
    Set
public:
virtual property int IntervalValue {
    int get ();
    void set (int value);
}
abstract IntervalValue : int with get, set
override IntervalValue : int with get, set

Property Value

Type: Int32
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.IntValue Property

XdsValueBaseIntValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.IntValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IntValue { get; set; }
Public Overridable Property IntValue As Integer
    Get
    Set
public:
virtual property int IntValue {
    int get ();
    void set (int value);
}
abstract IntValue : int with get, set
override IntValue : int with get, set

Property Value

Type: Int32
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.OctetValue Property

XdsValueBaseOctetValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.OctetValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual byte[] OctetValue { get; set; }
Public Overridable Property OctetValue As Byte()
    Get
    Set
public:
virtual property array<unsigned char>^ OctetValue {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
abstract OctetValue : byte[] with get, set
override OctetValue : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.ReferentialValue Property

XdsValueBaseReferentialValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.ReferentialValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XdsReferentialValue ReferentialValue { get; set; }
Public Overridable Property ReferentialValue As XdsReferentialValue
    Get
    Set
public:
virtual property XdsReferentialValue^ ReferentialValue {
    XdsReferentialValue^ get ();
    void set (XdsReferentialValue^ value);
}
abstract ReferentialValue : XdsReferentialValue with get, set
override ReferentialValue : XdsReferentialValue with get, set

Property Value

Type: XdsReferentialValue
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.StateValue Property

XdsValueBaseStateValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.StateValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool StateValue { get; set; }
Public Overridable Property StateValue As Boolean
    Get
    Set
public:
virtual property bool StateValue {
    bool get ();
    void set (bool value);
}
abstract StateValue : bool with get, set
override StateValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.StringValue Property

XdsValueBaseStringValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.StringValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string StringValue { get; set; }
Public Overridable Property StringValue As String
    Get
    Set
public:
virtual property String^ StringValue {
    String^ get ();
    void set (String^ value);
}
abstract StringValue : string with get, set
override StringValue : string with get, set

Property Value

Type: String
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.Type Property

XdsValueBaseType Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.Type"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XdsValueBaseContentType Type { get; set; }
Public Overridable Property Type As XdsValueBaseContentType
    Get
    Set
public:
virtual property XdsValueBaseContentType Type {
    XdsValueBaseContentType get ();
    void set (XdsValueBaseContentType value);
}
abstract Type : XdsValueBaseContentType with get, set
override Type : XdsValueBaseContentType with get, set

Property Value

Type: XdsValueBaseContentType
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.Value Property

XdsValueBaseValue Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueBase.Value"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Value { get; set; }
Public Overridable Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
See Also

Reference

XdsValueBase Class
DXMLBase.Xds Namespace


XdsValueBase.ContentType Enumeration

XdsValueBaseContentType Enumeration

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsValueBase.ContentType"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ContentType
Public Enumeration ContentType
public enum class ContentType
type ContentType
Members
Member name | Value | Description
String | 0 |
Int | 1 |
State | 2 |
DN | 3 |
Octet | 4 |
TeleNumber | 5 |
ClassName | 6 |
Interval | 7 |
Count | 8 |
Structured | 9 |
See Also

Reference

DXMLBase.Xds Namespace


XdsValueParent Class

XdsValueParent Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsValueParent"]

Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
More...

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class XdsValueParent : XdsElement
Public MustInherit Class XdsValueParent
    Inherits XdsElement
public ref class XdsValueParent abstract : public XdsElement
[<AbstractClassAttribute>]
type XdsValueParent =
    class
        inherit XdsElement
    end

The XdsValueParent type exposes the following members.

Constructors
 | Name | Description
Protected method | XdsValueParent | Initializes a new instance of the XdsValueParent class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues |
Public property | Values |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

DXMLBase.Xds Namespace
Inheritance Hierarchy
SystemObject
DXMLBase.XdsXdsElement
DXMLBase.XdsXdsValueParent
DXMLBase.XdsXdsAddAttr
DXMLBase.XdsXdsAddValue
DXMLBase.XdsXdsAttr
DXMLBase.XdsXdsReadAttr
DXMLBase.XdsXdsRemoveValue
DXMLBase.XdsXdsSearchAttr


XdsValueParent Constructor

XdsValueParent Constructor
Initializes a new instance of the XdsValueParent class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected XdsValueParent(
    XmlElement xdsElement
)
Protected Sub New (
    xdsElement As XmlElement
)
protected:
XdsValueParent(
    XmlElement^ xdsElement
)
new :
        xdsElement : XmlElement -> XdsValueParent

Parameters

xdsElement
Type: System.XmlXmlElement
The XmlElement that is the XDS parent of <value> elements.
See Also

Reference

XdsValueParent Class
DXMLBase.Xds Namespace


XdsValueParent Methods

XdsValueParent Methods

The XdsValueParent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getAttr | (Inherited from XdsElement.)
Protected method | getBoolAttr | (Inherited from XdsElement.)
Protected method | getChildContent | (Inherited from XdsElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newXdsValue |
Protected method | setAttr | (Inherited from XdsElement.)
Protected method | setBoolAttr | (Inherited from XdsElement.)
Protected method | setChildContent | (Inherited from XdsElement.)
Protected method | setXmlElement | (Inherited from XdsElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XdsValueParent Class
DXMLBase.Xds Namespace


XdsValueParent.newXdsValue Method

XdsValueParentnewXdsValue Method

[Missing <summary> documentation for "M:DXMLBase.Xds.XdsValueParent.newXdsValue"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsValue newXdsValue()
Public Function newXdsValue As XdsValue
public:
XdsValue^ newXdsValue()
member newXdsValue : unit -> XdsValue

Return Value

Type: XdsValue

[Missing <returns> documentation for "M:DXMLBase.Xds.XdsValueParent.newXdsValue"]

See Also

Reference

XdsValueParent Class
DXMLBase.Xds Namespace


XdsValueParent Properties

XdsValueParent Properties

The XdsValueParent type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from XdsElement.)
Public property | StringValues |
Public property | Values |
Public property | XmlElement | (Inherited from XdsElement.)
Top
See Also

Reference

XdsValueParent Class
DXMLBase.Xds Namespace


XdsValueParent.StringValues Property

XdsValueParentStringValues Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueParent.StringValues"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> StringValues { get; }
Public ReadOnly Property StringValues As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ StringValues {
    IEnumerable<String^>^ get ();
}
member StringValues : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

XdsValueParent Class
DXMLBase.Xds Namespace


XdsValueParent.Values Property

XdsValueParentValues Property

[Missing <summary> documentation for "P:DXMLBase.Xds.XdsValueParent.Values"]

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<XdsValue> Values { get; }
Public ReadOnly Property Values As IEnumerable(Of XdsValue)
    Get
public:
property IEnumerable<XdsValue^>^ Values {
    IEnumerable<XdsValue^>^ get ();
}
member Values : IEnumerable<XdsValue> with get

Property Value

Type: IEnumerable XdsValue
See Also

Reference

XdsValueParent Class
DXMLBase.Xds Namespace


XdsWarningException Class

XdsWarningException Class

[Missing <summary> documentation for "T:DXMLBase.Xds.XdsWarningException"]

Inheritance Hierarchy
SystemObject
SystemException
DXMLBase.XdsXdsStatusException
DXMLBase.XdsXdsWarningException

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XdsWarningException : XdsStatusException
Public Class XdsWarningException
    Inherits XdsStatusException
public ref class XdsWarningException : public XdsStatusException
type XdsWarningException =
    class
        inherit XdsStatusException
    end

The XdsWarningException type exposes the following members.

Constructors
 | Name | Description
Public method | XdsWarningException(String) | Initializes a new instance of the XdsWarningException class
Public method | XdsWarningException(String, Exception) | Initializes a new instance of the XdsWarningException class
Top
Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DXMLBase.Xds Namespace


XdsWarningException Constructor

XdsWarningException Constructor
Overload List
 | Name | Description
Public method | XdsWarningException(String) | Initializes a new instance of the XdsWarningException class
Public method | XdsWarningException(String, Exception) | Initializes a new instance of the XdsWarningException class
Top
See Also

Reference

XdsWarningException Class
DXMLBase.Xds Namespace


XdsWarningException Constructor (String)

XdsWarningException Constructor (String)
Initializes a new instance of the XdsWarningException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsWarningException(
    string message
)
Public Sub New (
    message As String
)
public:
XdsWarningException(
    String^ message
)
new :
        message : string -> XdsWarningException

Parameters

message
Type: SystemString
The message.
See Also

Reference

XdsWarningException Class
XdsWarningException Overload
DXMLBase.Xds Namespace


XdsWarningException Constructor (String, Exception)

XdsWarningException Constructor (String, Exception)
Initializes a new instance of the XdsWarningException class

Namespace: DXMLBase.Xds
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XdsWarningException(
    string message,
    Exception cause
)
Public Sub New (
    message As String,
    cause As Exception
)
public:
XdsWarningException(
    String^ message,
    Exception^ cause
)
new :
        message : string *
        cause : Exception -> XdsWarningException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:DXMLBase.Xds.XdsWarningException.#ctor(System.String,System.Exception)"]

cause
Type: SystemException
The underlying exception.
See Also

Reference

XdsWarningException Class
XdsWarningException Overload
DXMLBase.Xds Namespace


XdsWarningException Methods

XdsWarningException Methods

The XdsWarningException type exposes the following members.

Methods
 | Name | Description
Public method | addToChain | (Inherited from XdsStatusException.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsWarningException Class
DXMLBase.Xds Namespace


XdsWarningException Properties

XdsWarningException Properties

The XdsWarningException type exposes the following members.

Properties
 | Name | Description
Public property | Chain | (Inherited from XdsStatusException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Level | (Inherited from XdsStatusException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

XdsWarningException Class
DXMLBase.Xds Namespace


XdsWarningException Events

XdsWarningException Events

The XdsWarningException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

XdsWarningException Class
DXMLBase.Xds Namespace


DXMLBase.Xml Namespace

DXMLBase.Xml Namespace

[Missing <summary> documentation for "N:DXMLBase.Xml"]

Classes
 | Class | Description
Public class | NamespaceName |
Public class | XmlCharDefs |
Public class | XmlUtil | Utility class (primarily) for XML string handling.


NamespaceName Class

NamespaceName Class

[Missing <summary> documentation for "T:DXMLBase.Xml.NamespaceName"]

Inheritance Hierarchy
SystemObject
DXMLBase.XmlNamespaceName

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NamespaceName : IComparable
Public Class NamespaceName
    Implements IComparable
public ref class NamespaceName : IComparable
type NamespaceName =
    class
        interface IComparable
    end

The NamespaceName type exposes the following members.

Constructors
 | Name | Description
Public method | NamespaceName | Initializes a new instance of the NamespaceName class
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(String) |
Public method | Equals(NamespaceName) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name Description
NULL_NAMESPACE
A convenience constant for the null namespace
UNKNOWN_NAMESPACE
A convenience constant for use by
Copy
ExpandedQName
.
WILDCARD_NAMESPACE
A convenience constant for a "wildcard" namespace used for searching.
WILDCARD_URI
URI that is used as a wildcard for matching any URI
XML_NAMESPACE
XMLNS_NAMESPACE
Top
Properties
 | Name | Description
Public property | Empty |
Public property | String |
Top
See Also

Reference

DXMLBase.Xml Namespace


NamespaceName Constructor

NamespaceName Constructor
Initializes a new instance of the NamespaceName class

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NamespaceName(
    string namespaceName
)
Public Sub New (
    namespaceName As String
)
public:
NamespaceName(
    String^ namespaceName
)
new :
        namespaceName : string -> NamespaceName

Parameters

namespaceName
Type: SystemString

[Missing <param name="namespaceName"/> documentation for "M:DXMLBase.Xml.NamespaceName.#ctor(System.String)"]

See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName Fields

NamespaceName Fields

The NamespaceName type exposes the following members.

Fields
Name Description
NULL_NAMESPACE
A convenience constant for the null namespace
UNKNOWN_NAMESPACE
A convenience constant for use by
Copy
ExpandedQName
.
WILDCARD_NAMESPACE
A convenience constant for a "wildcard" namespace used for searching.
WILDCARD_URI
URI that is used as a wildcard for matching any URI
XML_NAMESPACE
XMLNS_NAMESPACE
Top
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.NULL_NAMESPACE Field

NamespaceNameNULL_NAMESPACE Field
A convenience constant for the null namespace

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly NamespaceName NULL_NAMESPACE
Public Shared ReadOnly NULL_NAMESPACE As NamespaceName
public:
static initonly NamespaceName^ NULL_NAMESPACE
static val NULL_NAMESPACE: NamespaceName

Field Value

Type: NamespaceName
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.UNKNOWN_NAMESPACE Field

NamespaceNameUNKNOWN_NAMESPACE Field
A convenience constant for use by
Copy
ExpandedQName
.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly NamespaceName UNKNOWN_NAMESPACE
Public Shared ReadOnly UNKNOWN_NAMESPACE As NamespaceName
public:
static initonly NamespaceName^ UNKNOWN_NAMESPACE
static val UNKNOWN_NAMESPACE: NamespaceName

Field Value

Type: NamespaceName
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.WILDCARD_NAMESPACE Field

NamespaceNameWILDCARD_NAMESPACE Field
A convenience constant for a "wildcard" namespace used for searching.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly NamespaceName WILDCARD_NAMESPACE
Public Shared ReadOnly WILDCARD_NAMESPACE As NamespaceName
public:
static initonly NamespaceName^ WILDCARD_NAMESPACE
static val WILDCARD_NAMESPACE: NamespaceName

Field Value

Type: NamespaceName
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.WILDCARD_URI Field

NamespaceNameWILDCARD_URI Field
URI that is used as a wildcard for matching any URI

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string WILDCARD_URI
Public Const WILDCARD_URI As String
public:
literal String^ WILDCARD_URI
static val mutable WILDCARD_URI: string

Field Value

Type: String
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.XML_NAMESPACE Field

NamespaceNameXML_NAMESPACE Field

[Missing <summary> documentation for "F:DXMLBase.Xml.NamespaceName.XML_NAMESPACE"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly NamespaceName XML_NAMESPACE
Public Shared ReadOnly XML_NAMESPACE As NamespaceName
public:
static initonly NamespaceName^ XML_NAMESPACE
static val XML_NAMESPACE: NamespaceName

Field Value

Type: NamespaceName
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.XMLNS_NAMESPACE Field

NamespaceNameXMLNS_NAMESPACE Field

[Missing <summary> documentation for "F:DXMLBase.Xml.NamespaceName.XMLNS_NAMESPACE"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly NamespaceName XMLNS_NAMESPACE
Public Shared ReadOnly XMLNS_NAMESPACE As NamespaceName
public:
static initonly NamespaceName^ XMLNS_NAMESPACE
static val XMLNS_NAMESPACE: NamespaceName

Field Value

Type: NamespaceName
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName Methods

NamespaceName Methods

The NamespaceName type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(String) |
Public method | Equals(NamespaceName) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.CompareTo Method

NamespaceNameCompareTo Method

[Missing <summary> documentation for "M:DXMLBase.Xml.NamespaceName.CompareTo(System.Object)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CompareTo(
    Object rhs
)
Public Overridable Function CompareTo (
    rhs As Object
) As Integer
public:
virtual int CompareTo(
    Object^ rhs
)
abstract CompareTo :
        rhs : Object -> int
override CompareTo :
        rhs : Object -> int

Parameters

rhs
Type: SystemObject

[Missing <param name="rhs"/> documentation for "M:DXMLBase.Xml.NamespaceName.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.Xml.NamespaceName.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.Equals Method

NamespaceNameEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(String) |
Public method | Equals(NamespaceName) |
Top
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.Equals Method (Object)

NamespaceNameEquals Method (Object)

[Missing <summary> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(System.Object)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object rhs
)
Public Overrides Function Equals (
    rhs As Object
) As Boolean
public:
virtual bool Equals(
    Object^ rhs
) override
abstract Equals :
        rhs : Object -> bool
override Equals :
        rhs : Object -> bool

Parameters

rhs
Type: SystemObject

[Missing <param name="rhs"/> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(System.Object)"]

See Also

Reference

NamespaceName Class
Equals Overload
DXMLBase.Xml Namespace


NamespaceName.Equals Method (String)

NamespaceNameEquals Method (String)

[Missing <summary> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(System.String)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    string rhs
)
Public Function Equals (
    rhs As String
) As Boolean
public:
bool Equals(
    String^ rhs
)
member Equals :
        rhs : string -> bool

Parameters

rhs
Type: SystemString

[Missing <param name="rhs"/> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(System.String)"]

See Also

Reference

NamespaceName Class
Equals Overload
DXMLBase.Xml Namespace


NamespaceName.Equals Method (NamespaceName)

NamespaceNameEquals Method (NamespaceName)

[Missing <summary> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(DXMLBase.Xml.NamespaceName)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    NamespaceName rhs
)
Public Function Equals (
    rhs As NamespaceName
) As Boolean
public:
bool Equals(
    NamespaceName^ rhs
)
member Equals :
        rhs : NamespaceName -> bool

Parameters

rhs
Type: DXMLBase.XmlNamespaceName

[Missing <param name="rhs"/> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(DXMLBase.Xml.NamespaceName)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.NamespaceName.Equals(DXMLBase.Xml.NamespaceName)"]

See Also

Reference

NamespaceName Class
Equals Overload
DXMLBase.Xml Namespace


NamespaceName.GetHashCode Method

NamespaceNameGetHashCode Method

[Missing <summary> documentation for "M:DXMLBase.Xml.NamespaceName.GetHashCode"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:DXMLBase.Xml.NamespaceName.GetHashCode"]

See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName Properties

NamespaceName Properties

The NamespaceName type exposes the following members.

Properties
 | Name | Description
Public property | Empty |
Public property | String |
Top
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.Empty Property

NamespaceNameEmpty Property

[Missing <summary> documentation for "P:DXMLBase.Xml.NamespaceName.Empty"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Empty { get; }
Public Overridable ReadOnly Property Empty As Boolean
    Get
public:
virtual property bool Empty {
    bool get ();
}
abstract Empty : bool with get
override Empty : bool with get

Property Value

Type: Boolean
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


NamespaceName.String Property

NamespaceNameString Property

[Missing <summary> documentation for "P:DXMLBase.Xml.NamespaceName.String"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string String { get; }
Public Overridable ReadOnly Property String As String
    Get
public:
virtual property String^ String {
    String^ get ();
}
abstract String : string with get
override String : string with get

Property Value

Type: String
See Also

Reference

NamespaceName Class
DXMLBase.Xml Namespace


XmlCharDefs Class

XmlCharDefs Class

[Missing <summary> documentation for "T:DXMLBase.Xml.XmlCharDefs"]

Inheritance Hierarchy
SystemObject
DXMLBase.XmlXmlCharDefs

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class XmlCharDefs
Public NotInheritable Class XmlCharDefs
public ref class XmlCharDefs abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlCharDefs =  class end

The XmlCharDefs type exposes the following members.

Methods
Name | Description
isXmlChar |
isXmlCombiningChar |
isXmlDigit |
isXmlExtenderChar |
isXmlLetter |
isXmlNameChar |
isXmlWhitespace |
Top
See Also

Reference

DXMLBase.Xml Namespace


XmlCharDefs Methods

XmlCharDefs Methods

The XmlCharDefs type exposes the following members.

Methods
Name | Description
isXmlChar |
isXmlCombiningChar |
isXmlDigit |
isXmlExtenderChar |
isXmlLetter |
isXmlNameChar |
isXmlWhitespace |
Top
See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlChar Method

XmlCharDefsisXmlChar Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlChar(System.Int32)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlChar(
    int c
)
Public Shared Function isXmlChar (
    c As Integer
) As Boolean
public:
static bool isXmlChar(
    int c
)
static member isXmlChar :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlChar(System.Int32)"]

Return Value

Type: Boolean
true if value is XML character
See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlCombiningChar Method

XmlCharDefsisXmlCombiningChar Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlCombiningChar(System.Char)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlCombiningChar(
    char c
)
Public Shared Function isXmlCombiningChar (
    c As Char
) As Boolean
public:
static bool isXmlCombiningChar(
    wchar_t c
)
static member isXmlCombiningChar :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlCombiningChar(System.Char)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlCombiningChar(System.Char)"]

See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlDigit Method

XmlCharDefsisXmlDigit Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlDigit(System.Char)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlDigit(
    char c
)
Public Shared Function isXmlDigit (
    c As Char
) As Boolean
public:
static bool isXmlDigit(
    wchar_t c
)
static member isXmlDigit :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlDigit(System.Char)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlDigit(System.Char)"]

See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlExtenderChar Method

XmlCharDefsisXmlExtenderChar Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlExtenderChar(System.Char)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlExtenderChar(
    char c
)
Public Shared Function isXmlExtenderChar (
    c As Char
) As Boolean
public:
static bool isXmlExtenderChar(
    wchar_t c
)
static member isXmlExtenderChar :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlExtenderChar(System.Char)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlExtenderChar(System.Char)"]

See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlLetter Method

XmlCharDefsisXmlLetter Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlLetter(System.Char)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlLetter(
    char c
)
Public Shared Function isXmlLetter (
    c As Char
) As Boolean
public:
static bool isXmlLetter(
    wchar_t c
)
static member isXmlLetter :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlLetter(System.Char)"]

Return Value

Type: Boolean
true if character is XML 1.0 'letter'
See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlNameChar Method

XmlCharDefsisXmlNameChar Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlNameChar(System.Char)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlNameChar(
    char c
)
Public Shared Function isXmlNameChar (
    c As Char
) As Boolean
public:
static bool isXmlNameChar(
    wchar_t c
)
static member isXmlNameChar :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlNameChar(System.Char)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlNameChar(System.Char)"]

See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlCharDefs.isXmlWhitespace Method

XmlCharDefsisXmlWhitespace Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlWhitespace(System.Char)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlWhitespace(
    char c
)
Public Shared Function isXmlWhitespace (
    c As Char
) As Boolean
public:
static bool isXmlWhitespace(
    wchar_t c
)
static member isXmlWhitespace :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:DXMLBase.Xml.XmlCharDefs.isXmlWhitespace(System.Char)"]

Return Value

Type: Boolean
true if character value is XML whitespace
See Also

Reference

XmlCharDefs Class
DXMLBase.Xml Namespace


XmlUtil Class

XmlUtil Class
Utility class (primarily) for XML string handling.
Inheritance Hierarchy
SystemObject
DXMLBase.XmlXmlUtil

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class XmlUtil
Public NotInheritable Class XmlUtil
public ref class XmlUtil abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlUtil =  class end

The XmlUtil type exposes the following members.

Methods
Name | Description
encodeAsCData | Output a text value as a CDATA section
encodeAttribute | Encode an attribute value as XML to a stream.
encodeText |
escape(String) |
escape(String, Int32) |
getLocalName | Returns the local name from a qname.
getPrefix | Returns the prefix from a qname.
getPseudoAttribute | Return the value of a pseudo XML attribute from a string. A pseudo attribute has the same syntax as an XML element attribute but is not from an element. For example, the xml-stylesheet processing instruction has pseudo attributes.
isNamespaceDecl | Checks an attribute qname to see if it is a namespace declaration
isNCName(Char) | returns whether the passed character matches the XML Namespace "NCName" production
isNCName(String) | returns whether the passed string matches the XML Namespace "NCName" production
isNCNameChar | Returns whether the specified character conforms to the NCNameChar production in the XML Namespace grammar. Such a character is allowed as the second or subsequent character in an XML 1.0 name.
isPITarget | Returns whether the passed string conforms to the PITarget production in the XML 1.0 Recommendation.
isQName | Returns whether the passed string conforms to the QName production found in XML Names: http://www.w3.org/TR/REC-xml-names
isXmlEncName | Return true if the passed string conforms to the XML EncName production. [81] EncName ::= [A-Za-z] ([A-Za-z0-9._] | '-')*
isXmlName(Char) | Returns whether the specified char conforms to the Name production in the XML 1.0 grammar.
isXmlName(String) | Returns whether the specified string conforms to the Name production in the XML 1.0 grammar.
isXmlNameChar | Returns whether the specified character conforms to the NameChar production in the XML 1.0 grammar. Such a character is allowed as the second or subsequent character in an XML 1.0 name.
isXmlValid | Return true if all of the characters in the passed string are valid XML characters.
isXmlVersionNum | Return true if the passed string conforms to the XML VersionNum production. [26] VersionNum ::= ([a-zA-Z0-9_.:] | '-')+
isXmlWhitespace(Char) | Returns whether the specified char conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.
isXmlWhitespace(String) | Returns whether the specified string conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.
normalizeWhitespace | Normalize whitespace in a string by stripping leading and trailing whitespace, and converting all internal sequences of whitespace into a single space each.
quote(String) |
quote(String, Int32) |
replaceBuiltInEntities | Replace XML's built-in references (&, etc.) with the corresponding characters.
toXml(String) |
toXml(String, String) |
Top
Fields
Name | Description
DIGITS |
HEX_DIGITS |
Top
Properties
Name | Description
NULL_NAMESPACE |
Top
Bibliography
See Also

Reference

DXMLBase.Xml Namespace


XmlUtil Fields

XmlUtil Fields

The XmlUtil type exposes the following members.

Fields
Name | Description
DIGITS |
HEX_DIGITS |
Top
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.DIGITS Field

XmlUtilDIGITS Field

[Missing <summary> documentation for "F:DXMLBase.Xml.XmlUtil.DIGITS"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DIGITS
Public Const DIGITS As String
public:
literal String^ DIGITS
static val mutable DIGITS: string

Field Value

Type: String
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.HEX_DIGITS Field

XmlUtilHEX_DIGITS Field

[Missing <summary> documentation for "F:DXMLBase.Xml.XmlUtil.HEX_DIGITS"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string HEX_DIGITS
Public Const HEX_DIGITS As String
public:
literal String^ HEX_DIGITS
static val mutable HEX_DIGITS: string

Field Value

Type: String
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil Methods

XmlUtil Methods

The XmlUtil type exposes the following members.

Methods
Name | Description
encodeAsCData | Output a text value as a CDATA section
encodeAttribute | Encode an attribute value as XML to a stream.
encodeText |
escape(String) |
escape(String, Int32) |
getLocalName | Returns the local name from a qname.
getPrefix | Returns the prefix from a qname.
getPseudoAttribute | Return the value of a pseudo XML attribute from a string. A pseudo attribute has the same syntax as an XML element attribute but is not from an element. For example, the xml-stylesheet processing instruction has pseudo attributes.
isNamespaceDecl | Checks an attribute qname to see if it is a namespace declaration
isNCName(Char) | returns whether the passed character matches the XML Namespace "NCName" production
isNCName(String) | returns whether the passed string matches the XML Namespace "NCName" production
isNCNameChar | Returns whether the specified character conforms to the NCNameChar production in the XML Namespace grammar. Such a character is allowed as the second or subsequent character in an XML 1.0 name.
isPITarget | Returns whether the passed string conforms to the PITarget production in the XML 1.0 Recommendation.
isQName | Returns whether the passed string conforms to the QName production found in XML Names: http://www.w3.org/TR/REC-xml-names
isXmlEncName | Return true if the passed string conforms to the XML EncName production. [81] EncName ::= [A-Za-z] ([A-Za-z0-9._] | '-')*
isXmlName(Char) | Returns whether the specified char conforms to the Name production in the XML 1.0 grammar.
isXmlName(String) | Returns whether the specified string conforms to the Name production in the XML 1.0 grammar.
isXmlNameChar | Returns whether the specified character conforms to the NameChar production in the XML 1.0 grammar. Such a character is allowed as the second or subsequent character in an XML 1.0 name.
isXmlValid | Return true if all of the characters in the passed string are valid XML characters.
isXmlVersionNum | Return true if the passed string conforms to the XML VersionNum production. [26] VersionNum ::= ([a-zA-Z0-9_.:] | '-')+
isXmlWhitespace(Char) | Returns whether the specified char conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.
isXmlWhitespace(String) | Returns whether the specified string conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.
normalizeWhitespace | Normalize whitespace in a string by stripping leading and trailing whitespace, and converting all internal sequences of whitespace into a single space each.
quote(String) |
quote(String, Int32) |
replaceBuiltInEntities | Replace XML's built-in references (&, etc.) with the corresponding characters.
toXml(String) |
toXml(String, String) |
Top
Bibliography
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.encodeAsCData Method

XmlUtilencodeAsCData Method
Output a text value as a CDATA section

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void encodeAsCData(
    TextWriter stream,
    string value
)
Public Shared Sub encodeAsCData (
    stream As TextWriter,
    value As String
)
public:
static void encodeAsCData(
    TextWriter^ stream,
    String^ value
)
static member encodeAsCData :
        stream : TextWriter *
        value : string -> unit

Parameters

stream
Type: System.IOTextWriter
The writer to which to serialize the CDATA section
value
Type: SystemString
The text value to output
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.encodeAttribute Method

XmlUtilencodeAttribute Method
Encode an attribute value as XML to a stream.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void encodeAttribute(
    TextWriter stream,
    string value
)
Public Shared Sub encodeAttribute (
    stream As TextWriter,
    value As String
)
public:
static void encodeAttribute(
    TextWriter^ stream,
    String^ value
)
static member encodeAttribute :
        stream : TextWriter *
        value : string -> unit

Parameters

stream
Type: System.IOTextWriter
The stream to which to write the attribute value.
value
Type: SystemString
The attribute value.
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.encodeText Method

XmlUtilencodeText Method

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.encodeText(System.IO.TextWriter,System.String)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void encodeText(
    TextWriter stream,
    string text
)
Public Shared Sub encodeText (
    stream As TextWriter,
    text As String
)
public:
static void encodeText(
    TextWriter^ stream,
    String^ text
)
static member encodeText :
        stream : TextWriter *
        text : string -> unit

Parameters

stream
Type: System.IOTextWriter

[Missing <param name="stream"/> documentation for "M:DXMLBase.Xml.XmlUtil.encodeText(System.IO.TextWriter,System.String)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:DXMLBase.Xml.XmlUtil.encodeText(System.IO.TextWriter,System.String)"]

See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.escape Method

XmlUtilescape Method
Overload List
Name | Description
escape(String) |
escape(String, Int32) |
Top
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.escape Method (String)

XmlUtilescape Method (String)

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string escape(
    string str
)
Public Shared Function escape (
    str As String
) As String
public:
static String^ escape(
    String^ str
)
static member escape :
        str : string -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String)"]

See Also

Reference

XmlUtil Class
escape Overload
DXMLBase.Xml Namespace


XmlUtil.escape Method (String, Int32)

XmlUtilescape Method (String, Int32)

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String,System.Int32)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string escape(
    string str,
    int maxLength
)
Public Shared Function escape (
    str As String,
    maxLength As Integer
) As String
public:
static String^ escape(
    String^ str,
    int maxLength
)
static member escape :
        str : string *
        maxLength : int -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String,System.Int32)"]

maxLength
Type: SystemInt32

[Missing <param name="maxLength"/> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlUtil.escape(System.String,System.Int32)"]

See Also

Reference

XmlUtil Class
escape Overload
DXMLBase.Xml Namespace


XmlUtil.getLocalName Method

XmlUtilgetLocalName Method
Returns the local name from a qname.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getLocalName(
    string qname
)
Public Shared Function getLocalName (
    qname As String
) As String
public:
static String^ getLocalName(
    String^ qname
)
static member getLocalName :
        qname : string -> string

Parameters

qname
Type: SystemString
the qname whose local name is to be returned

Return Value

Type: String
the qname's local name
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.getPrefix Method

XmlUtilgetPrefix Method
Returns the prefix from a qname.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getPrefix(
    string qname
)
Public Shared Function getPrefix (
    qname As String
) As String
public:
static String^ getPrefix(
    String^ qname
)
static member getPrefix :
        qname : string -> string

Parameters

qname
Type: SystemString
the qname whose local name is to be returned

Return Value

Type: String
the qname's local name or empty string if no prefix
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.getPseudoAttribute Method

XmlUtilgetPseudoAttribute Method
Return the value of a pseudo XML attribute from a string. A pseudo attribute has the same syntax as an XML element attribute but is not from an element. For example, the xml-stylesheet processing instruction has pseudo attributes.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string getPseudoAttribute(
    string data,
    string attrName
)
Public Shared Function getPseudoAttribute (
    data As String,
    attrName As String
) As String
public:
static String^ getPseudoAttribute(
    String^ data,
    String^ attrName
)
static member getPseudoAttribute :
        data : string *
        attrName : string -> string

Parameters

data
Type: SystemString
The data to parse for the attribute value
attrName
Type: SystemString

[Missing <param name="attrName"/> documentation for "M:DXMLBase.Xml.XmlUtil.getPseudoAttribute(System.String,System.String)"]

Return Value

Type: String
The name of the pseudo attribute
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isNamespaceDecl Method

XmlUtilisNamespaceDecl Method
Checks an attribute qname to see if it is a namespace declaration

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isNamespaceDecl(
    string name
)
Public Shared Function isNamespaceDecl (
    name As String
) As Boolean
public:
static bool isNamespaceDecl(
    String^ name
)
static member isNamespaceDecl :
        name : string -> bool

Parameters

name
Type: SystemString
the attribute qname

Return Value

Type: Boolean
true/false
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isNCName Method

XmlUtilisNCName Method
Overload List
Name | Description
isNCName(Char) | returns whether the passed character matches the XML Namespace "NCName" production
isNCName(String) | returns whether the passed string matches the XML Namespace "NCName" production
Top
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isNCName Method (Char)

XmlUtilisNCName Method (Char)
returns whether the passed character matches the XML Namespace "NCName" production

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isNCName(
    char c
)
Public Shared Function isNCName (
    c As Char
) As Boolean
public:
static bool isNCName(
    wchar_t c
)
static member isNCName :
        c : char -> bool

Parameters

c
Type: SystemChar
character to check

Return Value

Type: Boolean
true if character matches the XML Namespace "NCName" production
See Also

Reference

XmlUtil Class
isNCName Overload
DXMLBase.Xml Namespace


XmlUtil.isNCName Method (String)

XmlUtilisNCName Method (String)
returns whether the passed string matches the XML Namespace "NCName" production

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isNCName(
    string str
)
Public Shared Function isNCName (
    str As String
) As Boolean
public:
static bool isNCName(
    String^ str
)
static member isNCName :
        str : string -> bool

Parameters

str
Type: SystemString
string to check

Return Value

Type: Boolean
true if string matches the XML Namespace "NCName" production
See Also

Reference

XmlUtil Class
isNCName Overload
DXMLBase.Xml Namespace


XmlUtil.isNCNameChar Method

XmlUtilisNCNameChar Method
Returns whether the specified character conforms to the NCNameChar production in the XML Namespace grammar. Such a character is allowed as the second or subsequent character in an XML 1.0 name.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isNCNameChar(
    char ch
)
Public Shared Function isNCNameChar (
    ch As Char
) As Boolean
public:
static bool isNCNameChar(
    wchar_t ch
)
static member isNCNameChar :
        ch : char -> bool

Parameters

ch
Type: SystemChar
the character to be checked

Return Value

Type: Boolean
Copy
true
if the character is an XML 1.0 NameChar,
Copy
false
if it is not
Bibliography
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isPITarget Method

XmlUtilisPITarget Method
Returns whether the passed string conforms to the PITarget production in the XML 1.0 Recommendation.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isPITarget(
    string name
)
Public Shared Function isPITarget (
    name As String
) As Boolean
public:
static bool isPITarget(
    String^ name
)
static member isPITarget :
        name : string -> bool

Parameters

name
Type: SystemString
string to check

Return Value

Type: Boolean
true if passed string conforms to PITarget
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isQName Method

XmlUtilisQName Method
Returns whether the passed string conforms to the QName production found in XML Names: http://www.w3.org/TR/REC-xml-names

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isQName(
    string name
)
Public Shared Function isQName (
    name As String
) As Boolean
public:
static bool isQName(
    String^ name
)
static member isQName :
        name : string -> bool

Parameters

name
Type: SystemString
The string to check for conformance to QName.

Return Value

Type: Boolean
true if the string conforms to the QName production.
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlEncName Method

XmlUtilisXmlEncName Method
Return true if the passed string conforms to the XML EncName production. [81] EncName ::= [A-Za-z] ([A-Za-z0-9._] | '-')*

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlEncName(
    string str
)
Public Shared Function isXmlEncName (
    str As String
) As Boolean
public:
static bool isXmlEncName(
    String^ str
)
static member isXmlEncName :
        str : string -> bool

Parameters

str
Type: SystemString
The string to check.

Return Value

Type: Boolean
Copy
true
if the passed string conforms to the XML EncName production.
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlName Method

XmlUtilisXmlName Method
Overload List
Name | Description
isXmlName(Char) | Returns whether the specified char conforms to the Name production in the XML 1.0 grammar.
isXmlName(String) | Returns whether the specified string conforms to the Name production in the XML 1.0 grammar.
Top
Bibliography
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlName Method (Char)

XmlUtilisXmlName Method (Char)
Returns whether the specified char conforms to the Name production in the XML 1.0 grammar.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlName(
    char c
)
Public Shared Function isXmlName (
    c As Char
) As Boolean
public:
static bool isXmlName(
    wchar_t c
)
static member isXmlName :
        c : char -> bool

Parameters

c
Type: SystemChar
the char to be checked

Return Value

Type: Boolean
Copy
true
if the string is an XML 1.0 Name,
Copy
false
if it is not
Bibliography
See Also

Reference

XmlUtil Class
isXmlName Overload
DXMLBase.Xml Namespace


XmlUtil.isXmlName Method (String)

XmlUtilisXmlName Method (String)
Returns whether the specified string conforms to the Name production in the XML 1.0 grammar.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlName(
    string str
)
Public Shared Function isXmlName (
    str As String
) As Boolean
public:
static bool isXmlName(
    String^ str
)
static member isXmlName :
        str : string -> bool

Parameters

str
Type: SystemString
the string to be checked

Return Value

Type: Boolean
Copy
true
if the string is an XML 1.0 Name,
Copy
false
if it is not
Bibliography
See Also

Reference

XmlUtil Class
isXmlName Overload
DXMLBase.Xml Namespace


XmlUtil.isXmlNameChar Method

XmlUtilisXmlNameChar Method
Returns whether the specified character conforms to the NameChar production in the XML 1.0 grammar. Such a character is allowed as the second or subsequent character in an XML 1.0 name.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlNameChar(
    char ch
)
Public Shared Function isXmlNameChar (
    ch As Char
) As Boolean
public:
static bool isXmlNameChar(
    wchar_t ch
)
static member isXmlNameChar :
        ch : char -> bool

Parameters

ch
Type: SystemChar
the character to be checked

Return Value

Type: Boolean
Copy
true
if the character is an XML 1.0 NameChar,
Copy
false
if it is not
Bibliography
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlValid Method

XmlUtilisXmlValid Method
Return true if all of the characters in the passed string are valid XML characters.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlValid(
    string str
)
Public Shared Function isXmlValid (
    str As String
) As Boolean
public:
static bool isXmlValid(
    String^ str
)
static member isXmlValid :
        str : string -> bool

Parameters

str
Type: SystemString
The string to check.

Return Value

Type: Boolean
true if all characters are valid XML.
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlVersionNum Method

XmlUtilisXmlVersionNum Method
Return true if the passed string conforms to the XML VersionNum production. [26] VersionNum ::= ([a-zA-Z0-9_.:] | '-')+

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlVersionNum(
    string str
)
Public Shared Function isXmlVersionNum (
    str As String
) As Boolean
public:
static bool isXmlVersionNum(
    String^ str
)
static member isXmlVersionNum :
        str : string -> bool

Parameters

str
Type: SystemString
The string to check.

Return Value

Type: Boolean
true if the passed string conforms to the XML VersionNum production.
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlWhitespace Method

XmlUtilisXmlWhitespace Method
Overload List
Name | Description
isXmlWhitespace(Char) | Returns whether the specified char conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.
isXmlWhitespace(String) | Returns whether the specified string conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.
Top
Bibliography
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.isXmlWhitespace Method (Char)

XmlUtilisXmlWhitespace Method (Char)
Returns whether the specified char conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlWhitespace(
    char c
)
Public Shared Function isXmlWhitespace (
    c As Char
) As Boolean
public:
static bool isXmlWhitespace(
    wchar_t c
)
static member isXmlWhitespace :
        c : char -> bool

Parameters

c
Type: SystemChar
the char to be checked

Return Value

Type: Boolean
Copy
true
if the char is an XML 'S' production character
Bibliography
See Also

Reference

XmlUtil Class
isXmlWhitespace Overload
DXMLBase.Xml Namespace


XmlUtil.isXmlWhitespace Method (String)

XmlUtilisXmlWhitespace Method (String)
Returns whether the specified string conforms to the S production in the XML 1.0 grammar. Such a string consists only of XML whitespace.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isXmlWhitespace(
    string str
)
Public Shared Function isXmlWhitespace (
    str As String
) As Boolean
public:
static bool isXmlWhitespace(
    String^ str
)
static member isXmlWhitespace :
        str : string -> bool

Parameters

str
Type: SystemString
the string to be checked

Return Value

Type: Boolean
Copy
true
if the string consists only of XML whitespace,
Copy
false
if it does not
Bibliography
See Also

Reference

XmlUtil Class
isXmlWhitespace Overload
DXMLBase.Xml Namespace


XmlUtil.normalizeWhitespace Method

XmlUtilnormalizeWhitespace Method
Normalize whitespace in a string by stripping leading and trailing whitespace, and converting all internal sequences of whitespace into a single space each.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string normalizeWhitespace(
    string source
)
Public Shared Function normalizeWhitespace (
    source As String
) As String
public:
static String^ normalizeWhitespace(
    String^ source
)
static member normalizeWhitespace :
        source : string -> string

Parameters

source
Type: SystemString
The string to be normalized

Return Value

Type: String
The normalized string
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.quote Method

XmlUtilquote Method
Overload List
Name | Description
quote(String) |
quote(String, Int32) |
Top
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.quote Method (String)

XmlUtilquote Method (String)

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string quote(
    string str
)
Public Shared Function quote (
    str As String
) As String
public:
static String^ quote(
    String^ str
)
static member quote :
        str : string -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String)"]

See Also

Reference

XmlUtil Class
quote Overload
DXMLBase.Xml Namespace


XmlUtil.quote Method (String, Int32)

XmlUtilquote Method (String, Int32)

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String,System.Int32)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string quote(
    string str,
    int maxLength
)
Public Shared Function quote (
    str As String,
    maxLength As Integer
) As String
public:
static String^ quote(
    String^ str,
    int maxLength
)
static member quote :
        str : string *
        maxLength : int -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String,System.Int32)"]

maxLength
Type: SystemInt32

[Missing <param name="maxLength"/> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlUtil.quote(System.String,System.Int32)"]

See Also

Reference

XmlUtil Class
quote Overload
DXMLBase.Xml Namespace


XmlUtil.replaceBuiltInEntities Method

XmlUtilreplaceBuiltInEntities Method
Replace XML's built-in references (&, etc.) with the corresponding characters.

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string replaceBuiltInEntities(
    string rawString
)
Public Shared Function replaceBuiltInEntities (
    rawString As String
) As String
public:
static String^ replaceBuiltInEntities(
    String^ rawString
)
static member replaceBuiltInEntities :
        rawString : string -> string

Parameters

rawString
Type: SystemString
The string to convert.

Return Value

Type: String
The converted string.
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.toXml Method

XmlUtiltoXml Method
Overload List
Name | Description
toXml(String) |
toXml(String, String) |
Top
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.toXml Method (String)

XmlUtiltoXml Method (String)

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string toXml(
    string rawString
)
Public Shared Function toXml (
    rawString As String
) As String
public:
static String^ toXml(
    String^ rawString
)
static member toXml :
        rawString : string -> string

Parameters

rawString
Type: SystemString

[Missing <param name="rawString"/> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String)"]

See Also

Reference

XmlUtil Class
toXml Overload
DXMLBase.Xml Namespace


XmlUtil.toXml Method (String, String)

XmlUtiltoXml Method (String, String)

[Missing <summary> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String,System.String)"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string toXml(
    string rawString,
    string specials
)
Public Shared Function toXml (
    rawString As String,
    specials As String
) As String
public:
static String^ toXml(
    String^ rawString,
    String^ specials
)
static member toXml :
        rawString : string *
        specials : string -> string

Parameters

rawString
Type: SystemString

[Missing <param name="rawString"/> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String,System.String)"]

specials
Type: SystemString

[Missing <param name="specials"/> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:DXMLBase.Xml.XmlUtil.toXml(System.String,System.String)"]

See Also

Reference

XmlUtil Class
toXml Overload
DXMLBase.Xml Namespace


XmlUtil Properties

XmlUtil Properties

The XmlUtil type exposes the following members.

Properties
Name | Description
NULL_NAMESPACE |
Top
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace


XmlUtil.NULL_NAMESPACE Property

XmlUtilNULL_NAMESPACE Property

[Missing <summary> documentation for "P:DXMLBase.Xml.XmlUtil.NULL_NAMESPACE"]

Namespace: DXMLBase.Xml
Assembly: DXMLBase (in DXMLBase.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NULL_NAMESPACE { get; }
Public Shared ReadOnly Property NULL_NAMESPACE As String
    Get
public:
static property String^ NULL_NAMESPACE {
    String^ get ();
}
static member NULL_NAMESPACE : string with get

Property Value

Type: String
See Also

Reference

XmlUtil Class
DXMLBase.Xml Namespace